named-xfer is an ancillary program executed by named(1M) to perform an inbound zone transfer. It is rarely executed directly, and then only by system administrators who are trying to debug a zone transfer problem. See RFC 1033, RFC 1034, and RFC 1035 for more information on the Internet name-domain system.
Specifies the name of the zone to be transferred.
Specifies the name of the file into which the zone should be dumped when it is received from the primary server.
Specifies the serial number of our current copy of this zone. If the Start Of Authority (SOA) Resource Record (RR) received from the primary server does not have a serial number higher than this, the transfer will be aborted.
Print debugging information. The debuglevel is a number which determines the level of messages printed.
Specifies a log file for debugging messages. The default is system-dependent but is usually in /var/tmp or /usr/tmp. Note that this only applies if -d is also specified.
Specifies a trace file which will contain a protocol trace of the zone transfer. This is probably only of interest to people debugging the name server itself.
Use a different port number. The default value is the standard port number, that is, the port number returned by getservbyname for the domain service.
Perform a restricted transfer of only the SOA, NS records and glue A records for the zone. The SOA record will not be loaded by named but will be used to determine when to verify the NS records. See the stubs directive in in.named(1M) for more information.
Additional arguments are taken as name server addresses in ``dotted-quad'' syntax only. No host names are allowed here. At least one address must be specified. If the first address fails to transfer successfully, any additional addresses will be tried in the order specified in the command line.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|