#include <exec/chExec.h>int actorDelete(KnCap *actorcap);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
The actorDelete() call deletes the actor whose capability is given by actorcap.
If actorcap is K_MYACTOR, the current actor is deleted.
When the actor is deleted, all the actor's resources are deleted. For example, threads are deleted as if threadDelete(2K) had been called.
Upon successful completion a value of 0 is returned. Otherwise, a negative error code is returned.
actorcap is an inconsistent actor capability.
actorcap does not specify a reachable actor.
Some of the data provided are outside the current actor's address space.
The actor is already in the process of being deleted.
A user actor cannot delete a supervisor actor or a system actor.
The deleted actor and the current actor must be located on the same site.
Interrupt, trap, exception or time-out handlers connected by the actor are not disconnected on actor deletion in this version. When deleting SUPERVISOR actors, these handlers must be disconnected explicitly before invoking actorDelete(). Otherwise, unpredictable results may occur.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|