#include <exec/chExec.h>int actorName(KnCap *actorcap, char *oldname, char *newname);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
The actorName() call gets or sets the symbolic name of the actor whose capability is given by actorcap (see actorCreate(2K)). If actorcap is K_MYACTOR, the current actor is affected.
If oldname is not NULL, the actor's symbolic name is copied to the caller address space at the location specified by oldname. An actor's symbolic name has a maximum size of K_ACTORNAMEMAX (including the NULL character). If newname is not NULL, the actor's symbolic name is set to the new name pointed to by newname in the caller address space. The new name is truncated to a maximum size of K_ACTORNAMEMAX (including the NULL character).
Upon successful completion a value of 0 is returned. Otherwise, a negative error code is returned.
actorcap is an inconsistent actor capability.
actorcap does not specify a reachable actor.
Some of the data provided are outside the current actor's address space.
The target actor and the current actor must be located on the same site.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|