#include <exec/chExec.h>int actorSelf(KnCap *actorcap);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
actorSelf() returns the capability of the current actor into the structure pointed to by actorcap.
A value of 0 is returned upon successful completion. Otherwise, a negative error code is returned.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|