#include <exec/chExec.h>int actorStat(unsigned int options, KnActorStat *stat, unsigned int buffsize);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
The actorStat() call obtains the status of all actors created on the current site.
The stat argument points to a buffer in which the descriptions of existing actors will be returned. The buffsize argument gives the size of the buffer in bytes. The buffer is considered part of the caller (current user or supervisor) address space.
The options argument is reserved for future use and must be set to 0.
KnCap asCap ; KnActorStatus asStatus ;
The asCap field is the actor capability. The asStatus field is the actor status (K_STOPPED or K_ACTIVE; see actorCreate(2K) for details).
The actorStat() call is restricted to threads running with supervisor privilege or for which the actor is a system actor.
If successful, actorStat() returns the number of actors created on the current site. Otherwise a negative error code is returned.
Some of the arguments provided are outside the caller's address space.
The current thread is not allowed to perform this call.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|