#include <exec/chExec.h>int actorStart(KnCap * actorcap);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
The actorStop() call stops the actor whose capability is given by actorcap (see actorCreate (2K)).
If actorcap is K_MYACTOR, the current actor is stopped.
The effect of actorStop() is to prevent all the threads from running until the actor is restarted using actorStart (2K_I).
Performing actorStop() is equivalent to performing threadStop() on all the actor's threads.
All other threads executing in the actor and having entered it through safe LAPs, and any thread attempting to enter a stopped actor through a safe LAP will also be stopped.
The effect of actorStop() is not instantaneous on threads executing a system call that is implemented via a trap, but it guarantees that a thread performing this type of system call will not return from that call.
When an actor has been stopped, the internal status of its threads may, however, change (if messages are delivered or resumed, for example).
It is possible to resume individual threads using threadStart (2K_I).
The actorStart() call starts the actor whose capability is given by actorcap . It may be applied to a newly created actor, or to an actor previously stopped using actorStop (2K_I).
If actorcap is K_MYACTOR , the current actor is started.
After actorStart() , any of the runnable actor's threads may run user code.
Performing actorStart() is equivalent to performing threadStart() on all the actor's threads and to resuming all other threads executing in the actor or attempting to enter it through safe LAPs.
A value of 0 is returned upon successful completion. Otherwise, a negative error code is returned.
actorcap is an inconsistent actor capability.
actorcap does not specify a reachable actor.
Some of the data provided is out of the current actor's address space.
The target actor and the current actor must be located on the same site.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|