#include <blackbox/chBlackBox.h>uint_t bbGetNbb();
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
bbGetNbb() gets the number of black boxes configured on the node. By default, there will be at least two black boxes on the node, but this is configurable at system build time.
The returned value is the number of black boxes configured for the system.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|