#include <blackbox/chBlackBox.h>int bbRelease(KnBBId id);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
bbRelease() frees up a frozen black box.
Once a black box has been released by bbRelease(), it is no longer available for "opening" with bbOpen(); the data from that black box is no longer accessible.
The parameter id is the ID of the black box to release, e.g. as obtained by calling bbFreeze() or bbList().
bbRelease() returns 0 on success. Otherwise, a negative error code is returned.
id is an invalid blackbox identifier
The given blackbox is not frozen
The given blackbox is currently being opened by someone else
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|