#include <cx/dlfcn.h>char *dlerror(void);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
dlerror() is a member of the dynamic linking API, a family of routines that give the user direct access to dynamic linking functionality.
dlerror() is only available to programs and libraries compiled with imake rules of the form DynamicTypeTarget(), where Type is one of User, Sup, CXXUser, CXXSup or Library.
See ChorusOS 5.0 Application Developer's Guidefor more information on building executables with dynamic libraries.
dlerror() returns a null-terminated character string with no trailing newline that describes the last error that occurred during dynamic linking processing. If no dynamic linking errors have occurred since the last invocation of dlerror(), dlerror() returns NULL. Therefore, invoking dlerror() twice in a row returns NULL.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
Messages returned by dlerror() may reside in a static buffer that is overwritten on each call to dlerror(). Application code should not write to this buffer. Programs that need to preserve an error message should make their own copies of the message.