#include <pd/chPd.h>int padKeyDelete(PdKey key);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
The padKeyDelete function deletes an actor-specific data key previously returned by padKeyCreate (2K).
This function can only be called from a supervisor actor.
The actor-specific data values associated with key need not be NULL at the time padKeyDelete is called. The application frees storage and performs any cleanup operations needed for data structures related to the deleted key or to associated actor-specific data. The cleanup can be performed before or after invoking padKeyDelete. Any attempt to use key after the call to padKeyDelete can produce unpredictable results There are no destructor functions invoked by padKeyDelete.
At actor destruction, all keys still allocated by an actor will be deleted.
Upon successful completion a value of 0 is returned. Otherwise, a positive error code is returned.
The key value is invalid.
The Private Data Manager is unreachable.
This call is reserved for supervisor actors.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|