#include <ipc/chIpc.h>int portUi(KnUniqueId * portui, int portli);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
The portUi call returns to the KnUniqueId structure given by portui , the unique identifier of the port whose local identifier is portli in the current actor (the port must be attached to the current actor).
The portLi call returns the local identifier in the current actor of the port whose unique identifier is pointed by portui (the port must be attached to the current actor).
Upon successful completion, portui returns 0; portLi returns the local identifier of the port. Otherwise, a negative error code is returned.
For portUi : portli is not a valid port identifier within the current actor. For portLi : portui is not the unique identifier of a port attached to the current actor.
Some of the data provided are outside the current actor's address space.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|