#include <pd/chPd.h>int ptdKeyDelete(PdKey key);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
The ptdKeyDelete() call deletes a thread-specific data key previously returned by ptdKeyCreate(2K). The thread-specific data values associated with key need not be NULL when ptdKeyDelete() is called. The application frees storage and performs any cleanup operations needed for data structures related to the deleted key or to associated thread-specific data. The cleanup can be performed before or after invoking ptdKeyDelete(). Attempting to use key after the call to ptdKeyDelete() can produce unpredictable results. No destructor functions are invoked by ptdKeyDelete()
At actor destruction, all keys still allocated by an actor are silently deleted.
On successful completion, a value of 0 is returned. Otherwise, a positive error code is returned.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|