#include <pd/chPd.h>void ptdThreadDelete(void);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
The ptdThreadDelete() call deletes the thread-specific values associated with all valid keys in the current user actor for the current thread.
For each non-NULL value, ptdThreadDelete() calls the appropriate destructor before clearing the value.
In user mode, ptdThreadDelete() should be called before thread deletion to enable destructors to be invoked.
In supervisor mode, ptdThreadDelete() is an empty function. Destructors will be called at thread termination by the Private Data Manager.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|