#include <exec/chVecCtx_f.h>KnError svVecContext(KnVecCtx *oldctx, KnVecCtx *newctx);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
The svVecContext() system call gets or sets the Vector Unit execution (AltiVec) context of the current thread.
The oldCtx and newCtx parameters must be pointers to KnVecCtx structures defined in the <exec/chVecCtx_f.h> header file. The fields of this structure are machine-dependent. A thread's vector context is defined as the set of vector unit register values (vr0..vr31), the vector unit control and status registers and possibly family specific additional flags required for vector context management.
The thread's current vector execution context is copied into the structure pointed to by oldCtx (if not NULL) in the client address space. The thread's new context is taken from the structure pointed to by newCtx (if not NULL).
This call is typically intended to be used in handlers to save/restore the thread's vector contexts.
The svVecContext() system call is PowerPC-specific
On successful completion, a value of 0 is returned. Otherwise, a negative error code is returned.
The current actor must be a SUPERVISOR actor.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|