The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
sysShutdown() is executed by trusted user actors or supervisor actors to shut down the system. It is a high-level interface intended for use in multi-command actors such as C_INIT(1M).
sysShutdown() parameters are similar to the options for shutdown(1M). If the first parameter is -i, the subsequent digit indicates the system state and actions to perform as follows:
Shut down the entire system safely and reboot.
Perform a site restart. A site
restart means that the entire system is shut down safely and then restarted
from the system image, without accessing stable storage, such that direct
hot restartable actors are automatically restarted from persistent memory.
This state requires the
See the manual entry for restart(1M) for a more detailed description of site restart.
On successful completetion, 0 is returned and the system is no longer available. Otherwise, a negative error code is returned if a microkernel error is encountered, or a positive error code is returned if a system error is encountered.
Actor capability of the invoker cannot be obtained.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|