#include <exec/chExec.h>int threadDelay(KnTimeVal *waitLimit);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
threadDelay() delays the execution of the current thread according to the value of *waitLimit.
waitLimit is a pointer to a KnTimeVal structure containing a timeout interval, as described in sysTime(2K). Semantics and constant option values of the waitLimit argument are described in intro(2K). A waitLimit value of K_NOBLOCK (or zero) means that the thread is still ready to run after the call. In this case, threadDelay() may have the effect of simply yielding the processor to another thread that is ready to run. The precise actions in this case depend on the scheduler module configured.
The waitLimit structure is not a valid KnTimeVal.
A timeout occurred.
The thread has been aborted while delayed.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|