#include <etimer/chEtimer.h>int timerGetRes(int clock, KnTimeVal *resolution);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
The timerGetRes() system call obtains the resolution of the clock type clock. The value stored in resolution represents the smallest possible difference between two distinct time specifications related to clock.
The only clock type currently supported is K_CLOCK_REALTIME. This clock corresponds to the system time as returned by sysTime(2K).
On successful completion, K_OK is returned. Otherwise, a negative error code is returned.
clock is not equal to K_CLOCK_REALTIME.
An address argument falls outside the caller's address space.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|