#include <etimer/chEtimer.h>int timerThreadPoolInit(KnThreadPool *threadPool);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
timerThreadPoolInit() initializes the timer thread pool threadPool.
The threadPool object is opaque. It must be pre-allocated by the caller but its fields are inaccessible to the caller. A threadPool object must be initialized before it can be accessed by a timerCreate(2K).
On successful completion, K_OK is returned. Otherwise, a negative error code is returned.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|