NAME | SYNOPSIS | API RESTRICTIONS | FEATURES | DESCRIPTION | RETURN VALUES | ERRORS | RESTRICTIONS | ATTRIBUTES | SEE ALSO | STANDARDS | CAVEAT
#include <unistd.h>int access(const char *path, int mode);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
MSDOSFS, NFS_CLIENT, UFS
The access function checks the accessibility of the file named by path for the access permissions indicated by mode. The value of mode is the bitwise inclusive OR of the access permissions to be checked
for read permission,
for write permission, and
for execute/search permission, or an existence test.
All components of the pathname path are checked for access permissions (including F_OK).
The real user ID is used instead of the effective user ID, and the real group access list (including the real group ID) is used instead of the effective ID for checking permissions.
Even if a process has appropriate privileges and indicates success for X_OK,R_OK or W_OK, the file may not actually have execute permission bits set.
If path cannot be found or if any of the desired access modes would not be granted, a value of -1 is returned; otherwise a 0 value is returned.
Access to the file is denied if:
A component of the path prefix is not a directory.
A component of a pathname exceeded 255 characters, or an entire path name exceeded 1023 characters.
The named file does not exist.
Too many symbolic links were encountered in translating the pathname.
Write access is requested for a file on a read-only file system.
Write access is requested for a pure procedure (shared text) file currently being executed.
Permission bits of the file mode do not permit the requested access, or search permission is denied on a component of the path prefix. The owner of a file has permissions checked with respect to the ``owner'' read, write, and execute mode bits. Members of the file's group other than the owner have permissions checked with respect to the ``group'' mode bits, and all others have permissions checked with respect to the ``other'' mode bits.
Path points outside the process's allocated address space.
An I/O error occurred while reading from or writing to the file system.
On top of ChorusOS with etc/security, a process has the root credentials by default, so access() always returns 0 whatever the permission bits.
See attributes(5) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
---|---|
Interface Stability | Evolving |
MT-Level | Async-Signal-Safe |
The access call conforms to IEEE Std 1003.1-1988 POSIX .
access is a potential security hole and should never be used.
NAME | SYNOPSIS | API RESTRICTIONS | FEATURES | DESCRIPTION | RETURN VALUES | ERRORS | RESTRICTIONS | ATTRIBUTES | SEE ALSO | STANDARDS | CAVEAT