NAME | SYNOPSIS | LIBRARY | API RESTRICTIONS | DESCRIPTION | ERRORS | ATTRIBUTES | SEE ALSO
#include <unistd.h>int issetugid(void);
Standard C Library (libc, --lc)
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
The issetugid() function returns 1 if the process environment or memory address space is considered "tainted", and returns 0 otherwise.
A process is tainted if it was created as a result of an execve(2POSIX) system call which had either of the setuid or setgid bits set (and extra privileges were given as a result) or if it has changed any of its real, effective or saved user or group ID's since it began execution.
This system call exists so that library routines (for example, libc, libtermcap) can reliably determine if it is safe to use information that was obtained from the user, in particular the results from getenv(3STDC) should be viewed with suspicion if it is used to control operation.
A "tainted" status is inherited by child processes as a result of the fork(2POSIX) system call (or another library code that calls fork, such as popen(3STDC)).
It is assumed that a program that clears all privileges as it prepares to execute another will also reset the environment, hence the "tainted" status will not be passed on. This is important for programs which begin setuid(2POSIX) but need to be able to create an untainted process.
The issetugid() function is always successful, and no return value is reserved to indicate an error.
See attributes(5) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
---|---|
Interface Stability | Evolving |
NAME | SYNOPSIS | LIBRARY | API RESTRICTIONS | DESCRIPTION | ERRORS | ATTRIBUTES | SEE ALSO