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CHAPTER 1  

Welcome to StarOffice™ 6.0

This document provides an overview of the new and improved features and key changes
introduced in StarOffice™ 6.0 software. When designing this new version, the team paid close
attention to the demands of existing StarOffice software users from around the globe to
deliver a complete, cost-effective, world-class office productivity suite. 

 Enterprise users will benefit from the seamless cross-platform compatibility, enhanced Micro-
soft Office interoperability, and new XML and Asian language support. Small business owners
and professionals will enjoy the ease of working with powerful productivity tools in a fully
integrated, intuitive environment and the ability to jump-start their projects with profession-
ally designed templates. Educators and students will appreciate the multilingual writing aids
and online help, advanced graphics capabilities, colorful new clip art, and value of this award-
winning office suite.

Key Benefits
The key benefits of StarOffice 6.0 software include:

• Seamless integration with the Microsoft Windows and UNIX® operating systems to deliver
top performance for users of the Solaris™  Operating Environment, Linux, and Microsoft
Windows.

• Tighter integration of creativity and productivity tools to maximize efficiency and output.

• Exciting new clip art, templates, and fonts to jump-start projects and add color, fun, and
style to documents, reports, and presentations.

• Improved international and Unicode support to facilitate the creation of multilingual docu-
ments.

• New support for open standards to ensure your investment in StarOffice software is safe
for years to come.

• Improved Microsoft Office interoperability to facilitate the exchange of documents with
Microsoft Office users.

• Enhanced Help system to help both newcomers and seasoned StarOffice software users
make the most of StarOffice 6.0.

• Improved user interface to help you more easily navigate the StarOffice 6.0 menus, tool-
bars, and dialog boxes.

Seamless Integration with the Microsoft Windows and UNIX
Platforms

The StarOffice 6.0 productivity suite offers exceptional cross-platform compatibility with
enhanced support for users of the Solaris Operating Environment, Linux, and Microsoft
Windows.

New Quick Launch option (Microsoft Windows only). Get to work in a jiffy. The new Quick
Launch option enables you to launch new StarOffice documents or open existing ones at the
click of a mouse. Simply right-click the Quick Launch icon in the Microsoft Windows system
tray and select the type of document you want to create from the context menu. Double-
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clicking the icon launches the Templates and Documents dialog box. To toggle this option on
or off, select Load StarOffice at system start-up from the Quick Launch context menu or in the
Tools > Options > General dialog box.

New Open and Save As dialog boxes (Microsoft Windows only). By default, StarOffice 6.0
software uses the standard Microsoft Windows dialog boxes, which have been enhanced to
include some StarOffice software-specific features that make it easier to open and save files. If
you want to use the StarOffice Open and Save As dialog boxes, choose Tools > Options >
StarOffice > General from the Tools menu and then select the Use StarOffice dialogs check
box. 

Improved font rendering and printing solutions for the UNIX platform.  StarOffice 6.0 soft-
ware introduces new solutions for rendering and printing TrueType fonts for Solaris and
Linux software.

• Enhanced font handling and rendering  StarOffice 6.0 software introduces FreeType tech-
nology and TrueType support to enhance the text display quality for Solaris and Linux
software users. Other enhancements include support for text rotation and kerning,
embedded bitmapped graphics, vertical glyph substitution, and antialiasing, which works
with 24-bit and 32-bit video adapters as well as with 8-bit grayscale visuals. A display
render extension is supported, but not required.

• Improved SPAdmin utility The SPAdmin printer administration utility has been redes-
igned with an eye toward ease of use and functionality. Solaris and Linux software users
will appreciate the new simplified main dialog box; the new Connect tab page, located
below the Properties tab; the new Font Substitution tab page in the Configuration dialog
box; the ability to rename fonts using the font dialog box; and the new Add printer button,
which starts a utility that steps users through the task of adding a new printer. 

• New Adobe PDF support  Enhancements to the SPAdmin tool also enable users of Solaris
and Linux software to configure an Adobe PDF printer driver that converts Adobe Post-
Script output into a PDF document, provided Ghostscript or Adobe Acrobat Distiller is
installed. Using the Add Printer button makes it easy to configure the command line that
should be executed to process the Postscript output. If Ghostscript or Adobe Acrobat
Distiller is installed, StarOffice 6.0 software provides preconfigured command lines.

New e-mail support for sending documents  You can send any text, spreadsheet, drawing, or
presentation document as e-mail by selecting File > Send > Document As E-mail. The respec-
tive StarOffice module will send the document as an attachment using the default e-mail
client (Microsoft Windows only) or Netscape 6.x Messenger (Solaris and Linux). You can
specify an alternate e-mail client by selecting Tools > Options > StarOffice > External
Programs. 

Tighter Integration of Creativity and Productivity Tools

Using StarOffice software, you don't have to spend a lot of time trying to figure out the
shortest distance between any two components; nor do you have to understand the relation-
ships that exist between them. All StarOffice modules share the same basic menu commands,
toolbars, and function keys, and the program's IntuitiveUse technology automatically
provides the tools you need for the task at hand. StarOffice 6.0 maximizes your productivity
by introducing the following improvements:

New Features Guide 2



FIGURE1: Add fun and color to your documents with graphics and clip art from the new
StarOffice Gallery.

Improved StarOffice Gallery  Add color, fun, and style to your projects and reports — drag
and drop graphics from the newly designed StarOffice Gallery into your documents or presen-
tations. The StarOffice Gallery contains a variety of high-quality clip art, pictures, shapes, and
sounds, organized by themes. Browse through and select clips in thumbnail or list views, or
add your own themes and clips to this handy media organizer tool. Whether you're working
on a text document, spreadsheet, presentation, or drawing, you can quickly access the new
StarOffice Gallery by clicking the Gallery icon on the function bar or by selecting Gallery from
the Tools menu. 

New graphics tools  Generate pixel-perfect images across all StarOffice modules. The func-
tionality of StarOffice Writer, Calc, Draw, and Impress has been enhanced with a new set of
graphics tools that was previously available only in StarOffice Image. These new tools can be
accessed from the Graphics object bar, which becomes available as soon as you insert or select
a bitmap graphic into a text document, spreadsheet, or presentation. 

• New Graphics object bar Using the Graphics object bar, you can set the attributes of a
selected bitmap graphic, including Filter effects, Graphics mode (Default, Grayscale,
White/Black, and Watermark), Alpha channels (for the colors red, green, and blue), Bright-
ness, Contrast, Gamma value, and Transparency. Clicking the arrow on the right of the
Graphics object bar replaces the Graphics object bar with the enhanced Frame object bar
(StarOffice Writer 6.0 only).

• Enhanced Frame object bar (StarOffice Writer only) The Frame object bar enables you to
modify the frame attributes of selected bitmap graphics, including alignment, anchor posi-
tions, borders, and background color, which is useful for cropped graphics or if there is
space between a border and its contents.

New chart handling StarOffice 6.0 software provides integrated charting functionality across
all StarOffice modules. As a result, it is no longer necessary to save StarOffice charts as indi-
vidual files. However, you can still load standalone charts that were created with the StarOf-
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fice Chart 5.2 module or earlier, and insert them in your StarOffice 6.0 documents as OLE
objects.

• New Edit option (standalone charts only)  To edit a standalone chart, select Chart Data
from the Edit menu or the Chart context menu.

• New Source format option (embedded charts only)  The Axis dialog boxes include a new
option that enables you to assign the source format of the cells on which your chart is
based for the first and second X axis (XY charts only) and Y axis (all charts). To use this
option, select Format > Axis > X Axis (or Y Axis) and go to the Numbers tab. If you select the
Source format option, the X and Y axes will adopt the number format of the selected data
range on which the chart is based. For example, if all cells in a column have the same
number format, then this format is used for the Y axis as well.

New Data Source Administration dialog box  Integrate data sources quickly and easily.
StarOffice 6.0 software introduces a new dialog box for administering office-wide access to
data sources. Using this dialog box, you can build connections to existing data sources, specify
StarOffice Calc, Microsoft Excel, and other supported spreadsheet documents as data sources,
design and edit database tables, define new queries or edit existing ones, and create links to
remote data sources, including forms and text documents. When specifying a data source, the
program automatically enters the corresponding protocol scheme in the Data source URL text
box (for example, sdbc:dbase:), facilitating the task of establishing a connection to a desired
data source. The connected data sources appear in the list box on the left of the Data Source
Administration dialog box. 

FIGURE2: The new Data Source Administration dialog box makes it a snap to manage
your data sources.

New Address Book utility Manage your contacts with ease. The StarOffice 6.0 suite comes
with a new Address Book dialog box that enables you to continue to use your existing StarOf-
fice address books or integrate internal ones.  A new database driver called Addressbook
supports access to the LDAP, Mozilla, Netscape 6.x, Microsoft Outlook, and Microsoft Windows
address book sources. To access the new Address Book dialog box, select File > Templates >
Address Book Source. If you want to manage your address book source, click the Administrate
button in the Address Book dialog box, and the new Data Source Administration dialog box
opens.
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New Address Data Source AutoPilot Streamline the import of your existing contacts from
Netscape 6.x, Mozilla, LDAP, Microsoft Outlook, Microsoft Windows Address Book, or other
data sources. The new AutoPilot for Address Data automatically starts the very first time you
launch a StarOffice 6.0 task. The AutoPilot steps you through the process of selecting your
external address book source, specifying any relevant type-specific data source settings or
address book field mappings for custom address sources, and assigning a name to the new
address book.

New Page Preview feature Check the text flow and page breaks of your documents before
printing them. The new Page Preview feature enables you to see what your text document or
spreadsheet will look like on paper before you actually print it. Unlike earlier StarOffice
versions, the new Page Preview feature uses the current task window (instead of a new one)
for displaying the current document in print layout. To use this feature, select Page Preview
from the File menu. To return to the original document, click the Page Preview button on the
Preview object bar or deselect the Page Preview item in the File menu. 

Exciting New Clip Art, Templates, and Fonts

Jump-start your projects with professionally designed templates and enrich your work with
graphics, sounds, and animations that you can drag and drop from the new StarOffice Gallery
into your text, spreadsheet, drawing, and presentation documents. 

New Gallery themes and clip art Enrich your projects with new graphics and sounds. The
revamped StarOffice Gallery contains an extensive collection of useful, professionally
designed clip art, animations, pictures, shapes, and sounds, organized by themes to help you
find what you want, quickly and easily. Screen Beans clip art helps illustrate your ideas with
just the right touch of insight and humor.  Other StarOffice Gallery features include the
ability to create and organize your own themes, preview sounds and images, and import addi-
tional items.

New Templates and Documents dialog box Streamline your work with new templates and
sample files. Using the new Templates and Documents dialog box, you can browse and
organize the contents of the Templates, My Documents, and Samples directories, edit your
templates, and preview templates and documents before opening them. 

• New and updated templates Using the Templates and Documents dialog box, you can
choose from a new collection of professionally designed StarOffice 6.0 templates. Use and
modify at will, including templates that track the results of your favorite sports events or
the price history and current value of your stock portfolio (with live Internet updates). 

• New and updated sample files  StarOffice 6.0 software includes a new set of sample files
that highlight the strengths of the various StarOffice applications while giving you a hand
with everyday work.   

All templates and sample files can be accessed by selecting File > New > Templates and Docu-
ments. Microsoft Windows users can also double-click the the Quick Launch icon in the
system tray (if enabled). 
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FIGURE3: The new Templates and Documents dialog box makes it easy to organize, edit,
and preview your documents and templates.

New fonts and font effects StarOffice 6.0 comes with a new set of TrueType fonts, including
fonts and font effects that support Chinese, Japanese, and Korean character sets.

Improved International and Unicode Support

Check spelling and hyphenation in multilingual documents and create Japanese, Chinese, and
Korean documents. 

New Unicode support StarOffice 6.0 software supports the Unicode character standard, which
represents the principal written languages of the world, using a single character set. Unicode
support enables you to insert any combination of letters and diacritical marks into your docu-
ments, as well as use special characters from non-Western languages. You can access the
complete Unicode character set by selecting Special Character from the Insert menu. Using
the Subset drop-down list, you can then quickly zoom in on the character set of the alphabet
you want.
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FIGURE4: The Special Characters dialog box makes it easy to insert the complete
Unicode character set. 

New support for Asian languages StarOffice 6.0 software provides double-byte support for
Japanese, Chinese, and Korean, enabling you to create multilingual documents.

StarSuite 6.0 supports GB18030 encoding.  The character encoding length can be one, two or
four bytes.

NOTE: To enable StarOffice support for Asian languages, you must choose 
Tools > Options > Language Settings > Languages and select the (Asian languages
support) Enabled check box. Otherwise, you will not be able to see or access the following
new Asian language features included in StarOffice 6.0 software. 

Feature Enables You To ... How to Access

Vertical character position Specify the writing direction from bottom to
top or top to bottom by rotating text by 90 or
270 degrees. The rotated text can be scaled in
width or made to fit the current line.

Select Format > Character.

The Rotation/scaling options are located on the
Position tab of the Character dialog box.

Vertical text alignment Align rotated text vertically. You can choose
one of five options for vertical text
alignment: Automatic, Baseline, Top, Middle,
or Bottom.

Select Format > Paragraph.

The Vertical text alignment options are located on
the Alignment tab of the Paragraph dialog box.

Ruby text Add brief explanations or pronunciation aids
that appear above (or below) the selected
baseline text. Ruby text is used in most East
Asian languages to add information to
written text. 

Select Format > Ruby.

Using the Ruby dialog box, you can manage the list
of applied Ruby text entries, set the alignment of
the base text in relation to the Ruby text, change
the position of the Ruby text entry, and modify the
character style for the Ruby text. 

Different fonts for Asian and
Western text

Specify different fonts for Western and Asian
language text in multilingual documents.

Select Format > Character.

The font options for Western and Asian text can be
specified on the Font tab. 

Double-lined character attribute Insert snippets of Latin-based text within
Asian character-based documents.

Select Format > Character.

The Double-lined option can be activated on the
Asian Layout tab.
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Feature Enables You To ... How to Access

Emphasis mark character
attribute

Stress text in layout. The Emphasis Mark
character attribute provides a common way
for emphasizing text in Asian layouts. Using
StarOffice 6.0 software, you can choose from
four  attribute styles (Dot, Circle, Disc, and
Accent), which may be placed above or below
the selected text.

Select Format > Character.

The Emphasis Mark attribute can be specified on the
Font Effects tab.

Asian Layout options Specify the global settings for handling Asian
character kerning and spacing across your
documents.

Select Tools > Options > Language Settings > Asian
Layout.

Case/Characters text properties Assign Asian language case attributes to
selected Asian language text and characters,
including the Japanese case options Hiragana
and Katakana.

Select Format > Case/Characters.

Combine characters field type Define up to six consecutive characters which
will be handled as one character using the
new Combine characters field type.

Select Insert > Fields > Other.

The Combine characters field type is located on the
Functions tab. 

Line change formatting options Apply a list of forbidden characters to the
beginning and end of lines, permit hanging
punctuation, and use spacing between Asian,
Latin, and complex text.

Select Format > Paragraph.

The line change options are located on the new
Asian Typography tab.

Sounds like (Japanese) search
option

Specify which characters or syllables to treat
as equal and which to ignore during a find-
and-replace operation. 

To define the global settings for this feature,
select Tools > Options > Language Settings >
Searching in Japanese.

Select Edit >  Find & Replace.

Sort order options Use language-specific sort order options for
both text documents and spreadsheets.

The Sort dialog box in StarOffice Writer
enables users to select a language for the
sort operation, and then specify language-
dependent sort criteria.

The Sort dialog box in StarOffice Calc
contains the Language and Options list
boxes, which enable users to specify Asian
language-specific sort criteria.

In StarOffice Writer: 
Select Tools > Sort.

In StarOffice Calc: 
Select Data > Sort. 

The language and language-specific options can be
set on the Options tab.

AutoLayout designs for vertical
text in presentations

Support vertical text in presentations. StarOf-
fice Impress includes four new AutoLayout
designs.

Start a new presentation document and choose the
AutoLayout from the Modify Slide dialog box, or
select Modify Layout from the Format menu.

Encoded text filter Include the new Chinese, Korean and Japa-
nese character sets, as well as a new Unicode
set, which enables the creation of Unicode
text files that contain 16-bit instead of 8-bit
characters.

In the Save As dialog box, select Text (encoded)
from the Save as type drop-down list.

Hancom Hangul Word Proc-
essor import filter

Open Hancom Hangul Word Processor files,
the most popular word processor software in
Korea.

Select File > Open.

Select Hangul WP 97 from the Files of type drop-
down list.

WPS 2000/Office 1.0 import
filter

Opens WPS 2000 and WPS Office 1.0 text
documents. WPS is the most popular word
processor in the People's Republic of China
(PRC).

Select File > Open.

Select WPS 2000/Office 1.0 from the Files of type
drop-down list.

Ichitaro 8,9,10, and 11 import
filter

Opens Ichitaro document files and template
files.

Select File > Open.

Select Ichitaro 8/9/10/11 or Ichitaro 8/9/10/11
Template from the Files of type drop-down list.
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Feature Enables You To ... How to Access

Full-width Katakana user inter-
face

Use full-width Katakana in the StarOffice user
interface.

After changing all Japanese resource strings
from half width to full width with 641w the
641x update will be almost always capable of
showing these relatively long strings in all
dialogs without clipping.

Exceptions (that are not yet changed) are:

• Writer/Insert table - Button AutoFormat

• Writer/Insert indexes/Page Entries -
Buttons EntryText and Hyperlink

• Writer/Insert Frame/Wrap - One Imag-
eRadioButton is slightly clipped.

Run StarOffice.

Additional CJK templates More easily use simplified and traditional
Chinese fonts.

Japanese expense statement, estimate state-
ment, order statement, delivery statement,
map of Japan, Japan-centered map of the
world, and résumé.

File > New > Templates and Documents

or

File > Templates > Organize

or

File > Templates > Edit

Manuscript / grid layout Enables easier editing of CJK characters. Format > Page > Grid (line and character) on.

New international number formats  StarOffice 6.0 comes with a newly designed dialog box
for assigning number formats to support the international formats for date, time, and curren-
cies. 

• More language choices  To specify a number format for a specific locale, StarOffice soft-
ware users can choose from more than 90 locales. The program automatically provides the
corresponding time and calendar settings. To specify a locale, select Tools > Options >
Language Settings > Languages. 

• New date and time formats  To support the Gregorian, Japanese Gengou, and the Tradi-
tional Chinese ROC calendars, StarOffice 6.0 software introduces new date and time
formats in the Document and DocInformation tabs of the Fields dialog box. To define and
insert a date or time format, select Insert > Fields > Other. 

• New currency formats  StarOffice 6.0 software comes with a detailed list of locales and
their currencies. Users can specify a locale by selecting Options > Language Settings >
Languages from the Tools menu; StarOffice software  automatically sets the default
currency for the selected region. 

• New default currency option  The default currency is used in currency number formats,
currency fields, and the Number Format: Currency button on the StarOffice Calc object bar.
Users can set the default currency by selecting Tools > Options > Language Settings >
Languages. (Note: The Euro is default currency for all countries within the European Mone-
tary Union.)

New options for configuring writing aids  The Options dialog box contains a new tab page for
configuring writing aids. Using this new option, users can choose any major Western and
Asian language module, and specify up to three dictionaries (Spelling, Hyphenation, and
Thesaurus) for each language. To access this option, select Tools > Options > Language Settings
> Writing Aids.

New Support for Open Standards

StarOffice 6.0 software supports open standards and programming interfaces, including
HTML, ODBC, Java, and XML. By supporting open standards, the StarOffice product delivers
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quality and performance for users that seek an affordable and reliable alternative to today's
costly, proprietary office productivity offerings.

New language-independent API  Expand the StarOffice functionality and link to other appli-
cations with an open, language-independent, and component-oriented API. The new StarOffice
API supports  the C++ and Java™ languages Other programming languages are supported as
well, but programmers must provide their own language bindings. Developers who want to
write additional components, modify the StarOffice UI, or otherwise extend the StarOffice 6.0
functionality can download the Office Development Kit (ODK) at
http://udk.openoffice.org/udk_package.html. The ODK sources are readily available at
OpenOffice.org, www.openoffice.org. 

New XML file format and saving options  In response to customer demand for content-
stability, performance, and flexibility to create, manage and access complex documents and
Web pages for years to come, the StarOffice team has replaced the previous binary file format
with a new, XML-based file format. XML provides a standards-based, platform- and applica-
tion-independent environment for defining document markup.  The new file name exten-
sions are:

Module Extension

Writer sxw

Writer Master Document sxg

Calc sxc

Draw sxd

Impress sxi

Math sxm (fully compliant with mml standards)

• Enhanced file format compatibility  StarOffice 6.0 is backward compatible, allowing you
to load and edit documents created in StarOffice 5.2 or earlier. When saving StarOffice
documents, you can choose between saving files in the old binary format or the new XML
format. When saving files to XML, the XML filters of the various StarOffice modules store
packages instead of plain XML files. To validate the contents of an XML file, you must
unzip the package. The plain XML file is contained within the package's "Content" entry.

• New file format saving preferences  Don't want to save your documents in the new
StarOffice 6.0 default file format? You can set a default standard file format for your text,
spreadsheet, presentation, and drawing documents and formulas. To set  file format saving
preferences for individual StarOffice 6.0 modules, select Tools > Options > Load/Save >
General and go to the Standard file format list box.

• New Document Converter  StarOffice 6.0 software includes a new Document Converter
that steps you through the process of converting binary StarOffice and Microsoft Office
documents to the new StarOffice XML format in batches. The Document Converter also
includes an option for writing its actions to a log file that will be stored in the StarOffice
6.0 work folder. To use this tool, select File > AutoPilot > Document Converter.
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FIGURE5: Use the new Document Converter to convert binary StarOffice and Microsoft
Office files to the new StarOffice XML file format. 

Improved Microsoft Office Interoperability    

Collaborate across computing platforms. StarOffice software's filter architecture provides
consistent, reliable text and graphics import and export across platforms, and the best Micro-
soft Office import and export filters available today.

Improved import and export of objects  The Microsoft Office import and export filters have
been enhanced to facilitate the exchange of complex documents between StarOffice and
Microsoft office users. 

• New filter options for OLE objects  The Options dialog box contains new filter options for
the import and export of Microsoft Office documents. Using these options, you can specify
whether Microsoft Office OLE objects should be converted into StarOffice objects and vice
versa. Using these new filter options is of special interest for users of the Solaris and Linux
operating environments who work on platforms that don't support either the Microsoft
OLE technology or the StarOffice OLE technology. To use these options, select Tools >
Options > Load/Save > Microsoft Office.

• Improved export of hatches Hatches are background attributes for StarOffice drawing
objects that are not supported by Microsoft Office. To ensure the seamless export of StarOf-
fice drawing objects to Microsoft Word, Excel, or PowerPoint documents, StarOffice 6.0
introduces enhanced export filters that convert the vector-oriented hatches into bitmap
graphics.

• Improved import of Microsoft AutoShapes The StarOffice filter architecture has been
enhanced to ensure the import and export of all available Auto-Shapes in Microsoft Office.

• Improved import of Microsoft PowerPoint content Microsoft Office and StarOffice use
different algorithms to calculate the spacing between paragraphs in presentation docu-
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ments. To account for this difference, StarOffice 6.0 software introduces enhancements to
the Microsoft PowerPoint import filter. 

• Improved import and export of frames StarOffice 6.0 supports the new anchor and align-
ment settings for frames used in Microsoft Word 2000, including horizontal and vertical
alignment as well as anchor definitions.

• Improved import and export of form controls The Office 97/2000  import and export
filters also support the conversion of Microsoft Office controls to StarOffice controls, and
vice versa.

• Improved import and export of charts The Office 97/2000  import and export filters have
been greatly enhanced to facilitate the import and export of charts from Excel to StarOffice
Calc 6.0 and vice versa. This includes the content of charts, the format of 2-D and 3-D
charts, and the settings for x-, y-, and z-axes and gridlines. 

New and enhanced text attributes To further ensure a trouble-free document exchange with
Microsoft Office users, StarOffice 6.0 introduces the following new character and paragraph
attributes, which are fully supported by the Microsoft import and export filters.

• Relief The Relief character attribute has been added to the Font Effects tab of the Character
dialog box, enabling users to choose from two Relief options, Embossed and Engraved.
These options correspond to the Character Embossed and Character Engraved attributes
available in Microsoft Office.

• Enhanced Underlining You can now assign character-independent color attributes to the
Underlining and Strikethrough font effects. 

• Negative indents Set negative indents for paragraphs and tables, and specify the first line
indent independently from the left indent of a paragraph. In the case of tables, you can
specify negative values for the From left alignment option.

New MathType Filter  This filter ensures that formulas embedded in a Microsoft Word docu-
ment are converted from and to MathType when importing from or exporting to a Microsoft
Office file format. 

Enhanced StarOffice Calc functionality To support the document exchange with  Excel users,
StarOffice 6.0 introduces the following changes:

• Percent sign operator in formulas StarOffice 6.0 software recognizes the percent sign
operator in formulas, and formats results as percent values if appropriate. For example, 
=1% = 1% == 0.01
=(1+2)% = 3% == 0.03
=1+16% = 116% == 1.16
=1+(2+3)% = 105% == 1.05
=1%% = 0.01 == 0.0001

• New functions StarOffice Calc 6.0 includes a wealth of new functions that have been intro-
duced to increase productivity and facilitate the exchange with Excel users. All functions
are organized alphabetically by category and can be accessed by selecting Insert > Function
or clicking the AutoPilot Function button on the Function bar. The following table summa-
rizes and describes the new functions.

Function What It Does

ACCRINT Returns the accrued interest for a security that pays periodic interest.

ACCRINTM Returns the accrued interest for a security that pays interest at maturity.

AMORDEGRC Returns the prorated linear depreciation of an asset for each accounting period.

AMORLINC Returns the prorated linear depreciation of an asset for each accounting period.

BESSELI Returns the modified Bessel function In(x).

BESSELJ Returns the Bessel function Jn(x).
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Function What It Does

BESSELK Returns the Bessel function Kn(x).

BESSELY Returns the Bessel function Yn(x).

BIN2DEC Converts a binary number to decimal.

BIN2HEX Converts a binary number to hexadecimal.

BIN2OCT Converts a binary number to octal.

COMPLEX Converts real and imaginary coefficients into a complex number.

CONVERT_ADD Converts a number from one measurement system to another.

COUPDAYBS Returns the number of days from the beginning of the coupon period to the settlement date.

COUPDAYS Returns the number of days in the coupon period that contains the settlement date.

COUPDAYSNC Returns the number of days from the settlement date to the next coupon date.

COUPNCD Returns the next coupon date after the settlement date.

COUPNUM Returns the number of coupons payable between the settlement date and maturity date.

COUPPCD Returns the previous coupon date before the settlement date

CUMIPMT_ADD Returns the cumulative interest paid between two periods

CUMPRINC_ADD Returns the cumulative principal paid between two periods.

DEC2BIN Converts a decimal number to binary.

DEC2HEX Converts a decimal number to hexadecimal.

DEC2OCT Converts a decimal number to octal.

DELTA Tests whether two numbers are equal.

DISC Returns the discount rate for a security.

DOLLARDE Converts a dollar price, expressed as a fraction, into a dollar price, expressed as a decimal number.

DOLLARFR Converts a dollar price, expressed as a decimal number, into a dollar price, expressed as a fraction.

DURATION_ADD Returns the annual duration of a security with periodic interest payments.

EDATE Returns the serial number of the date that is the indicated number of months before or after the
start date.

EFFECT_ADD Returns the effective annual interest rate.

EOMONTH Returns the serial number of the last day of the month before or after a specified number of months.

ERF Returns the error function.

ERFC Returns the complementary error function.

FACTDOUBLE Returns the double factorial of a number.

FVSCHEDULE Returns the future value of an initial principal after applying a series of compound interest rates.

GCD_ADD Returns the greatest common divisor.

GESTEP Tests whether a number is greater than a threshold value.

HEX2BIN Converts a hexadecimal number to binary.

HEX2DEC Converts a hexadecimal number to decimal.

HEX2OCT Converts a hexadecimal number to octal.

IMABS Returns the absolute value (modulus) of a complex number.

IMAGINARY Returns the imaginary coefficient of a complex number.

IMARGUMENT Returns the argument q, an angle expressed in radians.

IMCONJUGATE Returns the complex conjugate of a complex number.

IMCOS Returns the cosine of a complex number.

IMDIV Returns the quotient of two complex numbers.
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Function What It Does

IMEXP Returns the exponential of a complex number.

IMLN Returns the natural logarithm of a complex number.

IMLOG10 Returns the base-10 logarithm of a complex number.

IMLOG2 Returns the base-2 logarithm of a complex number.

IMPOWER Returns a complex number raised by a real number.

IMPRODUCT Returns the product of complex numbers.

IMREAL Returns the real coefficient of a complex number.

IMSIN Returns the sine of a complex number.

IMSQRT Returns the square root of a complex number.

IMSUB Returns the difference of two complex numbers.

IMSUM Returns the sum of complex numbers.

INTRATE Returns the interest rate for a fully invested security.

ISEVEN_ADD Returns true if the number is even.

ISODD_ADD Returns true if the number is odd.

LCM_ADD Returns the least common multiple.

MDURATION Returns the Macauley modified duration for a security with an assumed par.

MROUND Returns a number rounded to the desired multiple.

MULTINOMIAL Returns the multinominal of a set of numbers.

NETWORKDAYS Returns the number of workdays between two dates.

NOMINAL_ADD Returns the annual nominal interest rate.

OCT2BIN Converts an octal number to binary.

OCT2DEC Converts an octal number to decimal.

OCT2HEX Converts an octal number to hexadecimal.

ODDFPRICE Returns the price per $100 face value of a security with an odd last period

ODDFYIELD Returns the yield of a security with an odd first period

ODDLPRICE Returns the price per $100 face value of a security with an odd last period.

ODDLYIELD Returns the yield of a security with an odd first period.

PRICE Returns the price per $100 face value of a security that pays periodic interest.

PRICEDISC Returns the price per $100 face value of a discounted security.

PRICEMAT Returns the price per $100 face value of a security that pays interest at maturity.

QUOTIENT Returns the integer portion of a division.

RANDBETWEEN Returns a random integer number between the numbers you specify.

RECEIVED Returns the prorated linear depreciation of an asset for each accounting period.

SERIESSUM Returns the sum of a power series based on the formula.

SQRTPI Returns the square root of ( number * pi ).

TBILLEQ Returns the bond-equivalent yield for a treasury bill.

TBILLPRICE Returns the price per $100 face value for a treasury bill.

TBILLYIELD Returns the yield for a treasury bill.

WEEKNUM_ADD Returns the week number in year.

WORKDAY Returns the serial number of the date before or after a specified number of workdays.

XIRR Returns the yield for a treasury bill.
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Function What It Does

XNPV Returns the net present value for a schedule of cash flows

YEARFRAC Returns the year fraction representing the number of whole days between start_date and end_date.

YIELD Returns the yield on a security that pays periodic interest.

YIELDDISC Returns the annual yield for a discounted security (for example, a treasury bill)

YIELDMAT Returns the annual yield of a security that pays interest at maturity

Enhanced Help System

Both newcomers and seasoned StarOffice users will appreciate the ease-of-use of the redes-
igned StarOffice Help system. 

New StarOffice Help window The StarOffice Help system has been completely redesigned
with an eye toward providing easier navigation and useful how-to information. The new Help
window opens as a separate task, which means you don't lose your digitally earmarked spot
when you return to or close documents. The window is divided into a searchable index pane
and a viewing pane that displays the contents of the selected index entries. 

The index pane features the Index, Find, and Bookmarks tabs. The Index tab lists the active
subset of all available help indexes. The Find tab enables users to search for terms that are not
individually indexed. The Bookmarks tab enables users to collect and organize a custom set of
frequently used help topics. 

The viewing pane displays the contents of the selected index entries and provides a toolbar
for browsing the help topics you have accessed during the current help session, and printing
or bookmarking the topics that are of special interest. 

FIGURE6: Use the new StarOffice Help window to find the answers you need, when you
need them

New Help contents Need to learn more about a particular StarOffice module? The index pane
features a drop-down list with help topics categorized by StarOffice modules. The contents are
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displayed in the viewing area of the StarOffice Help window, and consist of hypertext
manuals that provide useful how-to information about the tools and functions of the indi-
vidual StarOffice modules.

You can access StarOffice Help by pressing the F1 key, or by selecting Contents from the Help
menu.

Improved User Interface

The StarOffice 6.0 user interface has been given a face lift. Dialog boxes, tab pages, and menus
are redesigned to improve readability and make the application more intuitive to use. 

Enhanced menus  The StarOffice menus have been enhanced with icons that help you quickly
associate menu commands with icons and their corresponding use on toolbar buttons.

New layout To make StarOffice software more intuitive, menus have been updated with new
or renamed commands, and dialog boxes are redesigned and resized.

Enhanced dialog boxes StarOffice 6.0 treats all dialog boxes as system windows, which means
you can move them outside the current task window to clear the workspace. Furthermore, the
size of the standard dialog boxes is  increased to facilitate readability and navigation between
tab pages.

FIGURE7: StarOffice 6.0 sports a new look, with enhanced dialog boxes and menus.

New Features at a Glance
This section provides an overview of the new features in StarOffice 6.0, categorized by
module.
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What's New in StarOffice 6.0
Feature Enables You To... How to Access

Quick Launch
(Microsoft Windows only)

New

Easily launch new documents or open existing ones. Be sure to select the Quick Launch option
during setup.

Right-click the Quick Launch icon in the
Microsoft Windows system tray to launch
new documents.

Double-click the icon to open the New from
Template dialog box.

Dialog boxes as system
windows

Improved

Enjoy greater freedom when working with StarOffice by
moving dialog boxes outside the current StarOffice 6.0
task window. 

--

Address Book Source
utility

New

Integrate LDAP, Mozilla, Netscape 6.x, Microsoft
Outlook, and Microsoft Windows system address book
sources to facilitate mail merge operations and label
creation.

File > Templates > Address Book.

Address Data Source
AutoPilot

New

Import your existing contacts from Netscape
6.x/Mozilla, LDAP, Microsoft Outlook, Microsoft
Windows Address Book, or other data sources. The
AutoPilot steps you through the process of selecting an
external address book source, specifying relevant type-
specific data source settings or address book field
mappings for custom address sources, and assigning a
name to the new address book.

Opens automatically the first time you
launch a StarOffice 6.0 task.

File > AutoPilot > Address Data Source.

Send Document as E-mail

New

Send any document from within StarOffice as an e-mail
attachment using your default e-mail client. You can
set your default e-mail client by selecting Tools >
Options > StarOffice > External Programs.

File > Send > Document as E-mail.

XML-based file format

New

Maintain long-term file format compatibility.

Note: Binary StarOffice file formats are still
supported.

When saving files, select the Writer 6.0, Calc
6.0, Draw 6.0, Impress 6.0, or Math 6.0 file
types, respectively.

Password Encryption

New

Protect sensitive information. The new XML-based file
format also supports password encryption for text
documents and spreadsheets. Passwords are stored as
encrypted hash values. When saving files to the old
binary format, passwords are not encrypted. However,
when loading a document from a former version, the
password will be encrypted again.

In Writer 6.0:
Insert > Section.

In Calc 6.0:
Tools > Protect Document.

Document Converter

New

Convert binary Microsoft Office and StarOffice docu-
ments into the new StarOffice XML file format.

File > AutoPilot > Document Converter.

Advanced HTML export

New

Define the text encoding for the HTML export choosing
from a variety of character sets, including Unicode,
using the new Character Set dialog box in the HTML
Compatibility dialog box.

Note: When saving a document that contains charac-
ters that are not supported by the current character
set, the program alerts you to the characters that could
not be stored. These characters are then stored as 16-
bit Unicode character surrogates  in the format
&#1234 (for example, the Euro symbol in
iso-8859-1 is stored as &#8364).

Tools > Options > Load/Save > HTML
Compatibility.
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Feature Enables You To... How to Access

MathType filter
(Formula Editor only)

New

Ensures that formulas embedded in  a Microsoft Word
document are converted to and from MathType when
importing from or exporting to the Microsoft Office file
format.

File > Open or File > Save As.

Select the filter from the type drop-down list.

MathML filter
(Formula Editor)

New

Supports import and export for MathML files, the stan-
dardized W3 XML file format for equation exchange.

File > Open or File > Save As.

Select the filter from the type drop-down list.

Unicode support

New

Insert any combination of letters and diacritical marks,
as well as special characters from non-Western
languages.

Note: StarBats and StarMath fonts have been
replaced with corresponding characters in the new
Unicode character set. Font mapping ensures compati-
bility with documents that contain StarBats and Star-
Math fonts.

Insert > Special Character.

Support for Asian
languages

New

Create multilingual documents using Japanese,
Chinese, and Korean language features.

For details refer to the section "Improved International
and Unicode Support."

Tools > Options > Language Settings >
Languages; select the Enabled check box.

International number
formats

New

Use currency, date, and time formats for a specific
locale. 

For details refer to the section "Improved International
and Unicode Support."

To set the default currency:
Tools > Options > Language Settings >
Languages.

To specify date and time formats:
Insert > Fields > Other > Document or DocIn-
formation.

Mapping Algorithm for
Fonts

New

Accurately substitute fonts in documents that are not
installed on the system. These fonts are now mapped
with a newly implemented algorithm that uses hard-
coded internal tables, font family comparison, font
metrics, and internal name conventions. This results in
better font matching, even across platforms.

Tools > Options > Font Replacement.

Advanced Font Effects

New

Apply underlining and strikethrough to strings, not just
words. In previous StarOffice versions, these effects
could only be applied to alphanumeric characters (for
example, e-mail). Now every character (with the excep-
tion of spaces) is taken into account when using these
effects (for example, e-mail).

Format > Character > Font Effects.

StarOffice Gallery

Improved

Drag and drop colorful new clip art, pictures, shapes,
and sounds from the StarOffice Gallery into your docu-
ments, reports, presentations, and drawings. 

Toggle between a thumbnail view or list view
(complete with path and file names) of the StarOffice
Gallery's professionally designed contents.

Create your own themes and add  contents to this easy-
to-use media organizer.  

Select Tools > Gallery or click the Gallery
button on the Function bar.

To toggle Gallery views, use the Detailed
View and Icon View buttons on the Gallery
toolbar.

To add themes, click the New Theme button.

Help

New

Search for specific terms and phrases, bookmark
frequently accessed information, and quickly get help
about every StarOffice function and module using the
newly designed Help tool and user interface.  

Press F1 key or select Help > Contents.

New Features Guide 18



Feature Enables You To... How to Access

Templates and Documents
dialog box

Improved

Jump-start your projects with professionally designed
templates and sample files, including:

• New templates for business cards as well as busi-
ness and personal correspondence.

• New templates for tracking stocks and sports
results.

• Enhanced sample files highlight the strengths of
StarOffice 6.0.

Toggle between a thumbnail preview of the currently
selected file and its properties.

Organize and manage your templates with ease.

File > New > Templates and Documents.

Double-click the Quick Launch icon in the
system tray (Microsoft Windows only).

To toggle between views, select the Docu-
ment Properties and Preview buttons on the
dialog box's toolbar.

To organize templates, click the Organize
button.

Page Preview

Improved

Preview the layout of your document using the current
document window (previously, a new window was
opened). (StarOffice Writer 6.0 and Calc 6.0 only.) 

File > Page Preview

Paste button
(Function bar)

Enhanced

Streamline your copy, cut, and paste operations. The
Paste button, located on the Function bar, now
includes a drop-down menu. Using it, you can choose
whether you want to paste the selected text or object
in its original format or in a special format. The options
correspond to the same Paste Special options that are
available when you select Edit > Paste Special.

Select and copy or cut the object you want
to paste, and place the insertion point at the
new location.

Long-click the Paste button on the Function
bar.

Undo and Redo buttons
(Function bar)

Enhanced

Repeat or cancel a specific step. The Undo and Redo
buttons, located on the Function bar, now include drop-
down menus that enable you to choose from a range of
previous undo and redo steps. You can set the number
of Undo steps by selecting Tools > Options > StarOffice
> General.

Long-click the Undo or Redo button on the
Function bar.

Version info for DLLs

New

Verify the version of StarOffice DLLs under Microsoft
Windows.

Right-click the DLL and select Properties from
the context menu.

Automated Proxy settings
(Microsoft Windows only)

NewNewNewNew

Streamline the configuration of StarOffice 6.0 software.
When installing StarOffice for Microsoft Windows, the
setup routine automatically determines the system's
proxy settings and uses them as default.

Automated during the installation of the
StarOffice suite.

Quickstarter stops at
Setup

NewNewNewNew

Setup more easily.  If a quickstarter is running and the
setup is started in maintenance mode to remove,
restore or modify the office installation, the quick-
starter will be killed without any message.

New paper sizes

NewNewNewNew 

Use Japanese paper sizes

There are three new paper sizes on the tabpage
"Format - Page - Page":

• B4 (JIS) 257 x 364 mm

• B5 (JIS) 182 x 257 mm

• B6 (JIS) 128 x 182 mm

These are Japanese paper sizes for printing.

Format > Page > Page

Avery label support

NewNewNewNew    

Print to industry standard Avery labels. File > Print > Properties
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Feature Enables You To... How to Access

New icons

NewNewNewNew    

Identify the functions you need  more quickly during
installation.  The “All selected” and “Partial selected”
icons have been modified for easier differentiation.

-

Tools/Options/General

NewNewNewNew    

Reach the option you need quicker.  

The page Tools/Options/General is split up in two
pages as follows:

• The page "General" contains the settings for "Year
(two digits)", "Help Agent", "Open/Save dialogs".

• The page "Memory" contains the settings "Undo",
"Graphics cache", "Cache for embedded objects"
and "Quickstart".

Tools > Options > General

Language preselection

NewNewNewNew    

Save time upon startup.

The Language ListBox now preselects the language the
user has selected under
Tools/Options/Languages/Languages/Language of
Locale settings.  This is done each time the application
is started.

It remembers the selection and the dialog reopens
with the last selected language.

Tools > Options > Languages > Asian layout
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What's New in StarOffice Writer 6.0
Feature Enables You To... How to Access

Encoded Text filter

Enhanced

Save Asian language text files. The encoded text filter
has been enhanced to include the Chinese, Korean, and
Japanese character sets, as well as the Unicode (UTF-8)
set. 

For details on Asian language support refer to the
"Improved International and Unicode Support" section.

File > Save As.

Select Text (encoded) from the Save as type
drop-down list.

Graphics object bar

New

Set the graphic attributes (such as graphics mode, RGB,
contrast, and so on) of selected graphics from within
text, spreadsheet, drawing, and presentation docu-
ments. Previously, this feature was  available only in
StarOffice Image.

Insert or select a bitmap graphic.

Protect Record 

New

Add password protection to the Record feature. The
Record feature is used to make changes visible when
two or more people collaborate on the same
document. 

Edit > Changes > Protect Records.

Section Protection

Enhanced

Assign different passwords to individual sections. In
previous StarOffice versions, you could use just one
password for all sections.

Insert > Section.

Format > Section.

AutoFormat functionality

Enhanced

Specify whether you want the program to delete blanks
and tabs at the beginning or at the end of a paragraph
or a line when using the AutoCorrect feature.

Tools >  AutoCorrect/
AutoFormat > Options.

Line Numbering

Enhanced

Restart the numbering of lines with every new page. Tools > Line Numbering.

Automatic font color
attribute

New

Set the font color to your operating system's default
font color. If you change  the font's background to a
dark color, the font will automatically change to white.

Click the Font Color button on the Format
object bar and select Automatic.

Format > Character > Font > Font Color. 

Relief character attribute

New

Add 3-D effects to selected text elements.

This feature also facilitates the import and export of
Microsoft Word documents that contain the Character
Embossed and Character Engraved character attributes.

Format > Character > Font Effects.

Underlining Color
character attribute

New

Specify a color for underlining and strike-through
formatting independently from the font color.

This feature also facilitates the import and export of
Microsoft Word documents.

Format > Character > Font Effects. 

Negative indents for para-
graphs and tables

New

Set negative (left or right) indents to paragraphs and
tables, and specify the first line indent independently
from the left indent of a paragraph. 

For tables, you can also set negative values for the left
alignment. This enables you to align tables independ-
ently of the page setup margins.

This feature also facilitates the import and export of
Microsoft Word documents.

For paragraphs:
Format > Paragraph > Indents & Spacing.

For tables:
Format > Table > Table.

Border settings for para-
graphs and tables

New

Set the spacing between a border and its content to
zero (0). In former StarOffice versions, there was a
restriction for a minimal distance.

For paragraphs:
Format > Paragraph > Borders.

For tables:
Format > Table > Borders.

New Features Guide 21



Feature Enables You To... How to Access

Smart URL attributes

New

Streamline the process of changing a hyperlink in a
document. In StarOffice 6.0, the corresponding URL
attribute adapts the new settings automatically. For
example, if you change an e-mail address or a URL in a
document, the program changes the corresponding
mailto-address or the URL target, too. In former
versions, these attributes had to be changed manually.

--

Alternate cursor

New

More easily recognize when the Overwrite mode is
selected. When typing in Overwrite mode, the cursor
automatically selects the character that will be over-
written next.

Press Insert on your keyboard or click the
INSRT field on the status bar.

Hyphenation rules

Enhanced

Define the minimal number of characters for hyphen-
ation.

Tools > Options > Language Settings > Writing
Aids.

More flexibility when
creating labels

New

Modify existing label brands and types, and save them
as your own label format.

File > New > Labels > Format.

HTML 4 entities

New

Import HTML4 entities.  The HTML import of Writer and
Calc now supports all HTML4 character entities (like
&euro;).

Tools > Option > Load/Save > HTML compati-
bility 

Language support in HTML
filter 

New

Save and Writer's HTML filter now saves and loads
language information with the HTML filter.  

Textfilter

Improved

More easily access text filters.  Because the configura-
tion can't handle any system dependent entries, the
concept of StarOffice Writer Text filter has been
changed. The specific text filters for MAC, DOS and
UNIX are removed; but the functionality can now be
reached with the "Text (encoded)" filter.

The text filter remains in the filter list and has the old
functionality - use the system character set and system
line end value, where the Office is installed.
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Feature Enables You To... How to Access

Asian text font attributes

Improved

Set font attributes for Asian text.

The HTML filter now supports the Asian text font attrib-
utes, i.e. the Asian font name, size and typeface
(bold/italic).

If these attributes are contained in styles, and the
export settings allow it to make use of CSS, the Asian
font attributes are exported as additional CSS rules.
Two cases must be differentiated here: Styles that
directly correspond to an HTML tag (like 'Heading 1'
that corresponds to <H1>) and styles that are derived
from such styles.

In the first case, a single rule that has a tag (like H1) as
selector was exported before this feature change. Now,
up to three additional CSS rules are exported. These
rules all have the tag (like H1) and one of the classes
"western", "cjk" and "ctl" as selector.

They contain the font attributes that are specific to
western, Asian and complex text. And they are only
exported if the attribute settings for western, asian and
complex text differ. If they are the same, they remain
part of the rule that has a tag as selector only.

An example might be

• H1 { color: #ffff00 }

• H1.western { font-family: "Arial" }

• H1.cjk { font-family: "HG Mincho" }

On import, these rules are merged into the "Heading 1"
style again.

--

Smooth underlining

New

Underline adjacent portions of text which may have
different font sizes or text attributes, i.e. Asian charac-
ters next to Western spaces.

New default behavior

What's New in StarOffice Calc 6.0
Feature Enables You To... How to Access

ROMAN 
function

New

Convert a value between 0 and 3999 to a Roman style. The
function format is =ROMAN(value; mode). "Mode" is an
optional parameter to specify the accuracy of the Roman
value. 

For example:
ROMAN(999; 0) and ROMAN(999) returns CMXCIX
ROMAN(999; 1) returns LMVLIV
ROMAN(999; 2) returns XMIX
ROMAN(999; 3) returns VMIV
ROMAN(999; 4) returns IM

Insert > Function. 

Enter the function in the Formula bar.

ARABIC
function

New

Convert a text that represents a Roman number into a
value (between 0 and 3999). The function format is
=ARABIC(text).

Insert > Function. 

Enter the function in the Formula bar.

MIRR
function

New

Calculate the modified internal rate of return for a series
of cash flows with interest rates for investments and rein-
vestments. The function format is =MIRR(values;
rate_investment; rate_reinvestment).

Insert > Function. 

Enter the function in the Formula bar.
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Feature Enables You To... How to Access

CELL
function

New

Provide information about content, formatting, or location
of a specific cell. The  function format is =CELL(info_type;
reference). "Info_type" specifies the type of information
that should be returned. "Reference" is optional, and
determines the cell or cell range to be examined.

Insert > Function 

Enter the function in the Formula bar.

ISPMT
function

New

Calculate the interest of a credit or investment with
constant redemption rates: =ISPMT(rate;
amortization_periods; total_periods; investment).

Insert > Function. 

Enter the function in the Formula bar.

Analysis Addin 

New

Provide new analysis functionality and facilitate document
exchange with Microsoft Excel users.

For more details on these new functions see the "Improved
Microsoft Office Interoperability" section.

Insert > Function. 

External Data 
dialog box

New

Insert data from external sources (such as linked areas or
WebQueries). Using this dialog box, you can specify a file
or URL and select one or more of that file's named ranges.
If the source is an HTML file loaded with the new
WebQuery HTML filter, the names represent the tables in
the HTML file. In addition, you can specify an interval for
automatic link refresh. To change the settings for a linked
area, use the Modify button of the Edit Links dialog box
(Edit > Links).

Insert > External Data.

Sort options

New

Specify language- and locale-dependent sort options. The
default sort option depends on the system language
setting and locale.

Data > Sort > Options.

Protect Record 

New

Add password protection to the Record feature. The Record
feature is used to make changes visible when two or more
people collaborate on the same document. 

Edit > Changes >   Protect Records.

Matrix Arrays

Improved

Perform complex scientific calculations. The number of
elements that can be used in a matrix arra, has been
increased. In former versions, this number was limited to
16,384 elements per matrix, while the new limit is 512,000
elements.

--

Print options

New

Print spreadsheet documents with two additional options:

• Suppress output of empty pages:
If this option is active, pages that don't contain cell
contents or drawing objects are not printed. Cell
attributes (such as borders or background color) are
an exception to the rule, and don't count as content.

• Print only selected sheets:
If this option is active, choosing "All" in the print
dialog doesn't print the whole document, but only the
selected sheets. Similarly, a specified range of pages
is counted only within the selected sheets. 

To specify the default print options, select Tools > Options
> Spreadsheet > Print.

File > Print > Options.

Extended String length

Improved

Reduce calculation time and use less memory. The
maximum string length in formulas has been increased
from 255 bytes to 64 kilobytes. This enables the program
to handle concatenating strings, where the sum of all
lengths is greater than 255 characters. However, literal
strings entered directly in a formula (="hello world") are
still limited to 255 characters, including the quotes.

--

New Features Guide 24



Feature Enables You To... How to Access

Multiple Operations

Improved

Perform multiple operations with greater flexibility. This
feature now extends to formulas that contain references
to other formulas. Unlike previous StarOffice versions, a
multiple operation isn't restricted  to acting only on the
formula selected in the dialog box. Instead, cell addresses
that are indirectly referred to are replaced in every
formula encountered during the calculation of a multiple
operation.

Data > Multiple Operations.

Percent Sign Operator in
formulas

Improved

Calculate percentages of results with ease. The percent
sign operator is recognized in formulas, and if appropriate,
the result is displayed formatted as a percent value. The
percent sign operator divides the preceding subexpression
by 100.

This feature also facilitates collaboration with Microsoft
Excel users. 

Use in formulas or the Formula bar.

ASCII Import

Improved

Recognize English date formats, in addition to the default
formats set by the system language, when importing a
text file into StarOffice Calc. This enables you to import
formats such as 12-Mar-01, independent of the format used
by the system language.

File > Open.

Text filter

Improved

Import and export 16-bit Unicode text files. File > Open or File > Save As.

Select Text – txt - csv from the file type
drop-down list.

Printer Metrics for text
formatting

New

Solve the problem of different line breaks  on print and
screen by selecting the line break alignment option for
cells. This option shows line breaks as they appear in print
on-screen. 

Note: This option is global to the application, not saved
with documents. 

Tools > Options > Spreadsheet > General.

Automatic Hyphenation

New

Hyphenate text in cells.

Note: This option is available only in combination with
the Line break option.

Format > Cells > Alignment.

Copy filtering

Improved

Use filtering when copying cells.  When a cell range
containing rows which were filtered out (AutoFilter, Stan-
dard filte. Advanced filter) is copied and pasted, only the
cells from rows that were not filtered out are used.

The same is true for Drag&Copy, pasting from the primary
selection, and the API copyRange call (XcellRangeMove-
ment interface).

Cut&Paste, Drag&Drop (moving) and the API moveRange
method are not affected.  Columns or rows that were
hidden manually are also not affected.

Tools > Filter > Auto/Standard/Advanced

What's New in StarOffice Impress 6.0 / Draw 6.0
Feature Enables You To... How to Access

Crop button 

New

Access the Crop dialog box with a click of the mouse. This
new button is located on the Graphics object bar, which
becomes available when you insert or select a bitmap
(pixel) graphic.

Click the Crop button on the Graphics
object bar.

Rotate option for meta files

New

Rotate meta files just like ordinary bitmap graphics. Format > Position and Size > Rotation.

New Features Guide 25



Feature Enables You To... How to Access

Cache buffering

New

Set an upper limit (in kilobytes) for the total graphics cache
size, as well as cache a single graphic object. If the size of
one object exceeds this predefined size, the graphics output
is not cached. This means that the graphic is rendered
directly on-screen every time you move or access the
graphic.

Tools > Options > StarOffice > General.

Print options

Enhanced

Access new printing options for graphics that contain trans-
parencies. These include:

• Reduced Transparency
Enables you to treat all transparent objects as
nontransparent. If used in combination with the Auto-
matic option,  transparency is reduced only if the
covered area of replacement is more than 1/4 of the
whole page. The No transparency option always
reduces transparency completely.

• Reduce gradients
Decreases the number of gradient steps  to the real
number set when the gradient was defined.

• Reduce bitmaps
Prints transparent bitmaps at the maximum resolution
(in dpi).

• Convert colors to grayscale
Renders output in grayscale.

Tools > Options > StarOffice > Print.

AutoLayout designs
(Impress only)

New

Create slides for Asian audiences. StarOffice Impress 6.0
includes four new AutoLayouts that support vertical text to
complement the new StarOffice 6.0 Asian language
features.

For details on Asian language support refer to the
"Improved International and Unicode Support" section.

Start a new presentation; select design in
the Modify Slide dialog box.

Format > Modify Layout.

EPS export

Enhanced

Export text as glyph outlines. This enables you to export
text that contains Chinese, Japanese, Korean, or other
double-byte characters to Encapsulated PostScript (EPS).

File > Export.

Select EPS from the Save as type drop-
down list.

Command Line options
(Impress Player)

New

Control the StarOffice Impress Player more easily with
new command line options:

• [A|a]:
Enable/disable automatic slide transition

• [L|l]:
Enable/disable presentation looping

• [F|f]:
Enable/disable full-screen presentation window

• K:
Enable kiosk mode, which includes -A, -L and -F, as well
as forcing the presentation window into the fore-
ground.

Enter at the command prompt.

What's New in StarOffice Base 6.0
Feature Enables You To... How to Access

Database Source Concept

New

Manage data sources with ease. Instead of creating and
maintaining a proprietary StarOffice database format (.sdb),
StarOffice Base 6.0 works only with data sources. StarOffice
Base 6.0 connects and administers a wide variety of data
sources, and provides data access to all StarOffice compo-
nents

--
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Feature Enables You To... How to Access

Data Source Administration
dialog box

New

Administer the office-wide registered data sources from one
location. Using this dialog box, you can build connections
to existing data sources, specify (StarOffice Calc or Micro-
soft Excel) spreadsheet documents as data sources, design
and edit database tables, define new queries or edit
existing ones and create links to remote data sources.

Tools > Data sources.

Database Table Administra-
tion

Enhanced

Select individual database tables as well as an entire table
container (All tables). If you select a container, all future
database tables that are created as part of this source will
be automatically available when reconnecting to the data
source.

Note: When using databases that support version fields,
you can indicate the version of data records by selecting the
new Display version columns (when available) check box.

Tools > Data sources > Tables.

Data Source Browser

New

View the available tables and queries of the connected data
sources in a Microsoft  Explorer-like tree view. Switching
between data sources is as easy as selecting the data source
you want in the tree view — the program automatically
loads the data in the table grid. 

Depending on the current selection, the Table view context
menu offers commands for editing, copying, and deleting
database objects or creating new tables or queries in the
design mode. You can toggle the tree view on or off by
clicking the Explorer button on the Data Source browser
toolbar. 

Press the F4 key, or select View > Data-
base.

Database Driver

NewNewNewNew

Supports access to the operating system's address book,
including Microsoft Outlook Express, Microsoft Outlook,
Mozilla, and LDAP-compatible address books. You can select
the new Addressbook driver from the Database type drop-
down list in the Data Source Administration dialog box. To
specify the data source, click the Browse button next to the
Data source URL text box.

Note: Using the Database type drop-down list, you may
also specify a spreadsheet as a data source.

Tools > Data Sources.

Database Import AutoPilot

New

Import  StarOffice 5.2 (or earlier) databases. The Database
Import AutoPilot will store your existing StarOffice queries,
forms, and reports in the new DataAccess.xml configuration
file. Form documents are stored as regular documents.

In addition, the Database Import AutoPilot enables you to:

• Select an individual StarOffice database (sdb) file.

• Create a new data source with the settings extracted
from the file, so applications can access the data.

• Extract the queries from the file and store it in the
configuration file or another file you have specified.

• Extract the form documents in the file and store them
in a directory of your choice.

• Substitute StarOffice 5.2 variables for fixed paths. In
StarOffice 5.2, you could use the following variables
instead of path names when pointing to a data source:
• $(USER)

• $(USERURL)

• $(INST)

• $(INSTURL)
Note:  Reports are not extracted.

File > AutoPilot > StarOffice 5.2 Database
Import.
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Feature Enables You To... How to Access

AutoPilot for Combo and
List Boxes

Improved

Assign a database table to a combo or list box, in case the
form that the control belongs to is not bound to a data
source.

Form Functions (on the Main to0lbar) >
List Box or Combo Box.

AutoFocus for Form Layers

New

Set the focus for controls automatically when toggling
Design mode on or off. If the automatic control focus is
active, the first control of the first logical form element in
the document will get the focus. This is useful for forms in a
StarOffice document that is used for data entry only (for
example, a text document).

Click the Automatic control focus button
on the Form Functions toolbar.

Form Events

New

Bind macros with ease, using these two new form events:

• Before reloading: 
Called before a reload on the form is executed.

• Before unloading: 
Called before the form is unloaded.

Previously, these events could be used only with a scripting
language.

Form Functions (on the Main toolbar) >
Form Properties > Events.

Index Design for Tables

New

Edit the indexes of tables. This component has been
completely rewritten. A new Index Design button on the
Table Design toolbar provides one-click access to Indexes
dialog box. 

Right-click a table in the Data Sources
browser and select Edit Table from the
context.

Click the Index Design button on the
Table Design toolbar.

Use catalog for file-based
databases option

New

Toggle the catalogs used in file-based ODBC data source on
or off. By default, this option is not selected.

Tools > Data Sources > ODBC.

UTF-8 Support

New

Use the UTF-8 character set.

Note: This support does not extend to ADO (which do not
have a character set) or dBase data sources.

Tools > Data Sources.

IBM866 support 

New

Use the IBM866 character set, also known as cp866 or
csIBM866, with dBase and text data sources.  This is a
Cyrillic character set which had been requested by a
number of users.

Tools > Data Sources > dbase > IBM866

What's Different in StarOffice 6.0
If you've used a previous version of StarOffice, you may wonder what happened to some
StarOffice features, such as the StarOffice Integrated Desktop or the StarOffice Mail, Image,
Chart, and Schedule modules. Customer research indicated that most users of  StarOffice soft-
ware were not taking advantage of certain  features. In response to requests, the StarOffice 6.0
suite has been redesigned with a focus on improving the performance of the core module,
while giving you the freedom to supplement discontinued StarOffice features with their
preferred alternatives.

Module Previously What Has Changed

StarOffice Integrated
Desktop (including Beamer
and Explorer)

Providing a unified desktop work envi-
ronment, including file and folder
management.

StarOffice 6.0 software is seamlessly integrated with supported
operating systems, making the integrated desktop superfluous.

StarOffice Chart Creating and inserting standalone
charts.

The charting functionality is fully integrated with all StarOffice
modules. As a result, you no longer need a separate charting
application. However, you can still load standalone charts
created with StarOffice 5.2 or earlier, and insert them into
documents as OLE objects. To edit a standalone chart, select
Edit > Chart Data. 
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Module Previously What Has Changed

StarOffice Image Editing and creating bitmap graphics The StarOffice Image functionality has been merged with
StarOffice Writer, Calc, Draw, and Impress.

Tiling is no longer available as a single filter. Instead, a check
box in the Options dialog enables you to choose if edges
should be enhanced (old Mosaic functionality) or not (old
Tiling functionality).

When loading documents created with StarOffice 5.2 or earlier
that contain Image OLE objects, StarOffice 6.0 automatically
converts the OLE object into a graphic object. The graphic is
extracted based on the data included in the corresponding
Image OLE storage.

StarOffice Mail and StarOf-
fice News

Sending and receiving e-mail and
reading newsgroups

The StarOffice Mail and News modules have been removed
because the majority of StarOffice users were not using these
applications frequently. StarOffice 6.0 now uses the default e-
mail client (Microsoft Windows) or Netscape™ Messenger
(Solaris and Linux) for sending documents as attachments.

StarOffice Schedule Managing tasks and schedules An improved tool is being developed and will be available
soon. In the meantime, you can continue to use StarOffice 5.2
Schedule. 

StarOffice API Providing third-party tools and
building macros

StarOffice 6.0 introduces a new API, which is fully documented
in the ODK, available at
 www.openoffice.org. 

StarOffice Writer Form letter as email The mail merge function (File > Form Letter) no longer
supports email.

StarOffice Writer -- If the current task window contains an unnamed, unmodified
document and a new document is loaded, the new document
replaces the unnamed one.

StarOffice Writer -- StarOffice exits when the last document is closed.  To keep
StarOffice running, open a new document before closing the
last document on which you are working.

StarOffice Pack n Go functionality removed Pack n Go functionality has been removed.  StarOffice docu-
ments are now stored in a compressed industry-standard XML
format.

StarOffice (Setup) -- MS Office file types and HTML editor  are registered upon
setup.

For More Information
For more product information and to see how large enterprises, small businesses, educators,
and individuals are using the StarOffice 6.0 suite of productivity tools, please refer to the
StarOffice 6.0 Product Guide available at www.sun.com/staroffice.
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CHAPTER 2  

System Requirements and Availability

The StarOffice 6.0 Suite
To use the StarOffice 6.0 suite, your system must meet the following minimum requirements.

Solaris Operating Environment (SPARC Platform Edition)
• Solaris 7 Operating Environment (SPARC Platform Edition) or higher (Solaris 8 recom-

mended) 

• 128-Mbytes RAM

• 250-Mbytes available hard disk space

• X Server with 800 x 600 or higher resolution, with 256 colors

Patches

For patches, go to http://sunsolve.sun.com. 

• Required for Solaris 7: 106327-08, 106300-09 (64-bit only)

• Required for Solaris 8: 108434-01, 108773-12, 108435-01 (64-bit only)

Solaris Operating Environment (Intel Platform Edition)
• Solaris 7 Operating Environment (Intel Platform Edition) or higher

• Intel Pentium-compatible PC

• 64-Mbytes RAM

• 250-Mbytes available hard disk space

• X Server with 800 x 600 or higher resolution, with 256 colors

Patches

For patches, go to http://sunsolve.sun.com 

• Required for Solaris 7: 106328-08

• Required for Solaris 8: 108436-01

Linux Platform
• Linux Kernel version 2.2.13 or higher

• glibc2 version 2.1.2 or higher

• Intel Pentium-compatible PC

• 64-Mbytes RAM

• 250-Mbytes available hard disk space

• X Server with 800 x 600 or higher resolution, with 256 colors

New Features Guide 30



Microsoft Windows
• Microsoft Windows 95, 98, ME, NT, 2000, or XP

• Intel Pentium-compatible PC

• 64-Mbytes RAM

• 250-Mbytes available hard disk space

• 800 x 600 or higher resolution graphic device, with 256 colors

To obtain a copy of the StarOffice 6.0 suite, go to www.sun.com/staroffice/.

Sun Microsystems
901 San Antonio Road
Palo Alto, CA 94303

1 (800) 786.7638
1.512.434.1511

www.sun.com/staroffice/
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