Name | Synopsis | Interface Level | Parameters | Description | Return Values | Context | Attributes | See Also
#include <sys/neti.h> phy_if_t net_phylookup(const net_data_t net, const char *name);
Solaris DDI specific (Solaris DDI).
value returned from a successful call to net_protocol_lookup(9F).
name of the network interface to find.
The net_phylookup() function attempts to resolve the interface name passed in with the network protocol.
When called successfully, the value returned represents a network interface that exists, at the time of the call, within the scope of the network interface. This value is only guaranteed to be unique for a name within the scope of the network protocol.
The net_phylookup() function returns -1 if it is not supported by the network protocol, and 0 if the named network interface does not exist (or is otherwise unknown). Otherwise, it returns a value greater than 0 representing a network interface that currently exists within the scope of this network protocol.
The net_phylookup() function may be called from user, kernel, or interrupt context.
See attributes(5) for descriptions of the following attributes:
ATTRIBUTE TYPE |
ATTRIBUTE VALUE |
---|---|
Availability |
SUNWcsu |
Interface Stability |
Committed |
Name | Synopsis | Interface Level | Parameters | Description | Return Values | Context | Attributes | See Also