Sun Update Connection - Enterprise Release Notes

Configuration Issues

This section describes issues that you might encounter while configuring your Sun Update Connection – Enterprise environment.

Setting the Default Kernel for the Linux Knowledge Channel (#6456009)

Description:

If you are using the Linux knowledge channel, you cannot use Sun Update Connection – Enterprise to set the default kernel.


Note –

This issue is fixed in the 1.0.2 release.


Workaround:

Instead, you must set the default kernel manually.

Enabling Log Rotation in the Sun Update Connection – Enterprise Proxy (#6455904)

To enable log rotation in the Sun Update Connection – Enterprise Proxy, manually install a copy of the Log_rotation configuration file on the proxy.

The file is on the server at /etc/logrotate.d/director_server.

Local Solaris Patches That are Not Available on SunSolve are Not Included in the Knowledge Base (#6456168)

Local patches that are not available on SunSolveSM and that are distributed as part of a package are not included in the Sun Update Connection – Enterprise knowledge base.

In these cases, the Sun Update Connection – Enterprise agent might not have installed a needed patch given that the (needed) patch it intends to install is obsoleted by an already installed (local) patch.

For example, if PKG-1 installs Patch-Q (local patch not part of knowledge base), Sun Update Connection – Enterprise then recommends Patch-P. However, Patch-Q obsoletes Patch-P. In this case, UCE (correctly) fails to install the obsoleted patch Patch-P.

When using Solaris Baselines, add the obsoleted patch, Patch-P, to the black list.

Cookies are Expired When Downloading Red Hat Components (#6456196)

Description:

When you attempt to download Red Hat components from the Red Hat Network, the download fails because the cookies have expired.

You might see this problem when you use other web clients, such as Konqueror.

Cause:

This problem occurs when the system clock on your SDS is not set to the current time, but is set forward to a time in the future. Cookies created on your system might be expired.

Workaround:

Ensure that the system clock on the SDS machine is set to the current time. The system clock must be set to the current time because it is used for cookie validation.