halt and poweroff write out any pending information to the disks and then stop the processor. poweroff will have the machine remove power, if possible.
halt and poweroff normally log the system shutdown to the system log daemon, syslogd(1M), and place a shutdown record in the login accounting file /var/adm/wtmp. These actions are inhibited if the -n or -q options are present.
The following options are supported:
Force a system crash dump before rebooting. See dumpadm(1M) for information on configuring system crash dumps.
Suppress sending a message about who executed halt to the system log daemon, syslogd(1M), about who executed halt
Prevent the sync(4) before stopping.
Quick halt. No graceful shutdown is attempted.
Halt the system, even from a dialup terminal.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
This command requires the
privilege and an effective uid of 0 in order to run.
The poweroff utility is equivalent to init 5.