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Preface

Most of the information in the Java Desktop System Release 2 User Guide is generic for
the following releases of the Java Desktop System:

� Java Desktop System Release 2 for the Solaris™ Operating System on the x86
Architecture

� Java Desktop System Release 2 on Linux

Where the information is not generic, the platform is indicated.

Who Should Use This Book
This book is for users who plan to use the Java Desktop System as the default desktop
environment.

Before You Read This Book
Before you read this book, you should ensure that you have some familiarity with the
following topics:

� Three-button mouse devices
� Graphical user interfaces
� Command line interfaces
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How This Book Is Organized
This book is organized as follows:

� Getting Started

This chapter provides information about how to start, manage, and end Java
Desktop System sessions.

� Overview of the Java Desktop System

This chapter introduces the major components and functions of the Java Desktop
System. If you do not read anything else in this manual, read this chapter.

� Working With Panels

Panels are a key component of the Java Desktop System. This chapter tells you
how to use the different parts of your panels, and how to invoke the available
functions of the Java Desktop System using panels.

� Working With Menus

This chapter provides information about how to use and customize the menus in
the Java Desktop System.

� Working With Windows

This chapter describes basic windows functions such as moving and resizing. This
chapter also describes the controls that you use with windows.

� Using Your File Manager

This chapter describes how to use the file manager to work with your file system.

� Using Your Desktop Background

This chapter describes how to use the desktop background to start applications, and
open your files and folders. The chapter also describes how to use Trash from the
desktop background, how to use the desktop background menu, and how to
customize the desktop background.

� Using Your Preference Tools

This chapter describes how to use the preference tools to customize the Java
Desktop System.

� Appendix A: Mouse and Keyboard Functionality

This appendix provides information about mouse usage, shortcut keys, basic
window skills, and basic dialog skills.

� Glossary is a list of terms used in this book, and definitions of the terms.
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Related Documentation
The following manuals are related to this guide:

� Java Desktop System Release 2 Accessibility Guide
� Java Desktop System Release 2 Installation Guide
� Java Desktop System Release 2 Release Notes
� Java Desktop System Release 2 Administration Guide
� Java Desktop System Release 2 Troubleshooting Guide
� Java System Update Service User’s Guide

You can access these manuals on the accompanying software media, and at
http://docs.sun.com.

Associated Documentation
The following manuals are associated with this guide:

� StarOffice 7 Office Suite Administration Guide
� StarOffice 7 Office Suite Basic Guide
� StarOffice 7 Office Suite Setup Guide
� StarOffice 7 Office Suite User’s Guide
� Ximian Evolution 1.4 Sun Microsystems Edition User Guide

You can access these manuals on the accompanying software media, and at
http://docs.sun.com.

Accessing Sun Documentation Online
The docs.sun.comSM Web site enables you to access Sun technical documentation
online. You can browse the docs.sun.com archive or search for a specific book title or
subject. The URL is http://docs.sun.com.
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Ordering Sun Documentation
Sun Microsystems offers select product documentation in print. For a list of
documents and how to order them, see “Buy printed documentation” at
http://docs.sun.com.

Typographic Conventions
The following table describes the typographic changes used in this book.

TABLE P–1 Typographic Conventions

Typeface or Symbol Meaning Example

AaBbCc123 The names of commands, files, and
directories; on-screen computer output

Edit your .login file.

Use ls -a to list all files.

machine_name% you have
mail.

AaBbCc123 What you type, contrasted with
on-screen computer output

machine_name% su

Password:

AaBbCc123 Command-line placeholder: replace with
a real name or value

To delete a file, type rm
filename.

AaBbCc123 Book titles, new words, or terms, or
words to be emphasized.

Read Chapter 6 in User’s Guide.

These are called class options.

You must be root to do this.

Shell Prompts in Command Examples
The following table shows the default system prompt and superuser prompt for the C
shell, Bourne shell, and Korn shell.
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TABLE P–2 Shell Prompts

Shell Prompt

C shell prompt machine_name%

C shell superuser prompt machine_name#

Bourne shell and Korn shell prompt $

Bourne shell and Korn shell superuser prompt #
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CHAPTER 1

Getting Started

This chapter provides the information you need to start, manage, and end a Java
Desktop System session.

Logging In to Your Desktop
A session occurs between the time that you log in to the Java Desktop System and the
time that you log out. The login screen is your gateway to the Java Desktop System.
The login screen provides fields for you to enter your username and password. The
login screen enables you to select login options, for example you can select the
language of your session.

You start a session when you log in. The session manager starts after your username
and password are authenticated. The session manager enables you to manage the
session. For example, you can save the state of your most recent session and return to
that session the next time that you log in. The session manager saves and restores the
following:

� The appearance and behavior settings, for example fonts, colors, and mouse
settings.

� The applications that you were running, for example file manager and text editor
windows. You cannot save and restore applications that the session manager does
not manage. For example, if you start the vi editor from the command line in a
terminal window, session manager cannot restore your editing session.

To Log In to the Desktop on Linux
To log in to the desktop, perform the following steps:
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1. On the login screen, click on the Session icon. Choose the Java Desktop System
from the list of available desktop environments.

2. Enter your username in the Username field on the login screen, then press Return.

3. Enter your password in the Password field on the login screen, then press Return.

When you log in successfully, the session manager starts a session. If this is the first
time you log in, then the session manager starts a new session. If you have logged in
before, then the session manager restores your previous session, if you saved the
settings for the previous session when you logged out.

If you want to shut down or restart the system before you log in, click on the Actions
icon on the login screen. A dialog is displayed. Select the option that you require, then
click OK.

To Log In to a Different Language on Linux
To log in to the desktop in a different language, perform the following actions:

1. On the login screen, click on the Language icon. Choose the language you require
from the list of available languages.

2. Enter your username in the Username field on the login screen, then press Return.

3. Enter your password in the Password field on the login screen, then press Return.

Note – When you log in to a session in a different language, you choose the language
for the user interface. You do not specify a keyboard layout for the session. To specify
a keyboard layout, use the Keyboard Layout Switcher panel application.

Panel applications are small, interactive applications that reside within a panel, for
example CD Player. Each panel application has a simple user interface that you can
operate with the mouse or keyboard.

To Log In to the Desktop on the Solaris Operating
System
To log in to the desktop, perform the following steps:

1. Choose Options → Session. Choose the Java Desktop System from the list of
available desktop environments.

2. Enter your login name in the field on the Login Manager dialog, then click OK.

3. Enter your password in the field on the Login Manager dialog, then click OK.
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When you log in successfully, the session manager starts a session. If this is the first
time you log in, then the session manager starts a new session. If you have logged in
before, then the session manager restores your previous session.

To Log In to a Different Language on the Solaris
Operating System
To log in to the desktop in a different language, perform the following actions:

1. On the login dialog, choose Options → Session. Choose the Java Desktop System
from the list of available desktop environments.

2. On the login dialog, choose Options → Language.

3. Choose the language group that includes the language that you want.

4. Choose a language.

5. Log in.

Your system administrator sets the default language for your system. The Options
menu on the Login Manager dialog enables you to access other languages. When you
choose a language in the Options menu, your system sets the LANG variable for your
session. The system restores the default language at the end of the session.

When You Log In for the First Time
When you start a session for the first time, you should see a startup screen, with a
panel at the bottom of the screen and various icons on the desktop background.

Initial Desktop Configuration
This section describes what you see when you start a session for the first time. Your
system administrator might have set your default bottom edge panel according to
your local requirements, so you might see a slightly different bottom edge panel.

The Java Desktop System startup screen consists of the following:

� This Computer

Enables you to access media and configuration details about your system.

� Documents

Enables direct access to files stored in your default directory.

Chapter 1 • Getting Started 21



� Trash

Provides a temporary holding area for files, folders or desktop objects that you can
later retrieve or permanently delete.

� Learn About The Java™ Desktop System

Launches a help browser from where you can access Help about the Java Desktop
System.

� StarOffice 7

Launches the StarOffice application.

� Bottom edge panel

The following panel objects appear in your bottom edge panel by default:

� Launch button: Provides menus for applications and configuration tools on the
Java Desktop System.

� Clock: Displays the time and date in a panel.

� Show Desktop: Displays a button that you can click to minimize all open
windows.

� Window List: Displays a button for each window that is open. You can click on
a window list button to minimize and restore windows.

� Notification Area: Displays icons from various applications to indicate activity
in the application. For example, when you use the CD Player application to
play a CD, a CD icon is displayed in the Notification Area.

� Workspace Switcher: Displays a visual representation of your workspaces. You
can use Workspace Switcher to switch between workspaces.

� Volume Control: Displays a button that enables you to control and set the
sound level for your system.

� Input Method Switcher: Displays a button to provides integral and multilingual
input method capabilities.

� Desktop Background

The desktop background lies behind all of the other components on the Java
Desktop System. The desktop background is an active component of the user
interface. You can place objects on the desktop background to quickly access your
files and directories, or to start applications that you use often. You can also
right-click on the desktop background to open a menu.

To Lock Your Screen
To lock the screen, perform one of the following actions:

� Click Launch, then choose Lock Screen.
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� If the Lock button is present on a panel, click on the Lock button.

To add the Lock button to a panel, right-click on the panel. Choose Add to Panel →
Actions → Lock.

When you lock your screen, the screensaver starts. To unlock the screen, move your
mouse to display the locked screen dialog. Enter your username and password in the
locked screen dialog, then press Return.

For information on configuring your screensaver, see Using Your Preference Tools.

Note – To lock your screen correctly, you must have a screensaver enabled.

Managing Your Desktop Session
To configure your desktop session, use the Sessions preference tool. The Sessions
preference tool recognizes the following types of application:

� Applications that are session-managed. When you save the settings for your
session, the session manager saves all of the session-managed applications. If you
log out, then log in again, the session manager automatically starts the
session-managed applications.

� Applications that are not session-managed. When you save the settings for your
session, the session manager does not save any applications that are not
session-managed. If you log out, then log in again, the session manager does not
start non-session-managed applications. You must start the application manually.
Alternatively, you can use the Sessions preference tool to specify
non-session-managed applications that you want to automatically start.

For information on configuring your sessions, see Using Your Preference Tools.

To Define Log In and Log Out Behavior
To set how a session behaves when you log in and log out, use Sessions preference
tool. Make the changes you require in the Session Options tabbed section. For
example, you can select to display a splash screen when you log in.
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To Use Startup Applications
You can configure your sessions to start with applications that are not
session-managed. To configure non-session-managed startup applications, use the
Sessions preference tool. Use the Startup Programs tabbed section to add, edit, and
delete applications. If you save your settings and log out, the next time that you log in,
the startup applications start automatically.

To Browse Applications
To browse the applications in the current session, use the Sessions preference tool. The
Current Session tabbed section lists the following:

� All Java Desktop System applications that are currently running, that can connect
to the session manager, and that can save the state of the application.

� All preference tools that can connect to the session manager, and that can save the
state of the tool.

You can use the Current Session tabbed section to perform a limited number of
actions on the session properties of an application or preference tool. For example, you
can edit the startup order, and restart style of any Java Desktop System application or
preference tool that is in the list.

To Save Your Settings
To save your session settings, perform the following steps:

1. Configure your session to automatically save settings when you end the session. To
configure your session, use the Sessions preference tool. The Sessions preference
tool starts. Select the Automatically save changes to session option on the Session
Options tabbed section.

2. End your session.

If you do not select the Automatically save changes to session option, when you log
out, a dialog asks if you want to save your current settings. To save your settings,
select the option, then continue to log out.
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Logging Out
To end your session, close all your currently active processes, then perform one of the
following actions:

� Click Launch, then choose Log Out name.

� If the Log Out button is present on a panel, click on the Log Out button.

To add the Log Out button to a panel, right-click on the panel. Choose Add to
Panel → Actions → Log Out.

Before you end a session, you might want to save your current settings so that you can
restore the session later. During the logout process, a dialog asks if you want to save
your current settings. In the Sessions preference tool, you can select an option to
automatically save your current settings.
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CHAPTER 2

Overview of the Java Desktop System

This chapter introduces you to the features and main components of the Java Desktop
System. Before you start to use the Java Desktop System, read this chapter to
familiarize yourself with the various features, and how the main components work.
Since the Java Desktop System is very configurable, this chapter describes only the
typical default configuration.

Introducing the Java Desktop System
The most powerful features of the Java Desktop System are the high degree of
configurability and the multiple ways that you can perform tasks.

The Java Desktop System provides the following functionality that enables you to
interact efficiently with your applications and documents.

� Panels

Panels are areas in the Java Desktop System from which you can access all of your
system applications and menus.

� Menus

You can access all Java Desktop System functions through menus. You can use the
Applications menu to access almost all of the standard desktop applications,
commands, and configuration options. You can access the Applications menu from
the Launch button and from the Menu Bar panel application. You can add the
Launch button and the Menu Bar to your panels.

The Menu Bar contains an Actions menu. The Actions menu contains commands
that perform various functions, for example Find Files and Log Out.

� Windows

You can display many windows at the same time. You can run different
applications in each window. The window manager provides frames and buttons
for windows. The window manager enables you to perform standard actions such
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as move, close, and resize windows.

� Workspaces

You can subdivide the Java Desktop System into separate workspaces. A workspace
is a discrete area in which you can work. You can specify the number of
workspaces in the Java Desktop System. You can switch to a different workspace,
but you can only display one workspace at a time.

� File Manager

Nautilus is the name of the Java Desktop System file manager that provides an
integrated access point to your files and applications. You can display the contents
of your files within a file manager window, or open the files in the appropriate
application from the file manager.

The file manager also manages the desktop background.

� Desktop Background

The desktop background is behind all of the other components of the Java Desktop
System. The desktop background is an active component of the user interface. You
can place objects on the desktop background to quickly access your files and
directories, or to start applications that you use often. You can also right-click on
the desktop background to open a menu.

� This Computer

The This Computer location provides an access point to some of the key features
of the Java Desktop System. You can access your applications and configuration
tools from the This Computer location. You can also access programs that enable
you to configure your system as a server, and to modify other system configuration
details.

� Desktop Preferences

The Java Desktop System contains dedicated preference tools. Each tool controls a
particular part of the behavior of the Java Desktop System. To start a preference
tool, click Launch, then choose Preferences. Choose the item that you want to
configure from the submenus.

The components of the Java Desktop System are interoperable. Usually, you can
perform the same action in several different ways. For example, you can start
applications from panels, from menus, or from the desktop.

Your system administrator can make configuration changes to suit your needs, so that
the Java Desktop System that you use might not be exactly the same as described in
this chapter. Nevertheless, this chapter provides a useful quick guide to how to work
with the Java Desktop System.
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Main Components
The main components of the Java Desktop System are outlined in the following
sections:

� “GNOME Desktop” on page 29
� “Desktop Applications” on page 30
� “Panel Applications” on page 31
� “Ximian Evolution 1.4” on page 33
� “StarOffice 7” on page 34
� “Mozilla 1.4” on page 36
� “Java Technology” on page 36

GNOME Desktop
The Java Desktop System is based on the GNOME Desktop, which is a free software
desktop developed by a worldwide community.

The most important components of the GNOME Desktop are as follows:

Desktop Functionality Description

File Manager Enables you to do the following:
� Display your files and folders.
� Manage your files and folders.
� Customize your files and folders.
� Open special URL locations.
� Write data to a recordable CD.

Panels Contains application launchers, system menus, panel drawers, and panel
applications.

Window Manager Enables you to manage application windows and dialogs.

Desktop
Applications

A broad range of full-featured desktop applications that enable you to
perform all your usual work activities.

Panel Applications Small applications for specific tasks that reside within panels.
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Desktop Applications
The following table lists the desktop applications in the Java Desktop System.

Category Application Description

Accessories Archive Manager Enables you to create, view, modify, or unpack an archive.

Calculator Multifunctional mathematical and scientific calculator that
includes arithmetic, trigonometric, and logarithmic
functions.

Character Map Unicode character map that provides accented characters,
mathematical symbols, special symbols, and punctuation
marks.

Dictionary Enables you to look up an online dictionary for definitions
and correct spelling of words.

Text Editor A simple text editor that enables you to create and edit text
files.

Games See Java Desktop
System Release 2
Release Notes.

Games applications are not currently supported by Sun
Microsystems.

Graphics Diagram Editor Diagram editor that enables you to create flow charts, maps,
UML diagrams, and many other diagrams.

Image Editor GNU Image Manipulation Program that enables you to edit
images.

Image Organizer Image viewer and browser that displays thumbnails of
images on your desktop.

Image Viewer Enables you to view and save images using standard image
file formats.

PDF Document
Viewer

Enables you to view files in Portable Document Format
(PDF).

PostScript
Viewer

Enables you to view files in PostScript format.

Internet Email and
Calendar

See “Ximian Evolution 1.4” on page 33 for more information.

Instant
Messenger

Enables you to launch a multi-protocol instant messaging
client.

Java Web Start Enables you to start and manage your Java applications.
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Category Application Description

Sun Java System
Instant
Messaging

Launches URLs for the following:
� Register for Java IM Demo
� Run Java IM Demo

Web Browser See “Mozilla 1.4” on page 36 for more information.

Multimedia CD Player Enables you to play audio compact discs on your computer.

Volume Control Enables you to adjust the volume level on your system.

Office Project Manager Project management and scheduling tool.

Office
Applications

See “StarOffice 7” on page 34 for more information.

Note – StarSuite is the default Office application for users in
Japan, China, Korea, and Taiwan. Users in all other countries
have StarOffice as their default Office application.

Programming Interface Editor Glade is a user interface builder for GTK+ and GNOME.

Source Editor General purpose extensible editor for programmers.

Utilities Configuration
Editor

Enables you to directly edit your entire configuration
database.

Disk Analyzer Enables you to visualize your disk.

Online Update Update your system online.

Print Manager Displays printers and documents in the printer queues.

Terminal Enables you to access the command line.

Panel Applications
The following table lists the panel applications of the Java Desktop System.

Category Panel Application Description

Accessories Appointments
and Tasks

A calendar server client to manage your appointments
and tasks.

Clock Displays the time and the date.

Dictionary
Lookup

Enables you to look up an online dictionary for
definitions and correct spelling of words.

Sticky Notes Enables you to create and view small notes on your
desktop.

Stock Ticker Provides continuously updated stock quotes.
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Category Panel Application Description

Weather Report Monitors the current weather conditions and forecasts.

Actions Find Files Opens the Search tool.

Force Quit Stops an application running that does not respond to
your commands.

Lock Locks the screen and activates your screensaver.

Log Out Begins the process to log out of your current session.

Run Opens the Run Application dialog.

Screenshot Enables you to take screenshots.

Show Desktop Minimizes all open windows and displays the desktop.

Amusements Fish Displays an animated image and executes a
user-specified command when you click on the image.

Geyes Displays a pair of eyes that follow the mouse pointer
around the screen.

Internet Inbox Monitor Checks your mail server at regular intervals for new
mail in your mailbox.

WebEyes Enables you to access web search utilities and provides
quick access to websites you previously accessed.

Multimedia CD Player Enables you to play audio compact discs on your
computer.

Volume Control Enables you to control the sound volume on your
system.

Utility Character Palette Provides a convenient way to access non-standard
characters.

Command Line Provides a command line that you can use within any
panel on the desktop.

Input Method
Switcher

Provides a method of switching between software
components that enables you to enter text in ways other
than typing on a keyboard. Input Methods are
commonly used to enter text for languages using
thousands of different characters in keyboards with far
fewer keys.

Keyboard
Accessibility
Status

Shows the status of the keyboard accessibility features.

Keyboard
Indicator

Enables you to indicate different layouts to your
keyboard.
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Category Panel Application Description

Notification Area Displays icons from various applications to indicate
activity in the application. For example, when you use
the CD Player application to play a CD, a CD icon is
displayed in the Notification Area.

Pilot Applet Enables you to configure Palm OS devices.

Quick Lounge Organizes your preferred applications on panels.

Window List Enables you to manage the windows that are open on
your desktop.

Window Selector Displays a list of all visible windows open on your
desktop and enables you to select the one you want to
activate.

Workspace
Switcher

Enables you to switch between workspaces.

Ximian Evolution 1.4
Evolution is an advanced personal information management system that integrates
with email and calendar servers. Evolution contains the following components:

Component Description

Calendar Enables you to schedule appointments.

Contacts Enables you to create an address book of your contacts.

Email Enables you to compose, send, receive, and manage email messages.

Summary Provides an overview of your day. Summary displays an overview of
your email messages, appointments, meetings, and tasks.

Tasks Enables you to manage the work tasks that you perform.

Connectors Enables you to connect to mail and calendar servers.

Evolution includes the following features and benefits:

Feature Benefit

Versatility Evolution manages contact information, appointments and mail, and
integrates this functionality in an integrated package. Evolution acts as
the central point of control for all your communication needs.
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Feature Benefit

Compatibility Evolution supports global mail protocols, such as IMAP4, SMTP, POP3
and LDAP. Evolution also adheres to global standards and file formats,
such as mbox, to facilitate smooth integration into existing environments.

Integration Public interfaces to the core functionality of Evolutioncomponents ensure
easy integration with other applications.

Scalability Evolution can manage large amounts of mail and provides tools to
organize, read, and search through mail in an efficient way.

To Start Evolution
Click Launch, then choose Email and Calendar.

Alternatively, click Launch, then choose Launch → Applications → Internet → Email
and Calendar.

When you start Evolution for the first time, the Evolution Setup Assistant is displayed.
The Evolution Setup Assistant guides you through the initial configuration process for
Evolution. In the initial configuration process, you perform the following actions:

� Enter identity information.

� Create an email account, that is, configure how to receive email, configure how to
send email, and provide a name for the account.

� Select your time zone.

� Import data from other applications.

You can access Help for Evolution from within the Evolution application.

StarOffice 7
The StarOffice suite of Office applications runs on multiple operating systems,
including Linux, Solaris, and Windows. StarOffice contains the following applications:

� Word Processing
� Spreadsheet
� Presentation
� Graphics
� Database Capabilities

StarOffice includes the following features and benefits:
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Feature Benefit

Supports XML file formats You can create, manage, and access complex documents
and web pages.

Intuitive graphical user interface
(GUI)

Familiar interface concepts require minimal retraining.

Built on open standards and
OpenOffice.org open source code

You are not locked into proprietary formats.

To Start StarOffice
You can start StarOffice in the following ways:

� Double-click the StarOffice icon on the desktop background.
� Click Launch, then choose StarOffice 7.
� Click Launch, then choose Launch → Applications → Office.

StarOffice contains sample documents and templates to help you create documents. To
access these templates and documents, choose File → New → Templates and
Documents.

Choose File → AutoPilot to create user-defined templates, for example, for faxes,
presentations or web pages that you can use as a basis for further documents.

You can access Help for StarOffice from within each of the following StarOffice
applications:

Category Application Description

Office StarOffice 7
Presentation

Enables you to create presentations.

StarOffice 7
Spreadsheet

Enables you to create spreadsheets.

StarOffice 7
Text Document

Enables you to create text documents.

To Open a StarOffice File

To open a file previously created by StarOffice, click Launch, then choose StarOffice 7.
From the Templates and Documents — My Documents dialog, highlight the folder
where the file is located. For example, if your file is located in My Documents folder,
click on the My Documents icon and a list of your folders and files is displayed in the
Title pane. Locate the file that you want and double-click on the file.
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Mozilla 1.4
Mozilla is a powerful, cross-platform browser that integrates a wide variety of
features. Mozilla provides enterprise functionality in one powerful application suite
that enables you to do the following:

� Surf the Internet.
� Communicate with colleagues.
� Participate in discussion groups.
� Create dynamic web pages.

Mozilla includes the following features and benefits:

Feature Benefit

Powerful browsing
capabilities

Increases productivity thanks to streamlined and efficient browsing.

Sophisticated
navigation and
filtering

Saves time by managing and directing incoming mail messages to where
you want them to go. Fast and efficient streamlined searches and more
secured privacy.

Advanced
JavaScript controls

Enables you to save and publish web documents created in Composer to
a server of your choice in just a few clicks.

Tabbed browsing You can view multiple websites on tabbed pages within a single browser
window.

To Start Mozilla
Click Launch, then choose Web Browser. Alternatively, click Launch, then choose
Applications → Internet → Web Browser.

You can access Help for Mozilla from within the Mozilla application.

Java Technology
Java technology provides a multi-platform development environment and supports
many platforms, from servers, to cell phones, to smart cards. Java technology unifies
business infrastructure to create a seamless, secure, networked platform for users.

Java includes the following features and benefits:
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Feature Benefit

Mobility and
security

The Java platform provides the foundation for true mobility. Java
technology makes the ideal development and deployment vehicle for
mobile and wireless solutions.

Development
environment

Java facilitates fast development while reducing the number of
time-consuming and costly bugs.

Web services Java and XML languages are two of the most extensible and
widely-accepted computing languages.

Platform
compatibility

Java provides a secure, open, robust, viable, and flexible development
platform that enables you to do the following:
� Reduce costs
� Bring products to market faster
� Benefit from maximum flexibility
� Develop robust applications for consumer devices

Panels
You can add or delete panels at any time. When you start a session for the first time,
the Java Desktop System contains at least one panel.

You can perform the following actions with panels:

� Create panels.
� Delete panels.
� Hide panels.
� Add objects to panels.
� Manipulate panel objects.

To Create Panels
To add a panel, right-click on a vacant space on any panel, then choose New Panel.
The new panel is added to the Java Desktop System. The new panel contains no
objects. You can customize the new panel to suit your preferences. You can add objects
to the panel to fit your own requirements. You can also change the background of the
panel. You can create as many panels as you want.

To Delete Panels
To delete a panel, right-click on the panel then choose Delete This Panel.
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To Hide Panels
Panels can have hide buttons at each end of the panel. You click on the hide buttons to
hide or show the panel.

To Add Objects to Panels
A panel can hold several types of objects. The panel in Figure 2–1 contains each type
of panel object.

FIGURE 2–1 A Panel With Various Panel Objects

You can add any of the following objects to all types of panels:

� Panel application

Panel applications are small, interactive applications that reside within a panel, for
example CD Player in Figure 2–1. Each panel application has a simple user
interface that you can operate with the mouse or keyboard.

To add a panel application to a panel, right-click on a vacant space on the panel,
then choose Add to Panel. Choose the panel application that you require from one
of the following submenus:

� Accessories
� Amusements
� Internet
� Multimedia
� Utility

� Launchers

A launcher starts a particular application, executes a command, or opens a file. The
calculator icon in Figure 2–1 is a launcher for the Calculator application. A launcher
can reside in a panel or in a menu. Click on the launcher to perform the action that
is associated with the launcher.

You can create your own launchers for applications. For example, you can create a
launcher for a word processor application that you use frequently, and place the
launcher in a panel for convenient access. To add a new launcher to a panel,
right-click on a vacant space on the panel, then choose Add to Panel → Launcher.

38 Java Desktop System Release 2 User Guide • July, 2004



Alternatively, to add a launcher from a menu, right-click on a vacant space on the
panel, then choose Add to Panel → Launcher from menu. Choose the launcher to
add from the submenus.

� Action buttons

You can add buttons to your panels to provide quick access to common actions.
You can add the following buttons to your panels:

� Find Files: Use this button to start the Search Tool application, from which you
can search for files.

� Force Quit: Use this button to stop applications that do not respond to your
commands.

� Lock: Click on this button to lock your screen. The lock icon in Figure 2–1 is the
Lock button.

� Log Out: Click on this button to end your session

� Run: Click on this button to open the Run Application dialog, from which you
can run commands.

� Screenshot: Click on this button to take a screenshot of the screen.

� Show Desktop: Click on this button to minimize all windows.

To add a button to a panel, right-click on a vacant space on the panel, then choose
Add to Panel → Actions. You can then choose the button you require.

� Menus

You can access all Java Desktop System functions through menus. To open a menu
from a panel, click on the icon that represents the menu. To open a menu from the
Menu Bar, click on the text that represents the menu.

Menus that you add to your panels are represented by an icon with an arrow. The
arrow indicates that the icon represents a menu. For example, see the menu icon in
Figure 2–1.

You can add a Launch button to any of your panels. To add a Launch button to a
panel, right-click on a vacant space on the panel, then choose Add to Panel → Main
Menu.

You can also add the Menu Bar to any of your panels. To add the Menu Bar to a
panel, right-click on a vacant space on the panel, then choose Add to Panel →
Menu Bar.

� Drawers

Drawers are sliding extensions to a panel that you can open or close from a drawer
icon, as shown in Figure 2–1. Drawers can help you to organize your work when
you run a lot of applications simultaneously. You can place all the same functional
elements in a drawer that you can put in any other type of panel.

To add a drawer to a panel, right-click on a vacant space on the panel, then choose
Add to Panel → Drawer.

To open a drawer click on the drawer. To close a drawer click on the drawer again.
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To Manipulate Panel Objects
You can manipulate panel objects in the following ways:

� Move objects within a panel, or to another panel.

You can move any object to another location in the panel. You can also move an
object from one panel to another panel. Use the middle mouse button to drag the
panel object to the new location.

� Copy menu items to a panel.

Drag the item from the menu to the panel. Alternatively, if the menu item is a
launcher right-click on the menu item, then choose Add this launcher to panel.

Menus
You can access all Java Desktop System functions through menus. You can access your
menus from the following Java Desktop System components:

� Launch

The Java Desktop System main menu is represented by a Launch button as follows:

The Launch button provides access to the Applications menu, and various other
functions. You can use the Applications menu to access almost all of the standard
applications, commands, and configuration options.

To add a Launch button to a panel, right-click on the panel, then choose Add to
Panel → Main Menu. Click on the Launch button on a panel to open the Java
Desktop System main menu.

� Menu Bar

Menu Bar contains Applications and Actions menus. You can use the Applications
menu and the Actions menu to access almost all of the standard applications,
commands, and configuration options.

To add Menu Bar to a panel, right-click on the panel then choose Add to Panel →
Menu Bar.

� Panels

You can add as many additional menus as you want to any of your panels. To open
a menu that you add to a panel, click on the menu icon on the panel. You can
perform other actions on your menus, such as copy menu items to panels.
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Windows
You can display many windows at the same time in the Java Desktop System. Each
window has a frame. The window frame contains active control elements that you can
use to work with the window.

Types of Windows
The Java Desktop System features the following types of window:

� Application windows

When you run an application, a frame usually borders the window. The top edge
of the application window contains a titlebar. The titlebar contains buttons that you
can use to work with the window. The buttons in an application window frame
enable you to perform actions such as open the Window Menu, or close the
window. The Window Menu provides commands that you can perform on the
window.

� Dialog windows

Dialog windows are associated with interactive processes. A dialog window
consists of the window frame, and a single interactive pane that provides
information and controls for the user. This manual refers to the interactive part of a
dialog window as a dialog. The frame of a dialog window contains buttons that
enable you to open the Window Menu, or to close the dialog window.

To Manipulate Windows
You use the frame of an application window or dialog window to perform various
actions with the window. Most of the control elements are located on the top edge of
the window frame. Figure 2–2 shows the top edge of a frame for a typical application
window.
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FIGURE 2–2 Top Edge of Frame for a Typical Application Window

The active control elements of the window frame are as follows:

Control Element Description

Window Menu button Click on the Window Menu button to open the
Window Menu.

Titlebar You can use the titlebar to move and shade the
window.

Minimize button Click on the Minimize button to minimize the
window.

Maximize button You can use the Maximize button to maximize and
restore the window.

To maximize a window click on the Maximize button.
To restore the window click on the Maximize button
again.

Close Window button Click on the Close Window button to close the
window.

Border Right-click on the border to open the Window Menu.

To change the size of windows grab the border of the window, but not the titlebar.
Drag the border until the window is the size that you require.

To Give Focus to a Window
A window that has focus can receive input from the mouse and the keyboard. Only
one window can have focus at a time. The window that has focus has a different
appearance than other windows.

You can use the following elements to give focus to a window:
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Element Action

Mouse Click on the window, if the window is visible.

Shortcut keys Use shortcut keys to switch between the windows that are
open. To give focus to a window, release the keys. The default
shortcut keys to switch between windows are Alt + Tab.

Window List Click on the button that represents the window in Window
List.

Workspace Switcher Click on the window that you want to give focus to in the
Workspace Switcher display.

Workspaces
Your windows are displayed in subdivisions of the desktop that are called
workspaces. Every workspace contains the same desktop, the same panels, and the
same menus. However, you can run different applications, and open different
windows in each workspace. You can display only one workspace at a time on the
desktop but you can have windows open in other workspaces.

Workspaces enable you to organize the desktop when you run many applications at
the same time. When your current workspace becomes crowded with windows, you
can move your work to another workspace. You can also switch to another workspace
to start more applications.

Workspaces are displayed in the Workspace Switcher panel application. In Figure 2–3,
Workspace Switcher contains four workspaces. The first three workspaces contain
open windows. The last workspace does not contain currently active windows.

FIGURE 2–3 Workspaces Displayed in Workspace Switcher

To Switch Between Workspaces
You can switch between workspaces in the following ways:

� In Workspace Switcher, click on the workspace where you want to work.

� Press Ctrl + Alt + right arrow to switch to the workspace on the right of the current
workspace.
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� Press Ctrl + Alt + left arrow to switch to the workspace on the left of the current
workspace.

To Add Workspaces
To add workspaces to your desktop, right-click on the Workspace Switcher panel
application, then choose Preferences. The Workspace Switcher Preferences dialog is
displayed. Use the Number of workspaces spin box to specify the number of
workspaces that you require.

File Manager
The file manager provides an integrated access point to your files, applications, FTP
sites, and URIs. To open a file manager window, double-click on the Documents
object.

The file manager enables you to do the following:

� Browse your files and folders

You can also use file browser windows to browse your files and folders. When you
open a file or folder in a file browser window, the file or folder opens in the
window.

File browser windows can contain the following panes:

Side pane Enables you to navigate through your files. This pane also displays
information about the current file or folder. The side pane is on the
left side of the file browser window.

View pane Displays the contents of files and folders. The view pane is on the
right side of the file manager window.

� View files and folders

You can view your files and folders as icons or as a list. You can view the contents
of some types of file within a file manager window.

� Manage your files and folders

You can use the file manager to create, move, copy, rename, and remove files and
folders.

� Customize your files and folders

You can add emblems to your files and folders to indicate particular states. For
example, you can add an Important emblem to a file to indicate that the file is
important. You can also customize folders in the following ways:
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� Add a note to a folder.
� Specify a custom background or pattern for a folder.
� Specify a zoom setting for a folder.

� Open special Uniform Resource Identifiers (URIs)

The Java Desktop System contains special URIs that enable you to access particular
functions from the file manager. For example, to access the preference tools, you
can access the preferences:/// URI in the file manager.

� Write CDs

The file manager provides a special location where you can copy files and folders
that you want to write to a CD. You can write the contents of the location to a CD
easily.

The file manager also creates the desktop background.

To Move Files Between Folders
You can move files between folders by opening two or more file manager windows.
Open a different folder in each window, then drag the files from one window to the
other.

Desktop Background
The desktop background is an active component of the user interface. You can use the
desktop background to perform the following actions:

� Start your applications, and open your files and folders.

You can add desktop objects for convenient access to the files, folders, and
applications that you use frequently. For example, you add a launcher for an
application that you use often.

� Open the Desktop menu.

Right-click on the desktop background to open the Desktop menu. You can use the
Desktop menu to perform actions on the desktop background.
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To Open Desktop Background Objects
To open an object from the desktop background, double-click on the object. You can
set your preferences in a File Manager window so that you click once on an object to
execute the default action.

To Add Objects to the Desktop Background
You can add desktop objects for convenient access to files, folders, and applications
that you use frequently. You can add objects to your desktop background in the
following ways:

� Use the Desktop menu to add a launcher to the desktop background.

� Drag an object from a file manager window to the desktop background. For
example, you can create a symbolic link to a file that you use often, then drag the
link to your desktop background. The icon for the link is moved to the desktop
background. To open the file, double-click on the icon. You can also drag files and
folders to the desktop background.

� Drag an application launcher from a menu to the desktop background. For
example, you can open a menu that contains a launcher for an application that you
use often, then drag the launcher to your desktop background.

This Computer Location

The This Computer location enables you to access the following functions:

� File System

Double-click on File System to access your system files and folders.

� Applications

Double-click on Applications to access your key applications. You can also access
the Applications menu through the Menu Bar and the Launch button.

� Desktop Preferences

Double-click on Preferences to customize the Java Desktop System.
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� Programs that enable you to configure your system as a server, and to modify other
system configuration details.

You can access the This Computer location in the following ways:

� From the desktop background

Double-click on the This Computer object on the desktop background. The
contents of the This Computer location are displayed in a file browser window.

� From the Launch button

Click Launch, then choose This Computer. The contents of the This Computer
location are displayed in a file browser window.

� From a file browser window

Access the computer:/// URI in a file browser window. The contents of the This
Computer location are displayed in the window.

Desktop Preferences
You can use preference tools to configure almost every feature of the Java Desktop
System. Each tool controls a particular part of the behavior of the Java Desktop
System. For example, you can use a preference tool to select a theme for the Java
Desktop System. A theme is a group of coordinated settings that specify the visual
appearance of a part of your interface.

You can start your preference tools in either of the following ways:

� Click Launch, then choose Preferences. Choose the item that you want from the
submenus.

� Double-click on the This Computer object on the desktop. A file browser window
opens at the This Computer location. Double-click on the Preferences object to
display the preference tools. Double-click on the item that you require.
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Desktop Applications
The applications that are provided with the Java Desktop System share several
characteristics because the applications use the same programming libraries. An
application that uses the standard GNOME programming libraries is called a
GNOME-compliant application. For example, the Nautilus file manager and the gedit
text editor are GNOME-compliant applications.

GNOME provides libraries in addition to the libraries provided by your operating
system. The libraries enable GNOME to run your existing applications as well as
GNOME-compliant applications. For example, if your operating system is
UNIX-based, you can run your current X11 applications and Motif applications from
the Java Desktop System.

Some of the features of GNOME-compliant applications are as follows:

� Consistent look-and-feel

GNOME-compliant applications have a consistent look-and-feel.
GNOME-compliant applications use the look-and-feel settings that you specify in
the preference tools. You can use the following tools to change the look-and-feel of
your GNOME-compliant applications:

� Menus & Toolbars preference tool
� Theme preference tool

� Menubars, toolbars, and statusbars

Most GNOME-compliant applications have a menubar, a toolbar, and a statusbar.
The menubar always contains a File menu and a Help menu. The File menu always
contains a Quit menu item, and the Help menu always contains an About menu
item.

A toolbar is a bar that appears under the menubar. A toolbar contains buttons for
the most commonly-used commands. A statusbar is a bar at the bottom of a
window that provides information about the current state of what you are viewing
in the window. GNOME-compliant applications might also contains other bars. For
example, the File Browser window contains a location bar.

Some of the bars in GNOME-compliant applications are detachable. That is, the bar
has a handle that you can grab then drag the bar to another location. You can drag
the bar to snap to another side of the window, or to another part of the screen. For
example, you can detach the menubar, toolbar, and location bar in the file manager.

� Default shortcut keys

GNOME-compliant applications use the same shortcut keys to perform the same
actions. For example, to quit a GNOME-compliant application, press Ctrl + Q. To
undo an action in a GNOME-compliant application, press Ctrl + Z.

� Drag-and-drop
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GNOME-compliant applications use the same protocol to implement
drag-and-drop operations. Therefore, GNOME-compliant applications provide
consistent feedback when you drag-and-drop items.

The use of the same protocol also enables GNOME-compliant applications to
interoperate in a sophisticated manner. For example, GNOME-compliant
applications recognize the format of the items that you drag. When you drag a
HTML file from a File Manager window to a web browser, the file is displayed in
HTML format in the browser. However, when you drag the HTML file to a text
editor, the file is displayed in plain text format in the text editor.

To Find Out More
The Java Desktop System provides help if you want to find out more about the
following areas:

� Java Desktop System topics
� Panel Applications
� Desktop Applications

To Find Out More About Java Desktop System
Topics
You can find out more about particular Java Desktop System topics in the integrated
help system. To start the help system, click Launch, then choose Help.

To Find Out More About Panel Applications
To find out more about a specific panel application, right-click on the panel
application, then choose Help.

To Find Out More About Desktop Applications
To find out more about a specific desktop application, start the desktop application,
then choose Help → Contents. Alternatively, start the desktop application, then press
F1.
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CHAPTER 3

Working With Panels

The information in this chapter describes how to use panels. A panel is an area in the
Java Desktop System from which you can run applications and perform other tasks.

Introducing Panels
When you start a session for the first time, the Java Desktop System contains at least
one panel. Your system administrator might have set your default panels according to
your local requirements, so you might see slightly different default panels.

You can change the behavior and appearance of your panels to suit your requirements.
You can also add or remove objects from your panels. You can create multiple panels,
and choose different properties, objects, and backgrounds for each panel. You can also
hide panels.

Typically, the Java Desktop System contains a preconfigured panel displayed at the
bottom edge of the screen.

Bottom Edge Panel
The bottom edge panel contains the following items:

Object Description

Launch The Launch button contains menus and menu items for
applications and configuration tools on the Java Desktop System.
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Object Description

Clock Displays the time and date in a panel.

Show Desktop Displays a button that you can click to minimize all open
windows.

Window List Displays a button for each window that is open. You can click on
a window list button to minimize and restore windows.

Notification Area Displays icons from various applications to indicate activity in
the application.

Workspace Switcher Displays a visual representation of your workspaces. You can use
Workspace Switcher to switch between workspaces.

Volume Control Displays a button that enables you to control and set the sound
level for your system.

Network Monitor Displays the status of a network device.

Input Method Switcher Displays a button to provides integral and multilingual input
method capabilities.

Managing Your Panels
The following sections describe how to manage your panels.

To Add a New Panel
To add a panel, right-click on a vacant space on any panel, then choose New Panel.
The new panel is added to the Java Desktop System. The new panel contains no
objects. You can customize the new panel to suit your preferences.

To Interact With a Panel
To interact with a panel, you must left-click, middle-click, or right-click on a vacant
space on the panel. You can also middle-click or right-click on one of the hide buttons
to select the panel, if the panel has no vacant space. If the hide buttons are not visible
on a panel, modify the properties of the panel so that the hide buttons are visible.

You use the mouse buttons to interact with a panel in the following ways:

Middle-click Enables you to grab a panel, then drag the panel to a new location.
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Right-click Opens the panel popup menu.

To Move a Panel
You can move panels to different locations. To move a panel, middle-click and hold on
any vacant space on the panel, then drag the panel to the new location.

To Hide a Panel
You can hide or show panels. To hide a panel, use a hide button. If the hide buttons
are not visible on a panel, modify the panel properties so that the hide buttons are
visible.

Hide buttons are at either end of a panel. The hide buttons contain an optional arrow
icon. The following illustration shows hide buttons.

To hide a panel, click on one of the hide buttons. The panel reduces in the direction of
the arrow on the hide button. The hide button at the other end of the panel remains
visible.

To show a hidden panel again, click on the visible hide button. The panel expands in
the direction of the arrow on the hide button. Both hide buttons are now visible.

You can set a panel to autohide. When you set autohide, the panel hides automatically
when the mouse is not pointing to the panel. The panel reappears when you point to
the part of the screen where the panel resides. To set your panel to autohide, modify
the properties of the panel.

To Modify Panel Properties
To modify preferences for all panels, use the Panel preference tool to make the
changes that you require. For example, you can modify animation preferences for
panels.
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You can also modify properties for each individual panel. You can change the features
for each panel, such as the position of the panel, the hide behavior, and the visual
appearance.

To modify the properties of a panel perform the following steps:

1. Right-click on a vacant space on the panel, then choose Properties to display the
Panel Properties dialog. The Panel Properties dialog contains the following tabbed
sections:

� General
� Background

2. To modify panel size, position, and hiding properties, click on the General tab. The
following table describes the dialog elements on the General tabbed section:

Dialog Element Description

Name Type a name for the panel. When you use shortcut keys to
switch between your panels and the desktop, this panel name is
displayed.

Orientation Select the position of the panel on your screen. Click on the
required position for the panel.

Size Use the spin box to specify the size of the panel.

Expand Select this option if you want the panel to expand to the full
length of the edge of the screen where the panel is located.

Autohide Select this option to enable autohide.

Show hide buttons Select this option to display hide buttons on your panel.

Arrows on hide button Select this option to display arrows on the hide buttons, if the
hide button is enabled.

3. To modify the panel background, click on the Background tab. Choose the type of
background for the panel. The choices are as follows:

Dialog Element Description

None (use system theme) Select this option to use the default panel background. The
default panel background depends on the settings in the
Theme preference tool.
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Dialog Element Description

Solid color Select this option to specify a single color for the panel
background. Click on the Color button to display the color
selector dialog. Choose the color that you require from the
color selector dialog.

Use the Style slider to specify the degree of transparency or
opaqueness for the color. For example, to make the panel
transparent, move the slider towards the Transparent end.

Background image Select this option to specify an image for the panel
background. Enter the filename of the image to use in the
drop-down combination box. Alternatively, to browse for the
file, click on the Browse button. When you have selected the
file, click OK.

You can also drag a color or image on to a panel to set the color or image as the
background of the panel. For more information, see “To Drag a Color or Image to
the Background of a Panel” on page 55.

4. Click Close to close the Panel Properties dialog.

To Drag a Color or Image to the Background of a Panel
You can drag a color or image on to a panel to set the color or image as the
background of the panel. You can drag a color or image from many applications. For
example, you can drag a color from the file manager to a panel to set the color as the
background of the panel. You can also drag a color from any color selector dialog.

You can drag an image to a panel to set the image as the background of the panel. You
can also drag pattern images from the file manager to set the background of the panel.

To Delete a Panel
To delete a panel from the Java Desktop System, right-click on the panel that you want
to delete, then choose Delete This Panel.

Note – You must always have at least one panel in the Java Desktop System. If you
have only one panel in the Java Desktop System, you cannot delete that panel.
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Panel Objects
This section describes the objects that you can add to your panels, and use from your
panels.

Interacting With Panel Objects
You use the mouse buttons to interact with a panel object in the following ways:

Left-click Launches the panel object.

Middle-click Enables you to grab an object, then drag the object to a new location.

Right-click Opens the panel object popup menu.

You interact with panel objects in a different way. For more information, see “To Select
a Panel Application” on page 59.

To Add an Object to a Panel
You can add an object to a panel in several ways, as follows:

� From the panel popup menu

Right-click on a vacant space on a panel to open the panel popup menu. The panel
popup menu contains an Add to Panel submenu. The Add to Panel submenu
enables you to add the following objects to your panels:

� Panel applications in the following categories: Accessories, Amusements,
Internet, Multimedia, Utility.

� Buttons for quick access to common actions: Find Files button, Force Quit
button, Lock Screen button, Log Out button, Run Applications button,
Screenshot button, Show Desktop button.

� Launchers

� Launchers from menus

� Main Menu

� Menu Bar

� Drawers

� From any menu

When you right-click on a launcher in any menu, a popup menu for the launcher
opens. You can use this popup menu to add the launcher to a panel.

You can also drag menus, launchers, and panel applications from menus to panels.
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� From the file manager

Each launcher corresponds to a .desktop file. You can drag the .desktop file on
to your panels to add the launcher to the panel.

To Modify the Properties of an Object
Some panel objects, such as launchers and drawers, have a set of associated properties.
The properties are different for each type of object. The properties specify details such
as the following:

� The command that starts an application.
� The location of the source files for a menu.
� The icon that represents the object.

To modify the properties of an object perform the following steps:

1. Right-click on the object to open the panel object popup menu, as shown in Figure
3–1.

FIGURE 3–1 Panel Object Popup Menu

2. Choose Properties. Use the Properties dialog to modify the properties as required.
The properties in the Properties dialog depend on which object you select in step 1.

3. Click OK to apply the changes, then close the Properties dialog.

To Move a Panel Object
You can move panel objects within a panel, and from one panel to another panel. You
can also move objects between panels and drawers.

To move a panel object, middle-click and hold on the object and drag the object to a
new location. When you release the middle mouse button, the object anchors at the
new location.

Alternatively, you can use the panel object popup menu to move an object, as follows:

1. Right-click on the object, then choose Move.
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2. Point to the new location for the object, then click any mouse button to anchor the
object to the new location. This location can be on any panel that is currently in the
Java Desktop System.

Movement of a panel object affects the position of other objects on the panel. To
control how objects move on a panel, you can specify a movement mode. To specify
the movement mode, press one of the following keys as you move the panel object:

Key Movement Mode Description

No key Switched movement The object swaps places with other panel objects.
Switched movement is the default movement
mode.

Alt key Free movement The object jumps over other panel objects into the
next vacant space on the panel.

Shift key Push movement The object pushes other panel objects further
along the panel.

To Lock a Panel Object
You can lock panel objects so that the objects stay in the same position on the panel.
This feature is useful if you do not want some panel objects to change position when
you move other panel objects.

To lock an object to the current location of the object in the panel, right-click on the
object to open the panel object popup menu, then choose Lock. To unlock the object,
right-click on the object, then choose Unlock.

To Remove a Panel Object
To remove an object from a panel right-click on the object to open the panel object
popup menu, then choose Remove From Panel.

Panel Applications
A panel application is a small application whose user interface resides within a panel.
For example, the following figure shows the following panel applications, from left to
right:

� Window List: Displays the windows currently open on your system.
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� CD Player: Enables you to control the compact disc player on your system.

� Volume Control: Enables you to control the volume of the speaker on your system.

To Add an Application to a Panel
You can add an application to a panel from the panel popup menu. Right-click on any
vacant space on the panel to open the panel popup menu. Choose Add to Panel, then
choose the panel application that you want to add from one of the following
submenus:

� Accessories
� Amusements
� Internet
� Multimedia
� Utility

Alternatively, drag the panel application from the submenu on to the panel.

To Select a Panel Application
To modify the properties of a panel application, you must first right-click on the panel
application to display the panel object popup menu. To move a panel application, you
must middle-click on the panel application.

Some restrictions apply on where you can click on a panel application in order to
display the panel object popup menu, or to move the panel application, as follows:

� Some panel applications have popup menus of panel application-specific
commands that open when you right-click on particular parts of the panel
application. For example, the Window List panel application has a vertical handle
on the left side, and buttons that represent your windows on the right side. To
open the panel object popup menu for the Window List panel application, you
must right-click on the handle. If you right-click on a button on the right side, a
popup menu for the button opens.

� Some panel applications have areas that you cannot use to select the panel
application. For example, the Command Line application has a field in which you
enter commands. You cannot middle-click or right-click on this field to select the
panel application. Instead, middle-click or right-click on another part of the panel
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application.

To Modify Preferences for a Panel Application
To modify the preferences for a panel application perform the following steps:

1. Right-click on the panel application, then choose Preferences. Use the Preferences
dialog to modify the preferences as required. The preferences for panel applications
vary depending on the panel application.

2. Click Close to close the Preferences dialog.

Launchers
When you click on a launcher, you initiate one of the following actions:

� Start a particular application.

� Execute a command.

� Open a folder in a file manager window.

� Open a browser at a particular Uniform Resource Locator (URL). A URL is the
address of a particular location on the Web.

� Open special Uniform Resource Identifiers (URIs). The Java Desktop System contains
special URIs that enable you to access particular functions from the file manager.

You can find launchers in the following places in the Java Desktop System:

� Panels: On panels, launchers are represented by icons.

� Menus: On menus, launchers are represented by menu items. The menu items
usually have an icon beside the menu item.

� Desktop: On the desktop, launchers are represented by icons.

You can modify the properties of a launcher. For example, the properties of a launcher
include the name of the launcher, the icon that represents the launcher, and how the
launcher runs.

To Add a Launcher to a Panel
You can add a launcher to a panel in one of the following ways:

� From the panel popup menu
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To create a new launcher, right-click on any vacant space on the panel, then choose
Add to Panel → Launcher. A Create Launcher dialog is displayed. For more
information on how to complete this dialog, see “To Create a Launcher With the
Create Launcher Dialog” on page 61.

Alternatively, to add an existing launcher to the panel, choose Add to Panel →
Launcher from menu from the panel popup menu. Choose the launcher that you
want to add from the menu.

� From any menu

To add a launcher to a panel from any menu, perform one of the following steps:

� Open a menu that contains the launcher. Drag the launcher on to the panel.

� Open the menu that contains the launcher from the panel where you want the
launcher to reside. Right-click on the title of the launcher. Choose Add this
launcher to panel.

� From the file manager

To add a launcher to a panel from the file manager, find the .desktop file for the
launcher in your file system. To add the launcher, drag the .desktop file to the
panel.

To Create a Launcher With the Create Launcher Dialog
To create a launcher with the Create Launcher dialog perform the following steps:

1. Right-click on any part of a panel to open the panel popup menu. Choose Add to
Panel → Launcher to display the Create Launcher dialog.

2. Enter the properties of the launcher in the Basic tabbed section. The following table
describes the dialog elements on the Basic tabbed section:

Dialog Element Description

Name Use this text box to specify the name of the launcher. You can use
the Advanced tab to add translations of the name. This name is
the name that appears when you add the launcher to a menu or to
the desktop.

Generic name Use this text box to specify the class of application to which the
launcher belongs. For example, you might type Text Editor in
this text box for a gedit launcher. You can use the Advanced tab to
add translations of the generic name.

Comment Use this text box to specify a short description of the launcher.
The comment is displayed as a tooltip when you point to the
launcher icon on the panel. You can use the Advanced tabbed
section to add translations of the comment.
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Dialog Element Description

Command Use this field to specify a command to execute when you click on
the launcher. For sample commands, see the next section.

Type Use this drop-down combination box to specify the type of
launcher. Select from the following:
� Application: Select this option to create a launcher that starts

an application.
� Link: Select this option to create a launcher that links to a URI.

Icon Choose an icon to represent the launcher. To choose an icon, click
on the No Icon button. An icon selector dialog is displayed.
Choose an icon from the dialog. Alternatively, to choose an icon
from another directory, click Browse. When you choose an icon,
click OK.

Run in Terminal Select this option to run the application or command in a terminal
window. Choose this option for an application or command that
does not create a window in which to run.

3. To set advanced properties for the launcher, click on the Advanced tab.

4. Enter the advanced properties of the launcher in the Advanced tabbed section. The
following table describes the dialog elements on the top part of the Advanced
tabbed section:

Dialog Element Description

Try this before using Enter a command here to check before starting the launcher.
If the command is executable and is in your path, the
launcher appears on the panel.

Documentation Enter the path to the help file for the launcher. If you enter a
path in this field, a Help on launcher-name Application menu
item is displayed on the popup menu for the launcher.

5. You can also add a translation of the Name, Generic name, and Comment fields
from the Basic tabbed section. To add a translation, enter the details of the
translation in the Name/Comment translations table as follows:

Field Description

First field Enter the two-letter code for the language for which you want to add a
translation.

Second field Enter the translation of the Name of the launcher.

Third field Enter the translation of the Generic name of the launcher.
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Field Description

Fourth field Enter the translation for the Comment for the launcher.

Then click on the Add/Set button.

To edit a translation, select the translation. The translated text appears in the lower
part of this dialog. Edit the fields as required, then click on the Add/Set button.

To remove a translation, select the translation, then click on the Remove button.

6. To create the launcher and close the Launcher Properties dialog, click OK.

Launcher Commands
The type of commands that you can enter in the Command field depend on the option
that you choose from the Type drop-down combination box. If you choose
Application from the Type drop-down combination box, you can enter a normal
command. The following table shows some sample commands and the actions that the
commands perform:

Sample Application Command Action

gedit Starts the gedit text editor application.

gedit /user123/loremipsum.txt Opens the file /user123/loremipsum.txt in
the gedit text editor application.

nautilus /user123/Projects Opens the folder /user123/Projects in a file
manager window.

If you choose Link from the Type drop-down combination box, you can enter a link
command. The following table shows some sample link commands and the actions
that the commands perform:

Sample Link Command Action

http://www.sun.com Opens the Sun Microsystems website in your
default browser.

ftp://ftp.gnome.org Opens the GNOME FTP site in your default
browser.

applications:/// Opens the Applications location in a file
manager window. Double-click on an
application to start the application.
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Sample Link Command Action

preferences:/// Opens the Preferences location in a file manager
window. Double-click on a preference tool to
start the preference tool.

To Modify the Properties of a Launcher
To modify the properties of a launcher perform the following steps:

1. Right-click on the launcher to open the panel object popup menu.

2. Choose Properties. Use the Launcher Properties dialog to modify the properties as
required. For more information on the Launcher Properties dialog, see “To Create
a Launcher With the Create Launcher Dialog” on page 61.

3. Click Close to close the Launcher Properties dialog.

Buttons
You can add buttons to your panels to provide quick access to common actions and
functions.

Find Files Button
You can use the Find Files button to open the Search for Files dialog.

To add a Find Files button to a panel, right-click on any vacant space on the panel.
Choose Add to Panel → Actions → Find Files. To open the Search for Files dialog, click
on the Find Files button.

Force Quit Button
The Force Quit button enables you to select a window to terminate an application.
This button is useful if you want to terminate an application that does not respond to
your commands.

To terminate an application, click on the Force Quit button, then click on a window
from the application that you want to terminate. If you do not want to terminate an
application after you click on the Force Quit button, press Esc.
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Lock Screen Button
The Lock Screen button locks your screen and activates your screensaver. To access
your session again, you must enter your password. To lock your screen correctly, you
must have a screensaver enabled.

To add a Lock Screen button to a panel, right-click on any vacant space on the panel.
Choose Add to Panel → Actions → Lock Screen.

Right-click on the Lock Screen button to open a menu of screensaver-related
commands. Table 3–1 describes the commands that are available from the menu.

TABLE 3–1 Lock Screen Menu Items

Menu Item Function

Activate Screensaver Activates the screensaver immediately, but does not
lock the screen.

Lock Screen Locks the screen immediately. This command
performs the same function as when you click on the
Lock button.

Kill Screensaver Daemon Terminates the screensaver process. After you
terminate the screensaver process, you cannot lock
your screen.

Restart Screensaver Daemon Terminates and restarts the screensaver process. Use
this command after you change your password.
When you restart the screensaver process, use your
new password with the screensaver.

Properties Displays the XScreenSaver preference tool.

Log Out Button
The Log Out button begins the process to log out of a Java Desktop System session.

To add a Log Out button to a panel, right-click on any vacant space on the panel.
Choose Add to Panel → Actions → Log Out. To log out of your session or shut down
your system, click on the Log Out button.

Run Applications Button
You can use the Run Applications button to open the Run Application dialog.

To add a Run Applications button to a panel, right-click on any vacant space on the
panel. Choose Add to Panel → Actions → Run Applications. To open the Run
Application dialog, click on the Run Applications button.
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Screenshot Button
You can use the Screenshot button to take a screenshot of your screen.

To add a Screenshot button to a panel, right-click on any vacant space on the panel.
Choose Add to Panel → Actions → Screenshot. To take a screenshot of your screen,
click on the Screenshot button.

Show Desktop Button
You can use the Show Desktop button to minimize all open windows and show the
desktop.

To add a Show Desktop button to a panel, right-click on any vacant space on the
panel. Choose Add to Panel → Actions → Show Desktop. To minimize all windows
and show the desktop, click on the Show Desktop button.

Notification Area
The Notification Area displays icons from various applications to indicate activity in
the application. For example, when you use the CD Player application to play a CD, a
CD icon is displayed in the Notification Area. The graphic above illustrates the CD
icon in the Notification Area.

To add a Notification Area to a panel, right-click on any vacant space on the panel.
Choose Add to Panel → Utility → Notification Area.

Menus
You can add the following types of menu to your panels:

� Launch: You can access almost all of the standard applications, commands, and
configuration options from the Launch button. To add a Launch button to a panel,
right-click on any vacant space on the panel, then choose Add to Panel → Main
Menu. You can add as many Launch buttons to your panels as you want.

� Menu Bar: You can access almost all of the standard applications, commands, and
configuration options from the menus in the Menu Bar. The Menu Bar contains the
Applications menu and the Actions menu. To add a Menu Bar to a panel,
right-click on any vacant space on the panel, then choose Add to Panel → Menu
Bar. You can add as many Menu Bar objects to your panels as you want.
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� System menus: System menus contain the standard applications and tools that you
can use in the Java Desktop System. The Applications menu and Actions menu are
system menus. To add a system menu to a panel, right-click on a launcher in the
menu, then choose Entire menu → Add this as menu to panel.

Menus that you add to your panels are represented by an icon with an arrow. The
arrow indicates that the icon represents a menu or drawer. Figure 3–2 shows how
menus typically appear on panels.

FIGURE 3–2 Typical Menu Objects on a Panel

Drawers
A drawer is an extension of a panel. You can open and close a drawer in the same way
that you can show and hide a panel. A drawer can contain all panel objects, including
launchers, menus, other panel objects, and other drawers. When you open a drawer,
you can use the objects in the same way that you use objects on a panel.

The following figure shows an open drawer that contains two panel objects.

The arrow on the drawer icon indicates that the icon represents a drawer or menu.

You can add, move, and remove objects from drawers in the same way that you add,
move, and remove objects from panels.
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To Open and Close a Drawer
To open a drawer, click on the drawer object in a panel. You can close a drawer in the
following ways:

� Click on the drawer.
� Click on the drawer hide button.

To Add a Drawer to a Panel
You can add a drawer to a panel in the following ways:

� From the panel popup menu

Right-click on any vacant space on the panel, then choose Add to Panel → Drawer.

� From any menu

You can add a menu as a drawer object to a panel.

To add a menu as a drawer to a panel, open the menu from the panel. Right-click
on any launcher in the menu, then choose Entire menu → Add this as drawer to
panel.

To Add an Object to a Drawer
You add an object to a drawer in the same way that you add objects to panels. For
more information, see “To Add an Object to a Panel” on page 56.

To Modify Drawer Properties
To modify preferences for all panels and drawers, use the Panel preference tool. For
example, you can select various options related to the appearance and behavior of
objects on panels and drawers. You can also select options that relate to drawers only.
For example, you can select an option to close your drawers when you click on a
launcher in the drawer.

You can also modify other properties for each individual drawer. You can change
features for each drawer, such as the visual appearance of the drawer and whether the
drawer has hide buttons.

To modify properties for a drawer perform the following steps:

1. Right-click on the drawer, then choose Properties to display the Panel Properties
dialog. The dialog displays the General tabbed section.

2. Select the properties for the drawer in the dialog. The following table describes the
elements on the General tabbed section:
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Dialog Element Description

Name Type a name for the panel. When you use shortcut keys to
switch between your panels and the desktop, this panel name is
displayed.

Size Select the size of the panel.

Icon Choose an icon to represent the drawer. Click on the Icon button
to display an icon selector dialog. Choose an icon from the
dialog. Alternatively, click Browse to choose an icon from
another directory. When you choose an icon, click OK.

Show hide buttons Select this option to display hide buttons on your panel.

Arrows on hide button Select this option to display arrows on the hide buttons, if the
hide button is enabled.

3. You can use the Background tabbed section to set the background for the drawer.
For information on how to complete the Background tabbed section, see the step
on this topic in “To Modify Panel Properties” on page 53. You can also drag a color
or image on to a drawer to set the color or image as the background of the drawer.
For more information, see “To Drag a Color or Image to the Background of a
Panel” on page 55.

4. Click Close to close the Panel Properties dialog.

Chapter 3 • Working With Panels 69



70 Java Desktop System Release 2 User Guide • July, 2004



CHAPTER 4

Working With Menus

This chapter describes how to use menus in the Java Desktop System.

Introduction to Menus
You can access all Java Desktop System functions through menus. You can add menus
to panels and you can use a combination of menus and panels to perform your tasks.
You can perform various actions on your menus, such as copy menu items to panels.

You can access the following menus in the Java Desktop System:

� Launch button: You can access the items in the Applications menu from the Launch
button. You can have many Launch buttons in your panels.

� Menu Bar: You can access the items in the Applications and Actions menus from
Menu Bar. You can have many Menu Bar panel applications in your panels.

� Applications menu: You can access many of your applications, commands, and
configuration options from the Applications menu.

� Actions menu: You can access commands that enable you to perform various tasks
from the Actions menu. For example, you can start the Search Tool application, or
log out of the Java Desktop System.

You can also right-click on the desktop to open the Desktop menu. The Desktop menu
enables you to perform desktop-related tasks.

All of these menus provide you with multiple ways to perform your tasks, and enable
you to work in the way that you prefer.
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Menu Features
Menus can contain the following items:

� Submenus
� Launchers or menu items

An arrow to the right of an item in a menu indicates that the item is a submenu. When
you point to the submenu, the submenu opens. You can choose items from the
submenu.

When you choose a launcher, the launcher starts an application or runs a command.
You can also right-click on a launcher to open a popup menu. The popup menu
enables you to add the item to a panel, and perform other tasks. For more information
on the popup menu, see the next section.

You can change the theme for your session to change how all your menus look. To
change the theme, use the Theme preference tool.

Menu Item Popup Menu
Items in menus have an associated popup menu that enables you to perform tasks
related to the item. When you right-click on an item in a menu, the popup menu for
the item opens. The popup menu also contains a submenu that enables you to perform
menu-related tasks.

You can use the menu item popup menu to perform the following tasks:

� Add menu items as launchers to panels.

� Remove items from menus.

� Open the Run Application dialog with the menu item command in the dialog.

� Add menus to panels. You can add a menu as a menu object or as a drawer object.

� Add new items to menus.

� Change the properties of submenus and menu items.

Figure 4–1 shows the popup menu.
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FIGURE 4–1 Menu Item Popup Menu

Table 4–1 describes menu item popup menus.

TABLE 4–1 Menu Item Popup Menus

Item Description

Add this launcher to panel Adds the launcher to the panel from which you open
the menu.

Remove this item Removes the launcher from the menu.

Put into run dialog Displays the Run Application dialog with the
command from the Command field of the launcher in
the command field on the Run Application dialog.

Help on application-name Opens the online help for the application.

Properties Displays a dialog that enables you to edit the
properties of the launcher.

Entire menu → Add this as drawer to
panel

Adds the submenu as a drawer to the panel from
which you open the menu.

Entire menu → Add this as menu to
panel

Adds the submenu as a menu object to the panel
from which you open the menu.

Entire menu → Add new item to this
menu

Enables you to add an item to the submenu.

Entire menu → Properties Displays a dialog that enables you to edit the
properties of the submenu.

Applications Menu
The Applications menu contains a hierarchy of submenus, from which you can start
the standard Java Desktop System applications and preference tools.

You can access the Applications menu from the following places:
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� Launch button
� Menu Bar

Actions Menu
The Actions menu contains commands that enable you to perform various tasks in the
Java Desktop System. Table 4–2 describes the commands in the Actions menu.

TABLE 4–2 Actions Menu Commands

Menu Item Function

Run Application Opens the Run Application dialog. Use the Run
Application dialog to run commands. For more
information, see “Using the Run Application Dialog”
on page 74.

Open Recent Displays a submenu of the last ten files which you saved.

Take Screenshot Takes a screenshot of the screen, and opens the Save
Screenshot dialog. Use the Save Screenshot dialog to
save the screenshot.

Find Files Starts the Search Tool application.

Lock Screen Locks your screen.

Log Out Logs you out of the current session.

You can access the Actions menu items from the following places:

� Launch button
� Menu Bar

Using the Run Application Dialog
The Run Application dialog gives you access to the command line. When you run a
command in the Run Application dialog, you cannot receive output from the
command.

To run a command from the command line, perform the following steps:

1. Display the Run Application dialog. You can display the Run Application dialog
in any of the following ways:

� From any panel
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Add the Run button to a panel. Right-click on the panel, then choose Add to
Panel → Actions → Run. Click on the Run button.

� From the Launch button

Click Launch, then choose Run Application.

� From the Menu Bar

Choose Actions → Run Application.

� Use shortcut keys

The default shortcut keys to display the Run Application dialog are Super + R.
You can change the shortcut keys that display the Run Application dialog in
the Keyboard Shortcuts preference tool.

� From a menu item popup menu

Right-click on an item in a menu, then choose Put into run dialog from the
popup menu. The Run Application dialog opens with the command from the
menu in the command field.

2. Enter the command that you want to run in the blank field. Alternatively, to choose
a command that you ran previously, click the down arrow button beside the
command field, then choose the command to run.

Alternatively, select the Show list of known applications option to display a list of
available applications.

You can also use the Run with file button to choose a file to append to the
command line. For example, you can enter emacs as the command, then choose a
file to edit.

Select the Run in terminal option to run the application or command in a terminal
window. Choose this option for an application or command that does not create a
window in which to run.

3. Click on the Run button on the Run Application dialog.

To Take a Screenshot
You can take a screenshot in any of the following ways:

� From any panel

1. Add the Screenshot button to a panel.

2. Right-click on the panel, then choose Add to Panel → Actions → Screenshot.

3. Click on the Screenshot button to take a screenshot of the entire screen.

4. Use the Save Screenshot dialog to save the screenshot.

� Use shortcut keys

To take a screenshot, use the following shortcut keys:
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Default Shortcut Keys Function

Print Screen Takes a screenshot of the entire screen, and displays the
Save Screenshot dialog. Use the Save Screenshot dialog
to save the screenshot.

Alt + Print Screen Takes a screenshot of the window to which the mouse
points, and displays the Save Screenshot dialog. Use the
Save Screenshot dialog to save the screenshot.

You can use the Keyboard Shortcuts preference tool to modify the default shortcut
keys.

� From Menu Bar

To take a screenshot of the entire screen, choose Actions → Take Screenshot. A Save
Screenshot dialog is displayed. To save the screenshot, select the Save screenshot
to file option. Enter the path and filename for the screenshot in the drop-down
combination box. Alternatively, to save the screenshot to another directory, click
Browse. When you select a directory, click OK.

You can also save the screenshot to the desktop. To save the screenshot to the
desktop, select the Save screenshot to desktop option.

� Use a command

You can use the gnome-panel-screenshot command to take a screenshot. The
gnome-panel-screenshot command takes a screenshot of the entire screen, and
displays the Save Screenshot dialog. Use the Save Screenshot dialog to save the
screenshot.

You can also use options on the gnome-panel-screenshot command as
follows:

Option Function

--window Takes a screenshot of the window that has focus, and
displays the Save Screenshot dialog. Use the Save
Screenshot dialog to save the screenshot.

--delay=seconds Takes a screenshot after the specified number of seconds,
and displays the Save Screenshot dialog. Use the Save
Screenshot dialog to save the screenshot.

--help Displays the options for the command.
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Launch Button

The Launch button provides access to the Applications menu and many of the items in
the Actions menu. You can access almost all of the standard applications, commands,
and configuration options from the Launch button.

You can add Launch buttons to your panels.

To Access the Launch Button
You can access the Launch button in the following ways:

� From a panel with a Launch button.

Click Launch.

� Use shortcut keys.

You can use shortcut keys to open Launch.

The default shortcut keys to open Launch are Ctrl + Esc. To change the shortcut
keys that open Launch, use the Keyboard Shortcuts preference tool.

To Add a Launch Button to a Panel
You can add as many Launch buttons as you want to your panels. To add a Launch
button to a panel, right-click on any vacant space on the panel. Choose Add to Panel
→ Main Menu.

Menu Bar
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The Menu Bar provides access to the Applications and Actions menus. You can access
almost all of the standard applications, commands, and configuration options from the
Menu Bar.

To Add a Menu Bar to a Panel
You can add as many Menu Bar panel applications as you want to your panels. To add
a Menu Bar to a panel, right-click on any vacant space on the panel. Choose Add to
Panel → Menu Bar.

Customizing Your Menus
You can modify the contents of the following menus:

� Applications menu
� Preferences menu

You use the following Java Desktop System components to customize menus:

� Menus on panels
� File manager

When you use panels to customize your menus, you use the menu item popup menu.
For more information, see “Menu Item Popup Menu” on page 72.

When you use the file manager to customize your menus, you must access the
Applications menu or the Preferences menu from within the file manager. To access
the Applications menu or the Preferences menu, open a file manager window.

To access menus in the file manager, enter one of the following URIs in the field on the
location bar:

Menu Enter this URI

Applications menu applications:///

Preferences menu preferences:///
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To Add a Menu
To add a menu, perform the following steps:

1. In a file manager window, access the location where you want to add the menu.
For example, if you want to add a menu to the Applications menu, enter
applications:/// in the field on the location bar.

2. Choose File → Create Folder. An untitled folder is added to the view pane. The
name of the folder is selected.

3. Type a name for the folder, then press Return.

The next time that you log out then log in again, the menu is in the assigned location.

To Add a Launcher to a Menu
To add a launcher to a menu, perform the following steps:

1. Right-click on any item in the menu to which you want to add the launcher.
2. Choose Entire menu → Add new item to this menu.
3. Enter the properties of the launcher in the Create Launcher dialog.
4. Click OK.

To Add a Launcher to an Empty Menu
To add a launcher to an empty menu, perform the following steps:

1. In a file manager window, access the menu where you want to add the launcher.
2. Choose File → Create Launcher.
3. Enter the properties of the launcher in the Create Launcher dialog.
4. Click OK.

To Copy a Launcher to a Menu
To copy an existing launcher to a menu, perform the following steps:

1. In a file manager window, access the location from which you want to copy the
launcher. For example, if you want to copy a launcher from the Applications menu,
enter applications:/// in the field on the location bar.

2. Select the launcher that you want to copy, then choose Edit → Copy File.

3. In a file manager window, access the location to which you want to copy the
launcher.

4. Choose Edit → Paste Files. The launcher is added to the new location.

Alternatively, you can drag the launcher from one location to another.
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The next time that you log out then log in again, the launcher is in the new menu
location.

To Edit the Properties of a Menu
To edit the properties of a menu, perform the following steps:

1. Right-click on any item in the menu that you want to edit.
2. Choose Entire menu → Properties.
3. Modify the properties of the menu in the Launcher Properties dialog.
4. Click OK.

To Edit a Menu Item
To edit a menu item, perform the following steps:

1. Right-click on the item that you want to edit.
2. Choose Properties.
3. Modify the properties of the launcher in the Launcher Properties dialog.
4. Click OK.

To Delete an Item from a Menu
To delete an item from a menu, use the menu item popup menu. To delete an item
from a menu, perform the following steps:

1. Right-click on the item that you want to delete.
2. Choose Remove this item.
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CHAPTER 5

Working With Windows

The information in this chapter describes how to use windows in the Java Desktop
System. You can use several types of window managers with the Java Desktop System,
for example, Metacity and Sawfish. Many of the functions in Metacity are also
available in Sawfish. This chapter describes the functions that are associated with the
Metacity window manager.

Windows and Workspaces
Windows are displayed in subdivisions of the Java Desktop System that are called
workspaces. Every workspace contains the same desktop, the same panels, and the
same menus. However, you can run different applications, and open different
windows in each workspace. You can display only one workspace at a time, but you
can have windows open in other workspaces.

The Workspace Switcher panel application displays a visual representation of your
windows and workspaces, as shown in Figure 5–1.

FIGURE 5–1 Workspace Switcher Panel Application

You can add workspaces at any time. To add workspaces to the Java Desktop System,
right-click on the Workspace Switcher panel application, then choose Preferences. The
Workspace Switcher Preferences dialog is displayed. Use the Number of workspaces
spin box to specify the number of workspaces you require.
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Window Manager Behavior
A window manager controls how windows appear and behave. The window manager
manages where your windows are located, and which window has focus. The window
frame contains buttons that enable you to perform standard actions such as moving,
closing, and resizing windows.

You can set some window manager preferences in the Window Behavior preference
tool. This manual describes the functions that are associated with the default
configuration of the Metacity window manager. The default configuration is specified
in the Window Behavior preference tool.

Types of Window
The Java Desktop System features the following types of windows:

� Application windows

When you start an application, an application window opens. The window
manager applies a frame to the application window. By default, the top edge of the
application window contains a titlebar. The titlebar contains buttons that you can
use to work with the window. The buttons in an application window frame enable
you to perform actions such as open the Window Menu, or close the window. The
Window Menu provides a number of actions that you can perform on the window.

The following figure shows a typical application window.

� Dialog windows
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A dialog window is a popup window in which you enter information or
commands. The dialog appears within a window frame.

You can use the top edge of the frame to work with the window. For example, you
can use the titlebar to move the dialog. The frame also contains buttons that enable
you to do the following:

� Open the Window Menu
� Close the dialog window

Typically, you open a dialog window from an application window. When you open
a dialog window, the window is usually raised and has focus. Some dialog
windows do not allow you to use the application until you close the dialog.

The following figure shows a typical dialog window.

Window Frames
A window frame is a border around a window. The window frame contains a titlebar.
The titlebar contains buttons that you can use to work with the window.

Themes
You can apply several themes to your window frames. The theme determines how the
frame looks. To choose a theme for all your window frames, use the Theme preference
tool.

Control Elements
You can use the window frame to perform various actions with the window. In
particular, the titlebar contains various buttons. The following figure shows the
titlebar of an application window:
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Dialog windows also contain some of the window frame control elements. Table 5–1
describes the active control elements on window frames, from left to right.

TABLE 5–1 Window Frame Control Elements

Control Element Description

Window Menu button Click on the button to open the Window Menu.

Titlebar You can use the titlebar to perform the following
actions:
� To give focus to the window click on the titlebar.
� To move the window grab the titlebar and drag the

window to the new location.
� To shade the window, double-click on the titlebar.

To unshade the window, double-click on the
titlebar again.

Minimize button Click on the Minimize button to minimize the
window.

Maximize button Click on the Maximize button to maximize the
window.

Close Window button Click on the Close Window button to close the
window.

Border The border around the window. Use the border to
perform the following actions:
� To resize the window grab the border and drag the

border to the new size.
� To open the Window Menu, right-click on the

border.
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TABLE 5–1 Window Frame Control Elements (Continued)
Control Element Description

Window contents The area inside the window frame. Use the window
contents to perform the following actions:
� To move a window, press-and-hold Alt, click in the

window contents, then drag the window to the
new location.

� To resize a window, press-and-hold Alt, then
middle-click near the corner you want to resize. To
resize the window, drag from the corner on which
you middle-clicked.

� To open the Window Menu, press-and-hold Alt,
then right-click in the window contents.

Using Menus and Panel Applications
With Windows and Workspaces
This section describes the menus and panel applications that you can use to work with
windows and workspaces.

Window Menu
The Window Menu is a menu of commands that you can use to perform actions on
your windows. To open the Window Menu perform one of the following actions:

� Click on the Window Menu button on the window that you want to work with.

� Press Alt + spacebar.

� Press-and-hold Alt, then right-click on any part of the window that you want to
work with.

Table 5–2 describes the commands and submenus in the Window Menu.

TABLE 5–2 Window Menu Commands and Submenus

Menu Item Function

Minimize Minimizes the window.

Maximize or Unmaximize Maximizes the window. If the window is already maximized,
choose Unmaximize to restore the window to its previous size.
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TABLE 5–2 Window Menu Commands and Submenus (Continued)
Menu Item Function

On Top Places the window above any other open windows on the
desktop background.

Move Enables you to use the arrow keys to move the window.

Resize Enables you to use the arrow keys to resize the window.

Close Closes the window.

Put on All Workspaces or
Only on This Workspace

Puts the window on all of your workspaces. If the window is
already on all of your workspaces, choose Only on This
Workspace to put the window on the current workspace only.

Move to Workspace Right or
Move to Workspace Left

Move the window to the workspace to the right of the current
workspace. If the window is already in the last workspace at
the right of the Workspace Switcher, choose Move to
Workspace Left to move the window to the workspace to the
left of the current workspace.

Move to Another Workspace Moves the window to another workspace. Select the
workspace to which you want to move the window from the
submenu.

Window List
The Window List displays a button for each application window that is open. You can
use the Window List to perform the following tasks:

� To minimize a window

Click on the button that represents the window.
� To restore a minimized window

Click on the button that represents the window.
� To give focus to a window

Click on the button that represents the window.

When you open an application window, Window List displays a button that
represents the window. The window list buttons show which application windows are
open. You can view which windows are open even if some windows are minimized,
or other windows overlap a window. Window List can display buttons for the
windows in your current workspace, or in all workspaces. To select this option, you
must change the preferences of Window List.

You can also right-click on a window list button to open the Window Menu for the
window that the button represents. When you open the Window Menu from Window
List, the Window Menu does not contain the workspace commands. For more
information on the Window Menu commands, see “Window Menu” on page 85.
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Figure 5–2 shows Window List when the following windows are open:

� gedit
� Dictionary
� GHex
� GNOME Terminal

FIGURE 5–2 Window List Panel Application

The buttons in the panel application show the status of your windows. Table 5–3
explains the information that the window list buttons provide about the window. The
examples in Table 5–3 refer to Figure 5–2.

TABLE 5–3 Window Status Information on Window List Buttons

State Indicates Example

Button is pressed in. The window has focus. gedit

Square brackets around
window title.

The window is minimized. [Dictionary]

Button is not pressed in, no
square brackets around title.

The window is displayed, and
is not minimized.

ghex

Numeral on button, in
parentheses.

The button represents a group
of buttons.

Gnome-terminal (3)

Grouping Buttons
Window List can group the buttons that represent windows in the same class under
one window list button. The Gnome-terminal button in Figure 5–2 is an example of a
button that represents a group of buttons. The following figure shows an example of
Window List with a button group open:

To open a list of the windows in a group, click on the window list button that
represents the group. You can click on the items in the list to give focus to windows,
minimize windows, and restore windows.
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To open the Window Menu for a window in a button group, right-click on the window
list button that represents the group. A list of the windows in the group is displayed.
To open the Window Menu for a window in the group, click on the item in the list.
When you open the Window Menu from the Window List, the Window Menu does
not contain the workspace commands. For more information on the Window Menu
commands, see “Window Menu” on page 85.

Workspace Switcher
Workspace Switcher displays a visual representation of your workspaces, as shown in
Figure 5–3. Figure 5–3 shows the Workspace Switcher when the Java Desktop System
session contains four workspaces. Your workspaces appear as buttons on the panel
application. The background of the button in the Workspace Switcher that represents
the current workspace is highlighted. The current workspace in Figure 5–3 is the
workspace at the left of the panel application. To switch to another workspace, click on
the workspace in the panel application.

FIGURE 5–3 Workspace Switcher Panel Application

Workspace Switcher also displays the application windows and dialogs that are open
in your workspaces.

The panel application displays the workspaces in order from left to right across the
rows of the panel application. In Figure 5–3, the panel application is set up to display
the workspaces in one row. You can specify the number of rows in which your
workspaces are displayed in Workspace Switcher. You can also change the default
behavior of the Workspace Switcher to display the names of your workspaces in the
panel application.

Window Selector
You can view a list of all windows that are currently open. You can also choose a
window to give focus to. To view the window list, click on the Window Selector panel
application. The following figure shows an example of the Window Selector panel
application:
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To give focus to a window, select the window from the Window Selector panel
application.

The Window Selector lists the windows in all workspaces. The windows in all
workspaces other than the current workspace, are listed under a separator line.

Manipulating Windows
This section describes how to manipulate windows.

To Give Focus to a Window
A window that has focus can receive input from the mouse and the keyboard. Only
one window can have focus at a time. The window that has focus has a different
appearance than other windows.

You can use the following elements to give focus to a window:

Element Action

Mouse Click on the window, if the window is visible.

Shortcut keys Use shortcut keys to switch between the windows that are
open. To give focus to a window, release the keys. The default
shortcut keys to switch between windows are Alt + Tab.

Window List Click on the button that represents the window in Window
List.
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Element Action

Workspace Switcher Click on the window that you want to give focus to in the
Workspace Switcher display. If you click on a window in
another workspace, Workspace Switcher switches to the new
workspace, and gives focus to the window.

To Minimize a Window
To minimize a window perform one of the following actions:

� Click on the Minimize button on the window frame.
� Open the Window Menu, then choose Minimize.
� If the window has focus, click on the button that represents the window in

Window List. If the window does not have focus, click twice on the button that
represents the window.

� Right-click on the button that represents the window in Window List, then choose
Minimize from the popup menu.

To Maximize a Window
When you maximize a window, the window expands as much as possible. To
maximize a window perform one of the following actions:

� Click on the Maximize button on the window frame. Alternatively, open the
Window Menu, then choose Maximize.

� Right-click on the button that represents the window in Window List, then choose
Maximize from the Window Menu.

To Restore a Window
To restore a maximized window perform one of the following actions:

� Click on the Maximize button on the window frame.
� Open the Window Menu. Choose Unmaximize.
� Right-click on the button that represents the window in Window List to open the

Window Menu. Choose Unmaximize.

To restore a minimized window, click on the button that represents the window in
Window List.

To Place a Window on Top of Other Windows
To place a window on top of other windows, open the Window Menu, then choose On
Top.
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To Close a Window
To close a window perform one of the following actions:

� Click on the Close Window button on the window frame.
� Open the Window Menu. Choose Close.
� Right-click on the button that represents the window in Window List, then choose

Close from the Window Menu.

If you have unsaved data in the window, you are prompted to save your data.

To Resize a Window
To resize a window perform one of the following actions:

� Point to a corner of the window. The mouse pointer changes to indicate that you
can resize the window. Grab the corner and drag the window to the new size.

� Right-click on the button that represents the window in Window List. Choose
Resize from the Window Menu. Use the arrow keys to resize the window.

� Press-and-hold Alt, then middle-click near the corner that you want to resize. The
mouse pointer changes to indicate that you can resize from the corner. To resize the
window, drag from the corner on which you middle-clicked.

� To resize a window horizontally point to one of the vertical edges of the window.
The mouse pointer changes to indicate that you can resize the window. Grab the
edge and drag the window to the new size.

� To resize a window vertically point to the bottom edge of the window. The mouse
pointer changes to indicate that you can resize the window. Grab the edge and
drag the window to the new size.

Note – You cannot resize some dialog windows. Also, some application windows have
a minimum size below which you cannot reduce the window.

To Move a Window
To move a window perform one of the following actions:

� Grab the titlebar of the window and drag the window to the new location.
� Press-and-hold Alt, then drag the window to the new location.
� Open the Window Menu, then choose Move. Use the arrow keys to move the

window to the new location.
� Right-click on the button that represents the window in Window List, then choose

Move from the Window Menu. Use the arrow keys to move the window to the new
location.
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To Roll Up a Window
You can roll up and roll down windows, as follows:

Roll up Reduce the window so that only the titlebar is visible.

Roll down Switch a window from a rolled-up state so that the full window is
displayed.

To roll up a window perform one of the following actions:

� Double-click on the titlebar of the window. To roll down the window, double-click
on the titlebar again.

� Right-click on the button that represents the window in Window List, then choose
Roll Up from the Window Menu. To roll down the window, choose Unroll.

To Put a Window on All Workspaces
To put a window in all workspaces, open the Window Menu. Choose Put on All
Workspaces. To set the window to appear only in the current workspace, choose Only
on This Workspace.

To Move a Window to Another Workspace
You can move a window to another workspace in either of the following ways:

� Use Workspace Switcher

In the Workspace Switcher display, drag the window to the workspace you require.

� Use the Window Menu

Open the Window Menu. To move the window to the next workspace choose
Move to workspace-name.

To Resize Panes
Some windows contain more than one pane. A pane is a subdivision of a window. For
example, the file manager window contains a side pane and a view pane. A window
that contains panes has a resize handle on the edge between the panes. To resize the
pane, grab the resize handle, then drag the edge to the size you require.
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Using Tables
Some windows contain information that is organized in a table. This section describes
how to work with tables in windows.

To change the width of a column, drag one of the vertical edges of the column.

In some tables, you can sort the information by a particular column. To sort
information in a table, click on the heading on top of the column by which you want
to sort the information. An up arrow is displayed in the column heading by which the
table is sorted. The following figure shows the up arrow.

To reverse the sort order, click on the column heading again. The up arrow changes to
a down arrow. The down arrow indicates that the information in the column is sorted
in reverse order.

In some tables, you can select multiple items. The following table describes how to
select items in tables.

Task Action

Select an item Click on the item.

Select a group of contiguous
items

Press-and-hold Shift. Click on the first item in the group,
then click on the last item in the group.

Select multiple items Press-and-hold Ctrl. Click on the items that you want to
select.

Manipulating Workspaces
This section describes how to manipulate workspaces.

To Switch Between Workspaces
You can switch between workspaces in any of the following ways:

� Use Workspace Switcher

Click on the workspace that you want to switch to in Workspace Switcher.
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� Use shortcut keys

The default shortcut keys to switch between the workspaces are as follows:

Default Shortcut Keys Function

Ctrl + Alt + right arrow Selects the workspace to the right.

Ctrl + Alt + left arrow Selects the workspace to the left.

To Add Workspaces
To add workspaces to the Java Desktop System, right-click on Workspace Switcher,
then choose Preferences. The Workspace Switcher Preferences dialog is displayed.
Use the Number of workspaces spin box to specify the number of workspaces you
require. Workspace Switcher adds new workspaces at the end of the workspace list.

To Name Workspaces
The default names of your workspaces are Workspace 1, Workspace 2, Workspace
3, and so on. To assign names to your workspaces, right-click on Workspace Switcher,
then choose Preferences. The Workspace Switcher Preferences dialog is displayed.
Use the Workspaces names list box to specify the names of your workspaces. Select a
workspace, then type the new name for the workspace.

To Delete Workspaces
When you delete a workspace the windows in the workspace are moved to another
workspace, and the empty workspace is deleted.

To delete workspaces from the Java Desktop System, right-click on Workspace
Switcher, then choose Preferences. The Workspace Switcher Preferences dialog is
displayed. Use the Number of workspaces spin box to specify the number of
workspaces you require. Workspace Switcher deletes workspaces from the end of the
workspace list.
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CHAPTER 6

Using Your File Manager

Nautilus is the name of the Java Desktop System file manager that provides an
integrated access point to your files and applications.

This chapter describes how to use the file manager.

Introduction to File Manager
The file manager provides an integrated access point to your files and applications.
The file manager enables you to do the following:

� Create folders and documents.
� Display your files and folders.
� Manage your files and folders.
� Customize your files and folders.
� Open special URI locations.
� Write data to a CD.
� Use removable media on Linux.

The file manager also manages the desktop background. The desktop background lies
behind all of the other components on your visible desktop. The desktop background
is an active component of the user interface.

To open a file manager window, double-click on the Documents object on the desktop
background. The file manager window displays the contents of your default
documents location in the view pane.
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File Manager Windows
File manager windows enable you to display and manage your files and folders.
Figure 6–1 shows a file manager window that displays the contents of a folder.

FIGURE 6–1 Contents of a Folder in a File Manager Window

Table 6–1 describes the components of file manager windows.

TABLE 6–1 File Manager Window Components

Component Description

Menubar Contains menus that you use to perform tasks in the file manager.

Toolbar Contains buttons that you use to perform tasks in the file
manager.
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TABLE 6–1 File Manager Window Components (Continued)
Component Description

Location bar Contains the following elements:
� Location field or Go To field: Enables you to specify a file,

folder, or URI that you want to view.
� Zoom buttons: Enable you to change the size of items in the

view pane.
� View as drop-down list: Enables you to choose how to show

items in your view pane.

Side pane Performs the following functions:
� Shows information about the current file or folder.
� Enables you to navigate through your files.

The side pane contains a drop-down list that enables you to
choose what to show in the side pane. You can choose from the
following options:
� Information
� Emblems
� History
� Notes
� Tree

To display the side pane, choose View → Side Pane.

View pane Shows the contents of the following:
� Particular types of files
� Folders
� FTP sites
� Locations that correspond to special URIs

Statusbar Displays status information.

You can also open a popup menu from file manager windows. To open this popup
menu right-click in a file manager window. The items in this menu depend on where
you right-click. For example, when you right-click on a file or folder, you can choose
items related to the file or folder. When you right-click on the background of a view
pane, you can choose items related to the display of items in the view pane.

View Pane
The view pane can display the contents of the following:

� Particular types of files
� Folders
� FTP sites
� Locations that correspond to special URIs
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The file manager contains viewer components that enable you to display particular types
of file in the view pane. For example, you can use a text viewer to display text files in
the view pane.

Displaying a file in the view pane provides the following benefits:

� Uses less system resources than when you launch an application.
� Takes less time than when you launch an application.

However, you cannot edit a file in the view pane.

The file manager also includes views that enable you to display the contents of your
folders in different ways. For example, you can display the contents of a folder in the
following types of view:

� Icon view: Shows the items in the folder as icons.
� List view: Shows the items in the folder as a list.
� Audio view: Shows only the audio items in the folder.

Use the View menu to choose how to display a folder. For more information on views,
see “Using Views to Display Your Files and Folders” on page 119.

Side Pane
To display the side pane, choose View → Side Pane. You can choose what information
you want to view in the side pane. You can choose to display one of the following:

� Information

Displays an icon that represents the current file or current folder. Also displays
information about the current file or current folder. If a file is displayed in the view
pane, buttons appear in the side pane. The buttons enable you to perform actions
on a file, other than the default action.

� Emblems

Contains emblems that you can add to a file or folder.

� History

Contains a history list of files, folders, FTP sites, and URIs that you have recently
visited.

� Notes

Enables you to add notes to your files and folders.

� Tree

Displays a hierarchical representation of your file system. You can use the Tree to
navigate through your files.

To close the side pane, click on the X button at the top right of the side pane.
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Icons and Emblems
In icon view, the file manager displays your files and folders as icons. You can add
emblems to your file icons and folder icons. An emblem is a small icon that you can
add to an item to visually mark the item. For example, to mark a file as important, you
can add an Important emblem to the file icon to create the following visual effect:

For more information on how to add an emblem to an icon, see “To Add an Emblem
to a File or Folder” on page 117.

The following table describes the structure of the file icon:

Component Description

Emblem. This emblem is the Important emblem.

Icon that represents the file. This icon might contain a
preview of the contents of the file.

Icon caption. You can modify what items of information are
displayed in the icon caption.

The file manager includes default emblems for the following types of item:

� Symbolic links

� Items for which you have the following permissions:

� Read permission only
� No read permission and no write permission
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The following table shows the default emblems:

Default Emblem Description

Symbolic link

Read permission only

No read permission and no write permission

Navigating Your Computer
The file manager provides an integrated access point to your files, applications, FTP
sites, and URIs.

This section describes the following:

� How to display items in file manager windows.
� How to open files from file manager windows.
� How to navigate the files and folders in your file system.
� How to open locations on your file system.
� How to connect to a server.
� How to navigate to FTP sites.
� How to access special URI locations.

To Display a Folder
You can display the contents of a folder in any of the following ways:

� Double-click on the folder in the view pane.

� In the Location field, type the path of the folder that you want to display, then
press Return. The Location field includes an autocomplete feature. As you type a
path, the file manager reads your file system. When you type enough characters to
uniquely identify a directory, the file manager completes the name of the directory
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in the Location field.

� Use the Tree in the side pane. For more information, see “Using the Tree From the
Side Pane” on page 101.

� Use the Back toolbar button and the Forward toolbar button to browse through
your navigation history.

To change to the folder that is one level above the current folder, choose Go → Up.
Alternatively, click on the Up toolbar button.

To reload the display, click on the Reload button.

If you cannot find the folder that you want to display, you can use Search Tool. To start
the Search Tool, click Launch, then choose Find Files.

Using the Tree From the Side Pane
The Tree displays a hierarchical representation of your file system. The Tree provides a
convenient way to navigate your file system. To display the Tree in the side pane,
choose Tree from the drop-down list at the top of the side pane.

In the Tree, folders are represented as follows:

Folder State Graphic Representation

Closed folder Right arrow

Open folder Down arrow

Table 6–2 describes the tasks that you can perform with the Tree, and how to perform
the tasks.

TABLE 6–2 Tree Tasks

Task Action

Open the Tree. Choose Tree from the drop-down list at the
top of the side pane.

Close the Tree. Choose another item from the drop-down list
at the top of the side pane.

Open a folder in the Tree. Click on the arrow next to the folder in the
Tree.

Close a folder in the Tree. Click on the arrow next to the folder in the
Tree.
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TABLE 6–2 Tree Tasks (Continued)
Task Action

Display the contents of a folder in the view
pane.

Select the folder in the Tree.

Display the contents of a file in the view pane. Select the file in the Tree.

You can set your preferences so that the Tree does not display files.

Opening Files
When you open a file, the file manager performs the default action for that file type.
The default action can be one of the following:

� Use a viewer component to display the file in the view pane.
� Launch an application that opens the file.

The file manager checks the contents of a file to determine the type of a file. If the first
lines do not determine the type of the file, then the file manager checks the file
extension.

If you cannot find the file that you want to open, you can use Search Tool. To start the
Search Tool, click Launch, then choose Find Files.

Viewing Files in the View Pane
The file manager contains viewer components that enable you to display particular
types of file in the view pane. For example, you can display the following types of files
in the view pane:

� Plain text files
� PNG files
� Joint Photographic Experts Group (JPEG) files

To reload the contents of the view pane, choose View → Reload. To stop loading an
item in the view pane, choose View → Stop.

When you display a file in the view pane, the viewer component might add menu
items to the file manager menus. The menu items relate to the file type that is
displayed. For example, when you display a PNG file, the Edit menu contains flip and
rotate menu items.

Also, when you display some types of file in the view pane, you can use the file
manager zoom buttons to change the size of the item.
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To Execute the Default Action
To execute the default action for a file, double-click on the file. For example, if the
default action for plain text documents is to display the file in a text viewer. In this
case, you can double-click on the file to display the file in a text viewer.

You can set your file manager preferences so that you click once on a file to execute the
default action.

To Execute Non-Default Actions Using the Open With
Submenu
To execute actions other than the default action for a file, perform the following steps:

1. In the view pane, select the file that you want to perform an action on. Choose File
→ Open With. The Open With submenu opens. The items in this submenu
correspond to the contents of the following parts of the File Associations preference
tool:

� Default action drop-down list in the Edit file type dialog
� Viewer component drop-down list in the Edit file type dialog

2. Choose an action from the Open With submenu.

To Execute Other Actions When Displaying a File
When you display a file in the view pane, the side pane might contain buttons.

The buttons represent any actions that are defined in the File Associations preference
tool. The actions are defined in the Default action drop-down list in the Edit file type
dialog in the File Associations preference tool. Click on a button to execute an action.
For example, if an action defined for plain text documents is to open the file in the
gedit text editor. If this action is defined, an Open with gedit button is displayed in the
side pane. To open the file in the gedit application, click on the Open with gedit
button.

Note – A button that represents the action does not appear in the side pane if the
actions are excluded in either of the following dialogs:

� Open with Other Application
� Open with Other Viewer

To Open Locations
The file manager provides an integrated access point to your files, applications, FTP
sites, and URIs.
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You can use the file manager to quickly access different locations on your file system.
To open a location, perform the following steps:

1. Choose Go → Location.
2. In the Location field, type the path of the folder that you want to display
3. Press Return.

The Location field includes an autocomplete feature. As you type a path, the file
manager reads your file system. When you type enough characters to uniquely
identify a directory, the file manager autocompletes the name of the directory in the
Location field.

To Connect to a Server
If your Java Desktop System environment is configured to access servers on a
network, you can use the Connect to Server menu to connect to servers.

To connect to a server, perform the following steps:

1. Choose File → Connect to Server.

2. Enter the name of a server in the Link name field of the Connect to Server dialog.

3. Enter the URL location, for example ftp:///ftp.gnome.org in the Location
(URL) field.

4. Click on the Connect button.

Using the This Computer Location

The This Computer location enables you to access the following functions:

� Applications

Double-click Applications to access your key Java Desktop Systems applications.
You can also access the Applications menu through the Launch menu and the
Menu Bar.

� Preferences

Double-click on Preferences to customize the Java Desktop System. You can also
access the preference tools through the Launch menu

� File System
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Double-click on File System to access the top level folder of the Java Desktop
System.

You can access the This Computer location in the following ways:

� From the desktop background

Double-click on the This Computer object on the desktop background. The
contents of the This Computer location are displayed in a file browser window.

� From a file browser window, access the computer:/// URI.

To Access FTP Sites
You can use the file manager to access FTP sites. To access an FTP site, enter the URL
for the site in the field on the location bar, then press Return. The contents of the site
are displayed in the view pane. To copy a file from the FTP site, drag the file to the
new location.

To access an FTP site that requires a username and password, you can enter the URL
in the following form:

ftp://username:password@hostname.domain

To reload the FTP site in the view pane, choose View → Reload. To stop loading the
FTP site, choose View → Stop.

Accessing Special URI Locations
The Java Desktop System contains special URI locations that enable you to access
particular functions from the file manager. For example, to access the preference tools,
you can access the preferences:/// URI in a file manager window. Table 6–3 lists
the special URI locations that you can use with the file manager.

TABLE 6–3 Special URI Locations

URI Location Description

applications:/// Displays a list of the applications in the Java Desktop System.
The applications are the same as the applications in the
Applications menu. To open an application, double-click on
the application.

computer:/// Displays a list of applications and preference tools in the Java
Desktop System. Also displays icons to access your file
system, CD-ROM, and floppy drives.
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TABLE 6–3 Special URI Locations (Continued)
URI Location Description

preferences:/// Displays a list of the preference tools in the Java Desktop
System. The preference tools are the same as the preference
tools in the Preferences menu. To open a preference tool,
double-click on the preference tool.

server-settings:/// Displays a list of applications that you can use to configure
your system as a server.

system-settings:/// Displays a list of applications that you can use to modify your
system settings.

Using Your Navigation History
The file manager maintains a history list of files, folders, FTP sites, and URI locations.
You can use the history list to navigate to files, folders, FTP sites, and URI locations
that you have recently visited. Your history list contains the last ten items that you
viewed. The following sections describe how to navigate your history list.

To clear your history list choose Go → Clear History.

To Navigate Your History List Using the Go Menu
To display a list of previously-viewed items, choose the Go menu. Your history list is
displayed in the lower part of the Go menu. To open an item in your history list,
choose the item from the Go menu.

To Navigate Your History List Using the Toolbar
To use the toolbar to navigate your history list, perform one of the following actions:

� To open the previous file, folder, or URI in your history list, click on the Back
toolbar button.

� To open the next file, folder, or URI in your history list, click on the Forward
toolbar button.

� To display a list of previously-viewed items, click on the down arrow to the right
of the Back toolbar button. To open an item from this list, click on the item.

� To display a list of items that you viewed after you viewed the current item, click
on the down arrow to the right of the Forward toolbar button. To open an item
from this list, click on the item.
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To Navigate Your History List Using History in the Side
Pane
To display the History list in the side pane, choose History from the drop-down list at
the top of the side pane. The History list in the side pane displays a list of your
previously-viewed items.

To display an item from your history list in the view pane, click on the item in the
History list.

To Bookmark Your Favorite Locations
To access an item in your bookmarks, choose the item from the Bookmarks menu. You
can add your favorite locations to your Bookmarks menu. You can add bookmarks to
files and folders in your file system, to FTP sites, or to URI locations.

To Add a Bookmark
To add a bookmark, display the item that you want to bookmark in the view pane.
Choose Bookmarks → Add Bookmark.

To Edit a Bookmark
To edit your bookmarks perform the following steps:

1. Choose Bookmarks → Edit Bookmarks.

2. To edit a bookmark, select the bookmark on the left side of the Edit Bookmarks
dialog. Edit the details for the bookmark on the right side of the Edit Bookmarks
dialog, as follows:

Dialog Element Description

Name Use this text box to specify the name that identifies the bookmark
in the Bookmarks menu.

Location Use this field to specify the location of the bookmark.

3. To delete a bookmark, select the bookmark on the left side of the dialog. Click
Delete.
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Managing Your Files and Folders
This section describes how to work with your files and folders.

Drag-and-Drop in the File Manager
You can use drag-and-drop to perform several tasks in the file manager. When you
drag-and-drop, the mouse pointer provides feedback about the task that you perform.
Table 6–4 describes the tasks that you can perform with drag-and-drop. The table also
shows the mouse pointers that appear when you drag-and-drop.

TABLE 6–4 Drag-and-Drop in the File Manager

Task Action Mouse Pointer

Move an item Drag the item to the new location.

Copy an item Grab the item, then press-and-hold Ctrl. Drag the item
to the new location.

Create a symbolic
link to an item

Grab the item, then press-and-hold Ctrl + Shift. Drag
the item to the location where you want the symbolic
link to reside.
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TABLE 6–4 Drag-and-Drop in the File Manager (Continued)
Task Action Mouse Pointer

Ask what to do
with the item you
drag

Grab the item, then press-and-hold Alt. Drag the item
to the location where you want the item to reside.
Release the mouse button. A popup menu appears.
Choose one of the following items from the popup
menu:
� Move here

Moves the item to the location.
� Copy here

Copies the item to the location.
� Link here

Creates a symbolic link to the item at the location.
� Set as Background

If the item is an image, sets the image to be the
desktop background. You can use this command to
set the desktop background and the view pane
background.

� Cancel
Cancels the drag-and-drop operation.

To Select Files and Folders
You can select files and folders in several ways in the file manager. Table 6–5 describes
how to select items in file manager windows and from the desktop background.

TABLE 6–5 Selecting Items in the File Manager

Task Action

Select an item Click on the item.

Select a group of contiguous
items

In icon view, drag around the files that you want to select.

In list view, click on the first item in the group.
Press-and-hold Shift, then click on the last item in the
group.

Select multiple items Press-and-hold Ctrl. Click on the items that you want to
select.

Alternatively, press-and-hold Ctrl, then drag around the
files that you want to select.

Select all items in a folder Choose Edit → Select All Files.

To perform the default action on an item, double-click on the item. You can set your
file manager preferences so that you click once on a file to execute the default action.
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To Move a File or Folder
The following sections describe the ways that you can move a file or folder.

Drag to the New Location in a View Pane
To drag a file or folder to a new location in a view pane, perform the following steps:

1. Open a file manager window. Choose File → New Window to open a second file
manager window.

2. In one window, select the folder from which you want to move the file or folder. In
the other window, select the folder to which you want to move the file or folder.

3. Drag the file or folder that you want to move to the new location in the other
window.

To move the file or folder to a folder that is one level below the current location, do
not open a new window. Instead, drag the file or folder to the new location in the
same window.

Cut and Paste to the New Location
You can cut a file or folder and paste the file or folder into another folder, as follows:

1. Select the file or folder that you want to move, then choose Edit → Cut File.

2. Open the folder to which you want to move the file or folder, then choose Edit →
Paste Files.

To Copy a File or Folder
The following sections describe the ways you can copy a file or folder.

Drag to the New Location in a View Pane
To copy a file or folder perform the following steps:

1. Open a file manager window. Choose File → New Window to open a second file
manager window.

2. In one window, select the folder from which you want to copy the file or folder. In
the other window, select the folder to which you want to copy the file or folder.

3. Grab the file or folder, then press-and-hold Ctrl. Drag the file or folder to the new
location in the other window.

To copy the file or folder to a folder that is one level below the current location, do not
open a new window. Instead, grab the file or folder, then press-and-hold Ctrl. Drag the
file or folder to the new location in the same window.
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Copy and Paste to the New Location
You can copy a file or folder and paste the file or folder into another folder, as follows:

1. Select the file or folder that you want to copy, then choose Edit → Copy File.

2. Open the folder to which you want to copy the file or folder, then choose Edit →
Paste Files.

To Duplicate a File or Folder
To create a copy of a file or folder in the current folder perform the following steps:

1. Select the file or folder that you want to duplicate in the view pane.

2. Choose Edit → Duplicate. Alternatively, right-click on the file or folder in the view
pane, then choose Duplicate.

A copy of the file or folder appears in the current folder.

To Create a Folder
To create a folder perform the following steps:

1. Select the folder where you want to create the new folder.

2. Choose File → Create Folder. Alternatively, right-click on the background of the
view pane, then choose Create Folder.

An untitled folder is added to the view pane. The name of the folder is selected.

3. Type a name for the folder, then press Return.

To Rename a File or Folder
To rename a file or folder perform the following steps:

1. Select the file or folder that you want to rename in the view pane.

2. Choose Edit → Rename. Alternatively, right-click on the file or folder in the view
pane, then choose Rename.

The name of the file or folder is selected.

3. Type a new name for the file or folder, then press Return.

Templates and Documents
You can create templates from documents that you frequently create. For example, if
you often create invoices, you can create an empty invoice document and save the
document as invoice.doc in the $HOME/Templates folder.
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You can also access the templates folder from a file browser window. Choose Go →
Templates.

The template name is displayed as a submenu item in the Create Document menu.

You can also create subfolders in the template folder. Subfolders display as submenus
in the menu.

You can also share templates. Create a symbolic link from the template folder to the
folder that contains the shared templates.

To Create a Document
If you have document templates, you can choose to create a document from one of the
installed templates.

To create a document perform the following steps:

1. Select the folder where you want to create the new document.

2. Choose File → Create Document. Alternatively, right-click on the background of
the view pane, then choose Create Document.

The names of any available templates are displayed as submenu items from the
Create Document menu.

3. Double-click on the template name for the document that you want to create.

4. Rename the document and save to the appropriate folder.

To Move a File or Folder to Trash
To move a file or folder to Trash perform the following steps:

1. Select the file or folder that you want to move to Trash in the view pane.

2. Choose Edit → Move to Trash. Alternatively, right-click on the file or folder in the
view pane, then choose Move to Trash.

Alternatively, you can drag the file or folder from the view pane to the Trash object on
the desktop background.

Note – When you move a file or folder from a removable media to Trash, the file or
folder is stored in a Trash location on the removable media. To remove the file or
folder permanently from the removable media, you must empty Trash.
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To Delete a File or Folder
When you delete a file or folder, the file or folder is not moved to Trash, but is deleted
from your file system immediately. The Delete menu item is only available if you
select the Include a Delete command that bypasses Trash option in the Folders
Preferences dialog.

To delete a file or folder perform the following steps:

1. Select the file or folder that you want to delete in the view pane.

2. Choose Edit → Delete. Alternatively, right-click on the file or folder in the view
pane, then choose Delete.

To Create a Symbolic Link to a File or Folder
A symbolic link is a special type of file that points to another file or folder. When you
perform an action on a symbolic link, the action is performed on the file or folder to
which the symbolic link points. However, when you delete a symbolic link, you delete
the link file, not the file to which the symbolic link points.

To create a symbolic link to a file or folder, select the file or folder to which you want
to create a link. Choose Edit → Make Link. A link to the file or folder is added to the
current folder.

Alternatively, grab the item to which you want to create a link, then press-and-hold
Ctrl + Shift. Drag the item to the location where you want to place the link.

By default, the file manager adds an emblem to symbolic links.

Note – The permissions of a symbolic link are determined by the file or folder to which
a symbolic link points.

To View the Properties of a File or Folder
To view the properties of a file or folder, perform the following steps:

1. Select the file or folder whose properties you want to view.
2. Choose File → Properties.
3. Use the properties dialog to view the properties of the file or folder.
4. Click Close to close the properties dialog.

To Change Permissions
Permissions are settings assigned to each file and folder that determine what type of
access users can have to the file or folder. The following table lists the permissions that
you can set for files and folders, and the effect of the permission on files and folders:
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Permission File Folder

Read Permission to read the file. Permission to list the contents of the
folder.

Write Permission to make changes to the
file.

Permission to create and delete files in
the folder.

Execute Permission to run the file as a
program. This is only relevant if the
file is a program or script.

Permission to access files in the
directory.

You can set permissions for different types of user. The following table lists the types
of user that you can set for which you can set permissions:

User Category Description

Owner The user that created the file or folder.

Group The group to which the owner belongs.

Others All other users who are not in the group to which the owner
belongs.

To change the permissions on a file or folder perform the following steps:

1. Select the file or folder that you want to change.

2. Choose File → Properties.

3. Click on the Permissions tab. In the Permissions tabbed section, use the
drop-down lists and check boxes to change the permissions for the file or folder.
The following table describes the dialog elements on the Permissions tabbed
section:

Element Description

File owner To change the owner of the file or folder, select the
owner from the drop-down list.

File group To change the group to which a file or folder belongs,
select the group from the drop-down list.

Owner Select the permissions that you want to apply to the
owner of the file or folder.

Group Select the permissions that you want to apply to the
group to which the owner of the file or folder belongs.
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Element Description

Others Select the permissions that you want to apply to all
other users who are not in the group to which the
owner belongs.

Text view Displays the permissions that you select from the Read,
Write, and Execute options, in text format.

Number view Displays the permissions that you select from the Read,
Write, and Execute options, in text format.

Last changed Displays the date and time that the file or folder was
last modified.

4. Click Close to close the properties dialog.

Adding Notes to Files and Folders
You can add notes to files or folders. You can add notes to files or folders in the
following ways:

� From the Properties dialog
� From Notes in the side pane

To Add a Note Using the Properties Dialog
To add a note to a file or folder, perform the following steps:

1. Select the file or folder to which you want to add a note.

2. Choose File → Properties.

3. Click on the Notes tab in the properties dialog. In the Notes tabbed section, type
the note.

4. Click Close to close the properties dialog. A note emblem is added to the file or
folder.

To delete a note, delete the note text from the Notes tabbed section.

To Add a Note Using Notes in the Side Pane
To add a note to a file or folder, perform the following steps:

1. Open the file or folder to which you want to add a note in the view pane.

2. Choose Notes from the drop-down list at the top of the side pane. To display the
side pane, choose View → Side Pane.
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3. Type the note in the side pane. A note emblem is added to the file or folder in the
view pane, and a note icon is added to the side pane. You can click on this icon to
display the note.

To delete a note, delete the note text from Notes in the side pane.

Using Trash
You can move the following items to Trash:

� Files
� Folders
� Desktop background objects

If you need to retrieve a file from Trash, you can display Trash and move the file out
of Trash. When you empty Trash, you delete the contents of Trash permanently.

To Display Trash
You can display the contents of Trash in the following ways:

� From a file manager window

Choose Go → Trash. The contents of Trash are displayed in the window.

� From the desktop background

Double-click on the Trash object on the desktop background.

To Empty Trash
You can empty the contents of Trash in the following ways:

� From a file manager window

Choose File → Empty Trash.

� From the desktop background

Right-click on the Trash object, then choose Empty Trash.

Modifying the Appearance of Files and
Folders
The file manager enables you to modify the appearance of your files and folders in
several ways, as described in the following sections.
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To Add an Emblem to a File or Folder
To add an emblem to an item perform the following steps:

1. Select the item to which you want to add an emblem.

2. Right-click on the item, then choose Properties.

3. Click on the Emblems tab in the properties dialog to display the Emblems tabbed
section.

4. Select the emblem to add to the item.

5. Click Close to close the properties dialog.

To Add a New Emblem
To add a new emblem, perform the following steps:

1. Choose Edit → Backgrounds and Emblems.

2. Click on the Emblem button, then click on the Add a New Emblem button in the
Backgrounds and Emblems dialog.

3. Type a name for the emblem in the Keyword text box of the Create a New Emblem
dialog.

4. Click on the Image button.

5. Click Browse in the Select an image file for the new emblem dialog. When you
choose an emblem, click OK.

6. Click OK in the Create a New Emblem dialog.

To Change the Icon for a File or Folder
To change the icon that represents an individual file or folder, perform the following
steps:

1. Select a file or folder.

2. Choose File → Properties.

3. On the Basic tabbed section in the properties dialog, click on the Select Custom
Icon button.

4. Use the Select an icon dialog to choose the icon to represent the file or folder. Click
Ok.

5. Click Close to close the properties dialog.

To restore an icon from a custom icon to the default icon specified in the File
Associations preference tool, right-click on the icon then choose Remove Custom Icon.
Alternatively, click on the Remove Custom Icon button on the properties dialog.
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To change the icon that represents a file type, use the File Associations preference tool.

To Change the Size of Items in a View
You can change the size of items in a view. You can change the size if the view
displays a file or a folder. You can change the size of items in a view in the following
ways:

� To enlarge the size of items in a view, choose View → Zoom In.
� To reduce the size of items in a view, choose View → Zoom Out.
� To return items in a view to the normal size, choose View → Normal Size.

You can also use the zoom buttons on the location bar to change the size of items in a
view. Table 6–6 describes how to use the zoom buttons.

TABLE 6–6 Zoom Buttons

Button Button Name Description

Zoom Out button Click on this button to reduce the size of
items in a view.

Normal Size button Click on this button to return items in a
view to normal size.

Zoom In button Click on this button to enlarge the size of
items in a view.

The file manager remembers the size of items in a particular folder. The next time that
you display the folder, the items are displayed in the size that you selected. In other
words, when you change the size of items in a folder, you customize the folder to
display the items at that size. To return the size of the items to the default size
specified in your preferences, choose View → Reset View to Defaults.
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Using Views to Display Your Files and Folders
The file manager provides several ways to display the contents of your files. The file
manager includes viewer components that enable you to display particular types of
file in the view pane. For example, you can use a web page viewer to display HTML
files in the view pane. You can use a text viewer to view plain text files in the view
pane.

You can also use the file manager to open a file in an appropriate application. For
more information, see “Opening Files” on page 102.

The file manager includes views that enable you to show the contents of your folders
in different ways. For example, you can show the contents of a folder in the following
types of view:

� Icon view

Shows the items in the folder as icons.

� List view

Shows the items in the folder as a list.

Use the View menu to choose how to display a file or folder. You can also use the
View as drop-down list to choose how to display a file or folder. When you display a
folder, you can specify how you want to arrange or sort items in the folder. You can
modify the size of the items in the view pane. The following sections describe how to
work with icon view, list view, and views of files.

To Choose a View in Which to Display a File or Folder
Choose the type of view in which to display the contents of a file or folder from the
View menu.

Alternatively, to choose a view, choose View → View as. Select the view that you want
to use from the Open with Other Viewer dialog, then click on the Choose button.

You can also choose the type of view from the View as drop-down list. The View as
drop-down list is located at the right side of the location bar.

You can display different folders in different views. The file manager remembers the
view that you choose for a particular folder. The next time that you display the folder,
the file manager displays the folder in that view. To return the view for the folder to
the default view specified in your preferences, choose View → Reset View to Defaults.

To Arrange Your Files in Icon View
When you display the contents of a folder in icon view, you can specify how to
arrange the items in the folder. To specify how to arrange items in icon view, choose
View → Arrange Items. The Arrange Items submenu contains the following sections:
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� The top section contains an option that enables you to arrange your files manually.

� The middle section contains options that enable you to sort your files
automatically.

� The bottom section contains options that enable you to modify how your files are
arranged.

Choose the appropriate options from the submenu, as described in the following table:

Option Description

Manually Select this option to arrange the items manually. To arrange the
items manually, drag the items to the location you require within
the view pane.

By Name Select this option to sort the items alphabetically by name. The
order of the items is not case sensitive. If the file manager is set to
display hidden files, the hidden files are shown last.

By Size Select this option to sort the items by size, with the largest item
first. When you sort items by size, the folders are sorted by the
number of items in the folder. The folders are not sorted by the
total size of the items in the folder.

By Type Select this option to sort the items alphabetically by object type.
The items are sorted alphabetically by the description of their
MIME type in the File Associations preference tool. The MIME type
identifies the format of a file, and enables applications to read the
file. For example, an email application can use the image/png
MIME type to detect that a PNG file is attached to an email.

By Modification Date Select this option to sort the items by the date the items were last
modified. The most recently modified item is first.

By Emblems Select this option to sort the items by any emblems that are added
to the items. The items are sorted alphabetically by emblem name.
Items that do not have emblems are sorted after items with
emblems.

Compact Layout Select this option to arrange the items so that the items are closer
to each other.

Reversed Order Select this option to reverse the order of the option by which you
sort the items. For example, if you sort the items by name, select
the Reversed Order option to sort the items in reverse alphabetical
order.
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The file manager remembers how you arrange the items in a particular folder. The
next time that you display the folder, the items are arranged in the way that you
selected. In other words, when you specify how to arrange the items in a folder, you
customize the folder to display the items in that way. To return the arrangement
settings of the folder to the default arrangement settings specified in your preferences,
choose View → Reset View to Defaults.

To Resize an Icon in Icon View
In icon view, you can change the size of the icon that represents an item that is
displayed. To change the size of an item in icon view, perform the following steps:

1. Right-click on the item that you want to resize, then choose Stretch Icon. A
rectangle appears around the item, with a handle at each corner.

2. Grab one of the handles, then drag the icon to the size that you want.

To return the icon to the original size, right-click on the icon, then choose Restore
Icon’s Original Size.

You can also resize objects on the desktop background.

To Modify the Behavior of a View
You can modify the behavior of a view in the following ways:

� Specify that the view is the default view for a particular file or folder.

� Specify that the view is the default view for a file type or all folders.

� Specify that the view is an item in the View as submenu for a particular file or
folder.

� Specify that the view is an item in the View as submenu for all of a particular file
type or for all folders.

� Specify that the view is not an item in the View as submenu for a particular file or
folder.

To modify the behavior of a view perform the following steps:

1. Choose View → View as.

2. Select the view that you want to modify from the table in the Open with Other
Viewer dialog.

3. Click on the Modify button. The following table describes the options on the
Modify dialog:
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Option Description

Include in the menu for
item-name items

Select this option to include the view in the View as
submenu for this type of item.

Use as default for item-name
items

Select this option to use the view as the default for this
type of item.

Include in the menu for
item-name only

Select this option to include the view in the View as
submenu for this item only.

Use as default for item-name
only

Select this option to use the view as the default for this
item only.

Don’t include in the menu for
item-name items

Select this option to exclude the view from the View as
submenu for this type of item.

4. Click OK, then click Cancel to close the Open with Other Viewer dialog.

Note – You can also modify the actions that are associated with a file type in the Edit
file type dialog in the File Associations preference tool. To open the Edit file type
dialog, click on the Go There button.

Assigning Actions to Files
When you open a file, the file manager performs the default action for that file type.
The File Associations preference tool contains a table of file types, their associated file
extensions, and their default actions. This table specifies what happens when you
double-click on a file in the file manager.

You can also use the file manager to modify the actions that are associated with a
particular file or file type.

You can use the File Associations preference tool to perform the following tasks:

� Specify the default action for a file type. You can also change the default action for
a file type in the file manager.

� Associate a file type with one or more applications. The default action might
specify to open the file in an application that is associated with the file type.

� Associate a file type with one or more viewers. The default action might specify to
open the file in a viewer that is associated with the file type.

� Associate a file extension with a MIME type. The MIME type specifies the format
of the file so that Internet browsers and email applications can read the file.
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To Modify Actions
You can modify the actions associated with a file or file type. You can do the following:

� Specify that the action is the default action for a particular file.

� Specify that the action is the default action for a particular file type.

� Specify that the action is an item in the Open With submenu for a particular file.

� Specify that the action is an item in the Open With submenu for a particular file
type.

� Specify that the action is not an item in the Open With submenu for a particular file
type.

To modify the actions associated with a file or file type, perform the following steps:

1. In the view pane, select the file for which you want to modify an action. If you
want to modify an action associated with a file type, select a file of that type.

2. Choose File → Open With. Perform either of the following steps:

� Choose Other Application. An Open with Other Application dialog is
displayed.

� Choose Other Viewer. An Open with Other Viewer dialog is displayed.

3. From the table in the dialog, select the application or viewer for which you want to
modify the behavior.

4. Click on the Modify button. The following table describes the options on the
Modify dialog:

Option Description

Include in the menu for filetype
items

Select this option to include the application or viewer in
the Open With submenu for this file type.

Use as default for filetype items Select this option to use the application or viewer as the
default action for this file type.

Include in the menu for
filename only

Select this option to include the application or viewer in
the Open With submenu for this file, and not for other
files of this type.

Use as default for filename only Select this option to use the application or viewer as the
default action for this file, and not for other files of this
type.

Don’t include in the menu for
filetype items

Select this option to exclude the application or viewer
from the Open With submenu for this file type.

5. Click OK, then click Cancel to close the dialog.
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Note – You can also modify the actions that are associated with a file type in the Edit
file type dialog in the File Associations preference tool. To open the Edit file type
dialog, click on the Go There button.

Writing CDs
The file manager provides a special location where you can copy files and folders that
you want to write to a CD. You can write the contents of the location to a CD easily.

To write a CD, perform the following steps:

1. From a file browser window, choose Go → CD Creator. The file manager opens a
special location, burn:///, from which you can write CDs.

2. From a file browser window, copy the files and folders that you want to write to
CD into the burn:/// location.

3. Insert a writable CD into the CD writer device on your system.

4. Choose File → Write to CD. Alternatively, click on the Write to CD button on the
toolbar.

5. Use the Write files to a CD recorder dialog to specify how you want to write the
CD, as follows:

Dialog Element Description

Target to write to Select the device to which you want to write
the CD from the drop-down list. To create an
CD image file for the files and folders, select
the File image option.

Write speed Select the speed at which you want to write
the CD from the drop-down list.

CD name Type a name for the CD in the text box.

Erase CD Select this option to erase the current
contents of the CD.

Eject CD when done Select this option to eject the CD from the
drive when the CD is written.
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Dialog Element Description

Reuse these files for another CD Select this option if you want to write the
files and folders to another CD. If you select
this option, the files and folders are not
removed from the burn:/// location after the
CD is written.

6. Click on the Write files to CD button.

If you selected the File image option from the Target to write to drop-down list, a
Choose a filename for the cdrom image dialog is displayed. Use the dialog to
specify the location where you want to save the CD image file. By default, CD
image files have a .iso file extension.

A Writing CD dialog is displayed. When the CD is written or when the CD image
file is created, a message to indicate that the process is complete is displayed in the
dialog.

If you created a CD image file, you can write this file to a CD. To write a CD image
file to CD, right-click on the CD image file, then choose Write to CD from the
popup menu.

If you did not select the Reuse these files for another CD option, the files and
folders are removed from the burn:/// location.

Using Removable Media on Linux
The file manager supports all removable media on Linux that have the following
characteristics:

� The removable media has an entry in the /etc/fstab file. The /etc/fstab file
describes the file systems that the computer uses.

� The user option is specified in the entry for the removable media in the
/etc/fstab file.

To Mount Media on Linux
To mount media is to make the file system of the media available for access. When you
mount media, the data stored on the media becomes accessible from your file
manager.

To mount media, insert the media in the appropriate device. An object that represents
the media is added to the desktop background. The object is added only if your
system is configured to mount the device automatically when media is detected.
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If your system is not configured to mount the device automatically, you must mount
the device manually. Double-click on This Computer and then double-click on the
icon that represents the media. For example, to mount a CD-ROM, click Launch, then
choose This Computer → CD-ROM.

Note – You cannot change the name of a removable media object.

To Display Media Contents on Linux
You can display media contents in any of the following ways:

� Double-click on the object that represents the media on the desktop background.

� Right-click on the object that represents the media on the desktop background,
then choose Open.

A file manager window displays the contents of the media. To reload the display, click
on the Reload button from the toolbar in a file browser window. Alternatively, choose
View → Reload to reload and update the view of the media contents in the window.

To Display Media Properties on Linux
To display the properties of removable media, right-click on the object that represents
the media on the desktop background, then choose Properties. A dialog displays the
properties of the media.

To close the properties dialog, click Close.

To Format a Floppy Diskette on Linux
To format media is to prepare the media for use with a particular file system. You can
use the file manager to format floppy diskettes.

Caution – When you format media, you overwrite any existing information on the
media.

To format a floppy diskette, perform the following steps:

1. Insert the diskette in the diskette drive. Mount the diskette. For information on
how to mount media, see “To Mount Media on Linux” on page 125.

2. Right-click on the object that represents the diskette on the desktop background,
then choose Format.
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3. Select your format options in the Floppy formatter dialog. The following table
describes the elements on the dialog:

Dialog Element Description

Floppy device Displays the name of the floppy device.

Floppy density Select the density of the diskette. The density is the
amount of data that the diskette can store.

File system type Select the type of file system in which you want to format
the diskette. Select one of the following options:
� Linux Native (ext 2): Select this option to format a

diskette for use on Linux systems. Most non-Linux
systems cannot read diskettes with this file system
type.

� DOS (FAT): Select this option to format a diskette for
use on Windows systems. Most UNIX-based systems
can read diskettes with this file system type.

Volume name Type a name for the diskette in this text box.

Quick Select this option to create only the file system on the
diskette. A quick format does not check for bad blocks.

Select this option if the diskette has been formatted before.

Standard Select this option to create the file system on the diskette
and format the diskette. A standard format does not check
for bad blocks.

Select this option if the diskette has not been formatted
before.

Thorough Select this option to create the file system on the diskette,
check for bad blocks, and format the diskette.

Select this option if you want to verify that the diskette has
not been damaged.

4. Click Format to format the diskette.

To Eject Media on Linux
To eject media, right-click on the media object on the desktop background, then choose
Eject. If the drive for the media is a motorized drive, the media is ejected from the
drive. If the drive for the media is not motorized, wait until the desktop background
object for the media disappears, then eject the media manually.
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You cannot eject media from a motorized drive when the media is mounted. To eject
media, first unmount the media. To remove a floppy diskette from the drive, perform
the following steps:

1. Close all file manager windows, Terminal windows, and any other windows that
access the diskette.

2. Right-click on the object that represents the diskette on the desktop background,
then choose Eject. The desktop background object for the diskette disappears.

3. Eject the diskette from the drive.

Caution – If you eject the diskette from the drive before you unmount the diskette,
you might lose the data on the diskette.
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CHAPTER 7

Using Your Desktop Background

This chapter describes how to use the desktop background to start applications, and
open your files and folders. The chapter also describes how to use the desktop
background menu, and how to customize the desktop background.

Introduction to the Desktop Background
The desktop background lies behind all of the other components on your visible
desktop. The desktop background is an active component of the user interface. You
can perform the following tasks from your desktop background:

� Start your applications, and open your files and folders.

You can add desktop objects for convenient access to files, folders, and applications
that you use frequently. For example, you can add an application launcher to the
desktop background. You can create a symbolic link to a file that you use often,
then add this link to your desktop background. You can also store files and folders
on the desktop background.

� Open the Desktop background menu.

Right-click on the desktop background to open the Desktop menu. You can use the
Desktop menu to perform actions on the desktop background.

� Work with Trash.

You can move objects to Trash and empty your Trash.

� Customize your desktop background.

You can customize the pattern or color of the desktop background.

By default, your desktop background contains five objects. Table 7–1 describes the
functions of the default objects on the desktop:
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TABLE 7–1 Functions of Default Desktop Background Objects

Object Function

This Computer Provides an access point to some of the key features of the
Java Desktop System. You can access your applications and
configuration tools from the This Computer location. You
can also access programs that enable you to configure your
system as a server, and to modify other system
configuration details.

Documents Enables direct access to files stored in your default directory.

Trash Provides a temporary holding area for files, folders or
desktop objects that you can later retrieve or permanently
delete.

Learn About The Java Desktop
System

Launches a help browser from where you can access Help
about the Java Desktop System.

Star Office 7 Launches the StarOffice application.

Desktop Background Objects
A desktop background object is an icon on your desktop background that you can use
to open your files, folders, and applications. You can also add objects to your desktop
background to provide convenient access to files, folders, applications, and URIs that
you use frequently. For example, you can add a launcher to your desktop background
to enable you to open a particular application that you use often.

Table 7–2 describes the types of object that you can add to your desktop background.

TABLE 7–2 Types of Desktop Background Objects

Object Type Description

Symbolic link A symbolic link is an object that points to another file or folder.
When you choose a symbolic link from the desktop background,
the file or folder that the symbolic link points to is opened. You
can move or copy a symbolic link to the desktop background.

You can identify symbolic links by the default arrow emblem
that appears on all symbolic links.

Launcher You can add the following types of launcher to the desktop
background:
� Application: Starts a particular application.
� Link: Links to a particular file, folder, or URI.

130 Java Desktop System Release 2 User Guide • July, 2004



TABLE 7–2 Types of Desktop Background Objects (Continued)
Object Type Description

File You can add files to your desktop background. Files on your
desktop background reside in your .desktop directory.

Folder You can move folders to your desktop background, and you can
create folders on your desktop background. Folders on your
desktop background reside in your .desktop directory.

The following sections describe how to work with objects on the desktop background.

To Select Objects on the Desktop Background
To select an object on the desktop background, click on the object. To select multiple
objects, press-and-hold Ctrl, then click on the objects that you want to select.

You can also select an area on the desktop background to select all objects within that
area. Click-and-hold on the desktop background, then drag over the area that contains
the objects that you want to select. When you click-and-hold then drag, a rectangle
appears to mark the area that you select.

To select multiple areas, press-and-hold Ctrl, then drag over the areas that you want to
select.

To Open an Object from the Desktop Background
To open an object from the desktop background, double-click on the object.
Alternatively, right-click on the object, then choose Open. When you open an object,
the default action for the object executes. For example, if the object is a text file, the
text file opens in a file manager window. The default actions for file types are specified
in the File Associations preference tool.

To execute an action other than the default action for an object, right-click on the
object, then choose Open With. Choose an action from the Open With submenu.

The items in the Open With submenu correspond to the contents of the following parts
of the File Associations preference tool:

� Default action drop-down list in the Edit file type dialog
� Viewer Component drop-down list in the Edit file type dialog

You can set your preferences in a file manager window so that you click once on a file
to execute the default action.
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To Add a Launcher to the Desktop Background
A desktop background launcher can start an application or link to a particular file,
folder, FTP site, or URI location.

To add a launcher to your desktop background, perform the following steps:

1. Right-click on the desktop background, then choose Create Launcher.

2. Type the required information in the Create Launcher dialog. The command that
you enter for the launcher is the command that is executed when you use the
desktop background object.

To Add a Symbolic Link to the Desktop
Background
You can create symbolic links on your desktop background to perform the following
actions:

� Open a particular file in a particular application.
� Open a particular folder in a file manager window.
� Run a binary file or a script.

To create a symbolic link on the desktop background, perform the following steps:

1. Display the file or folder for which you want to create a symbolic link in a file
manager window.

2. Create a symbolic link to the file or folder. To create a symbolic link to a file or
folder, select the file or folder to which you want to create a link. Choose Edit →
Make Link. A link to the file or folder is added to the current folder. You can
identify symbolic links by the default arrow emblem that appears on all symbolic
links. The following figure shows a symbolic link to a file:

3. Drag the symbolic link to the desktop background. The icon for the object is moved
to the desktop background.

Adding a File or Folder to the Desktop Background
The following sections describe how you can add file objects and folder objects to the
desktop background.
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To Move a File or Folder to the Desktop Background
You can move a file or folder from the file manager to the desktop background. To
move a file or folder to the desktop background, perform the following steps:

1. Open a file manager window.

2. Display the file or folder that you want to move.

3. Drag the file or folder to the desktop background. The icon for the file or folder is
moved to the desktop background. The file or folder is moved to your .desktop
directory.

Alternatively, select the file or folder, then choose Edit → Cut Files. Right-click on
any desktop background object, then choose Paste Files.

To Copy a File or Folder to the Desktop Background
You can copy a file or folder from the file manager to the desktop background. To copy
a file or folder to the desktop background, perform the following steps:

1. Open a file manager window.

2. Display the file or folder that you want to move.

3. Press-and-hold Ctrl, then drag the file or folder to the desktop background. An
icon for the file or folder is added to the desktop background. The file or folder is
copied to your .desktop directory.

Alternatively, select the file or folder, then choose Edit → Copy Files. Right-click on
any desktop background object, then choose Paste Files.

To Create a Folder Object on the Desktop Background
To create a folder object, right-click on the desktop background to open the Desktop
menu. Choose Create Folder. An untitled folder is added to the desktop background.
Type the name of the new folder, then press Return. The folder is displayed with the
new name. The new folder resides in your .desktop directory.

To Rename a Desktop Background Object
To rename a desktop background object, right-click on the object, then choose Rename.
The name of the desktop background object is highlighted. Type the new name for the
object, then press Return.

To Remove an Object from the Desktop
Background
To remove an object from the desktop background, right-click on the object, then
choose Move to Trash. Alternatively, drag the object to Trash.
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Note – When you move a file or folder from a removable media to Trash, the file or
folder is stored in a Trash location on the removable media. To remove the file or
folder permanently from the removable media, you must empty Trash.

To Delete an Object from the Desktop Background
When you delete an object from the desktop background, the object is not moved to
Trash, but is immediately deleted from the desktop background. The Delete menu
item is only available if you select the Include a Delete command that bypasses Trash
option in the file manager File Management Preferences dialog.

To delete an object from the desktop background, right-click on the object, then choose
Delete.

Note – You cannot delete the This Computer or Trash desktop background objects.

To View the Properties of a Desktop Background
Object
To view the properties of a desktop background object, perform the following steps:

1. Right-click on the object whose properties you want to view, then choose
Properties.

2. Use the properties dialog to view the properties of the desktop background object.

3. Click Close to close the properties dialog.

To Change the Permissions of a Desktop
Background Object
To change the permissions of a desktop background object, perform the following
steps:

1. Right-click on the object whose permissions you want to change, then choose
Properties.

2. Click on the Permissions tab in the properties dialog.

3. In the Permissions tabbed section, use the drop-down lists and check boxes to
change the permissions for the file or folder. For more information on the dialog
elements in the Permissions tabbed section, see Using Your File Manager.
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4. Click Close to close the properties dialog.

To Add an Emblem to a Desktop Background
Object
To add an emblem to a desktop background object, perform the following steps:

1. Right-click on the object to which you want to add an emblem, then choose
Properties.

2. Click on the Emblems tab in the Emblems tabbed section.

3. Select the emblem to add to the item.

4. Click Close to close the properties dialog.

To Add a Note to a Desktop Background Object
To add a note to a desktop background object, perform the following steps:

1. Select the object to which you want to add a note.

2. Choose File → Properties.

3. Click on the Notes tab in Notes tabbed section. Type the note.

4. Click Close to close the properties dialog. A note emblem is added to the desktop
background object.

To delete a note, delete the note text from the Notes tabbed section.

To Change the Icon for a Desktop Background
Object
To change the icon for desktop background object, perform the following steps:

1. Right-click on the object whose permissions you want to change, then choose
Properties.

2. On the Basic tabbed section, click on the Select Custom Icon button.

3. Use the Select an icon dialog to choose the icon to represent the file or folder.

4. Click Close to close the properties dialog.

To restore an icon from a custom icon to the default icon, click on the Remove Custom
Icon button on the Properties dialog.
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To Resize a Desktop Background Object Icon
You can change the size of the icon that represents a desktop background object. To
change the size of an icon on the desktop background, perform the following steps:

1. Right-click on the desktop background object whose icon you want to resize, then
choose Stretch Icon. A rectangle appears around the icon, with a handle at each
corner.

2. Grab one of the handles, then drag the icon to the size that you want.

To return the icon to the original size, right-click on the icon, then choose Restore
Icon’s Original Size.

Using Trash on the Desktop Background
You can move the following items to Trash:

� Files
� Folders
� Desktop background objects

If you need to retrieve a file from Trash, you can view Trash and move the file out of
Trash. When you empty Trash, you delete the items in Trash permanently.

To Display Trash
You can display the contents of Trash in the following ways:

� From the desktop background

Double-click on the Trash object on the desktop background. The contents of Trash
are displayed in a file manager window.

� From a file browser window

Choose Go → Trash. The contents of Trash are displayed in the file browser
window.

To Empty Trash
You can empty the contents of Trash in the following ways:

� From the desktop background

Right-click on the Trash object, then choose Empty Trash.
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� From a file manager window

Choose File → Empty Trash.

Using the Desktop Background Menu
To open the Desktop background menu, right-click on a vacant space on the desktop
background. You can use the Desktop menu to perform actions on the desktop
background.

Table 7–3 describes the items in the Desktop background menu.

TABLE 7–3 Items on the Desktop Background Menu

Menu Item Function

Open Terminal Starts a Terminal application.

Create Folder Creates a new folder object.

Create Launcher Creates a launcher on your desktop background. For more
information, see “To Add a Launcher to the Desktop
Background” on page 132.

Create Document Creates a document. You can create templates from
documents that you frequently create. For example, if you
often create invoices, you can create an empty invoice
document and save the document as invoice.doc in the
$HOME/Templates folder.

Clean Up By Name Arranges the objects on the desktop background
alphabetically by name.

Keep Aligned Ensures that the left edges of the objects on the desktop
background are aligned with one another.

Paste Files Puts file or files into a selected folder or the desktop
background.

Use Default Background Resets the desktop background to the last pattern that you
chose from the Backgrounds and Emblems dialog. You can
access the Backgrounds and Emblems dialog from Nautilus
windows.

Change Desktop Background Starts the Desktop Background preference tool.
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Changing the Pattern or Color of the
Desktop Background
You can change the pattern or color of the desktop background to suit your
preferences. The file manager includes background patterns and colors that you can
use to change the look-and-feel of the desktop background.

You can change the pattern or color of the desktop background in any of the following
ways:

� Drag a pattern or color from another window or dialog to the desktop background.

If your desktop background is a color, you can create a gradient effect from a color
into the desktop background color. A gradient effect is a visual effect where one
color blends gradually into another color. To create a gradient effect on your
desktop background, drag a color to one of the edges of the screen. The color
blends from the edge to which you drag the color, to the opposite edge of the
screen.

Before you drag a color to a screen edge, check if there is an edge panel on the
screen edge. If there is an edge panel on the screen edge, you must hide the panel
before you drag the color.

� Use the Desktop Background preference tool.

� Choose a pattern or color for the background from the Backgrounds and Emblems
dialog. To change the pattern or color of the desktop background, perform the
following steps:

1. Open a file manager window.

2. Choose Edit → Backgrounds and Emblems.

3. To display a list of patterns that you can use, click on the Patterns button in the
Backgrounds and Emblems dialog. To display a list of the colors that you can
use, click on the Colors button.

4. To change the desktop background to a pattern, drag the pattern to the desktop
background. To change the desktop background to a color, drag the color to the
desktop background.

5. Click Close.
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CHAPTER 8

Using Your Preference Tools

This chapter describes how to start and use the preference tools to customize the Java
Desktop System.

Starting a Preference Tool
You can start the preference tools in the following ways:

� Click Launch, then choose Preferences. Choose the tool that you require from the
submenus.

� Double-click on the This Computer object on the desktop background. A file
browser window opens at the This Computer location. Double-click on the
Preferences object in the browser window to display your preference tools.
Double-click on the tool that you require.

Customizing the Desktop Background
To access the Desktop Background preference tool, click Launch, then choose
Preferences → Desktop Preferences → Display → Desktop Background.

You can customize the desktop background in the following ways:

� Select an image for the desktop background. The image is superimposed on the
desktop background color. The desktop background color is visible if you select a
transparent image, or if the image does not cover the entire desktop background.

� Select a color for the desktop background. You can select a solid color, or create a
gradient effect with two colors. A gradient effect is a visual effect where one color
blends gradually into another color.
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You can also change the appearance of your desktop background from within the file
manager.

Table 8–1 lists the background preferences that you can modify.

TABLE 8–1 Desktop Background Preferences

Dialog Element Description

Desktop Wallpaper Choose an image to display on the desktop background. To choose
an image, click on the Select picture button. An image selector
dialog is displayed. Use the dialog to choose an image. When you
choose an image, click OK.

Style To specify how to display the image, select one of the following
options from the Style drop-down list:
� Centered: Displays the image in the middle of the desktop

background.
� Fill Screen: Enlarges the image to cover the desktop

background and maintains the relative dimensions of the image.
� Scaled: Enlarges the image until the image meets the screen

edges, and maintains the relative dimensions of the image.
� Tiled: Enlarges the image until the image meets the screen

edges, and maintains the relative dimensions of the image.

Add Wallpaper
Click on Add Wallpaper to display the Add Wallpapers dialog.
Choose the wallpaper that you want to appear as the background,
then click OK.

Remove Choose the Desktop Wallpaper that you want to remove, then click
Remove.
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TABLE 8–1 Desktop Background Preferences (Continued)
Dialog Element Description

Desktop Colors To specify a color scheme, use the options in the Background Style
drop-down list, and the color selector buttons.

You can specify a color scheme in one of the following ways:
� Choose Solid color from the Background Style drop-down list

to specify a single color for the desktop background.
To choose the color that you require, click on the Color button.
The Pick a Color dialog is displayed. Choose a color, then click
OK.

� Choose Horizontal gradient from the Background Style
drop-down list. This option creates a gradient effect from the
left screen edge to the right screen edge.
Click on the Left Color button to display the Pick a Color
dialog. Choose the color that you want to appear at the left
edge.
Click on the Right Color button. Choose the color that you want
to appear at the right edge.

� Choose Vertical gradient from the Background Style
drop-down list. This creates a gradient effect from the top screen
edge to the bottom screen edge.
Click on the Top Color button to display the Pick a Color
dialog. Choose the color that you want to appear at the top
edge.
Click on the Bottom Color button. Choose the color that you
want to appear at the bottom edge.

Configuring a CD Database Server
To access the CD Database Server preference tool, click Launch, then choose
Preferences → Desktop Preferences → CD Database Server.

The CD Database Server preference tool enables you to configure a CD database
server that your system can query. A CD database server contains information about
CDs, such as the name of the artist, the title, and the track list. When an application
plays a CD, the application can query the CD database server about the CD, then
display the information.

Table 8–2 describes the preferences in the CD Database Server preference tool.
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TABLE 8–2 CD Database Server Preferences

Dialog Element Description

Send no information Select this option if you do not want to send any information to the
CD database server.

Send real information Select this option to send your name and hostname information to
the CD database server.

Send other information Select this option to send another name and hostname to the CD
database server. Enter the name in the Name field. Enter the
hostname in the Hostname field.

FreeDB round robin
server

FreeDB is a CD database. The FreeDB round robin server is a
load-sharing configuration of FreeDB servers. Select this option to
access the FreeDB CD database from this server.

Other FreeDB server Select this option to access the FreeDB CD database from another
server. Select the server that you require from the server table.

Update Server List Click on this button to update the list of available FreeDB servers in
the server table.

Other server Select this option to use another CD database server. Enter the
name of the server on which the database resides in the Hostname
field. Enter the port number on which you can access the database
in the Port field.

Configuring File Associations
To access the File Associations preference tool, click Launch, then choose Preferences
→ Desktop Preferences → File Associations.

Use the File Associations preference tool to configure the following:

File types You can specify how files of various types are displayed and edited. For
example, you can specify an icon to represent a particular type of file.
For another example, you can specify that if a file is a plain text file, the
file is launched in a text editor.

The file manager and other desktop applications check the contents of a
file to determine the type of a file. If the first lines do not determine the
type of the file, then the application checks the filename.
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Services A Uniform Resource Identifier (URI) is a string that identifies a particular
location in a file system or on the Web. For example, the web address of
a web page is a URI. A service is a protocol or task that a URI requests.
For example, the http://www.gnome.org URI requests the http
service.

You can associate an application with a service, so that the application
performs the task required by the service. For example, you can
associate your preferred web browser with the http service.

Table 8–3 describes the elements on the File Associations preference tool.

TABLE 8–3 Elements on File Associations Preference Tool

Element Description

Table To view the contents of a category of file types, click on the right
arrow next to the category name. The category expands, and
displays a description of each file type, and the file extension that is
associated with the file type.

To select a file type that you want to work with, click on the file
type.

Add File Type Click on this button to add a file type. For more information, see
“To Add a File Type” on page 143.

Add Service Click on this button to add a service. For more information, see “To
Add a Service” on page 144.

Edit To edit a file type, a service, or a file type category, select the item
that you want to edit, then click Edit.

Remove To delete a file type or a service, select the item that you want to
delete, then click Remove.

To Add a File Type
To add a file type, perform the following steps:

1. Start the File Associations preference tool.

2. Click on the Add File Type button.

3. Enter the properties of the file type in the Add File Type dialog. The following
table describes the dialog elements of the Add File Type dialog:
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Dialog Element Description

No Icon Choose an icon to represent the file type. To choose an
icon, click on the No Icon button. An icon selector
dialog is displayed. Choose an icon from the dialog.
Alternatively, to choose an icon from another directory,
click Browse. When you choose an icon, click OK.

Description Type a description of the file type.

MIME type Enter the MIME type for this type of file.

Category Enter the category to which you want the file type to
belong in this preference tool. Click on the Choose to
choose a category from the Choose a file category
dialog.

Filename extensions Enter the file extensions to associate with the file type.
Enter a file extension in the field on the left side, then
press Return. To delete a file extension, select the file
extension in the field on the right side, then click on the
Remove button.

Viewer component Select the viewer component to use to display files of
this type in the file manager.

Default action Select the default application to use to open files of this
type.

Program to run Specify a program to associate with the file type. Enter
the command to start the program in this field.
Alternatively, to choose a command that you entered
previously, click the down arrow button, then choose
the command to run.

You can also use the Browse button to choose a
command to run.

Run in Terminal Select this option to run the program in a terminal
window. Choose this option for a program that does not
create a window in which to run.

4. Click OK.

To Add a Service
To add a service, perform the following steps:

1. Start the File Associations preference tool.

2. Click on the Add Service button.

3. Enter the properties of the service in the Add Service dialog. The following table
describes the dialog elements on the Add Service dialog:
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Dialog Element Description

Description Type a description of the service.

Protocol Enter the protocol for the service.

Program to Run Information to be supplied in a future release.

Program Specify the program to associate with the service.
Enter the command to start the program in this
field. Alternatively, to choose a command that you
entered previously, click the down arrow button,
then choose the command to run.

You can also use the Browse button to choose a
command to run.

Run in Terminal Select this option to run the program in a terminal
window. Choose this option for a program that does
not create a window in which to run.

4. Click OK.

Setting File Management Preferences
You can customize your file management to suit your requirements and preferences.
This section describes how to customize your file management r preferences.

Setting Your Preferences
To access the File Management preference tool, click Launch, then choose Preferences
→ Desktop Preferences → File Management.

Alternatively, you can use the File Management Preferences dialog to set preferences
for the file manager. To display the File Management Preferences dialog, choose Edit
→ Preferences from any file browser window.

You can set preferences in the following categories:

� The default settings for views.
� The behavior of files and folders, executable text files, and Trash.
� The information that is displayed in icon captions.
� Preview options to improve the performance of the file manager.
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To Set Views Preferences
You can specify a default view, and select sort options and display options. You can
also specify default settings for icon views and list views. To specify your default view
settings, choose Edit → Preferences. Click on the Views tab to display the Views
tabbed section.

Table 8–4 lists the views preferences that you can modify.

TABLE 8–4 Views Preferences

Dialog Element Description

View new folders using Select the default view for folders. When you open a folder,
the folder is displayed in the view that you select.

Arrange items Select the characteristic by which you want to sort the items
in folders that are displayed in this view.

Sort folders before files Select this option to list folders before files when you sort a
folder.

Show hidden and backup files Select this option to display hidden files and backup files in
the view pane. The first character in a hidden filename is a
period (.). The last character in a backup filename is a tilde
(~).

You can hide files from the view pane by adding .hidden
extension to the filename.

Default zoom level Icon view and list view. Select the default zoom level for
folders that are displayed in this view. The zoom level
specifies the size of items in a view.

Use compact layout Select this option to arrange the items in icon view so that
the items in the folder are closer to each other.

Text beside icons Select this option to place the icon captions for items beside
the icon rather than under the icon.

Show only folders Select this option to display only folders in the Tree in the
side pane.

To Set Behavior Preferences
To set your preferences for files and folders, choose Edit → Preferences. Click on the
Behavior tab to display the Behavior tabbed section.

Table 8–5 lists the preferences that you can modify for files and folders.
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TABLE 8–5 File and Folder Behavior Preferences

Option Description

Single click to activate items Select this option to perform the default action for an item
when you click on the item. When this option is selected,
and you point to an item, the title of the item is underlined.

Double click to activate items Select this option to perform the default action for an item
when you double-click on the item.

Run executable files when they
are clicked

Select this option to run an executable file when you choose
the executable file. An executable file is a text file that can
execute, that is, a shell script.

View executable files when
they are clicked

Select this option to display the contents of an executable
file when you choose the executable file.

Ask each time Select this option to display a dialog when you choose an
executable file. The dialog asks whether you want to execute
the file or display the file.

Ask before emptying the Trash
or deleting files

Select this option to display a confirmation message before
Trash is emptied, or files are deleted.

Include a Delete command that
bypasses Trash

Select this option to add a Delete menu item to the
following menus:
� The Edit menu.
� The popup menu that is displayed when you right-click

on a file, folder, or desktop background object.

When you select an item then choose the Delete menu item,
the item is deleted from your file system immediately.

To Set Icon Captions Preferences
An icon caption displays the name of a file or folder in an icon view. The icon caption
also includes three additional items of information on the file or folder. The additional
information is displayed after the file name. Normally only one item of information is
visible, but when you zoom in on an icon, more of the information is displayed. You
can modify what additional information is displayed in icon captions.

To set your preferences for icon captions, choose Edit → Preferences. Click on the Icon
Caption tab to display the Icon Caption tabbed section.

Select the items of information that you want to display in the icon caption from the
three drop-down lists. Select the first item from the first drop-down list, select the
second item from the second drop-down list, and so on. The following table describes
the items of information that you can select:
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Information Description

Size Choose this option to display the size of the item.

Type Choose this option to display the description of the MIME
type of the item from the File Types and Programs
preference tool.

Date modified Choose this option to display the last modification date of
the item.

Date accessed Choose this option to display the date that the item was last
accessed.

Owner Choose this option to display the owner of the item.

Group Choose this option to display the group to which the item
belongs.

Permissions Choose this option to display the permissions of the item as
three sets of three characters, for example -rwxrw-r--.

Octal permissions Choose this option to display the permissions of the item in
octal notation, for example 764.

MIME type Choose this option to display the MIME type of the item.

None Choose this option to display no information for the item.

To Set List Columns Preferences
You can specify what information is displayed in list view in file manager windows.
You can specify which columns are displayed in list view, and the order in which the
columns are displayed.

To set your preferences for list columns, choose Edit → Preferences. Click on the List
Columns tab to display the List Columns tabbed section.

To specify a column to display in list view, select the option that corresponds to the
column, then click on the Show button. To remove a column from the list view, select
the option that corresponds to the column, then click on the Hide button.

Use the Move Up and Move Down buttons to specify the position of columns in list
view.

To use the default columns and column positions, click on the Use Default button.

The following table describes the columns that you can display:
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Information Description

Name Select this option to display the name of the item.

Size Select this option to display the size of the item.

Type Select this option to display the description of the MIME
type of the item from the File Types and Programs
preference tool.

Date Modified Select this option to display the last modification date of the
item.

Date Accessed Select this option to display the date that the item was last
accessed.

Group Select this option to display the group to which the item
belongs.

MIME type Select this option to display the MIME type of the item.

Octal Permissions Select this option to display the permissions of the item in
octal notation, for example 764.

Owner Select this option to display the owner of the item.

Permissions Select this option to display the permissions of the item as
three sets of three characters, for example -rwxrw-r--.

To Set Preview Preferences
The file manager include some file preview features. The preview features can affect
the speed with which the file manager responds to your requests. You can modify the
behavior of some of these features to improve the speed of the file manager. For each
preview preference, you can select one of the options described in the following table:

Option Description

Always Performs the action for both local files, and files on other file
systems.

Local Files Only Performs the action for local files only.

Never Never performs the action.

To set your preview preferences, choose Edit → Preferences. Click on the Preview tab
dialog to display the Preview tabbed section.

Table 8–6 lists the preview preferences that you can modify.
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TABLE 8–6 Preview Preferences

Dialog Element Description

Show text in icons Select an option to specify when to preview the content of
text files in the icon that represents the file.

Show thumbnails Select an option to specify when to show thumbnails of
image files. The file manager stores the thumbnail files for
each folder in a .thumbnails directory that is one level
below the folder.

Only for files smaller than Specify the maximum file size for files for which the file
manager creates a thumbnail.

Preview sound files Select an option to specify when to preview sound files.

Count number of items Select an option to specify when to show the number of
items in folders. If you have set your view to icon view, you
might need to increase your default zoom level in the Views
tabbed section to see the number of items in each folder.

Changing Backgrounds
The file manager includes backgrounds that you can use to change the look-and-feel of
the following screen components:

� Desktop
� Side pane and view pane of file browser windows
� Panels

To change the background of a screen component perform the following steps:

1. Choose Edit → Backgrounds and Emblems.

2. To display a list of patterns that you can use on the background, click on the
Patterns button in the Backgrounds and Emblems dialog. To display a list of the
colors that you can use on the background, click on the Colors button.

3. To change the background to a pattern, drag the pattern to the screen component.
To change the background to a color, drag the color to the screen component.

4. Click Close.

To reset the background of the view pane or side pane to the default background,
right-click on the background of the pane, then choose Use Default Background.

When you change the background of the side pane or the view pane of a particular
folder, the file manager remembers the background that you chose. The next time that
you display the folder, the background that you selected is displayed. In other words,
when you change the background of a folder, you customize the folder to display the
background.
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To Add a Pattern
To add a pattern to the patterns that you can use on your screen components, choose
Edit → Backgrounds and Emblems. Click on the Patterns button, then click on the Add
a New Pattern button. A dialog is displayed. Use the dialog to find the new pattern.
Click OK to add the new pattern to the Backgrounds and Emblems dialog.

To Add a Color
To add a color to the colors that you can use on your screen components, choose Edit
→ Backgrounds and Emblems. Click on the Colors button, then click on the Add a
New Color button. A color selector dialog is displayed. Use the color wheel or the
sliders to choose the color. Click OK to add the new color to the Backgrounds and
Emblems dialog.

Choosing Default Fonts
To access the Fonts preference tool, click Launch, then choose Preferences → Desktop
Preferences → Display → Fonts.

Use the Fonts preference tool to select the fonts to use in your applications, windows,
terminals, and desktop background.

Table 8–7 lists the font preferences that you can modify.

TABLE 8–7 Font Preferences

Dialog Element Description

Application font Click on the font selector button to select a font to use in your
applications.

Desktop font Click on the font selector button to select a font to use on your
desktop background only.

Window title font Click on the font selector button to select a font to use in the
titlebars of your windows.

Terminal font Click on the font selector button to select a font to use in the
Terminal application
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TABLE 8–7 Font Preferences (Continued)
Dialog Element Description

Font Rendering To specify how to render fonts on your screen, select one of the
following options:
� Monochrome: Renders fonts in black and white only. The

edges of characters might appear jagged in some cases
because the characters are not antialiased. Antialiasing is an
effect that is applied to the edges of characters to make the
characters look smoother.

� Best shapes: Antialiases fonts where possible. Use this option
for standard Cathode Ray Tube (CRT) monitors.

� Best contrast: Adjusts fonts to give the sharpest possible
contrast, and also antialiases fonts, so that characters have
smooth edges. This option might enhance the accessibility of
the Java Desktop System to users with visual impairments.

� Subpixel smoothing (LCDs): Uses techniques that exploit the
shape of individual Liquid Crystal Display (LCD) pixels to
render fonts smoothly. Use this option for LCD or flat-screen
displays.

Details Click on this button to specify further details of how to render
fonts on your screen.
� Resolution (dots per inch): Use the spin box to specify the

resolution to use when your screen renders fonts.
� Smoothing: Select one of the options to specify how to

antialias fonts.
� Hinting: Hinting is a font-rendering technique that improves

the quality of fonts at small sizes and an at low screen
resolutions. Select one of the options to specify how to apply
hinting to your fonts.

� Subpixel order: Select one of the options to specify the
subpixel color order for your fonts. Use this option for LCD or
flat-screen displays.

Configuring Input Methods
To access the Input Method preference tool, click Launch, then choose Preferences →
Desktop Preferences → Input Methods.

Input Methods are software components that enables you to enter text in ways other
than typing on a keyboard. Input Methods are commonly used to enter text for
languages using thousands of different characters in keyboards with far fewer keys.
Input Methods are mostly associated with languages such as Japanese, Chinese, and
Korean.
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Use the Input Methods preference tool to configure integral and multilingual input
method capabilities.

Table 8–8 describes the elements on the Input Methods preference tool.

TABLE 8–8 Input Methods Preference Tool

Element Description

Enable Input Methods Select this option to enable input method features. When you select
this option, all options in the Input Preference dialog become
available for selection. Changes to this option immediately takes
effect in your current session.

Enable Language Status
Bar

Select this option to make the input method status bar visible.

Placement Select from the drop-down list where to place the language status
bar. You can choose from the following:

On the desktop panel

Attached to application frames

Enable Lookup Choice
Window

Select this option to use a candidate choice window. When you
select this option, input methods displays a pop-up window that
list characters that you can choose to commit to the application
window.

Configuring Your Internet Connection
To access the Internet preference tool, click Launch, then choose Preferences →
Desktop Preferences → Internet.

The Internet preference tool enables you to configure how your system connects to the
Internet. You can configure the Java Desktop System to connect to a proxy server, and
specify the details of the proxy server. A proxy server is a server that intercepts
requests to another server, and fulfills the request itself, if it can. You can enter the
Domain Name Service (DNS) name or the Internet Protocol (IP) address of the proxy
server. A DNS name is a unique alphabetic identifier for a computer on a network. An
IP address is a unique numeric identifier for a computer on a network.

Table 8–9 lists the proxy configuration preferences that you can modify.
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TABLE 8–9 Internet Preferences

Dialog Element Description

Direct internet connection Select this option if you want to connect directly to the
Internet, without a proxy server.

Manual proxy configuration Select this option if you want to connect to the Internet
through a proxy server, and you want to configure the
proxy server manually.

HTTP proxy Enter the DNS name, or the IP address of the proxy server
to use when you request a HTTP service. Enter the port
number of the HTTP service on the proxy server in the Port
spin box.

Secure HTTP proxy Enter the DNS name, or the IP address of the proxy server
to use when you request a Secure HTTP service. Enter the
port number of the Secure HTTP service on the proxy server
in the Port spin box.

FTP proxy Enter the DNS name, or the IP address of the proxy server
to use when you request a FTP service. Enter the port
number of the FTP service on the proxy server in the Port
spin box.

Socks host Enter the DNS name, or the IP address of the Socks host to
use. Enter the port number for the Socks protocol on the
proxy server in the Port spin box.

Automatic proxy configuration Select this option if you want to connect to the Internet
through a proxy server, and you want to configure the
proxy server automatically.

Autoconfiguration URL Enter the URL that contains the information required to
configure the proxy server automatically.

Configuring Keyboard Accessibility
Options
To access the Keyboard accessibility preference tool, click Launch, then choose
Preferences → Accessibility → Keyboard.

Use the Keyboard accessibility preference tool to set the keyboard accessibility
preferences. The Keyboard accessibility preference tool is also known as AccessX.

You can customize the preferences for the keyboard accessibility in the following
functional areas:
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� Basic
� Filters
� Mouse

Basic Preferences
Table 8–10 lists the basic keyboard accessibility preferences that you can modify.

TABLE 8–10 Keyboard Accessibility Preferences

Dialog Element Description

Enable keyboard
accessibility features

Select this option to enable keyboard accessibility features. When you
select this option, the other options in the preference tool become
available.

Disable if unused for Select this option to deactivate keyboard accessibility preferences if
the keyboard is not used for a specified period of time. Use the slider
to specify the number of seconds of keyboard idle time required
before the system disables the keyboard accessibility preferences.
When the specified number of seconds elapses, the following
keyboard accessibility preferences are disabled:
� Bounce keys
� Mouse keys
� Slow keys
� Sticky keys
� Toggle keys

Beep when features
turned on or off from
keyboard

Select this option for an audible indication when a feature such as
sticky keys or slow keys is activated, or deactivated.

Import Feature Settings Click on this button to import an AccessX configuration file.

Enable Sticky Keys Select this option to perform multiple simultaneous keypress
operations by pressing the keys in sequence. Alternatively, to enable
the sticky keys feature, press Shift five times.

You can set the following sticky keys preferences:
� Beep when modifier is pressed: Select this option for an audible

indication when you press a modifier key.
� Disable if two keys pressed together: Select this option to specify

that when you press two keys simultaneously, you can no longer
press keys in sequence to perform multiple simultaneous
keypresses.
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TABLE 8–10 Keyboard Accessibility Preferences (Continued)
Dialog Element Description

Repeat Keys Select this option to enable the autorepeat settings for your keyboard.
You can set the following autorepeat preferences:
� Delay: Use the slider or the spin box to specify the interval to wait

after the first keypress before the automatic repeat of a pressed
key.

� Speed: Use the slider or the spin box to specify the number of
characters per second to enter.

Type to test settings The test area is an interactive interface so you can see how the
keyboard settings affect the display as you type. Type text in the test
area to test the effect of your settings.

For more information on configuring basic keyboard accessibility preferences, see the
Java Desktop System Release 2 Accessibility Guide.

Filter Preferences
Table 8–11 lists the filter preferences that you can modify.

TABLE 8–11 Filter Preferences

Dialog Element Description

Enable keyboard
accessibility features

Select this option to enable keyboard accessibility features. When you
select this option, the other options in the preference tool become
available.

Enable Slow Keys Select this option to control the period of time that you must
press-and-hold a key before acceptance. Alternatively, to enable the
slow keys feature, press-and-hold Shift for eight seconds.

You can set the following slow keys preferences:
� Only accept keys held for: Use the slider or the spin box to

specify the period of time that you must press-and-hold a key
before acceptance.

� Beep when key is: Select the appropriate option or options for an
audible indication when a key is pressed, accepted, or rejected.
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TABLE 8–11 Filter Preferences (Continued)
Dialog Element Description

Enable Bounce Keys Select this option to accept a key input and to control the key repeat
characteristics of the keyboard. You can set the following bounce keys
preferences:
� Ignore duplicate keypresses within: Use the slider or the spin

box to specify the interval to wait after the first keypress before
the automatic repeat of a pressed key.

� Beep if key is rejected: Select this option for an audible indication
of key rejection.

Enable Toggle Keys Select this option for an audible indication of a toggle keypress. You
hear one beep when a toggle key is turned on. You hear two beeps
when a toggle key is turned off.

Type to test settings The test area is an interactive interface so you can see how the
keyboard settings affect the display as you type. Type text in the test
area to test the effect of your settings.

For more information on configuring filter accessibility preferences, see the Java
Desktop System Release 2 Accessibility Guide.

Mouse Preferences
Table 8–12 lists the mouse preferences that you can modify.

TABLE 8–12 Mouse Preferences

Dialog Element Description

Enable keyboard
accessibility features

Select this option to enable keyboard accessibility features. When you
select this option, the other options in the preference tool become
available.

Enable Mouse Keys Select this option to make the numeric keypad emulate mouse
actions. You can set the following mouse key preferences:
� Maximum pointer speed: Use the slider or the spin box to specify

the maximum speed that the pointer moves across the screen.
� Time to accelerate to maximum speed: Use the slider or the spin

box to specify the duration of the acceleration time of the pointer.
� Delay between keypress and pointer movement: Use the slider

or the spin box to specify the period of time that must pass after a
keypress before the pointer moves.

Mouse Preferences Click on this button to open the Mouse preference tool.

For more information on configuring the mouse accessibility preferences, see the Java
Desktop System Release 2 Accessibility Guide.
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Configuring Keyboard Behavior
Preferences
To access the Keyboard preference tool, click Launch, then choose Preferences →
Desktop Preferences → Keyboard → Behavior.

Use the Keyboard Behavior preference tool to modify the autorepeat preferences for
your keyboard, and to configure typing break settings.

You can set the preferences for the Keyboard Behavior preference tool in the following
functional areas:

� Keyboard
� Typing Break
� Layouts
� Layout Options

Keyboard Preferences
Use the Keyboard tabbed section to set general keyboard preferences. To start the
Keyboard accessibility preference tool, that is, AccessX, click on the Accessibility
button.

Table 8–13 lists the keyboard preferences that you can modify.

TABLE 8–13 Keyboard Preferences

Dialog Element Description

Key presses repeat when
key is held down

Select this option to enable keyboard repeat. If keyboard repeat is
enabled, when you press-and-hold a key, the action associated
with the key is performed repeatedly. For example, if you
press-and-hold a character key, the character is typed repeatedly.

Delay Select the delay from the time you press a key to the time that the
action repeats.

Speed Select the speed at which the action is repeated.

Cursor blinks in text
boxes and fields

Select this option to enable the cursor to blink in fields and text
boxes.

Speed Use the slider to specify the speed at which the cursor blinks in
fields and text boxes.
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TABLE 8–13 Keyboard Preferences (Continued)
Dialog Element Description

Type to test settings The test area is an interactive interface so you can see how the
keyboard settings affect the display as you type. Type text in the
test area to test the effect of your settings.

Typing Break Preferences
Use the Typing Break tabbed section to set typing break preferences. To start the
Keyboard accessibility preference tool, that is, AccessX, click on the Accessibility
button.

Table 8–14 lists the typing break preferences that you can modify.

TABLE 8–14 Typing Break Preferences

Dialog Element Description

Lock screen to enforce typing break Select this option to lock the screen when you
are due a typing break.

Work interval lasts Use the spin box to specify how long you can
work before a typing break occurs.

Break interval lasts Use the spin box to specify the length of your
typing breaks.

Allow postponing of breaks Select this option if you want to be able to
postpone typing breaks.

Keyboard Layout
Use the Layouts tabbed section to set your keyboard layout. Select your keyboard
model from the drop-down list. Use the navigational buttons to add or remove a
selected layout from the list of available layouts.

You can choose different layouts to suit different locales.

To start the Keyboard accessibility preference tool, that is, AccessX, click on the
Accessibility button.

Keyboard Layout Options
Use the Layout Options tabbed section to set your keyboard layout options. Select an
option from the list of available layout options and click Add to select an option. Use
Remove to remove a selected option.
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To start the Keyboard accessibility preference tool, that is, AccessX, click on the
Accessibility button.

Customizing Menus and Toolbars in
Applications
To access the Menus & Toolbars preference tool, click Launch, then choose
Preferences → Desktop Preferences → Display → Menus & Toolbars.

You can use the Menus & Toolbars preference tool to customize the appearance of
menus, menubars, and toolbars for GNOME-compliant applications.

Table 8–15 lists the menu and toolbar preferences that you can modify for
GNOME-compliant applications.

TABLE 8–15 Menu and Toolbar Preferences

Dialog Element Description

Show icons in menus Select this option to display an icon beside each item in a menu.
Some menu items do not have an icon.

Detachable toolbars Select this option if you want to move toolbars from application
windows to any location on the screen. If you select this option,
handles are displayed on the left side of the toolbars in your
applications. To move a toolbar, click-and-hold on the handle, then
drag the toolbar to the new location.

Toolbar button labels Choose one of the following options to specify what to display on
the toolbars in your GNOME-compliant applications:
� Text below icons: Select this option to display toolbars with text

as well as an icon on each button.
� Text beside icons: Select this option to display toolbars with an

icon only on each button, and with text on the most important
buttons.

� Icons only: Select this option to display toolbars with an icon
only on each button.

� Text only: Select this option to display toolbars with text only
on each button.
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Setting Mouse Preferences
To access the Mouse preference tool, click Launch, then choose Preferences → Desktop
Preferences → Mouse.

Use the Mouse preference tool to configure your mouse for right-hand use or for
left-hand use. You can also specify the speed and sensitivity of mouse movement.

You can customize the settings for the Mouse preference tool in the following
functional areas:

� Buttons
� Cursors
� Motion

Buttons Preferences
Use the Buttons tabbed section to specify whether the mouse buttons are configured
for left-hand use. You can also specify the delay between clicks for a double-click.

Table 8–16 lists the mouse button preferences that you can modify.

TABLE 8–16 Mouse Button Preferences

Dialog Element Description

Left-handed mouse Select this option to configure your mouse for left-hand use.
When you configure your mouse for left-hand use, the functions
of the left mouse button and the right mouse button are swapped.

Timeout Use the slider to specify the amount of time that can pass between
clicks when you double-click. If the interval between the first and
second clicks exceeds the time that is specified here, the action is
not interpreted as a double-click.

Pointer Preferences
Use the Cursors tabbed section to set your mouse pointer preferences.

Table 8–17 lists the mouse pointer preferences that you can modify:
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TABLE 8–17 Mouse Pointer Preferences

Dialog Element Description

Small Select this option to display a small mouse
pointer.

Medium Select this option to display a medium mouse
pointer.

Large Select this option to display a large mouse
pointer.

Highlight the pointer when you press Ctrl Select this option to enable a mouse pointer
animation when you press and release Ctrl.
This feature can assist you to locate the mouse
pointer.

Motion Preferences
Use the Motion tabbed section to set your preferences for mouse movement.

Table 8–18 lists the mouse motion preferences that you can modify:

TABLE 8–18 Mouse Motion Preferences

Dialog Element Description

Acceleration Use the slider to specify the speed at which your mouse pointer
moves on your screen when you move your mouse.

Sensitivity Use the slider to specify how sensitive your mouse pointer is to
movements of your mouse.

Threshold Use the slider to specify the distance that you must move an item
before the move action is interpreted as a drag-and-drop action.

Customizing Your Panels
To access the Panel preference tool, click Launch, then choose Preferences → Desktop
Preferences → Panel.

The Panel preference tool enables you to configure the behavior of panels. Any
changes that you make with the Panel preference tool affect all of your panels.

Table 8–19 lists the panel preferences that you can modify:

162 Java Desktop System Release 2 User Guide • July, 2004



TABLE 8–19 Panel Preferences

Dialog Element Description

Close drawer when launcher is clicked Select this option if you want a drawer on a
panel to close when you choose a launcher in
the drawer.

Drawer and panel animation Select this option if you want your panels and
drawers to show and to hide in an animated
style.

Animation speed Select the speed of the panel animation from
the drop-down list.

Configuring PDA Devices
To access the PDA Devices preference tool, click Launch, then choose Preferences →
Desktop Preferences → PDA Devices.

A personal digital assistant (PDA) is a hand-held computer that you can use as a
personal organizer. You can store appointments, tasks, contacts, and other information
on your PDA. You can also transfer this information between your PDA and
applications in the Java Desktop System. For example, you can copy your calendar
appointments from your PDA to Ximian Evolution, and from Evolution to your PDA.

When you transfer data between your PDA and your computer, you perform a
HotSync operation. The actions that occur during a HotSync operation are controlled by
conduits. A conduit is an application that manages the transfer of data between your
computer and your PDA.

One of the actions that you can specify for a conduit is to merge data between your
PDA and your computer. This is called a synchronize action. For example, you might
add contact information to your PDA, then add different contact information in
Evolution. You want to add the contact information on your PDA to Evolution, and
you want to add the contact information in Evolution to your PDA. To do this, you
must synchronize the data between your PDA and Evolution.

The PDA Devices preference tool enables you to configure a PDA to work with the
Java Desktop System, and to modify PDAs that you have already configured. You can
perform the following tasks with the PDA Devices preference tool:

� Configure a PDA.

� Modify the configuration of a PDA.

� Configure how PDAs can connect to your computer.

� Modify how PDAs can connect to your computer.
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� Configure how conduits transfer data between your PDA and applications in the
Java Desktop System.

A background application waits for a PDA to attempt to synchronize with your
computer. This background application is called the PDA daemon. When a PDA
attempts to synchronize with the computer, the PDA daemon synchronizes the data on
the PDA with data on the computer.

Tip – gnome-pilot displays the activity of the PDA daemon. To add gnome-pilot to a
panel, right-click on the panel, then choose Add to Panel → Utility → PDA Monitor.
For more information about gnome-pilot, see the gnome-pilot Applet Manual.

To Configure a PDA
You can configure a PDA in one of the following ways:

� Use the Gnome Pilot Settings assistant. If you have not configured a PDA on your
computer previously, the Gnome Pilot Settings assistant is displayed when you
start the PDA Devices preference tool. The Gnome Pilot Settings assistant guides
you through the configuration process for a PDA.

� Use the PDA Devices preference tool. If you have configured a PDA on your
computer previously, the Pilot Settings dialog is displayed when you start the
PDA Devices preference tool. Use the Pilot Settings dialog to enter details for the
PDA.

To Use an Assistant to Configure a PDA
To configure a PDA, perform the following steps:

1. Connect your PDA to your computer. If your PDA has a cradle, place the PDA in
the cradle.

2. Click Launch, then choose Preferences → PDA Devices to start the PDA Devices
preference tool. A Gnome Pilot Settings assistant is displayed. Click on the Forward
button to begin the configuration process.

3. Enter information about how the PDA connects to your computer in the Cradle
Settings page. The following table describes the settings in the Cradle Settings
page:

Element Description

Name Type a name for the connection in the text box.
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Element Description

Port Enter a port for the connection in the drop-down
combination box. For example, if your PDA uses a Universal
Serial Bus (USB) port, you might enter /dev/ttyUSB1 in
this field. If the PDA does not connect properly, you might
need to try another port.

The default value for the Port field is /dev/pilot. If you
do not want to change the default value in this field, you can
make a symbolic link from the port that the PDA uses to
/dev/pilot. For example, if your PDA uses a USB port,
run a command similar to the following command:

# ln -s /dev/ttyUSB1 /dev/pilot

Note – You must have the appropriate permissions to access
the port that you specify. If you do not have the appropriate
permissions, contact your system administrator.

Speed Select the speed of the connection from the drop-down list.

Tip – Select the lowest speed. When you are sure that the
connection to the PDA works reliably at the lowest speed,
select the next highest speed. Continue to do this until you
find the highest speed at which the connection to the PDA
works reliably.

Timeout Use the spin box to specify the number of minutes for the
connection to be idle before the connection is broken.

Type Select the type of port from the radio buttons. Select from
the following options:
� Serial: Select this option for a serial port.
� USB: Select this option for a USB port.
� IrDA: Select this option for an infrared port.
� Network: Select this option for a network connection

port.

When you complete the connection information, click on the Forward button.

4. Enter identity information for the PDA in the Pilot Identification page. The
following table describes the elements in the Pilot Identification page:

Element Description

Yes, I’ve used sync software with this pilot
before

Select this option if you have set the
username and identifier on this PDA
previously. If you configure a PDA with a
computer, the username and ID are set on
the PDA.
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Element Description

No, I’ve never used sync software with this
pilot before

Select this option if you have not set the
username and identifier on this PDA
previously.

User Name If you have not set the username and
identifier on this PDA previously, type the
username in this text box.

ID If you have not set the username and
identifier on this PDA previously, type the
identifier in this text box. This identifier
must be unique between different PDAs that
you use.

When you complete the identity information, click on the Forward button. An
Initial Sync page is displayed.

5. Press the HotSync button on your PDA. Depending on the option you selected on
the Pilot Identification page, the Gnome Pilot Settings assistant does one of the
following:

� If you selected the Yes, I’ve used sync software with this pilot before option,
the Gnome Pilot Settings assistant gets the username and identifier that is
currently registered on the PDA from the PDA.

� If you selected the No, I’ve never used sync software with this pilot before
option, the Gnome Pilot Settings assistant sets the username and identifier on
the PDA to the values in the User Name text box and ID text box.

When the initial synchronization is complete, click on the Forward button. A Pilot
Attributes page is displayed.

6. Enter name and directory information for the PDA in the Pilot Attributes page.
The following table describes the settings in the Pilot Attributes page:

Element Description

Pilot Name Type a name for the PDA. This name is used to identify the
PDA to you in the user interface.

Local basedir Enter the directory where you want to store your PDA data.

When you complete the name and directory information, click on the Forward
button.

7. Click on the Apply button on the Success page to close the Gnome Pilot Settings
assistant.

Alternatively, click on the Cancel button to cancel configuration of the PDA.
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To Use the PDA Devices Preference Tool to Configure a
PDA
Perform the following steps:

1. Click Launch, then choose Preferences → PDA Devices to start the PDA Devices
preference tool.

2. In the Pilots tabbed section on the Pilot Settings dialog, click on the Add button. A
Pilot Settings dialog is displayed.

3. To receive the username and identifier from the PDA, click on the Get from pilot
button. To assign a username and identifier to the PDA, type the username and
identifier in the text boxes, then click on the Send to pilot button.

4. Enter name and directory information for the PDA in the Pilot Name and Local
basedir fields. For more information on the fields, see “To Use an Assistant to
Configure a PDA” on page 164.

To Modify a PDA
Perform the following steps:

1. Click Launch, then choose Preferences → PDA Devices to start the PDA Devices
preference tool.

2. In the Pilots tabbed section on the Pilot Settings dialog, select the PDA that you
want to modify, then click on the Edit button. A Pilot Settings dialog is displayed.

3. To receive the username and identifier from the PDA, click on the Get from pilot
button. To assign a username and identifier to the PDA, type the username and
identifier in the text boxes, then click on the Send to pilot button.

4. Enter name and directory information for the PDA in the Pilot Name and Local
basedir fields. For more information on the fields, see “To Use an Assistant to
Configure a PDA” on page 164.

5. Click OK on the Pilot Settings dialog.

To Configure How PDAs Can Connect to Your
Computer
Perform the following steps:

1. Click Launch, then choose Preferences → PDA Devices to start the PDA Devices
preference tool.

2. In the Devices tabbed section on the Pilot Settings dialog, click on the Add button.

3. Enter connection information for the PDA in the Device Settings dialog. For more
information about the elements in the Device Settings dialog, see “To Use an
Assistant to Configure a PDA” on page 164.
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To Modify How PDAs Can Connect to Your
Computer
Perform the following steps:

1. Click Launch, then choose Preferences → PDA Devices to start the PDA Devices
preference tool.

2. In the Devices tabbed section on the Pilot Settings dialog, select the hardware
settings that you want to modify, then click on the Edit button.

3. Enter hardware settings for the PDA in the Device Settings dialog. For more
information about the elements in the Device Settings dialog, see “To Use an
Assistant to Configure a PDA” on page 164.

To Specify How to Transfer Data Between a PDA
and Applications
Perform the following steps:

1. Click Launch, then choose Preferences → PDA Devices to start the PDA Devices
preference tool.

2. Ensure that the PDA daemon is active and functions properly. To do this, add the
gnome-pilot applet to a panel. If the gnome-pilot applet icon appears in black and
white, the PDA daemon is active.

3. In the Conduits tabbed section on the Pilot Settings dialog, select the PDA whose
conduits you want to configure from the Pilot Name drop-down list.

4. To enable a conduit, select the conduit from the table, then click on the Enable
button.

5. To disable a conduit, select the conduit from the table, then click on the Disable
button.

6. To configure a conduit, select the conduit from the table, then click on the Settings
button. Enter configuration details for the conduit in the Conduit Settings dialog.
The elements in the Conduit Settings dialog are described in the following table:
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Element Description

Action Select the action to perform when you do a HotSync
operation.

Select one of the following options:
� Disabled: Select this option to take no action for this

conduit.
� Synchronize: Select this option to synchronize data on

your PDA with data on your computer.
� Copy from pilot: Select this option to copy data from your

PDA to your computer, and overwrite the data on your
computer.

� Copy to pilot: Select this option to copy data from your
computer to your PDA, and overwrite the data on your
PDA.

One Time Action Select an action to perform once only. The action is performed
the next time that you do a HotSync operation. Select one of
the following options:
� None: Select this option to if you do want to configure a

one-time conduit action.
� Synchronize: Select this option to synchronize data on

your PDA with data on your computer.
� Copy from pilot: Select this option to copy data from your

PDA to your computer, and overwrite the data on your
computer.

� Copy to pilot: Select this option to copy data from your
computer to your PDA, and overwrite the data on your
PDA.

Backup directory Enter the directory where you want to store your PDA backup
data.

Backup conduit only.

Only backup changed
bases

Select this option to back up only data that has changed since
the last backup. The unchanged data is not deleted from your
backup directory.

Backup conduit only.

Remove local base if
deleted on pilot

Select this option to delete data from your computer that has
been deleted from your PDA.

Backup conduit only.

# of old backups to keep Use the spin box to specify how many previous backups to
retain on your computer.

Backup conduit only.
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Element Description

Sync Private Records Select this option if you want to include data that is marked as
private, when you perform a HotSync operation.

This options applies to the following conduits only:
� EAddress
� ECalendar
� EToDo

Default Sync Address Your contacts might have more than one address. For
example, your contacts might have a business address and a
home address. The contacts manager on your PDA might not
support multiple addresses.

Select the category of address that you want to synchronize
from the drop-down list. For example, if you want to
synchronize business addresses only, select Business.

EAddress conduit only.

Split MultiDay Events Select this option if you want to separate appointments that
occur over more than one day, into individual appointments.

ECalendar conduit only.

Default Priority Use the spin box to specify a default priority to assign to tasks
which have no priority value assigned.

EToDo conduit only.

7. Click OK to close the Conduit Settings dialog.

To Back Up PDA Data to Your Computer
You might want to back up the data on your PDA to your computer, to avoid data loss
if you have a problem with your PDA. To back up PDA data to your computer,
perform the following steps:

1. Click Launch, then choose Preferences → PDA Devices to start the PDA Devices
preference tool.

2. Ensure that the PDA daemon is active and functions properly. To do this, add the
gnome-pilot applet to a panel. If the gnome-pilot applet icon appears in black and
white, the PDA daemon is active.

3. In the Conduits tabbed section on the Pilot Settings dialog, select the PDA whose
data you want to backup from the Pilot Name drop-down list.

4. Select the Backup conduit from the table, then click on the Enable button.

5. Enter configuration details for the Backup conduit in the Conduit Settings dialog.
For more information about the elements in the Conduit Settings dialog, see“To
Specify How to Transfer Data Between a PDA and Applications” on page 168.
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6. Press the HotSync button on your PDA.

For information about how to restore backup data, see the gnome-pilot Applet Manual.

Choosing Your Preferred Applications
To access the Preferred Applications preference tool, click Launch, then choose
Preferences → Desktop Preferences → Preferred Applications.

Use the Preferred Applications preference tool to specify the applications that you
want the Java Desktop System to use when the preferred application starts. For
example, you can specify Xterm as your preferred terminal application. When you
click Launch, then choose Applications → Utilities → Terminal, Xterm starts.

You can customize the preferences for the Preferred Applications preference tool in the
following functional areas.

� Web Browser
� Mail Reader
� Text Editor
� Terminal

Web Browser Preferences
Use the Web Browser tabbed section to configure your preferred web browser. The
preferred web browser opens when you click on a URL. For example, the preferred
web browser opens when you select a URL in an application, or when you select a
URL launcher on the desktop background.

Table 8–20 lists the preferred web browser preferences that you can modify.

TABLE 8–20 Preferred Web Browser Preferences

Dialog Element Description

Select a Web Browser Select this option if you want to use a standard web browser. Use
the drop-down combination box to select your preferred web
browser.

Custom Web Browser Select this option if you want to use a custom web browser.
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TABLE 8–20 Preferred Web Browser Preferences (Continued)
Dialog Element Description

Command Enter the command to execute to start the custom web browser. To
enable the browser to display a URL that you click on, include
“%s” after the command.

Start in Terminal Select this option to run the command in a terminal window. Select
this option for a browser that does not create a window in which to
run.

Email Client Preferences
Use the Mail Reader tabbed section to configure your preferred email client.

Table 8–21 lists the preferred email client preferences that you can modify.

TABLE 8–21 Preferred Email Client Preferences

Dialog Element Description

Select a Mail Reader Select this option if you want to use a standard email client. Use the
drop-down combination box to select your preferred email client.

Custom Mail Reader Select this option if you want to use a custom email client.

Command Enter the command to execute to start the custom email client.

Start in Terminal Select this option to run the command in a terminal window. Select
this option for an email client that does not create a window in
which to run.

Text Editor Preferences
Use the Text Editor tabbed section to configure your preferred text editor.

Table 8–22 lists the preferred text editor preferences that you can modify.

TABLE 8–22 Preferred Text Editor Preferences

Dialog Element Description

Select an Editor Select this option if you want to use a standard text editor. Use the
drop-down combination box to specify your preferred text editor.
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TABLE 8–22 Preferred Text Editor Preferences (Continued)
Dialog Element Description

Custom Editor Select this option if you want to use a custom text editor. A Custom
Editor Properties dialog is displayed.
� Name: Type the name of the custom text editor.
� Command: Enter the command to start the custom text editor.
� This application can open multiple files: Select this option if

the default text editor can open multiple files.
� This application needs to be run in a shell: Select this option to

run the command in a terminal window. Select this option for
an editor that does not create a window in which to run.

After you specify a custom text editor, you can click on the
Properties button to display the Custom Editor Properties dialog.
You can use the dialog to modify the properties of the custom text
editor.

Use this editor to open
text files in the file
manager

Select this option if you want the file manager to start the custom
text editor to display text files.

Terminal Preferences
Use the Terminal tabbed section to configure your preferred terminal.

Table 8–23 lists the preferred terminal preferences that you can modify.

TABLE 8–23 Preferred Terminal Preferences

Dialog Element Description

Select a Terminal Select this option if you want to use a standard terminal. Use the
drop-down combination box to specify your preferred terminal.

Custom Terminal Select this option if you want to use a custom terminal.

Command Enter the command to execute to start the custom terminal.

Exec Flag Enter the exec option to use with the command.

Setting Screensaver Preferences
To access the Screensaver preference tool, click Launch, then choose Preferences →
Display → Screensaver.
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A screensaver is an application that you can use to replace the image on your screen
when the screen is not in use. You can use screensavers in the following ways:

� Activate after a specified period of idle time.
� Activate when you lock your screen.
� Manage power used by your monitor when your system is idle.

You can customize the settings for the Screensaver preference tool in the following
functional areas:

� Display Modes
� Advanced

Display Modes Preferences
Use the Display Modes tabbed section to set display mode preferences.

Table 8–24 lists the display mode preferences that you can modify.

TABLE 8–24 Screensaver Display Mode Preferences

Dialog Element Description

Mode Use the drop-down list to specify the behavior of the
screensaver application. Select from the following options:
� Disable Screen Saver: Select this option if you do not

want to use the screensaver application.
� Blank Screen Only: Select this option if you want your

screen to become blank when your screen locks.
� Only One Screen Saver: Select this option if you want

to display a single screensaver display from the display
list when your screen locks.

� Random Screen Saver: Select this option if you want to
display a random selection of screensaver displays from
the screensaver display list when your screen locks.

Display list Select the screensaver display that you require from the list.

Blank After Specify how long to wait after the last use of the mouse or
keyboard, to activate the screensaver.

Cycle After Specify how long to show a particular screensaver display
before the next display.

Lock Screen After Select this option if you want the screen to lock after the
screensaver is activated. Use the spin box to specify the
delay between the activation of the screensaver and when
the screen locks.
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TABLE 8–24 Screensaver Display Mode Preferences (Continued)
Dialog Element Description

Preview Click on this button to preview the screensaver display that
is selected in the screensaver display list. To stop the
preview, press any key or click a mouse button.

Settings Click on this button to display the options for the
screensaver display that is selected in the screensaver
display list.

Advanced Preferences
Use the Advanced tabbed section to set advanced screensaver preferences.

Table 8–25 lists the advanced screensaver preferences that you can modify.

TABLE 8–25 Advanced Screensaver Preferences

Dialog Element Description

Grab Desktop Images Some screensavers can take a screenshot of your screen,
then manipulate the screenshot to create your
screensaver display. Select this option to enable
screensavers to take a screenshot of your screen.

Grab Video Frames Some screensavers can capture a frame of video, then
manipulate the captured image to create your
screensaver display. If your system has a video capture
card, select this option to enable screensavers to capture
a frame of video.

Choose Random Image Select this option to enable screensavers to use images
from a directory that you select. Type the path for the
directory in the field. Alternatively, click Browse to
display a dialog from which you can select a directory.

Verbose Diagnostics Select this option if you want to display screensaver
diagnostic information.

Display Subprocess Errors Select this option if you want to display errors related
to screensaver subprocesses on screen.

Display Splash Screen at Startup Select this option if you want Xscreensaver to display a
splash dialog when Xscreensaver starts.

Power Management Enabled Select this option to enable power management of your
monitor. Power management can reduce energy
consumption by your monitor when you are not using
the monitor.
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TABLE 8–25 Advanced Screensaver Preferences (Continued)
Dialog Element Description

Standby After Specify how long to wait to put the monitor in standby
mode. When the monitor is in standby mode, the
screen is black.

Suspend After Specify how long to wait to put the monitor in
power-saving mode.

Off After Specify how long to wait to switch off monitor.

Install Colormap Select this option to install a private colormap when the
screensaver is active. Use of a private colormap might
improve the quality of the color in particular
screensaver displays.

Fade to Black When Blanking Select this option if you want your display to fade to
black when the screensaver activates.

Fade from Black When Unblanking Select this option if you want your display to fade from
black to the screen contents when the screensaver stops.

Fade Duration Specify how long to take to fade to black when the
screensaver activates.

Configuring Sessions
To access the Sessions preference tool, click Launch, then choose Preferences →
Desktop Preferences → Sessions .

The Sessions preference tool enables you to manage your sessions. You can set session
preferences, and specify which applications to start when you start a session. You can
configure sessions to save the state of applications in the Java Desktop System, and to
restore the state when you start another session. You can also use this preference tool
to manage multiple Java Desktop System sessions.

You can customize the settings for sessions and startup applications in the following
functional areas:

� Session Options
� Current Session
� Startup Programs

Setting Session Preferences
Use the Session Options tabbed section to manage multiple sessions, and to set
preferences for the current session.
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Table 8–26 lists the session options that you can modify.

TABLE 8–26 Session Options

Dialog Element Description

Show splash screen on
login

Select this option to display a splash screen when you start a
session.

Prompt on logout Select this option to display a confirmation dialog when you end a
session.

Automatically save
changes to session

Select this option if you want the session manager to save the
current state of your session. The session manager saves the
session-managed applications that are open, and the settings
associated with the session-managed applications. The next time
that you start a session, the applications start automatically, with
the saved settings.

If you do not select this option, when you end you session the
Logout Confirmation dialog displays a Save current setup option.

Sessions Use this area of the dialog to manage multiple sessions in the Java
Desktop System, as follows:
� To create a new session, click on the Add button. Use the Add a

new session dialog to specify a name for your session.
� To change the name of a session, select the session in the

Choose Current Session table. Click on the Edit button. The
Edit session name dialog is displayed. Type a new name for
your session.

� To delete a session, select the session in the Choose Current
Session table. Click on the Delete button.

Setting Session Properties
Use the Current Session tabbed section to specify startup order values, and to choose
restart styles for the session-managed applications in your current session.

Table 8–27 lists the session properties that you can configure.
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TABLE 8–27 Session Properties

Dialog Element Description

Order The Order property specifies the order in which the session
manager starts session-managed startup applications. The session
manager starts applications with lower order values first. The
default value is 50.

To specify the startup order of an application, select the application
in the table. Use the Order spin box to specify the startup order
value.

Style The Style property determines the restart style of an application. To
select a restart style for an application, select the application in the
table, then choose one of the following styles:
� Normal

Starts automatically when you start a Java Desktop System
session. Use the kill command to terminate applications with
this restart style during a session.

� Restart
Restarts automatically whenever you close or terminate the
application. Choose this style for an application if the
application must run continuously during your session. To
terminate an application with this restart style, select the
application in the table, then click on the Remove button.

� Trash
Does not start when you start a Java Desktop System session.

� Settings
Starts automatically when you start a session. Applications with
this style usually have a low startup order, and store your
configuration settings for the Java Desktop System and
session-managed applications.

Remove Click on the Remove button to delete the selected application from
the list. The application is removed from the session manager, and
closed. Applications that you delete are not started the next time
that you start a session.

Apply Click on the Apply button to apply changes to the startup order and
the restart style.

Configuring Startup Applications
Use the Startup Programs tabbed section of the Sessions preference tool to specify
non-session-managed startup applications. Startup applications are applications that
start automatically when you start a session. You specify the commands that run the
non-session-managed applications in the Startup Programs tabbed section. The
commands execute automatically when you log in.
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You can also start session-managed applications automatically. For more information,
see “Setting Session Preferences” on page 176.

Table 8–28 lists the startup applications preferences that you can modify.

TABLE 8–28 Startup Programs Preferences

Dialog Element Description

Additional startup
programs

Use this table to manage non-session-managed startup applications
as follows:
� To add a startup application, click on the Add button. The Add

Startup Program dialog is displayed. Enter the command to
start the application in the Startup Command field.
If you specify more than one startup application, use the Order
spin box to specify the startup order of the each application. The
startup order is the order in which you want the startup
applications to start.

� To edit a startup application, select the startup application, then
click on the Edit button. The Edit Startup Program dialog is
displayed. Use the dialog to modify the command and the
startup order for the startup application.

� To delete a startup application, select the startup application,
then click on the Delete button.

Customizing Keyboard Shortcuts
To access the Shortcuts preference tool, click Launch, then choose Preferences →
Desktop Preferences → Keyboard → Shortcuts.

A keyboard shortcut is a key or combination of keys that provides an alternative to
standard ways of performing an action.

Use the Shortcuts preference tool to display the default keyboard shortcuts. You can
customize the default keyboard shortcuts to your requirements. In addition, you can
also set shortcut key preferences for multimedia functions.

You can also create hot keys on Solaris systems. Hot keys are keyboard shortcuts that
start applications.

Table 8–29 lists the keyboard shortcut settings that you can customize on Linux.
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TABLE 8–29 Keyboard Shortcuts Preferences on Linux

Dialog Element Description

Text editing shortcuts Select one of the following settings:
� Default: Use this setting for standard shortcut keys.
� Emacs: Use this setting for Emacs shortcut keys.

Desktop shortcuts This table lists actions and the shortcut keys that are
associated with each action.

To change the shortcut keys for an action, click on the
action to select the action, then click on the shortcut for the
action. Press the keys that you want to associate with the
action.

To disable the shortcut keys for an action, click on the
action to select the action, then click on the shortcut for the
action. Press Back Space.

Table 8–30 lists the keyboard shortcut settings that you can customize on Solaris.

TABLE 8–30 Keyboard Shortcuts Preferences on Solaris

Dialog Element Description

Text editing shortcuts Select one of the following settings:
� Default: Use this setting for standard shortcut keys.
� Emacs: Use this setting for Emacs shortcut keys.

Desktop shortcuts This table lists actions and the shortcut keys that are
associated with each action.

To change the shortcut keys for an action, click on the
action to select the action, then click on the shortcut for the
action. Press the keys that you want to associate with the
action.

To disable the shortcut keys for an action, click on the
action to select the action, then click on the shortcut for the
action. Press Back Space.
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TABLE 8–30 Keyboard Shortcuts Preferences on Solaris (Continued)
Dialog Element Description

Custom Shortcuts To add a hot key, perform the following steps:
1. Click New. A Custom Binding dialog is displayed.

Enter the command to associate with the hot key in the
New Command field. Alternatively, to browse for the
command, click on the Browse button. When you have
selected the command, click OK. The command is
added to the Custom Shortcuts section of the Desktop
shortcuts table.

2. Click in the Shortcut column of the command in the
Custom bindings section of the Desktop shortcuts
table. Press the key or key combination that you want
to associate with the command.

To edit a hot key, select the hot key in the Custom
Shortcuts section of the Desktop shortcuts table, then click
Edit. Edit the command in the Custom Binding dialog.

To remove a hot key, select the hot key in the Custom
Shortcuts section of the Desktop shortcuts table, then click
Delete.

Use the Multimedia Keys preference tool to assign shortcut keys to an action.

Table 8–31 lists the shortcut key preferences that you can set for multimedia functions.

TABLE 8–31 Multimedia Keys Preferences

Dialog Element Description

Multimedia keys table To add the shortcut keys for an action, click on
the action to select the action, then press the
keys that you want to associate with the
action.

To disable the shortcut keys for an action, click
on the action to select the action, then press
Back Space.

Use PCM volume instead of Master volume Select this option if you want to use Pulse
Code Modulation (PCM) volume instead of
Master volume.
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Setting Sound Preferences
To access the Sound preference tool, click Launch, then choose Preferences → Desktop
Preferences → Sound.

The Sound preference tool enables you to control when the Java Desktop System
sound server starts. You can also specify which sounds to play when particular events
occur.

You can customize the settings for the Sound preference tool in the following
functional areas:

� General
� Sound Events
� System Bell

General Sound Preferences
Use the General tabbed section of the Sound preference tool to specify when to launch
the Java Desktop System sound server. You can also enable sound event functions.

Table 8–32 lists the general sound preferences that you can modify.

TABLE 8–32 General Sound Preferences

Dialog Element Description

Enable sound server
startup

Select this option to start the sound server when you start a
session. When the sound server is active, the Java Desktop System
can play sounds.

Sounds for events Select this option to play sounds when particular events occur in
the Java Desktop System. You can select this option only if the
Enable sound server startup option is selected.

Sound Event Preferences
Use the Sound Events tabbed section of the Sound preference tool to associate
particular sounds with particular events.

Note – You must select the Enable sound server startup option, and the Sounds for
events option before you can access the Sound Events tabbed section.
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Table 8–33 lists the sound events preferences that you can modify.

TABLE 8–33 Sound Event Preferences

Dialog Element Description

Sounds table Use the Sounds table to associate particular sounds with
particular events.

The Event column displays a hierarchical list of events that can
occur. To expand a category of events, click on the right arrow
beside a category of events.

The Sound File column lists the sound file that plays when the
event occurs.

Play Click on this button to play the sound file that is associated with
the selected event.

Sound file drop-down
combination box, Browse

To associate a sound with an event, select the event in the Sounds
table. Enter the name of the sound file that you want to associate
with the selected event in the drop-down combination box.
Alternatively, click Browse to display a Select Sound File dialog.
Use the dialog to specify the sound file that you want to associate
with the selected event.

Note – You can only associate sound files in .wav format with
events.

System Bell Settings
Use the System Bell tabbed section to set your preferences for the system bell.

Some applications play a bell sound to indicate a keyboard input error. Use the
preferences in the System Bell tabbed section to configure the bell sound. Table 8–34
lists the system bell preferences that you can modify.

TABLE 8–34 System Bell Preferences

Dialog Element Description

Sound an audible bell Select this option to enable the system bell.

Visual feedback Select this option to enable visual feedback to indicate input
errors.

Flash window titlebar Select this option if you want window titlebars to flash to indicate
an input error.

Flash entire screen Select this option if you want the entire screen to flash to indicate
an input error.
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Customizing Themes
To access the Theme preference tool, click Launch, then choose Preferences → Desktop
Preferences → Display → Theme.

A theme is a group of coordinated settings that specifies the visual appearance of a
part of the Java Desktop System. You can choose themes to change the appearance of
the Java Desktop System. Use the Theme preference tool to select a theme. You can
choose from a list of available themes. The list of available themes includes several
themes for users with accessibility requirements.

A theme contains settings that affect different parts of the Java Desktop System, as
follows:

Controls The controls setting for a theme determines the visual appearance
of windows, panels, and panel applications. The controls setting
also determines the visual appearance of the GNOME-compliant
interface items that appear on windows, panels, and panel
applications, such as menus, icons, and buttons. Some of the
controls setting options that are available are designed for special
accessibility needs. You can choose an option for the controls
setting from the Controls tabbed section in the Theme preference
tool.

Window frame The window frame setting for a theme determines the appearance
of the frames around windows only. You can choose an option for
the window frame setting from the Window Border tabbed section
in the Theme preference tool.

Icon The icon setting for a theme determines the appearance of the icons
on panels and the desktop background. You can choose an option
for the icon setting from the Icons tabbed section in the Theme
preference tool.

To Create a Custom Theme
The themes that are listed in the Theme preferences tool are different combinations of
controls options, window frame options, and icon options. You can create a custom
theme that uses different combinations of controls options, window frame options,
and icon options.

To create a custom theme, perform the following steps:

1. Start the Theme preference tool.

2. Select a theme in the list of themes.
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3. Click on the Theme Details button. A Theme Details dialog is displayed.

4. Select the controls option that you want to use in the custom theme from the list in
the Controls tabbed section. The list of available controls options includes several
options for users with accessibility requirements.

5. Click on the Window Border tab to display the Window Border tabbed section.
Select the window frame option that you want to use in the custom theme from the
list of available options. The list of available window frame options includes
several options for users with accessibility requirements.

6. Click on the Icons tab to display the Icons tabbed section. Select the icons option
that you want to use in the custom theme from the list of available options. The list
of available icons options includes several options for users with accessibility
requirements.

7. Click Close to close the Theme Details dialog.

8. On the Theme preferences tool, click on the Save Theme button.

9. Type a name and a short description for the custom theme in the Save Theme to
Disk dialog, then click Save. The custom theme now appears in your list of
available themes.

To Install a New Theme
You can add a theme to the list of available themes. The new theme must be an archive
file that is tarred and zipped. That is, the new theme must be a .tar.gz file.

To install a new theme, perform the following steps:

1. Start the Theme preference tool.

2. Click on the Install Theme button.

3. Enter the location of the theme archive file in the drop-down combination box of
the Install a Theme dialog. Alternatively, to browse for the file, click on the Browse
button. When you have selected the file, click OK.

4. Click on the Install button to install the new theme.

To Install a New Theme Option
You can install new controls options, window frame options, or icons options. You can
find many controls options on the Internet.

To install a new controls option, window frame option, or icons option, perform the
following steps:

1. Start the Theme preference tool.
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2. Click on the Theme Details button.

3. Click on a tab in the Theme Details dialog for the type of theme that you want to
install. For example, to install an icons option, click on the Icons tab.

4. Click on the Install Theme button.

5. Enter the location of the option archive file in the drop-down combination box of
the Install a Theme dialog. Alternatively, to browse for the file, click on the Browse
button. When you have selected the file, click OK.

6. Click on the Install button to install the new option.

To Delete a Theme Option
You can delete controls options, window frame options, or icons options.

To delete a controls option, window frame option, or icons option, perform the
following steps:

1. Start the Theme preference tool.

2. Click on the Theme Details button.

3. Click on a tab in the Theme Details dialog for the type of option that you want to
delete.

4. Click on the Go to Theme Folder button. A file manager window opens on the
default option folder.

5. Use the file manager window to delete the option.

Customizing Windows
To access the Window Behavior preference tool, click Launch, then choose Preferences
→ Desktop Preferences → Display →Window Behavior.

Use the Window Behavior preference tool to customize window behavior for the Java
Desktop System.

Table 8–35 lists the windows preferences that you can modify.
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TABLE 8–35 Windows Preferences

Dialog Element Description

Select windows when
the mouse moves over
them

Select this option to give focus to a window when you point to the
window. The window retains focus until you point to another
window.

Raise selected windows
after an interval

Select this option to raise windows a short time after the window
receives focus.

Interval before raising Specify the interval to wait before raising a window that has
received focus.

Double-click titlebar to
perform this action

Select the behavior that you want to occur when you double-click
on a window titlebar. Select one of the following options:
� Roll up: Shades the window.
� Maximize: Maximizes the window.

To move a window,
press-and-hold this key
then grab the window

Select the key to press-and-hold when you drag a window to move
the window.
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APPENDIX A

Mouse and Keyboard Functionality

This appendix discusses some of the basic skills that you need to work with the Java
Desktop System.

Mouse Functionality
This section describes the button conventions and action terminology used in this
manual. This section also describes the mouse pointers.

Mouse Button Conventions
All the instructions in this manual are for the following types of mouse devices:

� Devices that are configured for right-hand users.

� Three button devices. If you have a two-button mouse device, then you press the
two buttons simultaneously to simulate the effect of a middle mouse button.

The mouse button conventions used in this manual are as follows:

Mouse Button Definition

Left mouse button The button on the left side of a mouse device configured
for normal right-hand use.

Middle mouse button The middle button of a mouse device configured for
normal right-hand use.

189



Mouse Button Definition

Right mouse button The button on the right side of a mouse device configured
for normal right-hand use.

To reverse the handedness of your mouse device, start the Mouse preference tool, then
select the options that you require. If you do reverse the handedness of your mouse
device, then you must reverse the mouse button conventions used in this manual.

Mouse Actions
The following table describes the actions that you can perform with the mouse:

Mouse Button Usage

Left mouse button Use to perform the following actions:
� Select text.
� Choose items.
� Drag items.

Middle mouse button Use to perform the following actions:
� Paste text.
� Move items.

Right mouse button Opens a menu for the selected object, if a menu applies.

For example, if you want to copy text then perform the following steps:

1. Select the text with the left mouse button.
2. Move the mouse pointer to the location where you want to copy the text.
3. Click on the middle mouse button.

You can also right-click on the desktop background to open the Desktop background
menu.

Mouse Pointers
As you use the mouse, the appearance of the mouse pointer can change. The
appearance of the pointer can provide feedback about a particular operation, location,
or state. The following table lists and describes some of the mouse pointers.
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Pointer Associated Action Description

Point to an item, choose a menu
item

Normal pointer. The pointer that
appears during normal use of the
mouse.

Drag-and-drop Move pointer. Indicates that when
you drop the object, the object is
moved from the old location to the
new location.

Drag-and-drop Copy pointer. Indicates that when
you drop the object, a copy of the
object is created where you drop
the object.

Drag-and-drop Symbolic link pointer. Indicates
that when you drop the object, a
symbolic link to the object is created
where you drop the object. A
symbolic link is a special type of
file that points to another file or
folder.

Drag-and-drop Ask pointer. Indicates that when
you drop the object, a menu opens.
You can choose to move or copy
the object, or to create a symbolic
link to the object.

Drag-and-drop Not available pointer. Indicates that
you cannot drop the object at the
current location.

Move panel object Move panel object pointer.
Indicates that you have selected a
panel object to move.

Resize window horizontally Horizontal resize pointer. Indicates
that you have selected a vertical
window border to resize the
window horizontally.

Resize window vertically Vertical resize pointer. Indicates
that you have selected a horizontal
window border to resize the
window vertically.

Appendix A • Mouse and Keyboard Functionality 191



Pointer Associated Action Description

Resize window horizontally and
vertically

Corner resize pointer. Indicates that
you have selected a corner of a
window border to resize the
window horizontally and vertically.

Resize window pane or resize table
column

Window pane or table column
resize pointer. Indicates that you
have selected a column in a table to
resize.

Mouse Action Terminology
The conventions used in this manual to describe actions that you take with the mouse
are as follows:

Action Definition

Click Press and release the left mouse button, without moving
the mouse.

Click-and-hold Press and do not release the left mouse button.

Left-click Same as click. Left-click clarifies the action when there
might be confusion with right-click.

Middle-click Press and release the middle mouse button, without
moving the mouse.

Right-click Press and release the right mouse button, without moving
the mouse.

Double-click Press and release the left mouse button twice in rapid
succession without moving the mouse.

Drag Click-and-hold a mouse button, then move an object. For
example, you can drag a window or an icon. The left and
middle mouse buttons can perform drag actions.

Drag-and-drop Click-and-hold a mouse button, then move an object. For
example, you can drag-and-drop a window or an icon.
Release the mouse button to place the object in a new
location.
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Action Definition

Grab Point to an item that you can move, and click-and-hold on
the mouse button. For example, you can grab the titlebar of
a window, then drag the window to a new location.

Keyboard Functionality
For almost every task that you can perform with the mouse, you can use the keyboard
to perform the same task. Shortcut keys are keys that provide you with a quick way to
perform a task.

You can use shortcut keys to perform general Java Desktop System tasks and to work
with interface items such as panels and windows. You can also use shortcut keys in
applications. To customize your shortcut keys, use the Shortcuts preference tool.

You can also modify the desktop preferences to use keyboard accessibility features.

The following sections describe the shortcut keys that you can use.

General Shortcut Keys
General shortcut keys enable you to use the keyboard to perform general Java Desktop
System tasks. The following table lists some general shortcut keys:

Default Shortcut Keys Function

Ctrl + Esc Opens the Main Menu.

Super + R Displays the Run Application dialog.

Print Screen Takes a screenshot.

Alt + Print Screen Takes a screenshot of the window that has focus.

Ctrl + Alt + right arrow Switches to the workspace to the right of the current
workspace.

Ctrl + Alt + left arrow Switches to the workspace to the left of the current
workspace.

Ctrl + Alt + up arrow Switches to the workspace above the current workspace.

Ctrl + Alt + down arrow Switches to the workspace below the current workspace.
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Default Shortcut Keys Function

Ctrl + Alt + d Minimizes all windows, and gives focus to the desktop
background.

F1 Starts the online help browser, and displays appropriate
online Help.

Window Shortcut Keys
Window shortcut keys enable you to use the keyboard to perform window tasks. The
following table lists some window shortcut keys:

Default Shortcut Keys Function

Alt + Tab Switches between windows. When you use these shortcut
keys, a list of windows that you can select is displayed.
Release the keys to select a window.

Alt + Esc Switches between windows in reverse order. Release the
keys to select a window.

F10 Opens the first menu on the left side of the menubar.

Alt + spacebar Opens the Window Menu.

Arrow keys Moves the focus between items in a menu.

Return Chooses a menu item.

Esc Closes an open menu.

Ctrl + Alt + right arrow Switches to the workspace to the right of the current
workspace.

Ctrl + Alt + left arrow Switches to the workspace to the left of the current
workspace.

Ctrl + Alt + up arrow Switches to the workspace above the current workspace.

Ctrl + Alt + down arrow Switches to the workspace below the current workspace.

Ctrl + Alt + d Minimizes all windows, and gives focus to the desktop
background.
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Panel Shortcut Keys
Panel shortcut keys enable you to use the keyboard to perform panel tasks. The
following table lists panel shortcut keys:

Default Shortcut Keys Function

Ctrl + Alt + Tab Switches the focus between the panels and the desktop
background. When you use these shortcut keys, a list of items
that you can select is displayed. Release the keys to select an
item.

Ctrl + Alt + Esc Switches the focus between the panels and the desktop
background. Release the keys to select an item.

Ctrl + F10 Opens the popup menu for the selected panel.

Tab Switches the focus between objects on a panel.

Return Chooses the selected panel object or menu item.

Shift + F10 Opens the popup menu for the selected panel object.

Arrow keys Moves the focus between items in a menu. Moves the focus
between interface items in an applet also.

Esc Closes an open menu.

F10 Opens the Applications menu from the Menu Bar, if the Menu
Bar is in a panel.

Application Shortcut Keys
Application shortcut keys enable you to perform application tasks. You can use
shortcut keys to perform application tasks more quickly than if you use a mouse. The
following table lists some application shortcut keys:

Shortcut Keys Command

Ctrl + N New

Ctrl + X Cut

Ctrl + C Copy

Ctrl + V Paste

Ctrl + Z Undo

Ctrl + S Save
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Shortcut Keys Command

Ctrl + Q Quit

Access Keys
A menubar is a bar at the top of a window that contains the menus for the application.
An access key is an underlined letter in a menubar, menu, or dialog that you can use to
perform an action. On a menubar, the access key for each menu is underlined.

To open a menu, press Alt, then press the access key. In the menu, the access key for
each menu item is underlined. To choose a menu item, press the access key for the
menu item. The following table shows example access keys from the Text Editor
application:

Access Keys Function

Alt + F Opens the File menu.

N Chooses the New item on the File menu.

You can also use access keys to access elements in a dialog. In a dialog, one letter in
most dialog elements is underlined. To access a particular dialog element, press Alt,
then press the access key. The following table shows an example access key from the
Preferences dialog in the Text Editor application:

Access Key Function

Alt + U Gives focus to the Use default theme font check box.

You can use also other keys to navigate within a window or dialog.

Key Function

Tab Moves the focus from element to element in a window or
dialog.
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Key Function

Arrow keys Use the arrow keys to perform the following actions:
� In a menubar, move the focus from one menu to the

next menu. In an open menu, move the focus from one
menu item to the next menu item.

� Move the focus from one option to the next option to
make your selection, for example, within a group of
radio buttons in a dialog.

� Change the value that a spin box displays.
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Glossary

desktop Your visible Java Desktop System, including all panels, icons,
applications, and the desktop background.

desktop background The desktop background lies behind all of the other components on
the Java Desktop System.

desktop background
object

An icon on your desktop background that you can use to open your
files, folders, and applications.

DNS name A unique alphabetic identifier for a computer on a network.

drawer A drawer is a sliding extension to a panel that you can open or close
from a drawer icon.

format To prepare storage media for use with a particular file system. When
you format media, you overwrite any existing information on the
media.

GNOME-compliant
application

An application that uses the standard GNOME programming libraries.
For example, gedit text editor is a GNOME-compliant application.

hot key Hot keys are keyboard shortcuts that start applications.

IP address A unique numeric identifier for a computer on a network.

keyboard shortcut A keyboard shortcut is a key or combination of keys that provides an
alternative to standard ways of performing an action.

launcher A launcher starts a particular application, executes a command, or
opens a file. A launcher can reside on a panel or in a menu.

menubar A menubar is a bar at the top of an application window that contains
the menus for the application.
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MIME type A Multipurpose Internet Mail Extension (MIME) type identifies the
format of a file. The MIME type enables applications to read the file.
For example, an email application can use the image/png MIME type
to detect that a Portable Networks Graphic (PNG) file is attached to an
email.

mount To make a file system available for access. When you mount a file
system, the file system is attached as a subdirectory to your file
system.

pane A pane is a subdivision of a window. For example, the file browser
window contains a side pane and a view pane.

panel application A panel application is a small, interactive application that resides
within a panel, for example the CD Player.

PDA Personal Digital Assistant. A hand-held computer that you can use as a
personal organizer.

PDA daemon A background application which waits for a PDA to attempt to
synchronize with your computer. When a PDA attempts to
synchronize with the computer, the PDA daemon synchronizes the
data on the PDA with data on the computer.

preference tool A dedicated software tool that controls a particular part of the
behavior of the Java Desktop System.

shortcut keys Shortcut keys are keystrokes that provide a quick way to perform an
action.

slice A partition of a disk. You can create slices on your Zip and Jaz media.
An object for each slice appears on the desktop.

stacking order The stacking order is the order in which windows are stacked on top
of each other on your screen.

statusbar A statusbar is a bar at the bottom of a window that provides
information about the current state of what you are viewing in the
window.

symbolic link A special type of file that points to another file or folder. When you
perform an action on a symbolic link, the action is performed on the
file or folder to which the symbolic link points.

toolbar A toolbar is a bar that contains buttons for the most commonly-used
commands in an application. Typically, a toolbar appears under a
menubar.

Uniform Resource
Identifier

A Uniform Resource Identifier (URI) is a string that identifies a
particular location in a file system or on the Web. For example, the
address of a web page is a URI.

Uniform Resource
Locator

A Uniform Resource Locator (URL) is the address of a particular
location on the Web.
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view A file manager component that enables you to display a folder in a
particular way. For example, the file manager contains an icon view
which enables you to display the contents of a folder as icons. The file
manager also contains a list view which enables you to display the
contents of a folder as a list.

viewer component A file browser window component that enables you to display a
particular type of file in the view pane. A viewer component might
add menu items that are relevant to the file type to the file manager
menus. A viewer component might also enable you to use the file
browser window zoom buttons to change the size of the item in the
view pane.

workspace A workspace is a discrete area in the desktop in which you can work.
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Index

A
access keys, 196-197
accessibility

bounce keys, 157
configuring keyboard, 154-157
mouse keys, 157
repeat keys, 156
slow keys, 156
sticky keys, 155
toggle keys, 157

AccessX, See preference tools, Keyboard
Accessibility

action buttons, See buttons
applications

help, 49
overview, 38, 48-49
terminating, 64

B
backgrounds

adding colors, 151
adding patterns, 151
changing desktop background, 138
changing screen component, 150-151
customizing desktop background, 139-141

basic skills
keyboard skills, 193-197
mouse skills, 189-192

bottom edge panel
default contents, 51-52
introduction, 51-52

burning CDs, See writing CDs
buttons

adding to panel, 64-66
Force Quit, 64
Lock, 65
Log Out, 65
Run, 65
Screenshot, 66
Search, 64
Show Desktop, 66

C
CDs, writing, 124-125
closing windows, 91

D
default applications, See preferred applications
desktop

desktop objects, 130-136
overview, 45-46

Desktop applications, 30-31
desktop background

adding a file or folder to, 132-133
adding emblems to objects, 135
adding launchers, 132
adding notes to objects, 135
adding symbolic links, 132
background, changing pattern or color, 138
changing icon of a desktop object, 135
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desktop background (Continued)
changing permissions of object, 134-135
copying a file or folder to, 133
creating a folder on, 133
customizing background, 139-141
deleting an object from, 134
introduction, 129-130
moving a file or folder to, 133
opening objects, 131
removing an object from, 133-134
renaming object, 133
resizing icons, 136
selecting objects, 131
using Desktop menu, 137
using Trash, 136-137
viewing properties of object, 134

Desktop menu
description, 137
illustration, 137

desktop objects
adding emblems, 135
adding notes to, 135
changing icons, 135
changing permissions, 134-135
deleting, 134
files and folders, 132-133
launchers, 132
opening, 131
removing, 133-134
renaming, 133
resizing icons, 136
selecting, 131
symbolic links, 132
viewing properties, 134

devices, PDA, 163-171
drawers

adding objects to, 68
adding to panel, 68
closing, 68
modifying properties, 68-69
opening, 68

E
email client, preferred application, 172
emblems

adding new, 117

emblems (Continued)
adding to desktop objects, 135
adding to file, 117
adding to folder, 117
introduction, 99-100

events, associating sounds with, 182-184
Evolution

features and benefits, 33-34
starting, 34

F
file manager

assigning actions to files, 122-124
bookmarks, 107
changing backgrounds, 150-151
changing permissions, 114
copying files and folders, 110-111
creating documents, 111-112
creating folders, 111
creating symbolic link, 113
customizing, 145-151
deleting files or folders, 113
displaying folders, 100-101
drag-and-drop, 108-109
duplicating files and folders, 111
emblems

See emblems
executing default actions for files, 103
executing non-default actions for files, 103
executing other actions for files, 103
FTP sites

See FTP sites
History, 107
icon view

arranging files in, 119-121
illustration, 96

icons
caption preferences, 147-148
changing, 117-118
introduction, 99-100
resizing, 121

introduction, 95
managing files and folders, 108-116
modifying actions, 123-124
modifying appearance of files and

folders, 116-122

204 Java Desktop System Release 2 User Guide • July, 2004



file manager (Continued)
moving files and folders, 110
navigating, 100-107
navigating history list, 106-107
notes

adding, 115
deleting, 115

opening files, 102-103
overview, 44-45
preferences

behavior, 146-147
icon captions, 147-148
introduction, 145-150
preview, 149-150
views, 146

renaming folders, 111
selecting files and folders, 109
side pane

introduction, 98
special URI locations, 105-106
This Computer location

See This Computer location
Trash

See Trash
Tree, using, 101-102
view pane

See view pane
viewing files in view pane, 102
viewing properties, 113
views

choosing, 119
introduction, 119-122
modifying behavior, 121-122

windows, 96-100
writing CDs, 124-125
zooming in and out, 118

file types
adding, 143-144
configuring, 142-145
editing, 143

focus, giving to a window, 89-90
fonts

applications, 151-152
desktop background, 151-152
rendering, 151-152
terminal, 151-152
window title, 151-152

Force Quit button, 64

FTP sites, accessing, 105

G
GNOME Desktop, 29-30
GTK+ themes, See themes, controls options

H
help

applications, 49
how to find, 49
Java Desktop System topics, 49
panel applications, 49
starting help system, 49

hot keys, configuring, 179-181

I
icon themes, See themes, icons options
input methods, preferences, 152-153
Internet, configuring connection, 153-154
internet, setting preferences, 153-154
internet configuration, setting

preferences, 153-154

J
Java, features and benefits, 36-37
Java Desktop System components,

introducing, 27-28
Java Desktop System preference tools, See

preference tools

K
keyboard

basic skills, 193-197
configuring accessibility options, 154-157
configuring general preferences, 158-160
configuring sound preferences, 183-184

keyboard shortcuts, configuring, 179-181
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L
language, logging in different, 20, 21
Launch, opening, 77
Launch menu, adding to panel, 77
launchers

adding to panel, 60-64, 73
modifying properties, 64

Lock button, 22-23, 65
locking panel objects, 58
locking screen, 22-23, 65
Log Out button, 65
logging in, 20-21

to session, 19-20
to session in different language, 20, 21

logging out, 25

M
maximizing windows, 90
Menu Bar

adding to panel, 78
introduction, 77-78

menu item popup menu
description, 72-73
illustration, 73

menus
Actions menu, 74-76
adding, 79
adding launchers to, 79
adding to panel, 66-67, 73
Applications menu, 73-74
copying launchers to, 79-80
customizing, 78-80
deleting menu items, 80
Desktop menu, 137
editing menu items, 80
editing properties, 80
features, 72-73
in applications, customizing

appearance, 160
introduction, 71
Launch

See Launch Menu
Menu Bar

See Menu Bar
menu item popup menu, 72-73
overview, 40

menus (Continued)
Window Menu, 85-86

Metacity themes, See themes, window frame
options

minimizing, windows, 90
mouse

actions, 190
basic skills, 189-192
button conventions, 189-190
configuring, 161-162
pointers, 190-192

moving windows, 91
Mozilla

features and benefits, 36
functionality, 36
starting, 36

N
Nautilus desktop, See desktop
Nautilus file manager, See file manager
notes

adding to desktop objects, 135
adding to files and folders, 115
deleting, 115

Notification Area, 66

P
panel application

adding to panel, 59
getting help, 49

Panel applications, 31-33
panel applications

introduction, 58-60
modifying preferences, 60
Notification Area, 66
selecting, 59-60
Window List, 86-88
Workspace Switcher, 88

panel object popup menu, illustration, 57
panel objects

adding, 56-57
drawers

See drawers
Force Quit button, 64
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panel objects (Continued)
interacting with, 56
launchers

See launchers
Lock button, 65
locking, 58
Log Out button, 65
menus, 66-67
modifying properties, 57
moving, 57-58
Notification Area, 66
panel applications

See panel applications
removing, 58
Run button, 65
Screenshot button, 66
Search button, 64
Show Desktop button, 66

panels
adding new, 52
bottom edge panel

See bottom edge panel
changing background, 55
customizing behavior and

appearance, 162-163
deleting, 55
hiding, 53
interacting with, 52-53
introduction, 51-52
managing, 52-55
modifying properties, 53-55
moving, 53
overview, 37-40
panel objects

See panel objects
panes, resizing, 92
permissions

and emblems, 99
changing file and folder, 114
displaying as characters, 148, 149
displaying in octal notation, 148, 149
introduction, 113-115

pointers, See mouse pointers
preference tools

Background, 139-141
CD Database Server, 141-142
File Associations, 142-145
Font, 151-152

preference tools (Continued)
Input Methods, 152-153
internet configuration, 153-154
Keyboard, 158-160
Keyboard Accessibility, 154-157
Keyboard Layout, 159
Keyboard Layout Options, 159-160
Menus & Toolbars, 160
Mouse, 161-162
Multimedia Keys, 181
overview, 47
Panel Preferences, 162-163
PDA Devices, 163-171
Preferred Applications, 171-173
Screensaver, 173-176
Sessions, 23-24, 176-179
Shortcuts, 179-181
Sound, 182-184
Theme, 184-186
Windows Behavior, 186-187

preferences, file manager, See file manager
preferences

preferred applications
email client, 172
terminal, 173
text editor, 172-173
web browser, 171-172

R
removable media

displaying media contents, 126
displaying media properties, 126
ejecting, 127-128
formatting floppy diskette, 126-127
introduction, 125-128
mounting, 125-126

resizing windows, 91
restoring, windows, 90
rolling up windows, 92
Run Application dialog, using, 74-75
Run button, 65

S
screensaver, setting preferences, 173-176
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Screenshot button, 66
screenshots, taking, 75-76
Search button, 64
services

adding, 144-145
configuring, 142-145
editing, 143

sessions
browsing applications, 24
configuring screensaver, 173-176
different language, logging in, 20, 21
ending, 25
locking screen, 22-23
logging in, 19-20, 20-21
logging out, 25
login behavior, 23
logout behavior, 23
managing, 23-24
preferences, 176-179
saving settings, 24
setting options, 176-177
setting properties, 177-178
starting, 19-21
using startup applications, 24

shading windows, See rolling up windows
shortcut keys

application, 195-196
configuring, 179-181
general, 193-194
panel, 195
window, 194-195

Show Desktop button, 66
side pane, See file manager
sound

associating events with sounds, 182-184
configuring system bell preferences, 183-184
setting preferences, 182-184

sound server, 182-184
special URI locations

accessing, 105-106
and launchers, 60

special URIs, launchers, 63
StarOffice

applications, 34-35
opening a file, 35
starting, 35

startup applications
customizing, 176-179

startup applications (Continued)
non-session-managed, 24, 178-179
session-managed, 23-24, 177

startup programs, See startup applications
symbolic link

to desktop object, creating, 132
to file or folder, creating, 113

symbolic links, and emblems, 100
system bell, configuring preferences, 183-184

T
tables, using, 93
terminal, preferred application, 173
terminating applications, 64
text editor, preferred application, 172-173
themes

controls options
introduction, 184

icons options
introduction, 184

setting controls options, 184-186
setting icons options, 184-186
setting window frame options, 184-186
window frame options

introduction, 184
This Computer location

overview, 46-47
using, 104-105

toolbars, customizing appearance, 160
top edge panel, window selector icon, 88-89
Trash

displaying, 116, 136
emptying, 116, 136-137
introduction, 116
moving files or folders to, 112-113
using on desktop, 136-137

Tree, using, 101-102

U
URI, special, See special URI locations
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V
view pane

introduction, 97-98
viewing files in, 102

viewer components, 98, 102, 119-122

W
web browser, preferred application, 171-172
Window List panel application

grouping buttons, 87-88
introduction, 86-88
window status information, 87

window lists, Window List panel
application, 86-88

window manager, customizing, 186-187
window selector, top edge panel, 88-89
windows

closing, 91
frame control elements, 83-85
frames, 83-85
giving focus to, 89-90
introduction, 81-82
manipulating, 89-93
maximizing, 90
minimizing, 90
moving, 91
moving to another workspace, 92
overview, 41-43
panel applications and menus for working

with, 85-89
putting on all workspaces, 92
resizing, 91
resizing panes, 92
restoring, 90
rolling up, 92
setting frame theme options, 184-186
themes, 83
types of, 82-85
using tables, 93
Window List panel application

See Window List panel application
window managers, 82
Window Menu, 85-86

Workspace Switcher panel application, 88
workspaces

adding, 94

workspaces (Continued)
deleting, 94
introduction, 81-82
manipulating, 93-94
moving windows to, 92
naming, 94
overview, 43-44
specifying number of, 44
switching between, 43-44, 93-94
Workspace Switcher panel application, 88

writing CDs, 124-125

X
Ximian Evolution, main components, 33-34
XScreenSaver, See screensaver
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