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Preface

This book is geared towards network administrators familiar with the SNA
protocol, Unix, Windows, and server technology and who are responsible for
the installation and maintenance of the SunLink SNA 9.1 PU2.1 server. Sun
assumes that you are familiar with network administration, network
management, and the related terminology therein.

Before You Read This Book
Ensure that you have completed the installation of the SunLink SNA 9.1
software. Refer to the SunLink SNA 9.1 End Node Planning and Installation Guide
and the SunLink SNA 9.1 for Solaris Release Notes for installation instructions.

How This Book Is Organized
This manual contains the following chapters covering the following topic
areas:

Chapter 1, “Overview,” discusses the SunLink SNA 9.1 PU2.1 server and
introduces its features and functions.

Chapter 2, “Using the Administration Program,” describes how to start the
Sun Graphical Management Interface (SunGMI), how to use the components of
the main window, describes how to manage windows, and how to use the
dialog boxes provided by the SunGMI.
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Chapter 3, “Getting Started,” gets you started using the Graphical
Management Interface. Read this chapter carefully before you attempt any
administrative tasks on your server.

Chapter 4, “Configuring Systems,” describes how to configure the systems
that make up your Sun PU2.1 SNA Server.

Chapter 5, “Configuring PU2.1 Servers,” describes how to configure PU2.1
servers.

Chapter 6, “Configuring Connections,” describes how to add a Token Ring,
Ethernet, or FDDI connection, how to add a Synchronous Data Link Control
connection, and how to add a Qualified Logical Link Control connection.

Chapter 7, “Configuring PUs,” describes how to configure physical units
(PUs).

Chapter 8, “Configuring Dependent LUs,” describes how to configure a single
dependent logical unit (LU) or multiple dependent LUs, how to modify a
single dependent LU or a group of multiple LUs, how to delete a dependent
LU and how to configure an LU pool.

Chapter 9, “Configuring for LUType 6.2,” describes how to configure a local
independent logical unit (LU), how to configure a partner LU for a local
independent or dependent LU, how to configure the session mode for the LU-
LU pair, how to configure an LUType 6.2 user that can access a local
independent or dependent LU, how to configure a transaction program (TP)
that can be accessed by a local independent or dependent LU, how to configure
a TP resource access list for a TP that requires a user ID, a profile, or a user ID
and profile security verification, and how to modify an LU pool.

Chapter 10, “Configuring Users,” describes how to define a user record, how
to set up a user group, how to modify or delete a user record, how to delete a
user from a group, and how to delete access to a dependent LU from a user or
user group.

Chapter 11, “Managing the Server,” describes how to control access to the Sun
PU2.1 SNA Server by clients (users) and by operators (system/network
administrators), how to determine the number of manager systems to define,
how to create manager systems, and how to recover when 50% or fewer of the
manager systems are available, how to modify the active configuration and
how to save and distribute the updates, how to create and modify off-line
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configurations and how to activate an off-line configuration, how to start and
stop connections to the SNA network, and how to make resources unavailable
or available for client use.

Chapter 12, “Troubleshooting,” covers the diagnostic tools provided to help
you and SunLink Technical Support staff determine the cause of any problems
you may encounter. These tools include status monitoring, scope tracing, and
resource tracing, and NetView Response Time Monitor (RTM).

Appendix A,  “Resource Planning Forms,” describes what you need to know
before you begin designing your network.

Appendix B,  “Name Resolution,” describes the Domain Name System (DNS),
the Sun Name Server, and how to update the DNS configuration before you
use the Sun Name Server. It also describes the considerations to keep in mind
when using the Sun Name Server with APPC.

Appendix C,  “SNA Concepts,” provides a high level introduction to SNA and
its components for those unfamiliar with SNA.

Appendix D,  “IBM Token Ring Concepts,” outlines the basic concepts of IBM
Token Ring networking.

Appendix E,  “Load Balancing,” provides a brief description of load balancing.

Appendix F,  “Host Configurations,” describes how to coordinate host
configurations for 3270, 3770/RJE, APPC, and 5250 clients.

Appendix G,  “LUType 6.2 Security,” describes session-level security for peer-
to-peer operations, conversation-level security for peer-to-peer operations, and
Unix-level security for peer-to-peer operations. It also shows you how to
specify minimum security requirements for peer-to-peer operations and how to
use the TP resource access list to verify resource access for peer-to-peer
operations.
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Typographic Conventions
The following table describes the typographic changes used in this book.

Shell Prompts
The following table shows the default system prompt and superuser prompt
for the C shell, Bourne shell, and Korn shell.

Typeface or
Symbol Meaning Example

AaBbCc123 The names of commands,
files, and directories;
on-screen computer output.

Edit your .login  file.
Use ls -a  to list all files.
% You have mail.

AaBbCc123 What you type, when
contrasted with on-screen
computer output.

% su
Password:

AaBbCc123 Command-line variable:
replace with a real name or
value.

To delete a file, type rm filename.

Book titles, new words or
terms, words to be
emphasized

Read Chapter 6 in the User’s Guide.
These are called class options.
You must be root to do this.

Shell Prompt

C shell machine_name%

C shell superuser machine_name#

Bourne shell and Korn shell $

Bourne shell and Korn shell
superuser

#
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Related Documents
The following Sun documents contain topics that relate to the information
in SunLink SNA 9.1 PU2.1 Server Configuration Guide.

Application Deliverable Partnumber

Installation SunLink SNA 9.1 End Node Planning and Installation Guide 802-2665-12

Administration SunLink SNA/X.25 9.1 Configuration and Administration Guide 802-3166-12

Configuration and user
information

SunLink 3270 OpenClient 9.1 Configuration and User’s Guide 802-2667-12

Programming information SunLink Client IBM 3270 9.1 Programmer’s Guide 802-2668-12

Configuration and user
information

SunLink RJE/3770 9.1 Configuration and User’s Guide 802-2672-12

Configuration information SunLink SNA PU 2.1 9.1 Server Configuration Guide 802-2673-12

Reference information SunLink SNA SNM 9.1 Reference Manual 802-2674-12

Programming information SunLink LU0 9.1 API Programmer’s Guide 802-2676-12

Programming information SunLink SNA Peer to Peer LU 6.2 9.1 Programmer’s Guide 802-2680-12

Programming information SunLink SNA Peer to Peer CPI-C 9.1 Programmer’s Guide 802-2681-12

Late-breaking news SunLink SNA 9.1 for Solaris Release Notes 802-3165-12

CD-ROM insert for the
Answerbook package

CD-ROM insert for the AnswerBook version of the SunLink
SNA 9.1 product

804-5670-10

CD-ROM insert SunLink SNA 9.1 Gateway CD-ROM 804-5649-10

CD-ROM insert SunLink SNA 9.1 RJE/3770 804-5650-10

CD-ROM insert SunLink SNA/SNM 804-5651-10

CD-ROM insert SunLink SNA LU 0 804-5652-10

Programming information Solstice X.25 9.0 System Administrator’s Guide 802-7565-10

Programming information SolarNet PC Protocol Services 1.1 with IPX/SPX for the
Solaris 2.X Operating Environment

802-3531-10
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Other Publications

The following are non-Sun Microsystems publications.

Systems Network Architecture
• IBM Systems Network Architecture Concepts and Products, GC30-3072
• IBM Systems Network Architecture Technical Overview, GC30-3073
• IBM VTAM Installation and Resource Definition, SC23-0111
• IBM Network Control Program Resource Definition Guide, SC30-3349
• IBM 3174 Establishment Controller Planning Guide, GA27-3862
• IBM VTAM Operation, SC23-0113
• IBM NetView Operation, SC30-3364
• IBM 3174 Establishment Controller Functional Description, GA23-0218-11

DNS
• DNS & Bind, Paul Albitz and Cricket Liu, O’Reilly and Associates.

LU6.2 and CPI-C
• IBM Systems Network Architecture Transaction Programmer's Reference Manual

for LU Type 6.2, GC30-3084
• Systems Application Architecture Common Programming Interface

Communications Reference, SC26-4399

IBM Token Ring
• IBM Token-Ring Network Architecture Reference, SC30-3374

X.25
• IBM X.25 Network Control Program Packet Switching Interface, Planning and

Installation, SC30-3501
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Ordering Sun Documents
SunDocsSM is a distribution program for Sun Microsystems technical
documentation. Easy, convenient ordering and quick delivery is available from
SunExpress. You can find a full listing of available documentation on the World
Wide Web: http://www.sun.com/sunexpress/

Sun Welcomes Your Comments
Please use the Reader Comment Card that accompanies this document. We are
interested in improving our documentation and welcome your comments and
suggestions.

If a card is not available, you can email or fax your comments to us. Please
include the part number of your document in the subject line of your email or
fax message.

• Email: smcc-docs@sun.com

• Fax: SMCC Document Feedback
1-415-786-6443

Table P-1 SunExpress Contact Information

Country Telephone Fax

United States 1-800-873-7869 1-800-944-0661

United Kingdom 0800-89-88-88 0800-89-88-87

Canada 1-800-873-7869 1-800-944-0661

France 0800-90-61-57 0800-90-61-58

Belgium 02-720-09-09 02-725-88-50

Luxembourg 32-2-720-09-09 32-2-725-88-50

Germany 01-30-81-61-91 01-30-81-61-92

The Netherlands 06-022-34-45 06-022-34-46

Sweden 020-79-57-26 020-79-57-27

Switzerland 0800-55-19-26 0800-55-19-27

Holland 06-022-34-45 06-022-34-46

Japan 0120-33-9096 0120-33-9097
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Overview 1

This chapter contains the following sections:

• Overview - provides a brief description of the Sun PU2.1 SNA Server.
• Sun PU2.1 SNA Server Components - describes the components of the Sun

PU2.1 SNA Server that you will most frequently encounter.
• Systems and Servers - describes the meaning of configuring a system and

configuring a PU2.1 server.
• Connection Types - describes LAN, SDLC, QLLC, and channel connection

types.
• PU2.1 Emulation - describes the physical unit (PU) types supported by the

Sun PU2.1 SNA Server.
• LU Emulation - describes the logical unit types supported by the Sun PU2.1

SNA Server.
• LU Pools - describes how the Sun PU2.1 SNA Server uses LU pools.
• Users and User Groups - describes how to control access to resources by

setting up user records and user groups.
• Supported Clients - describes the clients supported by the Sun PU2.1 SNA

Server.
• Manager Network - describes how you can use multiple instances of the

Sun PU2.1 SNA Server to protect against system failure.
• Peer-to-Peer Operations - describes how the Sun PU2.1 SNA Server

supports peer-to-peer operations.
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1.1 Overview
The Sun PU2.1 SNA Server allows TCP/IP and SPX/IPX networked clients to
communicate with IBM SNA mainframes and midrange systems. You can
create an SNA enterprise network by distributing the server across several
networked systems and connections using different vendor platforms. By
distributing the server, you ensure that clients can access their applications
even when a system or connection fails.

Users see the distributed server as a single virtual gateway. You can manage
the SNA enterprise network as a single entity by using a graphical interface.

The Sun PU2.1 SNA Server can support tens of thousands of sessions. You can
add new systems into the distributed server environment at any time,
allowing you to add capacity incrementally as you migrate your users over
time from their current SNA access.

The following figure illustrates the Sun PU2.1 SNA Server in an SNA
enterprise network.

Figure 1-1 Sun PU2.1 SNA Server and Clients

Mainframe Front End
Processor

Sun PU2.1
SNA ServerAS/400

FTP to Host Router Network
TCP/IP and SPX/IPX

SNA 5250
Emulation

SNA LU6.2
Program

TN3270ESNA 3770
Emulation
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1.2 Sun PU2.1 SNA Server Components
The Sun PU2.1 SNA Server consists of several software components that
cooperate with each other to manage the distributed environment. The
following sections describe those components you will encounter most
frequently when using the server.

1.2.1 Graphical Management Interface

The Sun Graphical Management Interface (SunGMI) provides a graphical
interface for managing the Sun PU2.1 SNA Server. Using the SunGMI, you can
configure, monitor, and control the entire distributed server from a single
interface. For more information, refer to Chapter 2, “Using the Administration
Program.”

1.2.2 Gateway Manager

The Sun Gateway Manager (SunGMAN) is a network-level process that
manages the complexity of the distributed environment. The SunGMAN
maintains the configuration and status of the entire distributed server, provides
the Domain Name System (DNS) function, and supports the SunGMI.

To ensure that operational control is not lost and that new client connections
can be made, you can configure and run multiple instances of the SunGMAN
on multiple machines to provide a reliable manager network. If one SunGMAN
fails, the others can continue to provide service. For more information, refer to
Section 1.10, “Manager Network,” on page 1-19.

1.2.3 System Manager

The Sun System Manager (SunSMAN) is a system-level process that operates
on each system running a Sun PU2.1 server process. The SunSMAN processes
all connection requests from networked clients and performs access control.

As a Simple Network Management Protocol (SNMP) agent, the SunSMAN
responds to queries from all Sun Gateway Managers (and other SNMP
managers) and notifies these managers of system events using SNMP traps.
Since SNMP Version 2 is used as the basis for server management, security is
improved and you can use external SNMP managers, such as SunNet
Manager, HP OpenView, and NetView 6000, to manage the server.
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The client connection requests are directed to a system by the Sun Name
Server. For more information, refer to Section B.2, “Sun Name Server,” on
page B-3.

1.2.4 PU2.1 Server Process

The Sun PU2.1 server process (SunPU21) is the software component that
supports client connections and provides the actual data link connections to
SNA.

Each client connection requires a separate file descriptor. The number of client
connections that a PU2.1 server process can support depends on the file
descriptor limit of your operating system. For more information, refer to the
documentation for your system.

If you want a system to support more client connections than the process file
descriptor limit, you can install multiple PU2.1 server processes. You can also
install multiple PU2.1 server processes on symmetric multiprocessing (SMP)
platforms to take advantage of the multiple processors.

1.2.5 Sun Name Server

The Sun Name Server, which is part of the SunGMAN, is used with the DNS to
resolve resource requests from clients.

A client connects to the Sun PU2.1 SNA Server by specifying the name of the
resource it wants to access or by specifying its user name. If the client adds the
name of the Sun subdomain as an extension to the resource or user name, the
client instructs the local DNS to defer the resolution of the name to the Sun
Name Server. For more information about how the Sun Name Server resolves
resource requests from clients, refer to Section B.2, “Sun Name Server,” on
page B-3.

If the client requests an LU pool, the Sun Name Server performs load balancing
to direct the client to the system with the lightest load, with the highest
available bandwidth, and with available LUs. In addition, if the network is
configured appropriately, the Sun Name Server can direct the client to the
system in the most suitable geographical location. For more information, refer
to Appendix E, “Load Balancing.”
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1.2.6 Configuration Options

You can install the components of the Sun PU2.1 SNA Server in a variety of
ways, depending on your needs. For example, you could install all the
components on a single system. In this case, you would install one SunGMI,
one SunGMAN, and one SunSMAN. The number of SunPU21 processes would
depend on the number of client connections required. Refer to the following
figure.

Figure 1-2 Sample Configuration (Single System)

As another example, you could distribute the Sun PU2.1 SNA Server among
several systems. In this case, you could install the SunGMI on one system, the
SunGMAN on another system, and one SunSMAN on each system in the
network running a PU2.1 server process. The number of PU2.1 server processes
would depend on the number of client connections required. Refer to the
following figure.

SunGMI

SunGMAN

SunSMAN

SunPU2.1 SunPU2.1

System 1
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Figure 1-3 Sample Configuration (Multiple Systems)

As a final example, you could create a manager network by installing multiple
instances of the SunGMAN. Refer to the following figure. For more
information about manager networks, refer to Section 1.10, “Manager
Network,” on page 1-19.

System 1 System 2

System 3 System 4

SunGMI SunGMAN

SunSMAN

SunPU2.1

SunSMAN

SunPU2.1 SunPU2.1
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Figure 1-4 Sample Configuration (Manager Network)

1.3 Systems and Servers
The Sun PU2.1 SNA Server allows you to configure systems and PU2.1 servers.

When you configure a system, you define the machines that connect to your
SNA network and the distribution of functions among those machines. You can
add new systems at any time and bring them on-line without affecting other
systems.

When you configure a PU2.1 server, you define the SNA control point for the
local PU2.1 device, the Logical Link Control (LLC) parameters, and UNIX

security options. Each PU2.1 server supports its own data link connections.

For more information about configuring systems, refer to Chapter 4,
“Configuring Systems.” For more information about configuring PU2.1 servers,
refer to Chapter 5, “Configuring PU2.1 Servers.”

SunSMAN

SunPU2.1

System 1 System 2

System 3 System 4

SunGMAN SunGMAN

SunSMAN

SunPU2.1
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1.4 Connection Types
The following sections describe the connection types supported by the Sun
PU2.1 SNA Server. For more information about configuring connections, refer
to Chapter 6, “Configuring Connections.”

1.4.1 LAN Connections

The Sun PU2.1 SNA Server supports IBM Token Ring (802.5), Ethernet (802.2),
and FDDI local area network (LAN) connections.

You can connect the server across a LAN in one of the following ways:

• Directly to a host with an integrated communications adapter.
• To a communications controller.
• To an IBM 3174. Note that for IBM Token Ring, the IBM 3174 must support

the Token Ring 3270 gateway feature.

LAN networking consists of two data link control sublayers, Logical Link
Control (LLC) and Medium Access Control (MAC), which control the
transmission of data across the LAN.

For IBM Token Ring, the network can have a data rate of either 4 megabits per
second (4 Mb/s) or 16 Mb/s. The networks themselves can be interconnected
by using repeaters, source routed bridges, or transparent bridges.

Note – Ethernet and FDDI connections are not supported on all platforms. For
more information, contact your Sun sales representative.

1.4.2 SDLC Connections

The Synchronous Data Link Control (SDLC) protocol controls the transmission
of data across leased lines or switched (standard dial-up telephone) lines. You
can use SDLC to connect the Sun PU2.1 SNA Server to a communications
controller or to a peer system. Other supported features include:

• Point-to-point lines (full duplex).
• Multi-point lines (half duplex).
• Primary, secondary, and negotiable station roles.
• NRZ and NRZI encoding.
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To have an XID-3 exchange and independent LU support, you must set DLC
Role to Negotiable. Otherwise, SDLC support is PU 2.0 only.

1.4.3 QLLC Connections

You can use the Qualified Logical Link Control (QLLC) protocol to connect the
Sun PU2.1 SNA Server to an IBM communications controller over X.25 Packet
Switched Data Networks (PSDNs) by using X.25 virtual circuits (VCs). Both
Permanent Virtual Circuits (PVCs) and dial-in and dial-out Switched Virtual
Circuits (SVCs) are supported.

The communications controller runs the IBM NCP Packet Switched Interface
(NPSI) program (Version 2/Release 1 or higher) and uses the QLLC protocol to
control the transmission of data across the VC.

QLLC connections support packet and window size negotiation and point-to-
point lines.

Although multi-point lines are not supported, multiple QLLC connections can
be supported over a single link over the X.25 PSDN.

Note – The QLLC protocol only supports PU 2.0.

1.5 PU2.1 Emulation
When operating in traditional hierarchical SNA networks, the Sun PU2.1 SNA
Server emulates a PU2/PU2.1 device, such as a 3274 cluster controller or a 3174
establishment controller.

When operating in peer-to-peer SNA networks, the Sun PU2.1 SNA Server
uses Advanced Peer-to-Peer Networking (APPN) or Low Entry Networking
(LEN) to connect to a PU2.1 peer system, such as AS/400 and System/36. The
server supports traditional display emulation and hierarchical connectivity and
peer-to-peer connectivity using the SNA LUType 6.2 protocols.

The number of physical units you can configure depends on the connection
type, as follows:

• IBM Token Ring, Ethernet, and FDDI LAN connections - You can
configure multiple PUs for each Service Access Point (SAP) and multiple
SAPs for each network interface controller.
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• SDLC and QLLC connections - For point-to-point lines, you can configure
one PU for each line. For multi-point lines, you can configure multiple PUs
for each line.

• Channel connections - You can configure multiple PUs on the channel. Each
PU uses a separate subchannel address.

A PU2/PU2.1 emulated by the Sun PU2.1 SNA Server is activated by the IBM
mainframe Virtual Telecommunications Access Method (VTAM). VTAM
establishes a System Services Control Point (SSCP)-to-PU control session with
each PU2/PU2.1 during activation. The server maintains the SSCP-PU control
session and opens an interface to allow client programs to access it.

For more information about configuring PUs, refer to Chapter 7, “Configuring
PUs.”

1.6 LU Emulation
The Sun PU2.1 SNA Server supports both dependent LUs and independent
LUs, as follows:

• Dependent LUs - Each PU2.1 device can support the following types of
dependent LU: LUType 0, LUType 1, LUType 2, LUType 3, and LUType 6.2.

VTAM activates the dependent LUs, which rely on the SSCP-PU control
session for activation and session initiation. During activation, the IBM
mainframe establishes an SSCP-LU control session with each activated
dependent LU. The server maintains the SSCP-LU control session and opens
an interface to allow client programs to access it.

The server assists in the establishment of dependent LU-LU sessions. An
IBM mainframe application (primary LU) asks to bind with a client program
(secondary LU). If a client program is present at the LU, the server
establishes an SNA session.

You can group dependent LUs into LU pools to control access to the
dependent LUs. For more information, refer to the following section.

• Independent LUs - Independent LUs are activated locally either through
auto-activation or through operator control. Independent LUs can be
LUType 6.2 only.
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For independent LU-LU sessions, either independent LU can initiate the
session. In addition, multiple sessions, known as parallel sessions, can be
established between two independent LUs.

For both SSCP-LU control sessions and LU-LU application sessions, the Sun
PU2.1 SNA Server enforces the SNA protocols.

For more information about configuring dependent LUs, refer to Chapter 8,
“Configuring Dependent LUs.” For more information about configuring
independent LUs, refer to Chapter 9, “Configuring for LUType 6.2.”

1.7 LU Pools
LU pools are groups of dependent LUs that are accessible to certain users. If a
user specifies an LU pool name instead of an LU name, the Sun PU2.1 SNA
Server assigns the user to one of the dependent LUs in the LU pool. All
dependent LUs in a particular LU pool must be of the same type (all LUType
0, all LUType 1, all LUType 2, all LUType 3, or all LUType 6.2).

Although you can assign any type of dependent LU to an LU pool, LU pools
are most commonly used for LUType 2 dependent LUs for access by 3270
clients.

You can provide redundancy by distributing an LU pool across multiple
systems. If some of the systems are removed from operation, the remaining
systems can still accept new client connections.

If the LU pool is distributed across multiple systems, the server uses load
balancing to direct the client to the system with the lightest load, with the
highest available bandwidth, and with available LUs. In addition, if the
network is configured appropriately, the server can direct the client to the
system in the most suitable geographical location. For more information, refer
to Appendix E, “Load Balancing.”

LU pools are also useful for the following:

• You can simplify user access by providing all users with a single LU pool
name, instead of providing each user with a separate dependent LU name.
Users are isolated from configuration changes.

• You can maximize the use of host resources by defining only enough host
dependent LUs to meet your peak usage. Note, however, that defining
additional resources ensures adequate availability if a system or connection
fails.
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• A group of intermittent users can use limited resources more efficiently. For
example, if 15 users need only intermittent access to five dependent LUs,
you can create an LU pool for these users.

• By selecting an LU pool, a client or group of clients can ensure that
connections are limited to a known set of dependent LUs.

• If you want to limit a group of users to a single host and the host is
connected to a particular PU2.1 server, creating an LU pool ensures that any
client software started by these users connects to the correct host.

• Providing an LU pool separates the resources from the client, allowing
changes to the server without requiring changes to the client configuration.

For more information about creating an LU pool, refer to Section 8.4, “Creating
an LU Pool,” on page 8-9.

1.8 Users and User Groups
The Sun PU2.1 SNA Server allows you to create user records for clients and for
system/network administrators. You can also use a wild-carded fully-qualified
domain name or a masked IP address to specify a group of users (clients or
system/network administrators) that have common requirements without
specifying each user individually.

User records allow you to control the resources to which a client can connect.
You define a list of preferred and alternate default resources in the user record.
If the client does not (or cannot) specify a resource when connecting to the
host, the server tries to connect the client to the preferred default resource. If
the preferred resource is not available, the server sequentially checks the
alternate resources until it finds an available LU. If your LUs are
geographically dispersed, you can use multiple default resources to ensure that
LUs closest to the client are checked first.

You can specify one or more of the following default resources for each client:

• Dependent LU or independent LU - Allows you to provide a single known
LU for the client connection. In case of problems, you can determine which
LU the client was connected to. For a dependent LU, you can add this user
record to the access list of the LU to restrict the LU to that client connection.

Note – If you use an LU as the default resource and a system or network
outage occurs, the client may not be connected since the LU is not available.
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• LU pool - Allows you to maximize access to the host system. A client does
not depend on a system or a connection to access the host system, but can
connect to a dependent LU as long as the LU is available from the pool.

• PU - Allows you to provide several resources for the client connection. If a
particular dependent LU is unavailable or in use, the client can connect to
another LU under the PU. In addition, multiple users from a node can
access the host system.

Note – If you use a PU as the default resource and a system outage occurs,
local area users may not have host connections since the PU is not available.

Note – If you use multiple default resources, Sun recommends that you do not
specify a PU in the list.

For an LUType 2 client, if you do not specify a default resource or if none of
the default resources exist, and if the client does not specify a resource, the
server connects the client to the LU pool PUBLIC. For an LUType 0, LUType 1,
LUType 3, or LUType 6.2 client, if you do not specify a default resource or if
none of the default resources exist, and if the client does not specify a resource,
the software returns an error.

Note that you can also specify the users or user groups that can access a
resource (dependent LU or LU pool) in the configuration of the resource. This
allows you to make changes to a user record without modifying the resource.
Note that if no users or user groups are specified for a resource, any client can
access the resource.

User records also allow you to specify which resources system/network
administrators can configure and control. By default, all system/network
administrators are master operators. As a master operator, you can modify the
configuration of the server or change the status of resources without
restriction. You can also create user records to restrict the access of other
system/network administrators to a particular portion of the active
configuration, enabling you to establish independent operator domains.

Note – You can add, modify, or delete users at any time without affecting
existing sessions.
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For more information about configuring users and user groups, refer to
Chapter 10, “Configuring Users.”

1.9 Supported Clients
Client programs access SNA sessions through ports provided by the Sun PU2.1
SNA Server. The server provides the following services for client programs:

• SNA protocol enforcement.
• Lower-level SNA protocol support.
• Host notification of special events. If no client program is registered for a

dependent LU port, the server notifies the IBM mainframe that the
dependent LU is powered-off. If a client program registers for a dependent
LU port, the server notifies the IBM mainframe that the dependent LU is
powered-on.

The following sections describe the clients supported by the Sun PU2.1 SNA
Server. For more information, refer to your client documentation.

In addition, contact your Sun sales representative for information about third-
party software products that use the communications services of the Sun PU2.1
SNA Server. These third-party software products include on-line transaction
programs, data movement utilities, and distributed databases.

Note – No special client software is required to access the Sun PU2.1 SNA
Server.

1.9.1 Traditional Telnet 3270

Traditional Telnet 3270 (TN3270) is the standard method for connecting 3270
terminal emulators to IBM mainframes over TCP/IP networks. The Sun PU2.1
SNA Server, which includes a Telnet 3270 server, allows TN3270 clients to
connect to an IBM mainframe by using the SNA protocol. You do not have to
run TCP/IP on your mainframe.

You can configure LUs for traditional TN3270 clients as either terminals or
printers. Typically, use LU pools for assignment of terminal clients and use
specific LU assignment for printer clients.
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Because a traditional TN3270 client cannot specify a resource to connect to, the
Sun PU2.1 SNA Server allows you to define a user record for the client. The
user record includes either an IP address or an IP hostname to identify the
client and one or more default resources to be used by the client. The server
looks for a user record with either an IP address or IP hostname that matches
the IP address or IP hostname of the client and assigns one of the default
resources defined in the user record to the client at connection time. The
default resource can be an LU, a PU, or an LU pool. For more information
about configuring a user record, refer to Chapter 10, “Configuring Users.”

The Sun PU2.1 SNA Server supports NetView Response Time Monitoring
(RTM) for traditional TN3270 clients. For more information about initiating the
measurement of RTM statistics, refer to Section 12.1.1.4, “Using the RTM
Table,” on page 12-14.

1.9.2 Extended Telnet 3270E

Extended TN3270E (RFC 1646 and RFC 1647) provides the features of
traditional TN3270 as well as the following:

• TN3287 printer support.
• Associated printer support. You can associate a printer LU with a TN3270

terminal LU. This allows the user to configure the terminal and printer
emulators by knowing only the terminal LU name. At connection time, the
printer emulator requests the LU associated with the terminal, provides the
terminal LU name, and is connected to the correct printer LU.

• LUType 1 and LUType 3 printer support. You can use printers for either
SNA Character Stream (SCS) or 3270 Data Stream (DS) style printing.

• Access to SNA bind image and unbind notification.
• Support for ATTN and SYSREQ keys. The ATTN key causes an interrupt to

the application (Signal RU). The SYSREQ key provides access to SSCP-LU
sessions.

• Support for positive or negative SNA response handling by the client
software.

• Support for device pools. You can group terminals or printers into pools to
satisfy generic or specific resource requests.

Extended TN3270E clients can specify a resource (either an LU or an LU pool)
when connecting to the host. In addition, the Sun PU2.1 SNA Server allows
you to define a user record for an extended TN3270E client. The user record
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can contain one or more default resources to be used by the client when none
is specified in the connection request. For more information about configuring
a user record, refer to Chapter 10, “Configuring Users.”

1.9.3 Sun 3270

Sun 3270 (Sun3270) uses the LUType 2 interface to connect Sun 3270 terminal
emulators to IBM mainframes. Sun3270 provides the features of traditional
TN3270, the features of extended TN3270E, and additional features, such as the
exchange of keep-alive information.

Sun3270 clients can specify a resource (either an LU, an LU pool, or a PU/LU
local address pair) when connecting to the host. In addition, the Sun PU2.1
SNA Server allows you to define a user record for a Sun3270 client. The user
record can contain one or more default resources to be used by the client when
none is specified in the connection request. For more information about
configuring a user record, refer to Chapter 10, “Configuring Users.”

Sun3270 uses TN3270E to access SNA hosts. It emulates 3278 (models 2
through 5), 3279, and 3279G display stations, and 3287 printers. EHLLAPI,
IND$FILE file transfer, and GDDM are also supported.

1.9.4 Sun 3770/RJE

Sun 3770 (Sun3770) is an SNA 3770 emulator for an IBM 3776 workstation
device. It is used for Remote Job Entry (RJE) and batch file transfer over SNA
networks.

Sun3770 clients can specify a resource (either a PU, an LU, or an LU pool)
when connecting to the host. Since a Sun3770 client represents an RJE station
and can connect to multiple LUs, LU pools ensure that specific LUs are
assigned to a Sun3770 client at connection time. You can also define a user
record for the Sun3770 client and then specify the LU pool as the default
resource. For more information about creating an LU pool, refer to Section 8.4,
“Creating an LU Pool,” on page 8-9. For more information about configuring a
user record, refer to Chapter 10, “Configuring Users.”
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1.9.5 Sun APPC

Advanced Program-to-Program Communication (APPC) allows programs on
peer systems to communicate with each other over an SNA network. Sun
APPC (SUNWappc) allows you use the SunLU6.2 Transaction Programmer's
Reference verbs or the Common Programming Interface for Communications
(CPI-C) calls to write APPC transaction programs (TPs) to interact with both
IBM mainframe and SNA peer applications. For more information, refer to the
SunLU6.2 Transaction Programmer’s Reference and SunLU6.2 CPI-C
documentation listed in “Related Sun Documents” in the Preface.

For SunAPPC clients, you must configure the following:

• Local independent LU or local dependent LU. For information on
configuring an independent LU, refer to Section 9.1, “Configuring an
Independent LU,” on page 9-2. For information on configuring a dependent
LU, refer to Chapter 8, “Configuring Dependent LUs.”

• Partner LU for the local LU. For more information, refer to Section 9.2,
“Configuring a Partner LU,” on page 9-4.

• Session mode for the LU-LU pair. For more information, refer to Section 9.3,
“Configuring the Session Mode,” on page 9-7.

• LU6.2 users that can access the local LU. For more information, refer to
Section 9.4, “Configuring an LUType 6.2 User,” on page 9-12.

• Invocable TPs that are accessed by the local LU and the control operator TPs
that require special privileges. For more information, refer to Section 9.5,
“Configuring a Transaction Program,” on page 9-13.

Note – You can configure a TP for a specific local LU (Type 6.2) or for all local
LUs (Type 6.2). In addition, SNA service transaction programs, such as Change
Number of Sessions (CNOS), do not require a TP definition since they are
automatically defined.

If your Sun PU2.1 SNA Server is installed on multiple systems, you can
configure APPC on more than one of the systems. A networked TP can locate
the server it requires by using the Sun Name Server. The Sun Name Server
resolves requests for LU names to the system on which the local LU is
configured. For more information, refer to Section B.4, “Using the Sun Name
Server with APPC,” on page B-7.



1-18 SunLink SNA 9.1 PU2.1 Server Configuration Guide—August 1997

1

1.9.6 Telnet 5250 and Sun 5250

Telnet 5250 (TN5250) is the standard method for connecting 5250 display
system emulators to IBM midrange systems, such as AS/400, System/36, and
System/38, over TCP/IP networks. Sun 5250 (Sun5250) connects to the host
system by using TN5250 protocols.

For TN5250 and Sun5250 clients, you must configure the following:

• Local independent LU. For more information, refer to Section 9.1,
“Configuring an Independent LU,” on page 9-2.

• Partner LU for the local LU. For more information, refer to Section 9.2,
“Configuring a Partner LU,” on page 9-4.

• Session mode for the LU-LU pair. For more information, refer to Section 9.3,
“Configuring the Session Mode,” on page 9-7.

Note – Before you configure resources for TN5250 and Sun5250 clients, Sun
recommends that you consult with your AS/400 system programmer to
coordinate the AS/400 and Sun configurations.

1.9.7 File Transfer Protocol

The Sun PU2.1 SNA Server includes a file transfer protocol (FTP) that converts
TCP/IP file transfers into SNA file transfers. This allows a TCP/IP FTP client
to get files from and put files on any IBM mainframe or midrange system that
supports AFTP (APPC File Transfer Protocol) communications, without
running TCP/IP on the system. AFTP is available on all IBM SAA platforms
and is included in VTAM 4.2. Earlier versions of VTAM support AFTP as a
licensed product.

Note that you can configure the Sun AFTP server to run on one or more
systems.

For FTP clients, you must configure the following:

• Local independent LU or local dependent LU. For information on
configuring an independent LU, refer to Section 9.1, “Configuring an
Independent LU,” on page 9-2. For information on configuring a dependent
LU, refer to Chapter 8, “Configuring Dependent LUs.”

• Partner LU for the local LU. For more information, refer to Section 9.2,
“Configuring a Partner LU,” on page 9-4.
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• Session mode for the LU-LU pair. For more information, refer to Section 9.3,
“Configuring the Session Mode,” on page 9-7.

• LU6.2 users that can access the local LU. For more information, refer to
Section 9.4, “Configuring an LUType 6.2 User,” on page 9-12.

• Invocable TPs that are accessed by the local LU and the control operator TPs
that require special privileges. For more information, refer to Section 9.5,
“Configuring a Transaction Program,” on page 9-13.

• Note that you can configure a TP for a specific local LU (Type 6.2) or for all
local LUs (Type 6.2). In addition, SNA service transaction programs, such as
Change Number of Sessions (CNOS), do not require a TP definition since
they are automatically defined.

1.9.8 Other Sun SNA Clients

The Sun PU2.1 SNA Server also provides the TCP/IP-to-SNA gateway function
for the following Sun SNA clients:

• SunLU0 API - A series of library routines that allow you to write programs
that interact with IBM mainframe applications over TCP/IP. Your programs
have complete access to the SNA Request Headers and Request Units and
can use both LU-LU and SSCP-LU sessions.

• SunNMI API - A series of library routines that allow you to write programs
to interact with network management programs, such as NetView, residing
on the IBM mainframe. This API facilitates communication over SSCP-PU
control sessions.

• SunSNM - Captures events generated by SunNet Manager and reports
these events as SNA alerts to IBM NetView for logging and analysis.
SunSNM also allows NetView operators to issue RUNCMDs for execution
on remote UNIX systems. SunSNM is available on Sun SPARC-based
systems only.

1.10 Manager Network
To ensure the reliability of your system and protect against system failure, you
can create multiple instances of the SunGMAN and include them in a manager
network. Each instance of the SunGMAN is referred to as a manager system. If
one manager system fails, the Sun PU2.1 SNA Server continues to function.
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Each manager system automatically sets up a connection to each of the other
manager systems. When more than 50% of the manager systems are in contact
with each other, a quorum is established and the software automatically selects
one of the manager systems to be the primary manager system. The other
manager systems are secondary manager systems. When you connect to the
Sun PU2.1 SNA Server from the SunGMI, the Sun Name Server routes your
connection to the primary manager.

Only the primary manager system can make changes to configurations. When
you make a configuration change and save it, the primary manager system
updates the configuration database and distributes the updated configuration
to all the other manager systems in the network using a 2-phase commit
protocol. Since the complete configuration is replicated on each manager
system, data is not lost if a manager system fails, and service is not interrupted
while a backup is restored.

Both the primary manager system and the secondary manager systems can
update the status of resources, distribute event information, handle DNS
requests and return the IP addresses of the system where the specified
resource can be found, and perform load balancing. If a manager system is
located in each physical site, requests for resource location and load balancing
can be handled by the local manager system, reducing the time delay for client
requests.

If a manager system loses contact with the others, the manager network
continues to operate provided that a quorum is maintained among the
remaining manager systems. This prevents two (or more) disconnected
fragments of the manager network from attempting to manage the Sun PU2.1
SNA Server at the same time. If a quorum cannot be established, configuration
capability is disabled and only DNS requests can be performed. This
guarantees that the distributed database is correct at all times.

If the primary manager system fails and the remaining manager systems can
establish a quorum, a new primary manager system is elected. The primary
manager system is the manager system with the most up-to-date configuration.
If a manager system rejoins the manager network or if a new manager system
is created and added to the manager network, that manager system receives
the latest configuration from the primary manager system.

For more information on creating manager systems, refer to Section 11.3.2,
“Adding a Manager System,” on page 11-9.



Overview 1-21

1

1.11 Peer-to-Peer Operations
The Sun PU2.1 SNA Server supports peer-to-peer operations between a PU2.1
device and either a PU4 or PU5 device or another PU2.1 device, as follows:

• PU4 or PU5 device - The physical connection between the PU2.1 device and
a PU4 or PU5 device, such as a 3745 communications controller or an
ES/9000 mainframe, can be through any of the supported connection types.
For more information, refer to Section 1.4, “Connection Types,” on page 1-8.

For SDLC and QLLC connections, the local link station can assume a
primary, secondary, or negotiable role. Note that in traditional SNA
networks, only the secondary role is supported.

PU2.1 devices connect directly to VTAM in a PU5 device.

When using the Network Control Program (NCP), peripheral node Type2.1
support is included in Version 4, Release 3. You do not have to define the
traditional NCP parameters, such as DATMODE, MAXDATA, MAXOUT, MODULO,
and PASSLIM, since this information is conveyed on the XID. You should,
however, set PUTYPE=2 and XID=YES in the NCP PU macro definition.

• PU2.1 device - No host configuration is necessary. Information about the
device configuration is conveyed between the two devices, using their XID
exchange. The XID contains information about station identification, role,
modulo, outstanding frames, and maximum frame size.

The Sun PU2.1 SNA Server includes the SunLU6.2 security utility, which
provides both LU6.2-based security and UNIX-based security for peer-to-peer
operations.

For each local LUType 6.2, you can define a list of remote LUType 6.2 users
who are allowed to run TPs on the LU. In addition, you can define a list of
users who are allowed to run TPs on any local LU. When conversation-level
security is required, access security parameters in incoming Attach requests are
verified against this LUType 6.2 user information. If the Sun PU2.1 SNA Server
is configured to perform UNIX-level security, you do not have to specify
LUType 6.2 user passwords because users are verified with UNIX password
security. You can restrict TP access to a subset of the defined LUType 6.2 users.

For more information, refer to Appendix G, “LUType 6.2 Security.”
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This chapter contains the following sections:

• Starting the SNA Server Administration Program - describes how to start
the Sun Graphical Management Interface (sungmi).

• Using the Main Window - describes the components of the main window.
• Using Sub-Windows - describes the sub-windows that the SunGMI

supports.
• Managing Windows - describes how to manage windows.
• Selecting Items - describes how to select items in a window.
• Initiating Actions - describes how to initiate actions from the SunGMI.
• Using Dialog Boxes - describes how to use the dialog boxes provided by the

SunGMI.

2.1 Starting the Graphical Management Interface
The Sun Graphical Management Interface (SunGMI) allows you to perform
administrative tasks on the Sun PU2.1 SNA Server. To start the SunGMI,
execute the following command:

sungmi [X options] [-p password] domain &

where

sungmi is the name of the command.

X options are any standard X options (see X(1) for details).
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password specifies the password to use when connecting to the Sun PU2.1 SNA
Server.

domain is the name of the Domain Name System (DNS) domain implemented
by the Sun PU2.1 SNA Server.

If you do not specify a domain name, the software displays the Connect to
domain dialog box.

:
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To specify a domain name:

1. Enter the following information:

Domain Name
The DNS domain implemented by the Sun PU2.1 SNA Server. Note that if you
enter the IP hostname or address of a system running the server, you may not
connect to the primary server.

Username
The operator user name you want to connect as. The default is your Unix user
ID. If a user record with Operator privileges is defined, this Username must
match the User ID field of the user record. If a user record with Operator
privileges is not defined, any name is valid.

Password
The password to use when connecting. If a password is defined in a user
record, this Password must match the Password field of the user record. If not,
this Password is ignored.

2. Click Connect (or press the Enter key) to initiate the connection to the
server.
Click Cancel to abandon the connection attempt. Note that if you abandon
the connection attempt, the only actions you can perform are connecting to
the domain and exiting from the server.

Click Help to display more information about the dialog box.

After you connect to the domain, the software displays the main window. For
more information about the main window, refer to the next section.

2.2 Using the Main Window
The following figure illustrates the main window.
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The components of the main window are described as follows:

• Menu bar - Includes menu commands for performing all actions. The menus
that are available at a particular time and the commands that are available
from a particular menu depend on the currently selected window and
resource. For more information about menus, refer to Section 2.6.2, “Menu
Commands,” on page 2-12.

• Toolbar - Contains buttons that provide shortcuts for performing menu
actions. Buttons are enabled only if their actions are available at the current
time for the currently selected resource. For more information about the
toolbar buttons, refer to Section 2.6.1, “Toolbar Buttons,” on page 2-11.

• Client area - The large central area used to display sub-windows.
• Status line - The line at the bottom of the main window. The left-most area

is a text area used to display descriptions of menu and toolbar items and
error and progress messages. The middle area is the progress meter, which
displays the progress of operations in both text and bar form. Whenever the
SunGMI is communicating with the Sun Gateway Manager (SunGMAN),

Menu bar

Toolbar

Status line

Sub-window

Client area
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the progress bar displays a blue bar that moves back and forth. The right-
most area indicates when messages are being sent to (Tx) and received from
(Rx) the SunGMAN.

• Sub-window - A window that contains domain or resource information. For
information about the supported sub-windows, refer to the following
section.

2.3 Using Sub-Windows
The Sun PU2.1 SNA Server supports the following sub-windows, which are
described in the following sections:

• Configuration window
• Managers window
• Applications window
• Licenses window
• Traces window
• Events window
• Resource window

2.3.1 Configuration Window

The configuration window displays a list of the configurations that currently
exist. The title bar contains the name of the domain that contains the
configurations.

When you start the SunGMI, the configuration window is displayed in the
client area. Note that if <None> is displayed in the configuration window, either
you are not connected to the primary manager or no primary manager exists.
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2.3.2 Managers Window

The Managers window displays a list of the manager systems included in the
manager network (the systems that are currently running the SunGMAN).
Select Window → Managers List to display the Managers window.

2.3.3 Applications Window

The Applications window displays a list of application programs currently
connected to the Sun PU2.1 SNA Server. The list includes all instances of the
SunGMI that are connected. Select Window → Application List to display the
Applications window.
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2.3.4 Traces Window

The Traces window displays information about traces currently in effect. Select
Window → Active Traces List to display the Traces window.

2.3.5 Events Window

The Events window displays event information about the current domain.
Select Window → Event Log to display the Events window.
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2.3.6 Resource Window

The resource window displays all of the resources in the current configuration.
To display the resource window for a configuration, double-click the
configuration in the configuration window. The title bar of the resource
window contains the configuration name and the current position in the
hierarchy.

Resource
tree

Resource
table
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The resource window contains the following areas:

• Resource tree - The left area of the resource window contains the resource
tree, which shows a tree representation of the complete contents of the
configuration. To expand or contract elements in the tree, either double-click
the element with the left mouse button (MB1) or click and hold the right
mouse button (MB3) and then select Expand Entry or Contract Entry from
the popup menu.

• Resource table - For the highlighted element in the resource tree, the right
area of the resource window contains the resource table, which is a list of
resources. The resources listed depend on the element selected in the
resource tree. For example, if the Systems icon is selected, the resource table
displays a list of systems.

2.4 Managing Windows
The following table describes the tasks you can perform to manage windows.

Table 2-1 Window Management Tasks

Task Action

Shrink a window to an icon. Click the small button icon in the window’s
upper right corner, or click the button in
the upper left corner of the window and
then select Minimize.

Maximize a window. Click the large button icon in the window’s
upper right corner, or click the button in
the upper left corner of the window and
then select Maximize.

Restore a window from an icon. Double-click the icon, or select the window
from the Window menu.

Small button icon

Large button icon
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2.5 Selecting Items
To select a single item in a sub-window or in a resource table, click the item.
You can select multiple adjacent items in one of the following ways:

• Place the mouse pointer on one of the items, click and hold the left mouse
button (MB1), and drag the mouse pointer up or down.

• Select the first item, scroll down the window until the last object is
displayed, and press Shift-MB1.

• Click and hold the right mouse button (MB3) and select Select All from the
popup menu.

2.6 Initiating Actions
You can initiate an action in one of the following ways:

• Click a button on the toolbar. For more information, refer to the following
section.

• Select a menu command. For more information, refer to Section 2.6.2, “Menu
Commands,” on page 2-12.

• Position the mouse pointer on the appropriate resource, click and hold the
right mouse button (MB3), and select the action from the popup menu.

Restore a maximized window to its
original size.

Click the inverted large button icon in the
window’s upper right corner, or click the
button in the upper left corner of the
window and then select Restore.

Close a window. Click the button in the upper left corner of
the window and then select Close.

Arrange all open windows edge-by-
edge.

Select Window → Tile.

Arrange all open windows in an
overlapping display.

Select Window → Cascade.

Table 2-1 Window Management Tasks

Task Action
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Note – Throughout this manual, whenever you are directed to initiate an
action, only one of the above methods is described. In most cases, you can use
any of the other methods as well.

2.6.1 Toolbar Buttons

The following table describes the toolbar buttons you can use to initiate an
action from the SunGMI.

Table 2-2 SunGMI Toolbar

Button Task Button Task

Connect to the domain. Modify the selected
resource.

Disconnect from the domain. Undo the last edit
operation.

Create a new resource. Enable the selected
resource.

Save the open configuration. Disable the selected
resource.

Delete the selected resource. Display a new resource
window.

Cancel the deletion of the
selected resource.

Display a list of
configurations.
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2.6.2 Menu Commands

Menus are listed in the menu bar along the top of a window. To open a menu
and display the list of commands, either click the menu’s name in the menu
bar, or press Alt-x, where x is the underlined letter in the menu name. To select
a menu command, either drag the mouse to the desired command and release,
or press the underlined letter in the command name.

The menus available at a particular time and the commands available from a
particular menu depend on the currently selected window and resource.
Unavailable menu commands are grayed out and cannot be selected.

The following sections describe the commands available for each of the menus
in the menu bar.

Display the Events window. Display a list of manager
systems.

Display the Traces window. Display a list of
applications connected to
the domain.

Display the Licenses window.

Table 2-2 SunGMI Toolbar

Button Task Button Task



Using the Administration Program 2-13

2

2.6.2.1 File Menu

2.6.2.2 Edit Menu

Command Description

Connect Connects to a domain.

Disconnect Disconnects from a domain.

Open Opens a configuration.

Close Closes a configuration.

Save Saves a configuration.

Save As Saves a configuration with a new name.

Exit Exits the program.

Command Description

New < > Creates a new: manager system, user, user group, LU
pool, system, server, SDLC line, Token Ring line, QLLC
line, physical unit (PU), dependent LU, independent
LU, partner LU, mode, or transaction program
(depending on the context).

Delete Deletes the selected item.

Undelete Undeletes the selected item.
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2.6.2.3 Control Menu

Note – The commands available from the Control menu depend on the
currently selected resource.

Modify Displays the configuration dialog box for the item you
want to modify.

Undo Undoes the last edit you made.

Command Description

Activate Makes an off-line configuration active.

Cancel Activate Cancels the pending activation of an off-line configuration.

Start Starts a system, PU2.1 server, trace, or physical unit (PU).
For more information, refer to Section 11.6, “Controlling the
Status of Resources,” on page 11-17.

Stop Stops a system, PU2.1 server, trace, connection, or PU. For
more information, refer to Section 11.6, “Controlling the
Status of Resources,” on page 11-17.

Create Trace Starts a PU2.1 server trace. For more information, refer to
Section 12.1.4.2, “Starting a PU2.1 Server Trace,” on
page 12-29.

Trace Line Opens the SunSCOPE utility and starts a line trace. For more
information, refer to Section 12.1.3.2, “Starting a Line Trace,”
on page 12-17.

Enable Enables a disabled dependent LU.

Disable Disables a dependent LU without affecting sessions or client
connections.

Forced Disable Disables a dependent LU, destroying sessions and client
connections.
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2.6.2.4 Options Menu

2.6.2.5 Window Menu

Command Description

Table Formats Allows you to modify the format of a resource table in a
resource window. For more information, refer to
Section 12.1.1.2, “Customizing a Table Format,” on
page 12-2.

Save settings Saves any settings you changed in this session.

Command Description

Configurations Displays the list of configuration windows.

New Resource Opens a new resource window with the resource table
displaying the selected type of information (Status,
RTM, IPRTM, or SNARTM).

Application List Displays a list of applications.

Managers List Displays a list of current manager systems.

Licenses List Displays the list of defined licenses.
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2.6.2.6 Help Menu

2.7 Using Dialog Boxes
To customize the operation of the Sun PU2.1 SNA Server, you use the SunGMI
to configure objects, such as systems, PU2.1 servers, users, and dependent LUs.
For each object that you configure, the SunGMI provides one or two dialog
boxes that contain parameters appropriate to the object. The Basic dialog box
typically contains required parameters, while the Advanced dialog box
typically contains optional parameters.

You specify the setting of a parameter either by entering data into a text box,
by selecting an item from a drop-down menu, or by checking/clearing a check
box. Dialog boxes also contain action buttons. The action buttons are described
in the following table.

Active Traces List Displays the list of defined PU2.1 server traces.

Event Log Displays a list of current events.

Cascade Arranges windows in an overlapping display.

Tile Arranges windows edge-by-edge.

Arrange Icons Rearranges the icons on your desktop.

Command Description

Contents Displays the contents of the Help System.

Release Note Displays the latest version of the Sun PU2.1 SNA Server
release notes.
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The keyboard shortcuts you can use when entering information in a dialog box
are described in the following table.

Table 2-3 Dialog Action Buttons

Button Action

OK Accept the parameter settings.

Cancel Exit the dialog box without accepting the parameter
settings.

Reset Return all parameters to their initial default settings.

Advanced Display the Advanced dialog box.

Basic Display the Basic dialog box.

Help Display the contents of the Help system for the object.

Table 2-4 Keyboard Shortcuts

Key Action

Tab Move forward from one parameter to the next
parameter.

Shift-Tab Move backward from one parameter to the previous
parameter.

Spacebar Toggle between enabling and disabling a check box.

Delete Delete the setting of a parameter, returning the
parameter to its default value.



2-18 SunLink SNA 9.1 PU2.1 Server Configuration Guide—August 1997

2



3-1

Getting Started 3

This chapter contains the following sections:

• Overview of Configuration Tasks - a list of the tasks required to get you up
and running with the Sun PU2.1 SNA Server as quickly as possible.

• Starting the SunGMAN - describes how to start the Sun Gateway Manager.
• Starting the SunGMI - describes how to start the Sun Graphical Manager

Interface.
• Creating a Configuration - describes how to create a configuration and how

to add a system, a PU2.1 server, a connection, a physical unit (PU), and a
dependent logical unit (LU) to the configuration.

Note – This chapter is intended to get you up and running quickly. It assumes
that you are creating a manager network consisting of a single system. At a
later time, you can add additional manager systems to the manager network
for increased redundancy and reliability; add additional PU2.1 servers to each
system; create LU pools for dependent LUs; set up users and user groups;
configure additional components, such as those related to LU6.2 and
independent LUs; and run client SNA programs on other systems in your
network, using the Sun PU2.1 SNA Server as a gateway to the SNA network.
For more information, refer to the remainder of this manual and to the
appropriate Sun PU2.1 SNA Server Planning and Installation Guide.
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3.1 Overview of Configuration Tasks
The following figure illustrates the components you must configure to get up
and running with the Sun PU2.1 SNA Server.

Figure 3-1 Configuration Hierarchy

The tasks required to get the Sun PU2.1 SNA Server up and running are as
follows:

1. Plan the configuration of the Sun PU2.1 SNA Server. Refer to Appendix A,
“Resource Planning Forms."

2. Update the Domain Name System (DNS) configuration, if necessary. Refer
to Section B.3, “Updating the DNS Configuration,” on page B-5.

3. Install any required communication hardware and software. Refer to the
appropriate Sun PU2.1 SNA Server Planning and Installation Guide.

Configuration

System

PU2.1 ServerPU2.1 Server

SDLC Line LAN Connection

PU2PU2

Dependent LU Dependent LU



Getting Started 3-3

3

4. Install the Sun Gateway Manager (SunGMAN) and Sun Graphical
Management Interface (SunGMI) software. Refer to the appropriate Sun
PU2.1 SNA Server Planning and Installation Guide.

5. Install the Sun PU2.1 SNA Server software on the system that contains the
communication hardware that connects to your IBM SNA environment.
Refer to the appropriate Sun PU2.1 SNA Server Planning and Installation
Guide.

6. Create a configuration, if necessary. Refer to Section 3.4, “Creating a
Configuration,” on page 3-4.

7. Configure the system. Refer to Section 3.4.2, “Configuring a System,” on
page 3-5.

8. Add a PU2.1 server. Refer to Section 3.4.3, “Adding a PU2.1 Server,” on
page 3-6.

9. Add the appropriate connection. Refer to Section 3.4.4, “Adding a
Connection,” on page 3-7.

10. Add a PU. Refer to Section 3.4.5, “Adding a PU,” on page 3-10.

11. Add a dependent LU. Refer to Section 3.4.6, “Adding a Dependent LU,”
on page 3-11.

12. Save the configuration. Refer to Section 3.4.7, “Saving the New
Configuration,” on page 3-13.

13. Install the appropriate Sun SNA clients. Refer to the appropriate Sun
PU2.1 SNA Server Planning and Installation Manual for information on
configuring the Sun PU2.1 SNA Server for use with your particular client.

14. Before you begin operations, make sure that you have licenses for each of
your client connections. For more information about adding licenses, refer
to Section 11.2, “Managing Licenses,” on page 11-6.

3.2 Starting the SunGMAN
When you install the SunGMAN software, start-up scripts that run when the
Unix system boots up are created and linked to the start-up area. To start the
SunGMAN manually, use the sunsetup  command. By default, sunsetup  is
located in the /etc/Sun  directory.
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3.3 Starting the SunGMI
To start the SunGMI, enter the sungmi  command at the shell prompt. The
SunGMI is linked to the /usr/bin  directory (unless a different directory is
chosen during installation) and should be in your path in most environments.
For general information on how to use the SunGMI, refer to Chapter 2, “Using
the Administration Program."

3.4 Creating a Configuration
After you start the SunGMI and connect to a domain, the screen displays the
configuration window. The Sun PU2.1 SNA Server is installed with a
configuration called config1 . The following sections describe how to create a
manager system; how to configure a system, a PU2.1 server, a connection, a
PU, and a dependent LU for config1 ; and how to save the configuration.

3.4.1 Creating a Manager System

▼ To create a manager system:

1. Highlight config1  in the configuration window, and then select
File → Open from the menu bar to display the resource window for
config1 .

2. Select Window → Managers List to display the list of the manager systems
that are defined for config1 .

3. Select Edit → New Manager from the menu bar to display the Create
Manager dialog box.
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4. In the Host field, enter the hostname of the machine on which you
installed the SunGMAN software.

5. Typically, you can leave the default settings for the remaining parameters.
If you want to change any of the other parameters, refer to Section 11.3.2,
“Adding a Manager System,” on page 11-9.

6. Click OK to add the manager system to the manager network.

3.4.2 Configuring a System

▼ To configure a system:

1. Double-click the configuration you are using to display the resource
window.

2. Click Systems in the resource tree to select it.
If this is a new installation or if, during the installation procedure, you
specified that you wanted to run the manager system as the primary
manager system in your manager network, an entry for the local system is
automatically created. Go to the next section to add a PU2.1 server to the
system.

If you must create a new system, go to step 3.

3. From the main window, select Edit → New → System to display the Create
System dialog box.

4. In the Host field, enter the hostname of the system on which you installed
the Sun PU2.1 SNA Server.
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5. In the Type field, select the platform on which the server will run. Make
sure that you select the appropriate platform. Do not use the default
setting (Generic).

6. Typically, you can leave the default settings for the remaining parameters
in the Basic and Advanced dialog boxes. If you want to change any of the
other parameters, refer to Chapter 4, “Configuring Systems."

7. Click OK to add the system to the configuration.

3.4.3 Adding a PU2.1 Server

▼ To add a PU2.1 server to run on the system:

1. Double-click Systems in the resource tree to display the name of the
system you just added.

2. Double-click the system name to open its subordinate entries.

3. Click PU2.1 Servers in the resource tree to open a new resource table.

4. From the main window, select Edit → New → PU2.1 Server to display the
Create PU2.1 Server dialog box.

5. In the Name field, enter the name for the new PU2.1 server. The name can
contain up to eight alphanumeric characters (including @, #, and $). Tabs
and spaces are not allowed. The first character cannot be a number. The
name cannot be the same as any other PU2.1 server name.
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6. In the CP Name field, enter either the CP Name assigned by your IBM
network administrator or the name you entered in the Name field.

7. Click Advanced, tab to the SunOp Service field, and enter sunadmin_pu2 ,
if necessary. (Note that sunadmin_pu2  is the name of the service added to
the database during installation.)

8. Typically, you can leave the default settings for the remaining parameters
in the Basic and Advanced dialog boxes. If you want to change any of the
other parameters, refer to Chapter 5, “Configuring PU2.1 Servers."

9. Click OK to add the PU2.1 server to the system.

3.4.4 Adding a Connection

This section describes how to add a local area network (LAN), SDLC, or QLLC
connection to your configuration.

▼ To add a LAN connection:

1. Double-click PU2.1 Servers in the resource tree to display the name of the
PU2.1 server you just added.

2. Double-click the PU2.1 server name to open its subordinate entries.

3. Click LAN Connections in the resource tree.

4. From the main window, select Edit → New → LAN Connection to display
the Create LAN Connection dialog box.
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5. In the Line Name field, enter the name for the new line. The name can
contain up to eight alphanumeric characters (including @, #, and $). Tabs
and spaces are not allowed. The first character cannot be a number. The
name cannot be the same as any other connection name.

6. In the Type field, select Token Ring, Ethernet, or FDDI, as appropriate.
Note that Ethernet and FDDI are not supported on all platforms.

7. In the MAC Address field, enter the Medium Access Control (MAC)
address for the local station. See your host network administrator for the
correct value.

8. If you are running on a 16 Mb/s Token Ring, click Advanced, tab to the
LAN Speed field, and select 16 Mb/s.

9. Typically, you can leave the default settings for the remaining parameters
in the Basic and Advanced dialog boxes. If you want to change any of the
other parameters, refer to Section 6.1, “Adding a LAN Connection,” on
page 6-1.

10. Click OK to add the new LAN connection.

▼ To add an SDLC connection:

1. Double-click PU2.1 Servers in the resource tree to display the name of the
PU2.1 server you just added.

2. Double-click the PU2.1 server name to open its subordinate entries.

3. Click SDLC Lines in the resource tree.

4. From the main window, select Edit → New → SDLC Line to display the
Create SDLC Line dialog box.
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5. In the Line Name field, enter a name for the new SDLC line. The name
can contain up to eight alphanumeric characters (including @, #, and $).
Tabs and spaces are not allowed. The first character cannot be a number.
The name cannot be the same as any other connection name.

6. Typically, you can leave the default settings for the remaining parameters
in the Basic and Advanced dialog boxes. If you want to change any of the
other parameters, refer to Section 6.2, “Adding an SDLC Connection,” on
page 6-4.

7. Click OK to add the new SDLC line.

▼ To add a QLLC connection:

1. Double-click PU2.1 Servers in the resource tree to display the name of the
PU2.1 server you just added.

2. Double-click the PU2.1 server name to open its subordinate entries.

3. Click QLLC Lines in the resource tree.

4. From the main window, select Edit → New → QLLC Line to display the
Create QLLC Line dialog box.
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5. In the Line Name field, enter a name for the new QLLC line. The name
can contain up to eight alphanumeric characters (including @, #, and $).
Tabs and spaces are not allowed. The first character cannot be a number.
The name cannot be the same as any other connection name.

6. Typically, you can leave the default settings for the remaining parameters
in the Basic and Advanced dialog boxes. If you want to change any of the
other parameters, refer to Section 6.3, “Adding a QLLC Connection,” on
page 6-7.

7. Click OK to add the new QLLC line.

3.4.5 Adding a PU

▼ To add a PU:

1. In the resource tree, double-click LAN Connections (for Token Ring,
Ethernet, or FDDI connections), SDLC Lines (for SDLC connections), or
QLLC Lines (for QLLC connections) to display the name of the connection
you just added.

2. Click the connection name to select it.

3. From the main window, select Edit → New → DLC (PU2) to display the
Create DLC dialog box.

Note – The dialog box shown is for a LAN connection. The parameters
available for SDLC, QLLC, and channel connections may vary.
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4. In the DLC Name field, enter the name for the new PU. The name can
contain up to eight alphanumeric characters (including @, #, and $). Tabs
and spaces are not allowed. The first character cannot be a number.
Lowercase letters are converted to uppercase. The name cannot be the
same as any other PU, dependent LU, independent LU, or LU pool name.
Sun recommends that you use the name that is defined in the IBM
VTAM/NCP configuration. For more information, refer to IBM's VTAM
Installation and Resource Definition manual.

5. If your IBM network definitions contain an IDBLK/IDNUM setting, click
Advanced, tab to the Local Terminal ID field, and enter the
IDBLK/IDNUM setting.

6. Typically, you can leave the default settings for the remaining parameters
in the Basic and Advanced dialog boxes. If you want to change any of the
other parameters, refer to Chapter 7, “Configuring PUs."

7. Click OK to add the new PU.

3.4.6 Adding a Dependent LU

▼ To add a dependent LU:

1. Double-click the connection name in the resource tree to display the name
of the PU you just added.

2. Click the PU name to select it.

3. From the main window, select Edit → New → Dependent LU to display
the Create Dependent LU dialog box.
Note that the dialog box shown is for a LAN connection. The parameters
available for SDLC, QLLC, and channel connections may vary.
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4. In the Name field, enter the name for the dependent LU. The name can
contain up to eight alphanumeric characters (including @, #, and $). Tabs
and spaces are not allowed. The first character cannot be a number.
Lowercase letters are converted to uppercase. The name cannot be the
same as any other dependent LU, independent LU, LU pool, or PU name.

5. In the LU Type field, select the dependent LU type. Select LUType 1 for
3770 RJE. Select LUType 2 for 3270 terminal emulation. Select LUType 3
for printing. Select LUType 6.2 for APPC peer-to-peer communications.

Note – If you are using either an LUType 1 or an LUType 3 for printing, always
select LUType 3.

6. Typically, you can leave the default settings for the remaining parameters
in the Basic and Advanced dialog boxes. If you want to change any of the
other parameters, refer to Chapter 8, “Configuring Dependent LUs."

7. Click OK to add the dependent LU.
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3.4.7 Saving the New Configuration

▼ To save the new configuration:

1. From the main window, either select File → Save to save the configuration
as config1  or select File → Save As to save the configuration with a new
name. The screen displays the Save dialog box.

2. Click Changes should be made immediately and then click Yes in the
confirmation dialog box. The new configuration files are copied to the
PU2.1 server and the required processes are started/restarted on the
system.

3. While the processes are starting, the status of the system and PU2.1 server,
as shown in the configuration window, changes to Pending-Active. After
the processes start, the status changes to Active. The PU and LU entities
contained in the PU2.1 server change to Active when the IBM SNA
network activates them.

Note – The SNA host (VTAM) must activate its connections to the Sun PU2.1
SNA Server. Refer to IBM's NetView Operations manual for activation,
deactivation, and display commands for SNA resources.

4. To stop a process once it has been started, select the system or PU2.1
server from the resource tree and select Control → Stop System or Control
→ Stop Server
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This chapter describes how to configure the systems that make up your Sun
PU2.1 SNA Server. Before you begin, identify the systems that provide
connectivity into your SNA network and define the distribution of functions
among these systems. Use the hardware and software configuration planning
forms in Appendix A, “Resource Planning Forms,” to help you plan your
system configuration.

▼ To configure a system:

1. Double-click the appropriate configuration in the configuration window
to display the resource window.

2. Using the right mouse button (MB3), click and hold Systems in the
resource tree and select New → System from the popup menu. The screen
displays the Create System dialog box.

3. Enter the appropriate information in the Basic dialog box and then click
Advanced to display the Advanced dialog box. The following sections
describe the parameters in the Basic and Advanced dialog boxes.

4. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.
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4.1 Basic System Configuration

Host
The name of the system on which the servers are configured and run. You
must specify the name of the system. The name cannot be the same as any
other system name.

Comment
A free-form text area that you can use to further qualify and describe the
system configuration.

Type
The platform on which the servers run. This setting assures that platform-
specific parameters are controlled correctly. Select Generic for unsupported
platforms.
Sun recommends that you always select an appropriate platform and that you
do not select the Generic option.
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4.2 Advanced System Configuration

Initial Status
The initial status of the system when it is initialized. The value can be Active or
Inactive. If you select Active, the Sun System Manager (sunsman ) is activated
when the system is initialized. If you select Inactive, you must manually
activate the sunsman .

Command Options
The command line options that you can use when activating the sunsman .
Separate command line options with a space. The following table lists valid
command line options.
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1. Do not use thiscommand line option unless you are instructed to do so by
Sun Technical Support.

Table 4-1 Command Line Options

Option Description

-b number_seconds Set the time that an LU that was in session must
wait before attaching to another client to
number_seconds seconds.

-D1 Trace SNMP packets. This command line option is
valid only if you use the -t  command line option to
enable line tracing.

-F file_descriptors Set the number of file descriptors sunsman  can
support to file_descriptors.

-N port_number1 Set the port on which to listen for Telnet connections
to port_number.

-o number_seconds1 Set the time sunsman  should wait for a response
from a PU2.1 server before dropping the queued
request to number_seconds.

-O number_seconds Set the time to wait for a response from a client
during Telnet options negotiation to number_seconds
seconds. If you do not use this command line
option, no time-out value is used. If the time expires,
negotiations start again, omitting the option that
initiated the time-out.

-S interval When sending status messages to a client’s screen,
wait interval seconds before overwriting.

-t trace_flag1 Enable line tracing and set the type of internal traces
to capture in the trace file to trace_flag. Sun
recommends that you always set trace_flag to -1 ,
indicating all trace flags.

-T Use the terminal type when determining which LU
to match to an incoming client request.

-v Print the sunsman  version.

-W number_seconds Set the time sunsman  should wait for a response
when attempting to acquire an LU from a PU2.1
server to number_seconds.
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Enable AFTP Server?
Indicates whether the AFTP (APPC File Transfer Protocol) server functions are
enabled. Check the box to enable the AFTP server. Clear the box to disable the
AFTP server.

Note – This parameter is available only if you have configured a partner LU.
For more information, refer to Section 9.2, “Configuring a Partner LU,” on
page 9-4.

If you are using an IBM mainframe or mid-range system that supports an
AFTP server to send/receive files to/from internetwork FTP client software,
make sure that you enable the AFTP server after you configure the partner LU.
For more information on using AFTP, refer to Section 4.3, “Using APPC File
Transfer Protocol."

Partner LU
The partner LU name used to establish the AFTP session. This name must
match the Name specified in the partner LU configuration. For more
information, refer to Section 9.2, “Configuring a Partner LU,” on page 9-4.

Mode Name
The mode used to establish the AFTP session. This name must match the Mode
Name specified in the session mode configuration. For more information, refer
to Section 9.3, “Configuring the Session Mode,” on page 9-7.

4.3 Using APPC File Transfer Protocol
SunLink 9.1 AFTP functions as a Client to IBM's APPC Application Suite
(ASuite) AFTPD Server. IBM supplies ASuite as part of VTAM 4.2.

Users connect to the SunLink 9.1 AFTP Client via TCP/IP FTP - port 8021. The
SunLink 9.1 AFTP Client connects to the host system via an APPC
conversation. The translation from TCP/IP FTP protocol to SNA APPC
protocol is done by the SunLink 9.1 AFTP Client.

ASuite support under the VM/ESA and MVS/ESA is documented in:

• AAPC Application Suite Administration - SC31-6533

• APPC Application Suite User's Guide - SC31-6532.
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AFTP supports text file transfer to and from VM/ESA and MVS/ESA. AFTP
also supports binary file transfer from the client to the host and back - i.e.,
client (for example, Unix) binary files can be stored on the host and retrieved
by other clients. Although the reverse operation can probably be made to work
(host executable modules stored on client workstations, and retrieved by other
hosts), it is not supported.

▼ To configure AFTP on SunLink 9.1:

1.  On GMI: configure an Independent LU under one of the PU2.1 Servers.
The Local LUName is arbitrary.

2. Under this Independent LU: configure a PartnerLU with alias 'XFTPD'.
The fully qualified Partner LU Name is the name of the AFTPD Server on
the host.

• See the manuals above for VM/ESA and MVS/ESA configuration.
• See below for an example of VM/ESA configuration.

3. Under XFTPD, configure mode #BATCH. Set up session limits as desired
for ConWinner and ConLoser: for example, 4 of each is typical.

4.  Configure the AFTP LU 6.2 Definition in VTAMLST:

4.3.1 Sample setup for VM/ESA

1.  Set up a UserID for AVSVM, which provides the APPC Support under
VM.

 T015L000 LU    LOCADDR=0,                                              X
               DLOGMOD=SNASVCMG



Configuring Systems 4-7

4

2.  Set up the VTAM Application Major Node for AVSVM:

In the case, the Partner LU defined by XFTPD is:

3.  Set up AGWPROF GCS for AVSVM. The PROFILE GCS for AVS is
supplied with the system.

USER AVSVM AVSVM 32M 64M BG
* AVS virtual machine
 INCLUDE GCSPROF
 ACCOUNT 7 P390
 IUCV ANY
 IUCV *IDENT GATEANY GATEWAY REVOKE
 IUCV ALLOW
 OPTION COMSRV MAXCONN 20 ACCT
 CONSOLE 01F 3215 T OPERATOR
 LINK    MAINT  193 193 RR
 MDISK 191 FB-512 16     3504  AVSVM  MR ALL

*
AVSVM    VBUILD TYPE=APPL
*
AGWAFTPD  APPL  APPC=YES,AUTHEXIT=YES,AUTOSES=10,                    X
                DSESLIM=100,DMINWNL=50,DMIWNR=50,                    X
                MODETAB=AGWTAB,PARSESS=YES,SYNCLVL=SYNCPT,           X
                SECACPT=ALREADYV

network_name.AGWAFTPD
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Note –  VM UserID AFTPD will act as the AFTP Server, and is configured as a
Private, Dedicated Gateway to AVS. Also note that this statement connects the
VTAM APPL Node AGWAFTPD with the AFTPD UserID. Incoming Binds for
AGWAFTPD will be routed to the AFTP Server running on UserID AFTPD.

4. Set up the AFTPD UserID. Note that the ASuite UserID is 5654025, and
the ASuite files are on the 2C2 and 29A mdisks:

5.  Set up the AFTPD Profile Exec:

/********************************************************************/
/*                                                                  */
/*  SAMPLE AGWPROF GCS FOR AVS                                      */
/*                                                                  */

/********************************************************************/
'AGW ACTIVATE  GATEWAY AGWAFTPD PRIVATE USERID AFTPD' ;

USER AFTPD    AFTPD    16M    32M    ABG
* Configurator generated USERID  Fri Nov 22 10:53:49 1996
INCLUDE USERPROF
IPL CMS PARM AUTOCR
LINK 5654025  2C2   2C2  RR
LINK 5654025  29A   29A  RR
 MDISK 191  FB-512 16      500     AFT191 MR ALL
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6. Set up the AFTPD $SERVER$ NAMES file:

The parameter passed to the AFTPD EXEC is the TP name in the Attach, which
must also have a matching :tpname. entry  in the $SERVER$ NAMES file in
the CMS machine where AFTPD will run. The sample NAMES file has

   An entry such as

would, if the client set the TP name to AFTPSRVR in the AFTPD side info entry
or used the TPNAME command to change the TP name, cause the AFTPD
EXEC to start with AFTPSRVR as the parameter.

'SP CONS START CL A MAINT' ;
'ACC 2C2 B' ;
'ACC 29A C' ;
'CP SET PF12 RETRIEVE' ;
'CP SET RUN ON' ;
'SET SERVER ON' ;
'SET AUTOREAD OFF' ;
'SET FULLSCREEN OFF' ;
'EXEC AFTPD' ;
'EXIT ;

:tpname.AFTPD :list
              :module.AFTPD
:nick.AFTPD   :list.*
              :module.AFTPD

 :tpname.AFTPD  :list.*  :module.aftpd

 :tpname.AFTPSRVR :list.* :module.aftpd
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4.3.2  Connecting to the SunLink 9.1 AFTP Client and transferring files

▼ To connect to the SunLink 9.1AFTP client to transfer files

1. From the Unix prompt type:

2. Enter User ID:

3. Enter Password:

Note that the ftp is to the SunLink System. SunLink supports only one AFTP
Client per System.

4. Use remotehelp  to get help information from the host:

hostname% ftp SunLink_host 8021
          Connected to SunLink_host.
          220 sy-kalii SunLink FTP/AFTP server (Version 3.0.5) ready.

Name (SunLink_host:user_id):

331 Password required for user_id.
password:
230 User user_id logged in.
ftp>
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Normal ftp commands apply for setting ASCII or Binary file transfer mode,
changing directories, etc. (Note that on VM, mdisks  are referred to by /x/):

5. Use quote cmdxx  to execute commands unique to the host. This forces
the AFTP client to pass the command along unchanged to the host for
execution.

For example, for binary file transfer on VM, use quote recfm v  to also set
RECFM V on CMS:

ftp> remotehelp
214-The following commands are recognized (* =>'s unimplemented).
   USER            APPE*           DELE            XRMD
   PASS            MLFL*           CWD             PWD
   ACCT*           MAIL*           XCWD            XPWD
   SMNT*           MSND*           LIST            CDUP
   REIN*           MSOM*           NLST            XCUP
   QUIT            MSAM*           SITE            STOU*
   PORT            MRSQ*           SYST            AUTH*
   PASV            MRCP*           STAT            ADAT*
   TYPE            ALLO*           HELP            PROT*
   STRU*           REST*           NOOP*           PBSZ*
   MODE*           RNFR            MKD             SIZE*
   RETR            RNTO            XMKD            MDTM*
   STOR            ABOR            RMD
   MODENAME*       RECFM           DATE            OPEN*
   TPNAME*         ALLOC           TRACE           CLOSE*
   LRECL           BLOCK           MAP*
214 Direct comments to ftp-bugs@SunLink_host.
ftp>

ftp> cd /b/
250 CWD command successful.
ftp> pwd
257 "/b/" is current directory.
ftp>
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.

ftp> binary
200 Type set to BINARY.
ftp> quote recfm v
250 RECFM set to v
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This chapter describes how to configure PU2.1 servers.

▼ To configure a PU2.1 server:

1. Double-click Systems in the resource tree to display a list of systems.

2. Double-click the system name in the resource tree to open its subordinate
entries.

3. Using the right mouse button (MB3), click and hold PU2.1 Servers in the
resource tree and select New → PU2.1 Server from the popup menu. The
screen displays the Create PU2.1 Server dialog box.

4. Enter the appropriate information in the Basic dialog box and then click
Advanced to display the Advanced dialog box. The following sections
describe the parameters in the Basic and Advanced dialog boxes.

5. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.
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5.1 Basic PU2.1 Server Configuration

Name
The name of the server within the enterprise. The name can contain up to eight
alphanumeric characters (including @, #, and $). Tabs and spaces are not
allowed. The first character cannot be a number. You must specify the name of
the server. The name cannot be the same as any other PU2.1 server name.

CP Name
The name of the control point for the server. The format of the CP Name is
netid.netname, where netid is the SNA network ID and netname is the name of
the server within the SNA network. Each field can contain up to eight
alphanumeric characters (including @, #, and $). Tabs and spaces are not
allowed. The first character cannot be a number. Lowercase letters are
converted to uppercase. You must specify the name of the control point.

Comment
A free-form text area that you can use to further qualify and describe the
server configuration.

Use UNIX Security?
Indicates whether security for incoming attachments is verified against
information in the /etc/passwd  database file. Check the box if you want to
verify the information. Clear the box if you do not want to verify the
information. This parameter is appropriate for APPC transactions only.



Configuring PU2.1 Servers 5-3

5

For more information, refer to Section G.5, “Unix-Level Security,” on
page G-5.

Default User
The user ID for remotely invoked APPC transaction programs. The default
value is sunlu62 .

Note – You must add the Default User name manually (either sunlu62  or any
other name you specify) to the /etc/passwd  database file. This parameter is
appropriate for APPC transactions only.

Default Group
The group ID for remotely invoked APPC transaction programs.

Note – If you specify a Default Group name, you must manually add it to the
/etc/group  database file. This parameter is appropriate for APPC transactions
only.

5.2 Advanced PU2.1 Server Configuration
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Initial Status
The initial status of the server when the system is initialized. The value can be
Active or Inactive. If you select Active, the server is automatically activated
when the system is initialized. If you select Inactive, you must manually
activate the server.

Command Options
The command line options that you can use to customize the operation of the
server. Separate command line options with a space. The following table lists
valid command line options.

sunOP Service
The name of the TCP/IP service that the server uses when running the sunOP
troubleshooting utility. The service name must be in the NIS services database
or in the /etc/services  database file.

Table 5-1 Command Line Options

Option Description

-C Cause responses to be delayed until the Telnet client
has received the request. Used for Telnet
connections.

-F num_file_descriptors Set the number of file descriptors available to the
process. This is required if the number of client
connections exceeds the default number of file
descriptors for the platform.

-k keep_alive_type Send the keep_alive_type signal on Telnet client
connections. The value for keep_alive_type can be nop
or eor .

-L logfile_name Turn on Telnet client activity logging and set the file
to which data is logged to logfile_name.

-t trace_flag Enable SNA and Telnet tracing and set the type of
internal traces to capture in the trace file to
trace_flag. Sun recommends that you always set
trace_flag to -1 , indicating all trace flags. Note that
you can also turn on tracing dynamically. For more
information, refer to Section 12.1.3.2, “Starting a
Line Trace,” on page 12-17.

-v Print the sunPU21 process version.
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Note – If you are running multiple PU2.1 servers on the same system, the
SunOP service name must be unique for each server.

LU6.2 Service
The name of the TCP/IP service that the server uses to provide the LU6.2
transaction program (TP) interface. The service name must appear in the NIS
services database or in the /etc/services  database file.
This parameter is valid only when multiple LUType 6.2 servers are running on
the same system.

Use Source Routing?
Indicates whether you want the software to perform Token Ring source
routing. Check the box if you want to perform source routing. Clear the box if
you do not want to perform source routing.
Use this parameter only when the server is operating over a LAN connection.
If you are using a platform driver that provides source routing, disable source
routing. For more information about IBM Token Ring network concepts, refer
to Appendix D, “IBM Token Ring Concepts."

Table Size
The number of entries in the source routing table.
This parameter is valid only when source routing is enabled. Use this
parameter only when the server is operating over a LAN connection.

Timeout
The time, in seconds, to wait for a response to a source route determination
packet. The value can range from 1 to 30. The default is 10.
This parameter is valid only when source routing is enabled. Use this
parameter only when the server is operating over a LAN connection.

Retries
The number of attempts at on-ring then off-ring source route determination.
The value can range from 0 to 100. The default value is 1.
This parameter is valid only when source routing is enabled. Use this
parameter only when the server is operating over a LAN connection.
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Time To Live
The time, in minutes, to wait before discarding source route entries once the
route has been determined. The value can range from 1 to 1440. The default is
20.
This parameter is valid only when source routing is enabled. Use this
parameter only when the server is operating over a LAN connection.

LLC Device
The Unix pathname for the special file required for LLC.
Use this parameter only when the server is operating over a LAN connection.
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This chapter contains the following sections:

• Adding a LAN Connection - describes how to add a Token Ring, Ethernet,
or FDDI connection.

• Adding an SDLC Connection - describes how to add a Synchronous Data
Link Control connection.

• Adding a QLLC Connection - describes how to add a Qualified Logical Link
Control connection.

6.1 Adding a LAN Connection

▼ To add a LAN connection:

1. Double-click PU2.1 Servers in the resource tree to display the name of the
PU2.1 server.

2. Using the right mouse button (MB3), click and hold the server name in
the resource tree and select New → LAN Connection from the popup
menu. The screen displays the Create LAN Connection dialog box.

3. Enter the appropriate information in the Basic dialog box and then click
Advanced to display the Advanced dialog box. The following sections
describe the parameters in the Basic and Advanced dialog boxes.

4. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.
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6.1.1 Basic LAN Configuration

Line Name
The name that identifies the LAN connection. The name can contain up to
eight alphanumeric characters (including @, #, and $). Tabs and spaces are not
allowed. The first character cannot be a number. You must specify name of the
connection. The name cannot be the same as any other connection name.

Comment
A free-form text area that you can use to further qualify and describe the LAN
connection. For example, you can use this parameter to specify the physical
location of the connection or the patch panel.

Type
The type of LAN connection. The value can be Token-Ring, Ethernet, or FDDI.

Note – Ethernet and FDDI connections are not supported on all platforms.
For more information, contact your Sun sales representative.

Device
The Unix pathname for the device-specific file for the LAN port.
An entry is required in this field. However, if you specify an appropriate
system type, a default device is automatically provided. For more information,
refer to Type in Chapter 4, “Configuring Systems."
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Local MAC Address
A 12-character hexadecimal string representing the Medium Access Control
(MAC) ring station address of the host machine interface. See your host
network administrator for the proper setting of this parameter. You must
specify the MAC address.

Note – On most systems, the MAC address can be obtained from ROM on the
LAN adapter.

6.1.2 Advanced LAN Configuration

Interface
The name of the interface associated with the IBM Token Ring board.
This parameter only applies to certain systems. For more information, refer to
the appropriate Sun PU2.1 SNA Server Planning and Installation Guide.
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PPA
The TRI/S card instance number. Software installation of the TRI/S card
installs the Token Ring driver and creates the IP network interface trn, where n
represents the TRI/S card instance number and corresponds to the order in
which the cards are installed, starting at card instance 0.
This parameter only applies to certain systems. For more information, refer to
the appropriate Sun PU2.1 SNA Server Planning and Installation Guide.

Functional Address
Not used.

Group Address
Not used.

LAN Speed
The LAN speed for a Token Ring connection. The value can be 4 Mb/s or
16 Mb/s. The default is 4 Mb/s.

Note – You cannot select a LAN speed for Ethernet and FDDI connections. For
Ethernet, the LAN speed is always 10 Mb/s. For FDDI, the LAN speed is
always 100 Mb/s.

Maximum Data Size
The maximum MAC frame size (excluding MAC headers, trailers, and source
routing information) that can be sent and received over this network interface,
specified in bytes.
For Ethernet, the value can range from 60 to 1500. The default is 1500. For
Token Ring (4 Mb/s or 16 Mb/s LAN speed) and FDDI, the value can range
from 60 to 4472). The default is 4472.
This value must be greater than the Max Data set for the associated PU. For
more information, refer to Max Data in Chapter 7, “Configuring PUs."

6.2 Adding an SDLC Connection

▼ To add an SDLC connection:

1. Double-click PU2.1 Servers in the resource tree to display the name of the
PU2.1 server.
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2. Using the right mouse button (MB3), click and hold the server name in
the resource tree and select New → SDLC Line from the popup menu. The
screen displays the Create SDLC Line dialog box.

3. Enter the appropriate information in the Basic dialog box and then click
Advanced to display the Advanced dialog box. The following sections
describe the parameters in the Basic and Advanced dialog boxes.

4. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.

6.2.1 Basic SDLC Configuration

Line Name
The name that identifies this SDLC connection. The name can contain up to
eight alphanumeric characters (including @, #, and $). Tabs and spaces are not
allowed. The first character cannot be a number. You must specify the name of
the SDLC connection. The name cannot be the same as any other connection
name.

Comment
A free-form text area that you can use to further qualify and describe the name
or provide additional information.

Device
The Unix pathname for the device-specific file for the SDLC port.
An entry is required in this field. However, if you specify an appropriate
system type, a default device is automatically provided. For more information,
refer to Type in Chapter 4, “Configuring Systems."
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6.2.2 Advanced SDLC Configuration

Max Rcv Frame
The maximum incoming frame size for the physical device driver, specified in
bytes.

Duplex
The transmission mode. The value can be Full-duplex or Half-duplex. Select
Half for multi-point lines. Select Full for point-to-point lines. The default is
Full.

Line Type
The line type. The value can be Leased or Switched. The default is Leased. This
parameter controls the use of XID messages on the link. If you select Switched,
the link responds to XID requests from the host. If you select Leased, the link
does not respond to XID requests from the host.
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Clock Source
The clock source for the synchronous line. The value can be Internal or
External. The default is External.
If you are using a modem, select External.
If a cable directly connects the hardware running the Sun PU2.1 SNA Server
and the SNA Communications Controller, the value you select depends on
whether the Sun PU2.1 SNA Server provides the clocking. If the server
provides the clocking, select Internal. If the server does not provide the
clocking, select External. Note that you must use a special cable to
accommodate the direct connection.

Line Speed
The speed of the connection in bits per second. The value can be 2400, 4800,
9600, 19200, 56000, 64000, 128000, or 256000. The default is 9600 b/s. This
parameter is valid only if the clock source is set to Internal.

Poll Pause Timer
The time to wait before responding to a poll (in 100-millisecond intervals). The
value can range from 0 to 200. The default is 200. A value of 0 indicates no
pause.

Monitor Carrier Detect?
Indicates whether the line should be marked inoperative when the Carrier
Detect (CD) signal is lost. Check the box if the line should be marked. Clear the
box if the line should not be marked. By default, the line is not marked.

Use NRZI Encoding?
Indicates whether NRZI encoding should be used. Check the box if you want
to use NRZI encoding. Clear the box if you do not want to use NRZI encoding.
By default, NRZI encoding is not used.

6.3 Adding a QLLC Connection

▼ To add a QLLC connection:

1. Double-click PU2.1 Servers in the resource tree to display the name of the
server.

2. Using the right mouse button (MB3), click and hold the server name in
the resource tree and select New → QLLC Line from the popup menu. The
screen displays the Create QLLC Line dialog box.
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3. Enter the appropriate information in the Basic dialog box and then click
Advanced to display the Advanced dialog box. The following sections
describe the parameters in the Basic and Advanced dialog boxes.

4. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.

Note – QLLC does not support LU6.2.

6.3.1 Basic QLLC Configuration

Line Name
The name that identifies this QLLC line. The name can contain up to eight
alphanumeric characters (including @, #, and $). Tabs and spaces are not
allowed. The first character cannot be a number. You must specify the name of
the QLLC line. The name cannot be the same as any other connection name.

Comment
A free-form text area that you can use to further qualify and describe the name
or provide additional information.

Connection Type
The connection type. The value can be Permanent VC (virtual circuit) or
Switched VC.
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Accept Incoming Calls?
Indicates whether the server should accept incoming switched VC calls. Check
the box if you want the server to accept incoming calls. Clear the box if you do
not want the server to accept incoming calls.

Host DTE Address
The X.25 PSDN address of the NPSI system. The address is a decimal number
(up to 15 digits). This parameter is required for switched VC connections.

PVC Logical Channel No
The logical channel number (LCN) to use for permanent VC connections. The
value can range from 1 to 4096.

HDLC Lineef
The name of the sunX25 HDLC line. If you do not enter a name, the sunX25
server picks any link. For switched VCs, you can use wild cards to specify a set
of links (* matches any string and ? matches any single character). For
permanent VCs (leased lines), you must enter a full name.

6.3.2 Advanced QLLC Configuration
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Local DTE Address
The X.25 PSDN address of the local system. The address is a decimal number
(up to 15 digits). The default is the address configured in the X.25 software.
This parameter applies to switched VC connections only.

Packet Size
The packet size requested for the switched VC. The value can range from 16 to
4096.
Refer to the Solstice X.25 System Administrator’s Guide for information on setting
up other related parameters before you can establish a QLLC connection. (For
example, you must set Size Negotiation to Request Size Negotiation in the
Closed User Groups and Facilities Parameters for Link dialog box. You must
also specify the X.121 address, the serial port, and SVCs.)

Window Size
The window size requested for the switched VC. The value can range from 1 to
7 or from 1 to 127, depending on the HDLC modulus. The window size should
equal the default X25LINE WINDOW_SIZE parameter. If not, to allow flow
control negotiation, make sure that the X25LINE L3FLOW_CTL_NEG
parameter is set to ACCEPT.

Network User ID
The ASCII-coded network user ID in a call request. The ID can be any
alphanumeric string.

Request Reverse Charge
Indicates whether to request reverse charging in call requests. Check the box if
you want to request reverse charging. Clear the box if you do not want to
request reverse charging.

Closed User Group
An index (CUG) to include in call requests. The CUG index is a decimal
number (two or four digits). Do not specify a CUG with outgoing access or a
bilateral CUG.

RPOA List
A list of Recognized Private Operating Authority (RPOA) codes. These codes
map to the X.25 call request RPOA selection facility and represent the Data
Network Identification Code (DNIC) addresses of the preferred RPOAs. You
enter a string of up to 24 characters (up to 6 non-separated, 4-digit RPOA
codes).
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IP Host
The name of the host that is running the sunX25 server. The default is the local
host.

Max Connects
The number of times the server tries to connect to the sunX25 server before
declaring the QLLC line inoperative. This setting applies only to the console of
the sunX25 server. It does not apply to the X.25 call to the host system.

Connect Timeout
The delay in seconds between connect attempts.
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Configuring PUs 7

This chapter describes how to configure physical units (PUs).

▼ To add a PU to a connection:

1. Double-click the PU2.1 server name in the resource tree to open its
subordinate entries.

2. Double-click the appropriate connection icon (LAN Connections, SDLC
Lines, or QLLC Lines) to display the name of the connection.

3. Using the right mouse button (MB3), click and hold the connection name
in the resource tree and select New → DLC (PU2) from the popup menu.
The screen displays the Create DLC dialog box.

4. Enter the appropriate information in the Basic dialog box and then click
Advanced to display the Advanced dialog box. The following sections
describe the parameters in the Basic and Advanced dialog boxes.

5. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.
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7.1 Basic DLC (PU2) Configuration

LAN Connection

SDLC or QLLC Connection

Channel Connection
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DLC Name
The name that identifies the physical unit. The name can contain up to eight
alphanumeric characters (including @, #, and $). Tabs and spaces are not
allowed. The first character cannot be a number. Lowercase letters are
converted to uppercase. You must specify the name of the physical unit. The
name cannot be the same as any other PU, dependent LU, independent LU, or
LU pool name.
Sun recommends that you use the name that is defined in the IBM
VTAM/NCP configuration. For more information, refer to IBM's VTAM
Installation and Resource Definition manual.

Comment
A free-form text area that you can use to further qualify and describe the name
or provide additional information.

Remote MAC Address
A 12-digit hexadecimal string representing the Medium Access Control (MAC)
address of the remote SNA host. You must specify the MAC address. This
parameter is available only for LAN connections.
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7.2 Advanced DLC (PU2) Configuration

Figure 7-1 LAN Connection
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Figure 7-2 SDLC or QLLC Connection

Group LSAP for PU
A 2-digit hexadecimal string representing the group Service Access Point
(SAP) for this PU. The default is x’05’. This parameter is available only for
LAN connections.

Local LSAP for PU
A 2-digit hexadecimal string representing the SAP for this PU in increments of
x’04’. The default is x’04’. The value must be unique for each PU in the
configuration.
This parameter is available only for LAN connections.

Remote LSAP
A 2-digit hexadecimal string representing the remote LSAP for this PU in
increments of x’04’. The default is x’04’. This value must equal the LSAP of the
remote PU.
This parameter is available only for LAN connections.

Local Terminal ID
An 8-digit hexadecimal string that represents this node. The value can range
from 0 to FFFFFFFF. The default is x’00000000’. The Local Terminal ID consists
of two fields: idblk (first three digits) and idnum (last five digits), where idblk
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indicates the SNA device type, as shown in the following table, and idnum
indicates the serial number of the device or any unique value representing this
PU in the network.

The local terminal ID is used within an XID exchange, during node activation.

Local CP Name
The network-qualified name that identifies the control point (CP). The format
of the Local CP Name is netid.cpname, where netid is the network to which the
CP’s node belongs and cpname is a unique name in the network. Each field can
contain up to eight alphanumeric characters (including @, #, and $). Tabs and
spaces are not allowed. The first character cannot be a number. Lowercase
letters are converted to uppercase.
The local CP name is used within an XID exchange, during node activation.
The default is the CP name of the PU2.1 server. For more information, refer to
Section 5.1, “Basic PU2.1 Server Configuration,” on page 5-2. This Local CP
Name overrides the CP Name specified in the server configuration.

Remote Terminal ID
An 8-digit hexadecimal string that identifies the remote link station during the
XID exchange. The value can range from 0 to FFFFFFFF. The default is
x’00000000’. The Remote Terminal ID consists of two fields: idblk (first three
digits) and idnum (last five digits), where idblk indicates the SNA device type
and idnum indicates the serial number of the device or any unique value
representing this PU in the network. Refer to Local Terminal ID for a list of
supported devices.
If specified, this value is used to validate the incoming XID. The connection is
not established if the values do not match. If not specified, validation is not
performed.

Table 7-1 Local Terminal ID SNA Device Types

SNA Device Value of idblk

3274 models 21C, 31C, 51C, 61C 017

3276 model 12 018

3770 013

DISPW 03A

3270/3770 03E
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Remote CP Name
A name that is used to verify the incoming XID. The format of the Remote CP
Name is netid.netname, where netid is the returned ID of the SNA network and
netname is the name of the server within the SNA network. Each field can
contain up to eight alphanumeric characters (including @, #, and $). Tabs and
spaces are not allowed. The first character cannot be a number. Lowercase
letters are converted to uppercase.
If you do not specify a Remote CP Name, the Remote Terminal ID is used to
verify the incoming XID. If neither the Remote CP Name nor the Remote
Terminal ID is specified, no attempt is made to identify the remote station.

Automatic Connect?
Indicates whether the link station should try to establish a data link
connection. Check the box if you want the link station to establish a data link
connection. Clear the box if you want the link station to wait for the host to
connect.
This parameter applies only to LAN and switched SDLC connections.

Suppress ACTPU?
Indicates whether the ACTPU should be requested during XID exchange.
Check the box if ACTPU should not be requested. Clear the box if ACTPU
should be requested. If any dependent LUs are defined, make sure that ACTPU
is requested (default).

Limited Resource Link?
Indicates whether the PU should be disconnected when no sessions are active.
Check the box if the PU should be disconnected. Clear the box if the PU should
not be disconnected. Since SSCP-LU sessions are always active, this setting is
ignored if dependent LUs are defined.

Max Data
The maximum frame size for this station (excluding the transmission header,
request/response header, and link header), specified in bytes. This parameter
is applicable only for LAN connections. For Token Ring and FDDI, the value
can range from 41 to 4129. For Ethernet, the value can range from 41 to 1441.
The value must be less than the Maximum Data Size set for the LAN
connection. For more information, refer to Section 6.1.2, “Advanced LAN
Configuration,” on page 6-3.

Note – The frame size depends on the RU size. For more information, refer to
IBM formats.
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Modulus
The frame format for this station. The value can be Extended (128) or Normal
(8). The default is Extended for LAN connections and Normal for SDLC and
QLLC connections.

Response Count
The number of incoming frames that can be received before sending an
acknowledgment. The value can range from 1 to 127. The default is 7.
This parameter is available only for LAN connections.

Send Window (Size)
The maximum number of outstanding transmitted frames at any time. The
value can range from 1 to Modulus. The default is 7.

Receive Window
The maximum number of outstanding incoming frames at any time. The value
can range from 1 to Modulus. The default is 7.
This parameter is available only for LAN connections.

Response Timer
The value of the LLC response timer (T2) in milliseconds. The value can range
from 100 to 3000.
This parameter is available only for LAN connections.

Inactivity Timeout
The number of seconds of inactivity after which the link station disconnects.
The value can range from 0 to 20.

Reply Timeout
The value of the LLC reply timer (T2) in seconds. The value can range from 1
to 30. This value is used in XID poll time-outs for peer-to-peer connections for
PU2.1.

PMaximum Retries
The maximum number of consecutive retries to attempt before declaring an
error. The value can range from 1 to 255.
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Ack Count
The number of acknowledged incoming frames to be received before the
dynamic window is incremented. The value can range from 1 to 127.
This parameter is available only for LAN connections and should be modified
only for complex networks that are having problems with IBM Token Ring
bridge products. For more information, refer to Appendix D, “IBM Token Ring
Concepts.”

Window Increment
The size of the dynamic window after the number of incoming frames
specified by the Ack Count parameter has been received. The value can range
from 1 to 127.
This parameter is available only for LAN connections and should be modified
only for complex networks that are having problems with IBM Token Ring
bridge products. For more information, refer to Appendix D, “IBM Token Ring
Concepts.”

Transfer Mode
The SDLC protocol. The value can be TWA or TWS. Select TWA (two-way
alternating) for half-duplex transmission. Select TWS (two-way simultaneous)
for full-duplex transmission. The default is TWA.
The setting of this parameter is passed to the peer during XID negotiation. This
parameter is available only for SDLC connections and QLLC connections.

Station Address
A 2-digit hexadecimal string representing the SDLC station address. This
parameter is available only for SDLC connections and QLLC connections.

Role
The local link station role over the data link connection. The value can be
Primary, Secondary, or Negotiable. The default is Secondary. If you select
Negotiable, the link station role is determined by an XID exchange. When
connecting to a 37xx communications controller, select either Negotiable or
Secondary, since the 37xx has to be primary. This parameter is available only
for SDLC and QLLC connections.
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Configuring Dependent LUs 8

This chapter contains the following sections:

• Adding Dependent LUs - describes how to configure a single dependent
logical unit (LU) or multiple dependent LUs.

• Modifying Dependent LUs - describes how to modify a single dependent
LU or a group of multiple LUs.

• Deleting Dependent LUs - describes how to delete a dependent LU.
• Creating an LU Pool - describes how to configure an LU pool.
• Modifying an LU Pool - describes how to modify an LU pool.

Note – Before you begin, check with the host network administrator to
determine the names and addresses of the dependent LUs on your system.

This chapter describes how to configure dependent logical units. For
information on configuring independent logical units, refer to Chapter 9,
“Configuring for LUType 6.2.”
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8.1 Adding Dependent LUs

▼ To add a single dependent LU or a group of multiple dependent
LUs:

1. If you intend to include the dependent LU in an LU pool, create the LU
pool before you begin. For information on creating an LU pool, refer to
Section 8.4, “Creating an LU Pool,” on page 8-9.

2. Double-click the appropriate connection icon (LAN Connections, SDLC
Lines, or QLLC Lines) to display the name of the connection.

3. Double-click the connection name in the resource tree to display the name
of the physical unit (DLC).

4. Using the right mouse button (MB3), click and hold the physical unit
(DLC) name in the resource tree and select New → Dependent LU from
the popup menu. The screen displays the Create Dependent LU dialog
box.

5. Enter the appropriate information in the Basic dialog box and then click
Advanced to display the Advanced dialog box. The following sections
describe the parameters in the Basic and Advanced dialog boxes.

6. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.
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8.1.1 Basic Dependent LU Configuration

Name
The network name of a single dependent LU or a group of dependent LUs, as
defined by the host network administrator. The name can contain up to eight
alphanumeric characters (including @, #, and $). Tabs and spaces are not
allowed. The first character cannot be a number. Lowercase letters are
converted to uppercase. You must specify the LU name. The name cannot be
the same as any other dependent LU, independent LU, physical unit (PU), or
LU pool name.
For a group of multiple dependent LUs, the name consists of a prefix followed
by a number identifier. The prefix is a base name and is the same for all
dependent LUs in the group. The number identifier consists of a delimiter (%),
a number that specifies the size of the generated numbers that are appended to
the prefix, and a letter that indicates whether the generated numbers are in
decimal format (d) or hexadecimal format (x).
For example, if you are creating 255 dependent LUs and enter the string
DEPLU%02x, the software creates a group of dependent LUs with the prefix
DEPLU followed by 2-digit hexadecimal numbers (DEPLU01, DEPLU02, . . . ,
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DEPLUFF). If you are creating 255 dependent LUs and enter the string
DEPLU%03d, the software creates a group of dependent LUs with the prefix
DEPLU followed by 3-digit decimal numbers (DEPLU001, DEPLU002, . . . ,
DEPLU255).
Keep the following in mind when specifying the name of a group of multiple
dependent LUs:

• Since the entire name (including the prefix and the generated number) is
limited to a total of 8 characters, if you plan to use 3-digit numbers in the
number field, make sure that you limit the prefix to 5 characters or fewer.

• If you do not specify the size of the generated numbers, the generated
numbers are appended to the prefix without leading zeros.

• By default, the generated numbers that are appended to the base name are
sequential. If the numbers assigned by your host network administrator
are not sequential, you must modify the numbers of individual LUs after
they have been created. For more information on modifying dependent
LUs, refer to Section 8.2, “Modifying Dependent LUs,” on page 8-8.

LU TypeThe LU type. The value can be LUType 0, LUType 1, LUType 2,
LUType 3, or LUType 6.2). Select LUType 1 for 3770 RJE. Select LUType 2 if the
LU is used for 3270 terminal emulation. Select LUType 3 if the LU is used for
printing. Select LUType 6.2 for APPC peer-to-peer communications.
Note that if you are using either an LUType 1 or an LUType 3 for printing,
always select LUType 3, even if the actual printer stream is LUType 1. You can
still use LUType 1 when specifying the LU type to the host and when
configuring the VTAM LU.

Base LOCADDR
The address of the LU (for a single dependent LU) or the address of the first
LU (for a group of multiple LUs). The address can range from 1 to 254. The
default is 001 (if this is the first LU you are configuring) or the first sequentially
available address (if other LUs are already configured).
Check with your host network administrator for the correct address to use. The
address should match the LOCADDR = parameter of the LU definition in either
the VTAM or the NCP Gen on the host. If the address you specify has already
been assigned to an LU on the current PU, the screen displays an error
message requesting that you change the address.
Note that the addresses generated for additional LUs in a group of multiple
LUs are sequential, starting with the Base LOCADDR. If the addresses
assigned by your host administrator are not sequential, you must modify the
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numbers of individual LUs after they have been created. For more information
on modifying dependent LUs, refer to Section 8.2, “Modifying Dependent
LUs,” on page 8-8.

Number of LUs
The number of LUs you want to add.
For a single LU, use the default value of 1.
For a group of multiple LUs, the value can range from 1 to 254. Check with
your host network administrator to find out how many LUs are available for
your system. The software adds the number of LUs you specify, starting at
Base LOCADDR. If the address of an LU conflicts with an existing LU, the new
LU is not added.

Pool Name
The name of the LU pool you want to put the LU into. The default is PUBLIC
(for LUType 2) or None (for LUType 0, LUType 1, LUType 3, and LUType 6.2).
Note that all dependent LUs in a particular LU pool must be of the same type.
If you have not yet created the LU pool, exit the dialog box, create the LU pool
(refer to Section 8.4, “Creating an LU Pool,” on page 8-9), and then reopen the
dialog box to specify the new LU pool.

Access Control
A list of all defined users and user groups. Only users and user groups defined
in the records in the right-hand box (under Click to Remove) can access the
dependent LU. If the right-hand box is empty, any user can access the
dependent LU.
To add a user or user group to the right-hand box, click the record in the left-
hand box. To remove a user or user group from the right-hand box, click the
record in the right-hand box.
Note that access control is not applicable to LUType 6.2.
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8.1.2 Advanced Dependent LU Configuration

Terminal Type
The terminal type of an LUType 2. Select one of the listed terminal types or
enter a terminal type string if the client uses a nonstandard terminal. Select
None if any client can use the LU.
When an LU is selected from an LU pool, the terminal type assures that the
most suitable LU is selected.

Associated Printer
The name of the LUType 3 (printer) associated with the terminal. This
parameter applies to the TN3270 only. The name can contain up to eight
alphanumeric characters (including @, #, and $). Tabs and spaces are not
allowed. The first character cannot be a number. Lowercase letters are
converted to uppercase.

Enable TCP/IP Keepalive
Indicates whether to enable the TCP/IP keep-alive socket option. Check the
box to enable the keep-alive option. Clear the box to disable the keep-alive
option.
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Note – The setting of this parameter is overridden by the equivalent setting in
the user record. For more information about setting this parameter in the user
record, refer to Section 10.1.2, “Advanced User Record Configuration,” on
page 10-3.

PU2.1 Keepalive Timer
The time interval (in minutes) at which the Sun PU2.1 SNA Server sends keep-
alive signals to the client. The server continues to send signals at the specified
time interval until the client sends a response back to the server or until the
number of retries specified by the PU2.1 Keepalive Retries parameter is
exhausted.
This parameter is used in conjunction with the PU2.1 Keepalive Retries
parameter to detect failed client applications and/or workstations. Note that
the setting of this parameter is overridden by the equivalent setting in the user
record. For more information about setting this parameter in the user record,
refer to Section 10.1.2, “Advanced User Record Configuration,” on page 10-3.

PU2.1 Keepalive Retries
The number of times the Sun PU2.1 SNA Server continues to send keep-alive
signals to the client if the client does not send a response back to the server. If
the number of retries is exhausted before the client responds, the LU is freed
and becomes available for another client connection.
This parameter is used in conjunction with the PU2.1 Keepalive Timer
parameter to detect failed client applications and/or workstations. Note that
the setting of this parameter is overridden by the equivalent setting in the user
record. For more information about setting this parameter in the user record,
refer to Section 10.1.2, “Advanced User Record Configuration,” on page 10-3.

In-Session Idle Timeout
The idle time-out period for connections between the client and the host
application (in minutes). If no traffic is detected during the specified time
period, the Sun PU2.1 SNA Server releases the client connection and the active
LU session, and the LU becomes available for another client connection.

Note – The setting of this parameter is overridden by the equivalent setting in
the user record. For more information about setting this parameter in the user
record, refer to Section 10.1.2, “Advanced User Record Configuration,” on
page 10-3.
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No Session Idle Timeout
The idle time-out period for connections between the client and the host when
the client is attached to an LU but has not yet gone into session by starting an
application. If no application is started during the specified time period, the
LU is freed and becomes available for another client connection.

Note – The setting of this parameter is overridden by the equivalent setting in
the user record. For more information about setting this parameter in the user
record, refer to Section 10.1.2, “Advanced User Record Configuration,” on
page 10-3.

8.2 Modifying Dependent LUs

▼ To modify a single dependent LU or a group of dependent LUs:

1. Click the PU name in the resource tree to display the list of dependent
LUs.

2. Select the dependent LU(s) you want to modify. For more information on
selecting multiple dependent LUs, refer to Section 2.5, “Selecting Items,”
on page 2-10.

3. Select Edit → Modify from the menu bar to display the Modify
Dependent LU dialog box.

4. Modify the LU, as necessary. For information on the meaning of the
parameters, refer to Section 8.1, “Adding Dependent LUs,” on page 8-2.

Note – You cannot modify an LU name in the active configuration. In addition,
if you are modifying a group of dependent LUs, you cannot change the Base
LOCADDR parameter.

5. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.
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8.3 Deleting Dependent LUs

▼ To delete a single dependent LU or a group of dependent LUs:

1. Click the PU name in the resource tree to display the list of dependent
LUs.

2. Select the dependent LU(s) you want to delete. For more information on
selecting multiple dependent LUs, refer to Section 2.5, “Selecting Items,”
on page 2-10.

3. Select Edit → Delete from the menu bar and then click OK in the
confirmation dialog box.

8.4 Creating an LU Pool

Note – All dependent LUs in a particular LU pool must be of the same type. If
you are using different types of dependent LUs, make sure that you create a
separate LU pool for each type.

▼ To create an LU pool:

1. Click Pools in the resource tree to select it.

2. Select Edit → New Pool from the menu bar to display the Create Pool
dialog box.
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3. Enter the following information:

Name
The name of the LU pool. The name can contain up to eight alphanumeric
characters (including @, #, and $). Tabs and spaces are not allowed. The first
character cannot be a number. Lowercase letters are converted to uppercase.
You must specify the name of the LU pool. The name cannot be the same as
any other LU pool, PU, dependent LU, or independent LU name.

Comment
A free-form text area that you can use to further qualify and describe the name.

Access Control
A list of all defined users and user groups. Only users and user groups defined
in the records in the right-hand box (under Click to Remove) can access the LU
pool. If the right-hand box is empty, any user can access the LU pool.
To add a user or user group to the right-hand box, click the record in the left-
hand box. To remove a user or user group from the right-hand box, click the
record in the right-hand box.

Note – Access control is not applicable to LUType 6.2.

4. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.
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8.5 Modifying an LU Pool

▼ To modify an LU pool:

1. Double-click Pools in the resource tree to display the list of LU pools.

2. Click the LU pool you want to modify to select it.

3. Select Edit → Modify from the menu bar to display the Modify Pool
dialog box.

4. Modify the LU pool, as necessary. For information on the meaning of
parameters, refer to Section 8.4, “Creating an LU Pool,” on page 8-9.

Note – You cannot modify the LU pool name in the active configuration.

5. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.
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Configuring for LUType 6.2 9

This chapter contains the following sections:

• Configuring an Independent LU - describes how to configure a local
independent logical unit (LU).

• Configuring a Partner LU - describes how to configure a partner LU for a
local independent or dependent LU.

• Configuring the Session Mode - describes how to configure the session
mode for the LU-LU pair.

• Configuring an LUType 6.2 User - describes how to configure an LUType
6.2 user that can access a local independent or dependent LU.

• Configuring a Transaction Program - describes how to configure a
transaction program (TP) that can be accessed by a local independent or
dependent LU.

• Configuring a TP Resource Access List - describes how to configure a TP
resource access list for a TP that requires a user ID, a profile, or a user ID
and profile security verification.

Note – This chapter describes how to configure independent logical units. For
information on configuring dependent logical units, refer to Chapter 8,
“Configuring Dependent LUs."
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9.1 Configuring an Independent LU

▼ To configure an independent LU:

1. Double-click Systems in the resource tree to display a list of systems.

2. Double-click the system name to open its subordinate entries.

3. Double-click PU2.1 Servers to display a list of servers.

4. Double-click the PU2.1 server name to open its subordinate entries.

5. From the main window, select Edit → New → Independent LU to display
the Create Independent LU dialog box.

6. Enter the appropriate information in the Basic dialog box and then click
Advanced to display the Advanced dialog box. The following sections
describe the parameters in the Basic and Advanced dialog boxes.

7. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.

9.1.1 Basic Independent LU Configuration
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Name
The name of the local independent LU. The name can contain up to eight
alphanumeric characters (including @, #, and $). Tabs and spaces are not
allowed. The first character cannot be a number. You must specify the LU
name. The name cannot be the same as any other independent LU, dependent
LU, PU, or LU pool name.

Comment
A free-form text area that you can use to further qualify and describe the
independent LU.

Access Control
This parameter is not supported.

9.1.2 Advanced Independent LU Configuration
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Network Qual Name
The network-qualified (fully-qualified) name of the independent LU. The name
consists of two identifiers, an ID and a name, with a period used as a field
separator. Each field can contain up to eight alphanumeric characters
(including @, #, and $). Tabs and spaces are not allowed. The first character
cannot be a number. Lowercase letters are converted to uppercase.
By default, the software uses the netid of the PU2.1 server CP Name parameter
for the ID (refer to Section 5.1, “Basic PU2.1 Server Configuration,” on
page 5-2) and the local independent LU name for the name.

Session Limit
The maximum number of sessions supported by the independent LU. The
value can range from 1 to 1024.

Allow Partner LU to Queue BIND Rsp?
Indicates whether the local independent LU allows the partner LU to queue
bind requests if the session cannot be activated. Check the box if you want the
partner LU to queue bind requests. Clear the box if you do not want the
partner LU to queue bind requests.

Sync Level SYNCPT Supported?
Indicates whether the local independent LU supports conversations of sync
level sync point (SYNCPT). Check the box if the LU supports SYNCPT. Clear
the box if the LU does not support SYNCPT.

Note – The independent LU cannot support sync point on its own. However,
the LU can allow sync point flows (PS Headers) to pass through and then
recognize and return sync point recovery GDS variables to an external sync
point manager.

9.2 Configuring a Partner LU

Note – Before you can configure a partner LU, you must configure either a
local dependent LU or a local independent LU.

▼ To configure a partner LU:

1. Double-click the PU2.1 server name to open its subordinate entries.
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2. From the main window, select Edit → New → Partner LU to display the
Create Partner LU dialog box.

3. Enter the appropriate information in the Basic dialog box and then click
Advanced to display the Advanced dialog box. The following sections
describe the parameters in the Basic and Advanced dialog boxes.

4. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.

9.2.1 Basic Partner LU Configuration

Name
The name of the partner LU. The name can contain up to eight alphanumeric
characters (including @, #, and $). Tabs and spaces are not allowed. The first
character cannot be a number. Lowercase letters are converted to uppercase.
You must specify the partner LU name.

Local LU
The name of the local LUType 6.2 with which the partner LU is paired. You
must specify the local LUType 6.2 name.
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9.2.2 Advanced Partner LU Configuration

Network Qual Name
The network-qualified (fully-qualified) name of the partner LU. The name
consists of two identifiers, an ID and a name, with a period used as a field
separator. Each field can contain up to eight alphanumeric characters
(including @, #, and $). Tabs and spaces are not allowed. The first character
cannot be a number. Lowercase letters are converted to uppercase.
By default, the software uses the netid of the PU2.1 server CP Name parameter
for the ID (refer to Section 5.1, “Basic PU2.1 Server Configuration,” on
page 5-2) and the partner LU name for the name.

Uninterpreted Name
A name that identifies the partner LU to the System Services Control Point
(SSCP). The name can contain up to eight alphanumeric characters (including
@, #, and $). Tabs and spaces are not allowed. The first character cannot be a
number. Lowercase letters are converted to uppercase. The default
Uninterpreted Name is the partner LU name.

Note – This parameter applies only to dependent LU sessions on the INIT-
SELF and TERM-SELF.
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Session Init Type
The type of session that the SSCP initiates with this partner LU (Init Only or
Init or Queue). Use Init Only if you do not want the INIT-SELF that is sent to
the SSCP to be queued. Use Init or Queue if the SSCP can queue the INIT-SELF
until the partner LU becomes available.

Note – This parameter applies only to a local dependent LUType 6.2.

Parallel Sessions Supported?
Indicates whether parallel sessions are supported with the partner LU. Check
the box if parallel sessions are supported. Clear the box if parallel sessions are
not supported.

CNOS Supported?
Indicates whether the local LU supports CNOS exchanges with the partner LU.
This parameter is valid only if parallel sessions are supported.

Session Password
The LU-LU password for session-level verification on session activation. If you
do not specify a password, LU-LU verification is not performed.

Minimum Security
The minimum level of security that the local LU accepts on incoming allocation
requests from the partner LU. The values are described below:

9.3 Configuring the Session Mode

Note – Before you can configure a session mode, you must configure a partner
LU.

Minimum
Security Description

None No security information is accepted.

Conversation Conversation-level security (consisting of user ID,
password, and optional profile) is accepted.

Already Verified Conversation-level access with the already-
verified indicator is accepted.



9-8 SunLink SNA 9.1 PU2.1 Server Configuration Guide—August 1997

9

▼ To configure a session mode for the LU-LU pair:

1. Double-click the PU2.1 server name to open its subordinate entries.

2. Double-click Partner LU in the resource tree to display a list of partner
LUs.

3. Click the partner LU to select it.

4. From the main window, select Edit → New → Mode to display the Create
Mode dialog box.

5. Enter the appropriate information in the Basic dialog box and then click
Advanced to display the Advanced dialog box. The following sections
describe the parameters in the Basic and Advanced dialog boxes.

6. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.

9.3.1 Basic Session Mode Configuration

Mode Name
The name of the mode to be used on the LU-LU sessions. The name can
contain up to eight alphanumeric characters (including @, #, and $). Tabs and
spaces are not allowed. The first character cannot be a number. Lowercase
characters are converted to uppercase.
The mode name on the local LU must match the mode name on the partner
LU.
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DLC Name
The name of the data link connection (PU) associated with the mode. Use Local
to specify an intranode mode. In this case, symmetric definitions are required
for the local LU and the partner LU.
The association between mode and DLC is related to the Class of Service (COS)
required.

9.3.2 Advanced Session Mode Configuration

Unique Session Name
The unique name used to link this session mode with a particular partner LU.
The name can contain up to 15 alphanumeric characters (including @, #, and $).
The first character cannot be a number.
This parameter is valid only for users migrating from SunLink Version 8.0.

Lowest Max Receive RU Size
The lower limit of the maximum receive RU size for a session, as set in the
bind image. The value can range from 8 to 256.

Highest Max Receive RU Size
The upper limit of the maximum receive RU size for a session, as set in the
bind image. The value can range from 256 to 4096.
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Preferred Max Receive RU Size
The preferred maximum receive RU size for a session, as set in the bind image.
The value can range from 8 to 4096 and must be greater than or equal to the
Lowest Max Receive RU Size and less than or equal to the Highest Max
Receive RU Size.

Receive Pacing Window Size
The size of the pacing window for requests received on the normal flow when
in session. The value can range from 1 to 7.

Lowest Max Send RU Size
The lower limit of the maximum send RU size for a session, as set in the bind
image. The value can range from 8 to 256.

Highest Max Send RU Size
The upper limit of the maximum send RU size for a session, as set in the bind
image. The value can range from 256 to 4096.

Preferred Max Send RU Size
The preferred maximum send RU size for a session, as set in the bind image.
The value can range from 8 to 4096 and must be greater than or equal to the
Lowest Max Send RU Size and less than or equal to the Highest Max Send RU
Size.

Send Pacing Window Size
The size of the pacing window for requests sent on the normal flow when in
session.

Min Contention Winners
The minimum number of sessions with the partner LU for which the local LU
can be the contention winner. The value can range from 0 to 127.
This parameter is available only if both parallel sessions and CNOS are
supported for the partner LU. For more information, refer to Parallel Sessions
Supported? and CNOS Supported?.

Min Contention Losers
The minimum number of sessions with the partner LU for which the local LU
can be the contention loser. The value can range from 0 to 127.
This parameter is available only if both parallel sessions and CNOS are
supported for the partner LU. For more information, refer to Parallel Sessions
Supported? and CNOS Supported?.
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Maximum Sessions
The maximum number of sessions over this mode. The default equals Min
Contention Winners + Min Contention Losers.
This parameter is available only if both parallel sessions and CNOS are
supported for the partner LU. For more information, refer to Parallel Sessions
Supported? and CNOS Supported?.

Auto-init Session Limits?
Indicates whether session limits are established through CNOS processing
prior to session establishment. Check the box to specify that the first request
for a session over this mode initiates CNOS processing over the SNASVCMG
mode. If no SNASVCMG mode is active, one is brought up and session limits
are initialized. Clear the box to specify that session limits are not automatically
established.
This parameter is available only if both parallel sessions and CNOS are
supported for the partner LU. For more information, refer to Parallel Sessions
Supported? and CNOS Supported?.

Note – Auto-initialization is useful with CICS implementations that experience
CICS restarts or host failures.

Sessions to Auto Start
The number of contention-winner sessions that the local LU attempts to
activate for this session mode when the session limits increase because of
CNOS processing. The value can range from 0 to 127.
If you use this parameter in conjunction with the Auto-init Session Limits
parameter, you can initialize session limits prior to session activation.

Limited Resource Timeout
The time interval (in seconds) after which a “limited resource” session is
unbound if it is not used.

Session Restarted
The resource responsible for reinitializing a single session after a session
outage. The value can be Operator, PLU (primary LU), SLU (secondary LU),
PLU or SLU.
This parameter is valid only if neither parallel sessions nor CNOS are
supported for the partner LU. For more information, refer to Parallel Sessions
Supported? and CNOS Supported?.
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9.4 Configuring an LUType 6.2 User

▼ To configure an LUType 6.2 user:

1. Double-click the PU2.1 server name to open its subordinate entries.

2. Click LU6.2 Users in the resource tree to select it.

3. From the main window, select Edit → New → LU6.2 User to display the
Create LU6.2 User dialog box.

4. Enter the following information:

UserName
The user ID that is used for conversation-level security verification. The user
name can contain up to 10 alphanumeric characters. Tabs and spaces are not
allowed. You must specify the user ID.

Note – This UserName is not the same as the Default User name that is
specified for the PU2.1 server and is used for Unix-level security. For more
information, refer to Section 5.1, “Basic PU2.1 Server Configuration,” on
page 5-2.

Password
The password that is used for conversation-level security verification. The
password can contain up to 10 alphanumeric characters.

Note – If the Use UNIX Security? parameter is enabled for the PU2.1 server,
you do not have to specify a password here. Received passwords will be
verified against the Unix /etc/passwd  file. If the Use UNIX Security?
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parameter is disabled for the PU2.1 server, you must specify a password here.
For information, refer to Section 5.1, “Basic PU2.1 Server Configuration,” on
page 5-2.

Profile List
The names of the profiles to be used for conversation-level security
verification. You can specify up to 16 profile entries for each LUType 6.2 user.
Separate each profile name with a comma. Each profile entry can contain up to
10 alphanumeric characters. Tabs and spaces are not allowed.

Local LU
The name of the local LUType 6.2 with which the partner LU is paired. Select
Any if the LUType 6.2 user can access more than one independent LU and/or
dependent LU.

5. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.

9.5 Configuring a Transaction Program

▼ To configure a transaction program:

1. Double-click the PU2.1 server name to open its subordinate entries.

2. Click Transaction Programs in the resource tree to select it.

3. From the main window, select Edit → New → Transaction Program to
display the Create Transaction Program dialog box.

4. Enter the appropriate information in the Basic dialog box and then click
Advanced to display the Advanced dialog box. The following sections
describe the parameters in the Basic and Advanced dialog boxes.

5. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.

9.5.1 Basic Transaction Program Configuration

This section describes the fields on the Create Transaction Program dialog box.
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TP Name
The name of the TP. You can specify the name either as a type A string or as a
hexadecimal string. A type A string can contain up to 64 alphanumeric
characters (including $, #, @, and %). Tabs and spaces are not allowed. The first
character cannot be a number. Lowercase characters are converted to
uppercase. You must specify the TP name.
If you specify the TP name in hexadecimal format, with the first byte of the
name in the range 0x01 to 0x3F (excluding the values 0x0E and 0x0F), users can
write SNA service transaction programs and accept incoming conversations.

Local LU
The name of the local LU. Select Any if the TP can run with any pair of LUs.

Command Path
The complete command line used to start the TP process. Sun recommends that
you specify the command with an absolute pathname.
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9.5.2 Advanced Transaction Program Configuration

Initial Status
The initial status of the transaction program. The value can be Enabled,
Temporarily Disabled, or Permanently Disabled.

Security Verification
The security verification that is performed on incoming Attach requests. The
values are described below:

Security
Verification Description

None No verification is necessary. If the incoming
Attach request contains a user ID and password,
conversation-level security is performed.

Conversation Conversation-level security is performed. The
incoming Attach request must contain either both
a user ID and password or the already-verified
indicator. If you want to use the already-verified
indicator, the Minimum Security parameter of the
partner LU must be set to Already Verified. For
more information, refer to Minimum Security. No
resource access verification is performed.
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Max Instances
The number of instances of this TP that can run simultaneously.

Sync None Allowed?
Indicates whether an Attach request with a sync level of None is permitted to
invoke the TP. Check the box if you want the Attach request to invoke the TP.
Clear the box if you do not want the Attach request to invoke the TP.

Sync Confirm Allowed?
Indicates whether an Attach request with a sync level of Confirm is permitted
to invoke the transaction program. Check the box if you want the Attach
request to invoke the TP. Clear the box if you do not want the Attach request to
invoke the TP.

Sync SYNCPT Allowed?
Indicates whether an Attach request with a sync level of sync point (SYNCPT)
is permitted to invoke the transaction program. Check the box if you want the
Attach request to invoke the TP. Clear the box if you do not want the Attach
request to invoke the TP.

Basic Conv Allowed?
Indicates whether the TP supports incoming Attach requests for basic
conversations. Check the box if the TP supports basic conversations. Clear the
box if the TP does not support basic conversations.

Userid Conversation-level security is performed and the
user ID in the incoming Attach request must exist
in the TP resource access list. For more
information, refer to UserName.

Profile Conversation-level security is performed and the
profile in the incoming Attach request must exist
in the TP resource access list. For more
information, refer to Profile List.

Userid & Profile Conversation-level security is performed and both
the user ID and profile in the incoming Attach
request must exist in the TP resource access list.
For more information, refer to UserName and
Profile List.

Security
Verification Description
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Mapped Conv Allowed?
Indicates whether the TP supports incoming Attach requests for mapped
conversations. Check the box if the TP supports mapped conversations. Clear
the box if the TP does not support mapped conversations.

PIP Data Allowed?
Indicates whether Attach requests containing PIP data are supported by the TP.
Check the box if the TP supports PIP data. Clear the box if the TP does not
support PIP data.

Pass FMH Data to TP?
Indicates whether FMH data is passed to the transaction program. Check the
box if the TP supports FMH data. Clear the box if the TP does not support
FMH data. This parameter is valid only if the TP supports mapped
conversations.

CNOS Verbs?
Indicates whether the TP is allowed to issue the following CNOS verbs:
INITIALIZE_SESSION_LIMIT, RESET_SESSION_LIMIT,
CHANGE_SESSION_LIMIT. Check the box if the verbs are supported. Clear
the box if the verbs are not supported.

Session Control Verbs?
Indicates whether the TP is allowed to issue the following session control
verbs: ACTIVATE_SESSION, DEACTIVATE_SESSION. Check the box if the
verbs are supported. Clear the box if the verbs are not supported.

Definition Verbs?
This parameter is not supported. It is included for future compatibility only.

Display Verbs?
Indicates whether the TP is allowed to issue the following display verbs:
DISPLAY_LOCAL_LU, DISPLAY_MODE, DISPLAY_REMOTE_LU,
DISPLAY_TP. Check the box if the verbs are supported. Clear the box if the
verbs are not supported.

May Alloc Service TPs?
Indicates whether the TP is allowed to attach service TPs. Check the box if the
service TPs are supported. Clear the box if the service TPs are not supported.
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9.6 Configuring a TP Resource Access List

Note – A transaction program resource access list is required only for TPs
whose Security Verification parameter is set to Userid, Profile, or Userid &
Profile. For more information, refer to Security Verification.

▼ To configure a TP resource access list:

1. Double-click the PU2.1 server name to open its subordinate entries.

2. Double-click Transaction Programs in the resource tree to display a list of
TPs.

3. Click the TP name to select it.

4. From the main window, select Edit → New → TP Access Control to
display the Create TP Access Control dialog box.

5. Enter the following information:

UserName
The LUType 6.2 user that you are creating the TP resource access list for. Use
Any if you want any LUType 6.2 user to access the TP.

Profile List
The names of the profiles with which the specified LUType 6.2 user is allowed
to access the TP. This profile list must be a subset of the Profile List specified
for the LUType 6.2 user. For more information, refer to Profile List.

6. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.
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This chapter contains the following sections:

• Defining a User Record - describes how to define a user record.
• Setting up a User Group - describes how to set up a user group.
• Managing Users and Groups - describes how to modify or delete a user

record, how to delete a user from a group, and how to delete access to a
dependent LU from a user or user group.

10.1 Defining a User Record

▼ To define a user record:

1. Click Users in the resource tree to display a list of users.

2. Select Edit → New User from the menu bar to display the Create User
dialog box.

3. Enter the appropriate information in the Basic dialog box and then click
Advanced to display the Advanced dialog box. The following sections
describe the parameters in the Basic and Advanced dialog boxes.

4. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.
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10.1.1 Basic User Record Configuration

Name
The name of the user record. The name can contain up to eight alphanumeric
characters (including @, #, and $). Tabs and spaces are not allowed. The first
character cannot be a number. Lowercase letters are converted to uppercase.
You must specify the name of the user record. The name cannot be the same as
any other user or user group name.

Full Name
The full name of the user. This comment field is intended for identification
purposes and can store information about the user, such phone number and
department name.

Client Address Type
The address type of the client. The value can be IP Address, IP Hostname, IPX
Address, or None. Select None if there are no address restrictions on the user
record.

Default Resource
The name(s) of the resource(s) that you want to use as the default resource(s).
Default resources can be dependent logical units (LUs), independent LUs,
physical units (PUs), or LU pools.
You can specify multiple resources and mix types of resources. If you specify
multiple resources, enter them in the order in which you want them considered
and separate each resource name with a space. For example, if you want the
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software to use the dependent LU DEPLU02 if it is available, and if DEPLU02 is
not available, you want the software to use any LU in the LU pool POOL1, enter
DEPLU02 POOL1 in the field.
The name of each resource can have up to 8 characters. You can enter a total of
256 characters in the field.
If you specify multiple default resources, do not include a PU name in the list
of default resources or make sure that the PU name is the last in the list. If the
software encounters a PU name, the SunGMAN returns the address of the
system containing the PU and subsequent entries in the list are ignored.

10.1.2 Advanced User Record Configuration
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User ID
The user ID. If a connection sends a user ID, that user ID is checked against the
setting of this parameter. If you specify a user ID, but the connection does not
send a user ID, the connection fails. If you do not specify a user ID, no ID
checking is done.

Password
The password of the user. If a connection sends a password, that password is
checked against the setting of this parameter. If you specify a password, but
the connection does not send a password, the connection fails. If you do not
specify a password, no password checking is done.

IP Hostname
The IP node name. You can use wild cards to specify the name (* matches any
string and ? matches any single character). You can use the syntax nodename or
nodename.domainname.
This parameter is available only if the Client Address Type is IP Hostname.

IP Address
IP node address. You specify the IP address as a dotted address, such as
192.127.100.20 .
You can use this parameter with the Mask parameter to mask the IP address to
determine user access. If you do not specify an IP Address, no checking is
done. This parameter is available only if the Client Address Type is IP Address.

Mask
The mask value in dotted format.
You can use this parameter with the IP Address parameter to mask the IP
address to determine user access. The client’s IP address and the IP Address
parameter are ANDed with this value and then compared. If you do not
specify a Mask value, access is determined by the IP Address only. This
parameter is available only if the Client Address Type is IP Address.

Network Number
An 8-character hexadecimal string representing the IPX network number. This
parameter is available only if the Client Address Type is IPX Address.

MAC Address
A 12-character hexadecimal string that represents the Medium Access Control
(MAC) address. Note that each pair of hexadecimal characters is separated by
a colon, such as 00:00:c0:d5:4b:7c . This parameter is available only if the
Client Address Type is IPX Address.
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Privileges
A command that determines the resources that a user can access. The format of
the command for a system/network administrator (operator) is

oper=(resource_specifier [, resource_specifier ]... )

where resource_specifier indicates the top-level resource in the active
configuration that the operator can configure and control.
For example, if resource_specifier indicates a particular PU, the operator can
configure and control the PU and any LUs defined under the PU.
The format of resource_specifier is

[resourcetype =] resourcename

where
resourcetype is one of the following types of resource: Config, Pool, System,
Server, Line, DLC, or PU2. This field is optional. If you do not specify
resourcetype, operator control is based only on resourcename.
resourcename is the name of a resource that the operator can configure and
control. You can use wild cards to specify the name (* matches any string and ?
matches any single character).
For example, if you enter oper=(Pool=POOL1, Pool=POOL3 ), the operator can
control dependent LUs in POOL1 or POOL3.

Note – If you enter oper =  with no resources specified or if you leave this
parameter blank, master operator privileges are assumed (no restrictions). If
you enter oper = () , the operator can view the entire configuration, but
cannot modify anything.

Use Telnet Timing Mark?
Indicates whether your client connection supports the Telnet Timing Mark
option. Check the box if the client supports Timing Mark. Clear the box if the
client does not support Timing Mark.

Note – If you want to use the keep-alive, delayed response, or Response Time
Monitoring (RTM) feature, the client must support the Timing Mark option.

Enable TCP/IP Keepalive?
Indicates whether to enable the TCP/IP keep-alive socket option. Check the
box to enable the keep-alive option. Clear the box to disable the keep-alive
option.
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Note – The setting of this parameter overrides the equivalent setting in the
dependent LU configuration. For more information, refer to Section 8.1.2,
“Advanced Dependent LU Configuration,” on page 8-6.

PU2.1 Keepalive Timer
The time interval (in minutes) at which the Sun PU2.1 SNA Server sends a
keep-alive signal to the client. The server continues to send signals at the
specified time interval until the client sends a response back to the server or
until the number of retries specified by the PU2.1 Keepalive Retries parameter
is exhausted.
This parameter is used with the PU2.1 Keepalive Retries parameter to detect
failed client applications and/or workstations. Note that the setting of this
parameter overrides the equivalent setting in the dependent LU configuration.
For more information, refer to Section 8.1.2, “Advanced Dependent LU
Configuration,” on page 8-6.

PU2.1 Keepalive Retries
The number of times the Sun PU2.1 SNA Server continues to send keep-alive
signals to the client if the client does not send a response back to the server. If
the number of retries is exhausted before the client responds, the LU is freed
and becomes available for another client connection.
This parameter is used with the PU2.1 Keepalive Timer parameter to detect
failed client applications and/or workstations. Note that the setting of this
parameter overrides the equivalent setting in the dependent LU configuration.
For more information, refer to Section 8.1.2, “Advanced Dependent LU
Configuration,” on page 8-6.

In-Session Idle Timeout
The idle time-out period for connections between the client and the host
application (in minutes). If no traffic is detected during the specified time
period, the Sun PU2.1 SNA Server releases the client connection and the active
LU session, and the LU becomes available for another client connection.

Note – The setting of this parameter overrides the equivalent setting in the
dependent LU configuration. For more information, refer to Section 8.1.2,
“Advanced Dependent LU Configuration,” on page 8-6.
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No Session Idle Timeout
The idle time-out period for connections between the client and the host when
the client is attached to an LU but has not yet gone into session by starting an
application. If no application is started during the specified time period, the
LU is freed and becomes available for another client connection.

Note – The setting of this parameter overrides the equivalent setting in the
dependent LU configuration. For more information, refer to Section 8.1.2,
“Advanced Dependent LU Configuration,” on page 8-6.

10.2 Setting Up a User Group

▼ To set up a group of user records:

1. Click Groups in the resource tree to display a list of groups.

2. Select Edit → New Group from the menu bar to display the Create Group
dialog box.

3. Enter the following information:
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Name
The name of the user group. The name can contain up to eight alphanumeric
characters (including @, #, and $). Tabs and spaces are not allowed. The first
character cannot be a number. Lowercase letters are converted to uppercase.
You must specify the name of the user group. The name cannot be the same as
any other user or user group name.

Comment
A free-form text area that you can use to further qualify and describe the name.

Members
A list of all defined users. Only users in the right-hand box (under Click to
Remove) are in the user group.
To add a user to the right-hand box, click the record in the left-hand box. To
remove a user from the right-hand box, click the record in the right-hand box.

4. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel.

10.3 Managing Users and Groups
This section describes how to modify a user record, how to delete a user
record, how to delete a user from a group, and how to delete access to a
dependent LU from a user or user group.

10.3.1 Modifying a User Record

▼ To modify a user record:

1. Click Users in the resource tree to display the list of users.

2. Click the user record that you want to modify.

3. Select Edit → Modify from the menu bar to display the Modify User
dialog box.

4. Modify the user record, as necessary. For information about the meaning
of the parameters, refer to Section 10.1, “Defining a User Record,” on
page 10-1.
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5. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.

Note – You must modify a user record if you delete the resource specified in
the Default Resource parameter. If a user connects to a user record and the
Default Resource is not defined, the user gets an error message.

10.3.2 Deleting a User Record

▼ To delete a user record:

1. Click Users in the resource tree to display the list of users.

2. Click the user record that you want to delete.

3. Select Edit → Delete from the menu bar and then click OK in the
confirmation dialog box.

Note – If you delete the user record of a user who is part of a group, the user
is removed from the user group automatically.

10.3.3 Deleting a User from a Group

▼ To delete a user from a user group:

1. Click Groups in the resource tree to display a list of groups.

2. Select the group you want to delete the user record from.

3. Select Edit → Modify from the menu bar to display the Modify Group
dialog box.

4. From the Members box, click the user (in the right-hand box) that you
want to remove from the group.

5. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel.
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10.3.4 Deleting Access to a Dependent LU

▼ To delete access to a dependent LU:

1. Click the name of the PU in the resource tree to display the list of
dependent LUs.

2. Select the dependent LU that you want to modify.

3. Select Edit → Modify from the menu bar to display the Modify
Dependent LU dialog box.

4. From the Access Control box, click the user or group (in the right-hand
box) that you want to remove.

5. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.
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This chapter contains the following sections:

• Controlling Access to the Sun PU2.1 SNA Server - describes how to control
access to the Sun PU2.1 SNA Server by clients (users) and by operators
(system/network administrators).

• Managing Licenses - describes how to add and delete license information.
• Managing Manager Systems - describes how to determine the number of

manager systems to define, how to create manager systems, and how to
recover when 50% or fewer of the manager systems are available.

• Managing the Active Configuration - describes how to modify the active
configuration and how to save and distribute the updates.

• Managing an Off-line Configuration - describes how to create and modify
off-line configurations and how to activate an off-line configuration.

• Controlling the Status of Resources - describes how to start and stop
connections to the SNA network and how to make resources unavailable or
available for client use.

11.1 Controlling Access to the Server
The following sections describe how to control access to the Sun PU2.1 SNA
Server by clients (users) and by operators (system/network administrators).
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11.1.1 Controlling Client Access

By default, any client (user) can access any resource. If required, you can limit
access so that only specific clients can access specific dependent logical units
(LUs) and/or LU pools. To limit access, you define user records and user
groups and then include only those users and/or groups with access to the
resource in the resource’s access list.

For information on setting up:

• Users and user groups, refer to Chapter 10, “Configuring Users."
• An access list for a dependent LU, refer to the Access Control definition in

Section 8.1.1, “Basic Dependent LU Configuration,” on page 8-3.
• An access list for an LU pool, refer to the Access Control definition in

Section 8.4, “Creating an LU Pool,” on page 8-9.

The way the Sun PU2.1 SNA Server determines whether to grant a client access
to the LU depends on whether the client specifies the name of the LU or the
name of the LU pool that the LU is in. Refer to the following flow diagram.
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For example, assume that you want to tie a particular LU to a physical location
so that client requests from that location are directed to the LU. If you set up a
user record with the LU specified as the default resource and if you set up the
access list of the LU to allow access only from the specific user, the LU would
be protected against other clients accessing it.

As another example, assume that you want to offer a service to external
customers in different enterprises. You could define a user record for each
customer, specifying an LU pool as the default resource, and then set up the
access list of the LU pool so that only access from systems in the specific
customer network is allowed. In the following figure, clients at Acme Corp.
can access LUs in POOLA only. Clients in Bonzo Inc. can access LUs in POOLB
only.

Figure 11-1 Controlling Client Access
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To display a list of the client connections to each system, double-click System
in the resource tree, double-click the system name, and then click Client
Connections. Refer to the following Figure 11-2.

Figure 11-2 Displaying Client Connections

11.1.2 Controlling Operator Access

The Sun PU2.1 SNA Server supports the following types of operators
(system/network administrators):

• Master operator - By default, all operators are master operators. Any user
name is accepted when you connect to the Sun Graphical Management
Interface (SunGMI). As a master operator, you can modify the configuration
of the Sun PU2.1 SNA Server or change the status of resources without
restriction. You can also restrict the control of other system/network
administrators to a particular portion of the active configuration.

• Restricted operator - Restricted operators cannot configure or control
resources outside of their span of control, and they cannot modify or create
off-line configurations.

You specify whether an operator is a master operator or a restricted operator in
the Privileges parameter of the user record. For more information, refer to
Section 10.1.2, “Advanced User Record Configuration,” on page 10-3.

Note – Always create at least one master operator before creating any
restricted operators.
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If a restricted operator tries to modify a resource, the software scans the
resource tree looking for a resource whose type and name match a resource
specifier in the operator’s privilege list. If the software finds a resource that
matches an entry in the privilege list, the operator’s action is permitted.
Otherwise, it is denied.

For example, in the following figure, both a master operator and a restricted
operator are defined. The user GRAHAM is the master operator. The user SITE1  is
a restricted operator that can only access LUs associated with the physical unit
(PU) psite1  or LUs in the pool pool1 .

Figure 11-3 Master and Restricted Operator

To display a list of all currently connected operators and details of all
administration applications connected to the Sun PU2.1 SNA Server, select
Window → Application List to display the Applications window. For more
information, refer to Section 2.3.3, “Applications Window,” on page 2-6.

11.2 Managing Licenses
The maximum number of client connections allowed in the domain is
determined by the number of licenses you own. You may have to add licenses
to allow additional client connections. You may have to delete licenses if they
have expired or before adding new licenses. The following sections describe
how to add and delete licenses.
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11.2.1 Adding a License

▼ To add a new license:

Note – Before adding a new license, make sure that you get all the necessary
information from the Sun licensing center.

1. Select Window → Licenses List to display the Licenses window.

2. Click and hold the right mouse button (MB3) and select New License
from the popup menu. The screen displays the Create License dialog box.

3. Enter the following information:

Feature
The feature provided by the Sun licensing center. Note that the only feature
currently supported is dependentLU .

Version
The version number provided by the Sun licensing center.

Number of Licenses
The number of licenses provided by the Sun licensing center.

Expiry Date
The expiration date provided by the Sun licensing center in the format
MM.DD.YY.

Index
The index provided by the Sun licensing center.

Key
The key provided by the licensing center.

4. To accept the settings, click OK. To exit the dialog box without accepting
the settings, click Cancel. To return to the default settings, click Reset.
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11.2.2 Deleting a License

▼ To delete a license:

1. Select Window → Licenses List to display a list of the current licenses
configured for the Sun PU2.1 SNA Server.

2. Click the license that you want to delete.

3. Click and hold the right mouse button (MB3), select Delete from the
popup menu, and then click OK in the confirmation box.
If deleting a license causes the number of licenses to drop below the current
number of client connections, the Sun PU2.1 SNA Server blocks further
connections until the number of connections drops below the new number
of licenses.

11.3 Managing Manager Systems
The Sun PU2.1 SNA Server allows you to create multiple instances of the Sun
Gateway Manager (SunGMAN) to protect against system failure. Each instance
of the SunGMAN is referred to as a manager system.

The following sections describe how to determine the number of manager
systems to define, how to add manager systems to the manager network, and
how to recover when 50% or fewer of the manager systems are available.

11.3.1 Determining the Number of Manager Systems to Define

Each Sun PU2.1 SNA Server configuration requires at least one manager
system. When deciding how many additional manager systems to create, keep
the following in mind:

• In a large network, Sun recommends that you define at least three manager
systems. If you define two manager systems, the 50% quorum rule requires
that both manager systems are running at all times.

• If you have only two manager systems, set one of them to be the preferred
primary manager system. The primary manager system will continue to
operate as a primary manager system even if the second manager system
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fails. Note, however, that if the primary manager system fails, the second
manager system will not be able to take over as the primary manager
system.

• If the Sun PU2.1 SNA Server running in multiple physical sites, define one
manager system for each physical site. This allows local Domain Name
System (DNS) requests for resources and minimizes the delay in transferring
information from the server to the manager systems.

• Sun recommends that you do not define more than three manager systems,
since adding extra manager systems increases the traffic.

Note – When the Sun PU2.1 SNA Server software is installed, no manager
systems are defined.

11.3.2 Adding a Manager System

▼ To add a manager system to the manager network:

1. Select Window → Managers List to display the Managers window.

2. Click and hold the right mouse button (MB3) and select New Manager
from the popup menu. The screen displays the Create Manager dialog
box.

3. Enter the following information:

Host
The TCP/IP hostname of the system on which you installed the SunGMAN.
You must specify the hostname.

Comment
A free-form text area that you can use to further qualify and describe the host.

Preferred Primary?
Indicates whether you want the software to select this manager system as the
primary manager system, if possible. Check if you want this manager system
to be the primary manager system. Clear if you want this manager system to
be a secondary manager system. Note that only one manager system can be the
primary manager system.

4. To accept the settings, click OK. To exit the dialog box without accepting
the settings, click Cancel. To return to the default settings, click Reset.
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After you define each manager system, the software adds the manager system
to the manager network, the manager network negotiates among the connected
manager systems to determine their roles (primary or secondary), and the roles
of the manager systems are shown in the status display.

The following figure shows a Managers window with three manager systems
defined.

Figure 11-4 Multiple Manager Systems

11.3.3 Recovering from a Loss of Quorum

If a manager system fails and causes the number of connected manager
systems to drop below the 50% quorum, you must manually update the
manager network.

▼ To update the manager network:

1. Restart the SunGMI by entering the following command at the shell
prompt.

sungmi &

Do not specify the domain name in the command line. This ensures that the
screen displays the Connect to domain dialog box.
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2. In the Domain Name field of the Connect to domain dialog box, enter the
TCP/IP hostname of one of the manager systems that is up and running.
Do not enter the name of the domain. If you enter the domain name when a
quorum of manager systems is not available, the SunGMI may not connect
to the manager network.

3. Select Window → Managers List to display the Managers window.

4. From the list of manager systems, select one of the manager systems that
has failed. The status of a failed manager system is Inactive.

5. Click and hold the right mouse button (MB3), select Delete from the
popup menu, and then click OK in the confirmation box.

The manager network negotiates among the connected manager systems
attempting to determine a primary manager system. If a quorum of manager
systems is available, the manager network selects a primary manager system
and the status display indicates the selected primary manager system. If a
primary manager system is not determined in a minute or so, a quorum of
manager systems is not available. Repeat steps 4 and 5 until you have reduced
the manager network to a single manager system or until you have reduced
the manager network to enough available manager systems to satisfy the 50%
quorum rule.

Note that if a failed manager system is brought back on-line, the software
automatically determines that the failed system has been deleted from the
current manager network and adjusts the configuration files on the previously
failed system. When a failed manager system is restored to service, you can
add the manager system to the manager network. For more information, refer
to Section 11.3.2, “Adding a Manager System,” on page 11-9.

11.4 Managing the Active Configuration
You can have multiple configurations, but only one configuration can be active
at any given time. The following sections describe how to modify the active
configuration and how to save and distribute the updates.
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11.4.1 Modifying the Active Configuration

Note – Only one operator can make changes in a particular system at a
particular time. If you attempt to modify a resource in a system that is being
modified by another operator, an error is generated.

▼ To modify a resource in the active configuration:

1. Expand the elements of the resource tree until the resource that you want
to modify is displayed.

2. Select the resource(s) that you want to modify.
For information on selecting multiple resources, refer to Section 2.5,
“Selecting Items,” on page 2-10. Note that if you select multiple resources,
you will not be able to modify parameters that apply differently to each of
the selected resources.

3. Select Edit → Modify to display the appropriate Modify dialog box.

4. Make the appropriate changes in the Modify dialog box.

Note – Observe the following restrictions:

You cannot modify the name of an existing resource in the active configuration.
If you want to modify the name of a resource, you must delete the existing
resource and create a new one with the new name. You can, however, change
the name of a resource that has been added but has not yet been saved.

If you selected multiple resources, parameters that cannot be modified are
grayed out.

5. To accept the settings, click OK. To exit the dialog box without accepting
the settings, click Cancel. To return to the default settings, click Reset.
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11.4.2 Saving Changes to the Active Configuration

▼ To save changes to the active configuration:

1. Select File → Save. The screen displays the Save Type dialog box.

2. Select one of the following options to specify how you want the updates
to be applied to the active configuration:

Wait for servers to become idle - If a modified server still has active client
connections, the software sets the state of the server to Draining. The server
stops accepting client connections and is not considered available for load
control. (Clients are not directed to the manager system containing the
server unless they explicitly request a resource on that server.) When all
active connections terminate, the configuration is updated and the server is
restarted with the new configuration.

Changes should be made immediately - Each modified server is
immediately terminated and restarted with the new configuration.

In general, when the active configuration is modified and saved, only the
servers that were changed are affected. The primary manager system writes the
new configuration to disk locally and then initiates a distributed save
operation to each active secondary manager. When the distributed save is
complete and the configuration is stored on the active secondary manager
systems, a reply is sent to the SunGMI that initiated the Save command and the
operation is complete.

11.5 Managing an Off-line Configuration
You can use off-line configurations to make changes in an orderly fashion. Off-
line configurations allow you to make a series of updates off-line and then
bring them on-line at a specific time. The following sections describe how to
create and modify off-line configurations and how to activate an off-line
configuration.
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11.5.1 Creating an Off-line Configuration

▼ To create an off-line configuration:

1. Select Window → Configurations to display the configuration window.

2. Select Edit → New Configuration to display the Create Config dialog box.

3. Enter the following information:

Configuration Name
The name of the new off-line configuration. You must specify a new
configuration name.

Comment
A free-form text area that you can use to further qualify and describe the off-
line configuration.

Auditing Enabled?
Indicates whether you want to store auditing information about client
connections in a file on disk. Check the box if you want to store auditing
information. Clear the box if you do not want to store auditing information.

Max Disk Usage by Audit
The percentage of total disk space that can be in use before auditing
information is no longer stored. This parameter is available only if auditing is
enabled.

3270 Help Screen Display Key
The AID key that a client (user) can use to display a screen of LU information.
The value can be None, PF1 to PF24, or PA1 to PA3.

Note – If you change the value of this parameter, you must manually restart
the server for the changes to take effect. For more information about the LU
screen, refer to Figure 12-1 on page 12-31.

4. To accept the settings, click OK. An exact copy of the existing
configuration is created under the new name. To exit a dialog box without
accepting the settings, click Cancel. To return to the default settings, click
Reset.
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5. Save the configuration by highlighting the configuration in the
configuration window and then selecting File → Save from the menu bar.

11.5.2 Modifying an Off-line Configuration

Note – Only one operator can make changes in a particular system at a
particular time. If you attempt to modify a resource in a system that is being
modified by another operator, an error is generated.

▼ To modify a resource in an off-line configuration:

1. Select Window → Configurations to display the configuration window.

2. Highlight an existing configuration and then select File → Open to display
the resource window for the configuration.

3. Select File → Save As to display the Enter new name for config dialog box.

4. Enter a new name for the configuration in the Configuration Name field
and click OK.

5. Double-click the new configuration to display the resource window for
the configuration.

6. Expand the elements of the resource tree until the resource that you want
to modify is displayed.

7. Select the resource(s) you want to modify.
For information on selecting multiple resources, refer to Section 2.5,
“Selecting Items,” on page 2-10. Note that if you select multiple resources,
you will not be able to modify parameters that apply differently to each of
the selected resources.

8. Select Edit → Modify to display the appropriate Modify dialog box.

9. Make the appropriate changes in the Modify dialog box.

Note – Observe the following restrictions

If you selected multiple resources, parameters that cannot be modified are
grayed out.
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Unlike modifying an active configuration, you can modify the name of an
existing resource in an off-line configuration.

10. To accept the settings, click OK. To exit the dialog box without accepting
the settings, click Cancel. To return to the default settings, click Reset.

11. Specify the time to activate the new configuration. For more information,
refer to the next section.

11.5.3 Making an Off-line Configuration Active

▼ To activate an off-line configuration:

1. Highlight the off-line configuration in the configuration window.

2. Select Control → Activate from the menu bar. The screen displays the
Specify Activation Time dialog box.

3. From the Date and Time drop-down menus, select a preset date and time
to activate the configuration, or select User Supplied. If you select User
Supplied, the Date and Time text boxes become available. Enter the exact
date and time to activate the configuration. For the date, use the default
format for the current locale. For example, in the United States, use the
format MM/DD/YYYY. For the time, always use the format HH:MM in 24-
hour format.

4. To exit a dialog box without accepting the settings, click Cancel.
To accept the settings, click OK. If the specified activation time is in the
future, the configuration enters the Pending Activate state. When the
specified activation time arrives, the configuration enters the Activating
state and the following occurs:

All systems and PU2.1 servers in the active configuration are
immediately stopped and the active configuration becomes an off-line
configuration.

The off-line configuration information is downloaded to each of the
systems and PU2.1 servers defined in the off-line configuration, and the
systems and PU2.1 servers are started if their initial status is set to
Active.
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11.6 Controlling the Status of Resources
You can control the status of resources in the active configuration, as follows:

• You can specify the initial status of systems and PU2.1 servers (Active or
Inactive). If you select Active, the system or PU2.1 server is activated when
the system is initialized. The software makes sure that the system or PU2.1
server is always running and restarts the system or PU2.1 server if it fails. If
you select Inactive, you must manually activate the system or PU2.1 server.

• You can dynamically start or stop any resource by selecting the resource in
the resource tree and then initiating the Start or Stop command in one of the
following ways:
• Select Control → Start or Control → Stop from the menu bar.
• Click the Enable or Disable toolbar button. For more information, refer to

Section 2.6.1, “Toolbar Buttons,” on page 2-11.
• Position the mouse pointer over the appropriate resource, click and hold

the right mouse button (MB3), and select Start or Stop from the popup
menu.

The Start command is available only if the following are true:

• The active configuration is open.
• The state of the resource is Inactive or Pending Inactive.
• All of the parents of the resource are active. For example, you cannot start a

PU until the server and system that the PU is part of are both active.

The Stop command is available only if the following are true:

• The current configuration is active.
• The state of the resource is Active, Pending Active, or Failed. Note that if a

resource fails, you must disable the resource before you can restart it.
• All of the parents of the resource are active.

The following table lists the result of starting and stopping each type of
resource.
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Table 11-1 Stop and Start Results by Resource Type

Resource Command Result

System Start Starts the Sun PU2.1 SNA Server software on
the system. Starts any PU2.1 servers with an
initial status of Active. Makes the system
available for use by clients.

Stop Stops all PU2.1 servers on the system. Makes
the system unavailable for use by clients.

PU2.1
server

Start Starts the selected PU2.1 server process.

Stop Stops the selected PU2.1 server process.

PU (DLC) Start Activates the connection to the SNA network.

Stop Disconnects the connection to the SNA
network.

Client
connection

Stop Disconnects the client connection and frees the
LU.

Dependent
LU

Disable Makes the dependent LU unavailable. Existing
sessions and client connections are not
affected.

Forced
Disable

Makes the dependent LU unavailable. Existing
sessions and client connections are destroyed.

Enable Makes the dependent LU available for client
connections.
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This chapter contains the following sections:

• Diagnostic Tools - describes the diagnostic tools provided by the Sun PU2.1
SNA Server to help you and the Sun Technical Support staff determine the
cause of any problems you may encounter.

• Error Messages - describes what you should do if you encounter an error
code while using the Sun PU2.1 SNA Server.

• Common Problems - describes how to solve some common problems that
you may encounter when using the Sun PU2.1 SNA Server.

• Getting Help - describes how to get help from Sun.

12.1 Diagnostic Tools
To help you and the Sun Technical Support staff determine the cause of any
problems you may encounter, the Sun PU2.1 SNA Server provides the
following diagnostic tools, which are described in the following sections:

• Resource information tables
• Event logs
• Line traces
• PU2.1 server traces
• LU information screens



12-2 SunLink SNA 9.1 PU2.1 Server Configuration Guide—August 1997

12

12.1.1 Resource Information Tables

The Sun PU2.1 SNA Server allows you to display configuration information,
status information, or Response Time Monitor (RTM) information about
resources. The following sections describes how to select the type of
information to display, how to customize the format of a resource information
table, and how to use the status and RTM tables.

12.1.1.1 Selecting the Type of Information to Display

By default, the software displays a configuration table for each resource. In
addition, for systems, connections, physical units (PUs), dependent logical
units (LUs), and LU pools, the software allows you to display a status table.
For dependent LUs, the software allows you to display an RTM table. Note
that if you are monitoring an operational system, the status table or RTM table
usually contains more information than the configuration table.

▼ To select the type of information to display:

1. Highlight the resource in the resource tree.

2. Click and hold the right mouse button (MB3) and select
Display → Configuration, Display → Status, or Display → RTM from the
popup menu.

The information in the resource table changes to reflect the type of
information you selected.

If the Display command is not available in the popup menu, the table
format has not been created for the highlighted resource. For information on
customizing a table format for the resource, refer to the following section.

12.1.1.2 Customizing a Table Format

▼ To customize the format of a configuration, status, or RTM table:

1. Select Options → Table Formats to display the Table Formats dialog box.
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2. Enter the following information:

Select Format
The type of table format you want to modify. You can select one of the preset
table formats or you can click New to create a new table format.
Clicking New displays the Create Format dialog box. In the Format Name
field, you can enter a name for the new format and click OK.
If you want to delete a table format, click Delete and then click OK in the
confirmation box. Note that you cannot delete the Configuration table format.

Select Table
The type of resource whose table you want to modify.

Poll Manager for Updates?
Indicates whether you want to refresh the table when the specified poll interval
expires. Check the box if you want to refresh the table. Clear the box if you do
not want to refresh the table.

Poll Interval
The time interval (in seconds) at which the table is refreshed.
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Note – For large configurations, refreshing tables can be time-consuming and
system-intensive. Make sure that you specify a Poll Interval that does not
interfere with system operations.

MIB Variables
The Management Information Base (MIB) variables supported for the specified
resource. The list of MIB variables includes both configuration variables, status
variables, and RTM variables, as follows:

• Configuration variables - Used for the Configuration table format. The
configuration variables correspond to the parameters that you set for the
specified resource when you configure your manager system. For
example, the systemName variable corresponds to the Host parameter in
the Create System dialog box.

• Status variables - Used for the status table format. For more information
about the status variables, refer to Table 12-1 on page 12-5.

• RTM variables - Used for the RTM table format. For more information
about the RTM variables, refer to Table 12-2 on page 12-15.

To include an MIB variable in your table format, select the variable and click
Add. The variable is displayed in the Sample box. Note that the variables are
displayed in the order in which you add them.
To remove an MIB variable from your table format, select the variable in the
Sample box and click Remove.

Heading
For the selected MIB variable, the heading to use in the table. Sun recommends
that you use heading names that are simpler and shorter than the MIB variable
names.

Column Width
The width of the table column in which the selected MIB variable is displayed.

3. To accept the settings, click Done.

12.1.1.3 Using the Status Tables

If a status table format is defined for a resource, you can display a status table
for the resource or subordinate resources by highlighting the top-level resource
in the resource tree and selecting Display → Status. For example, if you select
a server, the software displays information about all the servers configured on
the system. If you select a LAN connection, the software displays information
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about all the PUs configured on that LAN connection. The particular
information displayed and the headings used for that information depend on
the way you set up your status table format. For more information, refer to
Section 12.1.1.2, “Customizing a Table Format,” on page 12-2.

The following table describes the MIB variables that you can use in a status
table for each of the supported resources.

Table 12-1 Status Table MIB Variables (1 of 9)

Resource MIB Variable Description

System systemName The name of the system.

systemOperStatus The current operational status of the
system. The value can be:
Inactive - The system has not yet been
started.
Active - The system is active and in
contact with the Gateway Manager.
Failed - The system has failed to start
up.

systemConfigStatus The current configuration status of the
system. The value can be Default,
Added, Modified, or Deleted.

systemLoadAverage The overall system load. This variable
is used in load balancing.

systemProcessorNum The number of the slot that the board
(application processor) occupies in the
Integrated Gateway.

systemNesting The nesting status of the board
(application processor) in the
Integrated Gateway. The value can be
Parent, Child, or None.

systemParent The name of the top-level Integrated
Gateway system (parent).
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LAN
connection

lanName The name of the LAN connection.

lanOperStatus The current operational status of the
LAN connection. The value can be:
Pending Active - The physical device
driver has received an operator
command to activate the link and is in
the process of doing so.
Active - The physical device driver is
activated and has brought up the
electrical interface.

lanConfigStatus The current configuration status of the
LAN connection. The value can be
Default, Added, Modified, or Deleted.

lanStatsMsgsRcvd The number of frames received since
start-up.

lanStatsCharsRcvd The number of bytes received since
start-up.

lanStatsRcvBadAddr The total number of information
frames received with a link station
address that does not match a Local
Service Access Point (LSAP).

lanStatsRcvBadCntl The number of frames received since
start-up with an invalid control field.

lanStatsRcvCrc The number of frames received since
start-up with incompatible source
routing fields (fields that cannot
handle the MAXPDU).

lanStatsRcvSize The number of frames received since
start-up with length exceeding the
maximum frame size.

lanStatsRcvAllocb The number of receive buffer
allocation failures since start-up.

Table 12-1 Status Table MIB Variables (2 of 9)

Resource MIB Variable Description
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LAN
connection
(cont.)

lanStatsRcvCanput The number of receive upstream
congestion errors since start-up.

lanStatsMsgsSent The number of packets transmitted
since start-up.

lanStatsCharsSent The number of bytes transmitted since
start-up.

lanStatsRcvFA The number of aborted frames
received.

lanStatsRcvOvr The number of receive overruns
received.

lanSourceRoute Not applicable.

lanSrcAddr The local MAC ring station address.

Table 12-1 Status Table MIB Variables (3 of 9)

Resource MIB Variable Description
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SDLC
connection

sdlcName The name of the SDLC connection.

sdlcOperStatus The current operational status of the
SDLC line. The value can be:
Pending Active - The physical device
driver has received an operator
command to activate the link and is in
the process of doing so.
Active - The physical device driver is
activated and has brought up the
electrical interface.

sdlcConfigStatus The current configuration status of the
SDLC line. The value can be Default,
Added, Modified, or Deleted.

sdlcStatsMsgsRcvd The number of frames received since
start-up.

sdlcStatsCharsRcvd The number of bytes received since
start-up.

sdlcStatsRcvBadAddr The total number of information
frames received with a link station
address that does not match the local
address. Note that for multi-point
lines, an address matching another
line counts in the total. Therefore, a
nonzero value may be valid.

sdlcStatsRcvBadCnt The number of frames received since
start-up with an invalid control field.

sdlcStatsRcvCrc The number of frames received since
start-up with CRC errors.

sdlcStatsRcvSize The number of frames received since
start-up with length exceeding the
maximum frame size.

sdlcStatsRcvFA The number of aborted frames
received since start-up.

Table 12-1 Status Table MIB Variables (4 of 9)

Resource MIB Variable Description
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SDLC
connection
(cont.)

sdlcStatsRcvOvr The number of receiver overrun
frames received since start-up.

sdlcStatsRcvAllocb The number of receive buffer
allocation failures since start-up.

sdlcStatsRcvCanput The number of receive upstream
congestion errors since start-up.

sdlcStatsMsgsSent The number of packets transmitted
since start-up.

sdlcStatsCharsSent The number of bytes transmitted since
start-up.

sdlcStatsXmtUnr The number of transmit underrun
errors since start-up.

sdlcStatsXmtWdt The number of lost transmit interrupts
since start-up.

sdlcMaxData The maximum size of a received
frame.

QLLC
connection

qllcOperStatus The current operational status of the
QLLC line.The value can be:
Pending Active - The physical device
driver has received an operator
command to activate the link and is in
the process of doing so.
Active - The physical device driver is
activated and has brought up the
electrical interface.

qllcConfigStatus The current configuration status of the
QLLC line. The value can be Default,
Added, Modified, or Deleted.

Table 12-1 Status Table MIB Variables (5 of 9)

Resource MIB Variable Description
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PU (DLC) pu2Name The name of the PU.

pu2OperStatus The current operational status of the
PU. The value can be:
Reset - The PU is inactive (the
operator entered adisable
command.
Pending Reset - The PU is being
deactivated.
Pending Contacted - The PU is
waiting for the SNA host to contact it
with a mode setting command, such as
SNRM for SDLC or SABME for
LLC.
Contacted - The PU has been
contacted by the SNA host (mode-
setting exchange and
acknowledgment), but the host has not
yet activated the PU.
Pending Active - The SNA host has
activated the PU by transmitting an
ACTPU request message, but the PU
has not responded to the activation
request. If this is a peer connection,
this state indicates that a data link
connection has been established.
Pending Active/Attached - The
SNA host has activated the PU by
transmitting an ACTPU request
message and a client SNA program is
attached to the PU port, but the PU
has not responded to the activation
request.
Active - The SNA host has activated
the PU. The SSCP-PU session is
active.
Active/Attached - The SNA host has
activated the PU, a client SNA
program is attached to the PU port,
and the SSCP-PU session is active.

pu2ConfigStatus The current configuration status of the
PU. The value can be Default, Added,
Modified, or Deleted.

Table 12-1 Status Table MIB Variables (6 of 9)

Resource MIB Variable Description
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PU (cont.) pu2StatsMsgsSent The total number of information
frames transmitted by this link station
since start-up.

pu2StatsCharsSent The total number of information
frame (data and control) bytes
transmitted by this link station since
start-up.

pu2StatsMsgsRcvd The total number of information
frames received by this link station
since start-up.

pu2StatsCharsRcvd The total number of information
frame (data and control) bytes
received by this link station since
start-up.

pu2StatsReXmits The total number of information
frames retransmitted by this link
station since start-up.

pu2StatsRespTimeout The total number of activity time-outs
detected by this link station since
start-up.

pu2StatsRmtBusy The total number of RNRs received
by this link station since start-up.

pu2StatsLclBusy The total number of RNRs transmitted
by this link station since start-up.

Table 12-1 Status Table MIB Variables (7 of 9)

Resource MIB Variable Description
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Dependent LU luName The name of the dependent LU.

luOperStatus The current operational status of the
LU. The value can be:
Inactive - The LU is not active.
Inactive/Attached - The LU is not
active and a client SNA program is
attached to the LU port.
Active - The SNA host has activated
the LU by transmitting an ACTLU
request message. The SSCP-LU
session is active.
Active/Attached - The SNA host has
activated the LU by transmitting an
ACTLU request message, a client
SNA program is attached to the LU
port, and the SSCP-LU session is
active.
Active/Session - The SNA host has
established an LU-LU session with a
client SNA program attached to the
LU port. The SSCP–LU session is
active.

luConfigStatus The current configuration status of the
dependent LU. The value can be
Default, Added, Modified, or Deleted.

luSessInBPiuCnt The number of Path Information Units
(PIUs) sent on the LU-LU session
since the session was activated.

luSessInBRuCharCnt The number of Request Unit (RU)
characters sent on the LU-LU session
since the session was activated.

luSessOutBPiuCnt The number of PIUs received on the
LU-LU session since the session was
activated.

luSessOutBRuCharCnt The number of Request Unit (RU)
characters received on the LU-LU
session since the session was
activated.

Table 12-1 Status Table MIB Variables (8 of 9)

Resource MIB Variable Description
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Dependent
LU (cont.)

luSessStartTime The time the LU-LU session was
activated.

luAvailStatus Indicates whether the dependent LU is
currently available for administrative
purposes.

luUserName The name of the user currently
attached to the dependent LU.

luNetAddrType The network address type of the client
currently attached to the dependent
LU.

luNetAddr The network address of the client
currently attached to the dependent
LU.

LU pools poolName The name of the LU pool.

poolOperStatus Not applicable.

poolConfigStatus The current configuration status of the
LU pool. The value can be Default,
Added, Modified, or Deleted.

poolTotalLUs The total number of LUs configured
in this pool.

poolAvailLUs The number of LUs in the pool that do
not have an attached client.

poolInUseLUs The number of LUs in the pool that
have an attached client.

poolActLUs The number of LUs in the pool that
have been activated by the host and
can support a user session.

poolInactLUs The number of LUs in the pool that
have not been activated by the host
and cannot support a user session.

Table 12-1 Status Table MIB Variables (9 of 9)

Resource MIB Variable Description
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12.1.1.4 Using the RTM Table

The Sun PU2.1 SNA Server allows a NetView operator to initiate the
measurement of response time statistics for selected 3270 display devices. The
server accumulates RTM statistics for the devices and delivers the statistics to
NetView on demand or on session termination. sun3270 clients measure both
SNA and TCP/IP response times. TN3270 clients can include the round-trip
TCP/IP time using the Telnet Timing Mark option. Response time information
is maintained separately for the SNA and TCP/IP networks.

Note – The Sun PU2.1 SNA Server also supports Network Performance
Monitor (NPM) response time measurements for sun3270 and TN3270 clients.
NPM uses definite response mode to measure round-trip delay. Since only
extended TN3270E clients can handle definite responses, for traditional
TN3270 clients, you must use the Telnet Timing Mark option to configure the
server to delay transmission of the definite response until the client has
received the request.

If an RTM table format is defined for a dependent LU, you can display an RTM
table by highlighting the dependent LU in the resource tree and selecting
Display → RTM. The particular information displayed and the headings used
for that information depend on the way you set up your status table format.
For more information, refer to Section 12.1.1.2, “Customizing a Table Format,”
on page 12-2.

The following table describes the MIB variables that you can use in an RTM
table for dependent LUs.
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Table 12-2 RTM Table MIB Variables (1 of 2)

MIB Variable Description

luRTMActive Indicates whether NetView has activated RTM for this
3270. The value can be Yes or No.

luRTMSendOnOv Indicates whether the Sun PU2.1 SNA Server will send
RTM statistics if any of its counters overflow. The value
can be Yes or No.

luRTMSendOnTerm Indicates whether the Sun PU2.1 SNA Server will send
RTM statistics when the LU-LU session is unbound. The
value can be Yes or No.

luRTMType The RTM collection type. The type can be one of the
following:
Stop on First Char - The time from the transmission of the
inbound AID request to the receipt of the first character of
the next outbound message.
Stop on Kbd Unlock - The time from the transmission of
the inbound AID request to the receipt of the next Change
Direction indicator, End Bracket indicator, or keyboard
restore request.
Stop on CDI/EBI - The time from the transmission of the
inbound AID request to the receipt of the next Change
Direction or End Bracket indicator.
Stop on Last Char - The time from the transmission of the
inbound AID request to the receipt of the last character of
the next outbound message.

luRTMNumBounds The number of RTM boundaries (or counters) requested.
The value can be 1, 2, 3, or 4.

luRTMBoundary[1-4] For each boundary, the upper limit of the response time
range (in milliseconds).

luRTMCount[1-4] For each boundary, the number of times a measured
response time fell into its response time range.

luRTMOverFlow The number of times a measured response time was
outside the upper limits of any of the counters.

luRTMTotalTime The total accumulated time (in milliseconds).

luRTMLastTime The last measured response time (in milliseconds).
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12.1.2 Event Log

The Sun PU2.1 SNA Server provides an event log to capture all events
generated by its components.

To display an event log, select Window → Event Log from the menu bar. The
software displays the Events window.

12.1.3 Line Trace

The Sun PU2.1 SNA Server provides a logical data scope utility, Sunscope,
that allows you to observe data sent and received on a LAN, SDLC, or QLLC
connection. Use this utility to capture a line trace of problem scenarios for
subsequent diagnosis.

The following sections describe how to configure your system for line tracing,
how to start a line trace, and how to read the output of a line trace.

luSnaRTMCount[1-4] For each boundary, the number of times the SNA
component of a measured response time fell into its
response time range.

luSnaRTMOverFlow The number of times the SNA component of a measured
response time was outside the upper limit of any of the
counters.

luSnaRTMTotalTime The total accumulated time that the network has SNA and
IP components (in milliseconds).

luSnaRTMLastTime The SNA component of the last measured response time.

luIpRTMCount[1-4] For each boundary, the number of times the IP component
of a measured response time fell into its response time
range.

luIpRTMOverFlow The number of times the IP component of a measured
response time was outside the upper limit of any of the
counters.

luIpRTMTotalTime The total accumulated time for the IP component of the
network.

luIpRTMLastTime The IP component of the last measured response time.

Table 12-2 RTM Table MIB Variables (2 of 2)

MIB Variable Description
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12.1.3.1 Configuring Your Systems for Line Tracing

The Sun Graphical Management Interface (SunGMI) starts the Sunscope utility
on the selected server’s system by invoking the Unix remote shell (rsh )
command. Each operator who wants to run the Sunscope utility must be
allowed to remotely access the server systems from the systems on which they
run the SunGMI. To provide this remote access, add the following entry for
each operator in the /etc/hosts.equiv  file on each server system:

hostname username

where

hostname is the name of the system on which the operator runs the SunGMI.

username is the operator’s log-in name.

Information in the /etc/hosts.equiv  file applies to the entire system. In
addition, operators can maintain their own .rhosts  files in their home
directories.

Note – The /etc/hosts.equiv  and .rhosts  files provide the remote
authentication database for the remote access commands rsh , rlogin , rcp , and
rcmd . The files specify remote hosts and users that are trusted. Trusted users
are allowed to access the local system without supplying a password. Since the
/etc/hosts.equiv  and .rhosts  files bypass the standard password-based
user authentication mechanism, use care when creating and maintaining these
files.

12.1.3.2 Starting a Line Trace

▼ To start a line trace:

1. In the resource tree, click the LAN, SDLC, or QLLC connection that you
want to trace. Make sure that you select the connection for the appropriate
system and PU2.1 server.

2. Select Control → Trace Line to display the Start Line Trace dialog box.
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3. Enter the following information:

Host
The hostname of the remote server system. You should not have to change this
field.

Working Directory
The directory on the remote host where the Sunscope utility is located. During
installation, the utility is placed in /opt/SUNWgmi .

Device
The target device name. For LAN and SDLC connections, this value defaults to
the Device name specified for the connection. For more information, refer to
Section 6.1, “Adding a LAN Connection,” on page 6-1 (for LAN connections)
or Section 6.2.1, “Basic SDLC Configuration,” on page 6-5 (for SDLC
connections). You should not have to change this field.

Output Log File
The name of the local file where you want to log the output of the Sunscope
utility. If you do not enter a file name, the data is displayed only on the screen.

Note – Output log files can grow very quickly, so choose a file system with
sufficient free space.
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Sunscope Options
The command line options that you can use when activating the Sunscope
utility. Separate command line options with a space. Valid command line
options are as follows:

Table 12-3 Sunscope Command Line Options

Options Description

-e Display hexadecimal numbers as EBCDIC characters.

-t Required for all LAN devices (IBM Token Ring, Ethernet,
FDDI).s

-c Required for channel devices on Integrated Gateway
systems.

-m dest_addr Display only frames sent to and from the destination
Medium Access Control (MAC) address specified by
dest_addr. All other frames are filtered out. The
destination MAC address is a 12-digit hexadecimal value
in the format 0x400010000012 .

-x xmit_size Set the maximum length for a display of a transmitted
packet to xmit_size bytes. If a transmitted packet exceeds
xmit_size bytes, only the first xmit_size bytes are
displayed.

-r rcv_size Set the maximum length for a display of a received
packet to rcv_size bytes. If a received packet exceeds
rcv_size bytes, only the first rcv_size bytes are displayed.

-p pattern Match the pattern specified by pattern against a packet.
The pattern is a hexadecimal value and can be any
length. If you use the -o  and -l  command line options,
the pattern is matched against the portion of the packet
that starts offset bits from the beginning of the packet and
extends for length bits. Make sure that pattern is greater
than or equal to length bits.
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xterm Command
The command line options that you can use to customize the xterm  command.
Separate command line options with a space. The following table lists some
valid command line options. Use the man xterm  command to display a
complete list of command line options.

-o offset Set the offset from the beginning of the packet, where you
want to begin pattern matching, to offset bits.

-l length Set the length of the portion of the packet used for
pattern matching to length bits.

-a Display only packets that match the pattern. If you use
the -o  and -l  command line options, display only
packets where the pattern matches the portion of the
packet that starts offset bits from the beginning of the
packet and extends for length bits.
For example, assume that the pattern is 0xff , the offset is
8 (bits), and the length is 8 (bits). If you use the -a
command line option, the Sunscope utility displays only
packets that have the value 0xff  in the second byte (bits
8 through 15).
If you do not use the -a  command line option, the
Sunscope utility displays only packets for which the
pattern does not match the portion of the packet that
starts offset bits from the beginning of the packet and
extends for length bits. For example, assume that the
pattern is 0xff , the offset is 8 (bits), and the length is 8
(bits). If you do not use the -a  command line option, the
Sunscope utility displays only packets that do not have
the value 0xff  in the second byte.

Table 12-3 Sunscope Command Line Options (Continued)
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4. To accept the settings and start the line trace, click Start. To exit a dialog
box without accepting the settings, click Cancel.

Note – If the remote authentication fails, the screen displays the message
“Permission Denied” in the trace window. Make sure that you have configured
your system appropriately for line tracing. For more information, refer to
Section 12.1.3.1, “Configuring Your Systems for Line Tracing,” on page 12-17.

12.1.3.3 Reading the Output

The Sunscope utility output resembles a hexadecimal dump. Each frame is
prefixed by S (for Sent frames) or R (for Received frames). The frame is
displayed in both hexadecimal (HEX) format and in ASCII format (or EBCDIC
format if the -e  command line option is specified). Only printable ASCII data
is shown.

The following sections show examples of SDLC and Token Ring output.

Sample SDLC Output
The following is a sample of SDLC output.

Table 12-4 xterm  Command Line Options

Command Line
Options Description

-j Jump scroll.

-sb Enable scroll bars.

-sl number Save the last number lines of output. For
example, to save the last 1,000 lines of
output, enter -sl 1000.

-geometry columnxline Create a window that is column columns
wide and line lines high. For example, to
create an 80-column by 48-line window,
enter -geometry 80x48.
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The first byte is the station address. The Sunscope utility captures all the data
traffic on the line being scoped. On a multi-point line, the utility displays
traffic for all the stations on the line. Reference only the messages with a
station address that matches the configured PU2 ADDR.

If the utility shows no traffic, the Sun PU2.1 SNA Server is not receiving any
data. Either there is a physical connection problem or the SNA host has not
activated your line station. PU Type 2 stations do not transmit any data until
contacted by the SNA host. PU Type 2.1 stations always transmit NULL XID

requests (ffbf ) unless configured for ALS_CONNECT=PASSIVE.

If the output contains Sent frames only (no Receive frames), the PU2.1 server is
not receiving data. If you are connected to a Token Ring, Ethernet, or FDDI
interface, make sure that you have specified the -t  command line option. If
you are connected to an Integrated Gateway, make sure that you have specified
the -c  command line option.

The sample SDLC output is continued below. Comments are in italics.

Note – The comments included in this section are not generated by the trace
utility. They are included simply to explain SDLC output.

(C) Copyright 1997 Sun Microsystems, Inc.

*-----> scope log data for line: /dev/ttys0 <-----*

# Host sends connect request (SNRM) to our
# station ( c1 ). We respond (UA).

R: c1 93 Al.
S: c1 73 A.

# 4 digit messages ending in 1 are Receiver Ready
# messages (RR).

R:c11 1 A.

——————————— Frame content in HEX —————————————————><—————— EBCDIC —————>
:c1ca280002000001 038000e6c5d3c3d6 d4c540e3d640e3c8  A....WELCOME TO THE
c540c9c2d440e3c5 e2e340c6c1c3c9d3 c9e3e840c6d6d940 IBM TEST FACILITY
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S:c11 1 A.
# Host sends activate PU (ACTPU= 11) request.
# We respond.

R:c1002d00000001e9 6b8000 1102010500 00000004 A......Z,..
R:c111 A.
S:c1202d00000001e9 eb8000 1111404040 4040404040000007A.....Z.....
01000000000000 .......
S:c131 A.

# Host sends activate LU (ACTLU= 0d) requests.
R:c1222d00020001ed 6b8000 0d0201 A.......,.....
R:c1242d00030001ee 6b8000 0d0201 A.......,.....
R:c1262d00040001ef 6b8000 0d0201 A.......,.....

# Host may send other types of messages like
# this Response Time Monitor (RTM) request
# (NMVT=41038d ).

R:c1282c0000000001 0b800 041038d 0000 0000000021808004A.................
 9288001994ed00ec 0000000100000000 00000004000a0014 kh..m.............
 00320064 ....
R:c131 A.

# We respond to activate LU requests.
S:c1a22d00000201ed eb8000 0d02010000 0000000c06010001As................
 000000 ...
S:c1a42d00000301ee eb8000 0d02010000 0000000c06010001Au................
 000000 ...
S:c1a62d00000401ef eb8000 0d02010000 0000000c06010001Aw................
 000000 ...

# We respond to previous RTM request.
S:c1a82c0000000001 8f900010030000 41 038d Ay................
S:c1b1 A.
R:c1b1 A.
S:c1b1 A.
R:c1b1 A.

# We notify the host when an client SNA
# program attaches to an LU port.

S:c1aa2c0000020001 0ba0008106200c06 030001000000 A........a........
S:c1b1 A.
R:c1d1 AJ
S:c1b1 A.
R:c1d1 AJ
S:c1b1 A.
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# For sun3270, the host sends a login banner.
# First piece, some removed.

R:c1ca280002000001 038000e6c5d3c3d6 d4c540e3d640e3c8A...WELCOME TO THE
 c540c9c2d440e3c5 e2e340c6c1c3c9d3 c9e3e840c6d6d940 IBM TEST FACILITY

# Possibly a second piece ...
R:c1cc240002000001 4040404040404040 40c1d7d7d3c9c44dA....... APPLID(
 e75d40d3d6c7d4d6 c4c54de85d40c4c1 e3c14de95d157e7e X)LOGMODE(Y)DATA(Z).==
 7e6e40 =>

# Host responds to our previous notification.
R:c1ce2c0002000001 8ba000810620 A..........a..
R:c1d1 AJ
S:c10c2c0000020001 838000 A.......c..
S:c111 A.
R:c1f1 A1
S:c111 A.
R:c1f1 A1

# We send a login request to NetView
# and the host responds.

S:c10e2c0000020002 0380009585a3a589 85a6 A..........netview
S:c111 A.
R:c1002c0002000002 838000 A.......c..

# Host sends an acknowledgment message and
# we respond.

R:c1022c0002000002 03800015d3d6c7d6 d540d9c5d8e4c5e2A.....LOGON REQUES
R:c111 A.
S:c151 A.
R:c111 A.
S:c1402c0000020002 838000 A ......c..
S:c151 A.
R:c131 A.
S:c151 A.

# Host sends BIND request (BIND= 31) and
# we respond.

R:c1242d00020101f0 6b8000 31010303b1 903080000187c701A....0,........gG.
 0002000000000018 5000007e000005c3 d5d4f0f100 .....&..=...CNM01.
R:c131 A.
S:c1622d00010201f0 eb8000 31 A......0....
S:c171 A^
R:c151 A.
S:c171 A^
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Sample Token Ring Output
The following is a sample of Token Ring output.

The first six bytes are the destination MAC address. The next six bytes are the
source MAC address, followed by 0 to 18 bytes of source routing information.
The Logical Link Control (LLC) information header follows the source MAC
address or the source routing information if it is present. SNA data is carried in
the information field of the LLC frames. For more information about MAC and
LLC frame formats and for a description of protocols and source routing, refer
to Appendix D, “IBM Token Ring Concepts." The Sunscope utility captures all
the data traffic for the IBM Token Ring network interface being monitored.

If Sunscope shows no traffic or only data originating from the local ring
station, the Sun PU2.1 SNA Server is not receiving any data. Either there is a
physical connection problem or the SNA host has not activated your link
station. Note that the Sun PU2.1 SNA Server transmits route determination
first, followed by XID polling after the route is determined.

The sample Token Ring output is continued below. Comments are in italics.

(C) Copyright 1997 Sun Microsystems, Inc.

*-----> scope log data for line: /dev/nit <-----*

# sunPU21 is sending out route determination
# frame to locate the Host-IBM Token Ring
# Interface device

S:4000123456784000 246835790000f3 ..... ....`..3
S:4000123456784000 246835790000f3 ..... ....`..3
S:4000123456784000 246835790000f3 ..... ....`..3

# Not found on local ring, check others
S:400012345678c000 2468357982700000 f3 .....{....`b...3
S:400012345678c000 2468357982700000 f3 .....{....`b...3
S:400012345678c000 2468357982700000 f3 .....{....`b...3

# Back to local ring

————————————— Frame content in HEX ————————————————><———— EBCDIC ——————>
R:4000246835794000 1234567804040404 2c00020000010380.....` ...........
 00e6c5d3c3d6d4c5 40e3d640e3c8c540 c9c2d440e3c5e2e3.WELCOME TO THE
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S:4000123456784000 246835790000f3 ..... ....`..3

# Host is located
R:4000246835794000 123456780001f3 ....` .......3

# XID Exchange Occurs with PU2.1 acting
# as the secondary

S:4000123456784000 246835790404bf ..... ....`...
R:400024683579c000 123456788220aaaa 0300000008060006....`{.....b......
 0800060400014000 12345678c009dc08 000000000000c009 .... ...{.......{.
 dc00 ..
S:4000123456784000 246835790404bf32 1d017000110000b0.... ...`.........
 0020000000000000 010b410008000000 00000700 ..................

# Mode-setting command, SABME, issued
# by the primary ring station

R:4000246835794000 1234567804047f ....` ......."
S:4000123456784000 24683579040573 ..... ....`...

# Station readiness determination
S:4000123456784000 2468357904040101 ..... ....`....
R:4000246835794000 1234567804050101 ....` .........

# Host sends activate PU (ACTPU= 11) request.
# We respond.

R:4000246835794000 1234567804040000 2d00000016dd6b80....` ...............,.
 00 11020105000000 0004 ..........
S:4000123456784000 2468357904050102 ..... ....`....
S:4000123456784000 2468357904040002 202d00000016ddeb..... ....`............
 8000 111140404040 4040404000000701 000000000000 ....    ..........
R:4000246835794000 1234567804050102 ....` .........

# Host sends activate LU (ACTLU= 0d) request.
R:4000246835794000 1234567804040202 2d00020016df6b80  ....` ...............,.
 00 0d0201 ....
S:4000123456784000 2468357904050104 ..... ....`....
S:4000123456784000 2468357904040204 042d00000216dfeb..... ....`.......
 8000 0d0201000000 00000c0601000100 0000 ..................
R:4000246835794000 1234567804050104 ....` .........

# For sun3270, the host sends a login banner.
# First piece, some removed.

R:4000246835794000 1234567804040404 2c00020000010380....` ............
 00e6c5d3c3d6d4c5 40e3d640e3c8c540 c9c2d440e3c5e2e3 .WELCOME TO THE
S:4000123456784000 2468357904040406 002c000002000187..... ....`......g
 900008310000 ......
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R:4000246835794000 1234567804050106 ....` .........

# Host sends a disconnect command
# we respond.

R:4000246835794000 12345678040453 ....` ........
S:4000123456784000 24683579040573 ..... ....`...

12.1.4 PU2.1 Server Trace

The Sun PU2.1 SNA Server allows you to activate up to 32 internal traces on
each PU2.1 server. You can use these traces to capture activity related to the
entire server or a specified set of resources. Because the traces are selective, you
can capture problem scenarios that would normally be hidden in the more
expansive line trace.

Note – You can also use the Sunscope utility to view link information about a
resource.

The following sections describe how to configure and start a PU2.1 server trace
and how to read the output of a PU2.1 server trace.

12.1.4.1 Configuring a PU2.1 Server Trace

▼ To configure a PU2.1 server trace:

1. In the resource tree, click the server that you want to trace.

2. Select Control → Create Trace to display the Create Trace dialog box.
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3. Enter the following information (note that the MIB variable names are in
parentheses):

System (traceSysName)
The name of the target server system.

Server (traceSrvName)
The name of the server.

Resources (traceResList)
The names of the resources (LUs, PUs, and connections) that you want to trace.
Separate each resource name with a comma. Use * to specify all resources.
If you specify an invalid resource name, the trace fails. You must delete the
failed trace (by highlighting the trace and selecting Edit → Delete) and then
configure a new trace using a valid resource name. You cannot modify a sever
trace.

Trace Type (traceFlags)
The trace flags you want to activate. Sun recommends that you specify
X’ffffffff’  to indicate all trace flags. If you want to use other values, contact
the Sun Technical Support staff for assistance.

Output File (traceFileName)
The full pathname of the trace file on the target system. You must enter an
output file name.
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Start Time (traceStartTime)
The time to start the trace in the format HH.MM.SS. The default is Now.

Duration (traceDuration)
The length of time in seconds that you want the trace to run. (When the trace
file becomes full, the trace ends even if the specified time has not elapsed.)

Records Per File (traceNumTracePts)
The number of trace points to write to the trace file. The value can range from
1 to 10000. The default is 1000.

Action on File Full (traceFileFull)
The action to perform when the number of trace points specified by the
Records Per File parameter has been written. The value can be Stop Trace or
Continue.
If you select Continue, when the file specified by the Output File parameter
becomes full, the software creates a new file called filename.1 (where filename is
the file specified by the Output File parameter) and continues to write trace
points to filename.1. Note that only two trace files are maintained. When
filename.1 becomes full, new trace points are written to filename, overwriting
any existing data.

4. To accept the settings, click OK. To exit a dialog box without accepting the
settings, click Cancel. To return to the default settings, click Reset.

12.1.4.2 Starting a PU2.1 Server Trace

▼ To start a PU2.1 server trace:

1. Select Window → Active Traces List to display a list of configured PU2.1
server traces.

2. Click the PU2.1 server that you want to trace.

3. Select Control → Start Server Trace to start the trace.

12.1.4.3 Reading the PU2.1 Server Trace

A sample trace point is shown below.
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Each trace point contains the following information:

• The date and time that the trace point was recorded (07/09/97 15:44:45, in
example).

• The time that has lapsed (in seconds) since the last trace point (0.017, in
example).

• The component that is recording this trace point (link send, in example). The
most common components are as follows:

link mngr send  - Messages controlling lines and line stations.

link mngr rcv  - Messages notifying line and line station status.

control_api_rcv  - Requests received on the SunOP utility interface.

control_api_send  - Responses and notifications sent on the SunOP
utility interface.

link send: station name  - Data messages sent to the PU, where
station name is the PU name.

link rcv: station name  - Data messages received from the PU, where
station name is the PU name. Always starts with FID2.

• A hexadecimal message dump or information string.

12.1.5 LU Information Screen

The Sun PU2.1 SNA Server allows clients (users) to display a screen of LU
information that you can use to help troubleshoot problems with the client’s
system. You specify the AID key that the client uses to display the screen in the
configuration. For more information on how to specify the AID key, refer to the
3270 Help Screen Display Key definition in Section 11.5.1, “Creating an Off-line
Configuration,” on page 11-14.

The following figure shows a sample LU information screen.

trace point: 07/09/97 15:44:45 lapse: 0.017 link send: BPU011
       2c00000200020380 009585a3a58985a6
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Figure 12-1 Sample LU Information Screen

If the client presses the AID key a second time, the AID key is sent to the host.

If the client is using the configured AID key for another purpose, the client can
change the AID key by pressing any other PF or PA key while the LU
information screen is displayed. This new key is used as the AID key for the
current session only. Once the current connection is broken, the configured
AID key is the key used to display the LU information screen.

To return the session to its previous state, the user can press the Enter key.

Note – When you press the Enter key to return the session to its previous state,
the PU 2.1 Server will generate an SNA LUSTAT command, indicating to the
host 'Presentation Space Lost' - meaning that the host application should
resend the latest screen to the client. Applications can vary in how they handle
this LUSTAT command.

LU Name: NLU2
Client Address: 199.97.127.56:42491
Server Address: 199.97.127.56:8023
Connect Time: Mon Jan 27 14:26:15 1997
LU Status: Active Session
User Name: TESTUSER
Pool Name: Not Available

Current AID for LU address information is: PF1

Press ENTER to return to previous screen or press another AID key to use
for LU address information prompting during this session.
Valid AID keys are PF1 - PF24, PA1 - PA3
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12.2 Error Messages
If an error occurs while you are using the Sun PU2.1 SNA Server, the software
displays an error code. For most error codes, the error message text and
display information is stored in the Sun Message Database (BMD). To use the
bmsg utility to display the text of messages and any associated user action
information, go to the /opt/SUNWpu21  directory and enter the following:

% bmsg COMPnnnn

where

COMP is the 4-character message group identifier.

nnnn is the message number.

For example, the following line appears in the event log:

Server Server1 PU200001: Initializing sunPU21 Server

To display information about any actions you should perform, enter the
following:

% bmsg PU200001

12.3 Common Problems
The following sections contain information about common problems that you
may encounter when using the Sun PU2.1 SNA Server.

Sun also provides an updated list of common problems and solutions through
the Internet. Refer to the Sun home page at http://www.Sun.com  or connect to
the anonymous FTP server at ftp.Sun.com and look in the
/pub/documentation directory for further information.

In addition, with each release of the Sun PU2.1 SNA Server, an updated
version of the release notes is provided. Check the release notes to see whether
a problem you are encountering has been corrected. The release notes are
located in the installation directory (/opt/SUNWpu21 , by default) and can be
displayed by selecting Release Note from the Help menu.
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12.3.1 The SunGMI Does Not Start

If you are using Solaris, the SunGMI will not run unless the Motif Runtime
package is installed and you have the environment variable LD_LIBRARY_PATH

defined to include the directories that contain the Motif shared libraries. These
directories are normally /usr/openwin/lib  and /usr/dt/lib .

If you see the message

 "fatal: libXm.so.3: can't open file: errno=2"

the Motif Runtime package or the environment variable may not be in place.
The Motif Runtime package is included on the Solaris 2.4 CD and can be
installed on Solaris 2.3, 2.4, and 2.5.1.

To set the environment variable, enter the following:

% export LD_LIBRARY_PATH=/usr/openwin/lib:/usr/dt/lib

If you see the message:

"Error: Can't open display"

the X-display from the machine running the  SunGMI cannot open a window
on your local workstation. To allow access to your screen, enter the following
from the system console display:

% xhost + machinename

where machinename is the system running the  SunGMI. On Solaris, xhost  is
located in the /usr/openwin/bin  directory by default.

12.3.2 The SunGMI Cannot Connect to the Running Domain

The manager system that you specified is not currently active, or a manager
network is in place but no primary manager system has been determined. If
the manager network is running, start the SunGMI again, connecting to the
TCP hostname that the SunGMAN process is running on by name instead of
by domain. Display the Managers window to see the status of the manager
systems in the manager network. For more information, refer to Section 2.3.2,
“Managers Window,” on page 2-6.
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12.3.3 The suncpd Process Is Not Running

The suncpd process allows the manager network to operate properly and
allows systems and servers to be started. It runs on systems that have the
SunGMAN process installed and on systems running the Sun PU2.1 SNA
Server. If you elected to create system boot files during the SunPU21 or
SunGMAN installation procedures, the suncpd process is started from the
system start-up files.

To restart thesuncpd process, enter the following:

/etc/rc2.d/S89SunPU21 or /etc/rc2.d/S90SunGMAN

If the working directory has changed since you installed the product, you must
edit the script files and then change to the working directory before running
the suncpd process.

The suncpd image must be able to translate the TCP/IP service name
brxgman_cpd_port into a port number at run-time. The product installation
procedures create entries in your /etc/services  file and list changes that you
should make to your NIS database (if used). If the port number definitions
change or get lost over time, you must restore them to their previous values.
For a description of the changes needed, refer to the installation log file in the
product installation directory.

12.3.4 The SunGMAN Process Does Not Start

You must run the SunGMAN process from the root account. If it was started
from another account, it will report an error and exit. Restart from the root
account.

The SunGMAN image must be able to translate a number of TCP/IP service
names into port numbers at run-time. The product installation procedures
create entries in your /etc/services  file and list changes that you should
make to your NIS database (if used). If the port number definitions change or
get lost over time, you must restore them to their previous values. For a
description of the port names and values needed, refer to the installation log
file in the product installation directory.
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12.3.5 The Sun PU2.1 SNA Server Configuration Does Not Start
Automatically

If the SunGMAN process is installed correctly and starts, but does not initialize
the configured systems and servers at start time, the manager network may
have 50% or fewer of the configured managers active. SunGMAN will wait
until at least 50% are active before activating the configuration. For more
information, refer to Section 1.10, “Manager Network,” on page 1-19.

If the systems or PU2.1 servers are listed in the resource window of the
SunGMI but are not active, they may be configured with an initial status of
Inactive. Change the initial status to Active and save the configuration. This
will restart the system/server and bring it to an operational state.

12.3.6 A System Fails

If a system in the SunGMI is displayed in red and is marked as "Failed", check
the event messages logged in the Events window of the SunGMI. The problem
may be one of the following:

• The TCP host on which the system is running is unreachable.
• The suncpd process on the remote system is not running.
• The sunSMAN process cannot locate the TCP service names it needs.
• The sunSMAN process is already running, but it was not started by the

SunGMAN process.

12.3.7 A PU2.1 Server Fails

The problem may be one of the following:

• The TCP host that the Sun PU2.1 SNA Server is running on is unreachable.
• The suncpd process on the remote system is not running.
• A PU2.1 server process (sunPU21) is already running, but either it was not

started by the SunGMAN process or it shares the same sunOP service name.
• The server configuration file is not valid. Check the errors logged in the

Events window of the SunGMI.
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12.3.8 The Connection Does Not Activate or the Connection Loops

Use the Sunscope utility to determine whether anything is being sent or
received over the connection. The problem may be one of the following:

• A hardware installation/cabling problem exists.
• Verify that the device name specified for the SDLC or LAN connection

exists on the machine and is connected.
• For SDLC, verify that the device port being used is a synchronous port

and verify the modem connections.

• The IBM host components are not active. Check with your IBM system
programmers to ensure that the IBM VTAM/NCP components are active.

• A configuration problem exists.
• Verify that the Local Terminal ID matches the remote IDBLK/IDNUM

definition.
• For Token Ring, verify that the SAPs being used are matching and are not

in use by another station.
• For SDLC, verify that the Station Address matches the IBM Addr

parameter.

12.3.9 The PU Does Not Activate

The problem may be one of the following:

• A configuration problem exists.
• Verify that the Local Terminal ID matches the remote IDBLK/IDNUM

definition.
• For Token Ring, verify that the SAPs being used are matching and are not

in use by another station.
• For SDLC, verify that the Station Address matches the IBM Addr

parameter.

• The IBM PU is not active.

12.3.10 Client Connections Are Failing

If a client connection fails, try one of the following:
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• Check the Events window of the SunGMI. If no event messages are listed,
verify that the client can establish a TCP/IP connection to the SunGMAN
system. Enter the command ping machinename , where machinename is the
system running the SunGMAN software.

• Verify that LUs are available for use in the PUBLIC pool. Display the status
of the LU pools using the SunGMI.

• If the client connection is using a Domain Name System (DNS) resource
name, such as xxx.Sun , try to connect to the system directly to see if the
DNS name resolution is failing.
• If the SunGMAN process is operating as a secondary DNS, verify that the

primary DNS is configured to know about the Sun subdomain and that
the primary DNS has an NS record that points to the machine running
SunGMAN.

• If you are using SunGMAN as a primary DNS, verify that the client
system's /etc/resolv.conf  file has an entry for a nameserver that lists
the address of the machine running the SunGMAN process.

• For Solaris, verify that the client system is using DNS for hostname
lookups. The /etc/nsswitch.conf  file lists the lookup methods for
network services.

• Check user records to ensure that they are configured to block access from
the client system.

12.4 Service Name Parameters
To allow a TP to write directly to a window, prefix xterm -e  to the TP Path
Executing this command directly from SunGMI fails.

If a TP cannot Open LocalLU, you may have a problem with shared libraries.
Check your library path variable and make sure it matches:

setenv LD_LIBRARY_PATH /opt/SUNWlu62:${PATH}

If not, restart SunGMAN/PU2.1 with LD_LIBRARY_PATH set correctly.

A TP will, by default, go to SunOp Service sunadmin_pu2/LU6.2 Service
sunlu62_serv. These Services are defined in GMI → PU 2.1 Servers → PU
2.1_server → Modify → Service Name Parameters.

The first PU2.1_server has these default Service Name Parameters. A second
PU.21_server will have parameters --a . The TP willneed to specify (by some
sort of call) that it is accessing non-default Service Name Parameters if it wants
to connect to a LocalLU on the 2nd, 3rd, etc., PU2.1_server.
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12.5 Getting Help
Sun is committed to 100% customer satisfaction and provides both a Technical
Support staff and a Professional Services staff.

12.5.1 Technical Support

If you have difficulty installing, configuring, or operating a Sun product,
contact Sun Technical Support.

Before you call, have the following information available:

• Your maintenance ID.
• Your company name and location.
• Time the problem occurred.
• Description of the problem, including whether you can determine the source

of the problem based on its symptoms.
• Any pertinent information related to the problem, such as error messages or

sample output.

To contact Technical Support, call your Service Representative.

Note – Services not covered by your maintenance contract may be billable.
Your Service Representative will tell you whether the service you are
requesting is covered by your maintenance contract or is a billable service.

12.5.2 Professional Services

The Professional Services staff provides the following services:

• Extended training for system/network administrators.
• Step-by-step installation and configuration guidance.
• Customized creation of scripts for automation, integration, and product

enhancement.
• Analysis of network performance.
• Customized setup of the Sun LU6.2 and Sun LU0 features.
• Diagnostics for Sun LU6.2 program failures.

To contact Professional Services, call your Service Representative.
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Resource Planning Forms A

Before you begin designing your network, you should answer the following:

• How many users will need a connection to the network?
• How many LUs are needed?
• How many servers are needed?
• How are users connected to your TCP/IP network today?
• How can you use the features of the Sun PU2.1 SNA Server to maximize

your network availability?

A.1 Platforms Supported
• Sun Solaris Version 2.3 to Version 2.5.1
• Sun Integrated Gateway

A.2 System Requirements
• Disk space: 50 MB
• Memory: The amount of memory required varies depending on the session

count.
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A.3 Communication Devices

A.4 Software Components to be Installed
• SunGMAN - At least one SunGMAN process must be installed in the

network. To avoid a single point of failure, at least one primary and two
secondary SunCMF processes should be configured.

• SunPU21 - The SunPU21 process must be installed on every system that is
physically connected to an IBM data link. The Telnet server is fully
integrated into the SunPU21 process.

• SunGMI - The SunGMI can be installed on any nodes that you want to use
to manage the Sun PU2.1 SNA Server.

A.5 Installation Utilities
• Solaris - Use pkgadd  to install each product. A product may contain

multiple packages. pkgadd  prompts for drivers to be installed.

A.6 Domain Planning Form

Operating
System

Connection Type

Token Ring Ethernet SDLC

Solaris SUN TRI/S SUN Controller ZBX

SBUS

HSI

Domain Name:

Status:

Connections:
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A.7 Remote Systems to Connect to

A.8 Manager Planning Form

A.9 Server Planning Forms

A.9.1 General Information

Host:

Comment:

Name:

CP Name:

Initial Status:

Command Options:

Comment:

Domain Name:



A-4 SunLink SNA 9.1 PU2.1 Server Configuration Guide—August 1997

A

A.9.2 LUType 6.2 Parameters

A.9.3 LLC Parameters

A.10 System Planning Form

A.10.1 General Information

Use Unix Security?

Default User:

Default Group:

Use Source Routing?

Table Size:

Time-out:

Retries:

Time to Live:

Max PDU Size:

LLC Device:

Host:

Comment:

Platform Type:

Initial Status:

Command Options:
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A.10.2 Independent LUs

A.10.3 Dependent LUs
f

A.10.4 Partner LUs

Name:

Comment:

Session Limit:

Allow Partner LU to Queue BIND Rep?

Sync Level SYNCPT Supported?

Name:

Network Qualified Name:

LU Type:

Base LOCADDR:

Number of LUs:

Pacing Window:

Pool Name:

Associated Printer:

Partner LU Name:

Network Qual Name:

Uninterrupted Name:

Local LU:
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A.10.5 Transaction Programs

Session Init Type:

Parallel Sessions Supported?

CNOS Supported?

Session Password:

Minimum Security:

TP Name:

Local LU:

Command Path:

Initial Status:

Security Verification:

Maximum Instances:

Command Path:

Basic Conversations Allowed?

Mapped Conversations
Allowed?

PIP Data Allowed?

Sync None Allowed?

Sync Confirm Allowed?

Sync SYNCPT Allowed?

Pass FMH Data to TP?
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A.10.6 SDLC Lines

CNOS Verbs Allowed?

Session Control Verbs
Allowed?

Display Verbs Allowed?

Service TPs Allowed?

Line Name:

Comment:

Device:

Special Device:

Max Rcv Frame:

Duplex:

Line Type:

Clock Source:

Line Speed:

Poll Pause Timer:

Monitor Carrier Detected?

Use NRZI Encoding?

Physical Link Type:
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A.10.7 LAN Connections

A.11 Pool Resource Form

A.12 Users Resource Form

Line Name:

Comment:

Device:

Interface:

PPA:

Local MAC Address:

Enable Source Routing:

LAN Speed:

Maximum Data Size:

Name:

Comment:

Access Control:

Name:

Full Name:

User ID:

IP Address:

Default Resource:
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A.13 Group Resource Form

A.14 Client Configuration Requirements

Name:

Comment:

Members:

sun3270 LUType 2:

Local Address:

Pool Name:

Access Control:

sun3287 LUType 1 or
LUType 2:

Local Address:

Pool Name:

sun5250 LUType 6.2:

Pool Name:

Session Limit:

Access Control:

sun3770 LUType 1:

Pool Name:

Number of LUs:
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Name Resolution B

This appendix contains the following sections:

• Domain Name System - describes the Domain Name System (DNS).
• Sun Name Server - describes the Sun Name Server.
• Updating the DNS Configuration - describes how to update the DNS

configuration before you use the Sun Name Server.
• Using the Sun Name Server with APPC - describes the considerations to

keep in mind when using the Sun Name Server with SUNWappc.

B.1 Domain Name System
The Domain Name System (DNS) is a distributed database of domain name
servers arranged in a hierarchical structure. DNS is used on the Internet to
advertise and access information about networked hosts and the services they
offer and is used by internetworking software, such as telnet , rlogin , and
ftp .

The following figure illustrates the hierarchical structure of the DNS database.
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Figure B-1 DNS Database

Each node in the tree represents a domain, which can be further partitioned
into other domains, called subdomains. Network hosts (or the information
describing network hosts) are also domains. The fully-qualified name of a
domain is determined by traversing the tree from the leaf to the root. For
example, in Figure B-1, the fully-qualified domain name of the Sun engineering
domain is eng.sun.com . The fully-qualified name of the network host sarah in
the Sun engineering domain is sarah.eng.sun.com .

Each domain is managed by the owning site or organization. The domain
administrator maintains the domain’s name servers with up-to-date
information about the domain, and the name server makes this information
available to the rest of the network. A domain’s database includes the location
and characteristics of the name servers for all its subdomains. Note that for
reliability and access efficiency, a domain would typically have more than one
name server.

Clients in a domain access a local name server to resolve hostnames into
Internet addresses. If the requested name is the name of a host in another
domain, the local name server locates the host by first querying the root name
server. The root name server refers the local name server to the next level
domain by returning the addresses of its name servers.

root

org
com net

sun dec

eng sales

sarah crocodile

edu

berkeley stanford

cs cche
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The local name server then reissues its query to the next-level name server, and
so on. When the requested host is located, the local name server returns the
name and network address of the host to the client. If a name is not fully-
qualified, the local name server expects the name to be (or to be in) one of its
own subdomains.

As a name is resolved, the local name server can temporarily store (cache) the
information it discovers about the name space, speeding up subsequent
queries and reducing the dependence and load on the higher-level name
servers (particularly the root name servers). To prevent name servers from
caching data indefinitely, the resolving name server returns a time-to-live
(TTL) value for the data it returns. The data is purged from the cache when the
TTL expires.

For more information about DNS and domain administration, refer to the
network administration documentation provided with your system or to DNS
and BIND by Paul Albitz and Cricket Liu, published by O’Reilly and
Associates.

B.2 Sun Name Server

Note – Before you can use the Sun Name Server, you must update the DNS
configuration. For more information about how to update the DNS
configuration, refer to Section B.3, “Updating the DNS Configuration,” on
page B-5

Note – You cannot run the Sun Name Server on a system that is running
another DNS. In addition, the Sun Name Server cannot replace another DNS.
Since the Sun Name Server is customized to handle a Sun SNA domain, it
cannot resolve name requests to other domain name servers.

A client connects to the host by specifying the name of the resource it wants to
access (resource selection) or by specifying its user name (user mapping). If the
client adds the name of the Sun subdomain as an extension to the resource or
user name, such as LU010A.sna  or jdaniels.sna , the client instructs the local
DNS to defer the resolution of the name to the Sun Name Server.

Resource selection and user mapping are described as follows:
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• Resource selection - The client specifies the name of the physical unit (PU),
logical unit (LU), or LU pool it wants to access. The Sun Name Server
directs the client to the system that contains the resource.

For example, the following figure illustrates a company, acme, that has built
a gateway and configured a subdomain, sna , to administer the Sun PU2.1
SNA Server name space. The resources include an LU (LU010A) and an LU
pool (TSOPOOL).

Figure B-2 Sun SNA Subdomain

If a client in the acme domain wants to connect to LU010A, the client specifies
the name LU010A.sna . If the client wants to connect to an LU in TSOPOOL,
the client specifies the name TSOPOOL.sna. Note that if a client in the widget

domain specifies the name TSOPOOL.sna, the corp  DNS will fail to resolve
the name request and will refer the request to its parent domain, acme.

• User mapping - The client specifies its user name. The Sun Name Server
maps the user by name to the default resource defined in the user
configuration and directs the client to the system that contains that resource.

User mapping allows users to indicate who they are rather than what
resource they want to access. For example, if a user specifies jdaniels.sna ,
the Sun Name Server maps the user to the configured default resource.

Whether the client uses resource selection or user mapping, the Sun Name
Server resolves the name request, selects a host to service the connection, and
then sends the IP address of the host to the client. When the client receives the
name resolution, the client sends its open request to the resolved address.

root

com

acme

sna corp

widget

sna resources
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When the Sun Name Server receives a name resolution request, it assumes that
the name is an SNA resource (PU, LU, or LU pool) and checks its resource
database for the name. If the name is not an SNA resource, the Sun Name
Server then checks its user database for the name.

If the client requests an LU pool, the Sun Name Server performs load
balancing, returning the addresses of all the systems that contain available LUs
in the requested pool. The Sun Name Server ranks the systems so that the
system with the smallest load, the highest available bandwidth, and, if the
network is configured appropriately, in the most suitable geographical location
is presented first. For more information about load balancing, refer to
Appendix E, “Load Balancing."

Note – The local DNS may reorder the addresses returned by the Sun Name
Server so that addresses on the local subnetwork are presented before
addresses on a remote subnetwork. In addition, since identical requests for a
pooled LU could resolve to different system addresses depending on
prevailing load conditions, the local DNS cannot cache the SNA domain
information. To prevent caching, the Sun Name Server returns a TTL of zero.

B.3 Updating the DNS Configuration
If your environment is already running a DNS, you must modify the DNS
configuration to ensure that the DNS is aware of the subdomain controlled by
the Sun Gateway Manager SunGMAN). (This subdomain is called Sun by
default.) If your environment is not running a DNS, you can use the DNS
contained in the SunGMAN as a primary DNS for the Sun subdomain.

If the SunGMAN installation procedure detects that a DNS is already
configured, the SunGMAN automatically configures itself as a secondary DNS.
The installation procedure also reports any changes that you must make to
your primary DNS to incorporate the Sun subdomain into the DNS
environment.
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▼ To update the DNS configuration:

1. If you are already running a DNS, install the SunGMAN and register it as
a name server in an existing domain database.
For each system that runs the SunGMAN, the installation procedure adds
the following record to the database of the primary server:

sna  IN NS <hostname>

where:

sna is the subdomain representing the SNA resources.

<hostname> is the host running the Sun Name Server.

If you are not running a DNS, go to step 3.

2. Register your Sun SNA domains as subdomains in an existing domain
database. You can add the SNA domains anywhere in your organization’s
or site’s name space.

3. Configure the Sun Name Server by editing the named.boot  file (the Sun
Name Server’s start-up file) and the named.db  file. These files are located
in the working directory.

4. If you are already running a DNS, no further configuration is required.
Your client systems are already set up to resolve names using DNS.
If you are not running a DNS, configure your client systems by editing the
/etc/resolv.conf  or /usr/etc/resolv.conf  file. The resolv.conf file
contains two or three of the following directives:

The domain directive specifies the default or local domain name. Referring
to Figure B-2, the resolv.conf  file on the widget  host would contain the
following domain directive:

domain corp.acme.com

The nameserver directive specifies the IP addresses of the local DNS hosts
and must be used if the local DNS does not run on the local host. For
example, to access the name server on hosts 199.97.127.10 and 199.97.127.20,
the resolv.conf  file would contain the following nameserver directive:
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nameserver 199.97.127.10
nameserver 199.97.127.20

Some domain name servers support a search directive to override the
default order in which domains are searched. Referring to Figure B-2, to
query acme.com before the default domain corp.acme.com , the
resolv.conf  file would contain the following search directive:

search acme.com corp.acme.com

To minimize the impact of introducing DNS, your client systems should, if
possible, be configured to use the Sun Name Server to attempt name resolution
after the usual name resolution schemes have failed.

In small sites, LAN-wide names are resolved by system files, which are copied
among all the machines on the LAN. These files include /etc/hosts ,
/etc/services , and /etc/passwd , which contain the mappings of host names
to IP addresses, the mappings of service names to TCP and UDP port numbers,
and user information, respectively. All systems use the /etc/hosts  file if DNS
fails to resolve a host name.

The most popular alternative to DNS is Sun’s Network Information System
(NIS), which is distributed by most Unix vendors. NIS maintains the system
files in synchronization across the networked systems. The files are
administered on one master system and distributed among the slaves by NIS.
An NIS resolver (implemented as part of the ypserv  program) performs name
mapping.

Depending on your operating system, you can configure systems to resolve
host names using the local /etc/hosts  file, NIS, and/or DNS in one of the
following ways:

• Solaris - Uses a control file, /etc/nsswitch.conf , to specify the order in
which the /etc/hosts  file, NIS, and DNS are queried to resolve names.

Hosts running the Sun Name Server must specify files  before dns  in the
/etc/nsswitch.conf  file. For efficiency, Sun recommends that Solaris client
systems also specify files  before dns  in the /etc/nsswitch.conf  file.

B.4 Using the Sun Name Server with APPC
SUNWappc TPRM programs issue the lu62_open()  call to connect to a server
and local LU. Assuming that the Sun Name Server domain is sna  and the local
LU is LUSP1, the call is issued as follows:
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lu62_open_req_t open_req;
    /* initialize open request to default values */
    memset(0, &open_req, sizeof(struct lu62_open_req));
    /* connect to local LU LUSP1 */
    strcpy(open_req.host, “LUSP1.sna”);
    strcpy(open_req.lu_name, “LUSP1”);
    if (lu62_open(&open_req) == LU62_ERROR) {
        printf("lu62_open error, 0x%x\n", lu62_errno);
        exit(1);
    }

Similarly, SUNWappc CPI-C programs issue the Open_LU()  call to connect to a
server and local LU as follows:

Open_LU(“LUSP1.sna”, “LUSP1”, &retcode);
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SNA Concepts C

This appendix contains the following sections:

• Hierarchical SNA - describes the traditional, host-based hierarchical SNA
(Systems Network Architecture) networks.

• Peer-to-Peer SNA - describes the distributed, peer-to-peer networks that use
Advanced Peer-to-Peer Networking (APPN).

• PU2.1 and PU2 Nodes - describes the differences between PU2.1 and PU2
nodes.

• LEN and APPN - describes the differences between Low Entry Networking
(LEN) and Advanced Peer-to-Peer Networking (APPN).

• APPC and LUType 6.2 - describes how the Advanced Program-to-Program
Communication (APPC) architecture defines the LUType 6.2.

For more information about how devices communicate in SNA networks and
the different products that implement SNA communications protocols, refer to
“Other Related Documents” in the Preface and ask your SNA host system
programmer about your SNA installation.

C.1 Hierarchical SNA
The following sections describe the traditional, host-based hierarchical SNA
network.
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C.1.1 Physical Components

A traditional SNA network is usually organized as a hierarchy of physical
components. IBM hosts reside at the top of the hierarchy. The network routing
nodes (communications controllers) occupy the middle tier of the hierarchy.
The end node devices (cluster controllers) are at the bottom of the hierarchy.
The following figure illustrates the hierarchical relationship of these physical
components in the SNA network. Note that many hosts, communications
controllers, and cluster controllers can be interconnected to form many
interlinked SNA networks.

Figure C-1 Hierarchical SNA Physical Components

The host system contains large applications accessed by users at peripheral
display and printer devices. For example, a System/370 host system can run
such applications as JES2, POWER, IMS, NetView, CICS, and TSO.

The communications controllers are specialized communications devices that
route data between the host and cluster controllers and between networks. An
IBM 3745 is an example of a communications controller.

Mainframe

FEP X.25
PSDNToken Ring

Cluster Controller Cluster ControllerCluster Controller

SDLC
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The cluster controllers control the input and output of attached devices, such
as display stations and printers. A 3174 or 3274 Control Unit is an example of a
cluster controller. The Sun PU2.1 SNA Server emulates a cluster controller with
attached devices.

The cluster controllers connect to the SNA network through a data link
connection to a Physical Unit Type 4 (PU4) device. The physical unit can be an
IBM communications controller, a specially configured cluster controller, or a
host with an integrated communications adapter.

SNA supports the following types of data link connections:

• Telecommunications lines - The cluster controller can be connected to the
communications controller by using telephone lines. The Synchronous Data
Link Control (SDLC) protocol controls the transmission of data across the
data link. The data link can be a switched line (such as a dial-up line) or a
non-switched line (such as a private, dedicated line). The data link can
support many stations (multi-point line) or two stations (point-to-point
line).

• X.25 packet-switched data networks (PSDNs) - The cluster controller and
the communications controller can be connected over X.25 PSDNs by using
X.25 virtual circuits (VCs). The Qualified Logical Link Control (QLLC)
protocol controls the transmission of data across the VC. The
communications controller, through the NCP Packet Switched Interface
(NPSI), provides the X.25 interface. Like SDLC, QLLC supports both
switched and non-switched connections. Switched connections are provided
by X.25 Switched Virtual Circuits (SVCs). Non-switched connections are
provided by X.25 Permanent Virtual Circuits (PVCs). Unlike SDLC, QLLC
supports only point-to-point connections.

• IBM Token Ring local area network - IBM Token Ring networking consists
of two data link control sublayers: Logical Link Control (LLC) and Medium
Access Control (MAC). LLC and MAC (802.5) control the transmission of
data across the local area network. The network can have a data rate of
either 4 million bits per second (4 Mb/s) or 16 Mb/s. The networks can be
interconnected using either repeaters or bridges and source routing.
Multiple cluster controllers, or Downstream Physical Units (DSPUs), can
attach to the IBM Token Ring and communicate with the host either directly
though a communications controller or indirectly through a specially
configured cluster controller (3174 Establishment Controller with the 3270
Gateway feature). Attaching the DSPUs through the communications
controller requires the NCP/Token Ring Interconnection (NTRI).
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• Ethernet local area network - Multiple DSPUs can attach to an Ethernet
local area network and communicate with the host either directly though a
communications controller or indirectly through a 3174 Establishment
Controller. Like IBM Token Ring, Ethernet operates two data link control
sublayers: LLC and MAC (802.3).

C.1.2 Logical Components

The logical components of a hierarchical SNA network are network
addressable units (NAUs). Each NAU has a unique address in an SNA
network. The NAUs are described as follows:

• System Services Control Point (SSCP) - Monitors and controls the entire
SNA network. The SNA Virtual Telecommunications Access Method
(VTAM) implements the SSCP functions. The SSCP activates and deactivates
all the network resources and coordinates the establishment of all sessions
between NAUs.

• Physical Unit (PU) - Provides services to the SSCP to monitor and control
the SNA resources associated with a physical node. Each SNA host,
communications controller, and cluster controller has a PU that manages its
resources.

PU types on SNA hosts and communications controllers are identified by a
subarea number, as defined in the following table.

• Logical Unit (LU) - Entry point through which end users, such as
application programs or terminal users, gain access to the SNA network.
LUs on SNA hosts are typically associated with large applications such as
CICS, TSO, NetView, JES2, and IMS. LUs on cluster controllers send data to
and receive data from the SNA network for terminal users.

Table C-1 Relationships Between PU Types

PU Type Example Description

5 System/370 Host node.

4 3745, 3725 Communications controller
node.

2 3274 Peripheral node.

2.1 AS/400, 3174, Sun
PU2.1 SNA Server

Peer node.
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Dependent LUs require a host-based SSCP to establish sessions and can be
LUType 0, LUType 1, LUType 2, LUType 3, or LUType 6.2.

The following figure illustrates the relationship between the logical
components in a hierarchical SNA network.

Figure C-2 Hierarchical SNA Logical Components

C.1.3 Sessions

Data is transferred between logical components using SNA sessions. A session
provides a logical communications pipe between end users and host
applications. The following table describes the four types of hierarchical SNA
sessions.

Mainframe

FEP X.25
PSDN

Token Ring

Cluster Controller Cluster Controller

LU LU LU LU LU LU

Cluster Controller

LU LU LU
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The Sun PU2.1 SNA Server maintains SSCP-PU sessions and SSCP-LU
sessions. The Sun SNA clients establish LU-LU sessions.

The following is an example of a hierarchical SNA session:

• You enter a log-in request on your terminal for TSO.
• SSCP receives your request on an SSCP-LU session.
• SSCP notifies TSO of your request by using the SSCP-LU session between

SSCP and TSO.
• TSO sends a bind request to your LU. The bind request specifies the session

parameters. TSO is the primary LU (PLU). Your terminal is the secondary
LU (SLU).

• Your terminal accepts the bind to establish an LU-LU session.

C.2 Peer-to-Peer SNA
The following sections describe distributed, peer-to-peer networks.

C.2.1 Physical Components

A peer-to-peer SNA network consists of autonomous nodes linked together
over an SNA transport network. The transport network contains the lower
layers of the SNA protocol stack: Path Control (PC), Data Link Control (DLC),
and the actual physical communications medium. The physical medium can be
telecommunications lines, such as SDLC and X.25, or local area networks, such

Table C-2 SBA Sessions

Type Connected Nodes Function

SSCP-SSCP SNA hosts Coordinates cross-network
session establishment.

SSCP-PU SNA host and node Manages SNA resources
associated with node.

SSCP-LU SNA host and
application

Manages sessions established by
application.

LU-LU Application and
application

Exchanges data between end
users.
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as IBM Token Ring and Ethernet. PU2.1 nodes can interconnect LUType 6.2-
based applications running on the same system. This is known as an intranode
session.

The following figure illustrates the connection of two PU2.1 nodes over an
SNA transport network. Applications on either the AS/400 or the System/36
can communicate either with applications on the other (peer) machine or with
applications resident on the same (local) machine.

Figure C-3 Peer-to-Peer SNA Physical Components

SNA PU2.1 end node devices connect to a peer-to-peer SNA network through
a data link connection to either another PU2.1 device or to a PU4 or PU5
device. Like hierarchical SNA, peer-to-peer SNA supports data link
connections over telecommunications lines using SDLC, over X.25 PSDNs
using QLLC, and over IBM Token Ring or Ethernet local area networks. Over
SDLC and QLLC, a PU2.1 node acts as a primary, secondary, or negotiable link
station. Over IBM Token Ring or Ethernet, a PU2.1 node acts as a negotiable
link station.

Note – Unlike traditional hierarchical SNA, peer-to-peer connectivity does not
require subordinate operation under a host. However, peer-to-peer
connectivity with a host is defined.

C.2.2 Logical Components

Like hierarchical SNA, logical components of a peer-to-peer SNA network are
NAUs. Each NAU has a unique name in an SNA network. The following figure
illustrates the relationship between the logical components of a peer-to-peer
SNA network.

AS/400 SNA transport
network System/36



C-8 SunLink SNA 9.1 PU2.1 Server Configuration Guide—August 1997

C

Figure C-4 Peer-to-Peer SNA Logical Components

The NAUs are described as follows:

• PU2.1 Control Point (CP) - Monitors and controls resources within the
PU2.1 nodes. The CP activates and deactivates all the network resources and
coordinates the establishment of all sessions between NAUs.

Note that the DLC components shown in Figure C-4 on page C-8 are not
NAUs. They emulate PUs when connecting to a host in the hierarchical
manner. Therefore, from the perspective of a traditional host, a Sun PU2.1
SNA Server, through its CP and DLC components, functions as a PU2
device.

• Logical Unit (LU) - Entry port for application and service transaction
programs. The programs can interface directly to end users, or the programs
can be self-contained, facilitating Advanced Program-to-Program
Communication (APPC). For more information about APPC, refer to
Section C.5, “APPC and LUType 6.2,” on page C-11.

Peer PU2.1 nodes can use dependent LUs or independent LUs. Independent
LUs, in conjunction with the PU2.1 CP, can establish sessions and act as
either primary or secondary LUs. Only LUType 6.2 on a PU2.1 node can act
as an independent LU.

Dependent LUs require a host-based SSCP to establish sessions. Dependent
LUs can be LUType 0, LUType 1, LUType 2, LUType 3, or LUType 6.2.

PU2.1
cp

DLC

DLC
SNA transport

network

LU6.2

DLC

DLC

LU6.2
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C.2.3 Sessions

Like data in hierarchical SNA networks, data in peer-to-peer SNA networks is
transferred between logical components using SNA sessions. A session
provides a logical communications pipe between end users and host
applications. The following table describes the two types of peer-to-peer SNA
sessions.

In addition to acting as either primary or secondary LUs, independent LUs
also support parallel sessions between LUs. An independent LU
communicating with another independent LU over multiple, parallel sessions
can be the primary LU on some sessions and the secondary LU on others.

The following is an example of a peer-to-peer SNA session:

• An LUType 6.2 transaction program (TP) requests a conversation with a
remote LU.

• The PU2.1 CP receives the request, assigns an address, and activates links, if
necessary.

• The LU, in conjunction with the PU2.1 CP, establishes a session.
• The LU attaches to a remote TP with information supplied by the local

program.
• LU-LU data is exchanged over the conversation.

CP-CP sessions are used in APPN-based nodes to exchange control
information about directory and topology services. Such functions are used for
remote LU location and route selection. For more information about APPN,
refer to Section C.4, “LEN and APPN,” on page C-10.

Table C-3 PU2.1 Nodes Session Types

Type Connected Nodes Function

LU-LU Applications and
applications

Data transfer.

CP-CP PU2.1 control points Facilitate APPN-based SNA
communication.
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C.3 PU2.1 and PU2 Nodes
PU2.1 is a superset of PU2. Applications that previously depended on PU2 for
SNA support, such as 3270 and 3770, also work with PU2.1. From the
perspective of the host, the only difference is the initial preconnection transmit
and receipt of special information packets known as Exchange Identifier
Format (XID). XID packets convey the identification and characteristics of the
transmitting node before link contact is established. This helps to reduce the
configuration information systems need to connect to one another.

SNA hosts that had in the past been in hierarchical networks now support
peer-to-peer operation with PU2.1 nodes. VTAM and NCP now support the
definition of independent LUs.

The Sun PU2.1 SNA Server can communicate with a host in the traditional
manner, can communicate with a host in the peer manner, and can
communicate with a peer simultaneously over any of the supported link
protocols. This allows 3270 displays, CICS applications, and customized
LUType 6.2 TPs to operate concurrently.

C.4 LEN and APPN
To connect PU2.1 nodes within a peer-to-peer SNA network, you can use Low
Entry Networking (LEN) or Advanced Peer-to-Peer Networking (APPN). A
PU2.1 node can be an end node (EN) or a network node (NN), as follows:

• Network node - Provides connectivity among other NNs and ENs. This
connectivity includes intermediate session routing, adaptive session-level
pacing, transmission priority, directory services, and topology and route
selection. Only APPN supports NNs.

• End node - Can connect with a network node or with another end node.
Both APPN and LEN support ENs. APPN ENs, when connected with NNs,
can receive network connectivity information through a CP-CP session. LEN
ENs, on the other hand, must maintain this information statistically,
although they can still use many of the connectivity services of the NNs. An
example organization of APPN network nodes, with APPN end nodes and
LEN end nodes, is shown in the following figure.
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Figure C-5 Example APPN Network

C.5 APPC and LUType 6.2
The APPC architecture defines the LUType 6.2 and is intended to support
communication between application programs running on any APPC-based
nodes in an SNA network. This enables distributed processing, in which two or
more TPs running on different systems cooperate to perform a task. The
following figure summarizes the LUType 6.2 model.

APPN
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LEN
EN

LEN
EN

NN NN

NN NN APPN
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Figure C-6 LUType 6.2 Model

C.5.1 Transaction Programs

A TP accesses the SNA network through its local LUType 6.2. The LUType 6.2
makes resources, including sessions, available to the TP, and operates the
session protocols. A key feature of the LUType 6.2 is that it can invoke a local
TP when it receives an allocation (or Attach) request from a remote TP.

TPs, LUType 6.2s, and sessions are described from the perspective of the local
node. Therefore, the local TP connects to its local LUType 6.2, which in turn is
in session with its partner (or remote) LUType 6.2. The remote TP is located at
the partner LU.

LU6.2 LU6.2

TP
TP

TP
TP

Basic Conversation Protocol Boundary

Mapped Conversation Protocol Boundary

Basic Conversation

Mapped Conversation
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C.5.2 Conversations and Verbs

TPs always communicate in pairs. A logical connection called a conversation is
established between the two TPs. Conversations make temporary use of
sessions set up between the TPs' respective LUs. Programs communicate on
conversations using the verbs defined on the conversation protocol boundary
between the TP and its local LUType 6.2. Mapped and basic conversation types
are supported.

A conversation is initiated by the invoking TP, which issues an Attach verb.
The local LUType 6.2 attaches a session (provided one is available or can be
activated) to the conversation and issues an Attach request on the session. The
partner LUType 6.2 receives the Attach request, and provided the request is
valid, invokes the remote TP.

You can specify the following parameters for a conversation:

• The conversation type(s) supported by the TP: mapped and/or basic.
• The sync level(s) supported by the TP: none and/or confirm (and in special

circumstances, sync point).
• The security required on the Attach request to run the TP.
• The process command line to start the TP, if required. If a TP is not already

waiting to accept the Attach request, the server will, if a command line is
configured, auto-start the TP. Otherwise, the TP must be started manually.

• An Attach time-out period to wait for the TP to accept the Attach request. If
the TP does not accept the Attach within this period, the server detaches the
conversation (TP_NOT_AVAILABLE).

C.5.3 Sessions and Modes

Sessions are the logical connections maintained between NAUs. LUType 6.2
sessions are attached to one conversation at a time. Since establishing and
removing LUType 6.2 sessions involve significant processing, a session is
usually left up when a conversation terminates so that the session can be made
available to the next conversation.

The characteristics of a session between a local LUType 6.2 and a remote
LUType 6.2 (or LU-LU pair) are specified with a mode. The mode defines
various communications and usage parameters, including the following:

• The preferred size of the Request/Response Units (RUs) to be exchanged by
the two LUType 6.2s.
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• Whether parallel sessions are supported between the LUType 6.2s. Parallel
sessions allow the LU-LU pair to support more than one active session of the
same mode at the same time. Parallel sessions allow optimal use of the LU-LU
pair, enabling multiple transactions of the same type to proceed concurrently.

An installation normally designates some of the defined sessions as auto-
activated sessions. These sessions are automatically activated whenever the
local LUType 6.2 is started or reset. This establishes a free pool of sessions,
avoiding the session activation overhead whenever a conversation requests
a session.

• The maximum number of active sessions of the mode that can exist between
the two LUType 6.2s. If this number is greater than 1, parallel sessions must
be supported.

• The polarity of the sessions. The session polarity determines which LUType
6.2 wins if both LUs simultaneously attempt to activate a particular session.

When the session is a contention winner (or first speaker), the local LU
always wins when there is contention. When the session is a contention
loser (or bidder), the partner LU always wins and the contention-loser
LUType 6.2 bids the contention-winner LUType 6.2 to use the session. The
mode defines the minimum number of contention-winner sessions and
contention-loser sessions available. Session limits and session polarities can
be changed using Change Number of Sessions (CNOS) verbs.

C.5.4 Independent or Dependent LUType 6.2s

An LUType 6.2 can be independent or dependent. An independent LUType 6.2
can communicate directly with a peer system over multiple parallel sessions. A
dependent LUType 6.2 is owned by a local PU type 2 (and has a configured
LOCADDR) and requires the support of a host (SSCP) to establish a single
session with a remote LUType 6.2.
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This appendix contains the following sections:

• Overview - provides an overview of the IBM Token Ring network.
• Frame Formats - describes the frame formats used to transmit information on

a IBM Token Ring network.
• Source Routing and Multiple-Ring Operation - describes how to

interconnect multiple rings using Token Ring bridges.

D.1 Overview
The IBM Token Ring is a Local Area Network (LAN) based on a token passing
access method. This token passing access method consists of a special frame,
called a token, that continuously circles the network medium, known as the
ring. A station that needs to communicate with another station must obtain the
token, change it from free to busy, append any applicable data, and transmit
the information. The receiving station recognizes that the frame is being
directed toward it by addressing information embedded in the data, and the
receiving station copies the data into its internal buffers and then releases the
frame back to the ring. When the station that initially sent the data receives the
frame that it transmitted, it examines any frame status information that was set
by the second station, removes the data from the ring, and releases a free
token. The next station on the ring then has the opportunity to transmit data, if
necessary, or pass the free token to the next station. This procedure continues
indefinitely.
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A Token Ring operation does not have the frame collision problem that exists
in Carrier Sense Multiple Access with Collision Detect (CSMA/CD) networks
such as Ethernet or Institute of Electrical and Electronics Engineers (IEEE)
Standard 802.3. The frame collision problem results from two or more stations
attempting to transmit to the network simultaneously. Because only one station
has access to the token at any given point in time, a Token Ring network
exhibits more deterministic operation.

Note that more than one station can have data on the ring at the same time
(newer versions of the IBM Token Ring network allow multiple frames to be
present on the ring at the same time). However, access to the free token is still
mutually exclusive. In addition, safeguards on an IBM Token Ring network
ensure that data frames do not circle the ring indefinitely and that all stations
on the network are uniquely addressable.

Many of functions and features of the IBM Token Ring network are
implemented as part of the network interface, or Token Ring adapter, chipset.
This chipset is the hardware responsible for interfacing to the Token Ring. Its
functions and features help to maintain the integrity and ensure smooth
operation of the IBM Token Ring network and are described as follows:

• The Active Monitor performs duties such as token monitoring and ring
clocking. These duties include removing frames that circle the ring
indefinitely and lowering the priority of a free token if the station that
released the token fails to do so.

• The Standby Monitor acts as a backup in the event of a failure of the Active
Monitor.

• The Ring Error Monitor (REM) collects various types of errors that occur on
the Token Ring. These errors include hard errors, which may indicate ring
and station failures, or soft errors, which do not affect the overall integrity
of the network.

• The Ring Parameter Server (RPS) provides initialization values to stations
that insert into the Token Ring.

• The Configuration Report Server (CRS) can be used with higher-level LAN
management functions to request status information from stations on the
Token Ring.

For more details on the capabilities of the Token Ring adapter chipset and the
functions provided by the various servers, refer to the appropriate
documentation.
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The IBM Token Ring is a compatible superset of the standard established by
the IEEE standards board and the American National Standards Institute
(ANSI) standard for a ring utilizing token passing as the access method: IEEE
Standard 802.5-1989. Data rates for the IBM Token Ring are 4 million bits per
second (4 Mb/s) and 16 Mb/s. Logic to improve throughput, known as early
token release, is covered by the latest version of the standard.

D.2 Frame Formats
The IBM Token Ring has two basic formats, or frames, for transmitted
information. These formats are shown in the following figure.

Figure D-1 IBM Token Ring Frame Format

The first format, known as the token format, consists of the following three
bytes of data and represents the free token:

• Starting delimiter (SD) byte.
• Access Control (AC) byte, which is used to differentiate between a free

token and a data frame.
• Ending delimiter (ED) byte.

The second format, known as the frame format, is used to transmit network
management and user information and consists of the following:

• Starting delimiter (SD) byte.
• Access Control (AC) byte, which is used to differentiate between a free

token and a data frame.
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• Frame Control (FC), which is used to identify the type of underlying
information.

• Destination Address (DA), which is used to identify the intended recipients
of the frame.

• Source Address (SA), which is used to identify the sender.
• Routing Information (RI), which is used to optionally include source route

paths.
• Information (INFO), which is used to include the actual data that is being

transmitted over the token ring network.
• Frame Check Sequence (FCS), which is used to include a Cyclic Redundancy

Check (CRC) for detecting transmission errors.
• Ending delimiter (ED) byte.
• Frame Status (FS), which is used to designate the actions performed on the

frame by the remote stations to which it was addressed.

The types of frame data information identified by the Frame Control are
described as follows:

• Medium Access Control - MAC is a sublayer to the Data Link Control
(DLC). It is used for lower layer communications activities in various data
communications and network architecture models, such as the Open
Systems Interconnect (OSI) reference model from the International
Standards Organization (ISO), SNA from IBM, and TCP/IP.

• Logical Link Control - LLC is a sublayer of the DLC. It defines frame
formats and protocols for the transmission of connectionless (Type 1) or
connection-oriented (Type 2) services. Information is transmitted within
LLC Protocol Data Unit (PDU) frames. LLC is described in IEEE Standard
802.2/ISO 8802-2.

LLC frame information is of more value to users of Sun's IBM Token Ring
network connectivity products because LLC frames carry SNA data. The
LLC frame format is shown in the following figure.

Figure D-2 LLC Frame Format

LLC frames consist of the following:
• Destination Service Access Point (DSAP).
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• Source Service Access Point (SSAP).
• One or two bytes of control information.
• Zero or more bytes of data information.

The SAPs are used as logical ports, or addresses, from the higher-level
communication and network models, such as OSI, SNA, and TCP/IP, into
the LLC sublayer. Communications between two entities on an IBM Token
Ring network is between addressable MAC/LLC entities. The addressing
for these entities is discussed in the next section.

D.2.1 Addressing

The following sections describe addressing of MAC and LLC entities.

D.2.1.1 MAC Entities

The IEEE Standard 802.5 provides two address formats for Token Ring
networks: 16-bit (2-byte) and 48-bit (6-byte). All nodes on a network must use
the same addressing scheme. Most networks use the 6-byte format, as shown
in the following figure.

Figure D-3 MAC Address Format

The following types of addresses are used with the IBM Token Ring network:

• Ring station address - Used to uniquely identify stations on the Token Ring.
A value of 0 in bit 0 of byte 0 indicates that a ring station address is present
in the frame. A value of 1 in bit 0 of byte 0 indicates either that the address is
a group address or that source routing information is present in the frame.
Note that when the ring station address is a source address, the group
address indicator bit is no longer relevant for group address identification
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purposes, since frames can only be sent from individual ring stations. For
more information about source routing, refer to Section D.3, “Source Routing
and Multiple-Ring Operation,” on page D-7.

Bit 1 of byte 0 indicates whether the address is being managed by the
network administrator or local management entity (locally administered) or
whether the addressing scheme is defaulting to the values assigned by the
IEEE and guaranteed to be unique (globally administered). Globally
administered addresses ensure that all the addresses for ring stations on the
network are unique. Locally administered addresses are useful when
various network management facilities are in use. For example, an office
number could be embedded in a station address so that the particular device
could be physically located given only its MAC address.

• Group addresses - Occur only in the Destination Address of the Frame
Format and are used to identify multiple stations on the Token Ring. Frames
with default group addresses of X'C000FFFFFFFF'  and X'FFFFFFFFFFFF'

(known as broadcast addresses) are received by all stations on a Token Ring.
You can define additional group addresses, if desired.

• Functional addresses - Special types of group addresses that are identified
by bytes 0 and 1 of the Destination Address being set to X'C000' , bit 0 of
byte 2 being set to 0, and one or more of the remaining 31 bits in bytes 2
through 5 being set as necessary. Each of these remaining 31 bits represents
network management functions, such as RPS and REM, and other optional
features, such as Token Ring bridges.

Sun's IBM Token Ring network connectivity products allow you to set the
Destination Address, Source Address, Group Address, and Functional
Address. The control of the Functional Address is included only for future use
and upward compatibility. When not used, the Functional Address recognition
feature is disabled. All Sun Token Ring network connectivity products
represent MAC addresses in hexadecimal format, such as X'40001A67F527' .

D.2.1.2 LLC Entities

LLC addresses are represented by SAPs and are one byte in length. The format
is shown in the following figure.
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Figure D-4 LLC Address Format

Each LLC PDU consists of one destination SAP and one source SAP. Bits 0
through 5 consist of the actual address bits. Bit 6 identifies whether the SAP
address is user-defined (set to 0) or defined by the IEEE (set to 1). Bit 7
identifies whether the SAP is an individual SAP (set to 0) or a group SAP (set
to 1).

Like group MAC addresses, group SAP addresses must occur in the DSAP of
the LLC frame format. Bit 7 in the SSAP field distinguishes an LLC command
from an LLC response. Since this is controlled internally, you must specify a
value of 0 for bit 7 when specifying a local SAP.

Sun Token Ring products allow you to set DSAPs, SSAPs, and group SAPs
with which the local SAP is associated. The value of X'FF'  is the default group
SAP for the local SAP and its value cannot be disabled. The value of X'00' ,
called the Null SAP, is used for ring station identification purposes and must
not be used in configuration definitions. Many products have default SAP
values. For example, Internetwork Protocol (IP) uses a default SAP value of
X'AA' , SNA uses a default SAP value of X'04'  and a group SAP value of
X'05' , and ISO uses a default SAP value of X'FE' .

D.3 Source Routing and Multiple-Ring Operation
Rather than have all stations on an IBM Token Ring network located on the
same physical ring, the IBM Token Ring architecture allows for interconnection
of multiple rings using Token Ring bridges. A Token Ring bridge is a specially
configured ring station that is connected to two physical Token Ring networks.
A ring station that has a frame to transmit decides whether to transmit the
frame on the local (or source) ring or to all rings. The decision to execute a
multiple-ring transmission depends on the higher-level protocols that exist on
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the ring station. To have a multiple-ring transmission occur, the originating
ring station inserts source routing information into the frame. The presence of
source routing information is indicated by bit 0 of byte 0 of the MAC source
address being set to 1. The source routing format is shown in the following
figure.

Figure D-5 Source Routing Format

The first two bytes of a source route are the routing control field. This field
identifies the type of route used, the total length of the source routing
information, the direction of the route with respect to the originating station,
and the largest frame size that can travel over the route.

Following the routing control field are zero to eight optional 2-byte segment
number fields. The segment number fields consist of a ring number identifier
and a bridge number identifier. Each ring in a multiple-ring network must be
uniquely numbered, and individual bridges between the same two rings must
be individually numbered. Bridges that connect different rings can have the
same number. However, Sun recommends that bridge numbers are also
unique.

The following types of source routes are used in an IBM Token Ring network:

• Nonbroadcast - Used when a route is known to a ring station on a remote
Token Ring network. The originating station transmits the frame with the
nonbroadcast source route attached. The Token Ring bridge, depending on
how it is configured, optionally transmits the frame on its second ring.
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Configuration issues that determine whether to transmit to the second ring
include internal bridge congestion, matching ring and bridge numbers, and
largest frame passable by the bridge.

• All-routes broadcast - Used when the path to the destination ring station is
not known. A bridge receiving an all-routes broadcast frame appends
segment field information depending on whether or not that exact segment
already occurs in the route. Therefore, multiple copies of the original frame,
each with different source routing information, may arrive at the destination
ring station and may also occur more than once on the same ring. The
originating station must be prepared to receive multiple responses (usually
nonbroadcast) and then select the optimum route, depending on such
parameters as frame sizes allowable by bridges, total number of bridges that
must be crossed (number of hops), and response time.

• Single-route broadcast - Used when the path to the destination ring station
is not known. Single-route broadcast packets are forwarded only by
specially configured bridges that have single-route broadcast active. Bridges
not configured with the single-route broadcast feature do not forward the
frame.

Single-route broadcast bridges communicate with one another and make use
of the spanning tree protocol to represent and continuously update the
topology of the network. The result is that the transmitted frame only occurs
once for each ring and the destination ring station only receives one copy of
the frame. The destination can respond to the originating station by using a
nonbroadcast frame containing the routing information of the frame that it
just received, or it can choose an all-routes broadcast to respond.

All of the bridges discard a frame when the hop count is exceeded. This
prevents prolonged packet forwarding and reduces the total number of
packets generated in an all-routes broadcast scenario.

Sun's IBM Token Ring network connectivity products use all-routes broadcasts
in source routing for route discovery. This increases the probability of
contacting the destination ring station if no intermediate bridge with single
route feature is active on the network. In addition, route selection is based on
response time, hop count, and maximum allowable frame size of intermediate
bridges. Sun products use sharable, cached source-routing tables so that
multiple products do not have to engage in redundant route discovery
attempts. Before the search for a ring station is sent to multiple rings, Sun
products check the local ring. This reduces the amount of network traffic and
provides compatibility with those ring stations that do not support source
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routing. Finally, Sun products can be run without source routing. All values,
including source routing, ring station discovery attempts, and maximum frame
size, are user-configurable.



E-1

Load Balancing E

This appendix contains the following sections:

• Overview - provides a brief description of load balancing.
• Normal Load Balancing - describes normal load balancing and provides an

example.
• Geographical Load Balancing - describes geographical load balancing and

provides an example.

E.1 Overview
If a traditional TN3270, extended TN3270E, or sun3270 client requests a
connection to a pool of logical units (LUs) that spans multiple hardware
platforms, the Sun PU2.1 SNA Server performs load balancing to ensure that
the client is connected to the best possible LU. Load balancing considers
available LUs, system load, and the highest bandwidth SNA data link type
available in determining the selection of an LU. If the LUs are geographically
dispersed, the server can use geographical load balancing to ensure that an LU
is selected from the most suitable geographical location.

The differences between normal load balancing and geographical load
balancing are described in the following sections.

E.2 Normal Load Balancing
The following sections provide a description of normal load balancing and a
normal load balancing example.
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E.2.1 Normal Load Balancing Description

Normal load balancing is simpler to configure and implement than
geographical load balancing and is useful if all clients are in the same
geographical location. However, it requires that each client knows the name of
the resource it wants to connect to or that a unique user record has been
defined for each client. In addition, if the LUs are geographically dispersed, a
client may connect to an LU at a remote location.

An extended TN3270E or sun3270 client can specify both a hostname/port ID
pair and the name of the a resource or user record for connection parameters.
If the client specifies a user record, the server checks the preferred default
resource for available LUs. If none are available, the server sequentially checks
the alternate default resources until it finds an available LU.

A traditional TN3270 client can specify only a hostname/port ID pair for
connection parameters. The server looks for a user record with either an IP
Address parameter or IP Hostname parameter that matches the IP address or
IP hostname of the client. The server checks the preferred default resource
specified in the user record for available LUs. If none are available, the server
sequentially checks the alternate default resources until it finds an available
LU.

E.2.2 Normal Load Balancing Example

The example described in this section assumes that each desktop is configured
so that all TN3270E client connections use the following connection
parameters:

• Hostname: foo.sna.sun.com

• Connection Resource: foo

The user record specifies the following:

• Name: foo

• Default Resource: POOL-1 PUBLIC

Refer to the following figure as you follow the procedure.
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Figure E-1 Normal Load Balancing

1. The client requests a connection to the domain, using the name of the user
record (foo ) as the resource name (foo ). The connection request is
handled by the DNS and sent to SunGMAN for name resolution.
A sample connection request is as follows:

suntn3270x -h foo.sna.sun.com -l foo

Sun PU2.1
SNA Server

SunGMAN

DNS Client
1

2

3 4

5

SunSMAN SunPU2.1
6

7
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2. SunGMAN looks for the user record with the name foo  and if it finds
one, considers the first (preferred) default resource in the list of default
resources (POOL-1). If POOL-1 is distributed across multiple systems and
more than one system has an available active LU, SunGMAN selects the
system with the lowest system load average and the highest bandwidth.
If an active LU is not available in POOL-1, SunGMAN considers the next
(alternate) default resource in the list (PUBLIC). If PUBLIC is distributed
across multiple systems and more than one system has an available active
LU, SunGMAN selects the system with the lowest system load average and
the highest bandwidth.

If no active LUs are found in either POOL-1 or PUBLIC, SunGMAN returns to
POOL-1 and searches both POOL-1 and PUBLIC again, this time allowing
inactive LUs to satisfy the request.

If the second pass is unsuccessful, SunGMAN selects the “least recently
used” system for the preferred resource.

3. SunGMAN returns the IP address of the system with the best LU for the
connection to DNS.

4. DNS returns the IP address of the system to the requesting client.

5. The client connects to the TCP port of the SunSMAN process on the
system with the IP address returned by SunGMAN.

6. The SunSMAN looks for a user record with the user name foo  to
determine which LU to connect the client to. If multiple Sun PU2.1 server
processes (sunPU21) are available, the SunSMAN performs load
balancing based on the number of connections on each PU2.1 server and
the bandwidths of the connections. The SunSMAN process then passes
this connection to the PU2.1 server that has the selected LU configured.

7. The client is now connected to the IBM host using the selected LU.

E.3 Geographical Load Balancing
The following sections provide a description of geographical load balancing
and a geographical load balancing example.
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E.3.1 Geographical Load Balancing Description

Geographical load balancing is useful if your LUs are geographically dispersed
or if you want all clients to connect to a resource using the same name.
Geographical load balancing is more difficult to implement, requiring a
detailed knowledge of the TCP/IP infrastructure relevant to IP addressing,
netmasking, and hostnames. However, it eliminates the need for individual
user-by-user configuration and reduces the communications costs and effort
required to manage the network.

To use geographical load balancing, you must create a user record for each
geographical location and specify one or more default resources and either an
IP address or an IP hostname. For each user record, specify the LU pool at or
closest to that geographical location first in the list of default resources. For
more information about configuring user records, refer to Chapter 10,
“Configuring Users."

You must also implement at least one secondary Domain Name System (DNS)
in each geographical location and configure each desktop to point to the
secondary DNS. This maps the incoming IP address or hostname of the name
resolution request received from the secondary DNS to the list of default
resources. For more information, refer to DNS or desktop-specific
documentation.

If you want all clients to connect to a resource using the same name, the client
connection request must contain the geographical load balancing keyword. The
presence of this keyword instructs the SunGMAN to perform geographical
load balancing when handling this connection request. When you install the
SunGMAN, the software enables geographical load balancing, using the
keyword glb  by default. If you want to change the keyword, you must include
-g keyword  on the command line to the SunGMAN, where keyword is the user-
defined keyword.

Note – Depending on the variety of IP addresses in a particular geographical
location, you may have to configure multiple user records to provide access for
all desktops.
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Note – If you are configuring printer connections and TN3270 connections
from the same desktop, you cannot use the geographical load balancing
keyword. This is because the incoming IP address used for looking up the user
record is the same for both. In this case, either use normal load balancing or
use RFC1646/RFC1647 standards for associated printers.

E.3.2 Geographical Load Balancing Example

The procedure described in this section assumes that site 1 located in Los
Angeles and site 2 is located in New York. POOL-1 is a pool of LUs located at
site 1. POOL-2 is a pool of LUs located at site 2.

The default geographical load balancing keyword glb  is used so that all clients
can connect to a resource using the same name. At least one secondary DNS
has been implemented in each location and each desktop has been configured
to point to the secondary DNS.

All TN3270E client connections use the following connection parameters:

• Hostname: glb.sna.sun.com

• Connection Resource: Not required

Each site has a user record associated with it. The user records for site 1 and
site 2 specify the following:

Note – Instead of specifying the Client Address Type as IP ADDRESS, you can
specify the Client Address Type as IP HOSTNAME. In this case, you specify
the IP Hostname parameter instead of the IP Address and Mask parameters.

Table E-1 User Records

Parameter Site 1 Site 2

Name SITE1 SITE2

Default Resources POOL-1 POOL-2 POOL-2 POOL-1

Client Address Type IP ADDRESS IP ADDRESS

IP Address 200.9.220.0 200.9.230.0

Mask (optional) 255.255.255.0 255.255.255.0
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Refer to Figure E-1 on page E-3 as you follow the procedure.

1. A client requests a connection to the domain, using the geographical load
balancing keyword (glb ). The connection request is handled by DNS and
sent to SunGMAN for name resolution.
A sample connection request is as follows:

suntn3270x -h glb.sna.sun.com

2. SunGMAN looks for a user record with either an IP Address parameter or
an IP Hostname parameter that matches the IP address of the system that
sent the connection request. Note that the connection request is sent to the
SunGMAN by the DNS, not by the client.
If the SunGMAN finds a matching user record, it considers the first
(preferred) default resource in the list of default resources. Because each site
has its own secondary DNS, SunGMAN finds user record SITE1  for clients
at site 1 and user record SITE2  for clients at site 2. Therefore, for clients at
site 1, the preferred resource is POOL-1 and for clients at site 2, the preferred
resource is POOL-2. In both cases, the preferred resource contains LUs that
are geographically closest to the client.

If the preferred LU pool is distributed across multiple systems and more
than one system has an available LU, SunGMAN selects the system with the
lowest system load average and the highest bandwidth.

If an LU is not available in the preferred LU pool, SunGMAN considers the
next (alternate) default resource in the list (POOL-2 for clients at site 1 and
POOL-1 for clients at site 2). If the alternate LU pool is distributed across
multiple systems and more than one system has an available LU,
SunGMAN selects the system with the lowest system load average and the
highest bandwidth.

If no active LUs are found in either LU pool, SunGMAN returns to the
preferred LU pool and searches both LU pools again, this time allowing
inactive LUs to satisfy the request.

If the second pass is unsuccessful, SunGMAN selects the “least recently
used” system for the preferred resource.

3. SunGMAN returns the IP address of the system with the best LU for the
connection to DNS.

4. DNS returns the IP address of the system that has the best LU for this
connection to the requesting client.
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5. The client connects to the TCP port of the SunSMAN process on the
system with the IP address returned by SunGMAN.

6. The SunSMAN looks for a user record with either an IP Address that
matches the client’s incoming IP address or an IP Hostname that matches
the client’s incoming IP hostname to determine which LU to connect the
client to. If multiple Sun PU2.1 server processes (sunPU21) are available,
the SunSMAN performs load balancing based on the number of
connections on each server and the bandwidths of the connections. The
SunSMAN process then passes this connection to the Sun PU2.1 server
process (sunPU21) that has the selected LU configured.

7. The client is now connected to the IBM host using the selected LU.



F-1

Host Configurations F

This appendix describes how to coordinate host configurations for the
following clients:

• 3270 clients
• sun3770/RJE clients
• APPC clients
• 5250 clients

F.1 3270 Clients
The following table lists the Sun PU2.1 SNA Server configuration parameters
specific to 3270 clients that you must coordinate with the host configuration. If
you change any of these parameters in one configuration, you must make the
corresponding changes in the other configuration.

Table F-1 PU2.1 SNA Server 3270 Configuration Parameters

Sun
Resource

Resource
Parameter Host Object

Host
Parameter

LU Local Address LU LOCADDR

Type LU
LOGMODE

DLOGMOD
PSERVIC
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The NCP/VTAM gen lists all the SNA resources connected to an SNA
communications controller. The LU macro defines the characteristics of the
3270 client attached to the corresponding LU port on the Sun PU2.1 SNA
Server.

The LU type is determined by parameters that are transferred on the SNA bind
message during session establishment.

The following sample configuration shows the LU definitions for three 3270
display clients and one 3287 printer.

**************************************************
*
* LU MACROS
*
**************************************************
BLU01102 LU LOCADDR=2,DLOGMOD=D4A32782
BLU01103 LU LOCADDR=3,DLOGMOD=D4A32782
BLU01104 LU LOCADDR=4,DLOGMOD=D4A32782

PLU01180 LU LOCADDR=X'80',DLOGMOD=DCS2K

In addition, the VTAM log-on mode (LOGMODE) tables require entries describing
the operating characteristics of logical units. The association between the LU
and its LOGMODE entry is created in the LU macro of the VTAM/NCP gen or in
the definition of a superior resource: group, line, or physical unit (PU).

A LOGMODE entry defines session and presentation values that are included in
the session activation request (BIND) sent by the SNA host application to the
3270 client. The LOGMODE entry values specify the expected screen size, display
formatting characteristics, maximum message sizes, and session protocol
definitions.

The following example is a LOGMODE entry suitable for a sun3270 client:

LOG32782 MODEENT LOGMODE=LOG32782,
FMPROF=X'03',
TSPROF=X'03',
PRIPROT=X'B1',
SECPROT=X'90',
COMPROT=X'3080',
RUSIZES=X'85C7',
PSNDPAC=0,
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SRCVPAC=0,
SSNDPAC=0,
PSERVIC=X'028000000000185000007E00'

Note – To execute file transfers with a 3270 client, the first two bytes of the
PSERVIC parameter must be 0280 . The 02  defines the LU as an LUType 2 and
the 80  indicates that structured queries are supported.

The following example is a LOGMODE entry for an LUType 1 printer client:

L32872K MODEENT LOGMODE=L32872K,
FMPROF=X'03',
TSPROF=X'03',
PRIPROT=X'B1',
SECPROT=X'90',
COMPROT=X'3080',
RUSIZES=X'8787',
PSNDPAC=0,
SRCVPAC=0,
SSNDPAC=0,
PSERVIC=X'010000000000185018507F00'

The following example is an LUType 3 printer LOGMODE definition:

DSC2K MODEENT LOGMODE=DSC2K,
FMPROF=X'03',
TSPROF=X'03',
PRIPROT=X'B1',
SECPROT=X'90',
COMPROT=X'3080',
RUSIZES=X'8787',
PSNDPAC=0,
SRCVPAC=0,
SSNDPAC=0,
PSERVIC=X'030000000000185018507F00'

For some IBM applications (such as CICS), you must add entries to
application-specific tables that define terminals and printers allowed to access
the application and the types of operations permitted. Refer to the appropriate
application reference manual to prepare the host generation.
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F.2 sun3770/RJE Clients
The following table lists the Sun PU2.1 SNA Server configuration parameters
specific to sun3770/RJE clients that you must coordinate with the host
configuration. If you change any of these parameters in one configuration, you
must make the corresponding changes in the other configuration.

The NCP/VTAM gen lists all the SNA resources connected to an SNA
communications controller. The LU macro defines the characteristics of the
sun3770/RJE client attached to the corresponding LU port on the Sun PU2.1
SNA Server.

The LU type is determined by parameters that are transferred on the SNA bind
message during session establishment.

The following sample configuration shows the LU definitions for six
sun3770/RJE data streams.

**************************************************
*
* LU MACROS
*
**************************************************
BLU01101 LU LOCADDR=1,DLOGMOD=BATCH
BLU01102 LU LOCADDR=2,DLOGMOD=BATCH
BLU01103 LU LOCADDR=3,DLOGMOD=BATCH
BLU01104 LU LOCADDR=4,DLOGMOD=BATCH
BLU01105 LU LOCADDR=5,DLOGMOD=BATCH
BLU01106 LU LOCADDR=6,DLOGMOD=BATCH

In addition, the VTAM log-on mode (LOGMODE) tables require entries describing
the operating characteristics of logical units. The association between the LU
and its LOGMODE entry is created in the LU macro of the VTAM/NCP gen or in
the definition of a superior resource: group, line, or PU.

Table F-2 PU2.1 SNA Server 3770/RJE Configuration Parameters

Sun
Resource

Resource
Parameter Host Object

Host
Parameter

LU Local Address LU LOCADDR

Type LU
LOGMODE

DLOGMOD
PSERVIC
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A LOGMODE entry defines session and presentation values that are included in
the session activation request (BIND) sent by the SNA host application to the
sun3770/RJE client. The LOGMODE entry values specify the expected screen size,
display formatting characteristics, maximum message sizes, and session
protocol definitions.

The following example is a LOGMODE entry suitable for the sun3770 client:

BATCH MODEENT LOGMODE=BATCH,
FMPROF=X'03',
TSPROF=X'03',
PRIPROT=X'A3',
SECPROT=X'A1',
COMPROT=X'7080',
RUSIZES=X'8686',
PSNDPAC=4,
SRCVPAC=2,
SSNDPAC=4,
PSERVIC=X'01102000F100800000010040'

You must also set up the JES2 application definitions to include information
about the remote devices associated with the sun3770 product. The following
example defines the line on which JES2 communicates with all SNA devices
and a 3770 workstation (RMT1) that can be used by the sun3770 product. For
the sun3770 workstation, seven card readers (R1.RD1-R1.RD7), four printers
(R1.PR1-R1.PR4), and three card punches (R1.PU1-R1.PU3) are defined.

LINE1 UNIT=SNA
RMT1 LUTYPE1,COMP.CONSOLE,SETUPINF,BUFSIZE=512,

NUMRD=7,NUMPR=4,NUMPU=3
R1.RD1
R1.RD2
R1.RD3
R1.RD4
R1.RD5
R1.RD6
R1.RD7
R1.PR1 CKPTLINE=32767,CDPTPAGE=32767,PRWIDTH=132
R1.PR2 CKPTLINE=32767,CDPTPAGE=32767,PRWIDTH=132
R1.PR3 CKPTLINE=32767,CDPTPAGE=32767,PRWIDTH=132
R1.PR4 CKPTLINE=32767,CDPTPAGE=32767,PRWIDTH=132
R1.PU1 CKPTLINE=32767,CDPTPAGE=32767
R1.PU2 CKPTLINE=32767,CDPTPAGE=32767
R1.PU3 CKPTLINE=32767,CDPTPAGE=32767
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Note – The connection between the JES2 devices and the LUs is made at run
time when the sun3770 client connects to JES2. For more information, refer to
the sun3770/RJE Configuration and User Manual.

F.3 APPC Clients
The Sun PU2.1 SNA Server configuration specifies the operating characteristics
of the local SNA resources with respect to LUType 6.2. An LUType 6.2
application programmer is particularly concerned with local LUs, partner LUs,
session modes, and transaction programs. Consult with the SNA host system
programmer to determine specific values for your configuration.

The following sections describe how the APPC configuration is defined on
VTAM, CICS, and AS/400.

F.3.1 Logical Unit

The LU configuration directive defines an LUType 6.2 entry point from the
local node to the SNA network. When connecting to an SNA host, such as
VTAM or CICS, you can specify both dependent and independent LUs. A
dependent LU requires SSCP assistance in establishing a session and must act
as a secondary, single-session LU. An independent LU requires no SSCP
intervention and can be a primary LU supporting parallel sessions.
Independent LUs, normally used for connecting with peer systems, such as an
AS/400 or a PC running APPC/PC, can also be connected directly to an IBM
host. From the perspective of the LUType 6.2 programmer, only the name of
the LU is relevant, since the other aspects are controlled by the configuration.

F.3.1.1 VTAM

The Sun LU configuration is matched against the VTAM LU when connecting
with an IBM host. For a dependent LU, the local address is specified as
LOCADDR=n, where n is a nonzero value representing the local address.

A dependent LU must be associated with a specific DLC in the Sun
configuration. You can define a network-qualified name or a fully-qualified
name with the Network Qual Name parameter as [ NETID.] NODEID, where
NETID is an optional network identifier and NODEID is a node identifier.
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Note – When connecting to a host as a dependent LU, set the uninterpreted LU
name, UI_LU_NAME, to the host-configured value to ensure proper SSCP
translation.

Independent LUs connecting to a host are not associated with a specific local
address and must be specified as LOCADDR=0.

Independent LUs have no corresponding PU. Instead, independent LUs are, by
default, associated with the local Control Point (CP). Both the CP and the LU
have network-qualified names. The network ID prefix must be identical for
both the CP and the LU and must match the network ID prefix defined for the
network. The host can also connect to the Sun PU2.1 SNA Server as a peer and
use independent LUs. In this case, the PU definition in VTAM must include the
following:

PUTYPE=2
XID=YES

F.3.1.2 CICS

When connecting with CICS for local LU definition, make sure that you
examine the following aspects of the connection definition:

CONNECTION IDENTIFIERS
NETNAME
INDSYS

REMOTE ATTRIBUTES
REMOTESYSTEM
REMOTENAME

CONNECTION PROPERTIES
ACCESSMETHOD VTAM
PROTOCOL APPC
DATASTREAM USER
RECORDFORMAT U

For defining the terminal control table, DFHTCT, with respect to the local LU
definition, the following parameters are relevant:
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TRMTYPE=LUTYPE62
SYSIDNT=idname
NETNAME=netname

F.3.1.3 AS/400

When connecting to an AS/400 for local LU definition, verify the following
parameters for the line description, controller description, and device
description:

CRTCLTAPPC
RMTCPNAME=remote-control-point-name
RMTNETID=remote-network-identifier
AUT=authorization-list-name

F.3.2 Partner LU

The partner LU configuration defines LUType 6.2s on remote systems that are
accessible to a locally-defined LUType 6.2. Each remote LUType 6.2 has a name
that is locally known. Use of such locally-known LU names allows network
reconfiguration to be transparent to the LUType 6.2 programmer. The partner
LU can reside on either a host or a peer node. The following sections describe
the differences in defining partner LUs on each of the node types.

F.3.2.1 VTAM

Partner LUs for local dependent LUs must be primary, single-session LUs.
Partner LUs for independent LUs can be either primary or secondary LUs and
support parallel sessions. VTAM defines resources that are viewed as remote
LUs by the Sun PU2.1 SNA Server with the APPC resource definition directive.
The following parameters are of particular interest:

APPC
PARSESS =YES (for independent LUs)

=NO (for dependent LUs)
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F.3.2.2 CICS

When connecting with CICS for partner LU definition, make sure that you
examine the following aspects of the connection definition:

CONNECTION PROPERTIES
SINGLESESS

SECURITY
BINDPASSWORD

For defining the terminal control table, DFHTCT, with respect to the partner LU
definition, the following parameters are relevant:

FEATURE =SINGLE
=PARALLEL

BINDPWD=xxxxxxxxxxxxxxxx

BINDPWD is the password used for encryption and decryption of random data
on both the bind and its associated response. This field is matched against the
Session Password parameter in the partner LU configuration.

F.3.2.3 AS/400

When connecting to an AS/400 for partner LU definition, verify the following
parameters for the line description, controller description, and device
descriptions:

CRTDEVAPPC
LCLLOCNAME=local-location-name
SNGSSN=number-of-conversations
LOCPWD=location-password
SECURELOC=YES|NO
AUT=authorization-list-name
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F.3.3 Session Mode

The MODE configuration directive defines the characteristics of sessions
between logical units. The mode, along with the partner LU and the
transaction program name, is specified on the various types of Attach requests.
The mode name must be common to both the local LU and the partner LU.

F.3.3.1 VTAM

Mode entries are defined using the MODEENT macro instruction. The following
parameters are of particular interest:

FMPROF=X'13'
TSPROF=X'07'
SSNDPAC=n
SRCVPAC=n
RUSIZES=n

F.3.3.2 CICS

When connecting with CICS for mode definition, make sure that you examine
the following aspects of the session definition:

OBJECT CHARACTERISTICS
SESSION_IDENTIFIERS

MODENAME
SENDSIZE
RECEIVESIZE

For defining the terminal control table, DFHTCT, with respect to the mode
definition, the following parameters are relevant:

MODENAME=mode-name
FEATURE=features
RUSIZE=n
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F.3.3.3 AS/400

When connecting to an AS/400 for mode definition, verify the following
parameters for the line description, controller description, and device
descriptions:

CRTDEVAPPC
MODE=mode-name

MODE DESCRIPTION
MODD=mode-name
COS=class-of-service-name
MAXSSN=maximum-sessions
MAXCNV=maximum-conversations
LCLCTLSSN=locally-controlled-sessions
PREESTSSN=pre-established-sessions
INPACING=inbound-pacing-value
OUTPACING=outbound-pacing-value
MAXLENRU=maximum-length-of-request-unit

F.3.4 Transaction Program

The TP configuration defines transaction programs to which incoming Attach
requests are directed. Access to TPs can be restricted depending on both LU
access security and TP resource access security. For more information on
security issues for APPC, refer to Appendix G, “LUType 6.2 Security." Note
that TPs on remote systems are not configured to the local system. The
selection of the remote TPs is made by the LUType 6.2 program itself.
Therefore, the LUType 6.2 programmer should know how TPs are defined on
the remote system:

CICS transaction programs are defined in the processing program table,
DFHPPT, and the program control table, DFHPCT. The following example defines
a CICS program, PRG1, that supports two transactions, TR100 and TR101. These
TRANSIDnames correspond to the remote_tp_name  parameter to lu62_Attach

(8.1) or lu62_mc_Attach  (9.1) verbs.

***************************************************

** PPT: define PRG1 **

***************************************************
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DFHPPT TYPE=ENTRY,
PROGRAM=PRG1,
PGMLANG=ASSEMBLER,

***************************************************

** PCT: define PRG1 transactions **

***************************************************

DFHPCT TYPE=ENTRY,
TRANSID=TR100,
PROGRAM=PRG1,
DTB=(NO),

DFHPCT TYPE=ENTRY,
TRANSID=TR101,
PROGRAM=PRG1,
DTB=(NO),

F.4 5250 Clients
The following sections describe how to coordinate the AS/400 communications
configuration for IBM Token Ring and SDLC connections.

F.4.1 IBM Token Ring

The following table lists the Sun PU2.1 SNA Server configuration parameters
that you must coordinate with the AS/400 configuration. If you change any of
these parameters in one configuration, you must make the corresponding
changes in the other configuration.
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Sun recommends that you configure the AS/400 Token Ring line to
automatically create controllers (LIN(TRLAN) AUTOCRTCTL=YES). In this case,
the APPC controller, CTL(APPC) , is created automatically when the PU2.1
server is started and the configuration task is simplified.

If the AS/400 Token Ring line is configured to automatically create controllers,
you must establish values for the following parameters only:

• The AS/400's remote network identifier (RMTNETID), which is the network
name (or NETID) field of the network-qualified CP and LU names.

• The AS/400's default local location name (LCLLOCNAME), which corresponds
to the partner LU name. Use the AS/400 display network attributes
(DSPNETA) command to determine this value. Make sure that you use the
default local location name value.

• The AS/400's local adapter address (ADPTADR), which corresponds to the
remote MAC address. This value is established when the AS/400 Token
Ring line description is created using the CRTLINTRN command.

• The mode name, which must be common in both configurations. If installed,
the PC Support/400 installation creates the mode description, QPCSUPP.

Table F-3 PU2.1 SNA Server AS/400 Configuration Parameters

Sun Resource Resource Parameter AS/400 Object AS/400 Parameter

PU2.1 server CP Name CTL(APPC) Remote network
identifier
Remote control point

LAN
connection

Type
LAN Speed
Local MAC Address

LIN(TRLAN)

CTL(APPC)

Connection type
Line speed
Remote adapter
address

DLC Remote MAC Address
Role

LIN(TRLAN)
CTL(APPC)

Local adapter
address
Data link role

Partner LU Network Qual Name CTL(APPC)
LCLLOCNAME

Remote network
identifier
Default local location
name

Session mode Mode Name MODE Mode description
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If the AS/400 is not configured to automatically create controllers (LIN(TRLAN)

AUTOCRTCTL=NO), use the remote control point name on the AS/400 controller
description as the PU2.1 server CP name.

F.4.2 SDLC Connection

The following table lists the Sun PU2.1 SNA Server configuration parameters
that you must coordinate with the AS/400 configuration. If you change any of
these parameters in one configuration, you must make the corresponding
changes in the other configuration.

You must establish values for the following parameters:

• The AS/400’s remote control point name on the AS/400 controller
description.

• The AS/400’s remote network identifier (RMTNETID), which is the network
name (or NETID) field of the network-qualified CP and LU names.

• The AS/400's default local location name (LCLLOCNAME), which corresponds
to the partner LU name. Use the AS/400 display network attributes
(DSPNETA) command to determine this value. Make sure that you use the
default local location name value.

Table F-4 PU2.1 SNA Server SLDC Connection Configuration Parameters

Sun Resource Resource Parameter AS/400 Object AS/400 Parameter

PU2.1 server CP Name CTL(APPC) Remote network
identifier
Remote control point

SDLC
connection

Line Type
Use NRZI encoding?
Line Speed
Duplex

LIN(SDLC) Connection type
NRZI data encoding
Line speed
Duplex

DLC Station Address
Role

CTL(APPC) Station address
Data link role

Partner LU Network Qual Name CTL(APPC)
LCLLOCNAME

Remote network
identifier
Default local
location name

Session mode Mode Name MODE Mode description
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• The mode name, which must be common in both configurations. If installed,
the PC Support/400 installation creates the mode description, QPCSUPP.
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LUType 6.2 Security G

This appendix contains the following sections:

• Session-Level Security - describes session-level security for peer-to-peer
operations.

• Conversation-Level Security - describes conversation-level security for
peer-to-peer operations.

• Security Access Verification - describes how to specify minimum security
requirements for peer-to-peer operations.

• Resource Access Verification - describes how to use the TP resource access
list to verify resource access for peer-to-peer operations.

• Unix-Level Security - describes Unix-level security for peer-to-peer
operations.

G.1 Session-Level Security
Before any TP security access, a session must be established between the
communicating LUs. Session verification between two LUs occurs during bind
processing using LU-LU passwords. If session-level security is used for bind
verification, both LUs must have the operation enabled.

For more information about session-level security, refer to LU6.2 architectural
specifications.
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G.2 Conversation-Level Security
Conversation-level security occurs after a session has been established between
two LUs. Whether the two LUs have used LU-LU verification during session
establishment is not important for conversation-level security. Conversation-
level security occurs when an allocation request is received by the partner LU.
An allocation request is generated when a program issues an (MC_) Attach verb
or a CPI-C Attach (CMALLC) call. The request is transmitted as an SNA Request
Unit (RU) containing a Function Management Header Type 5 (FMH-5), also
known as an Attach. Allocation requests can also occur as a result of an explicit
or implicit Change Number of Session (CNOS) request.

The Attach structure can contain the following access security information:

• User ID
• Password
• Profile
• Already Verified indicator

Already Verified indicates that the identity of the user has previously been
verified by the local LU. Since the partner LU trusts the local LU, no password
is sent.

The use of the user ID, password, and profile for conversation-level security
and Unix-level security is shown in the following figure.
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Figure G-1 Security Access Parameters
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G.3 Security Access Verification
If the Attach contains security information and it is determined that the LU has
a security restriction, parameters in the Attach are matched again those in the
LU security list.

You specify the minimum security required for LU-LU sessions in the partner
LU definition, as follows:

• None - An Attach is rejected if any security parameters are present.
• Conversation - Any request containing security, but not an Already Verified

indicator, is verified against the LU security list. The Attach is verified if an
entry in the security list matches all the security fields in the Attach.
Otherwise, the request is rejected.

• Already Verified - The Attach is checked for both Conversation and Already
Verified and is not checked for a password.

If no security parameters are defined for an LU (no security parameters are
contained in the Attach and the partner LU expects no security), the Attach is
passed to resource verification. Otherwise, the Attach is rejected.

G.4 Resource Access Verification
If you want to further control access to the TP, you can perform resource access
verification against the TP resource access list after security access. Each TP has
one resource access list.

The following levels of access security are supported:

• None - No verification is required. However, if security parameters are
received, conversation-level checks are performed.

• Conversation - Conversation-level checks are performed. Resource access
verification is not performed.

• User ID - The user ID must exist in the TP resource access list.
• Profile - The profile must exist in the TP resource access list.
• User ID and profile - Both the user ID and profile must exist in the TP

resource access list.
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G.5 Unix-Level Security
By default, Unix-level security controls only how processes are invoked from
remote systems to the local system. The Sun PU2.1 SNA Server provides
additional Unix-level security by not allowing user processes to be invoked as
root. Whenever the server invokes a user process, the server sets the user ID of
the process to the Default User name specified for the PU2.1 server. For
information, refer to Section 5.1, “Basic PU2.1 Server Configuration,” on
page 5-2.

Unlike other system files, which are automatically modified during
installation, the /etc/passwd  file (or any associated NIS password database
file) is not modified for security reasons. Therefore, you must manually add
the user ID specified for the PU2.1 server (either the default name sunlu62  or
any other name you specify) to the /etc/passwd  file. If you try to invoke a TP
through an Attach request and the /etc/passwd  file has not been updated, the
Attach request is rejected and the session is brought down with a security
violation sense code.

You can also specify a group ID for the PU2.1 server. If you do, you must
manually add the group ID to the /etc/passwd  file.

If the Sun PU2.1 SNA Server is configured to use full Unix-level security, you
can map the user ID, password, and profile from the Attach request to Unix
system parameters. The Attach parameters are checked against the
/etc/passwd  and /etc/group  files as the final check.
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Index

Numerics
3270 Help Screen Display Key

parameter, 11-14
3270, see Sun3270, TN3270, TN3270E
3770, see Sun3770
5250, see Sun5250, TN5250

A
A, 1-3
Accept Incoming Calls? parameter, 6-9
Access Control parameter

dependent LU, 8-5
independent LU, 9-3
LU pool, 8-10

Access list, see Access Control, TP
resource access list

Access to resources, controlling, 11-2
Ack Count parameter, 7-9
Action on File Full parameter, 12-29
Activating an off-line configuration, 11-

16
Active configuration, modifying, 11-12
ACTPU, requesting, 7-7
Advanced dialog box, 2-16
Advanced Peer-to-Peer Networking, see

APPN

Advanced Program-to-Program
Communications, see APPC

AFTP server, enabling, 4-5
AID key, 12-30

specifying, 11-14
Allow Partner LU to Queue BIND Rsp?

parameter, 9-4
APPC (Advanced Program-to-Program

Communications)
architecture, C-11
see also SunAPPC

APPC File Transfer Protocol, 4-5
Applications window, 2-6
APPN (Advanced Peer-to-Peer

Networking), C-10
Associated Printer parameter, 8-6
Auditing Enabled? parameter, 11-14
Auto-init Session Limits? parameter, 9-11
Automatic connect? parameter, 7-7

B
Base LOCADDR parameter, 8-4
Basic Conv Allowed? parameter, 9-16
Basic dialog box, 2-16
Buttons

in toolbar, 2-11
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C
Carrier Detect signal, 6-7
Cascading windows, 2-10
Channel connections, 1-10
Client access to resources, 11-2
Client Address Type parameter, 10-2
Client area (main window), 2-4
Clients, 1-14

see also Sun3270, Sun3770, Sun5250,
SunAPPC, SunNMI,
SunSNM, FTP, TN3270,
TN3270E, TN5250, Users

Clock Source parameter, 6-7
Closed User Group parameter, 6-10
Closing a window, 2-10
CNOS processing, specifying, 9-11
CNOS Supported? parameter, 9-7
CNOS Verbs? parameter, 9-17
Column Width parameter, 12-4
Command options

parameter for PU2.1 server, 5-4
parameter for system, 4-3
SunSCOPE, 12-19
xterm command, 12-20

Command Path parameter, 9-14
Comment parameter

configuration, 11-14
independent LU, 9-3
LAN connection, 6-2
LU pool, 8-10
manager, 11-9
PU, 7-3
PU2.1 server, 5-2
QLLC connection, 6-8
SDLC connection, 6-5
system, 4-2
user group, 10-8

Common problems, 12-32
Configuration

creating off-line, 11-14
displaying information, 12-2
modifying, 11-12, 11-15
options, 1-5

tasks, 3-2
window, 2-5

Configuration Name parameter, 11-14
Connect Timeout parameter, 6-11
Connection Type parameter, 6-8
Connections, channel, 1-10
Connections, LAN, 1-8, 1-9

configuring, 6-1
Connections, QLLC, 1-9, 1-10

configuring, 6-7
Connections, SDLC, 1-8, 1-10

configuring, 6-4
Contention loser, specifying, 9-10
Contention winner, specifying, 9-10, 9-11
Control menu, 2-14
Control point, specifying, 5-2, 7-6, 7-7
Controlling resources
Conversations, specifying, 9-16, 9-17
CP Name parameter, 5-2
Create Configuration dialog box, 11-14
Create Dependent LU dialog box, 8-2
Create DLC dialog box, 7-1
Create Group dialog box, 10-7
Create LAN Connection dialog box, 6-1
Create License dialog box, 11-7
Create LU6.2 User dialog box, 9-12
Create Manager dialog box, 11-9
Create Mode dialog box, 9-8
Create Partner LU dialog box, 9-5
Create Pool dialog box, 8-9
Create PU2.1 Server dialog box, 5-1
Create QLLC Line dialog box, 6-7
Create SDLC Line dialog box, 6-5
Create System dialog box, 4-1
Create TP Access Control dialog box, 9-18
Create Trace dialog box, 12-27
Create Transaction Program dialog box, 9-

13
Create User dialog box, 10-1
CUG, see Closed User Group
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D
Data Link Control, see PUs
Data size, specifying for LAN

connections, 6-4
Default Group parameter, 5-3
Default resource, 1-12

parameter (user), 10-2
Default User parameter, 5-3
Definition Verbs? parameter, 9-17
Dependent LUs, 1-10, 1-12

configuring, 8-2
deleting, 8-9
modifying, 8-8
names, generated automatically, 8-3

Device parameter
LAN connection, 6-2
line trace, 12-18
SDLC connection, 6-5

Diagnostic tools, 12-1
Dialog boxes, 2-16
Display

customizing, 12-2
selecting type, 12-2

Display Verbs? parameter, 9-17
DLC Name parameter

PU, 7-3
session mode, 9-9

DLC, see PUs
DNS (Domain Name System), B-1

updating configuration, B-5
Domain Name parameter, 2-3
Domain Name System, see DNS
Duplex parameter, 6-6
Duration parameter, 12-29

E
Edit menu, 2-13
Enable AFTP Server? parameter, 4-5
Enable TCP/IP Keepalive parameter

dependent LU, 8-6
user, 10-5

Error handling, 12-32
Ethernet, 1-8, 1-9

see also LAN connections
Event log, 12-16
Events window, 2-7
Expiry Date parameter, 11-7
Extended TN3270E, see TN3270E

F
FDDI, 1-8, 1-9

see also LAN connections
Feature parameter, 11-7
File menu, 2-13
File transfer protocol, see FTP
FMH data, specifying, 9-17
Frame size

MAC, specifying, 6-4
specifying for PU, 7-7

FTP (File transfer protocol), 1-18
Full duplex, specifying, 6-6
Full Name parameter, 10-2
Fully-qualified name, specifying, 9-4, 9-6
Functional Address parameter, 6-4

G
Gateway Manager, see SunGMAN
Geographical load balancing, see Load

balancing
GMAN, see SunGMAN
GMI, see SunGMI
Graphical Management Interface, see

SunGMI
Group Address parameter, 6-4
Group LSAP for PU parameter, 7-5
Group of users, configuring, 10-7

H
Half duplex, specifying, 6-6
HDLC Line parameter, 6-9
Heading parameter, 12-4
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Help menu, 2-16
Help, getting, 12-38
Highest Max Receive RU Size

parameter, 9-9
Highest Max Send RU Size parameter, 9-

10
Highlighting items, 2-10
Host address, specifying, 10-4
Host configurations, coordinating with

clients, xxi, F-1
Host DTE Address parameter, 6-9
Host parameter

line trace, 12-18
manager, 11-9
system, 4-2

Hostname, specifying, 10-4

I
IBM Token Ring, see Token Ring
Idle time-out period, specifying, 8-7, 8-8
Inactivity Timeout parameter, 7-8
Independent LUs, 1-10, 1-12

configuring, 9-2
Index parameter, 11-7
Information table

customizing, 12-2
selecting type, 12-2

Initial status, 11-17
parameter for PU2.1 server, 5-4
parameter for system, 4-3
parameter for TP, 9-15

Initiating actions, 2-10
In-Session Idle Timeout parameter

dependent LU, 8-7
user, 10-6

Installation options, 1-5
Interface parameter, 6-3
Invoking actions, 2-10
IP Address parameter, 10-4
IP Host parameter (QLLC connections), 6-

11
IP Hostname parameter (user), 10-4

K
Keep-alive option, enabling, 8-6, 10-5
Key parameter, 11-7

L
LAN connections, 1-8, 1-9

configuring, 6-1
LAN Speed parameter, 6-4
Leased lines, specifying, 6-6
LEN (Low Entry Networking), C-10
Licenses

adding, 11-7
deleting, 11-8

Limited Resource Link? parameter, 7-7
Limited Resource Timeout parameter, 9-

11
Line Name parameter

LAN connection, 6-2
QLLC connection, 6-8
SDLC connection, 6-5

Line Speed parameter, 6-7
Line trace, 12-16
Line Type parameter, 6-6
Lines, see Connections
LLC Device parameter, 5-6
Load balancing
Local area network, see LAN connections
Local CP Name parameter, 7-6
Local DTE Address parameter, 6-10
Local LSAP for PU parameter, 7-5
Local LU parameter

LUType 6.2 user, 9-13
partner LU, 9-5
TP, 9-14

Local MAC Address parameter, 6-3
Local Terminal ID parameter, 7-5
Logging data

line trace, 12-16
PU2.1 server trace, 12-27

Logical units, see Dependent LUs,
Independent LUs
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Loss of quorum, 11-10
Low Entry Networking, see LEN
Lowest Max Receive RU Size

parameter, 9-9
Lowest Max Send RU Size parameter, 9-

10
LU information screen, 11-14, 12-30
LU pools, 1-11, 1-13

configuring, 8-9
modifying, 8-11
specifying, 8-5

LU Type parameter, 8-4
LU6.2 Service parameter, 5-5
LUs (logical units), see Dependent LUs,

Independent LUs
LUType 6.2, C-11

configuring users, 9-12
coordinating host configurations, F-6
security, 1-21, G-1

M
MAC address

parameter for user, 10-4
specifying for LAN connection, 6-3
specifying for PU, 7-3

MAC frame size, specifying, 6-4
Main window, 2-3
Management Information Base, see MIB
Manager network, 1-19, 11-8
Manager systems, 1-19, 11-8

adding, 11-9
Managers window, 2-6
Mapped Conv Allowed? parameter, 9-17
Mask parameter, 10-4
Master operator, 1-13, 11-5
Max Connects parameter, 6-11
Max Data parameter (PU), 7-7
Max Disk Usage by Audit parameter, 11-

14
Max Instances parameter, 9-16
Max Rcv Frame parameter, 6-6

Maximizing a window, 2-9
Maximum Data Size parameter (LAN

connections), 6-4
Maximum Retries parameter, 7-8
Maximum Sessions parameter, 9-11
May Alloc Service TPs? parameter, 9-17
Medium Access Control, see MAC
Members parameter, 10-8
Menu

bar, 2-4
commands, 2-12
Control, 2-14
Edit, 2-13
File, 2-13
Help, 2-16
Options, 2-15
Window, 2-15

MIB Variables parameter, 12-4
Min Contention Losers parameter, 9-10
Min Contention Winners parameter, 9-10
Minimizing a window, 2-9
Minimum Security parameter, 9-7
Mode Name parameter

session mode, 9-8
system, 4-5

Mode, see Session mode
Modulus parameter, 7-8
Monitor Carrier Detect? parameter, 6-7
Multi-point lines, 6-6

N
Name parameter

dependent LU, 8-3
independent LU, 9-3
LU pool, 8-10
partner LU, 9-5
PU2.1 server, 5-2
user, 10-2
user group, 10-8

Name server, see Sun Name Server, DNS
NCP parameters, coordinating with

clients, xxi, F-1
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Network administrators, see Operator
Network Number parameter, 10-4
Network Qual Name parameter

independent LU, 9-4
partner LU, 9-6

Network User ID parameter, 6-10
No Session Idle Timeout parameter

dependent LU, 8-8
user, 10-7

Node address, specifying, 10-4
Node name, specifying, 10-4
NRZI encoding, 6-7
Number of Licenses parameter, 11-7
Number of LUs parameter, 8-5

O
Off-line configuration

creating, 11-14
modifying, 11-15

Operating systems supported, A-1
Operator

master, 1-13, 11-5
restricted, 11-5

Options menu, 2-15
Output File parameter, 12-28
Output Log File parameter, 12-18

P
Pacing window size, specifying, 9-10
Packet Size parameter, 6-10
Parallel Sessions Supported?

parameter, 9-7
Partner LU

configuring, 9-4
parameter for system, 4-5

Pass FMH Data to TP? parameter, 9-17
Password parameter

connecting to domain, 2-3
LUType 6.2 user, 9-12
user, 10-4

P-Bit Timeout parameter, 7-8

Peer-to-peer operations, 1-21
see also APPC

Permanent virtual circuit, specifying, 6-8
Physical Link Type parameter, 6-7
Physical units, see PUs
PIP Data Allowed? parameter, 9-17
Platforms

specifying, 4-2
supported, A-1

Point-to-point lines, 6-6
Poll Interval parameter, 12-3
Poll Manager for Updates? parameter, 12-

3
Poll Pause Timer parameter, 6-7
Pool Name parameter, 8-5
Pools, see LU pools
PPA parameter, 6-4
Preferred Max Receive RU Size

parameter, 9-10
Preferred Max Send RU Size parameter, 9-

10
Preferred Primary? parameter, 11-9
Primary manager system, 1-20

specifying, 11-9
Privileges parameter, 10-5
Problems, 12-32
Professional services, 12-38
Profile List parameter

LUType 6.2 user, 9-13
TP resource access control list, 9-18

PU2.1 Keepalive Retries parameter
dependent LU, 8-7
user, 10-6

PU2.1 Keepalive Timer parameter
dependent LU, 8-7
user, 10-6

PU2.1 server process, 1-4
PU2.1 server trace, 12-27
PU2.1 servers, 1-7

configuring, 5-1
PUs (physical units), 1-9, 1-13

configuring, 7-1
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specifying name, 9-9
PVC Logical Channel No parameter, 6-9

Q
QLLC connections, 1-9, 1-10

configuring, 6-7
Qualified Logical Link Control, see QLLC

connections
Quorum rule, 1-20, 11-10

R
Receive Pacing Window Size

parameter, 9-10
Receive Window parameter, 7-8
Records Per File parameter, 12-29
Recovering from loss of quorum, 11-10
Redundancy, 1-11, 1-19
Refreshing a table, 12-3
Remote CP Name parameter, 7-7
Remote Job Entry, see Sun3770
Remote LSAP parameter, 7-5
Remote MAC Address parameter, 7-3
Remote Terminal ID parameter, 7-6
Reply Timeout parameter, 7-8
Request Reverse Charge parameter, 6-10
Request Size Negotiation, 6-10
Requirements, A-1
Resource

default, 1-12
displaying information about, 12-2
selection, B-4
starting/stopping, 11-17
table, 2-9
tree, 2-9
window, 2-8
see also Systems, PU2.1 servers,

Connections, PUs,
Dependent LUs,
Independent LUs

Resource access list, see TP resource access
list

Resources parameter, 12-28
Response Count parameter, 7-8
Response Time Monitor, see RTM
Response Timer parameter, 7-8
Restoring

manager network, 11-10
window, 2-10

Restricted operators, 11-5
Retries parameter, 5-5
Reverse charging, specifying, 6-10
RJE, see Sun3770
Role parameter, 7-9
RPOA List parameter, 6-10
RTM (Response Time Monitor)

information, 12-14
displaying, 12-2

RU size, specifying, 9-9, 9-10

S
SAP, specifying, 7-5
Saving changes to active

configuration, 11-13
Scope utility, 12-16
SDLC connections, 1-8, 1-10

configuring, 6-4
Security Verification parameter, 9-15
Security, LUType 6.2, 1-21, G-1
Select Format parameter, 12-3
Select Table parameter, 12-3
Selecting items, 2-10
Send Pacing Window Size parameter, 9-

10
Send Window (Size) parameter, 7-8
Server parameter, 12-28
Server trace, 12-27
Service Access Point, see SAP
Session Control Verbs? parameter, 9-17
Session Init Type parameter, 9-7
Session Limit parameter, 9-4
Session mode

configuring, 9-8
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specifying, 4-5
Session Password parameter, 9-7
Session Restarted parameter, 9-11
Sessions to Auto Start parameter, 9-11
Size Negotiation, 6-10
SMAN, see SunSMAN
SNA

hierarchical, C-1
peer-to-peer, C-6

Software components, 1-3
installing, 1-5
PU2.1 server process, 1-4
Sun Name Server, 1-4, B-3
SunGMAN, 1-3
SunGMI, 1-3
SunSMAN, 1-3

Source routing, specifying, 5-5
Specify Activation Time dialog box, 11-16
Speed

specifying for SDLC connections, 6-7
specifying for Token Ring, 6-4

Start Line Trace dialog box, 12-17
Start Time parameter, 12-29
Starting

actions, 2-10
resources, 11-17

Station Address parameter, 7-9
Status information, 12-4

displaying, 12-2
Status line (main window), 2-4
Stopping resources, 11-17
Sub-window, 2-5
Sun 3270, see Sun3270
Sun 3770, see Sun3770
Sun 5250, see Sun5250
Sun Gateway Manager, see SunGMAN
Sun Graphical Management Interface, see

SunGMI
Sun Name Server, 1-4, B-3

using with APPC, B-7
Sun PU2.1 server process, see PU2.1 server

process

Sun System Manager, see SunSMAN
Sun3270, 1-16

coordinating host configurations, F-1
Sun3770, 1-16

coordinating host configurations, F-4
Sun5250, 1-18

coordinating host configurations, F-
12

SunAPPC, 1-17
coordinating host configurations, F-6
using with Sun Name Server, B-7

SunGMAN, 1-3
starting, 3-3

SunGMI, 1-3
starting, 2-1, 3-4

SunLU0, 1-19
SunLU6.2, 1-21
SunNMI, 1-19
SunOp Service parameter, 5-4
SunPU21, see PU2.1 server process
SunSCOPE, 12-16
Sunscope Options parameter, 12-19
SunSMAN, 1-3
SunSNM, 1-19
SunAPPC

see also APPC
Suppress ACTPU? parameter, 7-7
Switched lines, specifying, 6-6
Switched virtual circuit, specifying, 6-8
Sync Confirm Allowed? parameter, 9-16
Sync Level SYNCPT Supported?

parameter, 9-4
Sync None Allowed? parameter, 9-16
Sync SYNCPT Allowed? parameter, 9-16
Synchronous Data Link Control, see SDLC

connections
System administrators, see Operator
System Manager, see SunSMAN
System parameter, 12-28
Systems, 1-7

configuring, 4-1
Systems Network Architecture
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see SNA

T
Table

customizing, 12-2
displaying, 12-2
RTM information, 12-14
selecting type, 12-2
status information, 12-4

Table Formats dialog box, 12-2
Table Size parameter, 5-5
Technical support, 12-38
Terminal ID, specifying, 7-5, 7-6
Terminal Type parameter, 8-6
Tiling windows, 2-10
Time To Live parameter, 5-6
Timeout parameter, 5-5
Timing Mark, specifying, 10-5
TN3270, 1-14

coordinating host configurations, F-1
TN3270E, 1-15

coordinating host configurations, F-1
TN5250, 1-18

coordinating host configurations, F-
12

Token Ring, 1-8, 1-9, D-1
network concepts, B-1, C-1, D-1, E-1,

F-1, G-1
see also LAN connections

Toolbar, 2-4
buttons, 2-11

TP (transaction program), configuring, 9-
13

TP Name parameter, 9-14
TP resource access list, configuring, 9-18
Trace Type parameter, 12-28
Traces window, 2-7
Traditional TN3270, see TN3270
Transaction program, see TP
Transfer Mode parameter, 7-9
Troubleshooting, 12-1

TWA, specifying, 7-9
Two-way alternating/simultaneous,

specifying, 7-9
TWS, specifying, 7-9
Type parameter

LAN connection, 6-2
system, 4-2

U
Uninterpreted Name parameter, 9-6
Unique Session Name parameter, 9-9
Updating the manager network, 11-10
Use NRZI Encoding? parameter, 6-7
Use Source Routing? parameter, 5-5
Use Telnet Timing Mark? parameter, 10-5
Use UNIX Security? parameter, 5-2
User ID parameter, 10-4
User mapping, B-4
UserName parameter

connecting to domain, 2-3
LUType 6.2 user, 9-12
TP resource access control list, 9-18

Users/user groups
configuring, 10-1, 10-7
deleting, 10-9
deleting access to a dependent

LU, 10-10
deleting user from group, 10-9
LUType 6.2, 9-12
modifying, 10-8

V
Verbs

CNOS, 9-17
display, 9-17
session control, 9-17

Version parameter, 11-7
Virtual circuit, specifying, 6-8
VTAM parameters, coordinating with

clients, xxi, F-1
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W
Window

Applications, 2-6
cascading, 2-10
closing, 2-10
configuration, 2-5
Events, 2-7
main, 2-3
Managers, 2-6
maximizing, 2-9
menu, 2-15
minimizing, 2-9
resource, 2-8
restoring, 2-10
tiling, 2-10
Traces, 2-7

Window Increment parameter, 7-9
Window Size parameter, 6-10
Working Directory parameter, 12-18

X
X.25 PSDN address, specifying, 6-9, 6-10
Xterm Command parameter, 12-20


