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Preface
Thank you for using PointBase Console, a Graphical User Interface (GUI) tool designed to 
help administer your PointBase Relational Database Management System (RDBMS). The 
PointBase Console allows you to perform SQL operations without typing the SQL commands 
or statements at a command line. The PointBase Console is an alternative to the PointBase 
Commander, which is a command-line tool. This guide contains instructions for using 
PointBase Console.

Who Should Use This Guide

This guide is intended for developers, application programmers, and administrators. This guide 
assumes that you: 

• Understand terminology such as RDBMS, Java, SQL and classes.
• Understand the fundamentals of a relational database system and how tables and indexes 

are created.
• Have a basic knowledge of the SQL language.
• Are familiar with your operating system

How This Guide is Organized

This guide provides information necessary to first start the PointBase Console and continues to 
explain how to use it. Additionally, this guide explains PointBase Console’s toolbar and 
window options and menus. 

Document Feedback

Please send comments or suggestions for all PointBase Documentation to the following email 
address.

pbdocfeedback@pointbase.com
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Document Conventions Used in This Guide

The following table describes the document conventions used in this guide.

Convention Identifies Examples

ALL 
UPPERCASE
LETTERS

• Environment variables
• Database table names
• SQL Keywords

• PATH
• S_LST_OF_VAL
• CREATE TABLE

Courier 
New font

• Directory, file, folder, and path 
names

• Code
• Data you need to type

• c:\pointbase\img.bmp
• Set PointBase =
• Type Your Company 

Name Here

Initial 
Uppercase 
Letters

PointBase names, objects, properties, 
windows, screens, dialog boxes, 
menus, buttons, tabs, applets, fields, 
and icons

PointBase Embedded,
Business Component object, 
List Editor window, Main 
menu, and Cancel button

Italics • Book titles
• Cross references in an index or 

glossary
• Variables
• Arguments to statements of 

functions
• First appearance of a new word or 

phrase
• Emphasis

• User’s Guide
• see also or see

• APPSRVR_4X_ROOT
• variable, rate, prompt$

• new word or phrase

• Do not do this before you 
do that.

[ ] Optional italicized arguments or 
characters inside angle brackets

[caption$]

{ | } Choice from listed arguments; use OR 
operator (|) to separate

{Goto label | Resume Next | 
Goto 0}
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Connecting to the Database
This chapter explains how to connect to a database using the PointBase Console. Before you 
begin using the PointBase Console to access and manage data in the database, you must get a 
connection to the database through the PointBase Console. The following sections explain how 
to get a database connection using the initial PointBase Console window, Connect To 
Database, which appears after you launch the PointBase Console.

If you have already launched the PointBase Console and want to connect to a different 
database, go to the DBA menu and select the option to connect to a database. This option also 
displays the Connect To Database window.

Specifying the Database Driver

In the initial console window, Connect To Database, specify a database driver in the Driver 
field. It defaults to the PointBase JDBC driver, “com.pointbase.jdbc.jdbcUniversalDriver.”

Every time you try to connect to a database using the PointBase Console after you have closed 
your first connection, the PointBase Console picks up the defaults from the properties file that 
it created while exiting. That is, the new defaults when you connect again will be the driver, the 
user name, and the URL which you last used.

Specifying the Database URL

Specify the database URL in the URL field. It defines the protocol, subprotocol, and the 
subname as defined in the book, JDBC API Tutorial and Reference, Second Edition (Sun 
Microsystems). The subprotocol may define the database port number, where it listens for 
client connections, if you are trying to connect to a PointBase Embedded. It defaults to 
“jdbc:pointbase:embedded:sample,” where jdbc is the protocol, pointbase:embedded is the 
subprotocol, and sample is the subname. 

If you are using PointBase Embedded - Server Option, the URL should look like the following: 
“jdbc:pointbase:server://<machine_name><:port>/sample,” where pointbase:server” is the 
subprotocol, <machine_name> is the machine name where the database is running, and 
<:port> is the port number where PointBase is listening for client connections. You do not 
have to specify the port number if you are using the default port number for PointBase, which 
is 9092.(This only applies when using the Server Option. When not using the Server Option, 
PointBase Embedded does not use tcp/ip for connectivity and hence a port is not relevant.
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NOTE: PointBase supports all URLs from earlier PointBase versions.

Specifying the User

Specify the name of the user connecting to the database in the User field. The user name is not 
case-sensitive, and you may enter any alphanumeric characters or the equivalent in a language 
other than English. It defaults to PBPUBLIC.

Specifying the Password

Specify the password to connect to the database in the Password field. The password is not 
case-sensitive, and you may enter any alphanumeric characters or the equivalent in a language 
other than English. It defaults to PBPUBLIC.

Creating the Database

This section explains how to create a new database, connect to an existing database, or drop an 
existing database and re-create it. When you connect to a database, you specify the database 
name in the URL. If the database name you specify is new or existing, you must select the 
appropriate radio button on the Connect To Database window. The same is true if you want to 
drop an existing database and re-create it with the same name—overwriting the database. 

Opening an Existing Database

Select the radio button, Open Specified Database, to open an existing database. If the database 
you specified does not exist, PointBase Console throws an error.

Creating a New Database

Select the radio button, Create New Database, to create a new database. If you try to create a 
database that already exists, PointBase will simply connect to the existing database.

Overwriting a Database

Select the radio button, Drop Specified Database and Recreate, to completely overwrite an 
existing database. If you specify a database that does not exist, PointBase Console will create a 
new database with the name you specified.
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The PointBase Console Interface
This chapter describes the graphical user interface of the PointBase Console. It allows you to 
perform SQL commands at a click of a button, or you can enter SQL commands in an SQL 
Input field. The PointBase Console also allows you to explore your database by simply 
clicking icons to view entire database schemas or table structures. The following sections 
describe the different areas in the console interface.

PointBase Console Menus

The PointBase Console menus are located at the top of the PointBase Console interface. Each 
menu contains several different sub-menus and options from which you can select. The 
following list identifies the PointBase Console menus.

• File
• Edit
• SQL 
• DBA
• Result
• Windows
• Favorites
• Help 

Shortcut Buttons

The PointBase Console shortcut buttons provide fast access to common database tasks for 
example, opening and saving a file, executing SQL commands, and committing or rolling back 
SQL commands. The shortcuts are just below the PointBase Console menus.
Version 4.8  PointBase Console 8
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Navigation Tree

The PointBase navigation tree allows you to browse your database by simply clicking on icons 
to extend a tree structure of your database. The navigation tree is located in the left frame of 
the PointBase Console, just below the shortcut buttons. If you are using a mouse with the right-
click functionality, you may right-click on icons in the navigation tree to display added 
functionality.

SQL Input Frame

The PointBase Console SQL input frame is a field where you can enter SQL commands like a 
command line. The SQL input frame is located on the right side of the PointBase Console 
window, just below the shortcut buttons. 

Make sure to enter a semi-colon (;) to end each of your statements. To execute an SQL 
command, simply place the cursor after the semi-colon and click the Execute shortcut button. 
When you click Execute, you have the option to display read only output or updateable output. 
If you select to display updateable output, you may change data directly in the field that the 
Execute tab displays. To execute multiple SQL commands, click the Execute All shortcut 
button. PointBase Console executes all the SQL commands from that point and before it. You 
cannot update the SQL output if you choose Execute All.

Execute and Execute All Tabs

In the frame below the SQL input frame, there are Execute and Execute All tabs. The fields that 
these tabs display contain the SQL output from an SQL command you executed. You may 
toggle between Execute and Execute All; however, when you click the Execute shortcut button 
to execute an SQL command, PointBase Console automatically puts your results in the field 
that the Execute tab displays. If you click the Execute All shortcut button to execute an SQL 
command(s), PointBase Console puts your results in the field that the Execute All tab displays.

Execute Tab Functionality

Unlike the Execute All tab, which only displays SQL output, the Execute tab displays 
additional PointBase Console features. For example, if you selected to display updateable 
output, you have the option to change data directly in the SQL output field. After you have 
completed any changes to the output, click the appropriate button just below the SQL output 
field to execute your changes. 

SQL Output Buttons

Click the buttons just below the SQL output field to execute any changes you make to 
updateable output. The following buttons are displayed:

• Delete Row
• Insert New Empty Row
• Update Row
Version 4.8  PointBase Console 9
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Max Rows

Also below the SQL output field, is the Max Rows field. It defines the maximum amount of 
rows to display in the SQL output frame. You may change this number by editing the field 
directly.

SQL Execution Timer

The field next to the SQL output buttons calculates the number of seconds that the database 
needed to execute and display the most recent SQL command. To disable this feature, go to the 
SQL menu and un-check the option, Timer Mode.

Row and Column Counter

The field next to the SQL performance timer displays the number of rows and columns in the 
SQL output field. The first number is the number of rows followed by the number of columns.

Message Frame

At the bottom of the PointBase Console, the message frame displays PointBase Console 
messages. These messages range from the status of SQL commands which you executed, to the 
current connection status of the database. You may also clear the message frame by clicking 
the Clear History button just below the frame.

Re-sizable Frames

PointBase Console also provides the added functionality of re-sizeable frames, which you can 
use to resize the PointBase Console frames. Locate the arrows between the console frames, and 
click an arrow to automatically maximize or minimize a particular frame. You may also click 
and hold a frame border to manually resize it yourself.
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Managing the Database
This chapter explains how to manage your database using the PointBase Console. Managing 
database can range from creating tables, users, and schemas, to inserting, deleting, and 
querying the database. PointBase Console provides the capability to perform several database 
operations. In addition to using the SQL input frame, where you can manually enter SQL 
commands to manage your database, PointBase Console provides menus and other options, 
which you can use. The following sections explain the database operations that you may 
perform using the additional menus and options.

Creating Database Objects

The following table describes database objects and the different options to create them using 
the PointBase Console:

Database 
Object

Using the 
DBA Menu

Right-clicking the 
Navigation Tree Where to Right-click

Triggers yes yes Right-click the name of the 
table

Roles yes yes Right-click Roles

Tables yes yes Right-click the name of the 
table or the name of the schema

Routines yes no

Indexes yes yes Right-click the name of the 
table

Users yes yes Right-click Users

Schemas yes yes Right-click the database icon 
above the schemas icon

Databases yes no
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Dropping Database Objects

The following table describes database objects and the different options to drop them using the 
PointBase Console.

Altering Database Objects

The following table describes database objects and the different options to alter them using the 
PointBase Console.

Granting and Revoking

The following table describes database objects and the different options to grant or revoke 
them using the PointBase Console. 

Database 
Object

Using the 
DBA Menu

Right-clicking the 
Navigation Tree Where to Right-click

Triggers yes yes Right-click the name of the trigger

Roles yes yes Right-click the name of the role

Tables yes yes Right-click the name of the table

Routines yes

Users yes yes Right-click the name of the user

Indexes yes

Database 
Object

Using the 
DBA Menu

Right-clicking the 
Navigation Tree Where to Right-click

Users yes yes Right-click the name of the user

Tables yes yes Right-click the name of the table
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Querying Database Tables

You may query an entire table by right-clicking the desired table in the navigation tree of the 
PointBase Console. In addition to selecting an entire table by choosing the “SELECT * FROM 
<table_name>”, you have several other options from which you may choose to select. You 
may also add a SELECT statement to the Favorites menu, if you plan to use that particular 
SQL statement repeatedly and would like to store that statement for future use. See “Using 
Additional Features” for more information about using the Favorites menu.

Returning Updateable SQL Output

Using the PointBase Console, you may only return updateable output in the SQL output field if 
you enter a query in the SQL input frame. After entering a query, select Updateable Output 
from the Execute shortcut button or from the Execute option in the the SQL menu.

Inserting Rows

To insert a row into a table, simply execute a query in the SQL input frame that returns the 
desired table into which you want to insert. Make sure to select the Updateable Output option 
when you execute the query. 

After PointBase returns the updateable output, click the Insert New Empty Row button below 
the updateable output, and insert the appropriate data directly into the new empty row. When 
you are finished inserting data, click the Insert Row button to validate your new row. Note that, 
if autocommit is on, clicking the Insert Row button commits your new row to the database. If 
autocommit is off, you must execute the COMMIT statement to make your new row 
permanent to the database.

Deleting Rows

To delete a row, simply execute a query in the SQL input frame that returns the desired table 
into which you want to delete. Make sure to select the Updateable Output option when you 
execute the query. Click on the row you want to delete in the SQL output field and, click the 
Delete Row button. 

Database 
Object

Using the 
DBA Menu

Right-clicking the 
Navigation Tree Where to Right-click

Roles yes yes Right-click the name of the role

Privileges yes yes Right-click the name of the table
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Note that, if autocommit is on, clicking the Delete Row button commits your new row to the 
database. If autocommit is off, you must execute the COMMIT statement to make your new 
row permanent to the database.

Updating Rows

To update a row, simply execute a query in the SQL input frame that returns the desired table 
into which you want to update. Make sure to select the Updateable Output option when you 
execute the query. After you make changes to a value, click the Update Row button to validate 
your changes. 

Note that, if autocommit is on, clicking the Update Row button commits your new row to the 
database. If autocommit is off, you must execute the COMMIT statement to make your new 
row permanent to the database.

Configuring Database Properties

The DBA menu has the option, Database Properties, which you may select to configure the 
database properties. Please refer to the PointBase System Guide for information about the 
PointBase database properties.

Unloading the Database

The DBA menu has the option, Unload Database, which can unload the current database to a 
“.sql” file on your machine. Select Unload Database and follow the prompts to complete the 
process. Make sure to specify the file extension, when you are prompted for a destination file.

Using Autocommit

By default, the PointBase Console enables autocommit. To disable autocommit, go to the SQL 
menu and un-check the Autocommit option.

Displaying the Optimizer Plan

The SQL menu has the capability to display the optimizer plan for every query. To display 
optimizer plans for you queries, check the Optimizer Analysis Mode option.

Importing and Exporting Data
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The following sections describe how to import data into the database or export data to a file. 

Importing Data

To import data from a file or database into a table, go to the File menu. Select Import, and 
complete the wizard which guides you through this process.

When you import data, note that the transfer of data is faster when selecting Bulk Mode. Select 
Quote String Data if your data contains any quoted Strings. Choices of delimiters are: comma, 
space, tab, bar, and SQL. A delimiter is a character or String that you use to separate or mark 
the start and end of each value in the data. Choose the delimiter SQL if you want to import data 
from another database.

If you choose SQL for a delimiter, the PointBase Console displays a database URL for the 
field, Source URL. Make sure the database URL specifies the database from which you want to 
import data. After you click OK, an additional Import from Database window appears. Make 
sure to enter the required information for the database from which you are importing data. The 
required information is as follows: 

• Source Database Driver: Make sure the driver is in the classpath when you launched 
PointBase Console. See “<install_directory>/tools/embedded/startconsole.bat” for an 
example classpath. You must add the database driver to this classpath. 

• Source Database User
• Source Database Password
• Query: Specifies the query you want to perform on the database, from which you are 

importing data.

Exporting Data

To export results from a query to a file, go the File menu. Select Export and complete the 
wizard which guides you through this process.

When you export data, note that the transfer of data is faster when selecting Bulk Mode. Select 
Quote String Data if your data contains any spaces. Choices of delimiters are: comma, space, 
tab, and bar. A delimiter is a character or String that you use to separate or mark the start and 
end of each value in the data.

Spooling Output

You can spool the output to a file generated by Execute all button.  To enable this option, 
please select "Save results in File" from the DBA menu. Output will be appended if an existing 
file is selected. You can turn off this option by unchecking "Save results in File.

You can also turn on Spooling using the command line. For example:

C:>java com.pointbase.tools.toolsConsole -driver 
com.pointbase.jdbc.jdbcUniversalDriver -url 
jdbc:pointbase:embedded:sample -user PBPUBLIC -password 
PBPUBLIC -spoolfile \<user_home>\example.spl
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Using Additional Features
This chapter explains how to use the additional features that the PointBase Console offers. You 
may use these features to customize the look of your PointBase Console and to perform other 
common tasks. Each of the following sections explain how to use a PointBase Console feature.

Using the Window Menu

The Window menu has the capability to customize the look of your PointBase Console and to 
clear the SQL input frame and the SQL output field. To choose different themes for the 
PointBase Console, select from one of the following options in the Window menu:

• Metal
• CDE/Motif
• Windows

You may also hide the shortcut buttons on the PointBase Console, by de-selecting the ToolBar 
option from the Window menu.

Clearing SQL Input and Output

To clear the SQL input frame or the SQL output field, simply select the Clear Output or Clear 
Input options from the Window menu.

Using the Favorites Menu

The Favorites menu has the capability to store, manage, and execute SQL commands. You can 
use this feature to store SQL commands that you plan to use more than once. If you need to 
change your favorites, you can update or delete them as well. 
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Adding Favorites

There are two ways to store a favorite SQL command using the PointBase Console. Enter the 
command in the SQL input field, put the cursor after the semi-colon, which ends your 
statement, then select the option, Add to Favorites. You may only add one statement at a 
time. Additionally, you may add SQL commands by selecting the Organize Favorites option 
from the Favorites menu and entering the command in the provided field. In this particular 
field, do not enter a semi-colon at the end of the statement. After entering the command or 
statement, click the Add button.

NOTE: If you add a favorite command via the SQL input frame, you must include the semi-
colon at the end of the statement. If you use the Organize Favorites option to add a 
favorite, do not enter a semi-colon at the end of the statement.

Updating and Deleting Favorites

To update a favorite SQL command, select Organize Favorites, select the command you want 
to update, change it in the provided field, then click Update.

In the same window, Organize Favorites, delete a favorite command by selecting the command 
and clicking Delete.

Executing Favorites

Simply select the desired SQL command from the Get Favorite option to automatically 
execute it. 

Viewing the History

The History option displays a list of the last 10 SQL commands, which you have executed.

Copying SQL Output to Another Application

You can copy SQL output and paste it to another application, for example, an Microsoft Excel 
worksheet, using the PointBase Console. The Result menu has the capability to copy the entire 
SQL output or only specified rows in the SQL output. Select the SQL output that you want to 
copy, and click Copy from the Result menu. To copy the entire SQL output, click Select All 
from the Result menu and then click Copy. Note that the copied SQL output is tab separated.
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Saving SQL Output or Input to a File

The Save As option from the File menu has the capability to save the SQL output to an HTML 
file, an ASCII file, or a log file. You can also save the the SQL input to an “.sql” file. Select 
this option and follow the prompts to complete the process. Make sure to enter the file 
extension name when you are specifying the file to which you are saving SQL output or input, 
for example, “.sql,” for saving SQL input. For saving SQL output within the Execute tab, 
specify the file extensions, “.html” or “.dat.” Within the Execute All tab, specify the file 
extension, “.log.”

Using the Help Menu

The Help topics will launch the help system for Console. The Show System option in the help 
menu you determine the following:

1. PointBase Version and Build number

2. Operating System

3. Java System

4. Driver

5. Database

6. Username
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