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Introduction to Array Agents 
Sun StorageTek Business Analytics provides storage array agents supporting different 
vendor product lines or interfaces; including EMC Symmetrix, EMC Clariion, HDS 
Thunder and Lightning series, HP/Compaq EVA, HP/Compaq HSG80-based arrays, IBM 
ESS/Shark, LSI-based arrays (including IBM FastT and StorageTek FlexLine), and HP XP 
series. Refer to the Sun StorageTek Business Analytics Support Matrix that is located on 
the Documentation CD to obtain the latest information on supported product lines and 
interfaces as well as on their support prerequisites. 

Note: With the acquisition of StorageTek, Sun Microsystems has re-branded and re-
named Global Storage Manager (GSM) as Sun StorageTek Analytics, a member of the 
Enterprise Storage Manager portfolio of software solutions. The functionality of Business 
Analytics is identical to GSM, only the name has changed. 

Although no two array agents are implemented in exactly the same way, there are broad 
areas of similarity across vendors in terms of functionality and interface methods. For 
example, all array agents publish the same objects. 

Sun StorageTek Business Analytics 5.0 SP1 provides three installation CDs for agent 
server platforms: Windows Local Manager, Solaris Local Manager, and UNIX Agent 
Installation (AIX and HP-UX).  

Note: Before you install an Array Agent on a server running a previous release of that 
agent, uninstall the previously installed agent before you install the corresponding Sun 
StorageTek Business Analytics 5.0 Array Agent supplied with the latest software. The 
decision to upgrade an existing Array Agent may be performed because: 

• The Sun StorageTek Business Analytics Release Notes indicate a problem has been 
fixed or a new feature added. 

• The upgrade is recommended by your Sun representative. 

Automatic and Static Agent Registration 
Automatic agent registration is a configuration option for agent data collection. In the 
storability.ini file, automatic agent registration is configured as follows: 
 
• Local Manager – Specify the IP address or host name of the Local Manager to be 

contacted to activate agent registration.  
• Local Manager Registration Port – Specifies the TCP port number used by the 

Local Manager for agent auto registration. The default port number is 17146. 
• Enable Auto Registration – Turns agent auto registration on (default) or off. 
 
The HDS and HiCommand agents now support auto registration. The following agents do 
not auto-register with the Routing Agent and, therefore, need to 
be registered statically: 
 
• Compaq Agent 
• ESS Agent 
• Engenio/LSI Agent 
• HP XP Agent 
 
To register the Array Agent statically, proceed as follows: 
 
• Enter false in the Enable Auto Registration field.  
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• Modify the Routing Agent static agent configuration to include an entry (port 
number|<agent IP address/name>)  

• Restart the Routing Agent 
• Restart the companion Central Manager agents 

Array Agent Objects 
Table 1 lists the objects that the Array Agents publish.  
 
Table Columns 
alerts-3-0 sourceip, priority, alert_id, progname, alert, time, 

firsttime, refreshedtime, int1, text1, text2. 
gsa_agent_version-2_0 ip_ address, agent_name, version, compile time, 

tz_name, tz, timestamp. 
gsa_cache_control-2_0 ip_address, port, table_name, cache_age, 

last_update_request_length, update_request_pending, 
group_name, group_master, timestamp 

gsa_ini_control-2_0 ip_address, port, domain, parameter, value, status, 
timestamp 

gsa_parm_info ip_address, port, object, parm_name, value_syntax, 
description, example 

gsa_array_config-2_2 ip_ address, agent_name, array_id, array_name, 
array_maker, array _model, array_sw, cache_size, 
phydisks, controllers, data_ip_address, 
mgt_ip_address, dev_ip_address1, dev_ip_address2, 
product_line,timestamp. 

gsa_array_HBA_config-2_1 ip_ address, array_id, type, mode, security, 
current_speed_mbits_sec, wwn, port_wwn, port_id, 
timestamp. 

gsa_cache_perf-2_1 ip_ address, array_id, cache_hits_sec, rd_io_per_sec, 
wr_io_per_sec, timestamp. 

gsa_disk_perf-2_1 ip_address, array_id, addr_1, addr_2, addr_3, io_per 
_sec, rd_io_per_sec, wr_io_per_sec, timestamp. 

gsa_fctl_perf-2_1 ip_address, array_id, addr_1, io_per_sec, timestamp 
gsa_host_storage_unit-2_1 ip_address, array_id, wwn_alias, wwn_id, su_id, 

fe_port, mapped, assigned, scsi_vbus, scsi_target, 
scsi_lun, timestamp. 

gsa_local_unit_mapping ip_address, array_id, su_id, d_array_id, d_su_id, 
session_name, mapping_type, mapping_status, 
timestamp. 

gsa_phydisk ip_address, array_id, addr_1, addr_2, addr_3, 
disk_size, timestamp. 
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Table Columns 
gsa_remote_unit_mapping-
2_1 

ip_address, array_id, su_id, d_array_id, d_su_id, 
session_name, mapping_type, mapping_status, role, 
timestamp. 

gsa_storage_unit_config-2_1 ip_address, array_id, su_id, addr_1, addr_2, addr_3, 
addr_4, size, configuration, type, status, primary, 
component_1, component_2, timestamp. 

gsa_su_reference ip_address, array_id, su_id, su_uid, timestamp 
 

Table 1 - Array Agent Objects 

Installing Array Agents on Windows 
The Array Agents are located on the installation CD under folders that have the following 
structure: 
 

\Agents\Agent Name 
 
These agents share the following characteristics: 
• Are installed using the Install Shield-based setup program (setup.exe). 
• Are configured using the Configuration Tool. 
• Share a common configuration file (storability.ini) in the \Agents folder. 
• Log to their own Message.log file in the \<Agent _Name > folder. 
• Can be started using the context-sensitive Tools menu selection in the Configuration 

Tool or using the Windows Services panel. 
• Are installed with the required lmutilities and Configuration Tool components. 

Installing Array Agents on Solaris 
The Array Agents are located on the installation CD in directories that have the following 
directory structure: 
 

/Unix/<OS>/<version> 
 
These agents share the following characteristics: 
• Are installed as Solaris packages or using the install.sh utility. 
• Have binaries that are installed into the directory /opt/storability/bin. 
• Share a common configuration file (storability.ini) in the directory 

/opt/storability/etc. 
• Log to a common Message.log file in the directory /opt/storability/data. 
• Run as daemons and are started/stopped through run control scripts having the 

agent name and located in the directory /etc/init.d. 
• Can be started using the gsmuser account that the installation will create if the 

installer chooses. 
• Require the installation of the GSMbase package, which creates the directory 

structure, gsm group, as well as installs shared libraries. 
• Can use the process status command to verify Storability Agents are running: 

 
ps -ef | grep storability 

 
Notes: If your system does not auto mount the Local Manager installation media, 
mount the installation media in your CD-ROM drive using the following steps:  
 
a. Ensure that your CD device is at SCSI target 6 (SunBlade and some others use t1 or 

t2). 
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b. Verify that the /cdrom mount directory exists, or create it. 

Installing Array Agents on HP-UX 
The HP-XP Agent is supported on a HP-UX server. Refer also to the Sun StorageTek 
Business Analytics Support Matrix for the latest information on supported platforms and 
prerequisites. 

The following notes apply to installing agents on this platform: 

• The agent installation must be carried out locally by root 

• You may mount the software media directly using the local CD-ROM drive or copy 
the CD contents to some location on the server. 

• Depending on which filesystem extensions are recognized by the host, the location, 
relative to the CD root, will be: 

- UNIX/HP-UX/<version>    (basic ISO 9660 filesystem) 

- Unix/HP-UX/<version>    (ISO 9660 with extensions) 

• The software installation directory contains both the .tgz (gzipped tar) file and the 
install scripts. To install individual agents, simply run the corresponding installation 
script (i.e.,  ./<Agentname>_install.sh) script 

• The agent should be started and stopped using the init scripts in the /sbin/init.d 
directory. 

• Because the name of each agent binary ends in 'Agent',the following command can 
be used to confirm which are running: 

      $ ps -ef | grep Agent 

Introducing SMIS Array Agent 
The SMIS Array Agent collects data from SMI-S 1.0.2 compliant CIM Providers supporting the 
Array profile identified in the Sun StorageTek Business Analytics Support Matrix. In general, SMIS 
agents and non-SMIS are not supported collecting information from the same device. See also the 
Restrictions section of the following SMIS Array Agent Matrix. 
 

SMIS Array Agent Matrix 
 
Item Description 

Support Prerequisites  

Verify SMI-S 1.0.2 compliant CIM 
Provider 

Manufacturer’s documentation.  

Limitations  
Agent Objects The SMIS Array Agent does not currently populate 

the following agent objects: 
• gsa_remote_unit_mapping 
• gsa_fctrl_perf 
• gsa_disk_perf 
• gsa_cache_perf 

 
 
Item Description 
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EMC SMI-S Provider 
Limitations 

• For arrays with metaLUNs, the CIM provider does not furnish 
detailed information on metaluns regarding the parity space used. 
This results in an inaccurate calculation of RAW configured space 
in the reports. 

• The CIM provider does not supply information on the hyper 
components of a meta lun. This results in inaccuracies in reports 
regarding meta lun details. The CIM provider does not report 
individual meta members but does report the meta head with the 
capacity of the entire metavolume.  

• The CIM provider does not report that a device is a meta lun.  
Therefore, our agent will not distinguish between a meta and a 
normal volume. 

• The CIM provider does not report every “type of volume. Some 
administrative volumes, such as, BCV, SFS, VCM, DRV, etc. are 
not reported by the provider.  As a result, the agent does not 
report these volumes.  

• BCV assignments are not reported and the reports will incorrectly 
report the total storage allocated as well as remaining free space. 

• FC4700 private luns are not furnished by the CIM provided 
• The CIM provider does not give information on RAID-S raid 

groups. As a result, the agent will not populate the component_2 
column in the storage_unit_config table for RAID-S devices. In 
addition, this limitation means the agent does not correlate RAID-
S devices that are in the same raid group.  

• The provider does not provide detail disk information for RAID-S 
devices. This results in incorrect totals in our reports for RAW 
configured space.  

• Raid-S devices report incorrect parity information in the 
storage_unit_config table. 

• The CIM provider does not provide the agent with scsi vbus 
information so addr 4 of storage_unit_config table will be “-1” 

• This version of the agent does not support any of the array 
performance tables. 

• This version of the agent does not populate the 
gsa_local_unit_mapping and gsa_remote_unit_mapping tables. 

• Cache size data is not reported by the CIM provider. 
• Disk address prefixes, such as “DA & DF” for a Symmetrix, are 

not provided by the EMC CIM Provider. 
• The reports derived from this agent show the total of all 

controllers in the Front End Controllers field.  
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Item Description 

Engenio/LSI SMI-S Provider 
Limitations 

• The array_hba_config ports are not being 
provided correctly due to an Engenio CIM 
provider anomaly. 

 

SMIS Array Agent on Windows  • Sun StorageTek Business Analytics Windows 
Local Manager Installation CD (InstallShield) 

• Local Manager utilities and Configuration Tool 
required 

• Required Server Access: Administrator privileges 
 

SMIS Array Agent on Solaris • Sun StorageTek Business Analytics Solaris Local 
Manager Installation CD  

• Package Installation 
• Required Server Access: root access and 

Management Station permissions 
• GSMbase and GSMlmutilities must be installed for 

all array agents 
 

Configuration Parameters  

CIM_IP CIM_IP = provider ip|provider port  
(5988)|namespace| username|password 
 
One entry is required per SMI provider.  
 
The first field is the IP address of a CIMOM (Common 
Information Model Object Manager) provider.  This 
may be an individual array that supports CIM 
natively, or a CIMOM proxy reporting on one or more 
arrays. 
 
The second field is the CIMOM provider port, which is 
TCP port number 5988 by default. 
 
The third field, the namespace value, must be 
obtained from the vendor documentation for the 
CIMOM provider. For example, root/cimv2. 
 
The Username and password must be configured for 
an account that grants access to the CIM provider. 
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Item Description 

Local Manager Network-resolvable host name/IP address of Local 
Manager to be contacted for agent auto registration. 

Local Manager Registration Port Local Manager’s TCP port number (default is 17146) 
used for agent auto registration. 

Enable Auto Registration Turns agent auto registration on (default) or off. 

Table 2 - SMIS Array Agent Matrix 
 

Installing SMIS Array Agent - Windows 
The following section describes how to install and configure the Storability SMI-S Array 
Agent on a Windows platform.  

1. Insert the Sun StorageTek Business Analytics Windows Local Manager CD into the 
CD-ROM drive. 

2. Click Next on the Welcome menu to continue the installation. 

3. Click Yes to accept the terms of the software license agreement. 

4. Review/modify the User Name and Company Name and click Next>. 

5. Check the SMIS Array Agent checkbox on the screen that lists Sun StorageTek 
Business Analytics Agents for installation. 

 

   Figure 1 - Select Features To Be Installed 
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6. Review the settings and click Next. 

7. Specify whether or not to install the new version of the Configuration Tool. 

8. When the Configuration Tool is automatically launched, select File -> Edit -> Smart 
Agent Configuration. 

9. Click the SMIS Array Agent tab and click Add. As noted, all fields are required. 

10. Specify the following configuration settings: 

• IP or HostName– Specify one entry per SMI provider. This entry may support one 
or several arrays at the same time, depending on the configuration of the provider. 

• Port – Specify the provider port number. The default port number is 5988. 

• Namespace – Specify the namespace value that must be obtained from the 
vendor documentation for the CIM provider. 

• User Name – Specify a user name for an account that grants access to the CIM 
provider. 

• Password – Specify a password for the above specified user. 

11. Click Submit after you have finished configuring the SMI-S Array Agent. 

12. For Local Manager, specify the IP address or host name of the Local Manager to be 
contacted for agent auto registration. 

13. For Local Manager Registration Port, specify the TCP port number the Local 
Manager uses for agent auto registration. The default port number is 17146. 

14. Click Show Advanced Settings and review/modify the following configuration 
variables: 

• Enable Auto Registration – Turns agent auto registration on (default) or off. 
Default value is true (enabled) but may be set to false to disable agent auto 
registration. 

• CONFIG_CACHE_REFRESH_ INTERVAL - Specifies how often to collect array 
configuration data in seconds. The default value is 3000 seconds for 
CONFIG_CACHE_REFRESH_INTERVAL. 

• CMD_EXECUTION_TIMEOUT – Specifies how long the agent will wait for the 
completion of a command. The default value is 250 seconds. 

• EXCLUDE_ARRAY_ID – Specifies array ID to be excluded from data 
collection. Click the Change Option Values button to open the Enter 
EXCLUDE_ARRAY_ID Options dialog. Enter one array ID per line and click the 
Submit button when you have completed your entries. 

15. With “Save Configuration Settings” enabled (check mark), select File->Save to 
store the configuration settings within the storability.ini file. 

16. Select Tools->Start Service to start the agent before you verify agent 
functionality. 
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17. Select File->Exit to close the Configuration Tool. 

18. Use the Windows Services panel to start the agent before you verify it using the 
Sun StorageTek Business Analytics Agent Diagnostic Tool. 

Installing SMIS Array Agent - Solaris 
1. Mount the UNIX Local Manager installation CD on the Solaris server. For example: 

mount –F hsfs –o ro /dev/dsk/c0t6d0s0 /mnt 

2. Change directory to the appropriate directory for the Solaris operating system. 

3. Run the pkgadd command and the main package installation menu is displayed. 

   pkgadd –d . 

4. Type the package selection number for the SMIS Array Agent (Option 25) and press 
Enter to select installing this agent. 

 

5. Enter the IP address or network resolvable host name to connect to the CIMOM 
provider and press Enter.  This may be an individual library that supports CIM 
natively, or a CIM proxy server and press Enter.  

6. At the “Input the CIMOM TCP port#: [5988] [?] “ prompt, enter the TCP port number 
to connect to the CIMOM provider or press Enter to accept the default TCP port 
number (5988) and press Enter. 

7. At the “Input the CIMOM user name:” prompt, type the username of an account that 
grants access to the CIM provider and press Enter. 

8. At the “Password for <user_name>:” prompt, type the password for the above 
specified user and press Enter. 

9. At the “Confirm the password:” prompt, retype the password and press Enter. 
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10. At the “Input the CIMOM provider's namespace:” prompt, specify the namespace 
value that must be obtained from the vendor documentation for the CIM provider. 
Press Enter to continue. 

11. At the “Input the CIMOM interop namespace:” prompt, specify the interoperability 
namespace, which implies where the CIMOM interoperability classes are stored. 
Press Enter to continue. 

12. At the “Do you want to input another CIMOM? [n] [y,n,?]” prompt, type y to 
configure another CIMOM provider or n if you have finished. If you type y and press 
Enter, you again perform Steps 5-11 for the next CIMOM provider. If you type n and 
press Enter, you proceed directly to the following step. 

13. Type y and press Enter to review/modify the Advanced Settings. 

• Automatically restart this agent from agent Monitor – Type y or n to specify 
whether the SMIS Array Agent will be restarted if down by the agent monitor. 

• Intervals of updating configuration information - How long to wait before 
refreshing the configuration data in cache; default value is 3600 seconds. 

• Timeout on execution a single CIM read command – Specify the command 
execution timeout value; the default value is 120 seconds. 

• Array discovery/check interval - Specifies how often the agent performs an 
array status check. The default value is 5 seconds. 

• Enable automatic agent registration - Turn on or off agent auto registration; 
is enabled (true) by default. 

• (Re)start agents after install – Enter y or n to specify whether to start/restart 
agents after the install. 

• Local Manager address for auto registration - Network-resolvable host 
name/IP Address of Local Manager/Central Manager to be contacted for agent 
auto registration. 

• TCP port for auto registration – Local Manager Registration Port used for 
agent auto registration; default value is 17146. 

14. Type y and press Enter to restart agents after installation. 

15. Type y and press Enter to confirm installing the agent. 

16. The installation completes and returns you to the main package installation 
menu. 

17. Type Ctrl-D and q to exit the package installation menu. 

EMC Agent 
The EMC Agent reports configuration, capacity allocation, and performance information 
for EMC Symmetrix arrays. Refer to the Sun StorageTek Business Analytics Support 
Matrix to obtain the latest information on this agent’s software and hardware 
requirements. 
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EMC Agent Matrix 
 
Item Description 

Support Prerequisites  

Verify a supported version of EMS 
Solutions Enabler is installed 

symcfg –version 

Verify access to the VCM Database 
devices and check the version of 
Volume Logix installed on the system 

vcmfind (legacy) 
 
symmaskdb list database 

Verify access to Gatekeeper volumes  syminq  
Verify availability of physical disk 
information 

symdev show 

Using EMC Remote SYMCLI 
Functionality:  

 
 

1.  Configure storability.ini file REMOTE_CONNECTION = <proxy server name>  
SYMMASKDB_CMD_PATH  = <location of the 
symmaskdb executable on the machine you are 
running the command>    
(i.e.   C:\Program 
Files\EMC\SYMCLI\bin\symmaskdb.exe)  

2.  Set SYMCLI_CONNECT and 
SYMCLI_CONNECT_TYPE 
environment variables on Windows 
server 

SYMCLI_CONNECT = "<proxy server name>"    
                                             
SYMCLI_CONNECT_TYPE="REMOTE" 
 
Note: The "proxy server name" must correspond to 
an entry in the netcnfg file as set up by the 
Symmetrix administrator. 

Agent Installation  

EMC Agent on Windows  • Sun StorageTek Business Analytics Windows 
Local Manager Installation CD (InstallShield) 

• Local Manager utilities and Configuration Tool 
required 

• Required Server Access: Administrator 
privileges 

 
EMC Agent on Solaris  • Sun StorageTek Business Analytics Solaris 

Local Manager Installation CD  
• Package Installation 
• Required Server Access: root access and 

Management Station permissions 
• GSMbase and GSMlmutilities must be installed 

for all array agents 
 

EMC Agent on AIX • UNIX Local Manager Installation CD 
• Required server access: root access 
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Item Description 

Configuration Parameters  

Local Manager • Network-resolvable host name/IP address of 
Local Manager to be contacted for agent auto 
registration. 

Local Manager Registration Port • Local Manager’s TCP port number (default is 
17146) used for agent auto registration. 

Enable Auto Registration • Turns agent auto registration on (default) or 
off. 

SYMAPI_LOCAL=Yes/No • Indicates whether the agent will attempt to 
report on locally-attached Symmetrix arrays 
via local gatekeepers. The default value is 
Yes. Specifying No turns off the local access 
method. 

SYMCLI_CONNECT_TYPE="REMOTE" • This configuration setting must be set to run 
the EMC Agent in remote mode. 

SYMMASKDB_CMD_PATH • Specify the full pathname to the symmaskdb 
executable program. There is no default path 
on Windows; the default path on UNIX 
servers is: /usr/symcli/bin/symmaskdb. 

 
ARRAY_STATUS_CHECK_INTERVAL =  
<value>     

• Specifies how often the agent performs an 
array status check. The default value is 3600 
seconds. 

CONFIG_CACHE_REFRESH_INTERVAL 
= <value>   

• Specifies how often to collect array 
configuration data. The default value is 600 
seconds. 

PERF_SAMPLE_INTERVAL = <value>   • Specifies how often to take a new sample 
performance read. The value of zero (0) 
disables performance collection. The default 
value is 120 seconds. 

PERF_AVERAGE_INTERVAL = 
<value>  

• Specifies the interval over which we average 
our performance reads. The value of zero (0) 
disables performance collection. The default 
value is 3600 seconds. 

EXCLUDE_ARRAY_ID =   <array id>    • This is multi-valued variable; one per line in 
the storability.ini file.  Each entry specifies an 
Array Id from which the agent collects neither 
Configuration nor Performance data. 

EXCLUDE_PERF_ARRAY_ID = <array 
id>    

• This is multi-valued variable; one per line in 
the storability.ini file.  Each entry specifies an 
Array Id from which the agent does not 
collect Performance data. 

   Table 3 - EMC Agent Matrix 
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Sample SYMAPI netcnfg File 
The EMC SYMAPI netcnfg file contains the service names and connection information of 
the available network services. The Symmetrix administrator, who has knowledge of the 
available network services, maintains the file contents. A template file is shown in the 
following figure. 
 

 
Figure 2 - SYMAPI netcnfg File Example 

Installing EMC Agent - Windows 

This section describes how to install and configure the EMC Symmetrix Agent on a 
Windows server.  

1. Verify array access and gatekeeper devices. The designation of “GK” in the Type field 
indicates a gatekeeper device. For example: 

 

Figure 3 - Verify Array Access and Gatekeeper Devices 

 

2. Verify access to the Volume Logix database, if applicable. 
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Figure 4 Using symmaskdb list database 

3. Insert the Sun StorageTek Business Analytics Windows Local Manager CD into the 
CD-ROM drive. The Install Shield-based installation should automatically start up. 

4. Click Next> on the Welcome menu to continue the installation. 

5. Click Yes to accept the terms of the software license agreement. 

6. Review/modify the User Name and Company Name and click Next>. 

7. Select (check) the EMC Agent checkbox on the screen that allows you to select Sun 
StorageTek Business Analytics Agents for installation.  You may also wish to install 
the Host Agent if you have not already. Click Next to continue with the installation. 
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 Figure 5 - Select Features To Be Installed 

8. Review the settings and click Next> to continue. Besides the agent, the Local 
Manager is automatically installed with the Local Manager Utilities and the 
Configuration Tool. 

9. The installation proceeds and an informational splash box is displayed showing the 
progress of the agent installation. 

10. After the Configuration Tool is automatically launched, select File->Edit-> Smart 
Agent Configuration. 

11. Click the EMC Agent tab. 

12. For Local Manager, enter the IP Address or network-resolvable host name of the 
Local Manager to be contacted for agent auto registration. 

13. For Local Manager Registration Port, specify the TCP port number the Local 
Manager uses for agent auto registration. The default port number is 17146. 

 

 Figure 6 - EMC Agent Tab 

14. For Fully qualified path to symmaskdb.exe, click the Folder icon and browse to 
the location of the symmaskdb.exe program. Click Open to select the fully qualified 
path to this program, if applicable.  

15. The Report on all remote attached symmetrix arrays through SYMAPI proxy 
servers configuration setting allows you to configure the SYMAPI server interface if 
it is to be used. If to be used, proceed as follows: 

a. Click the Change Option Values button and the Enter 
REMOTE_CONNECTIONS Options dialog is opened. 
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b. Enter the servicename value for each (one per line) SYMAPI server that the 
EMC Agent will query. This value must correspond to an entry in the SYMAPI 
netcnfg file that the Symmetrix administrator has set up. 

c.   Click Submit after you have completed defining the SYMAPI servers. 

 

Figure 7 - Enter REMOTE_CONNECTION Options 

16. Click Show Advanced Settings to review/modify the configuration settings: 

• Enable Agent Auto Registration – Enable agent auto registration (default) or 
set to false to disable agent auto registration. 

• CONFIG_CACHE_REFRESH_ INTERVAL - Specifies how often to collect array 
configuration data. The default value is 600 seconds for 
CONFIG_CACHE_REFRESH_INTERVAL. 

• PERF_AVERAGE_INTERVAL - Specifies the interval over which the agent will 
average its performance reads. The default value is 3600 seconds for 
PERF_AVERAGE_INTERVAL. 

• PERF_SAMPLE_INTERVAL – Specifies how often the agent takes a sample 
performance read. The default value is 120 seconds. Specifying the value of zero 
(0) disables performance collection. 

• ARRAY_STATUS_CHECK_INTERVAL – Specifies how often the agent performs 
an array status check. The default value is 3600 seconds. 

• CMD_EXECUTION_TIMEOUT – Specifies how long the agent will wait for the 
completion of a command. The default value is 3600 seconds. 

• MAX_EXECUTION_THREADS – Specifies the maximum number of arrays the 
agent will process at a time. The default value is four (4). 
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• EXCLUDE_ARRAY_ID - This is a multi-valued variable; one entry per line in the 
storability.ini file.  Each entry will specify an Array ID for which the agent will 
neither collect configuration information nor performance data. 

• EXCLUDE_PERF_ARRAY_ID - This is a multi-valued variable one entry per line 
in the storability.ini file.  Each entry will specify an Array ID for which the agent 
will not collect performance data. 

17. With “Save Configuration Settings” enabled (check mark), select File->Save to 
store the configuration settings within the storability.ini file. 

18. Select Tools->Start Service to start the agent before you verify agent 
functionality. 

19. Select File->Exit to close the Configuration Tool. 

Installing EMC Agent - Solaris 

1. Verify array access and gatekeeper devices. The following example uses the syminq 
command; see Table 2: EMC Array Matrix for additional commands you can use. 

 
Figure 8 - Verify Access to Array 

2. Use the vcmfind command (legacy) or the symmaskdb list database command to 
verify access to the VCM Database devices. 

3. Verify fully qualified path to symmaskdb. The following example uses the find 
command. 

 

Figure 9 - Location of symmaskdb 

 

4. Insert the Sun StorageTek Business Analytics UNIX Local Manager CD into the CD-
ROM drive. 

5. Mount the CD using the following command, for example: 

 mount –F hsfs –o ro /dev/dsk/c0t6d0s0 /mnt 

6. Change directory to the directory corresponding to the host’s Solaris Operating 
System version. 

7. Run the package installation utility and the main package installation menu is 
displayed. 

pkgadd –d . 
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• EXCLUDE_ARRAY_ID - This is a multi-valued variable; one entry per line in the 
storability.ini file.  Each entry will specify an Array ID for which the agent will 
neither collect configuration information nor performance data. 

 

Figure 10 - Package Installation Main Menu 

8. Select GSMemc from the package installation menu; type 9 and press Enter. 

 

Figure 11 - Monitor Locally-Attached Symmetrix Arrays 

9. Specify whether (y/n) the agent will attempt to report on locally-attached Symmetrix 
arrays via gatekeeper devices. The default value is y(es). Specifying n(o) disables 
the local access method. 

10. For SYMAPI proxy server name, specify a SYMAPI server (servicename) that the 
agent will query, or press Enter to accept the default value of none. If specified, 
each servicename value must correspond to an entry in the SYMAPI netcnfg file, 
which the Symmetrix administrator has set up. 
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Figure 12 - EMC Agent Advanced Settings 

11. Type y and press Enter to review/modify the Advanced Settings. 

• Cache update interval for config data - Specifies how often to collect array 
configuration data. The default value is 1200 seconds. 

• Performance collection interval - Specifies how often the agent takes a 
sample performance read. The default value is 120 seconds. Specifying the value 
of zero (0) disables performance collection. 

• Performance average interval - Specifies the interval over which the agent will 
average its performance reads. The default value is 3600 seconds. 

• Array discovery/check interval - Specifies how often the agent performs an 
array status check. The default value is 3600 seconds. 

• Command execution timeout - Specifies how long the agent will wait for the 
completion of a command. The default value is 3600 seconds. 

• Maximum concurrent data collection threads - Specifies the maximum 
number of arrays the agent will process at a time. The default value is four (4). 

• Specify whether (y/n) the agents will be restarted after the package installation 
has completed. 

• Specify whether (y/n) agent auto registration is enabled. Agent auto registration 
is enabled by default. 
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• Review the port number on which the Local Manager listens for agent auto 
registration. The default TCP port number is 17146. 

12. Enter y if prompted to install conflicting files. 

13. Enter y and press Enter to confirm continuing with the EMC Agent, when prompted.  

14. The installation proceeds and returns you to the main package installation menu 
after it has completed. 

15. Type Ctrl-D and enter q to exit the package installation menu. 

Installing EMC Agent - AIX 

1. Verify array access and gatekeeper devices using the syminq command. 

2. Mount the installation CD in the CD-ROM drive of the AIX server. For example: 

 

mount -v cdrfs -r /dev/cd0 /mnt  # /mnt directory must exist  

 

3. Change directory to the software installation directory. For example: 

  cd /cdrom/UNIX/AIX/5.1  

4. Run the EMC Agent installation script. For example: 

  ./emcAgent-install.sh 

5. Set up the following agent configuration parameters: 
 

• CONFIG_CACHE_REFRESH_ INTERVAL - Specifies how often to collect array 
configuration data. The default value is 600 seconds for 
CONFIG_CACHE_REFRESH_INTERVAL. 

• PERF_AVERAGE_INTERVAL - Specifies the interval over which the agent will 
average its performance reads. The default value is 3600 seconds for 
PERF_AVERAGE_INTERVAL. 

• PERF_SAMPLE_INTERVAL – Specifies how often the agent takes a sample 
performance read. The default value is 120 seconds. Specifying the value of zero 
(0) disables performance collection. 

• ARRAY_STATUS_CHECK_INTERVAL – Specifies how often the agent performs an 
array status check. The default value is 3600 seconds. 

• CMD_EXECUTION_TIMEOUT – Specifies how long the agent will wait for the 
completion of a command. The default value is 3600 seconds. 

• MAX_EXECUTION_THREADS – Specifies the maximum number of arrays the 
agent will process at a time. The default value is four (4). 

• EXCLUDE_ARRAY_ID - This is a multi-valued variable; one entry per line in the 
storability.ini file.  Each entry will specify an Array ID for which the agent will 
neither collect configuration information nor performance data. 

• EXCLUDE_PERF_ARRAY_ID - This is a multi-valued variable; one entry per line in 
the storability.ini file. Each entry will specify an Array ID for which the agent will 
not collect performance data. 

6.  At the “Continue with Installation?” prompt, type y and press Enter to continue. 
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7. At the “(Re-)start agents after install [y]” prompt, specify whether (y/n) agents are 
to be restarted after the agent installation has completed. 

8. The Installation completes and the EMC Agent is started on the AIX server. 
 
 
 
 
Agent Auto Registration - Non-Solaris UNIX Hosts 
To configure agent auto registration, you can add the EMC Agent to a Local Manager 
Routing Agent configuration as a SUB_AGENT entry or manually add the required entries 
to the agent’s storability.ini file. Sample storability.ini settings appear below. 

 
GSM_LM_HOST = 10.255.252.123 

      GSM_LM_PORT = 17146 
       GSM_ENABLE_LM_REGISTRATION = true 
 
Verifying the EMC Symmetrix Agent  

1. Use the Sun StorageTek Business Analytics Agent Diagnostic Tool (gsmdiag.exe) to 
verify agent functionality. 

a. Enter the IP Address or Hostname of the server where the agent is installed and 
set the port to 17135 (or select the agent from the drop down list of service 
names). 

b. Click the Get Object List button and you should receive a list of tables published 
by the Storability EMC Agent. 

c. Select the gsa_ini_control-2_0 object and review the agent’s configuration 
settings. 

 

Figure 13 – Verify EMC Agent Configuration Settings 

d. Select the gsa_storage_unit_config-2_1 object and verify data is returned. 
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Figure 14 – EMC Agent Storage Unit Configuration Object 

e. Use the drop down list of Published Objects to proceed collecting all other 
objects published by the agent. 

2. Verify the Storability EMC Agent has registered successfully with its configured Local 
Manager. 

a. In the Agent location window, enter the IP Address or network resolvable Host 
Name of the Local Manager in the ip address/host name input box. 

b. Set the port to 17135 (or select the Storability Routing Agent from the drop down 
list of service names).  

c. Click the Get Object List button and you should receive a list of tables published 
by the Routing Agent. 

d. Select the gsa_agent_register object. 

e. Determine that the EMC Agent is registered for agent data collection: 

• Verify that its TCP port number (17135) appears in the “port” field and its 
host name/IP address is listed in the “active_peer” field.  

• Examine the “type” field. If the agent was registered through auto 
registration, the value is AUTO_NET. The value of STATIC means it was 
registered through a SUB_AGENT entry in the Routing Agent’s storability.ini 
file. 

Clariion Agent 
The Clariion Agent reports configuration and capacity allocation information for EMC 
CLARIION FC4500, FC 4700, and CX-series arrays. The Clariion Agent is now  enhanced 
to support CX array MetaLUN functionality, which requires EMC Navisphere Management 
Suite or the Navisphere command-line interface (Navicli) version 6.5 (included in release 
12 of CLARiiON firmware) or later.  
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Refer to the Sun StorageTek Business Analytics Support Matrix to obtain the latest 
information on this agent’s software and hardware requirements. 
 

Clariion Agent Matrix 
 
Item Description 

Support 
Prerequisites 

 

Resolve Firmware 
Version 

Example: navicli –h <ip address>  getagent 
 
Sample Output: 
Agent Rev:           6.7.1 (0.0) 
Name:                K10 
Desc:                 
Node:                A-APM00044403249 
Physical Node:       K10 
Signature:           1213832 
Peer Signature:      1206935 
Revision:            2.07.500.5.010 
SCSI Id:             0 
Model:               500 
Model Type:          Rackmount 
Prom Rev:            3.16.00 
SP Memory:           2046 
Serial No:           APM00044403249 
SP Identifier:       A 
Cabinet:             DPE2 
 
In the above example, the second decimal value is 07. To resolve 
the level of FW/Flare code, 7 is added to this value. In this 
example, our FW/Flare code version is 14 (7+7=14). If the value 
is greater than 15, this formula does not apply. 

Verify Navicli Version navicli –help 

Determine the access 
path to the array 
controller(s) and verify 
accordingly 

If the array is an FC4500, specify the IP address of a host running 
Navisphere Agent that is used to manage the array.  The host 
running Navisphere Agent must have in-band access to the FC4500 
array. If access to the array is through a fabric switch, the proper 
zoning must be in place to ensure the server has access to the 
array. 
 
For FC4700 or CX series arrays, specify the IP addresses of both 
array controllers. 
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Item Description 

Determine whether or 
not AccessLogix is 
enabled 

For Navicli 6.x, use the following command to verify whether 
AccessLogix is enabled: 
 
navicli -h <IP address of SP> storagegroup -status 
 
Data Access control: ENABLED # Sample command output 
 
For Navicli 5.x, use the following command: 
 
navicli -h <IP address of SP> storagegroup –list 
 
Or:  
 
Use the Navisphere GUI interface to determine if AccessLogix 
security is enabled on the array. 
 
If the command returns storagegroup information, AccessLogix is 
enabled.  However, if it does not return information, it could mean 
that AccessLogix is disabled, or it could mean that AccessLogix is 
in use but no volumes are assigned.  Please use the Navisphere 
GUI to verify the AccessLogix status in that case. 

User Name and 
Password 

The user name and password required to access the storage 
system using the Java CLI must be configured in the storability.ini 
file. The storage administrator uses the -AddUserSecurity or –
RemoveUserSecurity commands (e.g., java -jar navicli.jar -
AddUserSecurity -password mypass -scope 0) to set up users in 
the Navisphere security file. 

Best Practices  

Maximum number of 
monitored arrays 

Five arrays per agent 

Agent Installation  

Clariion Agent on 
Windows  

• Windows Local Manager Installation CD (InstallShield) 
• Required Server Access: Administrator privileges 
 

Clariion Agent on 
Solaris  

• Unix Local Manager Installation CD 
• Package Installation 
• Required Server Access: root access and Management Station 

permissions 
 

Configuration 
Parameters 

 

EMC MirrorView  Specify whether or not EMC MirrorView (remote replication) 
software is installed. 

SPA IP Address Specify the IP address of the SPA Controller. 

SPB IP Address Specify the IP address of the SPB Controller. 
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Item Description 

Access Logix  Specify whether Access Logix is installed. 

Collect Performance Specify whether the agent is to collect performance statistics. 

Cache Interval for 
Configuration Data 

Specifies how often to collect array configuration data. The default 
value is 1200 seconds. 

Local Manager Network-resolvable name/IP Address of Local Manager/Central 
Manager to be contacted for agent auto registration. 

Local Manager 
Registration Port 

Local Manager’s TCP port number (default is 17146) used for agent 
auto registration. 

Enable Auto 
Registration 

Turns agent auto registration on (default) or off. 

Table 4 - Clariion Agent Matrix 

Installing the Clariion Agent on Windows  

This section describes how to install and configure the EMC Clariion Agent on a Windows 
platform.  

1. Insert the Windows Local Manager Installation CD into the CD-ROM drive. The 
Install-Shield-based installation should be automatically started. 

2. Click Next> on the Welcome menu to continue the installation. 

3. Click Yes to accept the terms of the software license agreement. 

4. Review/modify the User Name and Company Name and click Next>. 

5. Check the Clariion Agent checkbox on the screen that allows you to select the  
agents for installation. Click Next>. 

6. Review the settings and click Next> to continue. 

7. Specify an install directory path or accept the default destination of 
<drive>:\Program Files\Storability. Click Next to continue. 

8. When the Configuration Tool is automatically launched, select File->Edit->Smart 
Agent Configuration. 

9. Click the Clariion Agent tab and then click Add. Specify the following information 
and then click Submit for each Clariion array: 

• SPA IP ADRESS –This line specifies the IP address of the SPA Controller or a 
Proxy server. 

• SPB IP ADRESS –This line specifies the IP address of the SPB Controller. 
• Access Logix Installed – Leave the check in the checkbox if Access Logix is 

installed, or remove it if it is not installed. 
• Collect Performance - Leave the check in the checkbox if performance data 

is to be collected, or remove it if it is not to be collected. 
• User Name – Enter a valid user name the storage administrator has added 

to the Navisphere security file. 
• Password – Enter the user’s password if it is not already defined in the 

Navisphere security file. 
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10. For Local Manager, enter the network-resolvable name/IP Address of Local 

Manager/Central Manager to be contacted for agent auto registration or accept 
localhost. 

11. For Local Manager Registration Port, the TCP port used for agent auto 
registration is 17146. 

12. For NaviCLI executable, enter the fully qualified path for the NaviCLI executable 
program or click the folder icon to browse for the program. 

13. Beside the MirrorView_Installed heading, specify Yes if MirrorView is installed or 
No if it is not installed. 

14. For Complete JRE Path, enter the fully qualified path to the Java runtime 
environment executable or click the Folder icon to browse for the location. To see the 
latest JRE supported, refer to the EMC Navisphere Manager and Manager Base 
Release Notes. 

 
15. Optionally click the Comments button and a dialog opens to allow you to type 

comments. 
 
16. Click Show Advanced Settings and review/modify the following configuration 

parameters: 
 

Enable Auto Registration – Turns on or off agent auto registration; is enabled 
(true) by default. 
 
CONFIG_CACHE_REFRESH_INTERVAL - How long to wait before refreshing the 
configuration data in cache; default value is 1200 seconds. 
 
PERF_AVERAGE_INTERVAL – Interval over which to average the performance of 
Read operations. Default value is 3600 seconds. 
 
PERF_SAMPLE_INTERVAL – Interval between collections of performance data for 
the Clariion array; default is 120 seconds. 

ARRAY_STATUS_CHECK_INTERVAL – Maximum cache age for status data in 
seconds; default is 3600 seconds. 

CMD_EXECUTION_TIMEOUT – Statistics and events collection interval in 
seconds; default is 120 seconds. 

MAX_EXECUTION_THREADS – Maximum number of threads used by agent; 
default value is 4. 

EXCLUDE_ARRAY_ID – Click the Change Option Values tab and the 
EXCLUDE_Array_ID Options dialog box opens. Specify each Array ID for which 
configuration data is not to be collected; enter one Array ID per line.  

Note: This option is provided for complex FC4500 array configurations, where a 
single FC4500 array is managed by more than one Navisphere Agent instance, and 
would be reported by more than one instance of Storability Clariion Agent.  In this 
case, the array must be excluded from all but one instance of the Clariion Agent to 
avoid duplication. 

17. Select File->Save and confirm saving the storability.ini file. 

18. Select File->Exit to close the Configuration Tool. 
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19. View the Readme file and click Finish to complete the installation. 

20. Use the Windows Services panel to start the agent before you verify agent 
functionality. 

Installing the Clariion Agent - Solaris 

1. Verify supported version of Navicli is installed. For example: 

 

Figure 15 - Verifying Navicli Version 

2. Verify whether AccessLogix is enabled. 

 

Figure 16 - Verify AccessLogix Enabled 

3. Mount the UNIX Local Manager installation CD on the Solaris server. For example: 

mount –F hsfs –o ro /dev/dsk/c0t6d0s0 /mnt 

4. Change directory to the appropriate directory for the Solaris operating system. 

5. Run the pkgadd command and the main package installation menu is displayed. 

   pkgadd –d . 
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Figure 17 – Select Clariion Agent Package  

6. Type the package selection number (Option 3) for the Clariion Agent and press 
Enter to select installing this agent. 

7. If navicli is not found in the default location (/opt/Navisphere/bin), the script will 
prompt you for its location. 

8. Type y if MirrorView is installed or n if not installed and press Enter. 

9. Type the number to specify the type of array and press Enter to continue. 

 

Figure 18 - Specify Clariion Array  

10. Specify whether or not the array supports Access Logix and press Enter to continue. 

11. Specify whether to collect performance information for this array. 

12. Type the SPA IP address and press Enter. 
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13. Type the SPB IP Address and press Enter. 

14. Repeat the above steps for the next array or type 4 and press Enter to specify you 
have finished configuring the arrays. 

15. Type y and press Enter to review/modify the Advanced Settings. 

 

Figure 19 - Clariion Agent Advanced Settings 

• Cache Update for Configuration Data - How long to wait before refreshing the 
configuration data in cache; default value is 1200 seconds. 

• Performance Collection Interval - Interval between collections of performance data 
for the Clariion array; default is 120 seconds. 

• Performance average interval - Interval over which to average the performance of 
Read operations. Default value is 3600 seconds. 

• Array discovery/check interval - Maximum cache age for status data in seconds; 
default is 3600 seconds. 

• Command execution timeout - Statistics and events collection interval in seconds; 
default is 120 seconds. 

• Maximum concurrent data collection threads - Maximum number of threads used 
by agent; default value is 4.  Increase this value if you are collecting data from 
more than 4 arrays using this agent. 

• Automatically restart agent from Agent Monitor – Specify whether a SNMP trap will 
be sent and the agent will be restart agent, if down. 

• Enable automatic agent registration - Turn on or off agent auto registration; is 
enabled (true) by default. 

• Local Manager address for auto registration - Network-resolvable host name/IP 
Address of Local Manager/Central Manager to be contacted for agent auto 
registration. 
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• TCP port for auto registration – Local Manager Registration Port used for agent 
auto registration; default value is 17146. 

16. Type y and press Enter to restart agents after installation. 

17. Type y and press Enter to confirm installing the agent. 

 

Figure 20 - Clariion Agent Installation Completed 

18. The installation completes and returns you to the main package installation menu. 

19. Type Ctrl-D and q to exit the package installation menu. 

Verifying the Storability Clariion Agent  

1. Use the Sun StorageTek Business Analytics Agent Diagnostic Tool to verify agent 
functionality. 

a. In Agent location window, enter the IP Address or Hostname of the server 
where the agent is installed. 

b. Set the port to 17141 (or select the agent from the drop down list of service 
names). 

c.   Click the Get Object List button and you should receive a list of objects 
published by the Storability Clariion Agent. 

d. Select the gsa_ini_control-2_0 object and examine/verify your configuration 
settings. 
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Figure 21 - Verify Clariion Agent Configuration Settings 

 

e. Select the gsa_storage_unit_config-2_1 object and verify data is 
returned. 

 

Figure 22 – Verify Storage Unit Configuration Object – Clariion Agent 

 

f. Select the gsa_host_storage_unit-2_1 object and verify that you can 
collect allocation information. 
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1. To verify the agent has registered successfully with its configured Local Manager: 

a. In the Agent location window, enter the IP Address or network resolvable 
Host Name of the Local Manager in the ip address/host name input box. 

b. Set the port to 17146 (or select the Storability Routing Agent from the drop 
down list of service names).  

c.   Click the Get Object List button and you should receive a list of tables 
published by the Routing Agent. 

d. Select the gsa_agent_register object. 

e. Determine that the Clariion Agent is registered for agent data collection: 

• Verify that its TCP port number (17141) appears in the “port” field and its 
host name/IP address is listed in the “active_peer” field.  

• Examine the “type” field. If the agent was registered through auto 
registration, the value is AUTO_NET. The value of STATIC means it was 
registered through a SUB_AGENT entry in the Routing Agent’s storability.ini 
file. 

Compaq EVA Agent 
The Compaq EVA Agent reports configuration and capacity allocation information on 
HP/Compaq StorageWorks EVA arrays. Refer to the Sun StorageTek Business Analytics 
Support Matrix to obtain the latest information on this agent’s software and hardware 
requirements. 

The Compaq EVA agent can monitor multiple management appliances that, in turn, 
manage one or more arrays. 

EVA Agent Matrix 
 
Item Description 

Support 
Prerequisites 

 

Verify Ethernet 
connectivity to 
SANWorks 
Management Appliance 
1.x or 2.0 

 

ping <IP_Address> 

Verify Virtual Controller 
Software (VCS) 1.x or 
2.0 is installed 

 

 

Verify SSSU 1.x or 2.0 
(included in host-
specific platform kit) is 
installed 

Provides the required SSSU CLI interface to the array. 
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Item Description 

Best Practices  

Maximum number of 
monitored arrays 

Monitor a maximum of 2 SAN Appliances per agent 

Agent Installation  

EVA Agent on Windows 
2000 

• Windows Local Manager Installation CD (InstallShield) 
• Required Server Access: Administrator privileges 
 

EVA Agent on Solaris  • Local Manager Installation CD (Unix) 
• Package Installation 
• Required Server Access: root access and Management Station 

permissions 
 

Configuration 
Parameters 

 

IP Address IP address of the management appliance interface for connection 
authentication. 

User Name User name for connection authentication 

Password Password for connection authentication 

EVA SSSU Command 
Path 

Fully qualified path to the SSSU CLI software  

Local Manager IP Address or host name of the Local Manager to be contacted for 
agent auto registration. 

Local Manager 
Registration Port 

Local Manager’s TCP port number used for agent auto registration. 
The default port number is 17146. 

Enable Auto 
Registration 

Turns agent auto registration on (default) or off. 

Agent Command 
Timeout Interval 

How long to wait for a data collection command to complete; 
default value is 60 seconds 

Interval to collect 
configuration data 

Array configuration cache interval; default value is 3600 seconds 

Interval to check the 
status  

Array status cache interval; default value is 3600 seconds 

Max. number of arrays 
to process at any one 
time 

Maximum number of simultaneously monitored arrays; default 
value is 5. 

Table 5 – Storability EVA Agent Matrix 

Installing the Storability EVA Agent - Windows 

1. Insert the Windows Local Manager CD into the CD-ROM drive. 
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2. Click Next> to on the Welcome menu to continue the installation. 

3. Click Yes to accept the terms of the software license agreement. 

4. Click Next>. 

5. Review/modify the User Name and Company Name and click Next. 

6. Check the Compaq EVA Agent checkbox on the screen that lists the Sun 
StorageTek Business Analytics Agents for installation. You may want to install the 
Host Agent as well. Click Next. 

7. Review the settings and click Next> to continue. 

8. Click Yes to acknowledge the SSSU executable requirement (or install this utility 
and re-install this agent) and click Next to continue. 

9. Specify whether or not to install the Configuration Tool. 

10. When the Configuration Tool is automatically launched, select File->Edit->Smart 
Agent Configuration. 

11. Click the Compaq EVA Agent tab and click Add to specify the configuration 
variables: 

IP Address - Specify the IP address of the management appliance interface for 
connection authentication. 

User Name - Specify the user name for connection authentication. 

Password - Specify the password for connection authentication. 

· Local Manager Network-resolvable name/IP Address of Local Manager/Central 
Manager to be contacted for agent auto registration. 

· Local Manager Registration Port - Local Manager’s TCP port number used for 
agent auto registration; default value is 17146.  

12. Click Show Advanced Settings and review/modify the following configuration 
parameters: 

Enable Auto Registration – Turn on (default) or off agent auto registration. 

EVA SSSU Command Path - Set the fully qualified path to the sssu program 
(sssu.bat). Clicking the Folder icon allows you to browse and locate the file. 

Agent Command Timeout Interval - Specify the timeout interval for data 
collection command execution. 

Interval to collect configuration data – Specify how often to collect 
performance information for the array.  

Interval to check the status of each array - Set the cache refresh interval (in 
seconds). 
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Maximum number of arrays to process at any one time – Specify the 
number of storage arrays to be monitored in your environment or accept the 
default value of 5. 

20. Select File->Save and confirm saving the changes. 

21. Select File-> Exit to close the Configuration Tool. 

22. View and then close the Readme file and click Finish. 

23.  Use the Windows Services panel to restart the Storability EVA Agent before you 
verify agent functionality. 

Installing the Compaq EVA Agent - Solaris  

1. Insert the UNIX Local Manager CD into the CD-ROM drive. 

2. Mount the CD using the command: 

mount –F hsfs –o ro /dev/dsk/c0t6d0s0 /mnt 

3. Change to the directory corresponding to the host’s Solaris Operating System 
version. Solaris 7 or 8 packages are located in /Unix/Solaris/7,8. 

4. Run the package installation utility and the main package installation menu appears. 

pkgadd –d . 

5. Select the GSMcpqeva agent; type 6 and press Enter. 

6. At the “IP Address of the EVA Manager” prompt, enter the IP address of the 
management appliance and press Enter. 

7. Enter the user name for connection authentication and press Enter. 

8. Enter and confirm the password for connection authentication. 

9. Specify the IP address, user name, and password for another array, or press 
Enter on an empty IP Address line to specify you are finished. 

10. At the “Location of sssu” prompt, specify the fully qualified path to the sssu 
program. The installation script verifies the path is valid. 

11. When prompted, review/modify the Advanced Settings: 

• Local Manager - Network-resolvable host name/IP address of Local Manager to 
be contacted for agent auto registration. 

• Local Manager Registration Port – Accept the default Local Manager 
Registration Port of 17146 

• Enable Auto Registration – Is enabled (true) by default; specify false to 
disable auto registration. 

• EVA_TIMEOUT_INTERVAL - Specify the timeout interval for read and write 
command execution. 

• ARRAY_REFRESH_INTERVAL - Set the cache refresh interval (in seconds). 

12. Enter y to (re) start the agents after installation. 

13. Enter y to confirm installing the Compaq EVA agent. 

14. Enter y if prompted to install conflicting files. 
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15. The installation proceeds and returns you to the main package installation menu 
after it has completed. 

16. Enter q to exit the package installation menu. 

Verifying the Compaq EVA Agent 

1. Use the Sun StorageTek Business Analytics Agent Diagnostic Tool to verify 
agent functionality. 

a. Enter the IP Address or Hostname of the server where the agent is installed and 
set the port to 17143 (or select the agent from the drop down list of service 
names). 

b. Click the Get Object List button and you should receive a list of tables 
published by the Storability EVA Agent. 

c. Select the gsa_storage_unit_config table and verify data is returned. 

d. Use the drop down list of objects to proceed collecting the other objects 
published by the agent. 

2. To verify the Storability EVA Agent has registered successfully with its configured 
Local Manager: 

a. In the Agent location window, enter the IP Address or network resolvable Host 
Name of the Local Manager in the ip address/host name input box and set the 
port to 17146 (or select the Storability Routing Agent from the drop down list of 
service names).  

b. Click the Get Object List button and you should receive a list of tables published 
by the Routing Agent. 

c. Select the gsa_agent_register object. 

d. Confirm that the Storability EVA Agent is registered: 

• Verify that its TCP port number (17143) appears in the “port” field and its 
host name/IP address is listed in the “active_peer” field.  

• Examine the “type” field. If the agent was registered through auto 
registration, the value is AUTO_NET. The value of STATIC means it was 
registered through a SUB_AGENT entry in the Routing Agent’s storability.ini 
file. 

Compaq Agent 
The Storability Compaq Agent reports configuration and storage allocation information 
for HP/Compaq HSG80-based arrays. 

Compaq Agent Matrix 
 
Item Description 

Support 
Prerequisites 

 

Verify serial 
connectivity from the 
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agent platform to both 
array controller serial 
console ports 
Warning  
Serial Port Parity Conserver (one of the agent’s components) won't connect to a 

HSG80-based array if the serial port is set to odd parity. 

Item Description 

Agent Installation  

HP/Compaq HSG80-
Based Array Agent on 
Windows 2000 

• Windows Local Manager Installation CD (InstallShield) 
• Required Server Access: Administrator privileges 
 

HP/Compaq HSG80-
Based Array Agent on 
Solaris  

• Local Manager Installation CD (Unix) 
• Package Installation 
• Required Server Access: root access and Management Station 

permissions 
 

Agent Installation  

HP/Compaq HSG80-
Based Array Agent on 
Windows 2000 

• Windows Local Manager Installation CD (InstallShield) 
• Required Server Access: Administrator privileges 
 

HP/Compaq HSG80-
Based Array Agent on 
Solaris  

• Local Manager Installation CD (Unix) 
• Package Installation 
• Required Server Access: root access and Management Station 

permissions 
 

Configuration 
Parameters 

 

Local Manager Network resolvable name or IP address of the Local Manager to be 
contacted for agent auto registration. 

Local Manager 
Registration Port 

TCP port number the Local Manager uses for auto registration. 
The default port number is 17146. 
 

HSG80 Array Logs Name of the top and bottom controller log files. 

HSG80 Log Directory Directory name where conserver logs the information for the 
arrays. 

Enable Auto 
Registration 

Specifies whether or not the agent is allowed to communicate with 
the upstream Local Manager for auto registration. Default value is 
true but may be set to false to disable auto registration. 

Read Interval Averaging interval; default value is 3600 seconds 

Read Update Interval How often performance data is collected; default value is 120 
seconds 

 
Installing the Storability Compaq Agent - Windows 

1. Insert the Windows Local Manager CD into the CD-ROM drive. 
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2. Click Next on the Welcome menu to continue the installation. 

3. Click Yes to accept the terms of the software license agreement. 

4. Review/modify the User Name and Company Name and click Next. 

5. Check the Compaq Agent checkbox on the screen listing Sun StorageTek Business 
Analytics Agents for installation. You may also want to install the Host Agent as well. 
Click Next> to continue. 

6. Review the settings and click Next> to continue. 

7. Specify whether or not to install Cygwin, if not already installed.  

Note: Cygwin is a prerequisite for this Sun StorageTek Business Analytics Agent; the 
installation will not proceed unless Cygwin is installed. 

8. Specify whether or not to install a new version of the Configuration Tool. 

9. When the Configuration Tool is automatically launched, select File -> Edit -> Smart 
Agent Configuration. 

10. Click the Compaq Agent tab and click Add.  The “Add property 
HSG80_ARRAY_LOGS” dialog box appears.  

11. Click the Folder icon to locate and select the top controller log (e.g., hsg01_top.log) 

12. Repeat the above step to locate and select the bottom controller log. 

13. Click Submit. 

 

Figure 23 - Compaq Agent Configuration Tab 

14. Repeat Steps 10-13 for each array to be monitored. 
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15. For Local Manager, type the network-resolvable name or IP address for the Local 
Manager to be contacted for auto registration. 

16. For Local Manager Registration Port, this value specifies the port number the 
Local Manager uses for auto registration. The default value is 17146. 

17. For HSG80 Log Directory, enter the name for the directory in which conserver logs 
the information for the arrays.  This is the Windows path to the directory, not the 
Cygwin path to the directory (i.e. c:\cygwin\var\log\hsg80). 

18. Click Show Advanced Settings. 

19. For Enable Auto Registration, specify whether the agent should automatically 
register (default) with the Local Manager or not. 

20. For Read Interval, specify the Averaging Interval in seconds or accept the default 
value of 3600 seconds. 

21. For Read Update Interval, specify the interval to collect performance data or 
accept the default value of 120 seconds. 

22. Select File->Save and verify saving the changes in the storability.ini file. 

23. Select File->Exit to close the Configuration Tool. 

24. Using a text editor (e.g., notepad) open the conserver.cf.sample file located in 
/opt/conserver/etc and save this file as conserver.cf. 

25. Read the information that specifies how to set up this configuration file for your 
storage array.  

 

Figure 24 - conserver.cf File 

 

26. Customize the conserver.cf file for your storage array and save the modified 
conserver.cf file. 

27. Use the Windows Services panel to restart the Storability Compaq Agent before you 
verify agent functionality. 

Installing the Storability Compaq Agent - Solaris 

1. Insert the UNIX Local Manager CD into the CD-ROM drive. 

2. Mount the CD using the following command, for example: 
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mount –F hsfs –o ro /dev/dsk/c0t6d0s0 /mnt 

3. Change to the directory corresponding to the host’s Solaris Operating System 
version.  

4. Run the package installation utility. 

pkgadd –d . 

5. Select STconsrv from the package installation menu. 

6. Press Enter to accept the default installation directory. 

7. Press Enter to allow the default directory to be created (if it does not exist). 

8. Enter y to continue with the installation. The installation proceeds and returns you to 
the main package installation menu. 

9. Enter q to exit and set up the conserver configuration file (conserver.cf). 

10. Using a text editor (e.g., vi) open the conserver.cf.sample file located in 
/opt/conserver/etc and save this file as conserver.cf. 

11. Read the information that specifies how to set up this configuration file for your 
storage array.  

 

Figure 25 - conserver.cf File 

12. Customize the conserver.cf file for your storage array and save the modified 
conserver.cf file. 

13. Repeat Step 4; run the package installation utility. 

14. Select the GSMcpq agent. 

15. Review/modify the configuration variables: 

HSG80_LOG_DIR - Enter the name for the directory to which conserver logs the 
information for the arrays.   

16. Enter y to add an array to be monitored by conserver. 

HSG80_ARRAY_LOGS - Enter the name of the top and bottom controller log 
files.  This filename should match the one created for the controller in the 
conserver.cf file.  
 
Local Manager – Specify the IP address/network resolvable host name of the  
Local Manager to be contacted for agent auto registration. 
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Local Manager Registration Port – Specifies the TCP port number the Local 
Manager uses for auto registration. The default value is 17146. 
 

17. Enter y to review/modify the default advanced settings. 

Enable Auto Registration – Turns agent auto registration on (default) or off. 

18. Enter y to continue with the installation. The installation proceeds and returns you to 
the main package installation menu. 

20. Enter q to exit the package installation menu. 

Verifying the Compaq Agent   

1. Use the Sun StorageTek Business Analytics Agent Diagnostic Tool to verify agent 
functionality. 

a. Enter the IP Address or Hostname of the server where the agent is installed 
and set the port to 17140 (or select the agent from the drop down list of 
service names). 

b. Click the Get Object List button and you should receive a list of tables 
published by the Storability Compaq Agent. 

c. Select the gsa_storage_unit_config object and verify data is returned. 

 

Figure 26 - Storage Unit Configuration - Compaq Agent 

d. Use the drop down list of objects to verify the other objects published by the 
agent. 

2. To verify the Storability Compaq Agent has registered successfully with its configured 
Local Manager: 
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a. In the Agent location window, enter the IP Address or network resolvable 
Host Name of the Local Manager in the ip address/host name input box and 
set the port to 17146 (or select the Storability Routing Agent from the drop 
down list of service names).  

b. Click the Get Object List button and you should receive a list of tables 
published by the Routing Agent. 

c. Select the gsa_agent_register object. 

d. Confirm that the Storability Compaq agent is registered: 

• Verify that its TCP port number (17140) appears in the “port” field and its 
host name/IP address is listed in the “active_peer” field.  

• Examine the “type” field. If the agent was registered through auto 
registration, the value is AUTO_NET. The value of STATIC means it was 
registered through a SUB_AGENT entry in the Routing Agent’s storability.ini 
file. 

HiCommand Agent 
The Sun StorageTek Business Analytics HiCommand Agent reports configuration and 
storage allocation information for HDS Arrays (e.g., HDS 99xx) accessed through HDS 
HiCommand software. Refer to the Sun StorageTek Business Analytics Support Matrix to 
obtain the latest information on this agent’s software and hardware requirements. 

HiCommand Agent Matrix 
 
Item Description 

Support  Prerequisites  

Verify Ethernet 
connectivity from the 
server running the 
HiCommand Agent to the 
server running the HDS 
HiCommand software 

 

ping <IP Address> 

Verify HiCommand 2.0 or 
2.1 is installed 

 

For Volume Allocation 
Reporting, verify LUN 
Security Option is enabled 
on the array 

 

Restriction  

HiCommand software and 
Storability SNMP Proxy 
Agent 

• Each HiCommand Agent supports only one HiCommand server. 
To support multiple HiCommand servers, install a HiCommand 
Agent for each HiCommand server. The HiCommand Agents 
must be installed on separate servers. 
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• The HiCommand management tool for the HDS 99xx series 
cannot be run from the same machine as the SNMP Proxy 
Agent. 
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Item Description 

Best Practices  

Maximum number of 
monitored arrays 

One HiCommand server per HiCommand agent, with a maximum 
of 5 arrays under management. 

Agent Installation  

HiCommand Agent on 
Windows  

• Windows Local Manager Installation CD (InstallShield) 
• Required Server Access: Administrator privileges 
 

HiCommand Agent on 
Solaris  

• Local Manager Installation CD (Unix) 
• Package Installation 
• Required Server Access: root access and Management Station 

permissions 
 

Configuration 
Parameters 

 

User Name User name for HiCommand connection authentication. For 
example, system. 

Password Password for HiCommand connection authentication. For example, 
manager.  

HiCommand Port TCP Port Number used to communicate with the HiCommand 
software. The default TCP port number is 2001. 

HC_DO_REFRESH Does cache refresh only if set to uppercase YES.  

Local Manager IP address or network resolvable host name of the Local Manager 
to be contacted for agent auto registration. 

Local Manager Registration 
Port 

TCP port number the Local Manager uses for agent auto 
registration. The default value is 17146. 

Enable Auto Registration Turns agent auto registration on (default) or off. 

Table 6 – HiCommand Agent Matrix 

 
Installing the HiCommand Agent - Windows 

1. Insert the Local Manager CD into the CD-ROM drive. 

2. Click Next on the Welcome menu to continue the installation. 

3. Click Yes to accept the terms of the software license agreement. 

4. Click Next. 

5. Review/modify the User Name and Company Name and click Next. 

6. Select the HiCommand Agent checkbox when the screen listing the Sun 
StorageTek Business Analytics Agents for installation appears. (You may also want to 
install the Host Agent as well). Click Next to continue. 



Page 48 Array Agents Installation Guide 
                                              

7. Review the settings and click Next to proceed with the installation. 

8. Specify whether or not to install the new version of the Configuration Tool. 

9. When the Configuration Tool is automatically launched, select File->Edit-> Smart 
Agent Configuration. 

10. Click the HiCommand Agent tab to review/modify the configuration variables: 

Local Manager – Specify the IP address or network resolvable host name of the 
Local Manager to be contacted for agent auto registration. 

Local Manager Registration Port – The port number the Local Manager 
uses for auto registration. The default port number is 17146. 
User Name/Password - Set the user name and password for connection 
authentication to the HiCommand server. 
HC Server IP Address - Specify the HiCommand server’s IP address. You may 
specify multiple IP addresses if you have multiple servers. 

 HC Server Port - Set the TCP port number used to communicate with the 
HiCommand server.  The default port number is 2001. 

 Include HDS9200 Checkbox - Specify whether or not the Agent will be used to 
manage HDS92xx storage arrays. Note: HiCommand does not provide 
performance data. For this reason, it is recommended that you use the DAMP 
HDS Agent for 9200 model arrays. 

 

 

Figure 27 - HiCommand Agent Configuration Window 

11. Click Show Advanced Settings and review/modify the following: 

Enable Auto Registration – Turns agent auto registration on (default) or off. 
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HC Max. Response Time - Sets the maximum command execution time in 
seconds. Note: If you are having difficulty collecting data from your HiCommand 
server, try increasing this value. 

  Array Refresh Interval – Sets the cache refresh interval. 

Enable Performance Refresh – Specifies whether the agent refreshes cache. It 
only refreshes cache if this configuration is set to uppercase YES.  

17. With “Save Configuration Settings” enabled (check mark), select File->Save and 
confirm changes to the storability.ini window. 

18. Select File->Exit to close the Configuration Tool. 

19. View the Readme file and click Finish to complete the installation. 

20. Use the Windows Services panel to restart the agent before you verify agent 
functionality. 

Installing the HiCommand Agent - Solaris  

If you have not already installed the GSMbase and GSMlmutil packages, install these 
packages before you install the HiCommand Agent. 

1. Insert the UNIX Local Manager CD into the CD-ROM drive. 

2. Mount the CD using the command: 

mount –F hsfs –o ro /dev/dsk/c0t6d0s0 /mnt 

3. Change to the directory corresponding to the host’s Solaris Operating System 
version. Solaris 7 or 8 packages are located in /Unix/Solaris/7,8. 

4. Run the package installation utility and the main package installation menu is 
displayed. 

pkgadd –d . 

 

Figure 28 - Select HiCommand Agent Package 
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5. Select to install the GSMhicmd agent; type 13 and press Enter. 

6. Specify the HiCommand server’s IP address.  

7. Enter the TCP port number used to communicate with the HiCommand server, or 
simply press Enter to accept the default port number (2001). 

8. Enter the HiCommand username or simply press Enter to accept the default user 
name (system). 

9. Enter the user’s password or simply press Enter to accept the default password 
(manager).  

10. Confirm the user’s password. 

 

Figure 29 - HiCommand Agent Configuration Settings 

 

11. Specify (y/n) whether or not the agent will be used to manage HDS92xx storage 
arrays. 

Note: HiCommand does not provide performance data. For this reason, it is 
recommended that you use the DAMP HDS Agent for 9200 model arrays. 

12. Type y and press Enter to review/modify the Advanced Settings: 

• Specify (y/n) whether the Agent Monitor will be used to restart the agent, if 
down. 

• Specify the frequency the agent refreshes its data; the default value is 600 
seconds. 

• Specify the maximum command execution time in seconds for agent timeout; the 
default value is 300 seconds. 

• Specify whether the agent refreshes cache. It only refreshes cache if this 
configuration is set to uppercase Y(es). The default value is n(o). 

• Turn agent auto registration on (default) or off. 

• Specify the Local Manager Registration Port for agent auto registration. The 
default port number is 17146. 

• Specify (y/n) whether to restart the agents after the installation has completed. 
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Figure 30 - HiCommand Agent Advanced Settings 

13. Enter y if prompted to install conflicting files. 

14. Type y and press Enter when prompted to confirm continuing with the installation 
of the HiCommand Agent. 

15. The installation proceeds and returns you to the main package installation menu. 

16. Type Ctrl-D and then enter q to exit the package installation menu. 

Verifying the HiCommand Agent  

1. Use the Sun StorageTek Business Analytics Agent Diagnostic Tool to verify agent 
functionality. 

a.   Enter the IP Address or Hostname of the server where the agent is installed 
in the Agent location window. 

b.  Set the port to 17144 (or select the agent from the drop down list of service 
names). 

c. Click the Get Object List button and you should receive a list of tables 
published by the Storability HiCommand Agent. 

d. Select the gsa_storage_unit_config object and verify data is returned. 
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Figure 31 – Verify HiCommand Storage Unit Configuration Object 

e. Use the drop down list of objects to verify all other objects published by the 
agent. 

2. To verify the Storability HiCommand Agent has registered successfully with its 
configured Local Manager: 

a. In the Agent location window, enter the IP Address or network resolvable 
Host Name of the Local Manager in the ip address/host name input box . 

b. Set the port to 17146 (or select the Storability Routing Agent from the drop 
down list of service names).  

c. Click the Get Object List button and you should receive a list of tables 
published by the Routing Agent. 

d. Select the gsa_agent_register object. 
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Figure 32 - Verify HiCommand Agent Registration 

e. Confirm that the Storability HiCommand agent is registered: 

• Verify that its TCP port number appears in the “port” field and its host 
name/IP address is listed in the “active_peer” field.  

• Examine the “type” field. If the agent was registered through auto 
registration, the value is AUTO_NET. The value of STATIC means it was 
registered through a SUB_AGENT entry in the Routing Agent’s storability.ini 
file. 

HDS Agent 
The Storability HDS agent reports configuration and storage allocation information for 
HDS storage arrays accessed through the Disk Array Management Program (DAMP) 
software. Refer to the Sun StorageTek Business Analytics Support Matrix to obtain the 
latest information on this agent’s software and hardware requirements. 
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HDS Agent Matrix 
 
Item Description 

Support 
Prerequisites 

 

Verify Ethernet 
Connectivity to array 

ping <IP Address> 

Verify DAMP CLI is 
installed 

 

For Volume Allocation 
Reporting, verify LUN 
Security Option on 
array 

 

Best Practices  

Agent Deployment It is recommended that you use this agent for HDS 9200 arrays 
rather than the HiCommand agent. 

Security Password Protection Option on array (recommended) 

Agent Installation  

HDS 58xx and 9200 
(DAMP) Agent on 
Windows  

• Windows Local Manager Installation CD (InstallShield) 
• Required Server Access: Administrator privileges 
 

HDS 58xx and 9200 
(DAMP) Agent on 
Solaris  

• Local Manager Installation CD (Unix) 
• Package Installation 
• Required Server Access: root access and Management Station 

permissions 
 

Configuration 
Parameters 

 

Access Code Password to access the array 

HDS Command Path Fully qualified path to the DAMP CLI software 

Status File Path Fully qualified path to the HDS status file 

Local Manager IP address or host name of the Local Manager to be contacted for 
agent auto registration. 

Local Manager 
Registration Port 

TCP port number the Local Manager uses for agent auto 
registration. The default is 17146. 

Enable Auto 
Registration 

Turns agent auto registration on (default) or off. 

Table 7 - HDS Agent Matrix 

Installing the Storability HDS Agent - Windows 

1. Insert the Windows Local Manager CD into the CD-ROM drive. 
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2. Click Next on the Welcome menu to continue the installation. 

3. Click Yes to accept the terms of the software license agreement. 

4. Review/modify the User Name and Company Name and click Next. 

5. Check the HDS Agent checkbox on the screen that allows you to choose the Sun 
StorageTek Business Analytics Agents for installation. You may also want to install 
the Host Agent as well. Click Next to continue. 

6. Review the settings and click Next>. 

7. Specify whether or not to install the new version of the Configuration Tool. 

8. When the Configuration Tool is automatically launched, select File->Edit->Smart 
Agent Configuration. 

9. Click the HDS Agent tab and then click Add to enter the configuration variables and 
click Submit to save them: 

 

Figure 33 - HDS Agent Configuration Window 

• For Local Manager, specify the IP address or network resolvable host name of 
the Local Manager to be contacted for agent auto registration. 

• For Local Manager Registration Port, this value specifies the TCP port number 
the Local Manager uses for agent auto registration. The default port number is 
17146. 

Access Code - Enter the password for the array. 

HDS Command Path - Type the fully qualified path to the Disk Array Manager 
CLI executables.  

10. Click Show Advanced Settings and review/modify the following configuration 
settings: 
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• Enable Auto Registration - This configuration parameter turns agent auto 
registration on (default) or off. 

• Launcher Command Line - The launcher command is used by the HDS agent.  
If you installed the agent into the default location, no changes need to be made 
to this entry.  Otherwise, browse to the location of the HDSAgent.exe file and 
select it. This will correctly create the launcher command line. 

• Status File Path – Enter the full path to the HDS status file. 

• Read Interval – Sets the frequency at which the agent collects performance 
data from the array.  The time is in seconds and is 600 by default. 

• Read Update Interval - Specifies how long data is cached.  The default value is 
3600 seconds. 

11. With “Save Configuration Settings” enabled (check mark), select File->Save and 
confirm changes to the storability.ini window. 

12. Select File-> Exit to close the Configuration Tool. 

13. Use the Windows Services panel to start the agent before you verify agent 
functionality. 

Installing the Storability HDS Agent - Solaris 

1. Insert the UNIX Local Manager CD into the CD-ROM drive. 

2. Mount the CD using the command: 

mount –F hsfs –o ro /dev/dsk/c0t6d0s0 /mnt 

3. Change to the directory for the host’s Solaris Operating System version.  

4. Run the package installation utility and the main package installation menu appears. 

pkgadd –d . 

5. Press Enter and type Ctrl-D to stop scrolling on the second list of package selections. 

6. Select the GSMhds agent; type 11 and press Enter. 

7. Enter the array password or simply press Enter to specify the default value of 
‘password’. 

8. Enter the path to the HDS CLI directory (i.e. /usr/damp). 

9. Enter the path to the HDS library directory (i.e. /usr/damp/lib). 

10. Type y and press Enter to review/edit the Advanced Settings: 

• Enter the desired READ_INTERVAL (in seconds).  This sets the frequency at 
which the agent collects performance data from the array.  The time is in seconds 
and is 600 by default. 

• Enter the desired READ_UPDATE_INTERVAL (in seconds), specifying how long 
data can be cached.  By default, this is 3600 seconds. 

• Enter the IP address or network resolvable host name of the Local Manager to 
be contacted for agent auto registration. 

• Accept the default Local Manager Registration Port number (17146) the Local 
Manager uses for auto registration. 
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• Enable Auto Registration turns agent auto registration on (default) or off. 

11. Enter y to start the agent after installation. 

12. Enter y if prompted to install conflicting files. 

13. Type y and press Enter when prompted to confirm continuing with the installation of 
the GSMhds agent. 

14. The installation proceeds and returns you to the main package installation menu. 

15. Enter q to exit the package installation menu. 

Verifying the HDS Agent  

1. Use the GSM Agent Diagnostic Tool to verify agent functionality. 

a. Enter the IP Address or Hostname of the server where the agent is installed in 
the Agent location window. 

b. Set the port to 17142 (or select the agent from the drop down list of service 
names). 

c. Click the Get Object List button and you should receive a list of tables published 
by the Storability HiCommand Agent. 

d. Select the gsa_storage_unit_config object and verify data is returned. 

e. Use the drop down list of objects to verify the other objects published by the 
agent. 

2. To verify the HDS Agent has registered successfully with its configured Local 
Manager: 

a. In the Agent location window, enter the IP Address or network resolvable Host 
Name of the Local Manager in the ip address/host name input box . 

b. Set the port to 17146 (or select the Storability Routing Agent from the drop down 
list of service names).  

c. Click the Get Object List button and you should receive a list of tables published 
by the Routing Agent. 

d. Select the gsa_agent_register object. 

f. Confirm that the Storability HiCommand agent is registered: 

• Verify that its TCP port number appears in the “port” field and its host 
name/IP address is listed in the “active_peer” field.  

• Examine the “type” field. If the agent was registered through auto 
registration, the value is AUTO_NET. The value of STATIC means it was 
registered through a SUB_AGENT entry in the Routing Agent’s storability.ini 
file. 

ESS Agent 
The ESS Agent reports configuration and allocation information for IBM TotalStorage 
(also called Shark) ESS storage arrays.  Refer to the Sun StorageTek Business Analytics 
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Support Matrix to obtain the latest information on this agent’s software and hardware 
requirements. 

Note: Use the LSI/Engenio agent to collect data from IBM FasT arrays. Sun StorageTek 
Business Analytics 5.0 supports Engenio/LSI firmware version 6.10 with the 5.40 LSI 
Agent. Beginning with 5.40, the agent library from Engenio is forward-compatible; it’s 
no longer firmware- specific.    

ESS Agent Matrix 
 
Item Description 

Support  Prerequisites  

Verify Ethernet connectivity to 
the Windows 2000 server or 
Solaris server running the ESS 
CLI 

ping <IP Address> 

Verify Ethernet connectivity to 
array 

ping <IP Address> 

Verify ESS CLI 2.1.1.8 is 
installed on the ESS 
management server 

 

Verify that an ESS Specialist 
Software Account with read-only 
access exists 

 

Best Practices  

Maximum number of monitored 
arrays 

Five arrays per ESS Agent 

Agent Installation  

IBM ESS Agent on Windows  • Windows Local Manager Installation CD (InstallShield) 
• Required Server Access: Administrator privileges 
 

Configuration Parameters  

IP address of server running 
ESS CLI 

 

User name and password for 
ESS Specialist account 

 

Local Manager IP address or host name of Local Manager to be contacted 
for agent auto registration. 

Local Manager Registration Port TCP port number the Local Manager uses for agent auto 
registration. The default port number is 17146. 

Enable Auto Registration Turns agent auto registration on (default) or off. Note: 
The ESS Agent does not current support auto registration. 
 
 

Table 8 - ESS Agent Matrix 
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Installing ESS Agent - Windows 
1. Insert the Windows Local Manager CD into the CD-ROM drive. The Install Shield-

based installation should be automatically started. 
2. Click Next> on the Welcome menu to continue the installation. 
3. Click Yes to accept the terms of the software license agreement. 
5. Review/modify the User Name and Company Name and click Next>. 
6. Check the ESS Agent checkbox on the screen listing Sun StorageTek Business 

Analytics Agents for installation. You may also want to install the Host Agent as well. 
Click Next> to continue. 

 

 
 

Figure 34 - Agent Selection Dialog 

 
7.  Select the ESS Agent and click Next>. The Installing ESS Agent splash box appears. 
8. Specify whether or not to install the Configuration Tool. 
9. When the Configuration Tool is automatically launched, select File -> Edit -> Smart 

Agent Configuration. 
10. Click the ESS Agent tab and then click Add to enter the configuration variables: 
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Figure 35 - Add ESS Agent Dialog Box 

 
•   IP Addresses (optional comma delimited) Enter the IP address of the ESS CLI, 

and the user name and password of the ESS Specialist Account in the supplied 
input boxes. The configuration details will be written to the storability.ini file in 
the format:  <IPAddr1 of ESS Server, IPAddr2 of ESS Server>. 

 
Notes: Each line represents a single ESS CLI Server. You can provide alternate 
paths to the same ESS Server by entering multiple IP addresses on the same 
line in the file. No space should be entered between the IP address and comma. 
 

•  User Name – Enter ESS Specialist user name 
•  Password – Enter password for this user 
 

 

 
 

Figure 36 - ESS Agent Configuration Tab 

 
11. Click Submit. 
12. Review/modify the following: 

Local Manager – Specify the IP address or host name of the Local Manager to 
be contacted for agent auto registration. 
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Local Manager Registration Port – Is the port number the Local Manager uses 
for auto registration; default port number is 17146. 

Pathname to ESS – Enter the fully qualified pathname to the ESS CLI including 
the executable name; may click the Folder icon to browse and locate the file. 

13. Click Show Advanced Settings and review/modify the following: 

Enable Auto Registration – Turns agent auto registration on (default) or off. 

Data Cache Refresh Interval - Specifies how long data can be cached. The 
time is specified in seconds and is 3600 seconds by default. 

Performance Data Cache Refresh Interval – Sets the frequency at which the 
agent collects performance data from the array.  The time is specified in seconds 
and is 120 by default. 

14. Select File->Save and then confirm saving changes to the storability.ini file. 

15. Select File->Exit to close the Configuration Tool. 

16. Use the Windows Services panel to start the agent before you verify agent 
functionality. 

Installing the ESS Agent - Solaris  

1. Insert the UNIX Local Manager CD into the CD-ROM drive. 

2. Mount the CD using the command: 

mount –F hsfs –o ro /dev/dsk/c0t6d0s0 /mnt 

3. Change to the directory corresponding to the host’s Solaris Operating System 
version.  

4. Run the package installation utility. 

pkgadd –d . 

5. Select to install the GSMess agent. 

6. Review/modify the configuration variables: 

ARRAY_FRESH_INTERVAL – Specifies how long data can be cached. The time is 
specified in seconds and is 3600 by default. 

READ_FRESH_PERF INTERVAL - Sets the frequency at which the agent collects 
performance data from the array.  The time is in seconds and is 120 by default. 

ESS_IP – Enter the IP address of the ESS Server, and user name and password of 
the ESS Specialist account when prompted. The configuration details will be written 
to the storability.ini file in the format: 

 <IPAddr1 of ESS Server,IPAddr2 of ESS  Server>|<ESS Specialist 
username>|<password> 

Notes: Each line represents a single ESS Server. You can provide alternate paths to 
the same ESS Server by entering multiple IP addresses on the same line. Do not 
enter a space between the IP address and the comma. 

Local Manager – Specify the network resolvable name or IP address of the Local 
Manager to be contacted for agent auto registration. 
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Local Manager Registration Port – Review/modify the TCP port the Local Manager 
uses for agent auto registration. The default port number is 17146. 

ESS_CMD_PATHNAME – Enter the fully qualified pathname to the ESS CLI 
including the executable name. 

Enable Auto Registration – Accept that auto registration is enabled (true); set this 
configuration parameter to false to disable auto registration. 

7. Type y to (re)start the agents after the install has completed. 

8. Type y to continue if prompted to install conflicting files.  

9. Type y and press Enter to confirm the continuation of the installation, when 
prompted. 

10. Type q and press Enter to exit the package installation menu. 

Verifying the Storability ESS Agent  

1. Use the Sun StorageTek Business Analytics Agent Diagnostic Tool to verify agent 
functionality. 

a. Enter the IP Address or Hostname of the server where the agent is installed. 

b. Set the port to 17154 (or select the agent from the drop down list of service 
names). 

c. Click the Get Object List button and you should receive a list of tables 
published by the Storability ESS Agent. 

d. Select the gsa_storage_unit_config object and verify data is returned. 

e. Use the drop down list of objects to verify the other objects published by the 
agent. 

2. To verify the ESS Agent has registered successfully with its configured Local Manager: 

a. In the Agent location window, enter the IP Address or network resolvable 
Host Name of the Local Manager in the ip address/host name input box . 

b. Set the port to 17146 (or select the Storability Routing Agent from the drop 
down list of service names).  

c. Click the Get Object List button and you should receive a list of tables 
published by the Routing Agent. 

d. Select the gsa_agent_register object. 

g. Verify the Storability ESS Agent is registered: 

• Verify that its TCP port number appears in the “port” field and its host 
name/IP address is listed in the “active_peer” field.  

• Examine the “type” field. If the agent was registered through auto 
registration, the value is AUTO_NET. The value of STATIC means it was 
registered through a SUB_AGENT entry in the Routing Agent’s storability.ini 
file. 
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Engenio/LSI Agent 
The Storability Engenio/LSI Agent reports configuration and storage allocation 
information for LSI controller-based disk arrays, StorageTek FlexLine arrays, and IBM 
FAStT arrays.  Refer to the Sun StorageTek Business Analytics Support Matrix to obtain 
the latest information on this agent’s software and hardware requirements. 

LSI Agent Matrix 
 
Item Description 

Support 
Prerequisites 

 

Verify Ethernet 
connectivity from agent 
platform to the disk 
array 

ping <IP Address> 

Verify supported 
controller firmware 
version 

There is a unique LSI agent version to support each controller 
firmware version that Storability currently supports.  Multiple 
versions of the LSI agent are included on the Local Manager 
Installation media for Windows or Solaris.  

Best Practices  

Maximum number of 
monitored arrays 

You may need to use a separate instance of the agent for each 
array firmware version you have deployed (i.e., if you have 2 
arrays with different firmware versions, you may need to deploy 2 
agents.). Beginning with 5.4, the agent library from Engenio is 
forward compatible; it is not longer firmware specific. 
 
Sun StorageTek Business Analytics 5.0 supports Engenio/LSI 
firmware version 6.10 with the 5.40 LSI agent.   

Agent Installation  

LSI Agent on Windows  • Windows Local Manager Installation CD (InstallShield) 
• Required Server Access: Administrator privileges 
 

LSI Agent on Solaris  • Local Manager Installation CD (Unix) 
• Package Installation 
• Required Server Access: root access and Management Station 

permissions 
 

Configuration 
Parameters 

 

Primary IP Address • IP address for the primary controller in the array or a proxy 
server 

Alternate IP Address • IP address for a second controller in the array 

Local Manager • IP address or host name of the Local Manager to be contacted 
for agent auto registration. 

Local Manager 
Registration Port 

• TCP port number the Local Manager uses for agent auto 
registration; the default value is 17146. 
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Item Description 

Enable Auto 
Registration 

• Turns agent auto registration on (default) or off. 

Table 9 - LSI Agent Matrix 

Installing the LSI Agent – Windows 
You must load the correct LSI agent binary to match the version of the firmware. 
Currently supported firmware versions are 5.01, 5.21, 5.30, 5.33, 5.36 and 5.40. The 
location of these agents is as follows: 
  

/Win32/LSI agents/lsi_agent-fw5.xx.exe  
 
For Windows servers, first perform the Local Manager installation and then replace the 
agent (binary) with the appropriate one for the version of the controller firmware 
running on the LSI agent array. 

1. Insert the Windows Local Manager CD into the CD-ROM drive. 

2. Click Next on the Welcome menu to continue the installation. 

3. Click Yes to accept the terms of the software license agreement. 

4. Review/modify the User Name and Company Name and click Next. 

5. Check the LSI Agent checkbox on the screen that lists Sun StorageTek Business 
Analytics Agents for installation. You may also wish to install the Host Agent. Click 
Next>. 
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Figure 37 - Agent Selection Dialog 

6. Review the settings and click Next>. The Installing LSI Agent splash box is 
displayed. 

7. Specify whether to install the Configuration Tool. 

8. When the Configuration Tool is automatically launched, choose File -> Edit -> 
Smart Agent Configuration. 

9. Click the LSI Agent tab and click Add. In the window below, note that the IP 
addresses are for illustrative purposes only and will not appear when you open the 
tab. 
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Figure 38 - LSI Agent Configuration Settings 

10. Enter the following configuration parameters and click Submit. 

Primary IP Address – Enter the IP address for the primary controller in the 
array. 
 
Alternate IP Address – Enter the IP address for a secondary controller in the 
array. The IP Address for all controllers must be provided in order to collect 
performance for all controllers. 
 

11. For Local Manager, enter the IP address or host name of the Local Manager to be 
contacted for auto registration. 

12. For Local Manager Registration Port, specify the TCP port number the Local 
Manager uses for agent auto registration. The default port number is 17146. 

 
13. Click Show Advanced Settings to review/modify the following parameters: 
 

Enable Auto Registration – Turns agent auto registration on (default) or off. 
Data Cache Refresh Interval – Specifies the frequency the agent refreshes 
cached data. The default value is 600 seconds. 
Performance Sampling Interval - Specifies how often (in seconds) the 
performance information is collected. 
Performance summary interval – Specifies how long (in seconds) the 
performance information is stored before being purged. 

14. Select File->Save and then confirm changes to the storability.ini window. 

15. Select File->Exit to close the Configuration Tool. 

16. Use the Windows panel to start the Storability LSI Agent before you verify agent 
functionality. Services 
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Installing the LSI Agent - Solaris 

If you have not already installed the GSMbase and GSMlmutil packages, install these 
packages before you install the LSI Agent. 

Multiple versions of the LSI agent are included on the Local Manager media. You must 
load the correct agent to match the version of the controller firmware. Currently 
supported firmware versions are 5.01, 5.21, 5.30, 5.33, 5.36 and 5.40. There is an LSI 
agent version to support the different firmware versions that Storability currently 
supports. For Solaris hosts, the correct package is selected from the pkgadd main menu 
and the proper agent will be installed. 

1. Insert the UNIX Local Manager CD into the CD-ROM drive. 

2. Mount the CD using the following command, for example: 

 mount –F hsfs –o ro /dev/dsk/c0t6d0s0 /mnt 

3. Change to the directory corresponding to the host’s Solaris Operating System 
version.  

4. Run the package installation utility and the main package installation menu is 
displayed. 

pkgadd –d . 

5. Select to install LSI agent package for your firmware revision. 

 

Figure 39 - LSI Agent Package Selections 

6. Specify the Primary IP address for the array or the IP address of the proxy server 
and press Enter. 

7. Enter the Secondary IP address for the array (if applicable) and press Enter. 

8. Press Enter on an empty line after you have finished specifying the above IP 
addresses. Note: Each IP address is the address for a single controller in the array. 
The IP Address for all controllers must be provided in order to collect performance 
for all controllers. 
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Figure 40 - LSI Agent Configuration Settings 

9. Type y and press Enter to review/modify the Advanced Settings. 

• Specify (y/n) whether the AgentMonitor will be used to restart the agent, if down. 

•   Specify the frequency that the agent refreshes its cache (configuration and 
performance data); the default value is 600 seconds. 

•   Specify how often performance data is sampled. 

•   Specify the period of time for which performance data should be summarized 
(e.g., provide an hourly average). 

•   Review/modify whether (y/n) agent auto registration is turned on (default). 

•   Specify the IP address or host name of the Local Manager to be contacted for 
agent auto registration. 

•   Review/modify the TCP port number the Local Manager uses for auto 
registration; the default value is 17146. 

•   Specify (y/n) whether to restart the agents after the installation has been 
completed. 

 

Figure 41 - LSI Agent Advanced Settings 

10. Enter y if prompted to install conflicting files. 

11. Enter y and press Enter to confirm the continuation of the LSI Agent installation, 
when prompted. 

12. The installation proceeds and returns you to the main package installation menu 
when it is finished. 
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13. Type Ctrl-D and enter q to exit the package installation menu. 

Verifying LSI Agent  

1. Use the Agent Diagnostic Tool to verify agent functionality. 

a.   Enter the IP Address or Hostname of the server where the agent is installed. 

b. Set the port to 17151 (or select the agent from the drop down list of service 
names). 

Click the Get Object List button and you should receive a list of tables  

c. Select the gsa_storage_unit_config object and verify data is returned. 

 

Figure 42 - Storage Unit Configuration Object - LSI Agent 

d. Use the drop down list of objects to verify the other objects published by the 
agent. 

2. To verify the Storability LSI Agent has registered successfully with its configured Local 
Manager: 

a. In the Agent location window, enter the IP Address or network resolvable 
Host Name of the Local Manager in the ip address/host name input box. 

b. Set the port to 17146 (or select the Storability Routing Agent from the drop 
down list of service names).  

c. Click the Get Object List button and you should receive a list of tables 
published by the Routing Agent. 

d. Select the gsa_agent_register object. 

• Verify that its TCP port number appears in the “port” field and its host 
name/IP address is listed in the “active_peer” field.  

• Examine the “type” field. If the agent was registered through auto 
registration, the value is AUTO_NET. The value of STATIC means it was 
registered through a SUB_AGENT entry in the Routing Agent’s storability.ini 
file. 
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XP Agent 
The XP Agent reports configuration and storage allocation for the HP-XP family of arrays 
(except for the XP256 series of arrays). 

Refer to the Sun StorageTek Business Analytics Support Matrix to obtain the latest 
information on this agent’s software and hardware requirements. 

XP Agent Matrix 
 
Item Description 

Support  
Prerequisites 

 

Verify Command View 
XP CLI version 1.8 or 
higher is installed 

Refer to the next section. 

Verify Ethernet 
connectivity to the 
CommandView server 
from the server running 
the XP Agent  

ping <IP Address> 

Verify access to the 
CommandView XP 
account with read 
privileges 

 

Verify Windows 2000 
server equipped with 
Service Pack 2 or 
higher 

Select Start->Settings->Control Panel->System to verify this 
requirement. 

Agent Installation  

 XP Agent on Windows  • Windows Local Manager Installation CD (InstallShield) 
• Required Server Access: Administrator privileges 
 

XP Agent on HP-UX •  root user privileges 

Configuration 
Parameters 

 

User Name CommandView XP account with read or greater privileges 

Password Password for that user account 

CommandView 
Directory 

Fully qualified directory containing the CVCLI and supporting files. 
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Item Description 

CommandView CLI File 
Name 

CVCLI command file name. 

Local Manager IP address or host name of Local Manager to be contacted for 
agent auto registration. 

Local Manager 
Registration Port 

TCP port number the Local Manager uses for agent auto 
registration; the default port number is 17146. 

Enable Auto 
Registration 

Turns on (default) or off agent auto registration. 

Mapped Unassigned 
Alias 

Specify a wwn_alias and wwn_id to report for mapped but 
unassigned volumes, which would otherwise be reported as 
unassigned. These are often Business Copy volumes. 

Array Refresh Interval Never change the default value. 

Array Update Interval Interval to collect performance data. 

Table 10 - HP XP Agent Matrix 

HP XP CommandView CLI Requirement 
The HP XP CommandView CLI must be configured properly to communicate with the 
CommandView Server.  If the agent is installed on the CommandView server, 
no modification to the CommandView CLI is normally required.  If the agent 
is installed on a separate system, the text file "CVCLI.properties" in 
the CVCLI installation directory must be modified.  
 
Edit this file and change the line: 

SERVLET_URL=http://localhost/hpstmgmt/servlet/MarsDm 
 
To: 
 

SERVLET_URL=http://servername/hpstmgmt/servlet/MarsDm 
 
replacing servername with the hostname or IP address of the CommandView 
server. 
 
The CommandView CLI requires a valid CommandView account with read 
privileges or higher to connect to the CommandView server.  This is an 
application username and password within CommandView, which the Command 
View administrator should be able to provide.  The default read-only 
Account, username=user password=user, will work unless the defaults 
have been changed. 
 
Before you install the Storability XP Agent, verify proper operation of the CommandView 
CLI by running a command.  
 
1. Open a command window. 
2. Change directory to the CommandView CLI installation directory, which contains 

CVCLI.properties and CVCLI.bat. 
3. Type the command: 
    cvcli -p username  password 
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The output should be similar to: 
Version : CV1.80.00 
Loading XML Parser for validation, Please wait..... 
Commands Loaded .... 

4. Enter the list device command 
 

CV_CLI> list device 
 

The command output should be similar to: 
Sending Request to CV server ... 
Array Sno,IpAddress,Array Type,Location,Contact 
info,Manage,Ftp,Protocol 
12345,10.10.10.10,XP 512,SanLab,John Doe,manage,ftp,snmp 
67890,10.10.10.11,XP 512,SanLab,John Doe,manage,ftp,snmp 
CV_CLI> exit 

 
Important Note: 
If the above commands fails or "list device" does not show any array devices, 
troubleshoot the CommandView CLI installation before proceeding to install the 
Storability XP Agent. When troubleshooting, be aware that the CVCLI.properties file 
must contain an entry like: 
 

SERVLET_URL=http://servername/hpstmgmt/servlet/MarsDm 
 

The hostname part of the URL must be the name or address of the Command 
View XP server.  The default is installed with hostname "localhost", and 
must be changed if the localhost is not the CommandView XP server.  Also, 
if CommandView XP was installed with SSL security enabled, the URL must be 
changed to https instead of http. 
 
Installing the Storability XP Agent - Windows 

This section describes how to install and configure the HP-XP Agent on a Windows 
platform.  

1. Insert the Windows Local Manager CD into the CD-ROM drive. 

2. Click Next> on the Welcome menu to continue the installation. 

3. Click Yes to accept the terms of the software license agreement. 

4. Click Next>. 

5. Review/modify the User Name and Company Name and click Next. 

6. Check the HP-XP Agent checkbox on the screen that lists the Sun StorageTek 
Business Analytics Agents for installation. You may want to install the Host Agent as 
well. Click Next. 

7. Review the settings and click Next to continue. 

8. Click Yes to acknowledge the informational dialog box that specifies the 
CommandView CLI (CVCLI) must be installed and properly configured for the HP-XP 
agent to operate correctly . The “Installing HP-XP Agent” popup window appears. 

9. Specify whether or not to install the Configuration Tool. 
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10. When the Configuration Tool is automatically launched, select File->Edit->Smart 
Agent Configuration. 

11. Click the HPXP Agent tab and click Add. 

 

Figure 43 – HP XP Agent Tab in Configuration Tool 

12.  Click Add and the “Add property” dialog appears. It allows you to specify user 
accounts in the dialog box: 

User Name - CommandView XP account with read or greater privileges. 

Password - Password for the user account specified above. 

13. Click Submit to add the user account. 

14. Review/modify the following configuration variables:  

• Local Manager – Network resolvable host name or IP address for the Local 
Manager with which the agent is to be registered if auto registration is enabled. 

• Local Manager Registration Port – Accept default TCP port number of 17146. 

• Directory Containing the CVCLI software – Fully qualified directory 
containing the CVCLI and supporting files. This directory must contain the CVCLI 
batch file or executable, and the CVCLI.properties file.   

• Filename for the CVCLI executable - Name of CVCLI command file. The 
expected value for Windows is cvcli.bat. 

15. Click Show Advanced Settings and review/modify the following variables: 

• Enable Auto Registration – Turns agent auto registration on (default) and off. 
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• MAPPED_UNASSIGNED_ALIAS - Specify a wwn_alias and wwn_id to report for 
mapped but unassigned volumes, which would otherwise be reported as 
unassigned. These are often BusinessCopy volumes. 

• ARRAY_FRESH_INTERVAL – Do not change the default setting (0). 

• ARRAY_UPDATE_INTERVAL - Specify the frequency in seconds to obtain 
updated data from the CVCLI interface. It is recommended that you do not set this 
variable to a value less than 600 seconds. 

16. Select File->Save and confirm saving the changes. 

17. Select File->Exit to close the Configuration Tool. 

18. View and then close the Readme file and click Finish. 

19. Use the Windows Services panel to restart the agent before you proceed to verify 
agent functionality. 

Installing the XP Agent on HP-UX  

The XP Agent prerequisites are described in the Sun StorageTek Business Analytics 
Support Matrix. Verify these prerequisites are met on the HP-UX server before you 
proceed to installing this agent. 

Note: The HP XP CommandView CLI must be configured properly to communicate with 
the CommandView Server. See the previous HP XP CommandView CLI section for 
additional information on this support requirement. 

1. Mount the installation CD in the CD-ROM drive of the HP-UX server. 

2. Change directory to the software installation directory. For example: 

cd /cdrom/UNIX/HP_UX/11.00 

3. Run the XP Agent installation script. For example: 

./xpAgent-install.sh\;1 xp_Agent-hpux.tgz\;1 

4. Read the displayed information on the agent, which should be similar to the text that 
follows: 

x opt/storability/bin/xpAgent, 3919872 bytes, 7656 tape blocks 

x opt/storability/bin/inicrypt, 2015232 bytes, 3936 tape blocks 

x opt/storability/tmp/request, 6559 bytes, 13 tape blocks 

x opt/storability/tmp/agents, 92 bytes, 1 tape blocks 

x opt/storability/tmp/install.sh, 660 bytes, 2 tape blocks 

x opt/storability/tmp/i.cfg, 1956 bytes, 4 tape blocks 

x opt/storability/tmp/i.touch, 343 bytes, 1 tape blocks 

x opt/storability/tmp/storability.ini, 290 bytes, 1 tape blocks 

x opt/storability/GSM-license.txt, 9930 bytes, 20 tape blocks 

x opt/storability/lgpl-license.txt, 26532 bytes, 52 tape blocks 

x opt/storability/openssl-license.txt, 6279 bytes, 13 tape blocks 

x opt/storability/pcre-license.txt, 1944 bytes, 4 tape blocks 

x opt/storability/snia-license.txt, 23716 bytes, 47 tape blocks 

x opt/storability/snmp++-license.txt, 1238 bytes, 3 tape blocks 

x opt/storability/xercesc-license.txt, 2697 bytes, 6 tape blocks 
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x sbin/init.d/xpAgent, 1567 bytes, 4 tape blocks 

x sbin/rc1.d/K248xpAgent symbolic link to ../init.d/xpAgent 

x sbin/rc3.d/S122xpAgent symbolic link to ../init.d/xpAgent 

This version of GSMhpxp was built on HP-UX B.11.00 and has 

not been tested on HP-UX B.11.11. 

5. At the “Continue with installation? [n]” prompt, type y and press Enter to continue. 

6. At the “Location of cvcli?” prompt, type the fully qualified path to the directory 
containing the CVCLI and supporting files and press Enter. This directory must 
contain the CVCLI batch file or executable, and the CVCLI.properties file.   

7. At the “Username for CommandView? [admin]” prompt, type the CommandView 
administrative user name or press Enter to accept the default user name (admin). 

8. At the “Password for CommandView?” prompt, type the password for that 
CommandView user. 

9. At the “Confirm password?” prompt, retype the password you entered. 

10. At the “(Re-)start agents after install [y]” prompt, press Enter to restart the agents 
after the installation is completed. 

The installation is completed and the agent is started. 

/opt/storability/etc/storability.ini:   updated. 

/opt/storability/etc/agents:    updated. 

/opt/storability/data/Message.log 

Starting Storability HP XP agent:       xpAgent started 

Agent Auto Registration 
• To configure agent auto registration, you can add the HP XP Agent to a Local 

Manager Routing Agent configuration or manually add the required entries to the 
storability.ini file.  

 
Sample entries follow. 
 

GSM_LM_HOST = 10.192.252.53 
      GSM_LM_PORT = 17146 

       GSM_ENABLE_LM_REGISTRATION = true 
 
Verifying the XP Agent 

1. Use the GSM Agent Diagnostic Tool to verify agent functionality. 

a. Enter the IP Address or Hostname of the server where the agent is installed, 
and select the Storability XP Agent from the drop down list of service names. 

b. Click the Get Object List button and you should receive a list of tables 
published by the HP XP Agent. If unsuccessful, verify the agent is running. 

c.   Select the storage_unit_config object published by the agent. Verify the 
ip_address, array_id, su_id, configuration, type, status, primary, and 
timestamp fields are reported. 
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Figure 44 - Storage Unit Configuration Object for XP Array 

d. Collect all other tables published by the agent. 

Note: The agent does not report performance, local copy (Business Copy XP), or 
remote copy (Continuous Access XP) information due to limitations of the 
CommandView interface used to obtain array data.  In particular, this means the 
following tables are expected to be empty: 

• gsa_fctrl_perf 

• gsa_cache_perf 

• gsa_disk_perf 

• gsa_local_unit_mapping 

• gsa_remote_unit_mapping 

• gsa_su_reference_config 

3. To verify the Storability Compaq Agent has registered successfully with its 
configured Local Manager: 

a. In the Agent Location window, enter the IP Address or network 
resolvable Host Name of the Local Manager in the ip address/host name 
input box. 

b. Set the port to 17146 (or select the Storability Routing Agent from the 
drop down list of service names).  

c. Click the Get Object List button and you should receive a list of tables 
published by the Routing Agent. 

d. Select the gsa_agent_register object. 
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e. Verify it reports the XP Agent in the “active_peer” field by IP address with 
a port number of 17158. 

Verifying Management Console Functionality 
The following procedure describes how the administrator verifies the Sun StorageTek 
Business Analytics Array Agent reports in the Management Console. Refer to the 
Administration chapter to obtain information on the administrative menus you can 
access from the Tools pull down menu, including the Data Polling Schedule and 
Change Dashboard menus. 
 
1. Log in to the Management Console as an administrative user (e.g., gsmuser) or 

another user whose views provide access to the desired assets (e.g., sites). 
2. Verify that your customized Home Page includes the Storage Allocation Overview 

dashboard (or use Change Dashboard to assign one). 
3. Select Tools->Data Polling Schedule. 
4. Use the Collect Now button to collect the Array (collection type) Configuration 

(Collection Metric) data using a polling schedule that includes the specific site or all 
sites. 

5. After you wait approximately thirty seconds, use the Collect Now button to collect 
the Array (collection type) Allocation (Collection Metric) data using a polling schedule 
that includes the specific site or all sites. 

6. After you wait approximately thirty seconds, use the Collect Now button to collect 
the Array (collection type) Performance (Collection Metric) data using a polling 
schedule that includes the specific site or all sites. 

7. Close the Data Polling Schedule window. 
8. Select Tools->Database->Refresh Capacity Allocation for the desired site to 

refresh the array data displayed in the Storage Allocation Overview pane on the 
home page. 

9. Verify the Storage Capacity Allocation Overview pane reports information on the 
array being monitored by the specific array agent you are verifying.  

 

 

Figure 45 - Storage Capacity Allocation Overview 

 
10. Click the Storage Array ID link in the pane and the Detailed Array Configuration 

report appears. 
11. Verify the Site and Array ID are reported properly on the General tab. 
12. Verify the tabular device reports by clicking the respective tabs: Ports, Volume 

Configuration, Volume Allocation, Performance, Trending, and Asset. 
Keep in mind that some device-specific tabs may not display data because they are 
not available for that particular array (e.g., Performance for an XP array). In these 
instances, the window may display “No Data Found” or an empty table. 
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Array Agent Troubleshooting 
 

1. Verify system/agent prerequisites – Refer to the Sun StorageTek Business 
Analytics Support Matrix that is located on the Documentation CD to verify the most 
recent support requirements for the agent. 

2. Verify Agent Functionality - Use the Sun StorageTek Business Analytics Agent 
Diagnostic Tool to save the output for all the tables if escalating a problem to Sun 
Support. 
a. Launch the Sun StorageTek Business Analytics Agent Diagnostic Tool from the 

Storability Program Folder. 
b. Enter the IP Address or Hostname of the server where the agent is installed 

and set the port number by selecting the particular Array Agent (e.g., Storability 
LSI Agent) from the drop down list of service names. 

c. Click the Get Object List button and you should receive a list of tables published 
by the agent. If unsuccessful, verify the Ethernet connectivity to the server 
running the agent and that the Array Agent is running. 

d. Select the alerts-3_1 table and examine the Description column for each 
reported alert. 

e. Select File->Save All and respond OK to “This action will network fetch all 
objects published by the currently specified agent and save the data to a single 
file.”  

f. When the Save As dialog appears, enter a meaningful file name and click OK to 
initiate the collection. 

g. Enter the desired file name and click OK.  
 

3. Review the Message Log – Review/collect the Message.log file that contains 
information on startup errors, configuration errors, or errors regarding accessing 
data or parsing output. 
 
Windows 

 
• Message.log is located by default in: <drive>:\Program 

Files\Storability\GSM\Agents\Storability <Array Agent Name> Agent folder. 
• You can enable debug level logging by appending LOG_SEVERITY=Debug to 

the <Array Agent> section of the storability.ini file (if Storability Support 
requests it). 

 
Solaris 

 
• GSM agents’ common Message.log file located by default in: /opt/storability/data. 
• You can enable debug level logging by appending LOG_SEVERITY=Debug to the 

<Array Agent> section of the storability.ini file (if StorageTek Support (Technical 
Excellence Center) requests it). 
 

4. Verify Local Manager Registration – Collect the configured Routing Agent’s 
gsa_agent_register object to verify the Array Agent has a STATIC or AUTO_NET 
type registration. If not, use the Sun StorageTek Business Analytics Agent Diagnostic 
Tool to: 

 Verify the gsa_ini_control object shows a valid IP address or network 
resolvable host name for the Local Manager used for auto registration. 

 “Enable auto registration” setting has a value of “true” 
 
5. Review the Routing Agent Message Log – Review/collect the Routing Agent 

Message Log to check for errors related to Ethernet connectivity or other problems 
collecting the Array Agent’s published objects.  
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6. Confirm Polling Schedules – Using the Management Console’s Data Polling 
Schedule menus under Tools, review/modify the existing Polling Schedules for the 
Collection Type of Array for all sites.  

 Verify the Collection Type of Array exists in the Polling Schedules window. 
 Verify the scheduled frequency: Start Date/Time and recurrence. 
 Try a Collect Now (on-demand) agent data collection. 

7. Review Aggregator Message Log – Wait a few minutes after you perform the 
above step and open the Aggregator’s Message Log in a text editor. 

 Verify that the Array objects are being requested (e.g., 
gsa_storage_unit_config). 

 Verify the Data Aggregator received array data. 
 Verify the Data Aggregator inserted the database without logged errors. 

 
Note: The log contains two entries, TID (Transaction ID) and SID (Session ID), 
which can help you locate (e.g., Find) and view relevant logged entries. For 
scheduled polling requests, the TID will be equal to the Job ID in the Polling menu. 
Each SID is a unique identifier for a particular agent data collection session. For on-
demand polling requests, the TID is a uniquely generated TID (not the Job ID) and 
SID, and the TID and SID will be equal to the same integer value.  

 
8. Check the assurent database – The assurent database is the data repository for 

your Sun StorageTek Business Analytics application. Use any MS SQL Query 
interface, such as isql, to verify rows have been inserted into the array-related 
tables, such as the gsa_storage_unit_config_v2 table. 

 
9. Verify Management Console Functionality – As a final step in the agent 

troubleshooting procedure, minimally verify the monitored arrays now appear in the 
Storage Allocation Overview dashboard or in the Asset Management report for the 
site. 

Upgrade Array Agent 
For upgrading a Sun StorageTek Business Analytics Array Agent, uninstall the current 
Array Agent before you upgrade by installing the Sun StorageTek Business Analytics 5.0 
Array Agent for the current software version. 

Uninstall Array Agent - InstallShield 
1. Select Start->Program Files->Storability->Uninstall->Uninstall Local 

Manager      
Or: 
Start->Program Files->Storability->Uninstall->Uninstall <Array Agent 
Name>.  The Storability Uninstall dialog appears. 

2. Click the checkbox for the particular Array Agent (e.g., Clariion Agent). 
3. Click Next>. The Question dialog appears. 
4. Click Yes to confirm uninstalling the agent. An uninstalling agent splash box appears 

as each selected agent is uninstalled. 
5. When the InstallShield Wizard Complete dialog box appears, click Finish. 

Uninstall Cygwin (HSG80 Agent on Windows Only) 
The cron service runs as the local SYSTEM account and takes ownership of  
certain files and directories.  Before uninstalling CYGWIN, run the following  
commands, in a CYGWIN command window as an Administrator: 
 

umount -s /app 
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cygrunsrv -R cron 
cygrunsrv -R conserver  # if installed 
cd / 
chown -R Administrator:Administrators var tmp 
chmod -R g+w var tmp 

 
This will take ownership and add write permission to all files under /var and /tmp. Next, 
exit ALL CYGWIN applications (including any bash shell windows). 
 
After the above commands have completed, it should be possible to delete the  
entire CYGWIN installation directory. 
 
Note:  If all users of CYGWIN are in the Administrators group, the above steps should 
be sufficient.  However, if there are CYGWIN users not in the Administrators group with 
home directories, then possibly the "home" directory will need to be added to the above 
list of directories for "chown" and "chmod". 

Uninstall Array Agent – Solaris 
1. Create a backup copy of the existing storability.ini file. 

2. Type: 

pkgrm GSM<array agent name> e.g., GSMemc 

3. At the “do you want to remove this package” prompt, enter y and press Enter. 

4. At the “do you want to continue the removal of the package?” prompt, type y and 
press Enter. The “Removal of GSM<agent name>” agent was successful” message 
should appear to indicate the package was removed successfully. 

Reinstall Array Agent – Non-Solaris UNIX Host 
The reinstallation procedure for all Storability agents supported on non-Solaris UNIX 
hosts, such as the EMC Agent on an IBM AIX server, requires that the installer perform 
the following steps before running the agent’s installation script: 

1. Make a backup copy of the existing agent configuration file (storability.ini). 

2. Make a backup copy of the contents of /opt/storability/etc/agents. 

3. Open the existing agent configuration file (storability.ini) in a system text editor. 

4. Locate the configuration section for the agent to be reinstalled. 

5. Delete all existing configuration settings for that Storability agent. 

6. Save the modified agent configuration file. 

7. Remove the existing /opt/storability/etc/agents directory. 

At this point, you may reinstall the agent using the agent’s installation script (e.g., 
emcAIX-install.sh). 

 




