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Introduction to Library Agents 
Sun StorageTek Business Analytics provides tape library agents that support various 
models of IBM and STK libraries. The library agents report on a library’s robot, slots, 
contents (i.e., tapes), interfaces, and drive interfaces. To obtain the latest information of 
agent support prerequisites: 

• Refer to the Sun StorageTek Business Analytics Support Matrix for the latest 
information on supported libraries and their support prerequisites.  

• Consult the Sun StorageTek Business Analytics Agent Features Quick Facts Sheet 
for a summary of the features supported by a particular agent, which may vary 
depending on data collection access method, platform or software components 
present. 

Note: With the acquisition of StorageTek, Sun Microsystems has re-branded and re-
named Global Storage Manager (GSM) as Sun StorageTek Analytics, a member of the 
Enterprise Storage Manager portfolio of software solutions. The functionality of Business 
Analytics is identical to GSM, only the name has changed. 

Sun StorageTek Business Analytics 5.0 SP1 provides three agent installation CDs: 
Windows Local Manager, Solaris Local Manager, and UNIX Agents (HP-UX and IBM AIX). 
To upgrade a Library Agent, uninstall the previously installed Library Agent before you 
install the Sun StorageTek Business Analytics 5.0 Library Agent. The decision to upgrade 
an existing Library Agent may be performed because: 

• The Sun StorageTek Business Analytics Release Notes indicate a problem has been 
fixed or a new feature added (e.g., SMIS Tape Library Agent). 

• The upgrade is recommended by Sun. 

Automatic and Static Agent Registration 
Automatic agent registration is a configuration option for agent data collection. In the 
storability.ini file, automatic agent registration is configured as follows: 
 
• Local Manager – Specify the IP address or host name of the Local Manager to be 

contacted to activate agent registration.  
• Local Manager Registration Port – Specifies the TCP port number used by the 

Local Manager for agent auto registration. The default port number is 17146. 
• Enable Auto Registration – Turns agent auto registration on (default) or off. 
 
To register the Library Agent statically, proceed as follows: 
• Enter false in the Enable Auto Registration field.  
• Modify the Routing Agent static agent configuration to include an entry (port 

number|<agent IP address/name>)  
• Restart the Routing Agent 
• Restart the companion Central Manager agents 
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Library Agent Objects 
Table 1 lists the objects that all Sun StorageTek Business Analytics Library Agents 
publish.  
 
Table Columns 
gsa_alerts-3-0 sourceip, priority, alert_id, progname, alert, time, 

firsttime, refreshedtime, int1, text1, text2. 
gsa_agent_version-2-0 ip_address, agent_name, version, compile_time, 

managed_entities, tz_name, tz, timestamp 
gsa_cache_control-2_0 ip_address, port, table_name, cache_age, 

last_update_request_length, update_request_pending, 
group_name, group_master, timestamp 

gsa_ini_control-2_0 ip_address, port, domain, parameter, value, status, 
timestamp 

gsa_parm_info ip_address, port, object, parm_name, value_syntax, 
description, example 

gsa_tlib_alias ip_address, agent, lib_id, lib_index, type, id-1, id_2, 
alias_source, alias_type, alias_id, timestamp 

gsa_tlib_cell_statistics Not currently populated 
gsa_tlib_config ip_address, agent, lib_id, lib_index, vendor, model, 

serial_no, lib_count, drive_cap, hw_version, 
fw_version, build_date, alias, url, timestamp 

gsa_tlib_contents ip_address, agent, lib_id, lib_index, slot_type, 
component_id, media_type, media_id, media_class, 
timestamp 

gsa_tlib_drives ip_address, agent, lib_id, lib_index, component_id, 
vendor, model, serial_no, fw_version, media_type, 
timestamp 

gsa_tlib_events ip_address, agent, lib_id, lib_index, type, id_1, id_2, 
event_source, event_id, event_severity, event_msg, 
event_time, timestamp 

gsa_tlib_ifaces ip_address, agent, lib_id, lib_index, owner_type, 
owner_id1, owner_id2, if_type, if_index, if_addr, 
timestamp 

gsa_tlib_slots ip_address, agent, lib_id, lib_index, slot_type, 
component_id, panel, row, col, timestamp 

gsa_tlib_statistics ip_address, agent, lib_id, lib_index, type, id_1, id_2, 
start, end, interval, duration, stat_type, successes, 
retries, failures, timestamp 

gsa_tlib_status ip_address, agent, lib_id, lib_index, type, id-1, id_2, 
status, timestamp 

Table 1 – Library Agent Objects 

STK Library Agent 
The STK Library Agent supports STK L-Series libraries with the exception of the STK 
L5500 (also called PowderHorn) library. Refer to the Sun StorageTek Business Analytics 
Support Matrix for the latest information on supported libraries and support 
prerequisites. 
 
This agent uses SNMP to collects its data. Therefore, SNMP must be enabled on the tape 
library. 
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STK Library Agent Matrix 
 
Item Description 

Support Prerequisites  
Verify Version 2.0 
(minimum) of the 
StorageTek SNMP MIB 

 

Verify SNMP is enabled on 
the library 

bulkall <IP Address> 

Verify Ethernet 
connectivity to the library 

ping <IP Address> 

Agent Installation  

Windows  • Windows Local Manager Installation CD (InstallShield) 
• Windows Administrator privileges 
 

Solaris  • Unix Local Manager Installation CD (package installation) 
• root user account 

AIX • Unix Local Manager Installation CD (package installation) 
• root user account 

Requirements • The STK Library Agent (SNMP) and the ACSLS Agent should 
not be configured to report on the same tape library. 

Configuration 
Parameters 

 

Local Manager IP address or network-resolvable host name of the Local 
Manager to be contacted for agent auto registration. The 
default value is local host. 

Local Manager Registration 
Port 

TCP port number the Local Manager uses for agent auto 
registration. The default port number is 17146. 

Enable Auto Registration Turns agent auto registration on (default) or off.  

SNMP  The address of the SNMP agent for the STK L-Series Library. 
This is identified through a combination of host, port, and read 
community. 
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Item Description 

TRUST_LXX_CAP_STATS Specify whether or not to report Cartridge Access Port (CAP) 
statistics. 

IGNORE_OOR_CAP_STATS Specify whether or not to ignore “out of range” CAP statistics. 

TLIB_STATUS_AGE Data collection and cache refresh interval (seconds) for the 
status tables; default is 300 (five minutes). 

TLIB_STATS_INTERVAL Statistics and events collection interval (seconds); default is 
300 (five minutes). 

TLIB_STATS_RETENTION Statistics retention period (seconds) default is 8600 (one day). 

STK_SNMP_AGENT Data collection and cache refresh interval (seconds) for the 
configuration tables; default is 3600 (one hour). 

Table 2- Library Agent Matrix 

 
Installing the STK Library Agent - Windows 

The following section describes how to install and configure the STK L-Series Library 
Agent on a Windows platform.  

1. Insert the Sun StorageTek Business Analytics Windows Local Manager Installation CD 
into the CD-ROM drive. 

2. Click Next on the Welcome menu to continue the installation. 

3. Click Yes to accept the terms of the software license agreement. 

4. Review/modify the User Name and Company Name and click Next. 

5. Check the STK Library Agent checkbox on the screen that lists Smart Agents for 
installation. 
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  Figure 1 - Select Features To Be Installed 

6. Review the settings and click Next. 

7. Specify whether or not to install the new version of the Configuration Tool, if 
prompted. 

8. When the Configuration Tool is automatically launched, select File -> Edit -> Smart 
Agent Configuration. 

9. Click the STK L-Series Agent tab and click Add.  
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Figure 2 - STK L-Series Agent Configuration Window 

 

• IP Address – Specify the IP address for the STK L-Series library. 

• Community – Specify the SNMP read string; the default Read community is 
public. 

• Port – Specify the port number where the default port is 161. 

Note: The configuration settings for two STK L-Series Libraries in the above screen 
are for illustrative purposes only; these will not display when you configure libraries 
for your environment. 

10. Repeat this procedure for each STK L-Series Library that the agent will collect data. 

11. Click Submit. 

12. For Local Manager, specify the IP address or network resolvable host name of the 
Local Manager to be contacted for agent auto registration. 

13. For Local Manager Port, specify the TCP port number the Local Manager uses for 
agent auto registration. The default port number is 17146. 

14. Click Show Advanced Settings and review/modify the following: 

• Enable Auto Registration – Turns agent auto registration on (default) or off. 

• Max cache age for config data – Specify how long library configuration data is 
cached. The default value is 3600 seconds. 
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• Max cache agent for status data - Specify how long library status data is 
cached. The default value is 600 seconds. 

• Statistics & events collection interval – Specify the frequency that statistics 
and events data is collected. The default value is 300 seconds. 

• Statistics retention period – Specify how long library statistics are cached. The 
default interval is 21600 seconds. 

• Enable cap stats on L20/L40/L80 – Turn collection of CAP statistics on or off 
(default) for the specified model libraries.  

15. With “Save Configuration Settings” enabled (check mark), select File->Save and 
then confirm saving the changes to the storability.ini file. 

16. Select File->Exit to close the Configuration Tool. 

17. Use the Windows Services panel to start the STL L-Series Agent before you verify 
agent functionality.  

 

Installing the STK Library Agent - Solaris 
 

1. Mount the Sun StorageTek Business Analytics Solaris Local Manager Installation CD 
on the Solaris server. For example: 

mount –F hsfs –o ro /dev/dsk/c0t6d0s0 /mnt 

2. Change directory to the UNIX directory for the Solaris operating system.  

3. Run the pkgadd command. The main package installation menu is displayed. 

pkgadd –d . 

4. Press Enter to scroll through the packages and then Ctrl-D to stop scrolling. 

5. Select to install the STK Library Agent (GSMstk) and press Enter. 

6. Enter the IP address or host name for the STK library.  

7. Enter the TCP port number or press Enter to accept the default port (161). 

8. Enter the SNMP Read community string or press Enter to accept the default Read 
community string (public). 

9. Repeat the above steps to configure SNMP read access to all libraries. 

 
Figure 3 - Configure STK L-Series Agent on Solaris 

10. Press Enter on an empty IP Address or Host Name prompt to indicate you are 
finished configuring libraries and to continue. 
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11. Type y and press Enter to review/modify the Advanced Settings. 

12. The installation program prompts to enter the installation path. 

 

Figure 4 - STK L-Series Advanced Settings 

• Specify whether (y/n) to have the Agent Monitor restart the agent if it is detected 
as not running. 

• For Maximum library configuration cache age, specify how long library 
configuration data is cached. The default value is 3600 seconds. 

• For Maximum library status cache age, specify how long library status data is 
cached. The default value is 600 seconds. 

• For Library stats collection interval, specify the frequency that statistics and 
events data is collected. The default value is 300 seconds. 

• For Library stats retention period, specify how long library statistics are 
cached. The default interval is 21600 seconds. 

• For Enable stats from Lxx libraries, turn collection of CAP statistics on or off 
(default) for the L20/L40/L80 model libraries. 

• For Ignore Out of Range Cap Stats, Specify whether or not to ignore “out of 
range” CAP statistics. 

• For Enable Auto Registration, agent auto registration is turned on by default, 
but can be disabled by specifying “false”. 

• For Local Manager, specify the IP address or network resolvable host name for 
the Local Manager to be contacted for agent auto registration. 

• For Local Manager Port, specify the TCP Port Number the Local Manager uses 
for agent auto registration. The default port number is 17146. 
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13. Specify whether (y/n) to restart the agents after the installation has completed. 

14. Type y and press Enter to restart the agents after installation. 

15. When prompted, type y to allow the installation script to run with super-user 
permissions. 

16. The installation will complete and return you to the main package installation menu. 

17. Enter the number for any other package you wish to install, or q or to quit. 

ACSLS Agent  
The Sun StorageTek Business Analytics ACSLS Agent supports STK PowderHorn libraries 
(including the L5500). Refer to the Sun StorageTek Business Analytics Support Matrix 
for the latest information on supported libraries and support prerequisites, 
 
The ACSLS Agent uses the STK ACS API to collect its data. On UNIX servers, the ssi 
process is the ACS API software. 
 
Item Description 

Support Prerequisites  
Verify Ethernet 
connectivity to the server 
running the ACSLS API. 

ping <IP Address> 

Verify separate server 
available to accommodate 
the agent 

The Storability ACSLS Agent  must be installed on a separate 
Solaris or AIX server from the one running the ACSLS API and 
the backup server. SSI is the interface to the ACS API. In 
effect, the library-monitoring configuration requires three 
separate servers: ACSLS API server, backup server, and 
Library Agent server. 
 
Use the process status (ps) command to ensure that the ACS 
software is not already running on the server where you plan 
to install the ACSLS Agent. Remember that the ssi process is 
the ACS API software. 
 
ps –ef | grep ssi 
 

RPC Binding Turned On RPC binding must be running on the machine that the ACSLS 
Agent (acslsAgent) is installed on. Many companies do not turn 
this on by default. 
 
The process status (ps) command may be used to verify this 
requirement. 
 
root@mymachine# ps -ef | grep rpc 
    root   493     1  0   May 06 ?        0:00 
/usr/sbin/rpcbind 
    root 29612 29603  0 12:14:10 pts/4  0:00 grep rpc 
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Item Description 

Agent Installation  
AIX  • UNIX Agent Installation CD  

• root user account 
Solaris  • Solaris Local Manager Installation CD (package installation) 

• root user account 

Restrictions  

Single ACS API client per 
machine 

You may only run one application that uses the ACS API per 
machine. Be aware that SSI is the Storability ACSL Agent’s 
interface to the ACSLS API. You can use the process status 
command to verify whether the SSI process is running on a 
UNIX server for an existing ACS API application (e.g., 
NetBackup Master Server). 
 
For example: 
 
 ps –ef | grep ssi 

Best Practices  

Library Agent Deployment • Sun recommends the use of the STK Library Agent for tape 
libraries that support SNMP because the ACSLS Agent only 
collects Enters/Ejects (puts/gets) for statistics. Using the 
STK Library Agent and the ACSLS Agent to both monitor a 
particular tape library is not supported. 

• When restarting the ACSLS Agent, ensure the ssi process 
has been stopped before you attempt to restart the ACSLS 
Agent. 

 
Configuration 
Parameters 

 

Local Manager IP address or host name of the Local Manager to be contacted 
for agent auto registration. The default value is local host. 

Local Manager Registration 
Port 

TCP port the Local Manager uses for agent auto registration. 
The default port number is 17146. 

Enable Auto Registration Turns agent auto registration on (default) or off. 

TRUST_LXX_CAP_STATS Specify whether or not to report Cartridge Access Port (CAP) 
statistics. 

IGNORE_OOR_CAP_STATS Specify whether (y/n) to ignore “out of range” CAP statistics. 
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Item Description 

TLIB_STATUS_AGE Data collection and cache refresh interval (seconds) for the 
status tables; default is 300 (five minutes). 

TLIB_STATS_INTERVAL Statistics and events collection interval (seconds) ; default is 
300 (five minutes). 

TLIB_STATS_RETENTION Statistics retention period (seconds) default is 8600 (one day). 

Table 3 –ACSLS Agent Matrix 

Installing the Storability ACSLS Agent – Solaris 

1. Mount the Sun StorageTek Business Analytics Solaris Local Manager Installation CD 
on the Solaris server. For example: 

mount –F hsfs –o ro /dev/dsk/c0t6d0s0 /mnt 

2. Change directory to the UNIX directory for the Solaris operating system. Solaris 7 or 
8 packages are located in /Unix/Solaris/9. 

3. Run the pkgadd command. The main package installation menu appears. 

   pkgadd –d . 

4. Type Ctrl-D to stop scrolling and select GSMacsls (Option 1). You will be presented 
with a blank line for the ACSLS server name. 

5. Type the IP address or network resolvable host name of the Solaris server equipped 
with the ACSLS API and press Enter. 

6. Type y and press Enter to a review/modify the following configuration settings: 

 

Figure 5 - ACSLS Library Agent Advanced Settings 
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• Specify whether (y/n) to have the Agent Monitor restart the agent if it is detected 
as not running. 

• For Default ACS request timeout, specify how long the ACSLS Agent waits to 
communicate with the ACSLS server. The default value is 120 seconds. 

• For Maximum ssi startup delay, specify how long to wait for SSI startup. The 
default value is 60 seconds. 

• For Maximum library configuration cache age, specify the maximum cache 
age for configuration data in seconds. The default cache refresh is 3600 seconds. 

• For Maximum library cache status, specify the maximum cache age for status 
data in seconds. The default value is 600 seconds. 

• For Library stats collection interval, specify the statistics and events collection 
interval in seconds. The default value is 300 seconds. 

• For Library stats retention period, specify the statistics retention period in 
seconds. The default value is 21600 seconds. 

• For Enable Auto Registration, accept that agent auto registration is enabled 
(true) or set this configuration parameter to false to disable agent auto 
registration.  

• For Local Manager, specify the network-resolvable host name or IP Address of 
the Local Manager to be contacted for agent auto registration. The default value 
is local host, 

•  For Local Manager Registration Port, specify the TCP port number the Local 
Manager uses for agent auto registration. The default TCP port number is 17146. 

7. The installation prompts you to specify whether or not to restart the agents after 
installation. 

8. Type y and press Enter to restart the agents after installation. 

9. When prompted, type y and press Enter to confirm continuing the installation of the 
ACSLS Library Agent. 

10. When prompted, type y to allow the installation script to run with super-user 
permissions. 

11. The installation will complete and return you to the main package installation menu. 

12. Enter the number for any other package you wish to install, or q or to quit. 

13. Use the process status command to verify the ACSLS library agent is running. The 
following screen shows the command output when both the Routing Agent and 
ACSLS Agent are running. 
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Figure 6 - Verifying ACSLS Library Agent Running 

Installing the ACSLS Agent - AIX 
All currently supported AIX agents are provided as a zipped tar archive with an 
installation script. To install the agent, simply ensure that archive (acslsAgent-AIX.tgz) 
and the install script (acslsAgent-install.sh) reside in the same location, and run the 
script. 

 

1. Mount the installation CD in the CD-ROM drive of the AIX server. For example: 

 

  mount -v cdrfs -r /dev/cd0 /mnt # /mnt directory must exist 

          

2. Change directory to the software installation directory. For example: 

 

cd /cdrom/Unix/AIX/5.2 

 

3. Run the installation script: 

 

./acslsAgent-install.sh 

 
AIX ACSLS Agent Configuration  
The installer is prompted to supply the following information to configure the ACSLS 
Agent for AIX: 
 

• Default ACS Request Timeout – How long the ACSLS Agent waits to 
communicate with the ACSLS server; default is 30 seconds. 

• Maximum SSI startup delay – How long to wait for SSI startup. 

• Maximum library configuration cache age – Maximum cache age for 
configuration data in seconds; default is 3600. 

• Maximum library cache status – Maximum cache age for status data in 
seconds; default is 600. 

• Library stats collection interval – Statistics and events collection interval in 
seconds; default is 300. 

• Library stats retention period – Statistics retention period in seconds; default 
is 21600. 
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Agent Auto Registration 
To configure agent auto registration, you can add the ACSLS Agent to a Local Manager 
Routing Agent configuration as a SUB_AGENT entry or manually add the required entries 
to the storability.ini file. Sample storability.ini settings for the agent appear below. 
 

GSM_LM_HOST = 10.192.1.15 
      GSM_LM_PORT = 17146 
 GSM_ENABLE_LM_REGISTRATION = true 

IBM 3494 Agent 
The IBM 3494 Agent supports IBM 3494 libraries. Refer to the Sun StorageTek Business 
Analytics Support Matrix for the latest information on supported libraries and support 
prerequisites. 
 
The IBM ATL Agent uses IBM ATL drivers and SNMP to collect its data. 
 
Item Description 

Support Prerequisites . 
IBM ATL drivers  Must have supported IBM ATL driver installed and configured 

for the server platform.  
Verify Ethernet 
connectivity to the library 

ping <IP Address> 

SNMP Enabled Verify that SNMP is enabled on the library. 
 
bulkall <IP Address> 

Agent Installation  
AIX  • UNIX Agent Installation CD  

• root user account 
 

Solaris  • Solaris Local Manager Installation CD (package installation) 
• root user account 
• GSMbase 
 

Windows  • Windows Local Manager Installation CD (InstallShield) 
• Windows Administrator privileges 
 

Linux • UNIX Agent Installation CD  
• root user account 
 

Configuration 
Parameters 

 

Local Manager IP Address or host name of the Local Manager to be contacted 
for agent auto registration. The default value is local host. 

Local Manager Registration  
Port 

TCP port number the Local Manager uses for agent auto 
registration. The default port number is 17146. 

Enable Auto Registration Turns agent auto registration on (default) or off. 
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Item Description 

IBM_ATL_LIBRARY Identifies the IBM 3494 Library to be monitored. The Library 
parameter is specified using a symbolic name for the library 
(device file).  On non-Windows servers, all ATL device files will 
be specified similar to lmcp<#> (e.g., lmcp0). 
 

Max. Cache Age for 
Configuration Data 

Specify the frequency that the agent refreshes the library 
configuration data (seconds). The default value is 3600 
seconds. 

Max. Cache Age for Status 
Data 

Specify the frequency that the agent refreshes the library 
status data. The default value is 600 seconds. 

Statistics and Events 
Collection Interval 

Specify the frequency that the agent collects statistics and 
events data. The default value is 300 seconds. 

Statistics Retention Period Specify how long the agent retains statistics. The default value 
is 86400 seconds (one day). 

Table 4 – IBM 3494 Agent Matrix 

 
Obtaining the Symbolic Device Name for Windows ATL 
Before you install the IBM 3494 Agent, obtain the configured symbolic library device 
name. 
 
1. Locate and open the ibmatl.conf file on the server equipped with the IBM 3494 ATL 

device drivers. On a Windows server, for example, the ibmatl.conf is located in the 
<drive>:\WINNT folder. 

2. Open the ibmatl.conf file using a system text editor. A sample configuration file is 
shown below. In this sample configuration file, note that: 

 
• The IP address for the library is 10.255.253.94 
• The library symbolic device name is L12. 
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Figure 5 - IBM ATL Configuration File 

 
Installing the IBM 3494 Agent - Windows 

The following section describes how to install and configure the IBM 3494 (ATL) Agent 
on a Windows platform.  

1. Insert the Business Analytics Windows Local Manager CD into the CD-ROM drive. 

2. Click Next> on the Welcome menu to continue the installation. 

3. Click Yes to accept the terms of the software license agreement. 

4. Review/modify the User Name and Company Name and click Next>. 

5. Check the IBM 3494 Library Agent checkbox on the screen that lists agents for 
installation. 
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6. Review the settings and click Next>. 

7. Specify whether or not to install the new version of the Configuration Tool, if 
prompted. 

8. When the Configuration Tool is automatically launched, select File -> Edit -> Smart 
Agent Configuration. 

9. Click the ibmATL Agent tab and click Change Option Values. 

 

Figure 6 - IBM Configuration Tool: ATL Agent 

10. For each library, enter on a line: 

• The symbolic name of the library (device) (from ibmatl.conf file): 

11. Click Submit after you have entered the list of libraries. 

12. For Local Manager, specify the IP address or network resolvable host name of the 
Local Manager the agent will contact for agent auto registration. 

13. For Local Manager Port, specify the TCP port number that the Local Manager uses 
for agent auto registration). The default port number is 17146. 

14. Click Show Advanced Settings to review/modify the following configuration 
variables: 

• Enable Auto Registration – Accept that auto registration is enabled (true) or 
set this configuration parameter to false to disable auto registration.  
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• Max. Cache Age for Configuration Data – Specify the frequency that the 
agent refreshes the library configuration data (seconds). The default value is 
3600 seconds. 

• Max. Cache age for status data (seconds) – Specify the frequency that the 
agent refreshes library status data. The default value is 600 seconds. 

• Statistics & events collection interval (seconds) - Specify the frequency that 
the agent collects statistics and events data. The default value is 300 seconds. 

• Statistics retention period - Specify how long the agent retains statistics. The 
default value is 86400 seconds (one day). 

15. With “Save Configuration Settings” turned on (check mark), select File->Save and 
then confirm saving changes to the storability.ini file. 

16. Select File -> Exit to close the Configuration Tool. 

17. Use the Windows Services panel to start the Library Agent before you verify agent 
functionality. 

 

Installing the IBM 3494 Agent - Solaris 
 

1. Mount the Solaris Local Manager Installation CD on the Solaris server. For example: 

mount –F hsfs –o ro /dev/dsk/c0t6d0s0 /mnt 

2. Change directory to the UNIX directory for the Solaris operating system. 

3. Run the pkgadd command. 

   pkgadd –d . 

4. Type the package selection number for the IBM ATL Library Agent and press Enter 
to select installing this agent. 

5. If a UNIX group does not exist for the agent to run under, you will be prompted to 
create a group, called gsm, for the application.  Press Enter to create the group 
using the default group ID (1090) or enter another one. 

6. When prompted, specify the following: 

7. For each library, enter: 

• The library device symbolic name (obtained from the ibmatl.conf file) 

8. For Local Manager, specify the IP address or network resolvable host name of the 
Local Manager the agent will contact for agent auto registration. 

9. For Local Manager Registration Port, specify the TCP port number that the Local 
Manager uses for agent auto registration. The default port number is 17146. 

10. For Enable Auto Registration, accept that auto registration is enabled (true) or 
set this configuration parameter to false to disable auto registration.  
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11. For Library, enter the symbolic name of the device file (e.g., lmcp0) on the Solaris 
server. 

12. For Max. Cache Age for Configuration Data, specify the frequency that the 
agent refreshes the library configuration data (seconds). The default value is 3600 
seconds. 

13. For Max. Cache age for status data, specify the frequency that the agent 
refreshes library status data. The default value is 600 seconds. 

14. For Statistics & events collection interval, specify the frequency that the agent 
collects statistics and events data. The default value is 300 seconds. 

15. For Statistics retention period, specify how long the agent retains statistics. The 
default value is 86400 seconds (one day). 

16. The installation prompts you to specify whether or not to restart the agents after 
installation. 

17. Type y and press Enter to restart the agents after installation. 

18. When prompted, type y to allow the installation script to run with super-user 
permissions. 

19. The installation will complete and return you to the main package installation menu. 

20. Enter the number for any other package you wish to install, or type Ctrl-D and q to 
exit. 

Installing the IBM 3494 Agent – HP-UX 
All currently supported HP-UX agents are provided as a zipped tar archives with 
installation scripts. To install an agent, simply ensure that the zipped tar archive 
(ibmAtlAgent-hpux.tgz) and the install script (ibmAtlAgent-install.sh) reside in the same 
location, and run the script.  
 
By default, HP-UX supports neither Rock Ridge nor Joliet extensions to the ISO 9660 
filesystem specification. As a result, support for long filenames may not be available. 
 
During the installation, you are prompted to specify the following configuration 
parameters: 
 
• Library – Enter the symbolic device file name (e.g., lmcp0). 
• Max. Cache Age for Configuration Data - The frequency that the agent refreshes 

the library configuration data (seconds). The default value is 3600 seconds. 
• Max. Cache age for status data - The frequency that the agent refreshes library 

status data. The default value is 600 seconds. 
• Statistics & events collection interval The frequency that the agent collects 

statistics and events data. The default value is 300 seconds. 
• Statistics retention period How long the agent retains statistics. The default value 

is 86400 seconds (one day). 
 

Agent Auto Registration  
To configure agent auto registration, you can add the IBM ATL Agent to a Local Manager 
Routing Agent configuration or manually add the required entries to the storability.ini 
file. Sample storability.ini settings appear below. 
 

GSM_LM_HOST = 10.255.252.99 
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      GSM_LM_PORT = 17146 
       GSM_ENABLE_LM_REGISTRATION = true 
 
Installing the Storability IBM 3494 Agent - AIX 
All currently supported AIX agents are provided as a “Tarball” with an installation script. 
To install the agent, simply ensure that the “Tarball” ibmAtlAgent-AIX.tgz) and the 
install script ibmAtlAgent-install.sh) reside in the same location, and run the script.  
1. Mount the UNIX Agent Installation CD. For example: 
 
 mount -v cdrfs -r /dev/cd0 /mnt # /mnt directory must exist 

          
2. Change to the appropriate directory on the installation media. For example: 
 

cd  Unix/AIX/5.1 
 

3. Run the install script for the agent.   
     ./ibmAtlAgent-install.sh 

 
IBM Tape Lib install Script 
Script started on Wed Dec  8 09:43:42 2004# ./ibmAtlAgent-install.sh 
Storability agent shutdown: 
Stopping Storability host agent:        hostAgent 21494 killed 
Storability agent shutdown complete. 
x opt/storability 
x opt/storability/bin 
x opt/storability/bin/ibmAtlAgent, 8544128 bytes, 16688 tape blocks 
x opt/storability/bin/ibmAtlDump, 8615132 bytes, 16827 tape blocks 
x opt/storability/data 
x opt/storability/etc 
x opt/storability/lib 
x opt/storability/tmp 
x opt/storability/tmp/request, 6179 bytes, 13 tape blocks 
x opt/storability/tmp/agents, 103 bytes, 1 tape blocks 
x opt/storability/tmp/libC.a, 5912953 bytes, 11549 tape blocks 
x opt/storability/tmp/install.sh, 665 bytes, 2 tape blocks 
x opt/storability/tmp/i.cfg, 1956 bytes, 4 tape blocks 
x opt/storability/tmp/i.touch, 343 bytes, 1 tape blocks 
x opt/storability/tmp/i.libC, 763 bytes, 2 tape blocks 
x opt/storability/tmp/storability.ini, 350 bytes, 1 tape blocks 
x opt/storability/GSM-license.txt, 10110 bytes, 20 tape blocks 
x opt/storability/STK-license.txt, 12005 bytes, 24 tape blocks 
x opt/storability/lgpl-license.txt, 26532 bytes, 52 tape blocks 
x opt/storability/openssl-license.txt, 6279 bytes, 13 tape blocks 
x opt/storability/pcre-license.txt, 1944 bytes, 4 tape blocks 
x opt/storability/pegasus-license.txt, 1500 bytes, 3 tape blocks 
x opt/storability/snia-license.txt, 23716 bytes, 47 tape blocks 
x opt/storability/snmp++-license.txt, 1238 bytes, 3 tape blocks 
x opt/storability/xercesc-license.txt, 2697 bytes, 6 tape blocks 
x etc/rc.ibmAtlAgent, 1372 bytes, 3 tape blocks 
GSMibmatl was built on AIX 4.3. 

IBM 3494 tape library device file?      # Example: /dev/lmcp  
IBM 3494 tape library device file?   # Done specifying libraries 

 (Re-)start agents after install [y] y 
 /opt/storability/etc/storability.ini:   updated. 
 /opt/storability/etc/agents:    updated. 
 /opt/storability/data/Message.log 
Storability agent startup: 
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Starting Storability host agent:        hostAgent started 
Starting Storability IBM 3494 Library agent:    ibmAtlAgent started 
Storability agent startup complete. 
# process 
sh: process:  not found 
# top 
sh: top:  not found 
# exit 

 
Agent Auto Registration  
To configure agent auto registration, you can add the IBM ATL Agent to a Local Manager 
Routing Agent configuration as a SUB_AGENT entry or manually add the required entries 
to the agent storability.ini file. Sample storability.ini settings appear below. 
 

GSM_LM_HOST = 10.192.1.153 
      GSM_LM_PORT = 17146 

GSM_ENABLE_LM_REGISTRATION = true 

SMIS Tape Library Agent 
The Sun StorageTek Business Analytics SMIS Tape Library Agent collects data from SMI-
S compliant CIM Providers supporting the Storage Library profile, as described in the 
Sun StorageTek Business Analytics Support Matrix. Note: In general, SMIS and non-
SMIS agents collecting information from the same device is not supported. 
 
Item Description 

Support Prerequisites  
Verify SMI-S 1.1 compliant 
CIM Provider 

Vendor documentation 

Agent Installation  
Solaris  • Solaris Local Manager Installation CD (package installation) 

• root user account 
• GSMbase 
 

Windows  • Windows Local Manager Installation CD (InstallShield) 
• Windows Administrator privileges 
 

Limitations The following tape library agent objects are not populated: 
 
• gsa_tlib_statistics  
• gsa_tlib_alias 

Configuration 
Parameters 

 

Local Manager IP Address or host name of the Local Manager to be contacted 
for agent auto registration. The default value is local host. 

Local Manager Registration  
Port 

TCP port number the Local Manager uses for agent auto 
registration. The default port number is 17146. 

Enable Auto Registration Turns agent auto registration on (default) or off. 
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Item Description 

CIM_IP CIM_IP = provider ip|provider port  (5988)|namespace| 
username|password 
 
One entry is required per SMIS CIMOM (Common Information 
Model Object Manager) provider.  
 
The first field is the IP address of a CIMOM provider.  This may 
be an individual array that supports the CIMOM natively, or a 
CIM proxy reporting on one or more libraries. 
 
The second field is the CIMOM provider port, which is TCP port 
number 5988 by default. 
 
The third field, the namespace value, must be obtained from 
the vendor documentation for the CIMOM provider. 
 
The Username and password must be configured for an account 
that grants access to the CIMOM provider. 
  

Max. Cache Age for 
Configuration Data 

Specify the frequency that the agent refreshes the library 
configuration data (seconds). The default value is 3600 
seconds. 

Max. Cache Age for Status 
Data 

Specify the frequency that the agent refreshes the library 
status data. The default value is 600 seconds. 

 
Installing the SMIS  Tape Library  Agent - Windows 

The following section describes how to install and configure the IBM 3494 (ATL) Agent 
on a Windows platform.  

1. Insert the Sun StorageTek Business Analytics Windows Local Manager CD into the 
CD-ROM drive. 

2. Click Next> on the Welcome menu to continue the installation. 

3. Click Yes to accept the terms of the software license agreement. 

4. Review/modify the User Name and Company Name and click Next>. 

5. Check the SMIS Library Agent checkbox on the screen that lists agents for 
installation. 

6. Review the settings and click Next>. 

7. Specify whether or not to install the new version of the Configuration Tool, if 
prompted. 
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8. When the Configuration Tool is automatically launched, select File -> Edit -> Smart 
Agent Configuration. 

9. Click the SMISTlib Agent tab and click Add. 

10. For each library, enter: 

• IP or Host Name – Enter the IP address or network resolvable host name to 
connect to the CIM provider.  This may be an individual library that supports CIM 
natively, or a CIM proxy reporting on one or more libraries. 

• Port – Is the TCP port number to connect to the provider; the default TCP port 
number is 5988. 

• Interop Namespace – Specify the interoperability namespace, which implies 
where the CIMOM interoperability classes are stored. 

• Namespace – Is the Provider namespace; must be obtained from the vendor 
documentation for the CIM provider. 

• Username – User name of an account that grants access to the CIM provider. 

• Password – Password of the above specified user. 

11. Click Submit after you have entered the list of libraries. 

12. For Local Manager, specify the IP address or network resolvable host name of the 
Local Manager the agent will contact for agent auto registration. 

13. For Local Manager Port, specify the TCP port number that the Local Manager uses 
for agent auto registration). The default port number is 17146. 

14. Click Show Advanced Settings to review/modify these optional configuration 
variables. 

• Enable Auto Registration - Turns agent auto registration on (default) or off. 

• CONFIG_CACHE_REFRESH_INTERVAL – Specifies the interval to collect 
configuration data. The default interval is 3000 seconds. 

• Maximum Execution Threads – Specify the number of threads the agent uses. 
The default value is five (5). 

• CMD_EXECUTION_TIMEOUT – Specify how long the agent waits for the execution 
of a command. The default value is 60 seconds. 

• Maximum library configuration cache age – Specify the maximum amount of time 
the agent caches configuration data. The default value is 600 seconds. 

• Maximum library status cache agent - Specify the maximum amount of time the 
agent caches library status information. The default value is 600 seconds. 

• Library stats collection interval – Specify the interval to collect library statistics. 
The default value is 300 seconds. 

• Library stats retention period – Specify how long statistics are retained. The 
default value is 21600. 
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15. With “Save Configuration Settings” turned on (check mark), select File->Save and 
then confirm saving changes to the storability.ini file. 

16. Select File -> Exit to close the Configuration Tool. 

17. Use the Windows Services panel to start the Library Agent before you verify agent 
functionality. 

 

Installing the SMIS Tape Library Agent - Solaris 
 

1. Mount the Solaris Local Manager Installation CD on the Solaris server. For example: 

mount –F hsfs –o ro /dev/dsk/c0t6d0s0 /mnt 

2. Change directory to the UNIX directory for the Solaris operating system (e.g., 
/Solaris/9). 

3. Run the pkgadd command. 

   pkgadd –d . 

4. Choose the SMIS Tape Library Agent (Option 26).  

5. At the “Input the CIMOM IP Address or hostname:” prompt, enter the IP address or 
network resolvable name to connect to the CIMOM provider and press Enter. 

6. At the “Input the CIMOM TCP port#: [5988]” prompt, enter the TCP port number to 
connect to the CIMOM or press Enter to accept the default value (5988). 

7. At the “Input the CIMOM user name:” prompt, type the user name of an account that 
grants access to the CIM provider. 

8. At the “Password for <user_name>:” prompt, enter the user’s password. 

9. When prompted, retype the password to confirm the password. 

10. At the “Input the CIMOM provider's namespace:” prompt, enter the provider 
namespace that must be obtained from the vendor documentation for the CIMOM 
provider. 

11. At the “Input the CIMOM interop namespace:” prompt, enter the interoperability 
namespace, which implies where the CIMOM interoperability classes are stored. 

12. At the “Do you want to input another CIMOM? [n] [y,n,?]” prompt, type y or n to 
specify whether you want to configure another CIMOM. 

13. Type y and press Enter to review/modify the advanced settings. 

• Automatically restart this agent from agentMonitor – Type y(es) or n(o) to 
specify whether the SMIS Tape Library Agent will be restarted by the Agent 
Monitor. 

• Intervals of updating configuration information? [3600] – Specify the 
frequency to refresh library configuration information. The default value is 
3600 seconds. 
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• Maximum number of execution threads – Enter the maximum number of 
execution threads; the default value is five (5). 

• Timeout on execution a single CIM read command – Enter the command 
execution timeout. The default value is 60 seconds. 

• Maximum library configuration cache age? [600] – Enter the maximum 
amount of time to cache library configuration data. The default value is 600 
seconds. 

• Maximum library status cache age? [600] - Enter the maximum amount of 
time to cache library status information. The default value is 600 seconds. 

• Library stats collection interval – Specify the frequency to collect library 
statistics. The default value is 300 seconds. 

• Library stats retention period – Specify how long library statistics are 
retained. The default value is 21600 seconds. 

• Enable agent auto registration, accept that auto registration is enabled (true) 
or set this configuration parameter to false to disable auto registration. 

• Local Manager address for agent registration – Enter the IP address or 
network resolvable name of the Local Manager with which to register. The 
default value is localhost. 

• TCP port for agent registration - Specify the TCP port number that the Local 
Manager uses for agent auto registration. The default port number is 17146. 

• (Re-)start agents after install – Type y or n to specify whether to re(start) 
agents after the installation is completed. 

14. When prompted, type y to confirm that you want to proceed with the agent 
installation. 

15. The installation will complete and return you to the main package installation menu. 

16. Enter the number for any other package you wish to install, or type Ctrl-D and q to 
exit. 

Verifying the Library Agent 
1. Use the GSM Agent Diagnostic Tool (GSMdiag) to verify agent functionality. 

2. Enter the IP Address or Hostname of the server where the agent is installed in the 
Agent location window, and select the agent (e.g., ACSLS Agent) from the drop 
down list of service names. 

3. Click the Get Object List button and you should receive a list of objects published 
by the Library Agent. 

4. Collect the gsa_ini_control object and review the agent’s storability.ini settings. 
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Figure 7 – Sample IBM 3494 Agent Configuration Settings 

 

5. Select the gsa_tlib_config object published by the agent and verify data is 
returned. 

 

 

Figure 8 – Sample Tape Library Configuration Object 

6. Collect and verify all other tables published by the agent.  

7. To verify the Library Agent has registered successfully with its configured Local 
Manager: 

• In the Agent location window, enter the IP Address or network resolvable 
Host Name of the Local Manager in the ip address/host name input box. 

• Set the port to 17146 (or select the Storability Routing Agent from the drop 
down list of service names).  
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• Click the Get Object List button and you should receive a list of tables 
published by the Routing Agent. 

• Select the gsa_agent_register object. 

• Verify this collected object reports the Library Agent in the “active_peer” field 
by IP address and in the port field by agent port number. The port numbers 
for Library Agents are listed as follows: 

o STK L-Series Agent – TCP port number is 17155 

o ACSLS Library Agent – TCP Port Number is 17157 

o IBM 3494 Agent – TCP Port Number is 17164 

o SMIS Library Agent – TCP Port Number is 17161 

Verifying Management Console Functionality 
The following procedure describes how the administrator verifies the Sun StorageTek 
Business Analytics Library Agent’s reports in the Management Console. Refer to the 
Administration chapter to obtain information on the administrative menus you can 
access from the Tools pull down menu, including the Data Polling and Change 
Dashboard menus. 
 
1. Log in to the Management Console as an administrative user (e.g., gsmuser) whose 

views provide access to the desired assets (e.g., sites). 
2. Verify that your customized Home Page includes the Tape Library Overview pane 

(or use Change Dashboard to assign one). 
3. Select Tools->Data Polling Schedule. 
4. Use the Collect Now button to collect the Library (collection type) Configuration 

(Collection Metric) data. 
5. Use the Collect Now button to collect the Library (collection type) Jobs (Collection 

Metric) data. 
6. Use the Collect Now button to collect the Library (collection type) Media (Collection 

Metric) data. 
7. Close the Data Polling Schedule window. 
8. Verify the Tape Library Overview pane reports information on the libraries being 

monitored by the specific library agent you are verifying.  
9. Close the browser session with the Management Console as the above steps 

complete verifying the Management Console functionality. 

Library Agent Troubleshooting 
 

1. Verify system/agent prerequisites – Refer to Sun StorageTek Business Analytics 
Support Matrix that is located on the Documentation CD to verify the most recent 
support requirements for the agent. 
 

2. Use the GSM Agent Diagnostic Tool (GSMdiag) to save the output for all the tables if 
escalating a problem to Sun Technical Support. 
a. Launch the GSM Agent Diagnostic Tool from the Storability Program Folder. 
b. Enter the IP Address or Hostname of the server where the agent is installed 

and set the port number by selecting the particular Library Agent (e.g., 
Storability STK L-Series Agent) from the drop down list of service names. 
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c. Click the Get Object List button and you should receive a list of tables published 
by the agent. If unsuccessful, verify the Ethernet connectivity to the server 
running the agent and that the Array Agent is running. 

d. Select the alerts-3_1 table and examine the Description column for each 
reported alert. 

e. Select File->Save All and the “This action will network fetch all objects 
published by the currently specified agent and save the data to a single file.” 
Message appears.  

f. Click OK and the Save As dialog appears.  
g. Enter a meaningful file name and click OK to initiate the collection. 
h. Enter the desired file name and click OK.  

 
3. Review the Message Log – Review/collect the Message.log file that can contain 

information on startup errors, configuration errors, or errors regarding accessing 
data or parsing output. 
 
Windows 

 
• Located by default in: <drive>:\Program Files\Storability\GSM\Agents\Storability 

<Library Agent Name> Agent folder. 
• Can enable debug level logging by appending LOG_SEVERITY=Debug to the 

<Library Agent> section of the storability.ini file (if Storability Support requests 
it). 

Solaris 
 

• GSM agents’ common Message.log file located by default in: /opt/storability/data. 
• Can enable debug level logging by appending LOG_SEVERITY=Debug to the 

<Library Agent> section of the storability.ini file (if Customer Support requests 
it). 

 
4. Verify Local Manager Registration - The configured Routing Agent’s 

gsa_agent_register table should be reviewed if the auto-registration feature is 
enabled (default). Otherwise, verify the necessary sub agent entry has been added 
to the Routing Agent’s storability.ini file. 

5. Review the Routing Agent Message Log – Review/collect the Routing Agent 
Message Log to check for errors related to Ethernet connectivity problems contacting 
that Library Agent. 

6. Confirm Polling Schedules – Using the Management Console’s Data Polling 
Schedule menu, review/modify the existing Polling Schedules for the Collection Type 
of Library for all sites.  

7. Review Aggregator Message Log – Open the Aggregator’s Message Log in a text 
editor and validate that the Library Tables are being requested and that rows are 
being inserted into the database. 
The log contains two entries, TID (Transaction ID) and SID (Session ID), which can 
help you locate (e.g., Find) and view relevant logged entries. For scheduled polling 
requests, the TID will be equal to the Job ID in the Polling menu. Each SID is a 
unique identifier for a particular agent data collection session. For on-demand polling 
requests, the TID is a uniquely generated TID (not the Job ID) and SID, and the TID 
and SID will be equal to the same integer value.  

8. Check the assurent database – The assurent database is the data repository for 
your Business Analytics application. For a Library Agent, use any MS SQL Query 
interface, such as osql, to verify rows have been inserted into the array-related 
tables, such as the gsa_tlib_config table. 

9. Verify Management Console Functionality – As a final step in the agent 
troubleshooting procedure, minimally verify the monitored libraries now appear in 
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the Tape Library Overview dashboard pane or in the Asset Management report for 
the site. 

Uninstall Library Agent - InstallShield 
1. Select Start->Program Files->Storability->Uninstall->Uninstall Local 

Manager      
Or: 
Start->Program Files->Storability->Uninstall->Uninstall <Library Agent 
Name>. The Storability Uninstall dialog appears. 

2. Click the checkbox for the appropriate Database Agent. 
3. Click Next>. The Question dialog appears. 
4. Click Yes to confirm uninstalling the agent. An uninstalling agent splash box appears 

as each selected agent is uninstalled. 
5. When the InstallShield Wizard Complete dialog box appears, click Finish. 

Uninstall Library Agent – Solaris 
1. Type: 

pkgrm GSM<Library_Agent_Name> 

2. At the “do you want to remove this package” prompt, enter y and press Enter. 

3. At the “do you want to continue the removal of the package?” prompt, type y and 
press Enter. The “Removal of GSM<Library_Agent_Name>” agent was successful” 
message. 

Reinstall Library Agent – Non-Solaris UNIX Host 
The reinstallation procedure for all Sun StorageTek Business Analytics agents supported 
on non-Solaris UNIX hosts, such as the IBM 3494 Agent on an AIX server, requires that 
the installer perform the following steps before running the agent’s installation script: 

1. Make a backup copy of the existing agent configuration file (storability.ini). 

2. Make a backup copy of the contents of /opt/storability/etc/agents. 

3. Open the existing agent configuration file (storability.ini) in a system text editor. 

4. Locate the configuration section for the agent to be reinstalled. 

5. Delete all existing configuration settings for that agent. 

6. Save the modified agent configuration file. 

7. Remove the existing /opt/storability/etc/agents directory. 

At this point, you may reinstall the agent using the agent’s installation script.\ 




