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Introduction to Backup Agents 
Sun StorageTek Business Analytics provides three backup agents supporting the 
Semantec Veritas NetBackup, IBM Tivoli Storage Manager (TSM), and EMC Legato 
NetWorker backup products. 

Note With the acquisition of StorageTek, Sun Microsystems has re-branded and re-
named Global Storage Manager (GSM) as Sun StorageTek Analytics, a member of the 
Enterprise Storage Manager portfolio of software solutions. The functionality of Business 
Analytics is identical to GSM, only the name has changed. 

While the agents share broad areas of similarity, each agent has unique attributes that 
are based on the differences among the product lines and interfaces. Refer to the Sun 
StorageTek Business Analytics Support Matrix to obtain the latest information on 
supported backup products and support prerequisites. In addition, consult the Sun 
StorageTek Business Analytics Backup Reports Quick Facts Sheet to obtain an overview 
of the Sun StorageTek Business Analytics reports supported by a particular Backup 
Agent. 

Sun StorageTek Business Analytics provides three agent installation CDs: Windows Local 
Manager, Solaris Local Manager, and UNIX Agents (HP-UX and IBM AIX). To upgrade an 
installed Backup Agent, uninstall the previously installed Backup Agent before you install 
the current Sun StorageTek Business Analytics Backup Agent. The decision to upgrade 
an existing Backup Agent may be performed because: 

• The Sun StorageTek Business Analytics Release Notes indicate a problem has been 
fixed or a new feature added. 

• The upgrade is recommended by your Sun representative. 

Automatic and Static Agent Registration 
Automatic agent registration is a configuration option for agent data collection. In the 
storability.ini file, automatic agent registration is configured as follows: 
 
• Local Manager – Specify the IP address or host name of the Local Manager to be 

contacted to activate agent registration.  
• Local Manager Registration Port – Specifies the TCP port number used by the 

Local Manager for agent auto registration. The default port number is 17146. 
• Enable Auto Registration – Turns agent auto registration on (default) or off. 
 
To register the Backup Agent statically, proceed as follows: 
• Enter false in the Enable Auto Registration field.  
• Modify the Routing Agent static agent configuration to include an entry (port 

number|<agent IP address/name>)  
• Restart the Routing Agent 
• Restart the companion Central Manager agents 

Backup Agent Objects 
All of our backup agents publish the same objects. If a particular agent does not support 
a particular object, it publishes an empty object. 
 
Table 1 lists the objects that all Sun StorageTek Business Analytics backup agents 
publish.  
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Table Columns 
alerts-3_1 sourceip, priority, alert_id, progname, alert, time, 

firsttime, refreshedtime, int1, text1, text2. 
gsa_agent_version-2_0 ip_address, agent_name, version, compile_time, 

managed_entities, tz_name, tz, timestamp 
gsa_cache_contro0l-2_1 ip_address, port, table_name, cache_age, 

last_update_request_length, update_request_pending, 
group_name, group_master,timestamp 

gsa_ini_control-2_0 ip_address, port, domain, parameter, value, status, 
timestamp 

gsa_parm_info ip_address, port, object, parm_name, value_syntax, 
description, example 

gsa_backup_calendar ip_address, master_server, policy, schedule, 
backup_type, schedule_type, value_1, value_2, 
value_3, timestamp 

gsa_backup_cat_usage-2_3 ip_address, server_name, product, cat_path, 
blocks_used, blocks_available, filesystemid, timestamp 

gsa_backup_client_policy-2_1 ip_address, master_server, policy, active_status, 
effective_date, timestamp 

gsa_backup_detail_new ip_address, backup_id, copy_number, frag_number, 
kilobytes, remainder, media_type, density, 
file_number, media_id, block_sz, offset, media_date, 
dev_written_on, flags, timestamp 

gsa_backup_device_class ip_address, server_name, devclass_name, 
access_strategy, stgpool_count, devtype, format, 
capacity, mountlimit, mountwait, mountretention, 
prefix, library_name, directory, servername, 
retryperiod, retryinterval, shared, last_update_by, 
last_update, timestamp 

gsa_backup_events ip_address, job_id, class, client, schedule, 
schedule_type, storage_unit, volume_pool, status, 
error_msg, host_id, error_explanation, 
error_recommendation, timestamp 

gsa_backup_filelist-2_2 ip_address, backup_id, job_id, client, slave, master, 
storage_unit, class, file_list, job_type, kilobytes, files, 
status, message, start_time, timestamp  

gsa_backup_frequency ip_address, master_server, policy, schedule, 
backup_type, retention_level, frequency, 
day_of_week, open_window, close_window, 
timestamp 

gsa_backup_legato_err_msg ip_address, backup_id, job_id, sequence_num, 
error_msg, timestamp 

gsa_backup_libraries ip_address, server, library_name, library_type, acs_id, 
private_category, scratch_category, external_mgr, 
shared, lanfree, obeymntretention, primary_lib_mgr, 
last_update_by, last_update, timestamp 

gsa_backup_library_volumes ip_address, server, library_name, volume_name, 
status, owner, last_use, home_element, 
cleanings_left, timestamp 
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Table Columns 
gsa_backup_master ip_address, backup_id, client, class, class_type, 

proxy_client, creator, schedule, schedule_type, 
retention_level, start_date, elapsed_time, 
expiration_date, compressed, encrypted, 
backed_up_kb, backed_up_files, number_of_copies, 
number_of_frags, db_compressed, 
catalogue_file_name, status, timestamp 

gsa_backup_status_new ip_address, time, netbackup_version, message_type, 
message_severity, server, job_id, job_group_id, 
client, class, schedule, error_ms, timestamp 

gsa_backup_storage_pools ip_address, server, stgpool_name, pooltype, devclass, 
est_capacity_mb, pct_utilized, pct_migr_pct_logical, 
highmig, lowmig, migproess, nextstgpool, maxsize, 
access, description, ovflocation, collocate, reclaim, 
maxscratch, reusedelay, migr-running, migr_mb, 
migr_seconds, recl_running, recl_volume, chg_time, 
chg_admin, reclaimstgpool, mig_delay, migcontinue, 
dataformat, copystgpools, copycontinue, crcdata, 
timestamp 

gsa_backup_volhist ip_address, server, date_time, unique, time, 
backup_series, backup_operation, volume_seq, 
volume_name, location, command, timestamp 

gsa_backup_volume_info-2_1 ip_address, media_id, media_type_desc, media_type, 
barcode, description, volume_pool_type, 
rebot_type_desc, robot_type, robot_number, 
robot_slot, robot_host, volume_group, creation_date, 
assigned_date, last_mount_date, first_mount_date, 
expiration_date, number_of_mounts, 
max_mounts_allowed, timestamp, status, status_flags 

gsa_backup_volumes ip_address, server, volume_name, stgpool, 
devclass_name, est_capacity_mb, pct_utilized, status, 
access, pct_reclaim, scratch, error_state, num_sides, 
times_mounted, write_pass, last_write_update, 
last_read_date, pending_date, write_errors, 
read_errors, location, chg_time, chg_admin, 
timestamp 

gsa_media_list-2_2 ip_address,media_id, partner_id, version, density, 
allocated_date, last_written_date, expiration_date, 
last_read_date, bu_Kbytes, bu_images, 
bu_unex_images, retention_level, volume_pool, 
num_restores, status, media_type, status_flags, 
bu_server, timestamp 

gsa_backup_drives ip_address, server, library_name, drive_name, 
device_type, online, element, acs_drive_id, 
drive_state, allocated_to, last_update_by, clean_freq, 
timestamp 

gsa_backup_filespaces ip_address, server, nodename, filespace_name, 
filespace_id, filespace_type, capacity, pct_util, 
backup_start, backup_end, delete_occurred, 
unicode_fiilespace, filespace_hex_name, timestamp 

gsa_backup_occupancy ip_address, server, nodename, type, filespace_name, 
stgpool_name, num_files, physical_mb, logical_mb, 
filespace_id, timestamp 

gsa_backup_paths ip_address, server,source_name, destination_name, 
destination_type, library_name, node_name, device, 
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Table Columns 
ext_manager, lun, initiator_id, directory, online, 
last_update_by, last_update, timestamp 

gsa_backup_sched_events ip_address, server, scheduled_start, scheduled_end, 
actual_start, domain_name, schedule_name, status, 
result, reason, timestamp 

gsa_backup_summary ip_address, server, start_time, end_time, activity, 
number, entity, address, schedule_name, examined, 
affected, failed, bytes, idle, mediaw, processes, 
successful, volume_name, drive_name, library_name, 
last_use, comm._wait, timestamp 

Table 1 - Backup Agent Objects 

NetBackup Agent 
The following sections describe how to install, configure, and verify the Sun StorageTek 
Business Analytics NetBackup Agent. 
 
Note: The Sun StorageTek Business Analytics NetBackup Agent must be installed on the 
Semantec Veritas NetBackup Master server. 

NetBackup Agent Matrix 
 
Feature Description 

Support Prerequisites  
Verify supported version of NetBackup 
product 

See the current version of the Sun StorageTek 
Business Analytics Support Matrix 

Verify Ethernet connectivity to Master 
Servers 

ping <IP Address> 

Base Package (GSMbase) Required on Solaris server 
Storability Host Agent Required to support the Meta Database Capacity 

report for Semantec Veritas NetBackup. 
Agent Installation  
Windows  • Windows Local Manager Installation CD 

(InstallShield) 
• Windows Administrator privileges 
 

Solaris  • Solaris Local Manager Installation CD (package 
installation) 

• root user account privileges 
 

HP-UX • UNIX Agent Installation CD  
• root user account privileges 

Job History Retention Sun recommends retaining this information for a 
minimum of three (3) days, which is the Semantec 
Veritas NetBackup default value. 
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Feature Description 

Configuration Parameters See backup agent-specific configuration parameters in 
the Installation sections that follow. 

Integration with SNMP Extension 
for the Real Time Event report 

1. Requires installation and configuration of the 
Semantec Veritas SNMP Extension for Semantec 
Veritas NetBackup (NBU). For more information 
about functionalities, you may email: 
vxsnmp@veritas.com 

  
2. Requires reviewing/modifying the following 

NetBackup Agent configuration settings for SNMP: 
 

Note: The NetBackup Agent refreshes the events cache 
every five minutes. 

  NETB_SNMP_PORT 
  Default Value: 1100 

Specifies the port that will be used to listen for SNMP 
traps. 
 

  NETB_TRAP_VERITAS_SUCCESS 
  Default Value : 
1.3.6.1.4.1.1035.1.1.251.0.2 

Specifies the trap value that indicates success. 

  NETB_TRAP_VERITAS_FAIL 
  Default Value : 
1.3.6.1.4.1.1035.1.1.251.0.1 

Specifies the trap value that indicates failure. 

Table 2 - NetBackup Agent Matrix 

NetBackup Agent Installation 
The following sections provide instructions on installing the Sun StorageTek Business 
Analytics NetBackup Agent on supported platforms. 
 
Installing NetBackup Agent - Windows 

1. Insert the Sun StorageTek Business Analytics Windows Local Manager CD into the 
CD-ROM drive. 

2. Click Next> on the Welcome menu to continue the installation. 

3. Click Yes to accept the terms of the software license agreement. 

4. Review/modify the User Name and Company Name and click Next. 

5. Select the Veritas NetBackup Agent checkbox on the screen that lists agents for 
installation. 
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   Figure 1 - Select Features To Be Installed 

6. Review the settings and click Next> to continue. 

7. Specify whether or not to install the new version of the Configuration Tool, if 
prompted. 

8. When the Configuration Tool is automatically launched, select File -> Edit -> Smart 
Agent Configuration. 

9. Click the NetBackup Agent tab. 
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Figure 2 - NetBackup Agent Configuration Window 

10. Review/modify the following configuration parameters:  

Note: For the parameters that require specifying a folder/directory, you can click the 
Folder icon to browse your system, or click the template-supplied value to move 
that value into the respective input field. 

• Local Manager – Specify the IP address or host name for the Local Manager to 
be contacted for agent auto registration. The default value is localhost. 

• Local Manager Registration Port – Specify the TCP port number the Local 
Manager uses for agent auto registration. The default TCP port number is 
17146. 

• NetBackup Install Path – Specify the fully qualified path to the NetBackup 
software.  

• NetBackup VolMgr Install Path – Specify the fully qualified to the NetBackup 
Volume Manager. 

• bpimagelist output file– Enter the full path for the output file used data 
returned from the bpimagelist. command. 

• bpmedialist output file– Enter the full path for the output file to be used for 
the data returned from the bpmedialist. command 

• bpimmedia output file – Enter the full path to the output file to be used for the 
data returned from the bpimmedia command. 
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• bpdbjobs output file – Enter the full path to the output file to be used for the 
data returned from bpdbjobs command. 

• bperror output file - Enter the full path to the output file  to be used for the 
data returned from the  bperror command. 

• schedules output file - Enter the full path to the output file to be used for the 
data returned from the bppllist and bpplsched commands. 

• vmquery output file - Enter the full path to the output file to be used for the 
data returned from the vmquery command. 

• policies output file - Enter the full path to the output file to be used for the 
data returned from the bppllist, bpplclients, and bpplinfo commands. 

• Full path to NetBackup catalog directory - Enter the directory that will be the 
target of the cat_usage command. 

• min/hour: interval - Specifies how often the dbimport job is to run. The first 
part (0:0) specifies the start time in minutes:hours. For example, 0:2 sets a start 
time of 2:00 a.m. The second field (14400) specifies the interval in seconds. In 
this case, every four hours. The default value is every four hours starting at 
midnight. 

• Default collection period (hrs) - Enter the NetBackup Agent report period; the 
default value "24". 

11. Click Show Advanced Settings to review/modify the following configuration 
parameter: 

• Enable Auto Registration – Turns agent auto registration on (default) or off. 

12. With “Save Configuration Settings” turned on (check mark), select File->Save and 
confirm saving changes to the storability.ini file. 

13. Select File->Exit to close the Configuration Tool. 

14. Use the Windows Services panel to start the Storability NetBackup Agent before you 
verify agent functionality. 

Installing NetBackup Agent on HP-UX  
All currently supported HP-UX agents are provided as zipped tar archives with 
installation scripts. To install an agent, simply ensure that the archive  
(netBackupAgent-hpux.tgz) and the install script (netbackupAgent-install.sh) reside in 
the same location, and run the script.  
 
 ./netbackupAgent-install.sh 
 
HP-UX supports neither Rock Ridge nor Joliet extensions to the ISO 9660 filesystem 
specification. As a result, support for long filenames may not be available. 
 
During the installation, the installer must specify the following information: 
 
• The location of Perl if not detected 
• The location of NetBackup if not detected 
• The location of NetBackup vmquery if not detected 
• The location of the NetBackup catalogs if not detected 
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Agent Auto Registration 
To configure agent auto registration on an HP-UX server, you can add the NetBackup 
Agent to a Local Manager Routing Agent configuration as a SUB_AGENT entry or 
manually add the required entries to the agent storability.ini file.  Sample storability.ini 
file entries appear below. 
 
• GSM_LM_HOST = 192.168.1.132 
• GSM_LM_PORT = 17146 

• GSM_ENABLE_LM_REGISTRATION = true 

Installing NetBackup Agent - Solaris  
On the NetBackup Master Servers, install the following packages in the specified order: 

1. GSMbase  The base package 

2. GSMnbu  The NetBackup-for-Unix package 

If the base package was already installed, you only need to install the Sun StorageTek 
Business Analytics NetBackup Agent package. 
 
In the "software application administration settings" (admin settings), the installer can 
change the full path names to the data files from the master server, and the master 
server name. These data files are created by the dbimport.sh script.  
 
These files include the ones listed below: 
• Veritas imagelist file 
• Veritas filelist file 
• Veritas media list 
• Veritas immedia list 
• Veritas stat file  
• Veritas schedule file 
• Veritas vmquery file  
• Veritas client policy file 
• Veritas catalog directory  

 
A full pathname must be specified. It should contain a unique name for the host.  The 
default path for all of the files is: '/opt/storability/data/xfer/'. For example, the default 
path to the image list file is as follows: 

 
'/opt/storability/data/xfer/bpimagelist.cust2.out '. 
 

The installation procedure to install GSMbase and GSMnbu follows. 

1. Open a terminal window on the desktop of the Solaris host. 

2. Mount the installation CD in your CD-ROM drive. 

For example:   
 

  mount –o ro –F hsfs /dev/dsk/c0t6d0s0 /mnt 
 

Note: The device path used for the CDROM device may vary. 

3. Change to the appropriate package directory for the operating system you are 
installing on. For example:  
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    cd /mnt/Unix/Solaris/8 

4. Run the pkgadd command to obtain a list of available Sun StorageTek Business 
Analytics software packages to install  

    pkgadd –d . 

 
GSMbase 

5. Select GSMbase. 

6. Accept the default path by pressing Enter. The software need not be installed 
directly into /opt/storability.  However, in order to ease administration and 
maintenance, a symlink will be created from /opt/storability to the real installation 
location if you choose a different base directory. 

7. If the GSM group does not exist, you will be prompted to create the group. Agents, 
which do not require root privileges, will be run using a dedicated account 
(username gsm, group gsm).  That user account need not be set up yet, but the 
group ownership of all the Business Analytics agent files requires that the group 
exist.  

Enter y to create then group and then enter a GID to be used for the gsm group or 
press Enter to accept the default GID of 1090.  

8. If the selected installation directory does not exist, you will be prompted to create 
it.  Enter y to create the directory. 

9. After checking package dependencies, the installation will prompt to allow it to 
execute scripts with super-user privileges.  Enter y to allow the installation to 
continue. The installation of the GSMbase package will complete and return to the 
package menu. 

GSMnbu 

10. Select GSMnbu (Option 19). 

11. Specify the fully qualified path to the NetBackup base directory where the bp.conf 
file is located and press Enter. 

12. The installation script prompts you to specify the directory for the data files that 
dbimport creates. The default setting (/app/storability/data/netbackupAgent) does 
not need to be changed unless the server is part of a cluster. In this environment, 
the directory should be located under the shared file system (e.g., 
/usr/openv/storability). 

If you change the default directory, a symbolic link will be created to 
/opt/storability/data/netbackupAgent. 

13. The installation will then prompt to modify the ‘advanced’ settings for the GSMnbu 
agent.  Enter y and press Enter to review/modify the default values. 

• Local Manager – Specify the IP address or host name of the Local Manager to 
be contacted for agent auto registration. 

• Local Manager Registration Port – Specifies the TCP port number the Local 
Manager uses for auto registration; the default port number is 17146. 
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• Enable Auto Registration – Turns agent auto registration on (default) or off. 

14. The installation will then prompt to start the agent after the installation.  Enter y to 
start the agent after the installation completes. 

15. After checking package dependencies, the package will prompt to allow it to execute 
scripts with super-user privileges.  Enter y to allow the installation to continue. 

16. The installation of the GSMnbu package will complete, the agent will be started, 
and it will then return to the Sun StorageTek Business Analytics package menu.   

17. The installation is now complete; enter q to exit the menu. 

If you decide to install the Sun StorageTek Business Analytics Host Agent on the Solaris 
clients of the NetBackup server, the following packages need to be installed on them in 
the following order: 

1. GSMbase - The base package 

2. GSMhost - The Host Agent package 

NetBackup Agent Installation in Cluster Environment Notes 
Typically in a clustered NetBackup environment, the /usr/openv filesystem is configured 
on shared disk. As a result, when the node fails over, that filesystem moves to the 
primary node. Our installation approach is summarized as follows: 
 
• Install the NetBackup Agent agent on both the primary and secondary nodes. When 

the NetBackup Agent is installed, a binary file called dbimport is installed.  It 
contains the commands used to extract the data from NetBackup. The NetBackup 
CLI commands extract the data that is then put in the configured ".out" files in the 
“opt/storability/data/netbackupagent” directory.  When a collect message is received 
by the NetBackup Agent, it parses those files and returns data upstream to the 
Routing Agent. Dbimport always checks to see if that NetBackup Agent data 
directory exists and will terminate if it does not.   

• Create a symbolic link from the opt/storability/data/netbackupagent directory to a 
directory on the /usr/openv filesystem. By putting a symbolic link to the shared disk, 
it is certain that the dbimport on the backup node will never run (because the 
directory doesn't exist as it is mounted to the active node).  When the failover 
occurs, the /usr/openv filesystem is moved along with all NBU processes at which 
time dbimport will now see the data directory and will execute the population of the 
'out' files. 
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Legato Agent  
The following sections describe how you install and configure the Sun StorageTek 
Business Analytics Legato Agent on supported platforms. Note: The Legato Agent must 
be installed on the Legato NetWorker backup server. 

Legato Agent Matrix 

Feature Description 

Support 
Prerequisites 

 

Verify supported 
version of Legato 
NetWorker product 

 

Verify Ethernet 
connectivity to Backup 
Servers 

ping <IP Address> 

Storability Host Agent Required to support the Meta Database Capacity report. 
Agent Installation  
Windows  • Windows Local Manager Installation CD (InstallShield) 

• Windows Administrator privileges 
 

Solaris  • Solaris Local Manager Installation CD (package installation) 
• root user account privileges 
• GSMbase 

Configuration 
Parameters 

The configuration parameters for each backup agent are specific 
to that agent. See the required configuration parameters in the 
Installation sections that follow. 

Table 3 - Legato Agent Matrix 

Installing Legato Agent - Windows 

1. Insert the Sun StorageTek Business Analytics Windows Local Manager CD into the 
CD-ROM drive. 

2. Click Next on the Welcome menu to continue the installation. 

3. Click Yes to accept the terms of the software license agreement. 

4. Review/modify the User Name and Company Name and click Next. 

5. Click the Legato Agent checkbox on the screen that lists agents for installation and 
click Next. 
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  Figure 3 - Select Features To Be Installed 

6. Review the settings and click Next to continue with the installation. 

7. When the dialog box appears, specify where the required mminfo.exe program is 
located. You can click the Browse button to locate it.  

8. Specify whether or not to install the new version of the Configuration Tool, if 
prompted. 

9. When the Configuration Tool is automatically launched, select File -> Edit -> Smart 
Agent Configuration. 

10. Click the Legato Agent tab and review/modify the following settings: 
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Figure 4 - Legato Agent Configuration Window 

 

• For Local Manager, specify the IP address or the host name of the Local 
Manager to be contacted for agent auto registration. 

• For Local Manager Registration Port, specify the TCP port number the Local 
Manager uses for agent auto registration. The default port number is 17146. 

• For Legato Header Terminator, specify the text string that marks the end of 
the syslog stamp and the start of real data. The default value is “lgtowin01:”. 

11. Click Show Advanced Settings and review/modify the following configuration 
parameters: 

• Enable Auto Registration turns agent auto registration on (default) or off. 

• Legato Networker Message File - Enter the fully qualified file name (e.g., 
c:\Program Files\nsr\logs\messages) for the file that provides the list of 
messages contained within the Legato completion reports. 

• Directory containing Legato binaries - Enter the full path to the folder where 
the Legato Networker software is installed. 

• Legato Agent Collection Interval - Enter the polling interval in seconds to 
scan for new completions of server backups in the Execution Interval column. 
This parameter is optional.  If not specified it defaults to one half hour (14400 
seconds). 
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• Legato Record Cache Expiration - Enter the polling interval in seconds to scan 
for new completions of server backups. This parameter is optional.  If not 
specified, the default value is one half hour (86400 seconds). 

• Legato Index Directory – Enter the full path to the Legato index directory. 

• Legato Messages to Ignore – Enter the full path to the file (e.g., 
IgnoreMsgs.txt) containing a list of completion messages to be ignored by the 
agent. 

• Legato End of Record Msgs – Enter the full path to the file (e.g., EorMsgs.txt) 
containing additional strings treated as an End of Record delimiter in the 
messages log. 

12. With “Save Configuration Settings” turned on (check mark), select File->Save and 
then close the storability.ini window. 

13. Select File->Exit to close the Configuration Tool. 

14. Use the Windows Services panel to start the Storability Legato Agent before you test 
agent functionality. 

 
Installing the Legato Agent - Solaris 

1. Open a terminal window on the desktop of the Sun host. 

2. Mount the installation CD in your CD-ROM drive. 

3. Change to the directory for the operating system you are installing on. For example: 

  cd /mnt/Unix/Solaris/8 

4. Run the pkgadd command. 

   pkgadd –d . 

5. Select the GSMlegato agent from the package installation menu. 
The Storability Software License Agreement appears. 

6. Specify the following required information: 

• Local Manager - Enter the network resolvable host name or IP address of the 
Local Manager that the Legato Agent will contact for agent auto registration, if 
enabled. 

• Local Manager Port – Specify the TCP port number the Local Manager uses for 
agent auto registration. The default TCP port number is 17146. 

• LEGATO_DIR – Specify the fully qualified path to directory where the nsradmin 
binary is located. 

• LEGATO_CAT_DIR – Specify the fully qualified path to the NetWorker index 
directory. 

• LEGATO_MESSAGE_FILE – Specify the fully qualified path to the Legato 
NetWorker messages log. 
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• LEGATO_HEADER_TERMINATOR – Specify the text string that marks the end 
of the syslog stamp and the start of real data. 

• LEGATO_IGNORE_MSGS – Specifies the fully qualified path to the file 
containing a list of completion messages to be ignored by the agent.  

Note: In addition to this file, a line on which a timestamp is immediately followed 
by an asterisk (*) will be ignored by the agent. 

• LEGATO_CLIENT_CMDS – Specifies the fully qualified path to the file containing 
commands used to gather client data. 

7. Type y and press Enter to review/modify the Advanced Settings: 
 

• Enabled Auto Registration – Turns agent auto registration on (default) or off. 

• Enter the MAXIMUM_CACHE_AGE (in seconds). 

• Enter the Data Collection Interval (in seconds). 

8. Enter y to restart the agents after installation. 

9. When prompted, type y to allow the installation script to run with super-user 
permissions. 

10. The installation will complete and return you to the main package installation menu. 

11. Enter the number for any other package you wish to install, q or to quit. 

Tivoli Storage Manager (TSM) Agent  
The following sections describe the installation and configuration of the Sun StorageTek 
Business Analytics TSM Agent. Currently, the TSM Agent must be installed on a 
supported Windows 2000 server. See also the Sun StorageTek Business Analytics 
Support Matrix. 
 
TSM Agent Matrix 
 
Feature Description 

Support 
Prerequisites 

 

Verify supported 
version of TSM product 

 

Verify Ethernet 
connectivity to 
Windows 2000 server 

ping <IP Address> 

Verify supported 
version of TSM ODBC 
Driver 

See the TSM ODBC System DSN Prerequisite section that follows 
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TSM Agent Matrix 
 
Feature Description 
Verify customer-
supplied 
login/password with 
query privileges or 
higher for each TSM 
database connection 

 

Agent Installation  
Windows 2000 • Windows Local Manager Installation CD (InstallShield) 

• Windows Administrator privileges 
 

Configuration 
Parameters 

See required configuration parameters in the Installation section 
that follows. 

Table 4- TSM Agent Matrix 

TSM ODBC System DSN Prerequisite 

The procedure to create the required System Data Source Name is outlined as follows: 
 
1. Select Start->Settings->Control Panel -> Administrative Tools from the Windows 

desktop. 
2. Select ODBC Data Sources to launch the ODBC Data Source Administrator. 
3. Click the System DSN tab. 
4. Click Add and the Create Data Source screen appears. 
 
 

 

Figure 5 - Create New Data Source for TSM ODBC Driver 

5. Use the scroll bars to verify a supported version of the TSM ODBC Driver is installed, 
and select the TSM ODBC Driver for the data source you are creating. The Configure 
a Data Source screen appears. 

6. Enter a descriptive name for the System DSN that will be used to connect to a TSM 
database server in the Data source name field. 

7. Enter the TCP/IP address to connect to the TSM database server in the TCP/IP 
address field. 
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Figure 6 - Configure a TSM Data Source 

 
Note: Sun StorageTek highly recommends that you use a third party ODBC query tool 
(e.g., QTADO) to verify the System DSN before you deploy it with a TSM Agent. 
 
Installing the TSM Agent - Windows 

The following section describes how to install and configure the TSM Agent on a 
Windows platform.  

1. Insert the Local Manager CD into the CD-ROM drive. 

2. Click Next on the Welcome menu to continue the installation. 

3. Click Yes to accept the terms of the software license agreement. 

4. Review/modify the User Name and Company Name and click Next. 

5. Click the TSM Agent checkbox on the screen that allows you to select agents for 
installation and click Next. 



Page 22 Backup Agents Installation Guide 

 

 

   Figure 7 - Agent Selection Dialog 

6. Review the settings and click Next to continue. 

Note: Installation checks for an instance of the TSM ODBC driver. If one is not 
detected, a dialog box appears that asks the installer to specify whether or not to 
continue the installation. 

7. Specify whether or not to install the new version of the Configuration Tool, if 
prompted. 

8. When the Configuration Tool is automatically launched, select File -> Edit -> Smart 
Agent Configuration. 

9. Click the TSM Agent tab and click Add. 
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Figure 8 - TSM Agent Configuration Window 

10. Review/modify the following variables: 

• DSN - The data source name that you configured when you created the System 
DSN  

• TSM Server Prefix- Optional string to be pre-pended to the server name TSM 
returns for this DSN. For example, host_name_servername. 

• User ID - User name to log into the TSM database 
• Password – Password for the user to log into the database  
• Period for Queries – Time interval (in seconds) that the agent should look back 

for historical queries. The default value is 86400 seconds (1 day). 
   

11. For Local Manager, enter the network resolvable host name or IP address of the 
Local Manager to be contacted for agent auto registration. 

12. For Local Manager Registration Port – Specifies the TCP port number the Local 
Manager uses for agent auto registration. The default port number is 17146. 

13. Click Show Advanced Settings to review/modify: 

• Enable Auto Registration - Turns agent auto registration on (default) or off. 

• Data Collection Interval (seconds) – Specifies how long agent data is cached; 
the default interval is 2400 seconds. 

14. With “Save Configuration Settings” turned on (check mark), select File->Save and 
confirm saving changes to the storability.ini file. 

15. Select File-Exit to close the Configuration Agent. 

16. Use the Windows Services panel to start the Storability TSM Agent before you verify 
agent functionality.  

Starting the agent will initiate a data collection. Depending on the size of your 
backup environment, this can utilize a significant amount of memory. 
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Verifying Backup Agent 
Use the GSM Agent Diagnostic Tool to verify the Backup Agent functionality. This tool is 
installed as part of the Central Manager or Local Manager software installation in the 
Storability Local Manager Utilities folder. It represents the primary tool to verify agent 
functionality or troubleshoot agent problems.  

Proceed as follows: 

1. Wait approximately 30 seconds after the Backup Agent has started to allow it to 
initialize before querying it with the GSM Agent Diagnostic Tool. 

a. In the Agent location window, enter the IP Address or network resolvable Host 
Name of the server where the agent is installed in the ip address/host name 
input box. 

b. Select the backup agent (e.g., Storability NetBackup Agent) from the drop down 
list of service names. 

c. Click the Get Object List button and you should receive a list of objects 
published by the agent.  

d. Check the agent configuration settings in the storability.ini file; collect the 
gsa_ini_control-2_0 object. 

 

 

Figure 9 - Sample NetBackup Agent Configuration Settings 
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Figure 10 - Sample Legato Agent Configuration Settings 

e. Select the gsa_backup_client_policy-2_2 object and verify that data is 
returned including IP Address, client, and policy. 

f. Proceed to verify all other objects published by the agent.  

2. To verify the Backup Agent has registered successfully with its configured Local 
Manager: 

a. In the Agent location window, enter the IP Address or network resolvable Host 
Name of the Local Manager in the ip address/host name input box. 

b. Set the port to 17146 (or select the Storability Routing Agent from the drop down 
list of service names).  

c. Click the Get Object List button and you should receive a list of objects 
published by the Routing Agent. 

d. Select the gsa_agent_register table. 

e. Verify this collected object reports the Backup Agent in the “active_peer” field by 
IP address (where the agent is installed) and appropriate port number: 

• Storability NetBackup Agent – TCP port number is 17133. 

• Storability Legato Agent – TCP port number is 17149 

• Storability TSM Agent – TCP port number is 17156 
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Verifying Management Console Functionality 
The following procedure describes how the administrator verifies the Backup Agent’s 
reports in the Management Console. Refer to the Administration chapter to obtain 
information on the administrative menus you can access from the Tools pull down 
menu, including the Polling and Change Dashboard menus. 
 
Note: You must be assigned Backup Administrator privileges to have access to the 
Backup Exceptions, Meta Database Capacity, Real Time Events, Backup Exposure, and 
TSM Daily Administration reports. Refer to the User Administration section of the 
Administration documentation to obtain additional information. 
 
1. Log in to the Management Console as an administrative user (e.g., gsmuser) whose 

view provides access to the desired assets (e.g., sites). 
2. Verify that your customized Home Page includes the Backup Status Summary 

dashboard or the TSM Summary Report pane as appropriate (or use Change 
Dashboard to choose one). 

3. Select Tools->Polling. In the Data Polling Schedule menu, locate appropriate 
Collection Type and Collection Metric polling schedules for the backup product.  

 

Figure 11 - Polling Schedules 

 

4. Click the Collect Now for the first on-demand agent data request for a Collection 
Type and Collection Metric related to the Backup Agent. 

5. Repeat the above step until you have collected all the data, including the Collection 
Type of Backup – Common, for the Backup Agent. Wait approximately thirty seconds 
between each on-demand agent data collection request. 
 
Note: The actual time it takes to collect backup information will vary depending on 
the size of the backup environment. 

6. Close the Polling Schedules window. 
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7. Use the Backup Status Summary pane for Veritas/Legato or the TSM Summary 
Report pane to determine if collected data is visible through the Management 
Console. It is normal for the Backup Status Summary pane to not display 
information if no failures occurred over the past 24 hours. 

8. Close the browser session with the Management Console as the above steps 
complete verifying basic Management Console functionality. 

Backup Agent Troubleshooting 
 

1. Verify system/agent prerequisites – Refer to Sun StorageTek Business Analytics 
Support Matrix that is located on the Documentation CD to verify the most recent 
support requirements for the Backup Agent. 

2. Use the Agent Diagnostic Tool to save the output for all the agent published objects 
if escalating a problem to Sun Technical Support. 
a. Run GSMdiag located in the Storability Local Manager Utilities folder. 
b. Enter the IP Address or Hostname of the server where the agent is installed 

and set the port by selecting the Backup Agent from the drop down list of service 
names. 

c. Click the Get Object List button and you should receive a list of tables published 
by the Backup Agent. If unsuccessful, verify the Ethernet connectivity to the 
server running the Backup Agent and that the agent is running. 

d. Select the alerts-3_1 table and examine the Description column for each 
reported alert. 

e. Select File->Save All and the “This action will network fetch all objects 
published by the currently specified agent and save the data to a single file.” 
Message appears.  

f. Click OK and the Save As dialog appears.  
g. Enter a meaningful file name and click OK to initiate the collection. 

 
3. Review the Message Log – Review/collect the agent’s Message.log file that can 

contain information on startup errors, configuration errors, or errors regarding 
accessing data or parsing output. 
 
Windows 

 
• Located by default in: <drive>:\Program Files\Storability\GSM\Agents\Storability 

<Backup Agent> Agent folder. 
• Can enable debug level logging by appending LOG_SEVERITY=Debug to the 

Backup Agent section of the storability.ini file (if a Support representative 
requests it). 

Solaris 
 

• The agents’ common Message.log file located by default in: /opt/storability/data. 
• Can enable debug level logging by appending LOG_SEVERITY=Debug to the 

Backup Agent section of the storability.ini file (if Sun Support requests it). 
 

4. Verify Local Manager Registration - The configured Local Manager 
gsa_agent_register table should be reviewed to verify a registration type (STATIC 
or AUTO_NET) is reported for the backup agent. If static registration is being used 
and no agent registration is reported, verify the necessary SUB_AGENT entry has 
been added to the Routing Agent’s storability.ini file and restart the Routing Agent. 

 
If agent auto registration is being used and no registration is reported in 
gsa_agent_register, proceed as follows: 
 

 Routing Agent’s storability.ini file has “Activate Agent Registration” turned on. 
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 Backup Agent is configured for agent auto registration: 
- Valid Local Manager IP address/host name 
- Local Manager TCP port number is 17146 (default port number) 
- Enable auto registration is turned on (true) 

 
5. Review the Routing Agent Message Log – Review/collect the configured Routing 

Agent’s Message Log to check for errors related to Ethernet connectivity problems 
contacting the Backup Agent. 

6. Confirm Polling Schedules – Using the Management Console’s Polling Schedules 
window, review/modify the existing Polling Schedules for the Collection Type and 
Backup product. Clicking the Job ID link on the Polling Schedules window opens the 
Add a New Polling Job window where changes can be made. 

 

 

Figure 12 - Add a New Polling Job 

 
7. Review Aggregator Message Log – Open the Aggregator’s Message Log in a text 

editor and validate that the Backup Tables are being requested and that rows are 
being inserted into the database. 
The log contains two entries, TID (Transaction ID) and SID (Session ID), which can 
help you locate (e.g., Find) and view relevant logged entries. For scheduled polling 
requests, the TID will be equal to the Job ID in the Polling menu. Each SID is a 
unique identifier for a particular agent data collection session. For on-demand polling 
requests, the TID is a uniquely generated TID (not the Job ID) and SID, and the TID 
and SID will be equal to the same integer value.  

8. Check the assurent database – The assurent database is the data repository for 
your Business Analytics application. For the Backup Agent, use any MS SQL Query 
interface, such as isql, to verify rows have been inserted into the Backup-related 
tables for the particular backup product.  Refer also to Table 2 - Populated Tables 
Matrix. 
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9. Verify Management Console Functionality – As a final step in the agent 
troubleshooting procedure, minimally verify that the Backup Status Summary or 
TSM Summary Report dashboard pane works properly. 

Upgrade Backup Agent  
To upgrade a Sun StorageTek Business Analytics Backup Agent, you perform the 
following procedure: 
 
1. Uninstall the previously installed Backup Agent. 
2. Upgrade by installing the latest Backup Agent supplied with your Sun StorageTek 

Business Analytics software. 

Uninstall Backup Agent - InstallShield 
1. Select Start->Program Files->Storability->Uninstall->Uninstall Local 

Manager      
Or: 
Start->Program Files->Storability->Uninstall->Uninstall <Backup Agent 
Name>.  The Storability Uninstall dialog appears. 

2. Click the checkbox for the particular agent (e.g., NetBackup Agent). 
3. Click Next>. The Question dialog appears. 
4. Click Yes to confirm the uninstalling the agent. An uninstalling agent splash box 

appears as each selected agent is uninstalled. 
5. When the InstallShield Wizard Complete dialog box appears, click Finish. 

Uninstall Backup Agent – Solaris 
1. Create a backup copy of the existing storability.ini file. 

2. Type: 

pkgrm GSM<backup agent name> e.g., GSMnbu 

3. At the “do you want to remove this package” prompt, enter y and press Enter. 

4. At the “do you want to continue the removal of the package?” prompt, type y and 
press Enter. The “Removal of GSM<agent name>” agent was successful” message 
should appear to indicate the package was removed successfully. 

Reinstall Backup Agent – Non-Solaris UNIX Host 
The reinstallation procedure for all Storability agents supported on non-Solaris UNIX 
hosts, such as the NetBackup Agent on a HP-UX server, requires that the installer 
perform the following steps before running the agent’s installation script: 

1. Make a backup copy of the existing agent configuration file (storability.ini). 

2. Make a backup copy of the contents of /opt/storability/etc/agents. 

3. Open the existing agent configuration file (storability.ini) in a system text editor. 

4. Locate the configuration section for the agent to be reinstalled. 

5. Delete all existing configuration settings for that Storability agent. 

6. Save the modified agent configuration file. 
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7. Remove the existing /opt/storability/etc/agents directory. 

At this point, you may reinstall the agent using the agent’s installation script. 




