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Introduction 
Getting Started is designed for the Sun StorageTek Business Analytics administrator 
who: 

• Is familiar with the Sun StorageTek Business Analytics software components and 
tools. 

• Does not require detailed instructions to install, configure, and verify these 
software components. 

 
Notes: 
• With the acquisition of StorageTek, Sun Microsystems has re-branded and re-

named Global Storage Manager (GSM) as Sun StorageTek Analytics, a member of 
the Enterprise Storage Manager portfolio of software solutions. The functionality 
of Business Analytics is identical to GSM, only the name has changed. 

• If you want to obtain more detailed, step-by-step procedures to install, configure 
and verify a first time installation of the infrastructure software components (or 
an upgrade installation), refer to the Installation manual.  

• Always refer to the Sun StorageTek Business Analytics Release Note to obtain the 
latest information on Sun StorageTek Business Analytics. 

Deployment Types 
There are several types of deployments: 

• First time deployment of Sun StorageTek Business Analytics 5.0 SP1 software 
components 

• Upgrade deployment of Sun StorageTek Business Analytics (e.g., upgrading GSM 
Release 4.0 SP4 to Sun StorageTek Business Analytics Release 5.0 SP1).  

The Installation chapter has separate instructions for each type of Sun StorageTek 
Business Analytics deployment. This chapter summarizes the procedure for a first 
time installation. 

Implementation Summary 
This implementation process may be divided into the following steps: 

1. Verify/install the Sun StorageTek Business Analytics Central Manager 
prerequisites. 

2. Verify/install the Sun StorageTek Business Analytics Management Console 
prerequisites. 

3. Install Sun StorageTek Business Analytics Central Manager on your Windows 
2000/2003 server. 

4. Install the software license file on the Central Manager. 

5. Configure and start the Central Manager agents. 

6. Install the Management Console on your Windows 2000/2003 server. 

7. Configure the Sun StorageTek Business Analytics application using the 
Management Console. 

8. Verify the basic functionality of the Management Console components. 

9. Install and configure Sun StorageTek Business Analytics Local Managers. 

10. Install and configure Sun StorageTek Business Analytics Smart Agents. 



Getting Started Page 5 
      

The following sections describe the high-level tasks to deploy and verify a Sun 
StorageTek Business Analytics Release 5.0 SP1 first-time implementation. 

Implementation Steps 

Step 1: Verify/Install Central Manager Prerequisites  
 
1a. Verify/install MSL SQL Server Database software. 
1b. Install and configure Database Client Software. 
 
Step 1: Checklist 
 
� If not installed, install Microsoft SQL Server using the instructions that the 

Installation chapter provides. 
�  Install Microsoft SQL Server Service Pack 3 (or higher) after you install Microsoft 

SQL Server. 
�  Install Microsoft data access client (this should be installed as part of SQL Server 

2000). 
�  Ensure the database client software can access the database server prior to 

installing the Central Manager software. 

Step 2: Verify/Install Management Console Prerequisites  
 
� 2a.  Verify/ install Microsoft IIS 5.0 or IIS 6.0. If you are using IIS 6.0, enable 

Active Server Pages.  
 
Verify Microsoft IIS is installed on the Management Console 
To verify the Microsoft IIS 5.0 or 6.0 requirements, proceed as follows: 

1. Open Internet Explorer on the Management Console server and enter a URL of 
http://127.0.0.1.  If the default page is not returned, IIS is not running, or more 
likely is not installed. If IIS is not installed, install it from the Windows 
2000/2003 installation CD. 

Install Microsoft IIS 5.0 
The installation procedure for IIS 5.0 is summarized as follows: 

2. Install and enable Microsoft IIS. 

3. Using the Windows Services panel, confirm the service is configured to auto-
start and is running before proceeding to the next step. 

Install Microsoft IIS 6.0 for Management Console 
The installation procedure for IIS 6.0 is summarized as follows: 
 
1. From the Start menu, click Control Panel.  
2. Double-click Add or Remove Programs.  
3. Click Add/Remove Windows Components.  
4. In the Components list box, click Application Server.  
5. Click Details.  
6. Click Internet Information Services Manager. 
7. Click Details to view the list of IIS optional components.  
8. Select all the optional components you wish to install. The World Wide Web 

Publishing Service optional component includes important subcomponents like 
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the Active Server Pages component and Remote Administration (HTML). To view 
and select these subcomponents, click World Wide Web Publishing Service and 
then click Details. 

9. Click OK until you are returned to the Windows Component Wizard. 
10. Click Next and complete the Windows Component Wizard. 
11. Click Start -> Administrative Tools -> IIS Manager (or load the Control 

Panel, enter the Administrative Tools folder, and double click IIS Manager). 
12. Go to the Web Service Extensions tab. 
13. Click Active Server Pages, and then press the "Allow" button on the left. Active 

Server Pages should now work. 
14. To prevent IIS from timing out before the Management Console, perform the 

following procedure: 
a. Open Properties on the Default Web Site.  
b. On the first tab (Web Site), change the Connection Timeout to 900 seconds, 

which is the setting used in IIS 5.0. 
 

Note: It is recommended that you set the resolution to greater than 256 colors on 
the Microsoft IIS Web server on which you install the Sun StorageTek Business 
Analytics Management Console. 

Step 3: Install Central Manager  
 
� 3a. Install Sun StorageTek Business Analytics Central Manager. 
� 3b. Perform post-installation tasks. 
 
Step 3a: Installation 
The Sun StorageTek Business Analytics Central Manager is an Install Shield-based installation. 
The Typical setup option installs the Data Aggregator, Routing Agent, License Agent, the Policy 
Agent, the Scheduler Agent, the Data Polling Agent, the Remote Host Agent, and the Host 
Agent as well as initializes the assurent and portal databases. It also creates the Scheduled 
Jobs in the Windows Scheduler.  
 
The SRM Agent and Proxy Agent can be optionally installed on the Sun StorageTek Business 
Analytics Central Manager by selecting the Custom installation option.  
 
Note: The Host Agent for Windows requires the Microsoft Disk Manager Diagnostics 
(dmdiag.exe) utility to report physical and logical volume information for dynamic disks.  This 
can be downloaded for Windows 2000 servers from Microsoft at the following URL: 
 
http://www.microsoft.com/windows2000/techinfo/reskit/tools/existing/dmdiag-o.asp 
 
In addition, you need to verify the installation directory of the EMC PowerPath software, if 
applicable, to enable end-to-end storage mapping in the reports. 
 
� Is EMC PowerPath software installed? 
� If installed, what is the location of the powermt executable program?  
 
Step 3b: Post-Installation Tasks 
 

1. Close the Configuration Tool that auto-launches after the installation is 
completed. You will configure the agents after you verify the Central Manager 
Database Setup completed successfully. 

2. If errors were encountered during the installation, review the installation log file: 
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� Check <install drive>:\Program Files\Storability\GSM\CminstallLog.txt for any warnings or 
error messages. 

 
Notes: The most common installation problem is the inability of the Central Manager Database 
Setup to install the databases.  This is typically because the database client software is not 
installed or configured, or the wrong username/password has been supplied to the installation 
program. 

Step 4: Install Software License  
1. Copy the Sun StorageTek Business Analytics license file (supplied separately by 

your Sun representative) to the Central Manager Routing Agent’s directory/folder 
on the Central Manager. The default installation path is: <install path>\ 
Program Files\Storability\GSM\Agents\Storability Routing Agent. 

2. Paste the license file in the above specified folder and save the file as 
license.txt. 

Note: You can verify that the Central Manager Routing Agent located a valid 
software license at startup by either checking the agent’s Message log for a logged 
message or by viewing the Management Console’s License Report (see the 
Administration chapter). 

Step 5: Configure and Start the Central Manager Agents 
 
� 5a.  Use the Configuration Tool to configure the agent-specific configuration 

 settings. 
� 5b.  Start the agents installed on the Sun StorageTek Business Analytics Central 

 Manager.  
� 5c.  Verify the Central Manager Agents’ functionality. 
 
Step 5a: Central Manager Agent Configuration 
The Configuration Tool is used to configure the Sun StorageTek Business Analytics 
agents that you have installed on the Central Manager. These agents must be 
installed, configured, and running before you set up agent data collection using the 
Management Console’s Polling Schedules menu.  
 
Notes: The GSM_LM_HOST, GSM_LM_PORT, and GSM_ENABLE_LM_REGISTRATION 
settings in the storability.ini file are used to control agent auto registration of Sun 
StorageTek Business Analytics agents. All agents installed on the Sun StorageTek 
Business Analytics Central Manager require “GSM Upstream Messaging” to be 
enabled with the exception of the Routing Agent. 
 
Launch the Configuration Tool 
 
1. Select Start->Programs->Storability->Launch Configuration Tool on the 

Sun StorageTek Business Analytics Central Manager to launch the Configuration 
Tool. 
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Figure 1 - Configuration Tool Splash Screen 

 
2. Select File->Edit->Smart Agent Configuration. The Smart Agent 

configuration main window is displayed, similar to the one shown below that has 
the License Agent tab enabled. 

 

 

Figure 2 - Storability License Manager Configuration Window 
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Configure Routing Agent 
A Sun StorageTek Business Analytics Central Manager (or Local Manager) runs a 
Routing Agent, whose primary responsibility is to perform agent data collection 
within the messaging infrastructure. 
 
Note: Because the Sun StorageTek Business Analytics Central Manager runs the 
Routing Agent, it is by definition also a Local Manager. However, the Central 
Manager Routing Agent serves as the top-level Routing Agent in the messaging 
infrastructure. 
 
Proceed as follows to configure this agent: 
 
1. Launch the Configuration Tool. 
2. Select File->Edit->Smart Agent Configuration. 
3. Click the Routing Agent tab. The Routing Agent Configuration Window, with 

Show Advanced Settings turned on, is shown below. 
 

 

Figure 3 - Routing Agent Configuration Window 

 
4. In the Routing Agent ID input box, enter the unique integer value to identify 

the Central Manager Routing Agent. The default Local Manager ID that the 
installation creates for the Default Local Manager is 300. Refer to the 
Administration chapter for additional information on Site/Local Manager 
Administration as well as the Default Local Manager and Default Site.  
Notes: If you leave the RID parameter field blank, a default RID of 1 is assigned 
when the Routing Agent is started. This RID will not match any Local Manager ID 
that is generated using the Management Console’s Site/Local Manager 
Administration menus. This condition will cause collected agent data to be 
written to the Sun StorageTek Business Analytics database, but it will not appear 
in the Management Console application! 
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5. Leave the Parent Routing Agent IP input box empty (blank); this parameter 
only has meaning for Local Manager Routing Agents. 

6. For the Port used to publish tables parameter, specify the TCP port on which 
the Central Manager publishes its objects. The default port number is 17130. 

7. For TCP Connect Timeout, accept the default time interval (10 seconds) to 
connect to an agent, which should be fine for most TCP environments. 

8. For Data Timeout, this parameter is generally ignored because the value is 
over-ridden by a system parameter passed to the Routing Agent by clients. The 
default value is 300 seconds. 

9. If your Central Manager Routing Agent will collect agent data from agents that 
are not configured to use auto registration, proceed as follows: 

 
a. Click Change Option Values button next to the Static Sub Agent 

heading. The Enter Static Sub Agent Registrations dialog box appears. 
b. Type the port number and IP address pair or the port number and server 

name pair to define each SUB_AGENT entry in the storability.ini file. 
c.   Click Submit after you have completed all the static agent registrations. 

 
10. Click Show Advanced Settings to review/modify the following configuration 

parameters: (Note: You do not have to make entries in this section unless you 
want to change from using the agent defaults.) 

 
• Allow GSM Upstream Messaging – Turns on (true) or off (false) having this 

agent publish the gsa_message object. For the Storability Routing Agent, 
this value should be turned off (false), which is the default value. 

• Auto Activate Registration – Allows the Central Manager by default to 
automatically activate incoming agent registrations. 

• Specific Network Interface to Bind to - The value may be an IP address, 
specified in standard Internet dot (“x.x.x.x “) notation, or a name service 
resolvable hostname. This option allows you to bind the Routing Agent to a 
specific network interface in a dual-homed computer, for example. If you do 
not bind the Routing Agent to a specific network interface, the Routing Agent 
will bind to all available local interfaces. 

• Max Number of Threads – Sets the number of threads the agent will 
spawn. A rule of thumb is to set this value to one half the number of 
immediate sub-agents (number of rows in the Routing Agent’s 
gsa_agent_register object, where rid = RID). This should be set no lower 
than five (5) and no higher than fifty (50). The default value is ten (10). 

• Number of Days Agents Remain Registered - Specifies the maximum 
number of days an agent can be down and remain registered. Its purpose is 
to provide a simple mechanism for removing records of agents that are no 
longer installed. When expired, the sub-agent registration is removed. 
However, the agent can always re-register if it ever comes back online. 

• Agent Registration Cache File – Is <drive>:\Program 
Files\Storability\Agents\Storability Routing Agent\ardb.dat by default. The 
agent registration cache file (e.g., ardb.dat) file will be created after the 
Routing Agent has been started. 

• License File Name – Use the Folder icon to specify the fully qualified name 
of the software license file; is <drive>:\Program 
Files\Storability\Agents\Storability Routing Agent\license.txt by default. 

• License Audit Frequency – Specifies how often to perform license audit; 
default value is 6 hours. The maximum value is 46 hours. 

• Frequency to Poll Agent Meta Table - Specifies how often in seconds to 
gather object schemas from sub agents.  
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11. With the “Save Configuration Settings” check box enabled, select File->Save 
and confirm your changes to the storability.ini file. 

12. Select another agent tab to review/modify its configuration settings or click File-
>Exit to close the Configuration Tool. 

 
Configure License Agent 
The Sun StorageTek Business Analytics License Agent supports the new Management 
Console Licensing report.  
 
Proceed as follows to configure this agent: 
 
1. Click the LicenseAgent tab within the main configuration window. 
2. For Local Manager, enter the network resolvable host name or IP address of the 

Local Manager to be contacted for agent auto registration. The default value is 
localhost. 

3. For Local Manager Registration Port, specify the TCP port number the Local 
Manager uses for agent auto registration. The default port number is 17146. 

4. To specify the fully qualified path for the license file, click the Folder icon. The 
fully qualified path is <drive>:\Program Files\Storability\Agents\Storability 
Routing Agent\license.txt by default. 

5. In the Central Manager IP and Port input box, identify the Central Manager 
Routing Agent by IP address or host name and the port number on which it 
publishes its objects. The pipe delimiter must separate these configuration 
parameters. For example: 127.0.0.1|17130. 
Click the Change Option Values button next to the Database Settings 
heading and the Enter Database Parameters Options dialog box appears.  
 

 

Figure 4 - License Manager Database Parameter Options 

 
Note: Although default ODBC settings are displayed, you must click Submit to 
have these settings saved to the storability.ini file. 
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6. Review the ODBC connection parameters that the License Agent will use to 
connect to the assurent database. By default, the Storability License Agent uses 
the “atlantis” ODBC System Data Source (DSN) that may have been 
automatically created and verified during software installation. 

 
Notes: Your Windows administrator can use the Windows ODBC Configuration 
menus to verify and test the “atlantis” ODBC System DSN or to set up a separate 
ODBC System DSN for use by the License Agent. The assurent database user’s 
default password is “st0rage”. 

 
7. Click Show Advanced Settings to review/modify the following configuration 

parameters: 
 

• Enable Auto Registration – Is used to turn auto registration on (true) or off 
(false). 

• Collection Timeout – Sets how long the License Agent waits to complete 
data collection; default value is 30 seconds. 

• Frequency to collect config data – Sets the frequency for collecting the 
software license-related configuration data; the default value is 3600 seconds 
(1 hour). 

 
8. With the “Save Configuration Settings” check box enabled (check mark), select 

File->Save and confirm your changes to the storability.ini file. 
9. Select another agent tab to review/modify its configuration settings or click File-

>Exit to close the Configuration Tool. 
 
Configure Storability Data Aggregator Agent 
The Storability Data Aggregator requests agent data collection and is responsible for 
inserting collected agent data into the Sun StorageTek Business Analytics database. 
Proceed as follows to configure this agent: 
 
1. Launch the Configuration Tool. 
2. Select File->Edit->Smart Agent Configuration. 
3. Click the Data Aggregator tab. The Data Aggregator Agent Configuration 

window, with Show Advanced Settings turned on, appears below. 
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Figure 5 - Data Aggregator Configuration Window 

 
4. For Local Manager, identify the Local Manager by IP address or host name that 

will be contacted for agent auto registration. The default value is the local host. 
5. For Local Manager Registration Port, specify the Local Manager port used for 

agent auto registration. The default port number for agent auto registration is 
17146. 

6. In the ODBC DSN Name input box, identify the ODBC System Data Source 
Name the Aggregator will use to update the database. The default value is 
“atlantis”. 

7. In the Database Server IP input box, specify the IP address of the Central 
Manager database server. 

8. The Database Name is “assurent” (default value). 
9. The default Database User is “assurent”. 
10. Accept the default Password for the assurent database user. 
11. Click Show Advanced Settings to review/modify: 
 

• Central Manager IP and Data Port – Specify the IP address of the Central 
Manager and its data port number. The Central Manager default data port 
number is 17130. 

• Enable Auto Registration – Turns auto registration on (true) or off (false) 
for this agent. 

• Allow GSM Upstream Messaging – Turns on (true) or off (false) having this 
agent publish the gsa_message object, used for communication between 
Storability agents on the Central Manager. This value must be true (enabled) 
for the Storability Data Aggregator. 

12. With the “Save Configuration Settings” check box enabled, select File->Save 
and confirm saving your changes to the storability.ini file. 

13. Select another agent tab to review/modify its configuration settings or click File-
>Exit to close the Configuration Tool. 
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Configure Storability Data Polling Agent 
In conjunction with the Storability Scheduler Agent, the Data Polling Agent is used to 
control the scheduling of agent data collection and policy management.  
 
Proceed as follows to configure this agent: 
 
1. Launch the Configuration Tool. 
2. Select File->Edit->Smart Agent Configuration. The Data Polling Agent 

Configuration window, with Show Advanced Settings turned on, appears below. 
 

 

Figure 6 - Data Polling Agent Configuration Window 

 
3. Click the Data Polling Agent tab. 
4. For Local Manager, identify the Local Manager by IP address or host name to be 

contacted for agent auto registration. The default value is localhost. 
5. For Local Manager Registration Port, identify the port number the Local 

Manager uses for agent auto registration. The default port number is 17146. 
6. The ODBC DSN Name is atlantis by default. 
7. The Database Login Name is assurent. 
8. The Database Password field is st0rage and is displayed as asterisks in the 

Configuration Tool window. A password is encrypted before stored in the 
storability.ini file. 

9. In the Scheduler Timeout field, specify how long the Data Polling Agent waits 
when communicating with the Scheduler Agent. The default timeout is 30 
seconds. 

10. Click Show Advanced Settings to review/modify the following parameters: 
• Enable Auto Registration – Turns agent auto registration on (default) or 

off. 
• Data Polling Agent Password – Is optional. 
• Portal Database Name – Is portal. 
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• Client Name – Sets the agent’s client name. 
• Scheduler Agent Name – Names the client. 
• Scheduler Agent Password – Optionally specifies the Scheduler Agent’s 

password. 
• Allow GSM Upstream Messaging – Turns on (true) or off (false) having this 

agent publish the gsa_message object, used for communication between 
Storability agents on the Central Manager. This value must be true (enabled) 
for the Storability Data Polling Agent. 

14. With the “Save Configuration Settings” check box enabled, select File->Save 
and confirm your changes to the storability.ini file. 

15. Select another agent tab to review/modify its configuration settings or click File-
>Exit to close the Configuration Tool. 

 
Configure Storability Scheduler Agent 
In conjunction with the Data Polling Agent, the Sun StorageTek Business Analytics 
Scheduler Agent is used to control the scheduling of agent data collection and 
execution of policy management. To configure the Scheduler Agent, you must specify 
the IP address or network-resolvable host name of the database server. 
 
Proceed as follows to configure this agent: 
 
1. Launch the Configuration Tool. 
2. Select File->Edit->Smart Agent Configuration. 
3. Click the Scheduler Agent tab. The Scheduler Agent configuration window, with 

Show Advanced Settings turned on, appears below. 
 

 

Figure 7 - Scheduler Agent Configuration Window 

 
4. For Local Manager, identify the Local Manager by IP address or host name to be 

contacted for agent auto registration. The default value is localhost. 
5. For Local Manager Registration Port, specify the port number that the Local 

Manager uses for agent auto registration. The default port number is 17146. 
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6. In the ODBC DSN Name input box, identify the ODBC System Data Source 
Name the Scheduler will use to access the database. The default value is atlantis. 

7. In the Database Server IP input box, specify the IP address (or network 
resolvable host name) of the Central Manager database server. 

8. The database name for polling schedules is “portal” (default value). 
9. In the Database Login Name field, accept the default value of “assurent”. 
10. Accept the default password for the assurent database user in the Database 

Password field. 
11. Click Show Advanced Settings to review/modify: 

• Enable Auto Registration – Turns agent auto registration on (default) or 
off. 

• Portal Database Name – Is portal. 
• Allow GSM Upstream Messaging – Turns on (true) or off (false) having this 

agent publish the gsa_message object, used for communication between 
Storability agents on the Central Manager. This value must be true (enabled) 
for the Storability Data Polling Agent. 

12. With the “Save Configuration Settings” check box enabled, select File->Save 
and confirm your changes to the storability.ini file. 

13. Select another agent tab to review/modify its configuration settings or click File-
>Exit to close the Configuration Tool. 

 
Configure Policy Agent 
The Sun StorageTek Business Analytics Policy Agent is responsible for executing the 
actions related to policy management.  Besides specifying auto registration 
information and an ODBC System DSN to access the Sun StorageTek Business 
Analytics database, you will enter SMTP client configuration settings.  
 
Note: The Policy Agent will not start successfully unless there is valid SMTP Server 
configuration details stored in its section of the storability.ini file. 
 
The policies are defined using the Management Console’s Policy Alerting menus. 
You must start the Policy Agent to use these menus.  
 
Note: Sun StorageTek Business Analytics provides an ETL data loading process 
policy alert. By default, the ETL process is set up to run as a policy alerting item at 
4:00 am each day in the application for the default user (gsmuser).  To view the 
policy, log into the Sun StorageTek Business Analytics application as gsmuser, and 
go to Tools -> Policy Alerting.  The name of the policy is “ETL data loading process” 
and should be enabled by default. To schedule the ETL process at another time, 
modify this policy accordingly. 

The ETL process will invoke a database stored procedure gsr_main_proc_etl in the 
Sun StorageTek Business Analytics assurent database.  The execution result of the 
stored procedure is kept in the gsr_statistics table. The best time to schedule the ETL 
process is during the off hours, when the load on the database server is light, and 
after the records for the array tables are newly populated by the array agents. 

By default, the ETL process is set up to run in “incremental mode”.  This means that 
the program will only process “delta” records, those records that are changed since 
the last ETL process; therefore, the impact on the database resources for the daily 
ETL process is lessened. However, in the case of an upgrade for a very large 
database, the ETL process may consume a lot of resources in order to go through the 
legacy records for the first time and build the data warehouse tables to be used by 
the Storage Wizards.  If you need to upgrade a large database, you should plan the 
upgrade process accordingly by allocating enough time and database resources to 
allow the ETL process to complete. 
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 Proceed as follows to configure this agent: 

 
1. Launch the Configuration Tool. 
2. Select File->Edit->Smart Agent Configuration. 
3. Click the Policy Agent tab. The Policy Agent configuration window, with Show 

Advanced Settings turned on, appears below. 
 

 

Figure 8 - Policy Agent Configuration Window 

 
4. For Local Manager, identify the Local Manager by IP address or host name to be 

contacted for agent auto registration. The default value is localhost. 
5. For Local Manager Registration Port, specify the port number the Local 

Manager uses for agent auto registration. The default port is 17146. 
6. For Central Manager, enter the Central Manager’s network resolvable host 

name or IP address; default value is local host. 
7. For Central Manager Port, identify the port on which the Central Manager‘s 

Routing Agent publishes its objects. The default port number is 17130. 
8. In the Email Address of Policy Alert Sender input box, enter the email 

address that will be used to send emails containing policy execution results. 
9. In the SMTP Server IP input box, specify the IP address of the SMTP Mail server 

used to send emails. 
10. In the SMTP Server Port input box, specify the SMTP server port used for 

sending emails. The default SMTP server port number is 25. 
11. In the ODBC DSN Name input box, specify the ODBC System Data Source Name 

the Policy Agent will use to access the database. The default value is “atlantis”. 
12. In the Database Server IP input box, specify the IP address of the Central 

Manager database server. 
13. The database name for polling schedules is “portal” (default value). 
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14. In the Database Login Name field, accept the default value of “assurent” as the 
database user ID. 

15. Accept the default password for the assurent database user. 
16. Click Show Advanced Settings to review/modify: 

• Enable Auto Registration – Turns auto registration on (true) or off (false). 
Auto registration is enabled (true) by default. 

• Enable GSM Upstream Messaging – Turns on (true) or off (false) having 
this agent publish the gsa_message object, used for communication 
between Storability agents on the Central Manager. This setting must be set 
to true for the Storability Policy Agent. 

• SMTP server login – Specify a valid SMTP server login if the SMTP server 
requires authentication. 

• SMTP server password – Enter the SMTP user’s password. 
• Scheduler password – Encrypted Scheduler agent password (if applicable). 
• Portal Database Name – Is “portal” by default. 
• Assurent Database Name – Is “assurent” by default. 
 

17. With the “Save Configuration Settings” check box enabled, select File->Save 
and confirm your changes to the storability.ini file. 

18. Select another agent tab to review/modify its configuration settings or click File-
>Exit to close the Configuration Tool. 

Configure Storability Host Agent 
The Host Agent reports configuration information as well as file system, physical 
volume, and logical volume information for Windows, Solaris, IBM AIX, HP-UX, 
VMWare, and Linux platforms. The Host Agent is automatically started after it is 
installed. 
 
If you change any configuration settings, such as the location of the EMC powermt 
program, restart the Host Agent to have the changes take effect. Proceed as follows 
to configure this agent on the Sun StorageTek Business Analytics Central Manager: 
 
1. Launch the Configuration Tool. 
2. Select File->Edit->Smart Agent Configuration. 
3. Click the HostAgent tab. 

 

 

Figure 9 - Host Agent Configuration Window 
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4. In the Local Manager field, type the network resolvable host name or IP 
address of the Local Manager to be contacted for agent auto registration. The 
default value is “localhost”. In this case, keep in mind that the Central Manager is 
also a Local Manager as it runs a Routing Agent. 

5. In the Local Registration Manager Port input box, specify the port number 
that the Routing Agent uses for agent auto registration. The default port is 
17146. 

6. In the Config Cache Update Interval input box, review/modify how long the 
agent caches data. The default value is 7200 seconds. 

7. Click Show Advanced Settings. 
8. Review/modify the Enable Auto Registration configuration setting that turns 

auto discovery on (true) or off (false). The default value of “true” will cause the 
agent to attempt to register with the Local Manager at start up. If registration 
fails, the agent will re-attempt registration every five minutes. If registration 
succeeds, the agent will “refresh” its registration every twenty-four (24) hours. 

9. Review/modify the EMC powerpath file for End to end mapping setting. If the 
host server has EMC PowerPath software installed, use the Browse icon to locate 
and specify the location of the powermt.exe file. 

10. With the “Save Configuration Settings” check box enabled (check mark), click 
File->Save and then confirm saving the storability.ini file. 

11. Click File->Exit to close the Configuration Tool. 
12. Use the Windows Services panel to restart the Host Agent if you have made any 

configuration changes. 
Start Sun StorageTek Business Analytics Central Manager Agents 
The Windows administrator can use the Windows Services panel to start, stop, or 
restart the agents installed on the Sun StorageTek Business Analytics Central 
Manager. Be sure to start the Routing Agent first and then allow time for each agent 
to auto register before you verify agent functionality. 
 
Note:  
If you restart the database server, you also must restart the Sun StorageTek 
Business Analytics Central Manager agents. 
 
1. Use the Windows Services panel to start the Sun StorageTek Business Analytics 

agents installed on the Central Manager in the following order: 
 
 a. Storability Routing Agent.  
 b. Storability License Agent. 
 c.   Storability Scheduler Agent. 

d. Storability Data Polling Agent. 
e. Storability Data Aggregator 
f. Other remaining Storability agents  

 
2. Use the Windows Services panel to start or restart the remaining Central 

Manager agents (i.e. Policy Agent, Host Agent, SRM Agent, SNMP Proxy Agent, 
and Remote Host Agent as applicable). 

 
The following section describes how to verify the Central Manager agents have 
started and registered successfully. 
Verify Central Manager Agents’ Functionality 
The GSM Agent Diagnostic Tool (gsmdiag.exe) should be used to verify the Central 
Manager agents are running and are publishing their objects. The utility is located in 
the installed Storability Local Manager Utilities folder.  
 
Proceed as follows: 
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1. Using Windows Explorer, launch gsmdiag.exe from the <install 
drive>:\Program Files\Storability\GSM\Utilities\Storability Local Manager folder. 

 
� Verify Routing Agent 
2. Wait approximately 30 seconds after the Storability Routing Agent has started to 

allow it to initialize before querying it with GSMdiag. 
3. On the Agent Info tab, enter the IP Address or network resolvable Host Name of 

the server where the agent is installed in the ip address/host name input box. 
4. Set the port to 17130 (or select the Routing Agent from the drop down list of 

service names). 
5. Click the Get Object List button and you should receive a list of objects 

published by the Routing Agent. 
6. Select the gsa_ini_control-2_0 object and verify each agent’s storability.ini 

configuration parameters.  
 
7. Select the alerts-3_1 object and examine the columns for warnings or errors. 
8. Collect the gsa_agent_version-2_0 object to verify the agent’s software 

release level. 
9. Verify the other objects the agent publishes. 
 
� Verify License Agent 
 
10. Wait approximately 30 seconds after the Storability License Agent has started to 

allow registration and agent initialization to occur. 
11. In the Agent Info window, enter the IP Address or network resolvable Host 

Name of the Central Manager/Local Manager in the ip address/host name 
input box. 

12. Set the port to 17167 (or select Storability License Agent from the drop down list 
of service names). 

13. Click the Get Object List button and you should receive a list of objects 
published by the License Agent. 

14. Select the gsa_ini_control-2_0 object to verify the agent’s configuration 
settings. 

15. Select the gsa_agent_version-2_0 object and verify the software version of 
the License Agent.  

16. Verify the other objects that the agent publishes. 
 
�  Verify Scheduler Agent 
 
17. Wait approximately 30 seconds after the Storability Scheduler Agent has started 

to allow registration and agent initialization to occur. 
18. In the Agent Info window, enter the IP Address or network resolvable Host 

Name of the Central Manager/Local Manager in the ip address/host name 
input box. 

19. Set the port to 17171 (or select Storability License Agent from the drop down list 
of service names). 

20. Click the Get Object List button and you should receive a list of objects 
published by the Scheduler Agent. 

21. Select the gsa_ini_control-2_0 object to verify the agent’s configuration 
settings. 

22. Select the gsa_agent_version-2_0 object and verify the software version of 
the Scheduler Agent.  

23. Verify the other objects that the agent publishes. 
 

� Verify Data Polling Agent 
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24. Wait approximately 30 seconds after the Storability Data Polling Agent has 
started to allow registration and agent initialization to occur. 

25. In the Agent Info window, enter the IP Address or network resolvable Host 
Name of the Central Manager/Local Manager in the ip address/host name 
input box. 

26. Set the port to 17165 (or select Storability Data Polling Agent from the drop 
down list of service names). 

27. Click the Get Object List button and you should receive a list of objects 
published by the Data Polling Agent. 

28. Select the gsa_ini_control-2_0 object to verify the agent’s configuration 
settings. 

29. Select the gsa_agent_version-2_0 object and verify the software version of 
the Data Polling Agent.  

30. Verify the other objects that the agent publishes. 
 
� Verify Data Aggregator Agent 
31. Wait approximately 30 seconds after the Storability Data Aggregator Agent has 

started to allow registration and agent initialization to occur. 
32. In the Agent Info window, enter the IP Address or network resolvable Host 

Name of the Central Manager/Local Manager in the ip address/host name 
input box. 

33. Set the port to 17147 (or select Storability Data Aggregator Agent from the drop 
down list of service names). 

34. Click the Get Object List button and you should receive a list of objects 
published by the Routing Agent. 

35. Select the gsa_ini_control-2_0 object to verify the agent’s configuration 
settings. 

36. Select the gsa_agent_version-2_0 object and verify the software version of 
the Data Aggregator Agent.  

 
At this point, the Central Manager agents are running and are publishing their 
objects. 

Step 6: Install the Management Console  
1. Insert the Sun StorageTek Business Analytics Management Console Installation 

CD into the CD-ROM drive. Note: If the Setup program does not auto-run after 
you insert the CD into the drive, run setup.exe from the installation media to 
start the InstallShield Wizard. 

2. Click Next> on the Installation Welcome screen. 

3. Click Yes to accept the Sun StorageTek Business Analytics License Agreement. 

4. Review/modify the Company Name and User Name and click Next> to 
continue. 

5. Select Typical on the Setup Type screen and click Next>. The COM Agent 
(comAgent) Configuration dialog appears. 
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   Figure 10 - Configure COM Agent 

 

6. In the respective input boxes, enter the following: 

• Central Manager Routing IP – Specify the IP Address or network resolvable 
host name for the Local Manager to be contacted for auto registration. The 
default IP address is localhost (127.0.0.1) and will need to be changed if the 
Local Manager/Central Manager is not running on the Management Console 
server. 

• Registration Port – Specify the Central Manager Routing’s Agent’s port used 
for agent auto registration. The default port is 17146. 

• Enable Auto Registration – Set this parameter to TRUE and allow the COM 
Agent to use agent auto registration, or set it to FALSE to disable auto 
registration for the Storability COM Agent. 

Click OK to continue. 

7. Click Next> to accept the default installation path on the Choose Destination 
Location screen (or click Browse to select a different installation path). 

8. Select Yes to have the installation create the System DSN to allow the 
Management Console to communicate with the Central Manager. 

9. Choose the Program Folder (e.g., Storability) to be updated and click Next>. 

10. Review your current settings and click Next> to continue. 

11. When the dialog appears that warns you that the installation will need to shut 
down Microsoft IIS-related services, click Yes to continue. 

Note: The system will display the Setup Status progress bar as the installation 
progresses.  

13. The InstallShield Installation Complete dialog appears. Specify whether or not to 
view the Readme file and click Finish.  
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Step 7: Basic Application Configuration  
7a: Launch Management Console 
1. Select Start->Programs->Storability-> Launch Management Console. The Sun 

StorageTek Business Analytics Management Console Login window appears.   
 

 

   Figure 11 - Management Console Login 

 
2. Log in using the default administrative account, gsmuser, as both the username 

and password. 
7b: Customize the Default Local Manager  
1. Select Tools -> Site/Local Manager Administration. 
2. Click the Default Local Manager link displayed in the Site/Local Manager Listing 

window. 
3. Customize the default name to suit your company and to accommodate the 

Central Manager that you are setting up as a Local Manager. Remember that the 
Central Manager also functions as a Local Manager because it runs a Routing 
Agent. 

4. Modify the Short Name or alias for the Local Manager to suit your application. 
5. Update the IP Address of the Central Manager to its actual IP address. 
6. Click Save and click OK on the confirmation dialog box to update the Local 

Manager. 
7c: Customize the Default Site 
 
1. Click the Default Site link for the listed default site. 
2. Enter a site name and location to suit your company’s implementation. 
3. Click Save and confirm the changes, when prompted. 
4. Close the window. 
7d: Create View and Assign to User 
5. Create a view: 

a. Select Tools -> View Administration and the Views wizard appears. 
b. Select Create New View (default) and click Next >> to continue. 
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c. In the Create View window, enter the name of your enterprise as the name of 
the view. 

d. Use the View Type list box to select Asset View (do not specify Composite 
View). 

e. Click Next>> and the Add Assets to View window appears for your new view. 
f. Select the “What type of asset do you wish to add to this view?”  list box and 

select Sites. 
g. Click the List button and the site(s) you created will appear. 
h. Click the Select check box to choose the site and then click the Add to View 

button. 
i. Click Next>>. The “Site assets added successfully.” text message appears on 

the Add Assets to View window to confirm adding the site to the view. 
j. Click Next>> and the Add Users to View <View Name> window appears. 
k. Use the checkbox to choose the (GSMuser) and click Add to View. The 

“Users Added Successfully” message is displayed in the Add Users to View 
window. 

l. Click Next> and the Create View – Summary window appears.  
m. Review the information on the new asset view, including its status 

(“<view_name> created successfully.”), View Type, and Asset List. You can 
optionally click the Printer Friendly Page button and then Print to print the 
Create View – Summary information on a local or network printer. 

n. Click Finish>> and you are returned to the Views Wizard window.  
o. Click Close to close the Views Wizard. 

7e: Dashboard Administration – Create Dashboard 
6. Create Dashboard: 

a. Select Tools->Dashboard Administration->Manage Dashboards. 
b. Click Create New. 
c. Type a meaningful name for the dashboard. 
d. Use the dashboard type list box to choose the dashboard security of public or 

private. Assign public to allow any Sun StorageTek Business Analytics user to 
choose the dashboard. Select private to restrict its use to its creator. 

e. Optionally enter a description. 
f. Beside the “Components in the layout:” heading, click each type of pane 

(Storage, etc.) you want to be included. In this example, minimally click 
Server. A check appears in the selection box for each component you select. 

g. Click Save.   
h. Close the window. 

7f: Dashboard Administration - Change Dashboard 
7. Select Tools->Dashboard Administration->Change Dashboard. 
8. Use the radio button to select the dashboard you created. 
9. Click Set as current dashboard and click OK to confirm. 
10. Verify the Home Page appears displaying the Host Filesystem Utilization pane (as 

pane well as any other selected panes in the dashboard you created). Note: 
Because you have not yet collected agent data using the Data Polling Schedules 
functionality, no data appears in the panes. 

7g: Data Polling Schedules  
11. Select Tools -> Data Polling Schedule.  
12. The Polling Schedules window is displayed. The default polling schedules in the 

database, which were automatically created at installation time, include three 
schedules for Host. These have a Collection Metric of Configuration, FileSystem, 
and Logical VM (Volume Manager). 

13. You are now ready to collect the Host Agents’ data for all sites. You can later 
repeat this procedure for the other Collection types after your Storability Agents 
(fabric, array, etc.) have been deployed. 

14. Click the Collect Now button for the Collection Type of Host and the Collection 
Metric of Configuration. 



Getting Started Page 25 
      

15. Wait approximately thirty seconds and click the Collect Now button for the 
Collection Type of Host and the Collection Metric of Filesystem. 

16. Wait approximately thirty seconds and click the Collect Now button for the 
Collection Type of Host and the Collection Metric of Logical VM. 

17. Verify the Central Manager server appears in the Host Filesystem Utilization 
dashboard. If so, your Sun StorageTek Business Analytics application is now 
verified to support agent data collection. 

Step 9: Install and Configure Local Manager(s) 
1. Install and configure the Sun StorageTek Business Analytics Local Manager using 

the Windows Local Manager Installation media or the Solaris Local Manager 
Installation media. Refer to the Installation chapter for detailed instructions. 

2. Configure the Local Manager’s Routing Agent to communicate with the 
appropriate Routing Agent (i.e., Central Manager Routing Agent) in the 
messaging hierarchy. The configuration parameters are essentially the same as 
those previously described for the Central Manager. However, you must specify 
a parent Routing IP for a Local Manager in the Routing section of the 
storability.ini file to have the messaging infrastructure work properly. 

Step 10: Install and Configure Smart Agents 
1. Refer to the Sun StorageTek Business Analytics Support Matrix that is located on 

the Documentation CD to obtain the latest Smart Agent prerequisites. 
2. The Documentation CD also provides installation manuals for all agent types 

(Fabric, Array, Host, Backup, Library, SRM, Database, and NAS) of Smart Agents. 
3. Be sure to use the Management Console’s administrative menus to update the 

users, views, and dashboards to allow the agent’s collected data to be viewed 
using the Management Console reports. 




