mountall is used to mount file systems specified in a file system table. The file system table must be in vfstab(4) format. If no file_system_table is specified, /etc/vfstab will be used. If `-' is specified as file_system_table , mountall will read the file system table from the standard input. mountall only mounts those file systems with the mount at boot field set to yes in the file_system_table .
Each file system which has an fsckdev entry specified in the file system table will be checked using fsck(1M) in order to determine if it may be safely mounted. If the file system does not appear mountable, it is fixed using fsck before the mount is attempted. File systems with a `-' entry in the fsckdev field will be mounted without first being checked.
umountall causes all mounted file systems except root , /usr , /var , /var/adm , /var/run , /proc , and /dev/fd to be unmounted. If the FSType is specified, mountall and umountall limit their actions to the FSType specified. There is no guarantee that umountall will unmount busy filesystems, even if the -k option is specified.
Specify the FSType of the file system to be mounted or unmounted.
Unmount all file systems listed in /etc/mnttab that are remote-mounted from host.
Use the fuser -k
command. See the fuser(1M)
for details. The -k
option sends the
signal to each
process using the file. As this option spawns kills for each process, the kill messages may not show up immediately. There is no guarantee that umountall
will unmount busy
filesystems, even if the -k
option is specified.
Limit the action to local file systems.
Limit the action to remote file system types.
Do not perform the umount operation in parallel.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
No messages are printed if the file systems are mountable and clean.