Solaris Common Desktop Environment: User's Transition Guide
Contents

Preface  v

1.  Moving from the OpenWindows Environment to Solaris CDE  1
   To Log In to CDE for the First Time  1
   Desktop  2
      CDE Desktop  3
      Applications and Actions  4
      Working With Files  5
   Windows and Objects  7
      Working with Windows  8
      Moving Text and Objects  9
   Mouse  11
      Keyboard Mnemonics and Special Keys  12
   User Preferences  12
      Startup and Shutdown Preferences  13
      Adding Personal Applications  13
      Preferences for an Application  14
      Color and Font Preferences  14
      Keyboard Preferences  14
      Mouse Preferences  15
Preface

The *Solaris Common Desktop Environment: User’s Transition Guide* helps you make the transition from the OpenWindows™ environment to the Solaris™ Common Desktop Environment (CDE).

Solaris CDE is an implementation of the CDE standard developed by Sun Microsystems, IBM, Hewlett-Packard, and Novell. It makes applications running on UNIX® systems portable and easy to use. CDE applications are more intuitive and consistent with other operating environments than the OpenWindows environment is.

Solaris CDE is web-enabled, allowing you to seamlessly view and manipulate web pages, files, and mail messages. This book discusses the CDE graphical operating environment under the following standard headings:

- Desktop
- Windows and objects
- User preferences
- Login sessions

Where helpful, the differences in behavior between the OpenWindows and CDE platform features are identified. The answers to frequently asked questions have been integrated into the relevant topics.

This book gives only an overview of CDE features and functions. For a detailed discussion of any aspect of CDE mentioned in this book, see *Solaris Common Desktop Environment: User’s Guide* and the CDE online help volumes.

**Note** - Solaris Common Desktop Environment is generally referred to as CDE hereafter in this book.
Ordering Sun Documents

Fatbrain.com, an Internet professional bookstore, stocks select product documentation from Sun Microsystems, Inc.

For a list of documents and how to order them, visit the Sun Documentation Center on Fatbrain.com at http://www1.fatbrain.com/documentation/sun.

Accessing Sun Documentation Online

The docs.sun.com™ Web site enables you to access Sun technical documentation online. You can browse the docs.sun.com archive or search for a specific book title or subject. The URL is http://docs.sun.com.

What Typographic Conventions Mean

The following table describes the typographic changes used in this book.

<table>
<thead>
<tr>
<th>TABLE P–1  Typographic Conventions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Typeface or Symbol</strong></td>
</tr>
<tr>
<td>AaBbCc123</td>
</tr>
<tr>
<td>AaBbCc123</td>
</tr>
</tbody>
</table>
TABLE P–1  Typographic Conventions  (continued)

<table>
<thead>
<tr>
<th>Typeface or Symbol</th>
<th>Meaning</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>AaBbCc123</td>
<td>Command-line placeholder: replace with a real name or value</td>
<td>To delete a file, type <code>rm</code> <code>filename</code>.</td>
</tr>
<tr>
<td>AaBbCc123</td>
<td>Book titles, new words, or terms, or words to be emphasized.</td>
<td>Read Chapter 6 in <em>User’s Guide</em>. These are called <em>class</em> options. You must be <em>root</em> to do this.</td>
</tr>
</tbody>
</table>

Shell Prompts in Command Examples

The following table shows the default system prompt and superuser prompt for the C shell, Bourne shell, and Korn shell.

TABLE P–2  Shell Prompts

<table>
<thead>
<tr>
<th>Shell</th>
<th>Prompt</th>
</tr>
</thead>
<tbody>
<tr>
<td>C shell prompt</td>
<td><code>machine_name$</code></td>
</tr>
<tr>
<td>C shell superuser prompt</td>
<td><code>machine_name#</code></td>
</tr>
<tr>
<td>Bourne shell and Korn shell prompt</td>
<td><code>$</code></td>
</tr>
<tr>
<td>Bourne shell and Korn shell superuser prompt</td>
<td><code>#</code></td>
</tr>
</tbody>
</table>
Moving from the OpenWindows Environment to Solaris CDE

This chapter helps you to use the CDE environment for the first time if you are already familiar with the OpenWindows environment. It takes you through the CDE login process, and then discusses aspects of the CDE environment.

- “To Log In to CDE for the First Time” on page 1
- “Desktop” on page 2
- “Windows and Objects” on page 7
- “User Preferences” on page 12
- “Help and User Documentation” on page 15

Where helpful, the difference between OpenWindows behavior and CDE behavior is explained.

This book does not describe CDE in detail. For detailed procedures and descriptions consult Solaris Common Desktop Environment: User’s Guide and the CDE online help volumes.

To Log In to CDE for the First Time

1. Display the login screen on your workstation.

2. Choose Session from the Options menu.

3. Select Common Desktop Environment (CDE).
The CDE logo is displayed on the login screen.

4. **Type your username and click OK.**
   Use your standard UNIX username and password. If you previously used OpenWindows, try the username and password you used for that environment, otherwise contact your system administrator. The login screen prompts you to enter your password.

5. **Type your password and click OK.**
   CDE logs you in and displays the default workspace, the Front Panel, and a welcome message.

   **Note** - For more information on logging in, see “Chapter 2, Starting a Desktop Session” in *Solaris Common Desktop Environment: User's Guide.*

Now read the following topics and explore the CDE desktop.

---

**Desktop**

Graphical environments such as the CDE and OpenWindows desktops use windows and other objects to represent applications, files, and services available to the user. When you log into CDE, the CDE *desktop* is displayed.
CDE Desktop

The CDE desktop comprises a Front Panel sitting over a selected workspace, or screen background. The Front Panel displays information about your workstation, and enables you to run applications, to log out, and to switch between workspaces. Applications that are running are represented by windows and icons on the workspace. As in OpenWindows, a Workspace menu is also available.

Front Panel

The Front Panel (see Figure 1–2) is a collection of frequently used controls and desktop services available in every workspace.

Some Front Panel controls have subpanels associated with them. The subpanels contain related groups of controls. Click the triangle above the Front Panel control to open its subpanel. Click an inverted triangle to close a subpanel.

Controls on the Front Panel enable you to access most applications; applications that do not have a control on the Front Panel can be accessed using Application Manager.
Workspaces

Workspaces are like separate screens or desktops. You can only display one workspace at a time, but applications in all workspaces can run simultaneously. To display another workspace, you click its button in the workspace switch in the center of the Front Panel.

By default, four workspaces named One through Four are available.

Tip - You can specify whether an application is displayed on one or all workspaces by clicking mouse button 3 on its window frame and selecting an item from the pop-up menu.

Workspace Menu

When you click mouse button 3 on an unused area of a workspace, the Workspace menu is displayed. It includes items on the Front Panel and Application Manager. Most applications are on the Applications menu (see Figure 1–1).

Applications and Actions

In CDE you run an application by clicking its control on the Front Panel, by double-clicking its icon in Application Manager, or by choosing it from the Workspace menu.
<table>
<thead>
<tr>
<th>Task or Feature</th>
<th>OpenWindows Method</th>
<th>CDE Methods</th>
</tr>
</thead>
</table>
| Run an application from the desktop | Choose a menu item on the Workspace menu                                          | Click a control on Front Panel
|                                     |                                                                                   | Choose a menu item from the Workspace menu
|                                     |                                                                                   | Double-click an icon in Application Manager |
| Add a personal application to Front Panel | Not applicable (no Front Panel)                                                   | Drop a program icon on an Add Icon drop zone on a subpanel |
| Run an OpenWindows application      | Choose a menu item on the Workspace menu                                          | Double-click an icon in the OpenWindows folder in Application Manager |

You can also run an application by dropping the appropriate file on a drop zone on the Front Panel. For example, dropping a file on the printer icon prints the file.

**Tip** - You can also start an application by entering UNIX commands on a command line in a terminal window. To display a terminal window, choose This Host on the Hosts subpanel of the Front Panel.

---

### About Application Manager

Application Manager enables you to organize applications for easy access by storing their icons in special folders. For example, you can launch your OpenWindows applications from icons in the OpenWindows folder (see Figure 1–2).

### Working With Files

Like OpenWindows, CDE provides full-functioned File Manager and File Finder applications. The Files subpanel gives you access to these applications and to other file-related devices and applications.
In File Manager and File Finder, files and folders are represented by icons that indicate their types. Clicking on mouse button 3 displays options for the selected object, and double-clicking an object invokes the default action for that object. For example, double-clicking a compressed file expands it, and double-clicking on an audio file plays it.
<table>
<thead>
<tr>
<th>Task or Feature</th>
<th>OpenWindows Method</th>
<th>CDE Methods</th>
</tr>
</thead>
<tbody>
<tr>
<td>To find a file</td>
<td>In File Manager, choose Find from the File menu</td>
<td>Click Find File on the Files subpanel</td>
</tr>
<tr>
<td>To carry out an action on a</td>
<td>Click mouse button 3 and choose from general pop-up menu</td>
<td>Click mouse button 3 on the file and choose from pop-up menu</td>
</tr>
<tr>
<td>file</td>
<td></td>
<td>Drag and drop the file on an appropriate drop zone</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click a control on the Files subpanel</td>
</tr>
<tr>
<td>Print a file</td>
<td>Select file in File Manager and choose Print from the File menu</td>
<td>Drop a file on the printer control on Front Panel</td>
</tr>
<tr>
<td>Access a floppy diskette or</td>
<td>In File Manager, choose Check for Floppy from the File menu</td>
<td>Click Open Floppy or Open CD-ROM on the Files subpanel</td>
</tr>
<tr>
<td>CD-ROM</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Deleting Files**

Like OpenWindows, CDE provides a *trash* or wastebasket facility. The Trash Can is a temporary store for objects (files and folders) to be deleted.

You can move selected objects to the Trash Can using drag-and-drop, by mapping certain menu items, or by pressing the Delete key. Once in the Trash Can, the objects no longer appear in their original folder.

In OpenWindows, you are offered the opportunity to empty the wastebasket when you exit File Manager.

To permanently remove the deleted files in CDE, you use the Empty Trash Can control on the Trash subpanel. To permanently remove the deleted files in OpenWindows, you use the Empty Waste button in the Wastebasket application, or you accept an option to empty the wastebasket that is presented when you are exiting File Manager.

**Windows and Objects**

The appearance and use of windows, icons, dialog boxes, and so on differs slightly between the OpenWindows and CDE environments.
Working with Windows

Application windows have common controls, title areas, and grab handles. Some of these are shown in the following figure.

![CDE Window Controls Diagram](image)

Minimize turns the window into an icon, and Maximize enlarges the window to its largest possible size, that is, the full screen.

In CDE and OpenWindows the verb to close has different meanings: When you close a CDE window, the application is killed; when you close an OpenWindows window, the application is displayed as an icon and continues to run.

**TABLE 1–1** Window Control Comparison

<table>
<thead>
<tr>
<th>Task or Feature</th>
<th>OpenWindows Method</th>
<th>CDE Methods</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimize a window</td>
<td>Choose Close from Window menu</td>
<td>Click the Minimize button</td>
</tr>
<tr>
<td>Expand or enlarge a window</td>
<td>Double-click on window frame (expands vertically)</td>
<td>Click the Maximize button (window covers entire screen)</td>
</tr>
<tr>
<td>Task or Feature</td>
<td>OpenWindows Method</td>
<td>CDE Methods</td>
</tr>
<tr>
<td>---------------------------------------</td>
<td>-------------------------------------</td>
<td>----------------------------------------------</td>
</tr>
<tr>
<td>Remove pop-up windows and dialog boxes</td>
<td>Click the pushpin</td>
<td>Choose Close or Cancel from the Window menu</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click the Close or Cancel button in the dialog box</td>
</tr>
<tr>
<td>Terminate an application</td>
<td>Choose Quit from the Window menu</td>
<td>Choose Close from the Window menu or Exit from the File menu</td>
</tr>
<tr>
<td>Move a window</td>
<td>Grab anywhere on window frame (except the corners) and move</td>
<td>Grab the title bar and move</td>
</tr>
</tbody>
</table>

**Note** - Do not confuse closing a window with closing a file within an application. For example, when you choose Close from the File menu of a CDE application, the file is closed, but the application window typically remains open.

See also “Chapter 1, Basic Skills” in *Solaris Common Desktop Environment: User’s Guide*.

**Moving Text and Objects**

CDE has a clipboard facility, a drag-and-drop facility, and a duplication facility.

**Clipboard**

CDE provides a clipboard facility that can handle text and graphics simultaneously. Most CDE applications have an Edit menu that provides the standard clipboard items (Cut, Copy, and Paste). Cut, Copy and Paste are also available through the following key combinations.
TABLE 1–2  Clipboard Key Comparison

<table>
<thead>
<tr>
<th>Task or Feature</th>
<th>OpenWindows Keys</th>
<th>CDE Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>Meta+X, or Cut</td>
<td>Alt+X, or Control+Delete, or Cut</td>
</tr>
<tr>
<td>Copy</td>
<td>Meta+C, or Copy</td>
<td>Alt+C, or Control+Insert, or Copy</td>
</tr>
<tr>
<td>Paste</td>
<td>Meta+V, or Paste</td>
<td>Alt+V, or Shift+Insert, or Paste</td>
</tr>
</tbody>
</table>

Drag and Drop

As in OpenWindows, in CDE you can drag a selected object or text from one location to another inside the application, or from one application to another. Unlike OpenWindows, CDE does not enable you to drop objects on a minimized program icon, but it enables you to drop objects and text on the Front Panel.

TABLE 1–3  Drag and Drop Behavior

<table>
<thead>
<tr>
<th>Task or Feature</th>
<th>OpenWindows Behavior</th>
<th>CDE Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drop an icon on the workspace</td>
<td>Launches application</td>
<td>Creates reference to item (original item still appears in File Manager)</td>
</tr>
<tr>
<td>Drop text or files on message area in Mailer</td>
<td>Inserts in message body</td>
<td>Only supported for Compose window. Inserts text at insertion point and attaches files.</td>
</tr>
<tr>
<td>Drop text or files in Attachments area in Mailer</td>
<td>Attaches messages</td>
<td>Attaches files to message being composed. Attaches dropped text as text file</td>
</tr>
<tr>
<td>Drop text into text window</td>
<td>Text appears at drop point</td>
<td>Text appears at insertion point (same as choosing Include from the File menu)</td>
</tr>
<tr>
<td>Drop a file on a minimized application</td>
<td>Application runs its default action (such as opening or printing the file) if it is of the appropriate type</td>
<td>Not supported</td>
</tr>
</tbody>
</table>
Duplication Button

In OpenWindows, mouse button 2 was referred to as the ADJUST button—because it was used to highlight the text to the right of a position selected by mouse button one. CDE uses mouse button 2 as a useful text duplication button, which is used to duplicate, or make copies of, selected text.

Duplication is faster than copy and paste or drag-and-drop, especially when you want to quickly copy a long file path into File Manager, or when you want to copy commands in a terminal window. The contents of the clipboard are unaffected when duplicating.

▼ To Duplicate Selected Text

1. Select the required text by holding down mouse button 1 and dragging the cursor over it.
2. Release mouse button 1.
3. Point the mouse at the location to which you wish to duplicate the text, and click mouse button 2.
   The text is copied to the new location without removing it from its original location.
4. (Optional), Repeat step 2 and duplicate the text in other locations.

Mouse

CDE uses all three mouse buttons (where available) to provide full point-and-click, drag-and-drop, and duplication services, as explained earlier.

In CDE, you use Control+mouse button 1 to select multiple elements in a window; in OpenWindows, you use mouse button 2. For example, use this keyboard-and-mouse combination when selecting multiple files in a File Manager window, or when selecting several messages from the Mailer message header list.
Keyboard Mnemonics and Special Keys

Unlike OpenWindows applications, CDE applications use *mnemonics*, or memorable key combinations, to enable you to select menu items without using the mouse. Mnemonics for a menu item are indicated by an underlined letter in the menu item name, such as the letter F in the File menu in File Manager. You activate a menu by pressing the Alt key and the underlined key, for example Alt+F to activate the File menu in File Manager.

As with OpenWindows, CDE supports the standard keyboards supplied with Sun™ Workstations™. For keyboards on IA–based systems, you need to use special key combinations, such as Control+Alt for the Meta key, to emulate keys not provided.

<table>
<thead>
<tr>
<th>Task or Feature</th>
<th>OpenWindows Method</th>
<th>CDE Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>To access a menu</td>
<td>Point and click</td>
<td>Point and click the mouse. Use keyboard mnemonics (Alt+underlined_key)</td>
</tr>
<tr>
<td>To switch the focus from one application window to another</td>
<td>Click on the window</td>
<td>Click on the window, or press Alt+Tab repeatedly until the window has the focus</td>
</tr>
<tr>
<td>Key mappings</td>
<td>OpenWindows defaults</td>
<td>CDE defaults (same as OpenWindows defaults)</td>
</tr>
<tr>
<td>Delete key</td>
<td>Deletes previous character</td>
<td>Deletes next character</td>
</tr>
</tbody>
</table>

User Preferences

Most user preferences are set using the Application Manager — Desktop_Controls application, which is available via the Front Panel.
Startup and Shutdown Preferences

By default CDE saves the current session, or the details of applications running when you log out, and resumes the current session the next time you log in. You can change this and other login behavior by clicking Startup in Style Manager.

Tip - To customize login time environment settings for the CDE login screen, modify your $HOME/.dtprofile file. (In OpenWindows, you modified your $HOME/.login file or $HOME/.profile file.)

Adding Personal Applications

- To can add an application to the Front Panel, drop its application icon on one of the Install Icon drop zones on a subpanel.
- To add an application to Application Manager, set up an action for it.
- To add an application to the Workspace menu, click Add Item to Menu on the Tools subpanel.
Preferences for an Application

In a CDE application, preferences that affect only that application are set using the Options or Format menu items on the File or Options menu. In an OpenWindows application, such preferences are set using Properties dialog box, accessed from the Workspace menu.

Color and Font Preferences

Use the Color dialog box in Style Manager to set colors. Use the Font dialog box in Style Manager to set the font size, type, and character group, and to add and delete font groups.

The Style Manager is the CDE equivalent of the OpenWindows Workspace Properties dialog box.

**Note** - Be sure you know what you are changing on the desktop as certain color combinations may not give you the best results. For more information see ColorUse, dynamicColor, foregroundColor, shadowPixmaps resources, and the Color Server section in the dtsession(1) or dtstyle(1) man pages located in /usr/dt/man/man1.

Color Flashing

If you are using a workstation that does not use a 24–bit graphics card, running certain applications may result in a phenomenon known as color flashing, where the application appears with incorrect colors while the rest of the desktop appears normal; when given the focus it displays with correct colors but the rest of the desktop does not. This is due to fundamental limitations in the X Windows system.

If you experienced color flashing in OpenWindows, you will probably experience it in CDE. You may be able to avoid color flashing by using the Number of Colors to Use setting, which is available from the Color dialog box in Style Manager.

Keyboard Preferences

CDE supports the default keyboard special key combinations for OpenWindows. However, keyboard settings in OpenWindows will not be preserved in CDE, so you need to make these settings again in CDE. See “Chapter 7, Customizing the Desktop Environment” in Solaris Common Desktop Environment: User’s Guide. If you need to make changes to your UNIX® keyboard bindings, refer to “Chapter 10, Using Text Editor” in Solaris Common Desktop Environment: User’s Guide.
Mouse Preferences
CDE supports the three-button mouse. To change settings for the mouse, click Mouse in Style Manager. Your mouse defaults should stay the same within CDE. If you want to change your defaults, use the Style Manager Mouse dialog box. In CDE, mouse button order is called handedness.

Printing Preferences
In CDE, printing status and commands are available through the Personal Printers subpanel on the Front Panel. Some tasks relating to printer setup require the system administrator to edit configuration files.

Help and User Documentation
The AnswerBook2® control on the Help subpanel contains gives you access to online documentation for Solaris Common Desktop Environment. The online documentation provides hierarchical browsing, full text search, and hypertext links. You can also consult the help volumes. Help is available when you:
- Press the Help key
- Choose Help from an application’s menu bar
- Click one of the controls on the Help subpanel
- Choose Help on the Workspace menu

Unlike OpenWindows, the CDE help volumes provide comprehensive indexing, a multi-volume table of contents, printing, and a copy-and-paste facility.
## Index

### A
- actions, 4
- adding applications to CDE, 13
- AnswerBook, accessing, 15
- Application Manager, 3
  - using, 5
- applications
  - adding to CDE, 13
  - on the desktop, 4

### B
- Backspace key, function, 12
- buttons, in CDE, 8

### C
- CDE, definition of, v
- clipboard facility, 9
- closing
  - definition of, 8
  - windows, 8
  - windows and files, 9
- color, changing, 14
- command line entry, 5
- controls, Front Panel, 3
- current session, 13

### D
- Delete key, function, 12
- desktop login, 1
- dialog boxes

### E
- exiting, definition of, 8

### F
- File Manager, drag-and-drop, 10
- Files subpanel, 5
- files, in CDE, 5
- finding files, 5
- font size, changing, 14
- frequently asked questions, 14
- Front Panel, 3

### G
- global options, 12
- graphics, moving and copying, 9

### I
- IA systems
  - keyboards, 12
- icons, appearance and use of, 7

### K
- keyboard behavior, changing, 14
- keyboard shortcuts, 12, 14
L
logging in to CDE, 1
login, setting preferences, 13

M
Mailer, drag-and-drop in, 10
managing files, 5
maximize, 8
menus, in CDE, 8
minimize, 8
mnemonic keys, 12
mouse
  changing behavior of, 15
  in CDE, 8
mouse buttons
  Adjust, 11
  Duplication, 11
  multiple selection, 11

O
objects, moving and copying, 9
online help, accessing, 15
OpenWindows
  frequently asked questions, v
  location of applications, 5
  options, 12

P
personal applications
  setting up, 5
preferences, 12
printing, 15
properties, 12

Q
quitting windows, 8

R
running an application
  by drag-and-drop, 5
  in OpenWindows and CDE, 5

S
selecting items, 11
settings, 12
special keys, 12
startup, setting preferences, 13
Style Manager, 14
subpanels, 3

T
terminal application, running
  running, 5
Text Editor, drag-and-drop, 10
text, moving and copying, 9

U
underlined letter
  on menus, 12
UNIX commands
  entering in CDE, 5
user preferences, 12
username, 2

W
windows
  appearance and use of, 7
  in CDE, 8
Workspace menu
  definition, 4
  location of, 5
Workspace Programs submenu, accessing, 4
workspace switch, 4
workspace, definition of, 4