## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preface</td>
<td>5</td>
</tr>
<tr>
<td>1. What’s New at a Glance</td>
<td>7</td>
</tr>
<tr>
<td>2. Removable Media</td>
<td>9</td>
</tr>
<tr>
<td>Using Removable Media Manager</td>
<td>9</td>
</tr>
<tr>
<td>Starting Removable Media Manager</td>
<td>9</td>
</tr>
<tr>
<td>Supported Media Classes</td>
<td>10</td>
</tr>
<tr>
<td>Viewing Additional Information About a Device</td>
<td>10</td>
</tr>
<tr>
<td>Properties</td>
<td>11</td>
</tr>
<tr>
<td>Formatting and Slicing Devices</td>
<td>11</td>
</tr>
<tr>
<td>Creating Solaris Slices</td>
<td>12</td>
</tr>
<tr>
<td>Protecting a Device</td>
<td>13</td>
</tr>
<tr>
<td>Changing Your Password</td>
<td>15</td>
</tr>
<tr>
<td>3. Using Window Manager Enhancements</td>
<td>17</td>
</tr>
<tr>
<td>Graphical Workspace Manager</td>
<td>17</td>
</tr>
<tr>
<td>Starting the Graphical Workspace Manager</td>
<td>18</td>
</tr>
<tr>
<td>Graphical Workspace Manager Tasks</td>
<td>19</td>
</tr>
<tr>
<td>▼ To Add a Workspace</td>
<td>20</td>
</tr>
<tr>
<td>▼ To Delete a Workspace</td>
<td>21</td>
</tr>
<tr>
<td>▼ To Rename a Workspace</td>
<td>21</td>
</tr>
<tr>
<td>▼ To Switch to a Different Workspace</td>
<td>21</td>
</tr>
<tr>
<td>▼ To Cascade All Windows in a Workspace</td>
<td>21</td>
</tr>
<tr>
<td>▼ To Tile All Windows in a Workspace</td>
<td>21</td>
</tr>
</tbody>
</table>
To Open the Options Dialog Box 21
To Minimize a Window 22
To Close a Window 23
To Terminate an Application 23
To Move a Window to a Different Workspace 23
To Occupy Workspace(s) 23
To Unoccupy Workspace(s) 23

Graphical Workspace Manager Options Dialog Box 24

Window List 26
Starting the Window List 26
Performing Window List Tasks From the Window Menu 27
Performing Window List Tasks From the Option Menu 30
Window List Options 32

Workspace Manager 33
Starting Workspace Manager 34

Using Workspace Manager Controls 35
To Display the Workspace Switch Area on the Front Panel 35
To Synchronize Workspaces Across Screens 35
To Set the Number of Workspaces 35
To Restore the Default Settings 36

4 Adding Multiple Files to Email 37
Attaching Multiple Files to Email 37
To Add an Attachment 37
Preface

The Solaris 8 Desktop User Supplement describes new features in Solaris 8™ Update releases. The following information adds to or supersedes information in the previous releases of Solaris 8 documentation sets. Solaris documentation is available on the Solaris 8 Documentation CD.

Note – The Solaris operating environment runs on two types of hardware, or platforms - SPARC™ and IA (Intel Architecture). The Solaris operating environment also runs on both 64-bit and 32-bit address spaces. The information in this document pertains to both platforms and address spaces unless called out in a special chapter, section, note, bullet, figure, table, example, or code example.

Ordering Sun Documents

Fatbrain.com, an Internet professional bookstore, stocks select product documentation from Sun Microsystems, Inc.

For a list of documents and how to order them, visit the Sun Documentation Center on Fatbrain.com at http://www1.fatbrain.com/documentation/sun.

Accessing Sun Documentation Online

The docs.sun.com™ Web site enables you to access Sun technical documentation online. You can browse the docs.sun.com archive or search for a specific book title or subject. The URL is http://docs.sun.com
Typographic Conventions

The following table describes the typographic changes used in this book.

### TABLE P-1 Typographic Conventions

<table>
<thead>
<tr>
<th>Typeface or Symbol</th>
<th>Meaning</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>AaBbCc123</td>
<td>The names of commands, files, and directories; on-screen computer output</td>
<td>Edit your .login file. Use <code>ls -a</code> to list all files.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You have mail.</td>
</tr>
<tr>
<td>AaBbCc123</td>
<td>What you type, contrasted with on-screen computer output</td>
<td><code>machine_name% su</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Password:</td>
</tr>
<tr>
<td>AaBbCc123</td>
<td>Command-line placeholder: replace with a real name or value</td>
<td>To delete a file, type <code>rm filename</code>.</td>
</tr>
<tr>
<td>AaBbCc123</td>
<td>Book titles, new words, or terms, or words to be emphasized.</td>
<td>Read Chapter 6 in <em>User's Guide</em>. These are called <em>class</em> options. You must be <em>root</em> to do this.</td>
</tr>
</tbody>
</table>

Shell Prompts in Command Examples

The following table shows the default system prompt and superuser prompt for the C shell, Bourne shell, and Korn shell.

### TABLE P-2 Shell Prompts

<table>
<thead>
<tr>
<th>Shell</th>
<th>Prompt</th>
</tr>
</thead>
<tbody>
<tr>
<td>C shell prompt</td>
<td><code>machine_name%</code></td>
</tr>
<tr>
<td>C shell superuser prompt</td>
<td><code>machine_name#</code></td>
</tr>
<tr>
<td>Bourne shell and Korn shell prompt</td>
<td><code>$</code></td>
</tr>
<tr>
<td>Bourne shell and Korn shell superuser prompt</td>
<td><code>#</code></td>
</tr>
</tbody>
</table>
CHAPTER 1

What’s New at a Glance

This chapter highlights new features that have been added to the Solaris 8 operating environment for the Update releases.

TABLE 1–1 Solaris 8 Update Features

<table>
<thead>
<tr>
<th>Feature Description</th>
<th>First Released</th>
</tr>
</thead>
<tbody>
<tr>
<td>Window Manager Enhancements</td>
<td>6/00 and updated 4/01</td>
</tr>
<tr>
<td>Graphical Workspace Manager provides a graphical representation of all workspaces, the ability to navigate across different workspaces with the press of a button, and the ability to drag and drop applications across different workspaces. With the 4/01 release, you are no longer limited to viewing nine workspaces. Also, the Graphical Workspace Manager Options dialog box has been added to provide a number of additional display options. For more information, see “Graphical Workspace Manager” on page 17.</td>
<td></td>
</tr>
<tr>
<td>Window List provides a list of all currently running applications. The Window List enables you, with the click of a mouse button, to locate any application, even those in workspaces other than the current workspace. The Window List also provides the ability to perform window actions on a selected group of applications. With the 4/01 release, you can choose to display or not display the Workspace column. For more information, see “Window List” on page 26</td>
<td>6/00 and updated 4/01</td>
</tr>
<tr>
<td>The Workspace Manager provides a graphical user interface (GUI) for controlling behavior and the number of workspaces. You can add and delete workspaces by using a slider. You can also display the Graphical Workspace Manager in the Workspace Switch Area of the Front Panel. For more information, see “Workspace Manager” on page 33.</td>
<td>4/01</td>
</tr>
<tr>
<td>Adding Multiple Files to Email</td>
<td></td>
</tr>
<tr>
<td>Feature Description</td>
<td>First Released</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>This feature enables you to keep the Mailer - Attachment - Add dialog box open in order to add two or more files to an email. The need to select Add Files from the Attachment menu multiple times is eliminated. For more information, see “Attaching Multiple Files to Email” on page 37.</td>
<td>1/01</td>
</tr>
<tr>
<td>Removable Media Manager</td>
<td>6/00 and updated 10/00</td>
</tr>
<tr>
<td>Removable Media Manager centralizes access to removable devices in one window. You can format, query properties, view directory structures, and where applicable, protect and slice media. For more information, see “Using Removable Media Manager” on page 9</td>
<td></td>
</tr>
<tr>
<td>Energy Star Standards</td>
<td>6/00</td>
</tr>
<tr>
<td>X11R6.4 standards have been enhanced with Frame Buffer Power Management (FBPM), an extension to the Display Power Management System (DPMS). This enhancement is added to fulfill the U.S. government’s Energy Star program requirements and only works on Energy Star-compliant hardware.</td>
<td></td>
</tr>
<tr>
<td>Early Access</td>
<td></td>
</tr>
<tr>
<td>This release includes an Early Access (EA) directory with EA software. For more information, see the Readme on the Solaris Software CD 2 of 2.</td>
<td></td>
</tr>
</tbody>
</table>
The Removable Media Manager has been enhanced in the Solaris 8 6/00 release and again in the 10/00 and 4/01 releases. The following information supplements information on the Removable Media Manager that is in “Using Removable Media with File Manager” in Solaris Common Desktop Environment: User’s Guide.

**Note** – For the most current man pages, use the man command. The Solaris 8 Update release man pages include new feature information that is not in the Solaris 8 Reference Manual Collection.

## Using Removable Media Manager

Use Removable Media Manager to format, protect, and view data on removable media devices such as diskettes, CD-ROM, DVD-ROM, Iomega Zip drives, and Iomega Jaz drives.

### Starting Removable Media Manager

To open the Removable Media Manager:

- In File Manager, choose Removable Media Manager from the File menu.
- From the Front Panel, click the Removable Media Manager icon in the Files subpanel.
- From the Workspace menu, choose Removable Media Manager in the Folders menu.
When Removable Media Manager starts, it displays all media currently loaded into the drives. The different forms of devices are represented by icons and are unlimited. For example, if a machine has three drives loaded with diskettes, three diskette icons are displayed. The icon view updates each time a device is inserted or ejected. Each class of media is represented by a different icon.

You can select one or more devices and perform operations on them. A device is displayed with a nickname \( \text{cdrom0} \), an optional volume name \( \text{ssa_2_1_sparc} \), and an optional partition or slice number \( \text{s1} \).

---

**Note** – In order to have the Removable Media Manager recognize a diskette, you must choose Open Floppy from one of the following:

- File subpanel of the Front Panel
- File menu of the File Manager
- Folders menu of the Workspace Menu

---

**Supported Media Classes**

The Removable Media Manager supports the following devices:

- Diskette
- CD-ROM
- DVD-ROM
- Iomega Zip drive
- Iomega Jaz drive
- Rmdisk (generic call includes Syquest drives)

**Viewing Additional Information About a Device**

To display additional information about a device, you must change the viewing option.

**To Change the Viewing Option**

1. In the Removable Media Manager window, click a device icon.
2. From the View menu, choose Set View Options.
3. In the Representation section, select By Name, date, size.
4. Click Apply to view the effect of the selection.
5. Click OK.
Note – If the device has no name, it is shown as ..unnamed.

In verbose mode, the Removable Media Manager shows the following for each media object:

- Volume name
- Media nickname or alias
- Media partition or slice number
- Total storage capacity
- Mount-point UNIX® permissions
- Mount-point owner name
- Mount-point group name
- Mount-point path
- Mount-point date

Properties

The Properties dialog box displays the properties and capacity capabilities of a device. You can display two property categories by using the Properties dialog box:

- Information – Shows the alias, product ID, write protect, and password protection status. Also displayed are the file system, mount point, and total capacity.
- Floating Capacities – Shows the used and available capacities for a device.

▼ To View the Properties of a Device

1. In the Removable Media Manager window, click a device icon.
2. From the Selected menu, choose Properties.
3. Click Close.

Note – To view properties by using the command line, type:

```
% sdtmedia_prop -u k /vol/dev/rdsk/...
```

where \( k \) is b, k, m, or g to show capacities in bytes, kilobytes, megabytes, or gigabytes.

Formatting and Slicing Devices

You can format, name, and create file systems in a single operation on all types of removable devices by using the format option in the Removable Media Manager window.
When the formatting process begins, two separate actions are launched. The first is a low-level format of the device, which utilizes a status bar to update you on the percentage completed. When the format is complete, the second action is launched, which applies the file system and optional name and slices to the device.

▼ To Format a Device

Formatting is done on all rewritable devices, including diskettes, Iomega Zip drives, and Iomega Jaz drives.

1. Click a device icon.

2. In the Removable Media Manager window, choose Format from the Selected menu.
   The Media Format window appears with appropriate selections.

3. Select either Quick Format or Long Format.

4. Choose a type from the File System Type menu.

5. (Optional) Under Volume Label, type a name for the formatted device.
   If no name is specified, the device is not named. If the device has already been formatted and has a volume name, the volume name is not shown.
   If UFS was selected as the file system, the Solaris Slice Editor button appears in the dialog box.

6. Click Format.
   “Long Format” ignores password protection on the device. If the media is read-write protected, you are prompted for the password. “Long Format” is the default value for previously sliced media, write-protected media, or write-protected with password media.

Note – To format, name, and create file systems on all types of removable devices by using the command line, type:

```
% sdtmedia_format -d volume_device_name
```

Creating Solaris Slices

Use the Media Slice Editor to create Solaris slices on a device. You can only create slices in a UFS file system. If you select a PCFS or UDFS file system, you do not have the option of creating Solaris slices.
After slices are created, you can use the Media Slice Editor to write UFS or UDFS file systems onto the slices. Where possible, the Media Slice Editor checks the slice values you supplied as well as the overall integrity of the slice information. For example, the editor reports errors for overlapping slices.

You can create slices by using AutoSlice or by typing slice values into the Slice Details section manually.

▼ To Use AutoSlice

1. In the Media Format window, click Solaris Slice Editor.

2. In the Slice Editor window, click AutoSlice.

3. Use the spin box to increase or decrease the number of slices to be created in the Number of slices numerical text field.

4. Click OK in the AutoSlice window.

5. Click OK in the Slice Editor window.

6. Click Format in the Media Format window.

▼ To Use Slice Details

1. Select B, K, M, or C for the slice unit in byte, kilobyte, megabyte, or cylinder.

2. Type the slice size in the Size field.

3. Click New.

4. Repeat steps 2 and 3 for each new slice.
   The slice number and size appear in the left side of the window.

5. Click OK in the Slice Editor window.

6. Click Format in the Media Format window.

Protecting a Device

Device protection enables you to view the software protection for a selected device and to either write protect, read-write protect, or disable protection. The device protection options are:

- Disable protection
- Write protect without password
- Write protect with password
- Read-write protect with password

▼ To View a Device’s Protection
1. In the Removable Media Manager window, click a device icon.
2. From the Selected menu, choose Properties.

▼ To Disable Protection
This option allows you to disable software protection if the device has been previously write protected or read-write protected.
1. In the Removable Media Manager window, click the device icon.
2. From the Selected menu, choose Disable Protection.
3. If the media has been write protected or read-write protected with a password, type the password into the Password dialog box.
4. Click Apply.

Note – To disable protection by using the command line, type:
% sdtmedia_prot -d /vol/dev/rdsk/...
If the device is password protected, you are prompted for the password.

▼ To Enable Write Protection Without a Password
This option allows you to enable software protection without password protection.
1. In the Removable Media Manager window, click the device icon.
2. From the Selected menu, choose Write Protect.

▼ To Enable Write Protection With a Password
This option allows you to enable software protection with password protection.
1. In the Removable Media Manager window, click the device icon.
2. From the Selected menu, choose Read-Write Protect.
3. Click Write Protect With Password.
4. Click OK.
5. Type the password in the Enter Password field.
6. Type the password in the Verify Password field.
7. Click Apply.

To Enable Read-Write Protection With a Password
1. In the Removable Media Manager window, click the device icon.
2. From the Selected menu, choose Read-Write Protect.
3. Click Read-Write Protect With Password.
4. Click OK.
5. Type the password in the Enter Password field.
6. Type the password in the Verify Password field.
7. Click Apply.

Note – To write protect by using the command line, type:

```
% sdtmedia_prot -w /vol/dev/rdsk/...
```

If the device is not protected, the -w option write protects the device without a password, and does not display any dialog boxes. If the device is already protected, the Password dialog box appears.

Changing Your Password

To change your password, you must first disable the existing password protection and then apply the new password protection to the device.

To Change Your Password

To change a password requires the following procedures:

1. See “To Disable Protection” on page 14.
2. See “To Enable Write Protection With a Password” on page 14 or “To Enable Read-Write Protection With a Password” on page 15
Using Window Manager Enhancements

Solaris 8 workspace and window management has been enhanced in the Solaris 8 6/00 release and again in the 4/01 release. The following information supplements desktop information that is in Solaris Common Desktop Environment: User’s Guide.

The workspace and window management enhancements consist of three separate applications. They are:

- “Graphical Workspace Manager” on page 17
- “Window List” on page 26
- “Workspace Manager” on page 33

These three applications provide the ability to manipulate workspaces and windows from the different applications, depending on the tasks you want to perform. The Graphical Workspace Manager allows for changes in workspaces and windows. The Window List concentrates on the manipulation of windows. Finally, the Workspace Manager controls the number of workspaces, whether or not the Workspace Switch Area appears on the Front Panel, and the ability to restore the default values.

Note – For the most current man pages, use the man command. The Solaris 8 Update release man pages include new feature information that is not in the Solaris 8 Reference Manual Collection.

Graphical Workspace Manager

The Graphical Workspace Manager enables you to operate a workspace “control panel.” This panel displays a window containing a miniaturized picture of each workspace on the desktop. Workspaces may be created, deleted, renamed, tiled, or cascaded. Application windows may be moved (within or between workspaces), terminated, minimized, or maximized.
Starting the Graphical Workspace Manager

You can start the Graphical Workspace Manager either from the desktop or from the command line.
To Start the Graphical Workspace Manager From the Desktop
1. Right-click on the desktop to open the Workspace Menu.
2. Choose Applications.
3. Choose Application Manager.
4. Double-click Desktop Apps.
5. Double-click GWM.

To Start the Graphical Workspace Manager From the Command Line
- At the command line, type `sdtgwm`.

Graphical Workspace Manager Tasks
You can perform several tasks by using the Graphical Workspace Manager.
- “To Add a Workspace” on page 20
- “To Delete a Workspace” on page 21
- “To Rename a Workspace” on page 21
- “To Switch to a Different Workspace” on page 21
- “To Cascade All Windows in a Workspace” on page 21
- “To Tile All Windows in a Workspace” on page 21
- “To Minimize a Window” on page 22
- “To Close a Window” on page 23
- “To Terminate an Application” on page 23
- “To Move a Window to a Different Workspace” on page 23
- “To Occupy Workspace(s)” on page 23
- “To Unoccupy Workspace(s)” on page 23
To Add a Workspace

1. Choose Add Workspace from the Workspace menu.
2. Type a name in the Add Workspace dialog box.
3. Click OK.
▼ To Delete a Workspace
1. Choose Delete Workspace from the Workspace menu.
2. Choose the workspace to be deleted from the submenu.

▼ To Rename a Workspace
1. Choose Rename from the Workspace menu.
2. From the submenu, select the workspace to be renamed.
3. Type the new name in the Rename Workspace dialog box.
4. Click OK.

▼ To Switch to a Different Workspace
1. Choose Switch to Workspace from the Workspace menu.
2. From the submenu, select the workspace to which you want to switch.

▼ To Cascade All Windows in a Workspace
This task executes in the current workspace.
- Choose Cascade All Windows from the Workspace menu.

▼ To Tile All Windows in a Workspace
This task executes in the current workspace.
1. Choose Tile All Windows from the Workspace menu.
2. From the submenu, choose either Horizontal or Vertical.

▼ To Open the Options Dialog Box
- Choose Options from the Workspace menu.

For further information on the Options dialog box, see “Graphical Workspace Manager Options Dialog Box” on page 24.
To Minimize a Window

1. In the Graphical Workspace Manager, select a window.
2. Choose Minimize from the Window menu.
To Close a Window

1. In the Graphical Workspace Manager, select a window.
2. Choose Close Window from the Window menu.
3. (Optional) If the window you are closing is the only window that contains the application, a confirmation dialog box appears. Click OK to continue with closing the window.

To Terminate an Application

1. In the Graphical Workspace Manager, select an application window.
2. Choose Terminate Application from the Window menu.
3. In the confirmation dialog box, click OK.

To Move a Window to a Different Workspace

1. In the Graphical Workspace Manager, select a window.
2. Choose Move to Workspace from the Window menu.
3. From the submenu, choose the workspace to which you want the window to move. You can also choose All Workspaces.

To Occupy Workspace(s)

1. In the Graphical Workspace Manager, select a window.
2. Choose Occupy Workspace from the Window menu.
3. Choose the workspace(s) from the submenu.
   You can select multiple workspaces by pressing the Control key and selecting the additional workspaces.
4. Click OK.

To Unoccupy Workspace(s)

1. In the Graphical Workspace Manager, select a window.
2. Choose Unoccupy Workspace from the Window menu.
Graphical Workspace Manager Options Dialog Box

You can set the following options from the Graphical Workspace Manager Options dialog box.

- **Show Workspace Thumbnails On Front Panel** – Ensures that the Graphical Workspace Manager workspace images appear on the Front Panel.
- **Show Workspace Backdrops** – Ensures that the actual workspace backdrops are displayed in the Graphical Workspace Manager.
- **Show Workspace Names** – Displays the workspace names in the thumbnailed workspaces of the Graphical Workspace Manager.
- **Number of Visible Rows** – Enables the setting of the number of rows that are used to display the open workspaces of the Graphical Workspace Manager.
- **Desired Thumbnail Width (Pixels)** – Sets the width, in pixels, of the workspace display in the Graphical Workspace Manager.
- **Changes Thumbnail Size** – Specifies that a resize of the Graphical Workspace Manager actually increases or decreases the size of the Graphical Workspace Manager main window. This option changes the size of the workspace thumbnails.
- **Changes Layout** – Specifies that a resize of the Graphical Workspace Manager changes only the layout of the workspace thumbnails within the Graphical Workspace Manager.
- **Show Window Contents** – Causes window images to be grabbed and displayed.
- **Show Window Frames** – Window images are not grabbed. Blank boxes are displayed.
- **Highlight Windows In Current Workspace** – The windows in the current workspace are displayed in the desktop highlight color. This option is only available if Show Window Frames is selected.
- **Show Window Names** – The command name of the window appears in the window. This option is only available if Show Window Frames is selected.
Using Window Manager Enhancements

Graphical Workspace Manager Options

- Show Workspace Thumbnails On Front Panel

Workspaces
- Show Workspace Backdrops
- Show Workspace Names

Number Of Visible Rows: 2
Desired Thumbnail Width (Pixels): 339

Resize Behavior
- Changes Thumbnail Size
- Changes Layout

Windows
- Show Window Contents
- Show Window Frames
  - Highlight Windows In Current Workspace
  - Show Window Names

OK  Cancel
Window List

The Window List displays information about all windows across the CDE workspaces. After it is launched, the window list is updated in a dynamic fashion.

You can sort the windows in one of the following orders:

- Workspace Name
- Window State
- Application Name
- Window Title

Starting the Window List

You can start the Window List either from the desktop or from the command line.
To Start the Window List From the Desktop

1. Right-click the desktop to open the Workspace Menu.
2. Select Applications.
3. Select Application Manager from the Applications submenu.
4. Double-click Desktop Apps.
5. Double-click Window List.

To Start the Window List From the Command Line

- At the command line, type `sdtwinlst`.

Performing Window List Tasks From the Window Menu

You can perform several tasks by using the Window List. These tasks are:

- **To Go to a Window** on page 28 – Goes to the selected window and gives it focus. If the window is in another workspace, you are moved to that workspace.
- **To Get a Window** on page 29 – Moves the selected window from whatever workspace it is in to the one you are currently in and gives it focus.
- **To Lower a Window in the Stack** on page 29 – Lowers the selected window to the bottom of the window stack.
- **To Minimize the Selected Window** on page 29 – Minimizes the selected window(s).
- **To Close a Window** on page 29 – Closes the selected window(s). If the window to be closed is the only window that is associated with an application, a confirmation dialog box appears.
- **To Terminate an Application** on page 29 – A confirmation dialog box appears and all windows that are associated with that application are closed.
- **To Move the Selected Window Into Another Workspace** on page 30 – Moves the selected window(s) to the specified workspace.
- **To Occupy the Selected Workspace** on page 30 – Opens the Workspace Chooser dialog box and places the selected window in the workspace that is chosen from the list.
- **To Unoccupy the Selected Workspace** on page 30 – Removes the selected window from the current workspace. If the current workspace is the only workspace that the selected window resides in, this option is grayed out.
- **To Cascade All Non-minimized Windows in a Workspace** on page 30 – Cascades all windows in the current workspace.
“To Tile All Non-minimized Windows in a Workspace” on page 30 – Tiles all windows in the current workspace. You can choose horizontal tiling or vertical tiling.

To Go to a Window

1. From the Window List, select a window.
2. Choose Go To Window from the Window menu.
Note – Depending on the setting of the Window List Options, you might be able to double-click the Window List entry and move to the workspace that contains the selected window. You could also have the window move to the current workspace. Refer to “To Set the Action of a Double-click on a Window Entry” on page 33.

▼ To Get a Window
1. From the Window List, select a window.
2. Choose Get Window from the Window menu.

▼ To Lower a Window in the Stack
1. From the Window List, select a window.
2. Choose Lower from the Window menu.

▼ To Minimize the Selected Window
1. From the Window List, select a window or windows.
2. Choose Minimize from the Window menu.

▼ To Close a Window
1. From the Window List, select a window or windows.
2. Choose Close Window from the Window menu.
3. (Optional) If the window you are choosing is the only window that contains a particular application, a confirmation dialog box appears. Click OK to close the window and terminate the application.

▼ To Terminate an Application
1. From the Window List, select a window.
2. Choose Terminate Application from the Window menu.
3. (Optional) If the window you are closing is the only window that contains a particular application, a confirmation dialog box appears. Click OK to close the window and terminate the application.
To Move the Selected Window Into Another Workspace
1. From the Window List, select a window or windows.
2. Choose Move to Workspace from the Window menu.
3. Choose a workspace or All Workspaces.

To Occupy the Selected Workspace
1. From the Window List, select a window or windows.
2. Choose Occupy a Workspace from the Window menu.
3. Choose the workspace for the window to occupy from the Occupy Workspace dialog box.

To Unoccupy the Selected Workspace
1. From the Window List, select a window or windows.
2. Choose Unoccupy a Workspace from the Window menu.

To Cascade All Non-minimized Windows in a Workspace
You can perform this task only in the current workspace.
- Choose Cascade All in Workspace from the Window menu.

To Tile All Non-minimized Windows in a Workspace
You can perform this task only in the current workspace.
1. Choose Tile All in Workspace from the Window menu.
2. Choose Horizontal or Vertical from the submenu.

Performing Window List Tasks From the Option Menu
You can perform the following tasks from the Option Menu.
- “Sorting Options” on page 31
- “Opening the Options Dialog” on page 31
### Sorting Options
1. Select Sort By from the Option menu.
2. Choose one of the four sort options.

### Opening the Options Dialog
- Select Options from the Option menu.
Window List Options

By using the Window List – Options dialog box, you can change the following options.

- Show Column
- Double-clicking a window in the list

These options enable you to select which columns appear in the Window List and what action is taken when you double-click a window item in the Window List.

![Window List – Options Dialog](image)

▶ To Show Columns

- Click the State, Application, or Workspace check boxes for that column to be displayed.
  The absence of a checkmark means the column will not be displayed.

---

*Note* – The Window Title column is always visible.
▼ To Set the Action of a Double-click on a Window Entry

The Window List provides the ability to select the effect of double-clicking a window entry in the Window List.

1. **Click the check box for Switches to the workspace where the window resides.**
   This setting has the effect of switching to the workspace that contains the selected window.

2. **Click the check box for Moves the window to the current workspace.**
   This setting has the effect of moving the selected window to the current workspace.

---

**Workspace Manager**

The Workspace Manager provides a graphical user interface (GUI) for controlling behavior and the number of workspaces. You can also add and delete workspaces by using the slider. Workspace Manager enables you to show the Workspace Switch Area on the Front Panel instead of the workspace buttons. You can also return to the default settings.
Starting Workspace Manager

You can start the Workspace Manager either from the Workspace Menu or at the command line.

▼ To Start the Workspace Manager From the Desktop

1. Right-click the desktop to open the Workspace Menu.
2. Choose Applications.
3. Choose Application Manager from the submenu.
4. Double-click Desktop Apps.
5. Double-click Workspace Manager Controls.

▼ To Start the Workspace Manager From the Command Line
  ● At the command line, type `sdtwsm`.

---

Using Workspace Manager Controls

You can perform several functions by using the Workspace Manager.

- “To Display the Workspace Switch Area on the Front Panel” on page 35
- “To Synchronize Workspaces Across Screens” on page 35
- “To Set the Number of Workspaces” on page 35
- “To Restore the Default Settings” on page 36

▼ To Display the Workspace Switch Area on the Front Panel

1. Select the check box for Show Workspace Switch Area On Front Panel.
2. Click OK.

▼ To Synchronize Workspaces Across Screens

1. Select the check box for Synchronize Workspaces Across Screens.
2. Click OK.

▼ To Set the Number of Workspaces

1. Move the Number of Workspaces slider until the desired number of workspaces appears.
2. If the resulting number of workspaces is an addition, the new workspace icon or icons appears on the Front Panel.
3. (Optional) If the resulting number of workspaces is a reduction, the Workspace Manager Delete Workspace dialog box appears. Click OK to delete the workspace or workspaces.

▼ To Restore the Default Settings
- Click the Default button in the Workspace Manager Controls window.
Adding Multiple Files to Email

The mailer feature is new in the Solaris 8 1/01 release and has been updated in the 4/01 release. The following information supplements information on the Mailer that is in “Using Mailer” in Solaris Common Desktop Environment: User’s Guide.

Note – For the most current man pages, use the man command. The Solaris 8 Update release man pages include new feature information that is not in the Solaris 8 Reference Manual Collection.

Attaching Multiple Files to Email

In the Mailer, the addition of the check box for Keep dialog box open on the desktop enables you to attach multiple files to an email. You no longer need to select Add Files from the Attachments menu each time you add another file.

To Add an Attachment

1. Compose your email message.
2. Choose Add File from the Attachments menu in the Compose window.
   The Mailer - Attachments - Add dialog box is displayed.
3. (Optional) Click the Keep dialog box open on desktop check box.
   When you click this option box, you indicate that you do not want the dialog box to close after you click the Add button. This action eliminates the need to choose Add File from the Attachments menu to add more than one attachment.
4. **Select a file to attach and click Add.**
   The attachment is added to the attachment list in the lower portion of the Compose window.
   To remove an attachment you just added, select its icon and choose Delete from the Attachments menu.
   To restore a deleted attachment, choose Undelete from the Attachments menu.

5. **(Optional) Choose Rename from the Attachments menu to change the name of a selected attachment.**
   If you drag and drop messages from the Message Header List in the main window to the attachment list, Mailer creates one mailbox that contains all of the messages.