syslogd reads and forwards system messages to the appropriate log files and/or users, depending upon the priority of a message and the system facility from which it originates. The configuration file /etc/syslog.conf (see syslog.conf(4)) controls where messages are forwarded. syslogd logs a mark (timestamp) message every markinterval minutes (default 20) at priority LOG_INFO to the facility whose name is given as mark in the syslog.conf file.
A system message consists of a single line of text, which may be prefixed with a priority code number enclosed in angle-brackets (< >); priorities are defined in <sys/syslog.h>.
syslogd reads from the STREAMS log driver, /dev/log, and from any transport provider specified in /etc/netconfig, /etc/net/transport/hosts, and /etc/net/transport/services.
syslogd reads the configuration file when it starts up, and again whenever it receives a HUP signal (see signal(3HEAD), at which time it also closes all files it has open, re-reads its configuration file, and then opens only the log files that are listed in that file. syslogd exits when it receives a TERM signal.
As it starts up, syslogd creates the file /etc/syslog.pid, if possible, containing its process identifier (PID).
If message ID generation is enabled (see log(7D)), each message will be preceded by an identifier in the following format: [ID msgid facility.priority]. msgid is the message's numeric identifier described in msgid(1M). facility and priority are described in syslog.conf(4). [ID 123456 kern.notice] is an example of an identifier when message ID generation is enabled.
If the message originated in a loadable kernel module or driver, the kernel module's name (for example, ufs) will be displayed instead of unix. See EXAMPLES for sample output from syslogd with and without message ID generation enabled.
In an effort to reduce visual clutter, message IDs are not displayed when writing to the console; message IDs are only written to the log file. See EXAMPLES.
The following options are supported:
Turn on debugging. This option should only be used interactively in a root shell once the system is in multi-user mode. It should not be used in the system start-up scripts, as this will cause the system to hang at the point where syslogd is started.
Specify an alternate configuration file.
Specify an interval, in minutes, between mark messages.
Specify an alternative log device name. The default is /dev/log.
Disable the syslogd UPD port to turn off logging of remote messages.
The following example shows the output from syslogd when message ID generation is not enabled:
Sep 29 21:41:18 cathy unix: alloc /: file system full
The following example shows the output from syslogd when message ID generation is enabled. Note that the message ID is displayed when writing to log file/var/adm/messages.
Sep 29 21:41:18 cathy ufs: [ID 845546 kern.notice] alloc /: file system full
The following example shows the output from syslogd when message ID generation is enabled when writing to the console. Note that even though message ID is enabled, the message ID is not displayed at the console.
Sep 29 21:41:18 cathy ufs: alloc /: file system full
STREAMS log driver
specifies the transport providers available on the system
network hosts for each transport
network services for each transport
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
The mark message is a system time stamp, and so it is only defined for the system on which syslogd is running. It can not be forwarded to other systems.