The ftp server, in.ftpd(1M), reads the ftpusers file. If the login name of the user matches one of the entries listed, it rejects the login session and sends the Login incorrect and Login failed error messages.
root daemon bin sys adm lp uccp nuucp listen nobody noaccess nobody4
The root entry is included in /etc/ftpusers as a security measure since the default policy is to disallow remote logins for this identity. This policy is also set in the the default value of the CONSOLE entry in the /etc/default/login file. See login(1). If you allow root login privileges by deleting the root entry in /etc/ftpusers, you should also should modify the security policy in /etc/default/login to reflect the site security policy for remote login access by root.
Other default entries are administrative identities that are typically assumed by system applications but never used for local or remote login, for example sys and nobody. Since these entries do not have a valid password field instantiated in shadow(4), no login can be performed.
If a site adds similar administrative or system application identities in passwd(4) and shadow(4), for example, majordomo, the site should consider including them in /etc/ftpusers for a consistent security policy.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|