The sleep utility will suspend execution for at least the integral number of seconds specified by the time operand.
The following operands are supported:
A non-negative decimal integer specifying the number of seconds for which to suspend execution.
To execute a command after a certain amount of time:
(sleep 105; command)&
while true do command sleep 37 done
See environ(5) for descriptions of the following environment variables that affect the execution of sleep: LC_CTYPE, LC_MESSAGES, and NLSPATH.
The following exit values are returned:
The execution was successfully suspended for at least time seconds, or
SIGALRM signal was received (see NOTES).
An error has occurred.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
If the sleep utility receives a
SIGALRM signal, one of the following actions will be taken:
Terminate normally with a zero exit status.
Effectively ignore the signal.
The sleep utility will take the standard action for all other signals.