Solaris Common Desktop Environment: User's Transition Guide
Contents

Preface v

1. Moving from the OpenWindows Environment to Solaris CDE 1
   Choosing Which Desktop to Log In To 1
   Front Panel Applications 2
   Accessing the Workspace Programs Menu 3
   Desktop Services 4
   Using Windows, Menus, Buttons, and the Mouse in CDE 5
   Using Drag and Drop in CDE 7
      File Manager Drag and Drop 7
      Mailer Drag and Drop 7
   Text Editor/Mailer Compose Window Drag and Drop 8
   Style Manager and Customizing the Workspace 8
   Applications and Application Manager 9
   Accessing Online Help and AnswerBook Documentation 9
   Frequently Asked Questions 10
      Desktop Transition Questions 11
      Color Scheme Questions 15

Index 17
Preface

The Solaris Common Desktop Environment: User’s Transition Guide can help users who are making the transition from the OpenWindows® environment to the Common Desktop Environment (CDE).

Ordering Sun Documents

The SunDocs℠ program provides more than 250 manuals from Sun Microsystems, Inc. If you live in the United States, Canada, Europe, or Japan, you can purchase documentation sets or individual manuals using this program.

For a list of documents and how to order them, see the catalog section of SunExpress™ On The Internet at http://www.sun.com/sunexpress.

What Typographic Changes Mean

Table P–1 describes the type changes used in this book.
TABLE P–1 Typographic Conventions

<table>
<thead>
<tr>
<th>Typeface or Symbol</th>
<th>Meaning</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>AaBbCc123</td>
<td>The names of commands, files, and directories; on-screen computer output</td>
<td>Edit your .login file.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Use ls -a to list all files.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>system% You have mail.</td>
</tr>
<tr>
<td>AaBbCc123</td>
<td>Command-line placeholder: replace with a real name or value</td>
<td>To delete a file, type rm filename.</td>
</tr>
<tr>
<td>AaBbCc123</td>
<td>Book titles, new words or terms, or words to be emphasized</td>
<td>Read Chapter 6 in User’s Guide. You must be root to do this.</td>
</tr>
</tbody>
</table>

Shell Prompts in Command Examples

The following table shows the default system prompt and superuser prompt for the C shell, Bourne shell, and Korn shell.

TABLE P–2 Shell Prompts

<table>
<thead>
<tr>
<th>Shell</th>
<th>Prompt</th>
</tr>
</thead>
<tbody>
<tr>
<td>C Shell prompt</td>
<td>machine_name%</td>
</tr>
<tr>
<td>C shell superuser prompt</td>
<td>machine_name#</td>
</tr>
<tr>
<td>Bourne shell and Korn shell prompt</td>
<td>$</td>
</tr>
<tr>
<td>Bourne shell and Korn shell superuser prompt</td>
<td>#</td>
</tr>
</tbody>
</table>
CHAPTER 1

Moving from the OpenWindows Environment to Solaris CDE

This document introduces the changes that users might expect when making the transition from the OpenWindows environment to the Solaris Common Desktop Environment (CDE). The best place to find complete information on an application or element on the desktop is in *Solaris Common Desktop Environment: User’s Guide* and the CDE online help volumes.

Consult this guide for an overview of some of the desktop differences. You may want to scan the “Frequently Asked Questions” on page 10 at the end of this document for possible answers to some of your questions.

Choosing Which Desktop to Log In To

With Solaris CDE you can choose to log in to either the OpenWindows desktop or the CDE desktop (as well as a failsafe session or your last desktop) from your login screen. For more information on logging in, refer to the Login Manager help volume or “Chapter 2, Starting a Desktop Session” in *Solaris Common Desktop Environment: User’s Guide*.

1. **Choose Session from the Options menu on the login screen.**
   
   You see the following choices: Common Desktop Environment, OpenWindows Desktop, OpenWindows 2 Desktop, User’s Last Desktop, Failsafe Session.
2. Select either OpenWindows Desktop or CDE.
   Once you have made your selection, you see either the OpenWindows or the CDE logo.

3. Continue your login.

Front Panel Applications

The Front Panel is a collection of frequently used controls and desktop services available in every workspace. Controls enable you to access applications. These are some of the available applications on the Workspace Programs menu. See Solaris Common Desktop Environment: User’s Guide for more information on the Front Panel.

Some Front Panel controls have subpanels associated with them. The subpanels contain frequently-used controls that are related to the Front Panel control. Click on the triangle above the Front Panel control to open its subpanel. Click on the inverted triangle to close the subpanel.

Workspaces are like separate screens or windows. You can display another workspace by clicking the workspace’s button in the workspace switch of the Front Panel.
Accessing the Workspace Programs Menu

In the OpenWindows environment, the main way to start an application was through the Workspace menu. A Workspace menu still exists in Solaris CDE; however, the main access point for workspace functionality is the Front Panel.

The applications available through the Workspace menu include the items on the Front Panel and also a subset of the applications available to you within Application Manager. Refer to Solaris Common Desktop Environment: User’s Guide for complete information on the Front Panel and Application Manager.

You can access a Programs submenu from your Solaris CDE Workspace menu that contains the following items:
Desktop Services

Some of the desktop services you are used to using in the OpenWindows environment are located in different places in Solaris CDE. The following list highlights some of the differences. The service is described first, then the OpenWindows location, and Common Desktop Environment (CDE) location.
TABLE 1–1  Location of Desktop Services

<table>
<thead>
<tr>
<th>Desktop Service</th>
<th>OpenWindows</th>
<th>CDE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logout</td>
<td>Workspace menu</td>
<td>Front Panel</td>
</tr>
<tr>
<td>LockScreen</td>
<td>Utilities menu</td>
<td>Front Panel</td>
</tr>
<tr>
<td>Customize Workspace</td>
<td>Workspace menu</td>
<td>Style Manager</td>
</tr>
<tr>
<td>Save Workspace</td>
<td>Utilities menu</td>
<td>Style Manager</td>
</tr>
<tr>
<td>Refresh</td>
<td>Utilities menu</td>
<td>Front Panel</td>
</tr>
<tr>
<td>Properties</td>
<td>Workspace menu</td>
<td>Style Manager</td>
</tr>
<tr>
<td>Help</td>
<td>Workspace menu</td>
<td>Front Panel, Application Manager, Workspace menu</td>
</tr>
</tbody>
</table>

Using Windows, Menus, Buttons, and the Mouse in CDE

Windows, menus, buttons and the mouse are used in Solaris CDE slightly differently than in the OpenWindows environment. For complete information on using window, menus, buttons and the mouse, refer to “Chapter 1, Basic Skills” in Solaris Common Desktop Environment: User’s Guide.
Examples of some of these differences are listed here. The task is described first, then OpenWindows (OW) behavior, and Common Desktop Environment (CDE) behavior.

- To iconify a window:
  OW: Choose Close to iconify.
  CDE: Click minimize to iconify.

- To expand or enlarge a window:
  OW: Maximize (double-click on frame) expands vertically.
  CDE: Maximize covers entire screen; can enlarge window by selecting and dragging window frame.

- To remove pop-up windows and dialog boxes:
  OW: Click pushpin to remove pop-up window or dialog box.
  CDE: Choose Close or Cancel from the Window menu (or the Close or Cancel button at the bottom of the dialog box) to remove pop-up windows or dialog boxes.

- To terminate an application:
  OW: Choose Quit or Exit from the Window menu to terminate an application.
  CDE: Choose Close or Exit from the Window menu to terminate application.

- To move a window:
  OW: Grab anywhere on window frame (except window corners) to move the window.
  CDE: Grab window title area to move the window.
Using Drag and Drop in CDE

Drag and drop enables you to perform a variety of tasks using the mouse. Refer to “Chapter 1, Basic Skills” in Solaris Common Desktop Environment: User’s Guide for complete drag-and-drop information. In certain areas, drag-and-drop behavior is different in CDE from what you might expect from OpenWindows behavior. The following list highlights only those operations that differ between the two desktops.

The task is described first, then OpenWindows (OW) behavior, and Common Desktop Environment (CDE) behavior.

File Manager Drag and Drop

- Select an icon from File Manager and drop it on a minimized icon on the desktop.

  OW: Results in appropriate action. If dropped on Print Tool, then the file would be printed. The OpenWindows environment does not have a Front Panel on which to drop icons.

  CDE workspace: Does not support drops on minimized icons. The Front Panel offers functionality similar to OW drag and drop. For example, dropping a selected icon on the Print control in the Front Panel results in the file being printed.

- Select and drop an icon on the workspace/desktop area.

  OW: Would result in that icon being launched or executed.

  CDE: Creates a reference to the dropped item. The original icon still appears in File Manager.

Mailer Drag and Drop

- Select and drag multiple messages from a Mailer header window to a File Manager window.

  OW: Creates one message icon per message. The original messages are not deleted.

  CDE: Creates one mailbox that contains all the selected messages. The original messages are not deleted.

- Select and drag a single message or multiple messages to another mailbox window.

  OW: Not available.

  CDE: Moves the selected messages to a destination mailbox.
- Drag and drop text selections or selected icons on the Mailer message or attachment area.

  OW: Inserts text selections icon in message area or attaches an icon in attachment list.
  CDE: Does not allow drops of text or icons. The message/attachment area is read-only. (They are allowed in the Compose window.)

Text Editor/Mailer Compose Window Drag and Drop

- Drop selected icon into text window in text region.
  OW: Text appears at drop point.
  CDE: Text appears at insertion point. Same as choosing Include from the File menu.

- Dragging multiple attachments to File Manager.
  OW: Attachments are copied and names are preserved.
  CDE: Mailer only supports dragging one attachment at a time.

Style Manager and Customizing the Workspace

The Style Manager replaces the OW Workspace Properties window. The items available through Style Manager are: Color, Font, Backdrop, Keyboard, Mouse, Audio, Screen, Window, and Startup. For complete information on Style Manager refer to Solaris Common Desktop Environment: User’s Guide.
Applications and Application Manager

Application Manager is a special File Manager view of special folders on your system. You can run your Open Windows and Motif® applications from Application Manager. For complete information refer to Solaris Common Desktop Environment: User's Guide.

Accessing Online Help and AnswerBook Documentation

An AnswerBook2® item is on the Help subpanel in Solaris CDE, and can be accessed from Application Manager. It contains documentation about the Solaris Common Desktop Environment. If you have OpenWindows software installed, the OpenWindows End-User AnswerBook documentation will also be available.
Frequently Asked Questions

The following questions are those that users might ask when transitioning from the OpenWindows environment to Solaris CDE.
Desktop Transition Questions

Read the following questions for more information on the differences between the CDE desktop and the OpenWindows desktop. Where applicable, the documentation location that contains the information has been noted.

Q. Where do I find my OpenWindows applications?
A. A folder in Application Manager, titled OpenWindows, contains your favorite OpenWindows applications.

If you ran OpenWindows applications from the command line, you can run them the same way from the terminal emulator (Terminal application) in Solaris CDE.

Q. I know how to close and quit applications in the OpenWindows desktop. How do I do this for CDE?
A. You can make the following choices from the Window menu:

Minimize turns the window into its smallest size (usually an icon), Maximize enlarges the window to its largest possible size, (this is usually full-screen), Close closes the window and removes it from the workspace, and Exit ends or quits the current application.


Q. In the OpenWindows environment I used the words "Properties" and "Settings" interchangeably. What are the terms in CDE and what do they mean?
A. In the OpenWindows environment, application-wide settings are set via the Properties dialog box, accessed from the Edit menu. In CDE, application-wide settings are set via the Options areas. Options choices are generally located under the application’s File menu or the separate menu item, Options.

In CDE, Properties (if they exist in an application) are generally found under the application’s Edit menu and are used to set characteristics of an object, such as its date or name, or display identifying characteristics of an object, such as typefaces. In CDE, format settings are usually found under the Format menu and enable margin and paragraph alignment to be set for a single paragraph, file, or message.

The File Manager Properties menu item is on the Selected menu. Use the Properties dialog box to view information about a selected file or folder or to view or revise permissions and Access Control Lists for the file or folder.
Q. What are global options and how do I set them?

A. Global options are like the properties you set from the Workspace menu in the OpenWindows environment. Set these properties from the CDE Style Manager application.


Q. In the OpenWindows environment I used the Workspace menu to access my programs and utilities. Where do I find those in Solaris CDE?

A. In Solaris CDE, the Workspace menu still exists but you can also gain access through the Application Manager and the Personal Applications subpanel in the Front Panel.

Q. Can I customize the Front Panel with the applications I use most often?

A. You can use drag and drop to copy frequently used applications from Application Manager to your Personal Applications subpanel on the Front Panel. See the “Chapter 4, Using the Front Panel” in Solaris Common Desktop Environment: User’s Guide for more information.

Q. How do I change color and font attributes in CDE?

A. Use the Color dialog box in Style Manager to set colors. Use the Font dialog box in Style Manager to set the font size, type, and character group, and to add and delete font groups.


Q. How do I make changes to my keyboard in CDE?

A. If you did not change your keyboard defaults in the OpenWindows environment they should stay the same within CDE. If you want to change your defaults, use the Style Manager Keyboard dialog box. See “Chapter 7, Customizing the Desktop Environment” in Solaris Common Desktop Environment: User’s Guide. If you need to make changes to your UNIX® keyboard bindings, refer to “Chapter 10, Using Text Editor” in Solaris Common Desktop Environment: User’s Guide.
Q. How do I make changes to my mouse behavior in CDE?
A. Your mouse defaults should stay the same within CDE, but if you want to change your defaults, use the Style Manager Mouse dialog box. Some of the names have been changed for the functions: You still have double-click, acceleration, and threshold. Mouse button order is now called handedness. See the “Chapter 1, Basic Skills” in Solaris Common Desktop Environment: User’s Guide.

Q. My mouse button 2 is now set to TRANSFER instead of ADJUST. What is TRANSFER and can I change this if I need to?
A. TRANSFER allows you to drag text or an icon using mouse button 2 to one area and drop it on another area. TRANSFER is the default for all CDE platforms. See “Chapter 7, Customizing the Desktop Environment” in Solaris Common Desktop Environment: User’s Guide.

Q. I used the Delete key and the backspace key in the OpenWindows desktop to delete characters. How does this work in CDE?
A. Backspace deletes the previous character in the text. Delete removes the next (forward) character in the text.

Q. I modified my $HOME/.login or $HOME/.profile file to set login time environment settings in the OpenWindows environment. What file should I modify for the CDE login screen?
A. Modify your $HOME/.dtprofile file to set login time environment settings for the CDE login screen. You can instead modify your $HOME/.login file or $HOME/.profile file if you first set DTSOURCEPROFILE=true in your $HOME/.dtprofile file.

Q. How do I find the keyboard shortcuts for CDE?
A. Check the chapter on the specific application in question, and Appendix A in the Solaris Common Desktop Environment: User’s Guide. If you need to make changes to your UNIX keyboard bindings, refer to “Chapter 10, Using Text Editor” in Solaris Common Desktop Environment: User’s Guide.
Q. I used drag and drop a lot in the OpenWindows environment. How does it work in CDE?
A. The CDE drag-and-drop behavior is similar to the OpenWindows drag-and-drop behavior. Refer to “Using Drag and Drop in CDE” on page 7 earlier in this discussion.

Q. In the OpenWindows environment you could perform the default action for a menu item by a single mouse click on the menu button. Does this work differently in CDE?
A. You use two clicks instead of one. The first click displays the menu, then you choose an item and click again.

Q. How do I permanently delete the trash from my CDE desktop?
A. Choose Select All from the Trash Can File menu, then select Shred from the File menu.

Q. How do I select more than one item?
A. Whether you are selecting multiple elements that are adjacent (contiguous selection) or are located throughout a collection (discontiguous selection) use Control+mouse button 1 to select the elements. For example, use this keyboard-and-mouse combination when selecting multiple files shown in the File Manager window, or when selecting several messages from the Mailer Message Header List.

Q. How do I use my diskettes and CD-ROMs?
A. The CDE File Manager and Folders subpanel give you access to your diskettes and CD-ROMs.

Q. Is Snapshot the same in OpenWindows as in CDE?
A. Snapshot is integrated with Image Viewer in the CDE environment. Snapshot is a menu item on the Image Viewer File menu. You view Snapshot images using Image Viewer. Both Snapshot and Image Viewer are menu items on the CDE workspace menu.
Color Scheme Questions

The following questions relate to how you use or change colors on your desktop. See “Chapter 7, Customizing the Desktop Environment” in the Solaris Common Desktop Environment: User’s Guide for information on changing color on your desktop. If you find you need further information than is provided in the documentation, check these questions first.

Q. Some of my Motif applications’ color schemes look different on the CDE desktop.

Q. How does the color scheme work with OpenWindows applications?

Q. My desktop flashes in different colors when I move the cursor in and out of different windows.

A. (This answer addresses all three questions above that are related to color.) Certain applications may have colormap requirements that prevent them from using the default colormap. If this occurs, these applications will appear with incorrect colors while the rest of the desktop appears normal. Typically, giving such an application the keyboard focus causes it to appear in its correct colors but will cause the rest of the desktop to appear incorrectly. (This phenomenon is commonly referred to as colormap flashing.)

Sometimes an application appears with incorrect colors even if you give it the keyboard focus. This occurs if the application has specified a list of colormaps to be installed. Only the first colormap in this list will be installed, and anything that uses the other colormaps in the list appears with incorrect colors. For these applications, you must use special keys on the keyboard to cycle through the colormaps.

Unfortunately, there is no easy way to tell whether your application has specified a list of colormaps. The only symptom is that the window doesn’t appear with its correct colors. If this occurs, you can move the keyboard focus to that window (if it isn’t there already) and try these keys to see whether they affect the colormap:
Control-L2 (or Control-Again)
Steps forward through the colormaps

Control-L4 (or Control-Undo)
Steps backward through the colormaps

Doing so may end up installing the correct colormap, and it will not affect the other windows on the desktop in any way.

During startup, \texttt{dtsession} will set \texttt{*foreground}, \texttt{*background} and other OpenWindows global color resources so that OpenWindows applications will be in the same color scheme as Solaris CDE applications. You can still control the appearance of their applications by setting application-specific resources. Or, change the palette in Style Manager and restart the OpenWindows application.

\textbf{Note} - Be sure you know what you are changing on the desktop as certain color combinations may not give you the best results. For more information see \texttt{ColorUse}, \texttt{dynamicColor}, \texttt{foregroundColor}, \texttt{shadowPixmaps} resources, and the Color Server section in the \texttt{dtsession(1)} or \texttt{dtstyle(1)} man pages located in /usr/dt/man/man1.
Index

A
AnswerBook, accessing, 9
Application Manager, using, 9

B
Backspace key, function, 13
buttons, in CDE, 5

C
CDs, using, 14
closing windows, 11
color, changing, 12
controls, Front Panel, 2
customizing with Style Manager, 8

drag and drop, in CDE, 7

D
Delete key, function, 13
desktop login, 1
desktop services
  logout, lockscreen, refresh, help, 4
diskettes, using, 14
drag and drop, in CDE, 7

F
File Manager, drag and drop, 7
font size, changing, 12
frequently asked questions, 10, 16
Front Panel applications, 2
Front Panel, customization, 12

G
global options, 12

I
Image Viewer, 14

K
keyboard shortcuts, 13
keyboard, changing, 12

L
logging in, 1
login screen, 2

M
Mailer, drag and drop, 7
maximize, 11
menus, in CDE, 5
minimize, 11
mouse behavior, changing, 13
mouse button, Adjust, 13
mouse button, Transfer, 13
mouse, in CDE, 5
multiple selection, 14

O
Online help, accessing, 9
OpenWindows applications, location, 11
options, 11

Index-17
P
properties, 11

Q
quitting windows, 11

S
selecting items, 14
settings, 11
Snapshot, 14

Style Manager, 8

T
Text Editor, drag and drop, 8
trash, deleting in CDE, 14

W
windows, in CDE, 5
Workspace menu, location, 12
Workspace Programs submenu, accessing, 3