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Preface

This manual describes how to install and use ShowMe™ TV™ system with your

Sun Workstation™. It is intended for users who want to broadcast and view

prerecorded and live video programs over a network.

How This Book Is Organized

Chapter 1 describes the ShowMe TV product.

Chapter 2 shows you how to receive and record audio and video broadcasts from

ShowMe TV Transmitters on your network.

Chapter 3 describes how to set up, start, and manage broadcasts to the ShowMe TV

Receivers on your network.

Chapter 4 describes how to use the ShowMe TV Address Book.

Chapter 5 contains audio, video, and file format information.

Chapter 6 contains technical information.
xi



Using UNIX Commands

This document may not contain information on basic UNIX® commands and

procedures such as shutting down the system, booting the system, and configuring

devices.

See one or more of the following for this information:

■ Solaris 2.x Handbook for SMCC Peripherals

■ AnswerBook™ on-line documentation for the Solaris™ 2.x software environment

■ Other software documentation that you received with your system

Typographic Conventions

TABLE P-1 Typographic Conventions

Typeface or
Symbol Meaning Examples

AaBbCc123 The names of commands, files,

and directories; on-screen

computer output.

Edit your .login file.

Use ls -a to list all files.

% You have mail .

AaBbCc123 What you type, when

contrasted with on-screen

computer output.

% su
Password:

AaBbCc123 Book titles, new words or

terms, words to be emphasized.

Command-line variable;

replace with a real name or

value.

Read Chapter 6 in the User’s Guide.

These are called class options.

You must be root to do this.

To delete a file, type rm filename.
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Shell Prompts

Related Documentation

The following documents contain topics that relate to the information in this

manual.

Sun Documentation on the Web
The docs.sun.com sm web site enables you to access Sun technical documentation

on the Web. You can browse the docs.sun.com archive or search for a specific book

title or subject at:

http://docs.sun.com

TABLE P-2 Shell Prompts

Shell Prompt

C shell machine_name%

C shell superuser machine_name#

Bourne shell and Korn shell $

Bourne shell and Korn shell

superuser

#

Application Title Part Number

SunVideo™ Plus for PCI SunVideo Plus for PCI User’s Guide 805-2682

SunVideo SunVideo User’s Guide 802-1318
xiii



Sun Welcomes Your Comments

We are interested in improving our documentation and welcome your comments

and suggestions. You can email your comments to us at:

docfeedback@sun.com

Please include the part number of your document in the subject line of your email.

Sending Your Comments on ShowMe TV

If you have comments about ShowMe TV, or if you would like more information,

you can use the Comment window to send email to Sun Microsystems.

1. Choose Help ➤ Comment from any Help menu on a ShowMe TV window or on
the main ShowMe TV Transmitter window.

2. Type your comments into the comment area of the window.

3. Make sure the System information box is selected.

When the System information box is checked, information about your system and

operating environment is displayed. If the box is not checked, the statement No
system information will be sent is displayed. Unless you have a specific

reason not to, please include the system information.

4. Click Send.
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CHAPTER 1

Introduction to ShowMe TV

ShowMe TV is a television system for local- and wide-area networks. You can use it

to view and broadcast live or prerecorded video programs on your network. You can

use it broadcast and view training courses, lectures, corporate messages, and to

monitor important news events.

ShowMe TV consists of ShowMe TV Receiver, ShowMe TV Transmitter, and

ShowMe TV Address Book.

ShowMe TV Receiver

ShowMe TV Receiver is essentially a TV on your workstation. But it also lets you

record broadcasts to a file and set up a viewing schedule to automatically watch or

record upcoming programs.

The ShowMe TV Receiver features include:

■ A Watch menu for choosing listed programs

■ A Program Information window

■ The ability to view multiple ShowMe TV Receivers at once

■ Audio controls

■ Playback and editing controls

■ Controls for viewing from SunVideo (Plus)

■ Zoom controls

■ Quick Record

■ Timers for automatically recording or watching upcoming programs

■ Color controls

■ A message area
1



ShowMe TV Transmitter

The ShowMe TV Transmitter sends video and its accompanying audio from your

workstation to the network connected to your workstation. You can broadcast video

from any source that you can plug into your SunVideo card—a video camera, a VCR,

a laser disk player, a tuner, a satellite feed. You can also broadcast audio-only

sources such as a CD player or your SunMicrophone™, even if you do not have a

SunVideo card. Further, you can broadcast prerecorded video and audio from a file

on disk or CD.

Your broadcasts go to network users that you select, or, if you choose, to all users on

your local area network or networks connected to it. You define your transmitter

broadcast range when you set up a broadcast.

ShowMe TV Address Book

The ShowMe TV Address Book contains the network addresses of people and

groups you usually work with or broadcast to. It enables you to send closed

broadcasts (broadcasts that go to only a specified list of people).

Online Help

You can read information about ShowMe TV online. You can access help from the

Help menu on each of the ShowMe TV main windows or from Help buttons located

on most dialog windows.
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Installation Information

Refer to your ShowMe TV product release information for software installation

instructions.

Installation Requirements

To install ShowMe TV, you must have the following hardware and software

configuration:

■ A SPARC™ system running Solaris 2.5 or higher operating environment

■ Approximately 20 to 25 Mbytes of available disk space

■ OpenWindows™ or CDE window environment

Installation Directories

By default, ShowMe TV is installed in the /opt/SUNWsmtv directory.

Note – While you may choose any directory with enough free disk space, you must

install all ShowMe applications under the same directory.

TABLE 1-1 ShowMe TV Directories

Directory Description

bin Contains links to the scripts and binaries which are meant to

be executed by the user.

help Contains binaries and some files for the online help.

utilities Contains the Address Book and Registry_svc (a program

named by ShowMe TV).

ShowMeTV Contains the scripts, binaries, and other files for the Receiver

and the Transmitter.

lib Contains libraries used by ShowMe TV, as well as message

files.

app-defaults Contains application defaults for the online help system.
Chapter 1 Introduction to ShowMe TV 3



XIL Runtime Libraries

Make sure you have the appropriate XIL Runtime libraries installed on your system.

XIL1.2 supports the Solaris 2.5 and 2.5.1 operating environment; XIL1.3 supports the

Solaris 2.6 operating environment; and XIL1.4 supports the Solaris 7 operating

environment. Contact your system administrator for more information.

Note – If you are using SunVideo™ or SunVideo Plus, make sure the software is

properly installed. Refer to SunVideo (Plus) documentation or your system

administrator.

SunVideo

To broadcast from video devices, you need to install a SunVideo or SunVideo Plus

for PCI card on any machine that is running ShowMe TV Transmitter. You also need

to connect the video sources from which the SunVideo (Plus) card will be

broadcasting. To install the SunVideo card, refer to the user’s guide delivered with

your SunVideo or SunVideo Plus card for complete hardware installation

procedures.

Note – With ShowMe TV, you do not need a SunVideo card to view broadcasts or

play files; you can still broadcast from audio-only devices or from a video file. But if

you have a SunVideo card installed, you can use ShowMe TV to view and record

directly off of the SunVideo card; you can broadcast from sources which are

connected to your SunVideo (Plus) card.

Audio Device Setup

If your system uses anything other than /dev/audio for audio input/output, set

the environment variable AUDIODEV to point to the alternative audio device. For

example, if the device installed on your system is /dev/myaudio (with the

corresponding /dev/myaudioctl ), set AUDIODEV to /dev/myaudio .

Most users will never need to set AUDIODEV themselves.
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CHAPTER 2

Using ShowMe TV Receiver

ShowMe TV Receiver enables you to receive and record audio and video broadcasts

from ShowMe TV Transmitters on your network. These broadcasts could be a live

talk from the broadcaster’s desktop, a rebroadcast of a TV channel coming in

through an antenna or cable, a videotape in the broadcaster’s VCR, a satellite feed,

or a broadcast of a ShowMe TV file.

This chapter is organized as follows:

■ ShowMe TV Receiver Basics

■ Watching a Program

■ Recording a Program

■ Setting the Timer to Watch or Record a Program

■ Using ShowMe TV Files

■ Troubleshooting

ShowMe TV Receiver Basics

This section contains the following topics:

■ To Start ShowMe TV Receiver

■ ShowMe TV Terminology

■ ShowMe TV Receiver Menus

■ To Change ShowMe TV Default Properties

■ To Exit ShowMe TV Receiver
5



▼ To Start ShowMe TV Receiver

Type the following at your system prompt:

The ShowMe TV Receiver is displayed.

To view optional command-line arguments and descriptions, type:

Note – If you have difficulty running ShowMe TV, contact your system

administrator and find out where it is installed. The default location is

/opt/SUNWsmtv/bin/showmetv

ShowMe TV Terminology

% showmetv

% showmetv -help

TABLE 2-1 ShowMe TV Terminology

Term Description

Program An audio and/or visual show sent by another computer

user (broadcaster) across your network. Audio and video

data for a program can come from the following sources:

video camera, VCR, TV or radio tuner, cable TV

broadcast, pre-recorded movie, or an audio-only file.

Broadcast An audio and/or video program sent from a ShowMe

Transmitter to a TV receiver.

Broadcaster The person sending a broadcast program across the

computer network.

ShowMe TV Transmitter The part of ShowMe TV that enables the broadcaster to

send programs across the network. ShowMe TV

Transmitter is much like a television station.

ShowMe TV Receiver The ShowMe TV window you use to watch a broadcast.

You can have several open at once.
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ShowMe TV Receiver Menus

The ShowMe TV Receiver has four menus on the menu bar: TV, Watch, PiP, and

Help.

Note – On menu selections containing optional keystroke shortcuts, use ♦+ keystroke
if you are in the CDE environment; use Alt+ keystroke if in OpenWindows.

TV Menu

Picture-in-Picture A small window within a ShowMe TV window that you

use to watch a program other than the one in the main

display area.

Timer A feature of the Program Information window that

automatically records or displays a program at a time

you specify.

Snap This snaps a still picture of the running broadcast. Also

called snapshot.

SunVideo This enables you to view directly from the SunVideo

board. Whatever video is being fed to the SunVideo

board appears in the TV window.

TABLE 2-2 TV Menu Item Descriptions

Menu Item Description

Properties Use to set audio, color, and other default settings.

Load movie Use to load a ShowMe TV file for watching and editing. See

Using ShowMe TV Files.

Save movie as Use to rename and copy the ShowMe TV file you are currenty

editing.

Picture statistics Use to view audio and video formats and the data rate of the

program running in ShowMe TV.

TABLE 2-1 ShowMe TV Terminology (Continued)

Term Description
Chapter 2 Using ShowMe TV Receiver 7



Watch Menu

This menu lists the current and scheduled broadcasts available to you, as well as the

names of ShowMe TV files that you have recently opened. The Watch menu items

are divided into the following categories:

■ Programs

■ Movie files

■ SunVideo

New programs added by a transmitter are automatically listed in the Watch menu.

Program info Use to see a schedule of current and upcoming programs, set

timers to record or display programs, and get detailed

information about any program.

Start new TV Starts another ShowMe TV window that you can use to watch

additional programs or files. See To Watch Several Programs

or Files Simultaneously.

Exit this TV Closes the ShowMe TV window you are working in.

Exit all TVs When you have more than one ShowMe TV running, this

closes all the ShowMe TV windows on your desktop.

TABLE 2-3 Watch Menu Item Descriptions

Menu Item Description

Programs Select any program in this list to watch. Programs listed are either

broadcasting or have been scheduled by a ShowMe Transmitter.

Files Select any file to watch. The ten files you have most recently

opened during current ShowMe TV session are listed. See Using

ShowMe TV Files.

SunVideo Views video selections running on your system SunVideo (Plus)

card. See To Use SunVideo.

Tune out Stops broadcasting to your TV. You can also stop a broadcast by

clicking the program name in the menu.

TABLE 2-2 TV Menu Item Descriptions (Continued)

Menu Item Description
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PiP Menu

The PiP menu is available only after you activate the PiP feature by clicking the PiP

button in the lower right corner of the ShowMe TV window.

Like the Watch menu, the PiP menu lists the currently running or scheduled

broadcasts. Unlike the Watch menu, it does not list previously opened files. See To

Use Picture-in-Picture (PiP).

Help Menu

Information on Help menu items is available through the Online Help system. To

access Help information,

● Choose Help ➤ Online Help from the window menu bar.

Program Title, Channel Selection, and Messages

The area under the ShowMe TV Receiver menu bar identifies the program or file you

are currently watching and gives other status information. Messages from ShowMe

TV broadcasters are placed in the line underneath the channel select arrows and

program name.
Chapter 2 Using ShowMe TV Receiver 9



▼ To Change ShowMe TV Default Properties

1. Choose TV ➤ Properties.

2. Set the properties you want.

3. Click OK to save the properties, or click Cancel to revert to the last saved
properties.

TABLE 2-4 ShowMe TV Properties Window Descriptions

Window Item Description

Audio output Select audio from your systems speaker, headphone, or from a

line-out source.

MPEG audio quality Active only when playing back MPEG1 or MPEG2 files.

Brightness Use to increase or decrease the brightness of the video image.

Viewing image Use to select either color or grayscale. Viewing images in

grayscale helps reduce the chance of colors flashing on your

screen.

Number of colors On 8-bit graphic cards, many applications could exhibit color

flashing. Use this parameter to prevent or to stop color flash.

This feature enables you to change the number of colors (or

grays) that ShowMe TV uses to display video images on your

screen. The more colors used, the greater the likelihood of color

flash occurring. You can select from one of the following:

Low = 54 colors or 32 shades of gray

Medium = 112 colors or 64 shades of gray

High = 200 colors, or 128 shades of gray

Your name and email

address

Type the name you want the broadcaster to see (such as a

nickname). Your name, email address, user name, and host

name are sent to broadcasters so that they can contact you when

you are watching their program. For best results, type your full

email address.

Note that since your user name and host name are always sent

to broadcasters, you cannot watch a program anonymously,

even if you leave the name and email fields blank.

Date format Select the date format you prefer:

mm/dd/yyyy, where February 11, 1999 would be 02/11/1999.

dd/mm/yyyy, where 11 February 1999 would be 11/02/1999.

ShowMe TV and ShowMe TV Transmitter use dates for setting

record timers, watch timers, and for displaying program

information.
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▼ To Exit ShowMe TV Receiver

● Choose TV ➤ Exit this TV to exit only the ShowMe TV window you are currently
watching.
or

● Choose TV ➤ Exit all TVs to exit all of the ShowMe TV windows running on your
desktop.

Note – If you have unexpired watch or record timers when you exit, ShowMe TV

prompts you and gives you the choice of running ShowMe TV in the background

until the timer expires (its stop time is reached).

ShowMe TV does not remember the timers you have set and will not reinstate them

the next time you run ShowMe TV.

Note – Watch timers and record timers will not activate when ShowMe TV is not

running (if you select Exit all TVs). A ShowMe TV window must be running (either

as an open window, an icon, or in the background) in order for the timers to work.

Watching a Program

This section contains the following topics:

■ To Watch a Program

■ To Use SunVideo

■ To Obtain Information About a Program

■ To Watch Several Programs or Files Simultaneously

■ To Send Mail to the Broadcaster

■ To Use Picture-in-Picture (PiP)

■ To Take a Snapshot

▼ To Watch a Program

● Select a program from the Watch menu.
Chapter 2 Using ShowMe TV Receiver 11



Note – To leave the ShowMe TV window open without a program playing, click the

name of the program in the programs list, or choose Watch ➤ Tune out.

Note – When you minimize the ShowMe TV window, the audio continues playing

unless it is muted. If you mute the audio by deselecting the speaker button, the

audio remains muted when you minimize the window.

If you select a program in the Watch menu that is not yet broadcasting, you will be

tuned in when that program begins. You can also set ShowMe TV to automatically

tune in to a scheduled program by setting a Watch timer. See Setting the Timer to

Watch or Record a Program.

▼ To Use SunVideo

1. Choose Watch ➤ SunVideo.

The ShowMe TV window displays a SunVideo (Plus) source program. The SunVideo

control and slider panel is also displayed.

2. Click Settings.

Use the Device Settings panel to change video card ports, compression type, audio

input and quality, and so on.
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Listening to Audio-Only Programs

It is possible to have audio-only broadcasts in ShowMe TV. When you choose an

audio-only program from the Watch menu, the ShowMe TV window is reduced to

save space on your screen. The video controls are inactive (dim) to show they cannot

be selected for this broadcast.

Note – When you minimize the ShowMe TV window, the audio continues playing

unless it is muted. If you mute the audio by deselecting the speaker button, the

audio remains muted when you minimize the window.

TABLE 2-5 SunVideo Device Settings

Parameter Description

Video input Select Ports 1 or 2 for radio tuners and VCRs, camcorders, video

disc players, a satellite feed, or video camera. The RCA-type ports

are labeled as Port 1 and Port 2 in the SunVideo Settings Window.

There is no difference between Port 1 and Port 2; both ports accept

composite video signals. Use S-Video for video units that transmit

S-Video signals for a sharper image.

Compression Select either CellB, H.261, or JPEG. CellB gives reasonable quality

with relatively low demand on your CPU. JPEG gives higher

quality but requires more processing power to decode. JPEG

supports only medium picture resolution, whereas CellB supports

all three (low, medium, high) resolutions.

As in JPEG and CellB cases, H.261 rate of compression also

depends on the characteristics of the image sequence. In general,

H.261 codec achieves better compression rates on video sequences

with little movement on the image scene. You can change H.261

compression rate by setting the desired Encoding Bit Rate.

Compression quality

(JPEG only)

Fine tune the picture quality for JPEG.

Picture resolution

(CellB and H.261 only)

Choose the number of pixels in the frame delivered to the system

by the SunVideo card.

Audio input Select either microphone or line-in depending on the audio input

source you are using.

Audio quality Select the quality of audio. Note that the higher qualities generate

significantly more data. This is something for you to consider if

you plan on recording the video and audio to disk.

Audio input level Adjust the volume of the audio.
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▼ To Obtain Information About a Program

1. Click TV ➤ Program info.

2. Select the program you want to learn about from the list.

3. Click Start new TV to create a new ShowMe TV window tuned to the program
you selected.

TABLE 2-6 Program Information Window Descriptions

Item Description

Program list The date, time, and name of available programs, and

whether you have a timer set to record or watch the

program (indicated by the letters R or W to the left of the

program entry).

Record and watch timers See Setting the Timer to Watch or Record a Program.

Unset timer button Unsets the timer for the currently selected program.

Program window sizing Adjust the relative sizes of the Program description and

Program list window panes by moving the Window pane

size control up or down.

Description The broadcaster’s description of the program currently

selected in the Programs list.

Broadcaster’s address The broadcaster’s network email address. See To Send Mail

to the Broadcaster for a description of using the Send mail

button.

Send mail To send email to the person who is or will be broadcasting a

particular program.

Audio address Address of audio broadcast.

Video address Address of video broadcast.

Program dates and times Start and end date and time of the program.

Audience The number of users (including you) watching the program.

Audio and video format See Chapter 5.

Motion speed The number of times per second that the image is updated

by ShowMe TV Transmitter.
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▼ To Send Mail to the Broadcaster

1. Select a program from the Program Information window.

2. Click Send mail.

3. Click in the Message area and type your message.

4. Click Deliver.

You can also use the Send mail to broadcaster command in the Help menu.

▼ To Watch Several Programs or Files

Simultaneously

1. Choose TV ➤ Start new TV, or click Start new TV on the Program Information
window.

2. In the new window, select the program you want to watch from the Watch menu,
or select Load movie.

Note – All receiver windows share the single speaker or headphone. Once you have

several receiver windows open, you can select which program you want to hear. Do

this by muting the window which “has” the audio device, and then clicking the

speaker button on the window with the program you want to hear.

Picture resolution The size of the image being broadcast by ShowMe

Transmitter.

Network demand The number of kilobits per second required by ShowMe TV

Transmitter for the program broadcast.

Start new TV Starts another ShowMe TV Receiver tuned to the program

that is currently selected in the Program list.

TABLE 2-6 Program Information Window Descriptions (Continued)

Item Description
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▼ To Use Picture-in-Picture (PiP)

1. Click PiP at the bottom of the TV receiver window.

2. Click the now activated PiP menu and select a program.

You can move the PiP window around within the display area by holding the left

mouse button down over the PiP window and dragging.

3. Click Swap to switch the program in the main window with the program in the
PiP window.

Note – When you Snap a TV window with PiP running, the PiP window is ignored

and does not appear in the snapshot. The Snap feature only takes a snapshot of the

program in the main TV window.

Note – If you are watching a file in the main window, the Swap button is disabled;

you cannot watch a file in the PiP window.

▼ To Take a Snapshot

1. Click Snap on the TV main window.

2. Save or print the picture.

■ To save the picture as a Sun rasterfile:

a. Click Save as.

The Save window is displayed.

b. Type a file name for the picture and click Save.

■ To send the picture to a printer or PostScript file:

a. Click Print.

The Print window is displayed.

■ To print to a printer:

i. Type the printer name.

ii. Select the Orientation of the page: portrait or landscape.

iii. Click the Print button to print the image using the currently displayed
settings.

■ To print to a PostScript file:
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i. Select Postscript File.

ii. Specify a file name in the File Name field.

This sends the output to a file on disk rather than to a printer.

3. Click Close to exit the Snap window.

Recording a Program

ShowMe TV can record only one file at a time, regardless of the number of ShowMe

TV windows open. Recording always overwrites the complete contents of the file if

you select an existing file as the destination of the recording. While recording,

ShowMe TV displays the elapsed time in seconds.

This section contains the following topics:

■ To Quick Record a Program

■ To Select a Recording Format

■ To Record Audio Only

You can also record using Record timers. See Setting the Timer to Watch or Record a

Program.

Note – You can record only one program at a time. There is only one ShowMe TV

recorder regardless of how many ShowMe TV Receiver windows you have open. If

you change programs while recording, recording stops when the new program is

displayed in the ShowMe TV Receiver.

Note – If your system administrator has disabled the Recording feature of

ShowMe TV, you will not be able to use Record timers or Quick Record. However, if

ShowMe TV files are available on your network, you will still be able to watch them.

See Using ShowMe TV Files.

Your system administrator may have limited the size of files you can record.
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▼ To Quick Record a Program

You can begin recording a ShowMe TV program at any time using Quick Record.

1. Click REC on the ShowMe TV Receiver.

2. Type the requested information and selections.

Note – See Storing ShowMe TV Files for file size limitations.

▼ To Select a Recording Format

1. Click Record on the ShowMe TV window.

2. Click Format.

3. Select a file format for recording.

See Chapter 5 for file format information.

▼ To Record Audio Only

Not all ShowMe TV programs contain a video portion. When you record audio-only

programs, the Record selector of the Record window is automatically set to Audio

Only.

● Choose an audio-only format prior to recording the broadcast.
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Setting the Timer to Watch or Record a
Program

▼ To Set the Watch Timer

1. Choose TV ➤ Program info.

2. Select the program you want to watch.

3. Click Watch.

4. Type a time for ShowMe TV to tune into the program.

By default, the timer is set to display the program at its scheduled start time. If the

program is continuous, the default watch time is five minutes from the current time.

5. Click OK to activate the timer.

On the Program Information window, the program you selected is now marked with

the letter W to indicate that the program is scheduled to be watched.

Note – You do not need to set a Watch timer for the program currently selected in

the Watch menu of a ShowMe TV window. ShowMe TV will automatically begin

displaying that program in the receiver when it starts.

▼ To Set the Record Timer

1. Choose TV ➤ Program info.

2. Select the program you want to record.

3. Click Record.

4. Click Files to select a file.

5. Enter a maximum file size for the recording.

See Storing ShowMe TV Files for file size information.

6. Enter a time for ShowMe TV to record the program.

7. Enter a time for ShowMe TV to stop recording the program.
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8. Click OK to set the timer.

The program you selected is now marked with the letter R in the Program

Information window to indicate that it is scheduled to be recorded.

A ShowMe TV Receiver opens when the ShowMe TV begins recording the program.

Note – If you enter start or end times that conflict with another record timer,

ShowMe TV prompts you to change the start or end time of one of the conflicting

record timers.

Using ShowMe TV Files

This section contains the following topics:

■ Storing ShowMe TV Files

■ Sharing ShowMe TV Files

■ To Watch a ShowMe TV File

■ To Edit a ShowMe TV File

You can use ShowMe TV to watch, save, and edit files recorded by ShowMe TV, or

any other program capable of producing QuickTime or AVI movies. If no

ShowMe TV files are available to you, you can create one by recording a program

(see Recording a Program).

ShowMe TV movie files can be identified by extensions: .mov , or .avi . For example,

videoclip.mov and movie.avi. For audio files, extensions are audio.au and

audio.wav .
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Storing ShowMe TV Files

ShowMe TV files can be quite large. Therefore, you need to consider the amount of

disk space a recording will require. To estimate the required file size of a program

you plan to record, compare the program information from the Program Information

window with the following information:

Sharing ShowMe TV Files

Since ShowMe TV files are typically large, you should not send them over email. To

share a ShowMe TV file with others, consider these options:

■ You can substantially reduce the size of a file by deleting segments of the file; see

To Edit a ShowMe TV File.

■ You can record to a local disk to reduce network traffic.

■ You can set ShowMe TV to automatically stop recording a program when the file

reaches a certain size. This size has a default, which you can set, or can be

selected at the time you record a program or set a record timer. To learn about

setting the size for a particular recording, see the next sections Recording a

Program and Setting the Timer to Watch or Record a Program.

TABLE 2-7 Average ShowMe TV File Size (in megabytes per minute)

Average Motion Speed
(in frames per second)

Resolution of the Broadcast Image

Low Medium High

1–5 0.5 2.0 8.0

6–10 1.0 4.0 16.0

11–15 1.5 6.0 24.0

16–20 2.0 8.0 32.0

21–25 2.5 10.0 40.0

26–30 3.0 12.0 48.0
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▼ To Watch a ShowMe TV File

1. Choose TV ➤ Load movie.

2. Select the program you want to watch and click OK.

Note – Once you have opened a file, the file name will also appear in the Watch

menu. You can switch between the ten most recent files you have opened by

selecting them from the Watch menu.

3. Click Play to play the file from the beginning.

4. Use the slider to jump to a particular part of the file when you are playing or have
paused.

a. To step forward or backward through the file one second at a time, click on the
slider region on either side of the slide elevator.

You can do this while the file is playing.

b. Click either button at the end of the slider to jump to the beginning or end of
the file.

5. Click Pause to stop or pause the file.

6. Select either the file you are viewing, another file, or a program from the Watch
menu to close the file.

▼ To Edit a ShowMe TV File

You can delete segments of a file you open in ShowMe TV. You can do this to

shorten the file length and decrease the amount of disk space it requires.

1. Choose TV ➤ Load movie.

2. Select the file you want to edit and click OK.

3. Click Edit.

The editing controls are displayed at the bottom of the window.
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Troubleshooting

TABLE 2-8 ShowMe TV Receiver Troubleshooting

Problem Possible Cause/Solution

Color flash On an 8-bit color machine, ShowMe TV shares a color palette with the other

applications on the desktop. There are 256 color entries available on an 8-bit

machine, and all of the applications running on the desktop compete for these

entries. When all of the colors have been used up—the workstation color

palette is full—the desktop applications create their own color palettes. Once

they do this, you see color flash. When you move your pointer into a window

with its own color palette, all the other colors on the desktop change. When you

move your pointer out of that window, its colors also change.

The ShowMe TV applications have been designed to reduce the possibility of

color flash occurring on your system. All of the icons and buttons presented in

ShowMe TV windows use a palette of 16 colors. The Motif window manager

also allocates nine colors to display the default ShowMe TV window colors

(this includes highlight colors for widgets), resulting in a total of 25 colors used.

However, ShowMe TV also allocates colors for the video display area. The

number of colors allocated is governed by the “Number of colors used” field of

the Properties window. The settings are as follows: Low (54 colors), Medium

(112 colors), and High (200 colors). If you are experiencing color flashing when

moving the pointer in and out of ShowMe TV windows, try using a lower

setting.

Movie file is not played

back by ShowMe TV or

played incorrectly

Movie format might be unsupported by ShowMe TV. For a list of supported

formats. see Chapter 5.

Timer failed to record or

watch the broadcast

ShowMe TV was not running when the timers were to expire. In order for a

timer to work properly, at least one ShowMe TV window must be running

either as a full window or an icon, or you must have requested ShowMe TV to

run in the background when you exited. See Troubleshooting for more

information about running ShowMe TV in the background.

The ShowMe Transmitter terminated prior to the timer’s expiration.
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Audio and video not

synchronized

Sometimes the audio and video of a broadcast get out of synchronization. A

person’s voice will not match their mouth motions in the video. ShowMe TV

tries to monitor and correct this as the program runs, but sometimes it is not

successful. If this is the case, do the following:

- Temporarily switch to another program, then switch back to the program you

were watching.

- Toggle the mute button.

- Check the value of the synchronization threshold in the .showme-defaults
file in your home directory. The synchronization threshold should be about

250000 milliseconds.

No picture Check the brightness slider on the Properties window and ensure that it is not

too low.

If network traffic is very high, you will see images but the frame rate may be

very slow.

TV is wrong color when

using mwm
Make sure that mwmis installing the proper colormap. Your mwmcolormap focus

policy should be set in your .Xdefaults file:

Mwm*colormapFocusPolicy: pointer

Error messages

File filename is not in any of

the readable formats

The file is corrupted or recorded in a format not supported by ShowMe TV.

For the list of supported file formats see Chapter 5.

No audio device is found,

or another process might be

using the audio device right

now.

Check if the audio device name is different from the default /dev/audio . If so,

set the environment variable AUDIODEV to the full pathname of your audio

device. For example, if the device installed on your system is

/dev/myaudio (with the corresponding /dev/myaudioctl ), set AUDIODEV

to /dev/myaudio .

TABLE 2-8 ShowMe TV Receiver Troubleshooting (Continued)

Problem Possible Cause/Solution
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CHAPTER 3

Using ShowMe TV Transmitter

ShowMe TV Transmitter is like a television station. It broadcasts video programs to

the network. From the ShowMe TV Transmitter, broadcasts (also called programs) are

sent to workstations on your network running ShowMe TV. These broadcasts can be

a commercial television channel coming in through a cable or antenna, a live talk to

or from your desktop, a video tape in a VCR, a satellite feed, or a broadcast of a

ShowMe TV movie file. ShowMe TV Transmitter also sends out advertisements of

your broadcasts so that viewers know what programs will be available for watching

and recording.

This chapter is organized as follows:

■ ShowMe TV Transmitter Basics

■ Creating a New Broadcast

■ Broadcasting

■ Broadcasting a ShowMe TV File

■ ShowMe TV Transmitter Daemon

■ Troubleshooting
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ShowMe TV Transmitter Basics

This section contains the following topics:

■ To Start ShowMe TV Transmitter

■ ShowMe TV Transmitter Terminology

■ Broadcast Status Area

■ Program List

■ Controlling the Current Broadcast

■ To Set ShowMe TV Transmitter Properties

In order to use the ShowMe TV Transmitter to broadcast anything other than a

ShowMe TV movie file, you must have a SunVideo (Plus) card and a source for

video and audio installed at your workstation.

▼ To Start ShowMe TV Transmitter

1. Type the following at your system prompt:

Note – If ShowMe TV Receiver is not already running on your workstation, you

need to start it now to watch the broadcast that you are creating (see To Start

ShowMe TV Receiver). Also, you can use the Preview window (see To Preview a

Broadcast), or start a ShowMe TV receiver from the Transmitter menu.

To view optional command-line arguments and descriptions, type:

If you have difficulty running the ShowMe TV Transmitter, contact your system

administrator and find out where it is installed. The default installation location is

/opt/SUNWsmtv/bin/showmetvt .

hostname% showmetvt

% showmetvt -help
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ShowMe TV Transmitter Terminology

TABLE 3-1 ShowMe TV Transmitter Basic Terminology

Term Description

Program An audio/visual broadcast sent by another computer user

(Broadcaster) across your network. This could be a live

presentation, videotape, television via cable, satellite, or

antenna, or audio only.

Broadcast Audio and video program sent from a ShowMe TV

Transmitter to a receiver.

Transmitter ShowMe TV Transmitter (this application), the application

the broadcaster uses to send programs across the network.

VCR A video cassette recorder attached to the transmitting

workstation SunVideo card.

On the Air The ShowMe TV Transmitter is currently broadcasting a

program to the network.

Off the Air The ShowMe TV Transmitter is not currently broadcasting a

program to the network.

Audience The users on the network who are watching a ShowMe TV

broadcast or waiting for one to start.

Motion speed The rate at which ShowMe TV Transmitter sends full

screens of video to the network. Each full screen is called a

frame, and the rate is quoted in units of frames per second.

Picture resolution The number of pixels used to display the video.

Statistics Information gathered from the ShowMe TV Transmitter and

the ShowMe TVs tuned in to a broadcast. This information

is the number and names of users watching a broadcast, the

motion speed and picture resolution, and the rate at which

the broadcast is travelling through the network.

Preview Viewing a scheduled program before or while it is broadcast

to the network by the ShowMe TV Transmitter.
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ShowMe TV Transmitter Menus

ShowMe TV Transmitter menu bar has two menus: Transmitter and Help.

Note – On menu selections containing optional keystroke shortcuts, use ♦+ keystroke
if you are in the CDE environment; use Alt+ keystroke if in OpenWindows.

Transmitter Menu

Help Menu

Information on Help menu items is available through the Online Help system. To

access Help information,

● Choose Help ➤ Online Help from the window menu bar.

Broadcast Status Area

At the top of the ShowMe TV Transmitter window, under the menu bar, is the

broadcast status area. This area is updated continuously to give you the current

status of the ShowMe TV Transmitter. It tells you whether you are now broadcasting

and, if you are, the time remaining for the current program. If you are not

broadcasting, it gives the time to the next scheduled broadcast.

TABLE 3-2 Transmitter Menu

Menu item Description

Properties Opens the Properties window. See To Set ShowMe TV Transmitter

Properties.

Preview broadcast Opens a special ShowMe TV Preview window that enables you to

view a broadcast before or while it is transmitted.

Start ShowMe TV Starts ShowMe TV if it is not already running on your workstation.

Statistics Opens the Statistics window, which lists the users watching the

current broadcast and gives other useful information.

Address book Opens your address book.

Exit Quits ShowMe TV Transmitter.
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Program List

The ShowMe TV Transmitter program list shows the current and upcoming

broadcasts for this transmitter. It gives their start date and time and the program

title. As you schedule new broadcasts they are automatically added to the list. When

a broadcast ends or you remove it, it is removed from the list.

Use the broadcast setup buttons under the program list to add, change, or remove

programs from the broadcast schedule and the program list. Click the New

broadcast and Change broadcast buttons to set up or modify program settings.

These are described in Creating a New Broadcast and To Configure Broadcast

Information.

Controlling the Current Broadcast

The ShowMe TV Transmitter Off the air and On the air buttons enable you to stop a

broadcast while it is running, or starts it before its scheduled time. See To Go Off the

Air for a description of this button; see To Go On the Air for a description of this

button.

The Message box and Send button enables you to compose and send a short message

to all users watching the current program or, if you are not currently broadcasting,

to users waiting for the next one. See To Send a Message to the Entire Audience.

▼ To Set ShowMe TV Transmitter Properties

Before starting or scheduling a broadcast, use the ShowMe TV Transmitter

Properties window to set some of the long term information used and broadcast by

the Transmitter.

1. Click Transmitter ➤ Properties.

2. Type the appropriate information.

TABLE 3-3 ShowMe TV Transmitter Properties

Item Description

Broadcasts are by Type your full name.

Your name is associated with your broadcasts and appears in

ShowMe TV in the Program Information window. If you do not

provide a name, ShowMe TV Transmitter sends your username and

hostname.
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Email contact Type your email address.

Your email address is included in your broadcasts so that receivers

can send you email during the broadcast by using the Send Mail to

Broadcaster feature of ShowMe TV.

Broadcasts should Use this setting to tell ShowMe TV Transmitter whether you want

broadcasts to begin without confirmation.

Select “Prompt before beginning” to have ShowMe TV Transmitter

prompt before starting a broadcast.

Select “Begin automatically” to have ShowMe TV Transmitter use

the start time that you specified on the Configure Broadcast

Information window and to automatically begin the broadcast.

Show dates as ShowMe TV Transmitter uses the date format that you specify

either here in the Properties window or in ShowMe TV. If you

would like to use a different date format than the one currently

selected, select the date format you prefer. You can select between

two formats:

mm/dd/yyyy, where February 11, 1999 would be 02/11/1999.

dd/mm/yyyy, where 11 February 1999 would be 11/02/1999.

Ok Click Ok to close Properties and save your changes. Click Cancel to

dismiss this session and restore your original properties.

TABLE 3-3 ShowMe TV Transmitter Properties (Continued)

Item Description
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Creating a New Broadcast

This section contains the following topics:

■ To Configure Broadcast Information

■ To Configure Audio and Video Information

■ To Configure Audience Information

■ To Configure Network Information

■ To Change the Configuration Defaults

■ To Preview a Broadcast

You can use the defaults that ShowMe TV Transmitter has set for the broadcast, but

you should check the information to see that it is correct.

▼ To Configure Broadcast Information

1. Click New broadcast.

The New Broadcast window is displayed showing the Configure Broadcast

Information window.

2. Type the broadcast name and description.

3. Set the Begin Date and Time.

You can click the Now button to enter the current time. The default is for the

broadcast to begin 10 minutes from the current time.

4. Set the End Date and Time.

By default, the end time is one hour from the default start time.

Transmit Continuous Broadcasts.

Click the Continuous button (instead of setting an end time) to broadcast 24 hours a

day. If in continuous broadcast, no other broadcasts are able to start from the same

workstation until that broadcast has ended, even if you have Start Automatically

selected on the Properties window.
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▼ To Configure Audio and Video Information

1. Click New broadcast.

The New Broadcast window is displayed showing the Configure Broadcast

Information window.

2. Click the Configure Information menu on the New broadcast window.

3. Choose Audio and Video.

Broadcasting From Audio/Video Inputs or ShowMe TV File

The source of the broadcast can be a ShowMe TV file on disk or the SunVideo (Plus)

card and Sun audio inputs of your workstation. In order to broadcast from inputs,

you must have the appropriate hardware installed.

1. Connect your video source (camera, VCR, Sun Tuner, and so on) into the
SunVideo card in your system.

2. Connect your audio source into the microphone or line-in jack.

3. Leave the default Audio/Video inputs selected.

Switching Between Video Inputs

ShowMe TV Transmitter can broadcast from any of the video sources plugged into

your workstation SunVideo (Plus) card. You can switch between the three input

ports, labeled S-Video, Port 1, and Port 2 on the card backplate if you want to

broadcast video from a VCR, camera, or other source. This control is not available in

an audio-only broadcast or in a broadcast from a file.

To switch between video sources, select the setting that corresponds to the port you

want to use. For example, if you want to switch to a VCR you have plugged into

Port 1 on the SunVideo card, click Port 1.

If you click No video, you create an audio-only broadcast. Some of the other controls

on the window then become inactive.
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Selecting Video Compression

ShowMe TV Transmitter supports three video compressions: CellB, JPEG and H.261.

CellB provides reasonable image quality and compression, and is fairly efficient to

decode so the CPU load on receiving workstation is reasonable. JPEG provides

better image quality and a slightly better compression ratio than CellB, but it is more

demanding on the CPU.

Use JPEG for its superior picture quality and lower bandwidth requirements. H.261

codec achieves better compression rates on video sequences with little movement on

the image scene.

Limiting Motion Speed

When you change your motion speed limit, you are changing the rate at which your

image is broadcast.

Note – You will not notice a significant difference in the appearance of video images

above 18 frames per second. However, the demand on the network significantly

increases as you raise the motion speed limit. We suggest that you use no higher

than 15 frames per second.

This control is not available in an Audio Only Broadcast or in a Broadcast From a

File.

Adjusting Compression Quality

If you select JPEG as the video compression, then this item is active. You can fine

tune the compression image quality with this slider. A low number results in

reduced image quality and correspondingly less bandwidth and CPU requirements

to decode. A higher number improves quality but also increases bandwidth usage

and CPU load.

Set this to 50. Setting much lower than 40 results in a significant loss in image

quality; setting much higher than 60 does not improve image quality appreciably.
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Adjusting Picture Resolution

When you change the Picture transmit resolution, you are changing the size of the

image that is sent. This control is not available in an Audio Only Broadcast or in a

Broadcast From a File. There are three image sizes available:

■ If you are sending an NTSC video source (primarily used in United States,

Canada, Mexico, Japan, Peru) the sizes are 160x120 (low), 320x240 (medium), and

640x480 (high) pixels.

■ If you are sending PAL (primarily used in U.K., Australia, China, Spain, Italy,

Germany, India) the available sizes are: 192x144 (low), 384x288 (medium), and

768x576 (high) pixels.

■ If you are sending H.261 encoded streams, the sizes will be 176x144 (low, or

QCIF) or 352x288 (medium, or CIF). This is the case for both PAL and NTSC.

The selection of NTSC or PAL is done automatically by the SunVideo (Plus) card.

Your awareness of which of these protocols is being used merely helps you interpret

the precise resolution and the impact on file size.

Use low or medium resolution for faster performance.

Note – The larger the image you send, the greater your impact on the network.

High resolution video requires four times as much data to be broadcast as medium

resolution, and sixteen times as much data as low resolution. And although a high

resolution image contains more image data, the image is not noticeably better

quality than medium resolution.

Switching Between Audio Inputs

Indicate the Audio input where you have connected your audio device.

Selecting Audio Quality

ShowMe TV supports five audio quality settings. All but one are compressed.

Depending on the source material, the audio compression used by ShowMe TV may

introduce a slight fuzziness during quiet passages or dialog, but the higher quality

compressed settings result in much greater dynamic range.

Use the menu to select the audio quality setting you want. The status line below the

menu gives you information on what format is used, and the bandwidth (in

thousands of bits per second) that the audio requires.
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If your broadcast consists primarily of spoken word, or a large number of your

viewers are using SPARCstation 1 or 2 class systems, consider using “Voice

(uncompressed).” This provides telephone quality audio in a format compatible with

older systems and the network bandwidth requirement is still reasonable.

If you want to minimize network bandwidth usage, use “Voice.” This requires half

the bandwidth of uncompressed Voice.

If your broadcasts has more dynamic audio (music, action sequences, and so on) or

you want the more “open” feel that increased dynamic range provides, choose Low,

Medium or High quality.

Older Sun systems (SPARCstation 1, 2, IPC, IPX, and so on) only support

uncompressed voice; therefore, Audio Quality is inactive on these systems.

Note – Viewers using older workstation can still watch broadcasts that use high

quality audio because ShowMe TV converts the audio to the workstation native

format before playing.

Adjusting Audio Input Level

Use the Audio input level slider to adjust the broadcast volume. This control is not

available in a broadcast from a File. You may need to readjust the audio level during

the broadcast. Levels may also vary widely depending on your audio source.

● Bring up the Preview window to monitor the sound, then adjust the Audio input
level slider to the desired volume.

▼ To Configure Audience Information

In configuring audience information, you determine who may watch your broadcast.

You determine whether this is an open broadcast that anyone can watch or a closed

broadcast with a restricted list of viewers.

1. Click the Configure Information menu on the New broadcast window.

2. Choose Audience.
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Choosing Open Broadcast or Closed Broadcast

The default is Open broadcast which enables anyone to watch the broadcast.

If you choose Closed broadcast, then your broadcast is available only to the people

you specify in the Audience list who are within the broadcast range. Click “Show

Address Book cards” to view the cards listed for closed broadcasts.

The users on your closed broadcast audience list see the broadcast advertised in the

Watch menu and Program Information window of their ShowMe TV. They are able

to watch it when the broadcast is on the air.

Specifying Members of a Closed Broadcast

To specify the members of a closed broadcast: click in the Audience list text area and

enter the network addresses of users permitted to watch.

The Audience list is available only if you have specified that you want a Closed

Broadcast.

Note – Be certain of the correct spelling when you enter addresses in the form

user@hostname . ShowMe TV Transmitter broadcasts to these addresses exactly as

specified without verifying that they are valid addresses. If you misspell the address,

you will not know that the intended viewer cannot watch the broadcast.

▼ To Configure Network Information

1. Click the Configure Information menu on the New broadcast window.

2. Choose Network.

Choosing Multicast or UDP Broadcast

Use Multicast for all your broadcasts. This is the most efficient way to send video to

the network.

Note – If you choose UDP broadcast, ShowMe TV Transmitter sends the broadcast

to only your local area network.
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Choosing a TTL for Multicast

If you are unsure about picking the right multicast time to live (TTL) number,

contact your system administrator.

1. Click the broadcast range menu on the Configure Network Information window.

2. Choose the approximate broadcast range.

ShowMe TV Transmitter creates an advertisement for the broadcast and begins

sending it to each ShowMe TV.

▼ To Change the Configuration Defaults

1. Click the Configuration menu on the New broadcast window.

2. Open each of the Configure Information windows in turn and change to the
values you want.

3. Type the changed values into each of the New Broadcast windows: Broadcast,
Audio and Video, Audience, and Network.

4. Click Set defaults at the bottom of each window when you have completed
changing the default settings.

TABLE 3-4 Approximate Broadcast Range Submenu

Menu Item Description

Local Restricts the broadcast to your own local area network. This control

is not available for UDP broadcasts. The TTL number is 1.

Vicinity Limits your broadcast to your floor or building. The TTL number

is 4.

Site Restricts the broadcast to the site. The TTL number is 32.

Region Restricts the broadcast to the geographic region. The TTL number is

64.

Continent Restricts the broadcast to the continent. The TTL number is 128.

Unrestricted Sends the broadcast, unrestricted, onto the network. The TTL

number is 255.
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▼ To Preview a Broadcast

1. Choose Transmitter ➤ Preview broadcast.

The ShowMe TV Receiver is displayed.

Note – When you select the ShowMe TV Preview window for the next broadcast, it

is not possible to preview other broadcasts.

■ Check that the camera, tuner, or VCR is functioning.

■ Check to see that the audio is present and the levels are acceptable.

■ See whether the motion speed and resolution you have chosen is adequate.

2. On the ShowMe TV Transmitter: Preview window, choose TV ➤ Controls.

3. Set properties for displaying the preview video.

Avoiding Audio Feedback While Previewing

When you are previewing your broadcast, you may experience feedback or echo in

your audio. Feedback occurs when the audio output feeds back into your audio

input (this happens if you are using a microphone and listening with a speaker). The

easiest way to avoid feedback is to use headphones to listen to the audio or to turn

down the output volume so that it is not picked up by a microphone.

▼ To Change the Broadcast

1. In the ShowMe TV Transmitter main window, select the desired broadcast from
the broadcast list.

2. Click Change broadcast.

3. Turn to the appropriate configuration page and make the necessary changes.
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Broadcasting

ShowMe TV Transmitter always shows you the time to the next broadcast on the

main window. When it is time for your broadcast to begin, ShowMe TV Transmitter

does one of two things:

■ If your ShowMe TV Transmitter Properties window indicates that the broadcast is

set to “Begin automatically,” then ShowMe TV Transmitter automatically uses the

broadcast configurations you have set and starts the broadcast.

■ If your ShowMe TV Transmitter Properties window indicates that the broadcast is

set to “Prompt before beginning,” then ShowMe TV Transmitter brings up the

“Begin Broadcast” window informing you that it is time for your broadcast to

begin.

▼ To Go On the Air

To begin your broadcast ahead of schedule, you can immediately place the broadcast

on the air.

1. On the ShowMe TV Transmitter, click On the air.

2. Using ShowMe TV, tune in to your broadcast.

Your broadcast is displayed under the Watch menu.

Controlling the Current Broadcast

Once you have started a broadcast, you may wish to interact with the audience.

ShowMe TV Transmitter enables you to see who is watching your broadcast and to

contact those viewers.

▼ To Use the Statistics Window

The Statistics window shows you the viewer name (as provided by the viewer), user

name, and host name of each viewer of your broadcast.

● On the ShowMe TV Transmitter, choose Transmitter ➤ Statistics.

▼ To Send Mail to a Member of the Audience

1. Select a name from the Statistics window audience list.
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2. Click Send mail to selected.

▼ To Send a Message to the Entire Audience

When you send a message to all audience members at once, the message is

displayed at the top of the ShowMe TV Receiver and stays there until you stop

watching the program or until you send a different message.

Ending the Broadcast

ShowMe TV Transmitter always shows you the time to the end of your running

broadcast on the main window. When it is time for your broadcast to end, ShowMe

TV Transmitter automatically stops the broadcast and removes it from the list of

broadcasts.

▼ To Go Off the Air

● Click Off the air.

This stops the broadcast but does not remove it from the broadcast list. Broadcasts

are removed from the list only after the end time has expired or you select them

from the Broadcast list and click Remove broadcast.

▼ To Remove a Broadcast

Normally broadcasts are removed from the Broadcast list after their end time has

past. If you would like to manually remove a broadcast, either before it starts or

while it is running, do the following:

1. Select desired broadcast on the ShowMe TV Transmitter.

2. Click Remove broadcast.

Broadcasting a ShowMe TV File

You can broadcast a ShowMe TV file rather than broadcasting from a live audio or

video source. (Chapter 5 contains a list of files that ShowMe TV supports.) The steps

in setting up a broadcast of a file are just like those for setting up a normal

broadcast. You need to do the following, however, in the Audio and Video

Information window.

1. Click New broadcast on the Transmitter.
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2. Choose Audio and Video.

3. At the selection The broadcast will come from, click a ShowMe TV file.

4. Type the full path name for the file you wish to broadcast.

5. Click OK.

If the Properties window indicates that broadcasts should start automatically, then

ShowMe TV Transmitter automatically starts playing the ShowMe TV file for you

when the broadcast begins.

If the Properties window indicates that broadcasts should prompt you before

starting, then you are prompted to start the broadcast.

Controlling the Broadcast of a ShowMe TV File

During the broadcast of a file, playback controls are displayed on the main window

and on the Preview window.

Treat these controls as if they were on a VCR attached to your SunVideo (Plus) card.

Simply pressing the Play button is not enough to put you on the air. The broadcast

must begin first. Furthermore, if the broadcast is on the air and you stop playback of

the file or forget to start playback, the broadcast sends no data to the audience.

If ShowMe TV Transmitter reaches the end of the file before the broadcast end time,

it replays the file from the beginning. If you have configured the broadcast as a

continuous broadcast, ShowMe TV Transmitter will replay the file indefinitely.

▼ To Broadcast Audio Only

1. Click New broadcast on the Transmitter.

2. Choose Audio and Video.

3. Click No video.

This inactivates the video controls.

If you do not have a SunVideo (Plus) card installed in your workstation, the “No

video” button is inactive. This indicates that you have no choice and can only live-

broadcast audio-only programs.
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ShowMe TV Transmitter Daemon

Most of the work of ShowMe TV Transmitter is performed by showmetvd , the

ShowMe TV Transmitter daemon. The daemon is responsible for running all

broadcasts and starting and stopping them at their scheduled times. It also sends out

the broadcast advertisements. The daemon must be running for broadcasts to be

advertised and to occur. It is possible to have the daemon running after you exit the

Transmitter program showmetvt . In order to have this happen, start showmetvt
with the -background option. The broadcast will continue even though you exited

showmetvt . If you start a new showmetvt , it will attach itself to the daemon
showmetvd .

Once you invoke the background option, the daemon stops only when you reboot

your workstation or explicitly kill it with the UNIX kill command.

If you want the daemon to start automatically whenever you log in to your

workstation, and remain running until you reboot or explicitly kill it, add the

following in your .login , .cshrc (or equivalent), or .openwin-init file:

Replace /opt/SUNWsmtv with the actual path if ShowMe TV is not installed in the

default location.

/opt/SUNWsmtv/bin/showmetvd parameters &
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Troubleshooting

TABLE 3-5 Transmitter Troubleshooting

Problem Possible cause/solution

Your broadcast is not reaching a particular TV

receiver.

User you are sending broadcast to does not have ShowMe

TV running. It is not tuned to your broadcast.

If it is a closed broadcast, check to see that the user address

is in the audience list. Check that the user and host names

are correct.

Verify that the user is connected to your network.

Your multicast broadcast is not reaching a

particular TV receiver.

Check that the TTL number is not too low to reach the user

network. See Choosing a TTL for Multicast.

Check that multicast is installed on the your machine.

Network multicast may not be enabled for all participants.

No video image for your broadcast Check that a SunVideo (Plus) card is installed on your

system.

Check that your SunCamera is properly connected and that

the camera lens is not shut.

Another user may be using the SunVideo (Plus) card on

your workstation.

Verify that the video input setting in your Transmitter

Properties window matches the actual connection in your

SunVideo (Plus) card. See Switching Between Video Inputs.

Network traffic may be very high, causing image movement

to be very slow.

Check for sufficient lighting for the camera to video.

Error messages

XIL error messages

Refer to an XIL manual for information.
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CHAPTER 4

Using the ShowMe TV Address
Book

The ShowMe TV Address Book helps you keep track of individuals by storing their

home and work addresses, telephone numbers, login name and host name,

conference addresses, and more.

This chapter is organized as follows:

■ ShowMe TV Address Book Basics

■ Using the Address Book

■ Using Address Book Group Cards
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ShowMe TV Address Book Basics

▼ To Start ShowMe TV Address Book

● Type the following at your system prompt:

or

● Choose Transmitter ➤ Address Book.

Address Book Menus

Address Book has four menus: File, Cards, Navigation, and Help.

● Choose Help ➤ Help from the Address Book menu bar for menu item
descriptions.

Note – On menu selections containing optional keystroke shortcuts, use Alt+ if you

are in the CDE environment, ♦+ if in OpenWindows.

% showmetvab
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Using the Address Book

This section contains the following topics:

■ To Create an Address Book

■ To Change Your Default Address Book

■ To Create a New Card

■ To Open an Address Book

■ To Import Cards to Your Address Book

■ To Export Cards to Other Address Book Users

■ To Print Cards From Your Address Book

■ To Duplicate a Card

■ To Delete and Undelete a Card

■ To Add and Remove Card Fields

▼ To Create an Address Book

When you first start Address Book, a new Address Book is created for you.

However, you can create another new Address Book, as follows:

1. In the Address Book, choose File ➤ New.

Note – Since Address Book saves changes automatically, you need to give your

Address Book a name right away. If you already have an Address Book open, the

changes are automatically saved before creating a new Address Book.

2. Type a unique name for your new Address Book.

Note – You must attach the suffix .ab to the name you select. For example, to name

your Address Book JSBach , you need to label it JSBach.ab .
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▼ To Open an Address Book

1. Choose File ➤ Open.

2. Select or type the file name of the Address Book you want to open.

3. Click Ok.

Note – The current Address Book is saved before the new Address Book is opened.

▼ To Change Your Default Address Book

By default, Address Book loads . addresses from your home directory. To use a

different default Address Book,

1. Choose File ➤ Preferences.

2. In the Default Address Book field, enter the name of the Address Book file you
want to load each time you start the Address Book.

3. Select the order in which you want to sort your cards.

4. Click Ok.

▼ To Create a New Card

1. Choose Cards➤New card.

2. Type the applicable information into the blank card fields.

3. Click Apply to save your card.

▼ To Edit a Card

1. Click on the card in your Address Book card list that you want to edit.

2. Change the information in the card fields.

3. Click Apply.
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▼ To Import Cards to Your Address Book

1. Choose File ➤Import.

2. Type the file name, or click on the file name, of the Address Book that you want to
import.

3. Click Ok.

▼ To Export Cards to Other Address Book Users

1. Choose File ➤ Export.

2. Specify the cards you want to export.

■ Click “From all cards” to export your entire Address Book.
■ Click on one or more card names to highlight them for selective card export.

To deselect a card, click on it again.

3. Click Ok.

4. Type a unique file name for your card.

When you export cards, you are saving an Address Book database that other

Address Book users can access.

5. Click Ok.

▼ To Print Cards From Your Address Book

Address Book enables you to print specific cards from your Address Book. You can

choose from several formats to fit a particular layout. To print labels,

1. Choose File ➤ Print.

2. Select the Printer destination: Printer or File.

a. To print to a printer, enter the printer name.

b. To print to a file, enter the file name.
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3. Indicate whether you want to use manual feed.

4. Click on the names in the card list that you want to print.

5. Click Print format and choose a format.

▼ To Duplicate a Card

1. Select the card you want to duplicate from the Address Book card list.

2. Choose Cards ➤ Duplicate card.

3. Change the information in the card fields.

4. Click Apply to save your card.

▼ To Delete and Undelete a Card

Once you delete a card from the Address Book card list, it is placed in an Undelete

holder. During a session, you can access a deleted card from the Undelete holder and

return it to your Address Book card list.

▼ To Delete a Card

1. Click on the name in your Address Book card list that you want to delete.

Note – Each time you close your Address Book, you cannot later retrieve any cards

you have deleted during that session. That is, the card is lost from the Undelete

holder when a session ends.

2. Choose Cards ➤ Delete Card.

▼ To Undelete a Card

1. Choose Cards ➤ Undelete cards.

2. Click on the cards that you want to undelete.

3. Click Undelete.
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▼ To Add and Remove Card Fields

1. Choose Cards ➤ Add fields to card.

2. Click on each of the fields you want to add to your current card.

The list contains all of the available fields that are not already in your current card.

To deselect fields, click on them a second time.

3. Click Add fields.

Note – You can remove any field on a card by removing all of the data in that field.

▼ To Find a Card

To find a card based on special criteria, you can use the Address Book main window

Find controls. See online Help for menu item descriptions.

1. Type the text you want to look for into the Find field.

2. Click the Any name menu to choose the fields you want to search.

3. Select a field that you want to locate.

4. Click Begins with.

5. Choose the search method that you want to use.

Note – You can also use regular expressions in your searches. For example, if you

type w* into the Find field, the Address Book searches for entries with words that

start with the letter “w.”

6. Click Find.

All of the cards containing this text appear in the Card list.

Note – When you use Find to select particular cards in your Address Book (for

example, all cards beginning with “Di”), the “Show all cards” button is activated.

7. Click Show all cards to again list all entries in your Address Book.
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Sorting the Address Book

You can sort the cards in your Address Book by toggling the “Sort by” control.

Selecting First sorts the cards alphabetically by first name. Selecting Last sorts the

cards alphabetically by last name. Cards representing groups of people are sorted

alphabetically with all of the other cards. A card representing a group is denoted by

a bullet preceding the name of the card.

Saving an Address Book

You never have to explicitly save your Address Book. The Address Book

automatically saves your Address Book each time you do one of the following:

■ Press the Apply button

■ Flip to another card

■ Create a new card

■ Open a new Address Book

■ Exit the Address Book

Using Address Book Group Cards

▼ To Create or Add a Group Card

1. Choose Cards ➤ New group card, or click New group card on the Address Book.

2. Determine a name for the group and enter it into the Group name field.

3. Select the members from the list in the Groups window.

4. Click Ok.

The group card is created and listed in your Address Book Card list with a bullet

next to it.

▼ To Edit a Group Card

1. Click on a group listed in your Address Book card list.

2. Click Edit Group on the group card.
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The Groups editing window is displayed with the names listed in all your group

cards. The names in the selected group card are highlighted.

3. Click on the highlighted name to delete it from the list.

4. Click on a name to add it to the group.

5. Click Ok.
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CHAPTER 5

Audio, Video, and File Formats

ShowMe TV supports QuickTime, AVI, and MPEG-I/MPEG-2 movie files. It also

supports Wave and Sun.au audio files. The degree of support depends on the

particular characteristics of the file, and the operation you want to perform.

TABLE 5-1 Movie File Formats

File format Compression File Playback Record to File Broadcast

QuickTime, AVI CellB Yes Yes Yes

QuickTime, AVI JPEG Yes Yes Yes

QuickTime, AVI H.261 Yes Yes Yes

QuickTime Cinepak Yes No No

QuickTime RLE Yes No No

MPEG-I MPEG-I Yes No No

MPEG-2 MPEG-2 Yes No No

Sun .au Audio only Yes Yes Yes

Wave Audio only Yes Yes Yes
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Note – When playing audio data on the workstation audio device, ShowMe TV

automatically converts the audio data to the closest format that the hardware

supports. When broadcasting from a file, ShowMe TV Transmitter automatically

converts the audio data to the closest format.

TABLE 5-2 Audio Formats

Feature Format Supported

File Playback 8-bit u-law Mono, 8000 Hz

8-bit linear (signed) Mono/Stereo, 11127, 22254 Hz

8-bit linear (unsigned) Mono/Stereo, all sample rates

16-bit linear (signed) Mono/Stereo, all sample rates

MPEG-I, -2 Layer-1, Layer-2 and Layer-3

16-bit IMA ADPCM/IMA4 Mono/Stereo, 8000, 11025, 22050,

44100 Hz

Direct Capture/record 8-bit u-law Mono, 8000 Hz

16-bit linear (signed) Mono, 11025, 22050, 44100 Hz

Broadcast 8-bit u-law Mono, 8000 Hz

CSM, 8000 Hz, Mono

IMA ADPCM/IMA4 Mono, 8000, 11025, 22050, 44100 Hz

TABLE 5-3 File Formatting Terms

Term Description

AVI A multimedia file format developed by Microsoft that supports

synchronized audio and video. ShowMe TV supports only three of

its compression schemes: CellB, JPEG, and H.261.

CellB A video compression scheme developed by Sun Microsystems with

a ratio of 10:1. It is based on intra-frame coding of 4 x 4 pixel “cells.”

The resulting image looks somewhat blocky. It uses relatively few

CPU cycles to achieve a high compression ratio.
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H.261 The H.261 coding system is a video compression standard

developed by the International Telegraph and Telephone

Consultative Committee (now International Telecommunications

Union [ITU]) for video teleconferencing applications using

transmission over Integrated Services Digital Network (ISDN) lines.

During its development, H.261 was called p x 64 (p times sixty four)

coding in reference to the fact that ISDN provides channels in

increments of 64 Kbits/s.

The H.261 system is a hybrid intraframe/interframe method based

upon DCT coding. The intraframe mode of H.261 is similar to the

JPEG DCT scheme. The data rate of the coding algorithm was

designed to be able to be set to between 64 Kbits/s and 2 Mbits/s.

Developed with videoconferencing in mind, this encoding scheme is

most effective in dealing with scenes where users are talking in front

of a camera and most movement is concentrated in the heads and

the shoulders. Once more quality critical or movement-intensive

video data needs to be compressed and transmitted, H.261 may

become inadequate.

IMA ADPCM/IMA4 An audio compression method defined by the Interactive

Multimedia Association. It takes 16-bit linear samples and

compresses them down to 4 bits.

JPEG Originally developed by Joint Photographic Expert Group to

compress still images, JPEG is also good at compressing video. It is a

DCT-based compression scheme and gives much better image

quality with a slightly better compression ratio than CellB. This is

done at the expense of more CPU computations.

Linear Linear Pulse Code Modulation (PCM). An uncompressed audio

format in which sample values are directly proportional to the audio

signal voltage. The samples are 8 or 16 bits and can either be

represented as a signed or unsigned value. The 16-bit linear PCM is

almost always signed.

MPEG-1 MPEG-1 is both a file format and an audio/video compression

scheme. It was developed by the Motion Picture Expert Group and

uses very sophisticated compression techniques. Based on DCT and

inter-frame motion estimation, MPEG-1 provides high image quality

with high (30:1) compression ratio. It is very CPU intensive to

decode.

TABLE 5-3 File Formatting Terms (Continued)

Term Description
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MPEG-2 MPEG-2 was based on MPEG-1, but optimized for higher data rates,

to deliver broadcast quality digitally encoded audio and video. As a

result, the main applications for MPEG-2 are high definition

television (HDTV), digital storage media, and DVD. Additional

features implemented in the MPEG-2 specification include interlaced

video formats, multiple picture aspect ratios (such as 4:3 and 16:9, as

required by HDTV), multiple (up to five) channel audio, and so on.

CPU requirements for MPEG-2 are even higher than those for

MPEG-1.

QuickTime A multimedia file format developed by Apple. Supports

synchronized audio and video. Video is compressed by one of many

compression schemes.

RLE RLE (Run Length Encoding) is another image compression method

most suitable for animated graphics. ShowMe TV supports the RLE

specified in the Apple-QuickTime standard. It is a simple

compression scheme based on a representation of repeating pixel

values with specific byte codes. RLE is the least CPU intensive to

decode and does not lose quality during compression. But for

photorealistic images, the compression ratio is relatively small, and

thus ineffective.

Sun .au Sun Microsystems audio file format.

u-law A standard for voice data (CCITT G.711) used by telephone

companies in the US, Canada, and Japan. u-law is sampled at 8000

samples per second with 12 bits of precision. The data is then

compressed to 8-bit samples. Audio quality is similar to that of the

telephone.

Wave An audio file format popular on PC’s.

TABLE 5-3 File Formatting Terms (Continued)

Term Description
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CHAPTER 6

Technical Topics

This chapter contains ShowMe TV technical information. It is provided to help you

understand, troubleshoot, and configure ShowMe TV. Contact your SunService™

representative for more information.

Using Motif Applications (for OPEN
LOOK Users)

If you are familiar with the Motif window manager (mwm) and have switched to

using a Motif desktop, you should probably skip this section. However, if you are

running OpenWindows and the OPEN LOOK window manager (olwm), then you

should read further.

If you are using OPEN LOOK applications, you will notice that Motif applications

like ShowMe TV behave somewhat differently. For more information, see the Motif
1.2 User’s Guide.
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Customizing Motif Window Manager
(for OPEN LOOK Users)

If you have recently switched from the OpenWindows window manager, olwm, to

the Motif window manager, you may want to make some customizations to mwm. To

do so, you can add the following lines to your .mwmrc file.

The following lines, added to your .mwmrc file, make the Sun keyboard Open and

Front keys work correctly under mwm.

The following lines, when added to your .mwmrc file, make the three mouse buttons

behave more as they do in OpenWindows. (For example, the right mouse button

opens a menu.)

Keys DefaultKeyBindings
{
<Key>F15 window|icon f.raise_lower
<Key>F17 window f.minimize
<Key>F17 icon f.normalize
}

#
# Default Button bindings
#
Buttons DefaultButtonBindings
{

<Btn1Down> window|icon f.raise
<Btn2Down> icon f.raise
<Btn3Down> icon|title|frame|border f.post_wmenu
<Btn1Down> root f.menu RootMenu
<Btn2Down> root f.circle_up
<Btn3Down> root f.menu RootMenu

}
You must also add the following line to your .Xdefaults file:
Mwm*keyBindings: DefaultKeyBindings
Mwm*buttonBindings: DefaultButtonBindings
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Customizing ShowMe TV Window
Colors (Xdefaults)

There are three colors used in ShowMe TV:

■ application color is used on the main application window.

■ dialog color (also known as the background color) is used on the main menu bar

and on all dialog windows for that application.

■ foreground color is the color used for the text.

To change the colors, you need to add the following lines to your .Xdefaults file,

use the xrdb -load ~/.Xdefaults command to update your X resources, and

restart ShowMe TV. Below is an example for choosing colors other than the default.

■ Foreground is #ffffffffffff (white)

■ Application color is #666696969797 (green)

■ Dialog color is #67669935ab37 (blue)

To change the colors used by ShowMe TV, replace these values in your .Xdefaults
file with your new color values.

*foreground: white
*background: #67669935ab37
*applicationWindow*background: #666696969797

ShowMeTV*foreground: white
ShowMeTV*background: #67669935ab37
ShowMeTV*applicationWindow*background: #666696969797

ShowMeAddressBook*foreground: white
ShowMeAddressBook*background: #67669935ab37
ShowMeAddressBook*applicationWindow*background: #666696969797
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ShowMe TV Configuration Files

ShowMe TV and ShowMe TV Transmitter refer to several configuration files when

they start. Some give the default values to use for ShowMe TV properties and other

user-level parameters. They are under your control. The other holds system-wide

limits, restrictions, and parameters. It is managed by the system administrator.

ShowMe TV Default File

The values you set in the ShowMe TV Properties window are stored in the file

.showme-defaults in your home directory. This file is automatically created and

filled with default values when you run ShowMe TV for the first time. Other

information not directly modifiable from ShowMe TV windows is stored there also.

The default parameters for current and upcoming broadcast programs are in

.showmetv-programs- hostname.

Open your own .showme-defaults file for examples of setting these entries.

TABLE 6-1 .showme-defaults File

File item Description

ShowMe.UserName This shows the full name you entered in the Properties window.

The default is taken from your UNIX password entry.

ShowMeTV.EmailAddr Enter your email address. The default is userid@host .

ShowMeTV.DateFormat Enter the date format is either mmddyyyy or ddmmyyyy.

ShowMeTV.AudioOutputSource Enter the audio source. The audio source is either Headphones ,

Speaker , or LineOut .

ShowMeTV.OutputVolume Enter the desired default speaker volume level. The values are

an integer value between 0 and 100, inclusive.

ShowMeTV.ColorUsage Enter the number of colors for video. The options are Low,

Medium, or High .

ShowMeTV.Color This is to select video in color or in gray scale. Enter True for

color, False for gray scale.

ShowMeTV.Brightness Enter the desired default brightness level. The values are an

integer value between 0 and 100, inclusive.

ShowMeTV.TVSyncThreshold The “lip synch” threshold. It is the number of milliseconds by

which the audio and video are allowed to be out of synch

before the program will try to correct the situation. Enter an

integer value greater than or equal to 62500 (1/16 second).
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ShowMeTV.AudioInputPrescision Number of bits each audio sample is: 8 or 16.

ShowMeTV.AudioInputEncoding Audio encoding: “ULAW” or Linear”

ShowMeTV.AudioInputSampleRate Number of audio samples per second: 8000, 11025, 22050, or

44100.

ShowMeTV.ZoomSize The default zoom size when a Receiver window first opens.

Enter either Quarter , Half , Normal , or Double .

ShowMeTV.RecordMaxFileSize The maximum size file to create when recording. Enter the size

in megabytes.

ShowMeTV.AddressBookPath The UNIX path name of your default address book file.

ShowMeTV.BroadcastType This specifies either Multicast or UDP Broadcast.

ShowMeTV.AudioInputSource The audio input source: Mic or LineIn .

ShowMeTV.VideoInputSource The video input source: Port1 , Port2 , Svideo , or NoVideo .

ShowMeTV.InputVolume The desired default speaker volume level. The values are an

integer value between 0 and 100, inclusive.

ShowMeTV.Resolution The default picture resolution: Low, Medium, or High.

ShowMeTV.MotionSpeed The default motion speed in frames per second. This is an

integer value between 1 and 30, inclusive.

ShowMeTV.MulticastTtl The default TTL number for multicast broadcasts. This is an

integer value between 1 and 256, inclusive.

ShowMeTV.PromptBegin Indicates whether you want to be prompted before starting a

schedules broadcast. Specify True to request prompting, False
for no prompting.

ShowMeTV.TransmitterSyncThreshold The “lip synch” threshold. It is the number of milliseconds by

which the audio and video are allowed to be out of synch

before the program will try to correct the situation. Enter an

integer value greater than or equal to 62500 (1/16 second).

ShowMeTV.AudioInputCompression Audio compression to use: None or DVI. DVI uses IMA

ADPCM algorithm.

ShowMeTV.VideoCodec Compression scheme: JPEG, CellB, or H.261

ShowMeTV.CompQuality Compression quality: 1 - 100

ShowMeTV.MpegAudioQuality MPEG audio quality used during playback: Low, Medium,

High.

ShowMeTV.MpegAudioMode MPEG audio playback mode: Left, Right, Stereo.

TABLE 6-1 .showme-defaults File (Continued)

File item Description
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ShowMe TV System Configuration File

The ShowMe TV system configuration file enables a system administrator to

configure ShowMe TV to control the system and network resources that can be used

by ShowMe TV users.

See the file itself for its syntax and instructions for modifying it. The path name of

the file is

/opt/SUNWsmtv/ShowMeTV/share/showmetv-defaults

Host Name Addresses

Name Services

To send a closed broadcast to someone outside of your network domain, you must

provide that person’s network address.

There are two UNIX commands that can help you construct your own complete

network address: hostname (uname -n on Solaris 2.x) and domainname . When you

enter hostname in a shell, it returns your machine name. When you enter

domainname in a shell, it returns your domain name. Append the domain name to

the machine name to get your full name. For example, if your machine name is

bullwinkle and your domain name is West , appending the two gives your full

name, bullwinkle.West .

Hosts Database

Alternatively, an organization may keep its list of host names in a file called

/etc/hosts . If this is the case in your organization, a copy of this file is stored on

every machine. It is essential for the proper functioning of the network that all

machines know the addresses of all other machines, and that there are no duplicate

addresses. A sample entry in a host’s file looks like the following:

129.144.221.36 bullwinkle.West

The number is the Internet address for the machine named bullwinkle . Although

there may be more than one machine on the network named bullwinkle (for

example, bullwinkle .East and bullwinkle.West ), there is exactly one machine

named bullwinkle with an Internet address of 129.144.221.36.
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Note – When you broadcast to a user in ShowMe TV, you can refer to a machine

either by its full name (for example, rivers@bullwinkle.west ), if it is known to

the name service, or by its unique Internet address (for example,

rivers@129.144.221.36 ).

Using Multicast

Multicast enables ShowMe TV Transmitter to give broadcast data an address so that

the data goes to a group of people or machines, rather than to a single person or

machine. In this way, you can send out one copy of your video or audio stream and

multiple people can receive it. With multicast there is no data duplication and no

wasted bandwidth.

Installing Multicast

To broadcast to people beyond your local subnet, install mrouted on each of the

routers between you and them (or create a multicast tunnel). Without mrouted ,

multicast data is not sent from one local network to another. If you are not using Sun

machines for gateways, you should contact your router company and ask them if

they support multicast.

TTL on Your Network

The current multicast routing technology (mrouted ) is not very sophisticated in its

transportation of data: mrouted takes all multicast data and transmits it to all of the

interior nodes (routers) of a multicast tree, regardless of whether any of the leaf

nodes (workstations) have requested multicast data.

If you choose a very high TTL, even though only two people are tuned into the

broadcast, all multicast routers are required to carry the traffic because they are

within the TTL range.

Caution – This means that multicast data is sent to every gateway within the range

of the TTL number you have chosen. A large TTL number could have a serious

impact on your network.
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There is a new version of mrouted under development that has a more

sophisticated method for handling multicast routing. This version prunes off areas of

the multicast tree that have not requested traffic (that is, joined a particular multicast

group). This version also allows some bandwidth policy enforcement.

For More Information on Multicast

The following RFC document is available for multicast:

■ MBone: Interactive Multimedia on the Internet by Vinay Kumar. Published by New

Riders, Indianapolis, Indiana. Reprinted in 1995. This contains references to many

other publications.

Calculating Network Bandwidth Use

To calculate the impact that a single video stream has on the network, you have to

take into account the compression used, the picture resolution, and the motion speed

of the video. The following table describes these three parameters.

Compression

CellB

CellB achieves a range of compression from 0.75 bits per pixel (bpp) to 1.5 bpp for

each pixel in the image. This is because CellB uses motion estimation or intra-frame

coding. The amount of compression varies depending on the amount of movement

in the video image. An image of a person sitting relatively still results in

compression closer to 0.75 bpp. an image with rapidly changing pictures or a noisy

video signal results in compression closer to 1.5 bpp.

JPEG

JPEG achieves a range of compression from 0.75 bits per pixel to 1.0 bpp for each

pixel in the image. JPEG uses a still image compression method based on discrete

cosine transform (DCT). The amount of compression varies depending on the

compression quality set and the complexity of individual image. If the compression
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quality is lower, the image is more capable of achieving a higher compression ratio.

An image with little details and variation in contrast will generate higher

compression ratio than an image with lots of contrast and details.

H.261

As in JPEG and CellB cases, H.261 rate of compression also greatly depends on the

characteristics of the image sequence. In general, H.261 codec achieves better

compression rates on video sequences with little movement on the image scene.

User can influence H.261 compression rate by setting the desired Encoding Bit Rate.

In most situations, H.261 achieves compression rates anywhere from 0.1 to 0.5 bpp.

Picture Resolution

For CellB, ShowMe TV supports three image sizes. For NTSC format video data, low

resolution is 160 x 120 pixels, medium resolution is 320 x 240 pixels, and high

resolution is 640x480 pixels.

PAL format is also supported. PAL low resolution is 192 x 144 pixels, medium

resolution is 384 x 288 pixels, and high resolution is 768 x 576 pixels.

JPEG is supported only in medium resolution:

■ NTSC is 320 x 240 pixels

■ PAL is 384 x 288 pixels.

H.261 broadcasts have the following resolution sizes, which are independent of

video source format (PAL or NTSC). The possible screen resolution sizes are:

■ Low - 176 x 144

■ Medium - 352 x 288

■ High - 704 x 576 (achieved by zooming a 352 x 288 broadcast resolution)

Motion Speed

Motion speeds from 1 to 30 frames are supported. Higher motion speeds means

more data in the video stream.
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The bandwidth of a single video stream equals the resolution of the image

multiplied by the frame rate and the compression rate. In general, the bandwidth of

a stream is:

If, for example, we broadcast in CellB, where c (the compression ratio) ranges from

0.7 to 1.5 bits per pixel, then:

■ At low resolution (160x120 pixels) and 1 frame per second will yield from

(160*120*1*0.75)Kbps to (160*120*1*1.5)Kbps. Or from 14Kbps when there is little

motion in the image to 29Kbps when there is a lot of motion. This is the smallest

possible bandwidth for one video stream.

In contrast, if you send an uncompressed low resolution 8-bit video image at one

frame per second you would send 160*120*8 = 153Kbps.

■ At high resolution and 12 frames per second will yield from

(640*480*12*0.75)Kbps to (640*480*12*1.5)Kbps. Or from 2.8Mbps to 5.5Mbps.

Audio Considerations

An average audio does not consume nearly as much network bandwidth as video.

TABLE 6-2 Audio Format Bandwidth Requirements

Quality Format
Bandwidth

(K bits per second)

Voice (uncompressed) 8 bit ulaw, 8000 Hz, mono 64

Voice IMA ADPCM/IMA4, 8000 Hz, mono 32

Low IMA ADPCM/IMA4, 11025 Hz, mono 44

Medium IMA ADPCM/IMA4, 22050 Hz, mono 88

High IMA ADPCM/IMA4, 44100 Hz, mono 178

width height
pixels
frame
---------------- 

 × f
frames

ondsec
------------------- 

 × c× bits
pixel
------------- 

  b
bits

ondsec
------------------ 

 =
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Conserving Network Bandwidth

If you are concerned about the effect that ShowMe TV Transmitter is having on your

network, there are several steps you can take to minimize network impact.

If you want to decrease your impact on the network while using ShowMe Video you

can:

■ Reduce the motion speed to fewer frames per second.

■ Decrease your picture resolution. A high resolution image (640x480 pixels) sends

sixteen times as much data as a low resolution image (160x120 pixels).

■ Use multicast. For more information on multicast see Using Multicast.

X-terminal Support

ShowMe TV supports X-terminals. This means that multiple users on a machine can

each run their own copy of ShowMe TV on their X terminal. However, there are two

things to keep in mind:

■ The audio output from a broadcast goes to the original workstation speaker, not
the X-terminal.

■ Uncompressed video data is sent via the X protocol to the X-terminal. This could

be a significant amount of data being sent. For example, a single 8-bit color video

stream at 340x260 pixels and 15 frames per second is approximately 9.2 Megabits

per second.

Any displays conforming to X11R5 specifications, including those available on PCs

and Macintosh, should work.

Preventing Color Flash

On an 8-bit frame buffer machine, ShowMe TV shares a color palette with the other

applications on the desktop. There are 256 color entries available on an 8-bit

machine, and all of the applications running on the desktop compete for these

entries. When all of the colors have been used up—the color map is full—the

desktop applications create their own color maps. Once they do this, you see color
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flash. When you move your pointer into a window with its own color map, you will

see all other colors on the desktop change. When you move your pointer out of that

window, its colors also change. This is called color flash.

ShowMe TV has been designed to reduce the possibility of color flash occurring on

your system. All of the icons and palettes presented in the ShowMe TV windows use

a palette of 16 colors. The window manager also allocates nine colors to display the

default ShowMe TV window colors (this includes highlight colors for the widgets),

resulting a total of 25 colors used.

However, ShowMe TV always uses a certain number of colors to display video

images.

If you are experiencing color flash, there are a number of things you can do to

combat this problem:

■ Quit applications on your desktop that consume a large number of colors. Any

application that displays an image or uses many colors to present windows and

images probably consumes a significant number of colors. You may need to

restart ShowMe TV after you quit these applications in order for ShowMe TV to

recognize the newly available colors.

■ Change ShowMe TV to use fewer colors or change to grayscale.

ShowMe TV runs on 1-bit monochrome, 8-bit color and 24-bit color displays.

ShowMe TV Transmitter supports broadcasting to a mixture of display hardware.

For more information on this, see Graphics Compatibility.

Note – There are displays that support multiple depths. For example, a Sun

SPARCstation with a GS display supports 4-bit, 8-bit and 24-bit applications all at

the same time. ShowMe TV runs on these types of displays, but only if 1-bit, 8-bit or

24-bit depths are supported by the display. ShowMe TV does not run on 24-bit

StaticGray or 24-bit DirectColor displays.

Locking in a Colormap

If you are using olwm, you can lock in a colormap. This means that as you move

from window to window, the colormap that you lock remains the current colormap.

Ctrl+Again locks the colormap in to the current window and Ctrl+Undo unlocks it.
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The Motif window manager (mwm) has Next colormap and Previous colormap

commands which you can bind to keyboard commands by including the following

lines in your .mwmrc file:

This makes the Again key and the Undo key on the Sun keyboard go to the next and

previous colormaps on the desktop. You can bind these commands to other

keyboard keys if you want.

Graphics Compatibility

The images sent by ShowMe TV are display independent. Each display that receives

an image shows the video images for its own display. Monochrome machines show

black and white images, 8-bit and 24-bit machines show color images. If you are

using a 24-bit machine, there is three times as much color information to display.

Therefore, the frame rate on 24-bit machines is slower.

On monochrome systems, ShowMe TV supports only one viewing size. This means

that the picture-in-picture and zoom controls are not available.

Hardware and Software Limitations

The H.261 decompression and display software requires the X Shared Memory

Extensions of non-Ultra based systems This is available on all systems from Sun.

There are, however, situations when you cannot run H.261 decompression; for

example, while running via rlogin or telnet. Therefore, you cannot use H.261

decompression through rlogin or telnet on non-Ultra systems (for example,

SPARCstation 20).

When using the SunVideo card for H.261 video compression, the captured images

are slightly altered. For an NTSC camera, the captured image is 320 × 240 pixels, and

it is stretched vertically to a 320 × 288 image. For a PAL camera, the right hand side

of the 384 × 288 pixel image is cut off to fit a canvas size of 352 × 288. These

limitations do not exist with the SunVideo Plus card.

Ctrl<Key>L2 window|icon f.next_cmap
Ctrl<Key>L4 window|icon f.prev_cmap
Chapter 6 Technical Topics 71



72 ShowMe TV User’s Guide • May 1999



Index
SYMBOLS
.showme-defaults , 62

A
audio compression

IMA ADPCM/IMA4, 57

audio file format

Sun.au, 55

u-law, 58

Wave, 55, 58

audio formats, 56

audio recording, 18

audio-only programs, 13

AVI file format, 55, 56

B
bandwith use, 66

broadcast range, 37

C
CellB, 55, 56, 63

Cinepak, 55

color flash, preventing, 69

configuration files, 62

ShowMe TV system, 64

customizing, window colors, 61

D
default files, 62

F
file sizes, video, 21

formats, recording, 18

H
H.261, 55, 57, 63

hostname addresses, 64

I
IMA ADPCM/IMA4 audio compression, 57

installation

directories, 3

requirements, 3

SunVideo, 4

J
JPEG, 55, 57, 63

L
limitations, hardware and software, 71
Index 73



M
movie file format

AVI, 55, 56

MPEG-1, 55, 57

MPEG-2, 55, 58

QuickTime, 55, 58

MPEG-1 file format, 55, 57

MPEG-2 file format, 55, 58

MPEG-I, 55

multicast broadcasts, 36

multicast, installing, 65

mwmrc, 60

N
network addresses, 65

network bandwidth

conserving, 69

ShowMe TV impact, 66

NTSC image source, 34

O
online help, 2

OPEN LOOK, 60

P
PAL image source, 34

picture resolution, frame rates, 68

PiP (picture-in-picture), 16

previewing broadcast, 38

program information, 14

Q
quick record, 18

QuickTime file format, 55, 58

R
record timer, setting, 19

recording

audio-only programs, 18

formats, 18

recording programs, 17, 18

RLE, 55, 58

S
ShowMe TV Address Book, 45

adding card fields, 51

changing default, 48

creating a new, 47

creating group cards, 52

duplicating cards, 50

editing cards, 48

editing group cards, 52

exporting cards, 49

finding cards, 51

group cards, 52

importing cards, 49

menus, 46

printing cards, 49

saving, 52

sorting cards, 52

starting, 46

ShowMe TV files

editing, 22

storing, 21

watching, 22

ShowMe TV Receiver

features, 1

help menu, 9

menus, 7

multiple TV receivers, 15

picture-in-picture (PiP), 16

properties, setting default, 10

starting, 6

troubleshooting, 23

watching a program, 11

watching TV files, 20

ShowMe TV Transmitter

audio input, selecting, 34

audio-only broadcast, 41

broadcast status area, 28

broadcasting a TV file, 40

changing configuration defaults, 37

closed broadcast, 36
74 ShowMe TV User’s Guide • May 1999



configuring audience, 35

configuring audio and video, 32

configuring broadcast, 31

configuring network, 36

creating a broadcast, 31

daemon, 42

deleting and undeleting cards, 50

ending a broadcast, 40

menus, 28

motion speed, limiting, 33

open broadcast, 36

overview, 2

properties, 29

selecting video port, 32

starting, 26

troubleshooting, 43

showmetv  command, 6

showmetvab  command, 46

showmetvt  command, 26

snapshots, taking, 16

Sun .au, audio file format, 55

SunVideo, 13

SunVideo installation, 4

SunVideo, using, 12

T
technical tips, 59

troubleshooting

ShowMe TV Receiver, 23

ShowMe TV Transmitter, 43

TV menu, 7

U
u-law, 58

V
video compression, 63

CellB, 13, 33, 55, 56

H.261, 13, 33, 55, 57

JPEG, 13, 33, 55, 57

MPEG-1, 55

MPEG-2, 55

RLE, 55, 58

video device settings, 13

video file sizes, 21

W
watch menu, 8

watch timer, setting, 19

watching a program, 11

Wave, audio file format, 55, 58

X
Xdefaults, 60, 61

XIL runtime libraries, 4

X-terminal support, 69
Index 75



76 ShowMe TV User’s Guide • May 1999


	Preface
	Introduction to ShowMe TV
	ShowMe TV Receiver
	ShowMe TV Transmitter
	ShowMe TV Address Book
	Online Help
	Installation Information
	Installation Requirements
	Installation Directories
	XIL Runtime Libraries
	SunVideo
	Audio Device Setup


	Using ShowMe TV Receiver
	ShowMe TV Receiver Basics
	To Start ShowMe TV Receiver
	ShowMe TV Terminology
	ShowMe TV Receiver Menus
	TV Menu
	Watch Menu
	PiP Menu
	Help Menu
	Program Title, Channel Selection, and Messages

	To Change ShowMe TV Default Properties
	To Exit ShowMe�TV Receiver

	Watching a Program
	To Watch a Program
	To Use SunVideo
	Listening to Audio-Only Programs
	To Obtain Information About a Program
	To Send Mail to the Broadcaster
	To Watch Several Programs or Files Simultaneously
	To Use Picture-in-Picture (PiP)
	To Take a Snapshot

	Recording a Program
	To Quick Record a Program
	To Select a Recording Format
	To Record Audio Only

	Setting the Timer to Watch or Record a Program
	To Set the Watch Timer
	To Set the Record Timer

	Using ShowMe�TV Files
	Storing ShowMe TV Files
	Sharing ShowMe TV Files
	To Watch a ShowMe TV File
	To Edit a ShowMe TV File

	Troubleshooting

	Using ShowMe TV Transmitter
	ShowMe TV Transmitter Basics
	To Start ShowMe TV Transmitter
	ShowMe TV Transmitter Terminology
	ShowMe TV Transmitter Menus
	Transmitter Menu
	Help Menu

	Broadcast Status Area
	Program List
	Controlling the Current Broadcast
	To Set ShowMe TV Transmitter Properties

	Creating a New Broadcast
	To Configure Broadcast Information
	Transmit Continuous Broadcasts.

	To Configure Audio and Video Information
	Broadcasting From Audio/Video Inputs or ShowMe�TV File
	Switching Between Video Inputs
	Selecting Video Compression
	Limiting Motion Speed
	Adjusting Compression Quality
	Adjusting Picture Resolution
	Switching Between Audio Inputs
	Selecting Audio Quality
	Adjusting Audio Input Level

	To Configure Audience Information
	Choosing Open Broadcast or Closed Broadcast
	Specifying Members of a Closed Broadcast

	To Configure Network Information
	Choosing Multicast or UDP Broadcast
	Choosing a TTL for Multicast

	To Change the Configuration Defaults
	To Preview a Broadcast
	Avoiding Audio Feedback While Previewing
	To Change the Broadcast


	Broadcasting
	To Go On the Air
	Controlling the Current Broadcast
	To Use the Statistics Window
	To Send Mail to a Member of the Audience
	To Send a Message to the Entire Audience

	Ending the Broadcast
	To Go Off the Air
	To Remove a Broadcast


	Broadcasting a ShowMe�TV File
	Controlling the Broadcast of a ShowMe�TV File
	To Broadcast Audio Only

	ShowMe TV Transmitter Daemon
	Troubleshooting

	Using the ShowMe TV Address Book
	ShowMe TV Address Book Basics
	To Start ShowMe�TV Address Book
	Address Book Menus

	Using the Address Book
	To Create an Address Book
	To Open an Address Book
	To Change Your Default Address Book
	To Create a New Card
	To Edit a Card
	To Import Cards to Your Address Book
	To Export Cards to Other Address Book Users
	To Print Cards From Your Address Book
	To Duplicate a Card
	To Delete and Undelete a Card
	To Delete a Card
	To Undelete a Card

	To Add and Remove Card Fields
	To Find a Card
	Sorting the Address Book
	Saving an Address Book

	Using Address Book Group Cards
	To Create or Add a Group Card
	To Edit a Group Card


	Audio, Video, and File Formats
	Technical Topics
	Using Motif Applications (for OPEN LOOK Users)
	Customizing Motif Window Manager (for OPEN LOOK Users)
	Customizing ShowMe TV Window Colors (Xdefaults)
	ShowMe TV Configuration Files
	ShowMe�TV Default File
	ShowMe�TV System Configuration File

	Host Name Addresses
	Name Services
	Hosts Database

	Using Multicast
	Installing Multicast
	TTL on Your Network
	For More Information on Multicast

	Calculating Network Bandwidth Use
	Compression
	CellB
	JPEG
	H.261

	Picture Resolution
	Motion Speed

	Audio Considerations
	Conserving Network Bandwidth
	X-terminal Support
	Preventing Color Flash
	Locking in a Colormap

	Graphics Compatibility
	Hardware and Software Limitations

	Index

