NAME | SYNOPSIS | DESCRIPTION | FILES | ATTRIBUTES | SEE ALSO
#include <sys/stropts.h>
#include <sys/ethernet.h>
#include <sys/dlpi.h>
#include <sys/gld.h>
The Xircom Pocket Ethernet driver (pe) is a multi-threaded, loadable, clonable, STREAMS hardware driver supporting the connectionless Data Link Provider Interface, dlpi(7P), with a Xircom Pocket Ethernet Adapter III (PE3). Multiple PE3 controllers installed within the system are supported by the driver.
The pe driver provides basic support for the PE3 hardware. Functions include chip initialization, frame transmission and reception, multicast and "promiscuous" support, and error recovery and reporting.
The pe driver supports both bi-directional and unidirectional parallel ports. The Port and Adapter type is automatically detected and set when the driver initializes.
It is important not to attempt to use any other driver that may also use the same port when the pe driver is operational. This may interfere with network traffic that is currently being sent or received by the PE3 adapter.
The cloning, character-special device /dev/pe is used to access all PE3 controllers installed within the system.
The pe driver is dependent on /kernel/misc/gld, a loadable kernel module that provides the pe driver with the DLPI and STREAMS functionality required of a LAN driver. See gld(7D) for more details on the primatives supported by the driver.
The values returned by the driver in the DL_INFO_ACK primitive in response to the DL_INFO_REQ from the user are as follows:
The max SDU is 1500 (ETHERMTU).
The min SDU is 0.
The dlsap address length is 8.
The MAC type is DL_ETHER or DL_CSMACD.
The sap length value is -2, meaning the physical address component is followed immediately by a 2-byte sap component within the DLSAP address.
The broadcast address value is Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).
See attributes(5) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
---|---|
Architecture | x86 |
NAME | SYNOPSIS | DESCRIPTION | FILES | ATTRIBUTES | SEE ALSO