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Preface

The Forte TeamWare User’s Guide describes how to use the Forte™ for Java™,

TeamWare module (hereinafter referred to as Forte TeamWare) code management

tools. This manual is intended for the software developer, but can be used by anyone

involved in team development of a product, including integrators, administrators,

and release engineers.

This manual assumes some understanding of the Solaris™ Operating Environment

and UNIX® commands. You do not needs to have previous experience with the

Source Code Control System (SCCS).

Multiplatform Release

This release of Forte TeamWare supports the following platforms and operating

systems:

■ Solaris 8 SPARC™ Platform Edition
■ Solaris 7 SPARC™ Platform Edition
■ Microsoft Windows 2000

■ Microsoft Windows NT 4.0

■ Red Hat Linux 6.2

Microsoft Windows Issues

Appendix C, “Using Forte TeamWare in a Microsoft Windows Environment,”

discusses special considerations to note when using Forte TeamWare in a Microsoft

Windows environment. If you install Forte TeamWare on the Microsoft Windows
1



platform, the installation creates shortcuts in a TeamWare subdirectory of the Start

menu. However, if you use the shortcut to launch Forte TeamWare from the Start

menu, it operates as a standalone application—that is, without any integration into

the Forte for Java environment. See “Starting Configuring” on page 17 for further

details.

Using Forte TeamWare as an Integration

Module

Chapter 11, “Using Forte TeamWare From Within the Forte for Java IDE,” describes

issues related to using Forte TeamWare as a module within the Forte for Java

integrated development environment (IDE). The chapter includes charts detailing

access to Forte TeamWare commands directly from the Forte for Java GUI.

Accessing Man Pages

Man pages (text-based online documentation traditionally found on UNIX systems)

are not available through the conventional means—that is, by typing man command—

in Forte TeamWare. Instead, man pages are available through the Forte TeamWare

online help system, which is accessible from the Help menu.

To access man pages, choose Command Reference in the upper contents frame of the

Forte TeamWare online help system.

How This Book Is Organized

Chapter 1, “Introduction to Forte TeamWare,” provides a full introduction to the

Forte TeamWare product.

Chapter 2, “Managing Workspaces,” presents step-by-step instructions on how to

create and manage workspaces.

Chapter 3, “Advanced Workspace Management,” provides step-by-step instructions

on how to customize Configuring and perform more advanced tasks on workspaces.
2 Forte TeamWare User’s Guide • August 2001



Chapter 4, “Controlling Workspace Access,” provides step-by-step instructions on

how to grant or deny permission to perform workspace transactions.

Chapter 5, “Managing Files,” provides step-by-step instructions on how to check out

and put back files.

Chapter 6, “Resolving Differences Between Files,” provides step-by-step instructions

on how to resolve the differences between files using the Merging tool.

Chapter 7, “Advanced File Management,” provides step-by-step instructions on how

to view file history, move or rename files, and customize Versioning.

Chapter 8, “Using Freezepointing,” provides step-by-step instructions on how to

create and use freezepoints.

Chapter 9, “Using the dmake Utility,” describes dmake, a tool that allows you to

distribute builds over several hosts concurrently. The operation of dmake is

described, and instructions given on how to distribute your build efficiently.

Chapter 10, “Forte TeamWare Shortcuts,” provides information on how to use Forte

TeamWare commands at the command line, and also lists mouse and keyboard

shortcuts.

Chapter 11, “Using Forte TeamWare From Within the Forte for Java IDE,” discusses

Forte TeamWare as an integration module to the Forte for Java IDE and provides

information on how to access Forte TeamWare commands from within that

environment.

Chapter 12, “Forte TeamWare Architecture,” lists metadata files, describes how

Configuring manipulates SCCS history files during file transfer transactions, and

explains SCCS Mergeable IDs (SMIDs) and SCCS delta IDS (SIDs).

Appendix A, “Error and Warning Messages,” lists error messages and warnings.

Each message is defined and a possible solution is provided.

Appendix B, “Troubleshooting,” lists some common problems with Forte TeamWare

and their solutions.

Appendix C, “Using Forte TeamWare in a Microsoft Windows Environment,”

describes issues specific to using Forte TeamWare on Microsoft Windows.

The Glossary provides an explanation of terms used in this manual.
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Typographic Conventions

TABLE P-1 shows the typographic conventions that are used in Forte for Java

documentation.

Shell Prompts

TABLE P-2 shows the default system prompt and superuser prompt for the C shell,

Bourne shell, and Korn shell.

TABLE P-1 Typographic Conventions

Typeface Meaning Examples

AaBbCc123 The names of commands, files,

and directories; on-screen

computer output

Edit your .login file.

Use ls -a to list all files.

% You have mail .

AaBbCc123 What you type, when

contrasted with on-screen

computer output

% su
Password:

AaBbCc123 Book titles, new words or terms,

words to be emphasized

Read Chapter 6 in the User’s Guide.

These are called class options.

You must be superuser to do this.

AaBbCc123 Command-line placeholder text;

replace with a real name or

value

To delete a file, type rm filename.

TABLE P-2 Shell Prompts

Shell Prompt

C shell %

Bourne shell and Korn shell $

C shell, Bourne shell, and Korn shell superuser #
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Related Documentation

You can access documentation related to the subject matter of this book in the

following ways:

■ Through the Forte TeamWare Release Notes.
The Forte TeamWare release notes are available in HTML format. To access them,

in your Netscape™ Communicator 4.0 or compatible version browser, open the

following file:

FFJ-user-dir/docs/com/sun/teamware/relnotes/relnotes.html

Where FFJ-user-dir is the installation directory in which Forte TeamWare is

installed.

■ Through the Forte TeamWare Online Help.
Choose Help ➤ About Documentation in any Forte TeamWare tool window.

■ Through the Forte for Java Online Help.
Choose Help ➤ Documentation in the Forte for Java main window.

■ Through the Internet at the docs.sun.com sm Web site. You can search for a

specific book title or you can browse by subject, document collection, or product

at the following Web site:

http://docs.sun.com
Preface 5
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CHAPTER 1

Introduction to Forte TeamWare

This chapter provides an overview of the Forte TeamWare software. The following

topics are discussed:

■ What Forte TeamWare Does

■ Basic Concepts

■ Forte TeamWare Models

■ Working With Forte TeamWare

■ Forte TeamWare Scenarios

The remaining chapters provide detailed instructions for using Forte TeamWare tools

and features.

What Forte TeamWare Does

Forte TeamWare is a source management tool designed for use by a team of people

who develop software concurrently. Forte TeamWare tools save time and increase

your organization’s productivity by simplifying source code management. More

specifically, Forte TeamWare enables you to:

■ Configure your working directories and subdirectories (also called folders) into

workspaces to suit the phases of your project and the structure of your team.

■ Work on individual versions of the same file, while ensuring that everyone has

the latest version in their own individual workspaces.

■ Lock a file for editing to prevent unmanaged conflicts inside a single workspace.

■ Inspect and selectively merge versions of a single file that was edited in different

workspaces.

■ Find and “freeze” a particular version of a workspace, archiving it for later use.

■ Build an application for release from selected files and directories—either locally

(serially or in parallel) or across distributed systems.
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■ Notify team members automatically of each action that has been taken on a file.

Forte TeamWare's version-control capability is based on an underlying program

called SCCS (Source Code Control System). The workspaces you configure with

Forte TeamWare tools act only upon files that have been placed under SCCS control.

If you have files under the RCS source-code control system, they can be migrated to

Forte TeamWare.

Basic Concepts

The Forte TeamWare development model it is based on the concept of copy-modify-
merge. Also fundamental are the concepts of parent and child workspaces and the

relationships between them. Forte TeamWare works only on files under UNIX Source

Code Control System (SCCS) version control, therefore you also need to be familiar

with SCCS. Each of these concepts is briefly described in the following sections.

Why Use Forte TeamWare?

Often the most difficult challenge in large software development projects is

coordinating the work of developers who share common and interdependent files.

If developers have private copies of the source code, the changes they make to the

source base are difficult to track when all of the code is finally merged. One solution

is to allow serial access to the common files, one developer at a time. Unfortunately,

when only one programmer at a time has access to the code, a bottleneck occurs.

Forte TeamWare supports coordinated parallel development, because it allows you

to create one or more isolated, private workspaces for each developer. Each

developer copies project files from a central workspace into his or her own private

workspace, makes changes to files, and then copies those changes back to the central

workspace.

Parent and Child Workspaces

Your team does its work in directories (also called folders) and files. To gain the

advantages of Forte TeamWare, place all your working directories in one high-level

directory. You then use Forte TeamWare to transform that directory hierarchy into a

workspace. Forte TeamWare uses these tools:
8 Forte TeamWare User’s Guide • August 2001



■ Configuring – Forms intelligent connections between workspaces that are owned

by different Forte TeamWare users. Configuring also maintains a history of the

workspaces and all of the transactions performed.

■ Versioning – Maintains a history of the files and the deltas, or changes, to each file.

■ Merging – Protects against changes to files overwriting each other.

■ Freezepointing – Captures a “snapshot” of the workspace.

Forte TeamWare converts your high-level directory into an intelligent workspace.

When you create a new workspace from a copy of a workspace, a special

relationship is created between the first workspace and the new copy. The first

workspace is considered the parent workspace of the newly created child workspace.

Rather than risk corrupting the master files in the parent workspace, each team

member works on copies of those files in his or her own child workspace. Forte

TeamWare lets team members easily copy directories back and forth between their

child workspaces and the parent workspace.

A parent workspace can have many child workspaces – one or more for each team

member. Team members populate their child workspaces with the directories and

files they need. A particular child workspace can contain a copy of every directory

and every file in the parent workspace, or only a subset of the parent’s contents.

In a complex project encompassing many levels, one workspace may be the parent of

some workspaces and the child of another workspace.

Source Code Control System (SCCS)

Forte TeamWare recognizes only those files that are under the Source Code Control

System (SCCS). Each time you check out a file, change it, and check it in again, SCCS

keeps track of the changes. The difference between two versions of a file is known as

a delta. Forte TeamWare manages files based on SCCS deltas. When you edit, move,

or copy a file, Configuring copies or merges the file’s SCCS history file. The way

Forte TeamWare manipulates and merges SCCS history files is described in “How

Configuring Merges Files” on page 163.

See the Solaris Programming Utilities Guide for a description of SCCS.

Forte TeamWare Models

The following two models show how Forte TeamWare can be used in software

development projects:
Chapter 1 Introduction to Forte TeamWare 9



■ The copy-modify-merge model, which is the basic model on which Forte

TeamWare software is built

■ Forte TeamWare’s user model for teams and projects—at setup time and for day-

to-day use

The Copy-Modify-Merge Model

Forte TeamWare configuration management tools are based on a concurrent-

development model called Copy-Modify-Merge. When you use these tools in your

daily work on project files, you follow these basic steps:

1. Bring over (copy) the latest version of a file or directory from the parent

workspace.

2. Modify a file from that directory inside your own child workspace.

3. Put back that file to the parent workspace. If someone else has worked on another

copy of the same file and put it back from his or her own workspace to the parent

workspace, you can selectively merge the two sets of changes.
10 Forte TeamWare User’s Guide • August 2001



In the following Copy-Modify-Merge example, you see a common software

development scenario in which two people are working simultaneously on the same

or related parts of a project.

Both you and Developer x copy the

same file from the project integration

workspace to your separate, individual

workspaces.

Developer x changes the file and copies

the changed file back into the

integration workspace.

You modify the same file in your

workspace and attempt to copy the file

back into the integration workspace.

TeamWare Configuring blocks your

attempt to copy, because it would

overwrite Developer x’s changes.

Configuring informs you of the

conflicting changes. You copy the file

containing Developer x’s changes from

the integration workspace to your

workspace.

Using the Configuring tool, you

resolve the conflicts, merge the

changes, test the changes, and

successfully copy the file back to the

integration workspace.

Integration
worspace

Your workspace Dev x’s workspace

Your workspace Dev x’s workspace

Integration
worspace

Dev x’s workspaceYour workspace

Dev x’s workspaceYour workspace

Integration
worspace

Your workspace Dev x’s workspace

Integration
worspace

Integration
worspace
Chapter 1 Introduction to Forte TeamWare 11



The Team-Project Model

The Copy-Modify-Merge model for an individual user fits into Forte TeamWare's

larger team-development model for a team. Over the life of a typical large-scale

project, your team may need to set up and use a complex project structure and

process to reflect your project’s shape and schedule. Following is an example of such

a structure and process—first, during setup time, and second, as the day-to-day

work continues.

Forte TeamWare Environment Setup

In the beginning of a project, before team development starts, the following steps

must be completed.

1. One team member—perhaps a team leader or a system administrator—sets up a

group of parent workspaces to encompass separate phases and divisions of your

project, such as:

■ Alpha – The workspace where your team’s latest files reside

■ Integration – The workspace where team leaders combine everyone's work

■ Team Workspaces – The workspace for each engineering team

■ Beta/Final - The workspace for different versions of builds that are based on

criteria such as project phase, release, platform, or locale

2. Before starting to work on files, each team member sets up his or her own child

workspace in relation to the team workspace (Dev1, Dev2, Dev3).

3. Each team member brings over from the parent workspace a copy of the

directories and files he or she will need to modify.
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FIGURE 1-1 Setting Up a Typical Forte TeamWare Environment

Now the team’s environment is set up for concurrent development. To continue the

example, this team uses their workspace structure as described in the next section.

Day-to-Day Work in a Forte TeamWare Environment

As the members of your development team work on files and directories, and as the

team moves through the process of developing an application, they do the following

tasks on a regular, iterative basis.

1. Team members bring over directories from the team parent workspace to their

own child workspaces.

■ Each team member must do bringovers frequently. This practice keeps the

team's changes freshly propagated throughout their workspaces, which is

necessary for everyone to stay up-to-date.

■ Team members make changes in their individual child workspaces, and then

put back the changed directories to the team parent workspace.

■ Forte TeamWare automatically notifies whoever is on the notification list when

changes have been put back.

Alpha

Final

Engine

Integration

Utilities GUI

Beta

Dev1 Dev2 Dev3
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2. Team leaders check the changes that team members have put back. Team leaders

then put back those changed directories from the team workspaces to the

Integration workspace.

3. When the buildmaster is notified that the files in the Integration workspace are

ready, the buildmaster integrates all the files, builds the application, and puts

back the resulting directories to the Alpha workspace.

4. When the software testers are notified that Alpha workspace is ready, they test

the application in the Alpha workspace.

5. When the alpha phase of the product is complete, the Beta workspace is created

as a child of the Alpha workspace. Then the Integration workspace is reparented

to the Beta workspace.

6. Periodically, a team member sets aside or archives a particular “snapshot” of a

workspace, called a freezepoint, for later use. Team members can then extract a

workspace from the freezepoint that was created, with all of its contents reflecting

that point in time.

Working With Forte TeamWare

The following table briefly explains which Forte TeamWare tool or feature you use

for which task.

TABLE 1-1 Uses for Forte TeamWare Tools

Task Forte TeamWare Tool

Turn a directory into a workspace Configuring

Create a child workspace from the parent workspace Configuring

Bring over directories from a parent workspace to a child workspace Configuring

Check out a file from your own workspace Versioning

Modify and save a file Versioning

Check in a file to your workspace Versioning

Create new files in a workspace Versioning

Put back copies of new and modified files to the parent workspace Configuring
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Forte TeamWare Scenarios

Users have different kinds of interaction with Forte TeamWare depending on their

roles and responsibilities within their projects and teams. Consider the following

two scenarios as examples.

Joining an Existing Team

If you are the newest member of a team that has been using Forte TeamWare

configuration management tools for concurrent software development, and if their

workspaces are already set up, follow these steps.

To join an existing team:

1. Find out the configuration of your team's parent workspace or workspaces.

2. Find out your team’s policies, processes, and schedules for builds.

3. Set up a child workspace for yourself, in which you will do your work.

4. Set up e-mail notifications within Forte TeamWare.

5. Bring over the directories you want from the parent workspace.

6. Check out each file to modify it; save the file; and check it in again.

7. Add files to your child workspace and delete files from the workspace as
necessary. Place any new files under SCCS control.

8. Put back the whole directory to the parent workspace when you are finished
changing files.

Your team is automatically notified of the changes you made.

Merge conflicting versions of a file that two or more team members

have modified in their own workspaces

Merging

Put back the resulting merged file to the parent workspace Configuring

Preserve a particular workspace version for later use Freezepointing

TABLE 1-1 Uses for Forte TeamWare Tools (Continued)

Task Forte TeamWare Tool
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9. Merge the changes and then put back the resulting file – if you are attempting to
put back a file that another team member has already changed and put back to the
parent workspace.

Setting Up a Forte TeamWare Environment

If no Forte TeamWare workspaces for your project exist yet, and you are responsible

for setting up the workspaces, follow these steps.

To set up a Forte TeamWare environment:

1. Decide how to configure your team's workspaces, based on criteria such as the
following:

■ The project's discrete phases

■ The geographical distribution of your team, or the networks and file systems they

use

■ The platforms on which and for which the application is being developed

■ The release structure of your project

2. Create the parent workspaces for your project.

3. Notify your team of the workspaces you have created so that they can now create
their child workspaces.

4. Set up and publish agreements within the team for the following processes:

■ Regular bringovers

■ Putbacks

■ Periodic cutoffs (such as before weekly builds)

■ Periodic putbacks from lower parent workspaces to higher ones

■ Periodic builds

■ Freezepoints of builds or other milestone-related versions

5. Set up your own child workspaces and use Forte TeamWare tools on a regular
basis as shown in “Joining an Existing Team” on page 15 if you are also involved
in developing the application along with your team.
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CHAPTER 2

Managing Workspaces

To use Forte TeamWare’s features, you must put your files and directories into Forte

TeamWare workspaces. A workspace is a specially designated directory, its

subdirectories, and the files contained in those directories. Using Forte TeamWare

tools, you manage the files in the workspace and the relationships with other

workspaces. Use the Configuring tool to view workspaces, their relationships, and to

execute commands on workspaces. This chapter shows you how to perform these

basic tasks in Configuring:

■ Starting Configuring

■ Creating a Parent Workspace

■ Creating Child Workspaces

■ Propagating Changes Across Workspaces

■ Undoing Changes to a Workspace

■ Renaming or Moving Workspaces

■ Deleting or Reconverting Workspaces

■ Viewing Workspace History

Starting Configuring

The Configuring tool is the entry point into Forte TeamWare. Depending on how it is

launched, Forte TeamWare will operate as either a stand-alone application or as an

integrated feature within the Forte for Java IDE.

When you start Forte TeamWare Configuring, the Configuring window opens (see

FIGURE 2-1).
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▼ Launching Forte TeamWare from the Forte for

Java IDE

If you are using Forte for Java, you can start Forte TeamWare Configuring by doing

either of the following:

■ Click the Configuring button in the Forte for Java TeamWare tool bar

Note: the abbreviated Forte for Java TeamWare toolbar appears by default. To

access the full Forte for Java TeamWare toolbar, see “Accessing the Forte for Java

TeamWare Toolbar” on page 145 for details.

■ From the Forte for Java Main window:

i. With a Forte TeamWare directory selected in the Forte for Java Explorer
window, click Versioning

ii. Chooset TeamWare Configuring.

■ From the Forte for Java Explorer window:

i. Right click on a Forte TeamWare directory

Note: you must first mount the Forte TeamWare directory before it will appear

in the Forte for Java Explorer window. See “Mounting a Forte TeamWare

Filesystem” on page 144 for details

ii. Choose TeamWare ➤ Configuring

See Chapter 11 for further information about launching Forte TeamWare tools and

accessing commands from within the Forte for Java IDE.

▼ Launching Forte TeamWare as a Stand-Alone

Application

To start Configuring on Solaris or Linux, type the following at a command line:

To start Configuring on Microsoft Windows, under the Start menu choose:

Programs ➤ Forte for Java ➤ TeamWare ➤ CodeManager Tool (Configuring)

% twconfig &
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FIGURE 2-1 Configuring Window With Child and Parent Workspaces Loaded

TABLE 2-1 describes the Configuring window menus.

TABLE 2-1 Configuring Window Menus

Menu Description

File Provides commands for loading, unloading, and creating

workspaces.

View Provides commands to change how the workspaces appear in the

workspace pane.

Workspace Provides commands for managing workspaces.

Actions Opens the Transactions dialog box, which provides commands for

synchronizing files (bringovers, updates, and putbacks).

Options Provides commands for setting the workspace and Configuring

options.

TeamWare Provides commands for starting other Forte TeamWare tools, such

as Versioning, Merging, and Freezepointing.

Help Provides commands to start online help, get a documentation road

map, send comments to the Forte TeamWare development team,

and get the version number.
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See the Forte TeamWare online help for a complete list of these menus and their

functions. For information on how to customize Configuring, see “Using Tool

Properties to Customize Configuring” on page 49.

Creating a Parent Workspace

When you begin to use the Forte TeamWare code management tools, you can start a

new project or import existing project files into Forte TeamWare. To do this, you

must set up workspaces.

Start a project by creating a top-level (parent) workspace. You create a child

workspace from this parent workspace by doing a special copy of the files called a

bringover. You make changes in your own child workspaces, and later integrate your

files with changes made by other developers. When you integrate changes, it is

called a putback.

When you create a workspace, Forte TeamWare creates a subdirectory, named

Codemgr_wsdata , that stores information about the files in the workspace. There

are two ways to create a parent workspace:

■ Create an empty workspace and then populating it with a hierarchy of new

directories and files

■ Create a workspace from an existing hierarchy of files

Note – If you have existing project files, you should know the location (path name)

of the top-level directory before you begin using Configuring.

Creating an Empty Workspace

To create a new empty workspace:

1. Start Configuring.

See “Starting Configuring” on page 17 for details.

2. Choose File ➤ Create Workspace.

3. In the Workspace Directory text box, type a workspace name.

If the directory does not already exist, Forte TeamWare will create it.
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4. Click OK.

TeamWare Configuring creates a workspace in the directory you have specified and

creates an icon for it in the Configuring window.

When you create files, you will have to check the files in to the workspace. See

“Adding Files to a Workspace” on page 67.

Creating a Workspace from Existing Files

If you have a directory containing the files that you want to make into a workspace,

do the following to create a new workspace:

1. Start Configuring.

See “Starting Configuring” on page 17 for details.

2. Choose File ➤ Create Workspace.

3. In the Workspace Directory text box, type the path name to the directory that
contains the files.

4. Click OK.

TeamWare Configuring creates a workspace in the directory you have specified and

creates an icon for it in the Configuring window.

5. Check in the files using Forte TeamWare Versioning.

Forte TeamWare recognizes only files that are under SCCS version control. If your

files are not already under SCCS version control, see “Adding Files to a Workspace”

on page 67.

Creating Child Workspaces

After you create a parent workspace, team members will need to create their own

child workspace with copies of the parent workspace files. Configuring transactions

revolve around these parent-child relationships: bring over files from the parent

workspace; change files in the child workspace; put back files to the parent

workspace.

To create a child workspace:

1. Start Configuring.

See “Starting Configuring” on page 17 for details.
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2. If the workspace from which you must obtain your files is not automatically
loaded, choose File ➤ Load Workspaces.

3. Select the workspace in the Load Workspaces dialog box and click Load
Workspaces.

The parent workspace is loaded and its icon appears in the Configuring window.

4. Choose Actions ➤ Bringover Create.

This opens the Bringover Create Tab in the Transactions dialog box (see FIGURE 2-2).

FIGURE 2-2 Transactions Dialog Box: Bringover Create Tab

5. To select the directories and files to bring over, do one of the following:

■ Accept the default ‘‘./ ’’ to bring over all files

■ Click the Entire Workspace button to bring over all files

■ Click the Add button to display the Add Files dialog box where you can add or

delete specific files.

Add
button
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a. In the Add Files dialog box (FIGURE 2-3), navigate to the files you want to
include.

Navigate through the file system hierarchy by double-clicking on any directory

icon. Double-click on the directory icon to move hierarchically upward in the file

system. To move directly to a directory, type its path name in the Name text box

and click the Load Directory button. You cannot move outside of the parent

workspace hierarchy.

FIGURE 2-3 Add Files Dialog Box

b. Select files and directories.

Click any file or directory icon. You can Shift-click to select multiple files and

directories.

c. Click Add button to add the files to the Bringover Create tab.

d. Click Close.

6. In the Bringover Create tab, click the Bringover button.

A Transaction Output window displays the status of the bringover and indicates

Transaction Output window displays the status of the bringover and indicates when

the bringover is complete.

You now have a child workspace from which you can check out files, make changes

to them, and put back to the parent workspace. To learn how to check out files, see

“Checking In a File” on page 70. To learn how to put back files to a parent

workspace, see “Propagating Changes Across Workspaces” on page 24.
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Propagating Changes Across
Workspaces

After you have created a hierarchy of workspaces, it is important to keep the

contents synchronized. All Configuring transactions are performed from the

perspective of the child workspace; hence the Bringover transaction “brings over”

groups of changes from the parent to the child workspace. Inversely, the Putback

transaction “puts back” changes from the child workspace to its parent.

Use the Bringover Update transaction to update changes from the parent workspace

to a child workspace. Use the Putback transaction to take changes in a child

workspace and put them back to a parent workspace. Putting the files back into the

parent makes those changes available to other members of the team.

Updating a Child Workspace (Bringover Update)

To initiate a Bringover Update transaction:

1. In Configuring, load your workspace with File ➤ Load Workspace.

2. Click on your workspace to select it.

3. Choose Actions ➤ Bringover Update.

This displays the Bringover Update tab of the Transactions dialog box (see

FIGURE 2-4).

The parent and child names are automatically inserted in the Workspaces text boxes.

You can insert a new path name, and edit the text box at any point.
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FIGURE 2-4 Transactions Dialog Box: Bringover Update Tab

4. To select the directories and files to bring over, do one of the following:

■ Accept the default ‘‘./ ’’ to bring over all files

■ Click the Entire Workspace button to bring over all files

■ Click the Add button to display the Add Files dialog box where you can add or

delete specific files.

Add
button
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a. In the Add Files dialog box (see FIGURE 2-3), navigate to the files you want to
include.

Navigate through the file system hierarchy by double-clicking on any directory

icon. Double-click on the directory icon to move hierarchically upward in the file

system. To move directly to a directory, type its path name in the Name text box

and click the Load Directory button. You cannot move outside of the parent

workspace hierarchy.

b. Select files and directories.

Click any file or directory icon. You can Shift-click to select multiple files and

directories.

c. Click Add Files to add the files to the Bringover Update tab.

d. Click Close.

5. In the Bringover Update tab, click the Start Bringover button.

A Transaction Output window displays the status of the bringover and indicates

when the bringover is complete. You now have the most recent copies of the files

from the parent workspace in your child workspace.

Note – If you want to preview your transaction, click the Preview option to verify

your transaction before you transfer any files.

Putting Back Changes to a Parent Workspace

To initiate a Putback transaction:

1. In Configuring, load your workspace with File ➤ Load Workspace.

2. Click on your workspace to select it.

3. Choose Actions ➤ Putback.

This displays the Putback tab of the Transactions dialog box (see FIGURE 2-5).

The names are automatically inserted in the Workspaces text boxes. You can insert a

new path name and edit the text box at any point.
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FIGURE 2-5 Transactions Dialog Box: Putback Tab

4. To select the directories and files to put back, do one of the following:

■ Accept the default ‘‘./ ’’ to bring over all files

■ Click the Entire Workspace button to bring over all files

■ Click the Add button to display the Add Files dialog box where you can add or

delete specific files.

Add
button
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a. In the Add Files dialog box (see FIGURE 2-3), navigate to the files you want to
include.

Navigate through the file system hierarchy by double-clicking on any directory

icon. Double-click on the directory icon to move hierarchically upward in the file

system. To move directly to a directory, type its path name in the Name text box

and click the Load Directory button. You cannot move outside of the parent

workspace hierarchy.

b. Select files and directories.

Click any file or directory icon. You can Shift-click to select multiple files and

directories (see FIGURE 2-3).

c. Click Add Files to add the files to the Putback tab in the Transactions dialog
box (FIGURE 2-5).

d. Click Close.

5. Type a comment that describes the Putback transaction.

This comment is included in the Workspace History and can be up to 8 Kilobytes

long.

6. In the Putback tab, click the Putback button.

A Transaction Output window displays the status of the putback and indicates when

the putback has completed. You have now synchronized the contents of your files

and the files in the parent workspace.

Note – When you try to perform a putback on a file that you have changed in your

child workspace, but which has already been changed in the parent workspace,

Configuring prevents you from putting back the file until you have resolved the

differences between them. See Chapter 6.

Action taken during the Putback transaction can be reversed using the Undo

transaction. Refer to the next section, “Undoing Changes to a Workspace,” for

details.

Undoing Changes to a Workspace

You can reverse (undo) the action of the most recent Bringover or Putback

transaction in a workspace by using the Undo tab in the Transactions dialog box.

Undo the Putback or Bringover transaction in the destination workspace (the one in

which the files are changed). You can undo a Bringover or Putback transaction as
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many times as you want until another Bringover or Putback transaction occurs in

that workspace; only the most recent Bringover or Putback transaction can be

undone.

If a file is updated or found to be in conflict by the Putback or Bringover transaction,

the Undo transaction restores the file to its original state. If a file is “new” (created

by the Bringover/Putback transaction), then it is deleted.

To initiate an Undo transaction:

1. Specify the workspace in which to reverse the transaction.

If you select a workspace icon on the Workspace Graph pane prior to displaying the

Undo layout, its name is automatically inserted in the Workspace Directory text box.

At any point, you can insert a new path name followed by a Return, or change the

text box.

2. Click Undo to initiate the transaction.

Renaming or Moving Workspaces

Configuring does all the administrative work of keeping track of workspaces, files

and their relationships. It is important that you use Configuring to rename, move or

move or delete workspaces so it can maintain workspace histories and the

relationships between workspaces.

Note – Use these procedures to rename or move workspaces, rather than with the

operating system commands for moving or renaming files. Using the procedures

detailed below will maintain the parent-child relationships of workspaces.

Rename or move workspaces with the move command available from the

Configuring Workspace menu.

To rename or move a workspace:

1. Load the workspace with File ➤ Load Workspaces.

2. Select the workspace by clicking on it once.

3. Choose Workspace ➤ Rename.

4. In the Rename dialog box, type in the new name or location for your workspace.

5. Click OK.

The workspace with the new name or location appears in the Configuring window.
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Deleting or Reconverting Workspaces

Use these procedures to delete or reconvert workspaces, rather than using Operating

System commands.

Deleting a Workspace

Note – This procedure permanently removes files and/or directories from your

system.

To delete a workspace:

1. Load the workspace with File ➤ Load Workspaces.

2. Select the workspace by clicking on it once.

You can Shift-click to select multiple workspaces.

3. Choose Workspace ➤ Delete.

4. Select the Delete Source and Codemgr_wsdata Directory button

5. Click OK in the Delete Confirmation dialog box.

The workspace icon disappears in the Configuring window. The corresponding

directory, its files and subdirectories, are permanently deleted.

Reconverting a Workspace

To convert a Forte TeamWare workspace back into a regular directory:

1. Load the workspace with File ➤ Load Workspaces

2. Select the workspace by clicking on it once.

You can Shift-click to select multiple workspaces.

3. Choose Workspace ➤ Delete.

4. Select the Delete Codemgr_wsdata Directory Only button.

5. Click OK in the Delete Confirmation dialog box.
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The workspace icon disappears in the Configuring window, but the files remain

intact.

Viewing Workspace History

Configuring transactions are logged in the workspace history file.

■ Commands that affect a single workspace are logged only in that workspace.

■ Commands that affect more than one workspace are logged in both the source

and destination workspaces. Although command entries are logged in both the

source and destination workspaces, the list of changed files is entered only in the

destination directory.

You can view the contents of the workspace history file to track or reconstruct

changes that have been made to a workspace over time. Command log entries

consist of the underlying command-line entries. If you have any questions about the

meaning or syntax of a command, refer to its man page for details. For information

about accessing man pages, see Chapter 10.

To view the history of a workspace:

1. From the Configuring Window, click on a workspace to select it.

2. Choose Workspace ➤ View History.

The Workspace History Viewer opens (see FIGURE 2-6).

Changing the Workspace History Viewer Display
You can customize the following in the Workspace History Viewer:

■ How much transaction information is included

■ In what order the transactions appear

■ Which items are included
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By default, the status of the transaction is the only transaction information displayed

in the Workspace History Viewer. TABLE 2-2 shows the categories for the Workspace

History Viewer Display.

TABLE 2-2 Workspace History Viewer Display Categories

Category Contents

Time Date and time of the transaction

Operation Transaction name

User User that initiated the transaction

Host Name of the machine from which the transaction was initiated

TW Release Which version of TeamWare executed the transaction

Status Exit status of the transaction
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FIGURE 2-6 Workspace History Viewer
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Adding or Removing Transaction Information

From the Workspace History Viewer

To add or remove transaction information:

1. In the Workspace History Viewer Window, choose View ➤ Options.

2. In the Workspace History Viewer Options dialog box, check the items in the
Display section that you want included in or removed from the Workspace
History report.

3. Click OK.

The Workspace History Viewer Options dialog box disappears, and the details you

have selected are included in the Workspace History Viewer window.

Sorting Transaction Information in the Workspace

History Viewer

By default, transactions are sorted chronologically, with the most recent transactions

at the bottom.

1. In the Workspace History Viewer Window, choose View ➤ Options.

2. In the Workspace History Viewer Options dialog box, click one of the Sort By
radio buttons.

3. Click OK.

The transaction information is sorted based on the category you selected.

Adding Filtering Options to the Workspace

History Viewer

You can filter the Workspace History transaction information by Operation, User,

Host, Release, or Exit Status. By default, all transactions appear in the Transaction

Information pane and the only filter option displayed is User. If the category you

want to use to filter transactions does not appear in the Workspace History Viewer,

you must add the option.

To add filter options to the Workspace History Viewer window:

1. In the Workspace History Viewer Window, choose View ➤ Options.
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2. In the Options dialog box, check the items in the Filter section that you want to
use as a filter.

3. Click OK.

The items you selected appear in the Workspace History Viewer window.

Filtering Transaction Information From the

Workspace History Viewer

To filter transaction information:

1. In the Workspace History Viewer Window, click the filter check box above the
filter(s) you want to use: click Operation, User, Host, Release or Exit Status.

You can select more than one filter.

2. Type the user, host, or release you want to filter by, or select an Operation or Exit
Status.

3. Click Apply Filter.

Searching for Transactions

If you want to find a particular transaction, you can search for text strings in the

comments or command log.

To search the Command Log:

1. In the Workspace History Viewer, choose Find ➤ Search Comments.

2. In the Search Comments dialog box, type a search string.

3. Click Find Next.

If Configuring finds the search string, it will highlight it in the History Viewer

Comments pane.

To search the Command Log:

1. In the Workspace History Viewer, choose Find ➤ Search Command Log.

2. In the Search Command Log dialog box, type a search string.

3. Click Find Next.

If Configuring finds the search string, it will highlight it in the History Viewer

Command Log pane.
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CHAPTER 3

Advanced Workspace Management

To learn basic Configuring tasks, see Chapter 2. This chapter covers these advanced

Configuring tasks:

■ Using Bringover and Putback Options

■ Creating Customized Bringover and Putback File Lists

■ Notifying Users of Transactions

■ Giving a Workspace a Descriptive Name

■ Reparenting a Workspace

■ Using Tool Properties to Customize Configuring

■ Configuring Environment Variables

■ Converting From a Revision Control System Project

Using Bringover and Putback Options

There are two types of options for bringovers/putbacks:

■ Options in the Transactions dialog box that are available to you each time you

perform a bringover/putback

■ Tool properties that you set for all bringovers/putbacks

Setting Options During a Bringover or Putback

To access options during a bringover/putback:

1. In the Configuring window, choose a transaction from the Action Menu:

■ Bringover Create

■ Bringover Update

■ Putback
37



2. Click a check box in the Options section (see FIGURE 3-1).

FIGURE 3-1 Transactions Dialog Box: Options Section

Options
Section
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TABLE 3-1 describes each check box in the Options section of the Bringover Create,

Bringover Update, and Putback tabs in the Transactions dialog box.

Setting Tool Properties

Use the Bringover/Putback tab of the Tool Properties dialog to set options for

bringovers and putbacks. To open the Bringover/Putback tab, in the Configuring

Window:

1. Choose Options ➤ Configuring.

2. Select the Bringover/Putback tab.

TABLE 3-1 Bringover and Putback Options

Check Box Description

Preview Previews the results of the transaction. If you invoke a transaction

with this option selected, the transaction proceeds without

transferring any files. You can monitor the output messages in the

Transaction Output window and verify the expected outcome of the

transaction.

Verbose Increases the amount of information displayed in the Transaction

Output window. By default, a message is displayed for each

created, updated, or conflicting file. Verbose causes Configuring to

print a message for each file, including those that are not brought

over. If both the Verbose and Quiet options are specified, the Quiet

option takes precedence.

Quiet Suppresses the output of status messages to the Transaction Output

window.

Delta Comments Includes additional information in the Transaction Output window:

delta number, owner, and comments.

Skip SCCS gets Bypasses the SCCS get command as part of the Bringover

transaction. Normally, g-files are extracted from the SCCS history

after they are brought over. Using this option improves transaction

performance, although it shifts the responsibility to the user to do

the appropriate gets at a later time.

Force Conflicts Causes all updates to be treated as conflicts.

Skip Backups Skips the step of copying the existing files to the

Codemgr_wsdata/backup/files directory in the destination

workspace. Using this option reduces the disk space occupied by

the child workspace and improves transaction performance, but it

removes the option of using Undo.
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TABLE 3-2 lists the options for Bringover/Putback Tool Properties.

Creating Customized Bringover and
Putback File Lists

Configuring maintains a list of files each time you bring over or put back to a

specific workspace. This section explains how Configuring generates a default list of

files for bringovers and putbacks and how you can change the default. You can also

direct Configuring to generate a list of files to bringover or putback using an FLP

(File List Program).

Saving a Default List of Files

Configuring saves the list of files and directories you include when performing a

bringover or putback. This list is loaded by default for the next bringover/putback

transaction in the same workspace. Each time you perform a bringover/putback,

Configuring determines whether the file list is more encompassing than the list from

the previous transaction; if the new list is of a wider scope, the new list replaces the

old.

TABLE 3-2 Bringover/Putback Tool Properties

Check Box Description

Transaction File List:

Autoload

Reads the Codemgr_wsdata/args file and loads it into the File

Pane whenever a new workspace is selected. Deselect this property

when you want to use the same file list for a number of transactions

involving different workspaces. The default is on.

Transaction Output:

Auto Display

Displays the Transaction Output dialog box during Bringover,

Putback, and Undo transactions. If this option is not selected, you

must activate the Transaction Output dialog box using the Show

Output button. The default is on.

Putback: Auto

Bringover Update

Invokes a bringover when a putback determines that files have

changed in the parent. The default is off.

Bringover/Putback:

Warn Comment

Reusing

Displays an alert reminding you that the comments are the same as

the last bringover or putback. The default is on.
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You can reload the default list at any time by clicking Load from args File. This is

useful if you have made changes to the list that you do not want to save. Use Load

List from args File to revert the list to its default state.

If you change the list and want to make the new list the default, click Save to args

File. This is useful if you have eliminated files or directories from the list. If you add

files, Configuring automatically adds them to the args file as part of a Bringover or

Putback transaction.

Generating a Customized List of Files

In addition to explicitly specifying individual files for transfer, you can direct

Configuring to execute a program to create a customized list of files to bringover/

putback.

By default, Forte TeamWare generates a list of files to include in a bringover/

putback transaction by using File List Program (FLP). The FLP generates a list of files

and then passes this list to bringover and putback transactions. Configuring uses a

default FLP named def.dir.flp. The FLP def.dir.flp recursively lists the

names of files that are under SCCS control in directories that you specify in the File

List pane. The files generated by this (or any) FLP are included for transfer, in

addition to any files that you also specify in the File List pane.

If you want to have more control over which files are included in a bringover or

putback, you can write your own FLP. You can, for example, include only files with

a certain extension, such as html. If you want to use your own FLP(s) during a

transaction, you specify them in the File List pane.

To generate your own list of files for a bringover/putback:

1. Write an File List Program (FLP) that creates the list of files you want to bringover/
putback.

For example:

2. In the Bringover/Putback tab, click the File List Programs (FLPs) button.

3. Click Add.

4. Select your FLP in the Add FLPs dialog box.

5. Click Add Files.

# my FLP
cd subdir/webfiles
ls *.html
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This sets the FLP for the current transaction only. You can direct Configuring to

always use your FLP by setting the CODEMGR_DIR_FLPenvironment variable. This

variable overrides Configuring’s default FLP, which is named def.dir.flp .

If you use the bringover or putback commands at the command line, use the -f
option to specify an FLP. For more information about using command line

commands, see Chapter 10.

Notifying Users of Transactions

You can have Configuring automatically send out an email to members of your team

each time a transaction occurs in a workspace. The email will contain the transaction

type, file names, and transaction comments.comments.

To set up email notification:

1. Start Configuring.

See “Starting Configuring” on page 17 for details.

2. Select Workspace ➤ Properties.

3. In the Workspace Properties dialog box, type the name of a workspace.

4. Click the Notification tab.

5. In the Notification tab, click Create Entry.

6. In the Notification Entry dialog box:

a. Type an email address in the Mail To text box.

b. Select the transactions for which you want to generate an email notification.

c. If you want to generate a notification only for certain files in the workspace,
click the Specify button.

■ Click the Add to List button and select the files you want to include.

■ Click Add files.

■ Click Cancel to close the Add Files dialog box.

d. Click OK in the Notification Entry dialog box.

7. To save the entry, click OK in the Workspace Properties dialog box.

% setenv CODEMGR_DIR_FLP /home/workspaces/my.flp
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Giving a Workspace a Descriptive Name

Often, a workspace name is a long path, such as /home/src/rel7/ver2 . Forte

TeamWare lets you give a workspace a name that is more meaningful to users, such

as “current development area” or “Bob’s workspace.” The descriptive name is

displayed in the Configuring window (when you select View ➤ Descriptive names),

and appears as a part of e-mail notification.

You can also create a detailed description of the workspace for your own use. The

detailed description is displayed when you select View ➤ Descriptive names.

To give a workspace a descriptive name:

1. Start Configuring.

See “Starting Configuring” on page 17 for details.

2. Choose File ➤ Load Workspaces.

3. Load the workspace you want to give a descriptive name.

4. Click on the workspace to select it.

5. Choose Workspace ➤ Properties.

6. In the Workspace Properties Dialog Box, click the Description tab.

7. In the Name text box, type a descriptive name for your workspace.

This name appears as a label for the workspace.

8. In the Description text box, type a longer description of your workspace.

This information is stored in the Codemgr_wsdata/description file.

Note – Clicking Load in the Description tab displays description information from

the description file. It does not save any information.

9. Click OK.

To view descriptive names:

■ In the Configuring window, choose View ➤ Descriptive Names.

■ Use the workspace descr command.

The syntax is workspace descr [ -n | -d | -a ] wsname ...
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TABLE 3-3 lists the options to the workspace descr command.

For more information about using command line commands, see Chapter 10.

Reparenting a Workspace

As discussed in “Parent and Child Workspaces” on page 8, the parent-child

relationship is the thread that connects workspaces to each other. Configuring

provides the means for you to change this relationship. This section discusses:

■ Reasons to Change a Workspace’s Parent

■ Ways to Reparent Workspaces

■ Reparenting Example

Reasons to Change a Workspace’s Parent

You can permanently or temporarily change a workspace parent for any of these

reasons:

■ To populate a new top-level workspace. You have just completed Release 1 of

your product and need to begin work on Release 2. You can:

1. Create a new (empty) Release 2 workspace (File ➤ Create Workspace).

2. Make the Release 2 workspace the new parent of the Release 1 workspace.

3. Use the Putback transaction to copy files to the Release 2 workspace.

4. Reparent the Release 1 workspace to its original parent.

■ To move a feature into a new release. If a feature intended for a particular release

is not completed in time, the workspace in which the feature was being

developed can be reparented to the following release’s integration workspace.

TABLE 3-3 workspace descr Command Options

Option Description

-n Lists descriptive name only

-d Lists detailed description only

-a Lists both descriptive name and detailed description (default)

wsname Workspace name
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■ To apply a bug fix to multiple releases. The workspace in which work was done

to correct a bug is reparented from hierarchy to hierarchy. Use the Configuring

Putback transaction to incorporate the changes into the new parent. An example

of this use for reparenting is included in “Reparenting Example” on page 46.

■ To reorganize workspace hierarchies. You can:

■ Add additional levels to the hierarchy

■ Remove levels from the hierarchy (do not specify a new parent during

reparenting)

■ Reorganize workspace branches within the project hierarchy

■ To adopt an orphan workspace. If a file is orphaned (for example, if its

Codemgr_wsdata/parent file has been deleted or its parent is corrupted), you

can use the reparenting feature to restore its parentage.

Ways to Reparent Workspaces

There are two equivalent ways to reparent workspaces permanently: using the

Reparent command or dragging and dropping workspace icons. You can also change

dragging and dropping workspace icons. You can also change a workspace’s parent

during a bringover or putback transaction, but this new relationship lasts only for

the duration of the transaction.

The Reparent Command

To reparent a workspace using the reparent command:

1. Start Configuring.

See “Starting Configuring” on page 17 for details.

2. Choose File ➤ Load Workspaces.

3. Load the workspace you want to reparent.

4. Click on the workspace to select it.

5. Choose Workspace ➤ Reparent.

6. Type the name of the new parent in the Reparent dialog box.

7. Click OK.

If you do not specify a parent workspace in the New Parent Workspace Directory

text box, the workspace is orphaned—it has no parent. The Workspace Graph pane

is automatically adjusted to reflect its new status.
Chapter 3 Advanced Workspace Management 45



Drag-and-Drop Workspace Icons

You can change a workspace’s parent by selecting its icon in the Workspace Graph

Pane, pressing the Control key, and dragging it on top of its new parent’s icon. You

are prompted to confirm the change. The display is automatically adjusted to reflect

the new relationship.

You can also “orphan” a workspace by selecting its icon, pressing Control, and

dragging it to an open area on the Workspace Graph pane. The workspace no longer

has a parent: the display is automatically adjusted to reflect its new status.

Temporary Reparenting

You can change a child workspace’s parent for the duration of a single Bringover

Update transaction by specifying the new parent’s path name in the From Parent

Workspace text field in the Bringover Update tab (Actions ➤ Bringover Update). You

can also change a child workspace’s parent for the duration of a single Putback

transaction by specifying the new parent’s path name in the To Parent Workspace

text box in the Putback tab (Actions ➤ Putback). You change the parent for that

transaction only.

Reparenting Example

When a bug is fixed in a version of a product, often a patch release is made to

distribute the fixed code. The code that was fixed must also be incorporated into the

next release of the product as well. If the product is developed using Forte

TeamWare, the patch can be incorporated relatively simply by means of reparenting.

In the following example, a patch is developed to fix a bug in Release 1.0 of a

product. The patch must be incorporated into the Release 2.0 code, which has

already begun development.
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1. In the Configuring window, you load two workspaces, Release2.0 and
patch1.0 .

These workspaces do not have a parent-child relationship (see FIGURE 3-2).

FIGURE 3-2 Two Unrelated Workspaces

2. Before you make any changes, make a child of the patch1.0 workspace using a
Bringover Create transaction. (see FIGURE 3-3)

FIGURE 3-3 Clone Workspace Created
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3. Change the parent of patch1.0_clone from patch1.0 to Release2.0 using
the reparent command (see FIGURE 3-4).

FIGURE 3-4 Clone Workspace Reparented to Release2.0

4. Update the patch1.0_clone with a Bringover Update from its new parent,
Release2.0 (see FIGURE 3-5).

This includes merging the fixes made for the patch in patch1.0_clone with the

files from Release2.0 .

5. Put back the changes from patch1.0_clone to Release2.0 (FIGURE 3-5).

FIGURE 3-5 Files Brought Over, Merged, and Incorporated into the New Release

6. Now that it has served its purpose, you can delete patch1.0_clone using
Workspaces ➤ Delete.

Bringover Putback
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You now have the two unrelated workspaces, Release2.0, which now includes the

fixes from patch1.0 and patch1.0, which is unchanged from the transactions.
Now the patch is available to the children of Release2.0 (see FIGURE 3-6).

FIGURE 3-6 patch1.0_clone Deleted; Release2.0 Includes Fixes

Using Tool Properties to Customize
Configuring

Using the Tool Properties dialog box (see FIGURE 3-7), you can customize the

behavior of:

■ Configuring window functions

■ Bringover/Putback transactions

■ Resolve transaction

■ Workspace History Viewer

To open the Tool Properties dialog box, choose Options ➤ Configuring. The tabs in

the dialog box lets you switch between the Configuring, Bringover/Putback,

Resolve, and Workspace History Viewer panes. Options in the Resolve tab are

described in “Merging Options” on page 84.

The Configuring tab of the Tool Properties dialog box (see FIGURE 3-7) lets you

change the behavior of the Configuring main window. The specific properties are

described in TABLE 3-4.
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FIGURE 3-7 Tool Properties: Configuring Tab
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TABLE 3-4 Configuring Tool Properties

Property Description

Working Directory Lets you specify the directory to which Configuring actions are

relative.

Workspace Double

Click Action

Lets you specify the commands you want launched when you

double-click on a standard workspace icon. Select Versioning,

History Viewer, or Other and type the path name of a command.

The command executes based on the working directory and your

search path. The default double-click action is Versioning

(twversion ).

Conflict Workspace

Double Click Action

Lets you specify the commands you want launched when you

double-click on workspaces that contain conflicts. Type the path

name required to execute the commands based on the working

directory and your search path. By default, the Resolve Transaction

window opens for conflicted workspaces.

Load Workspaces Select this check box if you want the parent and children of

workspaces you load in the Workspace Graph pane automatically

loaded with them. By default this box is not checked.

Load Children These radio buttons are active only if you have the Load

Workspaces check box checked. Select Selective if you want to

specify which child workspaces to load. Select All if you want all

children to be loaded. By default, all children are loaded.

Display Style Select Tree View if you want workspace hierarchy displayed

graphically from top to bottom. Select Detailed View if you want

workspace hierarchy displayed using indentation. Tree View is the

default. This property corresponds to the first two items under the

View menu in the Configuring main window.

Workspace Names Changes the format of workspace names. This property corresponds

to choosing View ➤ Names in the Configuring main window.

Full Displays workspaces labeled with full path

names in the Workspace Graph pane.

(Default.)

Short Displays workspaces labeled with just the

file name.

Descriptive Displays the descriptive name you have

assigned to a workspace. See “Giving a

Workspace a Descriptive Name” on page 43.

If there is no descriptive name for the

workspace, and you select Descriptive

name, the file name appears in angled

brackets, for example <myworkspace> .
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Configuring Environment Variables

This section provides examples of how to use Configuring environment variables:

■ Loading Workspaces Automatically

■ Setting Focus for Command-Line Commands

■ Setting a Search Path

For information about how to set a default FLP using the CODEMGR_DIR_FLP
variable, see “Generating a Customized List of Files” on page 41.

Loading Workspaces Automatically

You can set the CODEMGR_WSPATHvariable to a single workspace, a list of

workspaces, or to all the workspaces in a directory. To set the CODEMGR_WSPATH
variable to the location of the workspace, type:

To load more than one workspace, put a list of workspaces in quotes:

To load all the workspaces in one directory, set the variable to a directory that

contains multiple workspaces. For example:

% setenv CODEMGR_WSPATH /home/ws/myworkspace

% setenv CODEMGR_WSPATH "/home/ws/myworkspace /home/ws/anotherws"

% setenv CODEMGR_WSPATH /home/ws/myworkspaces
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Setting Focus for Command-Line Commands

The CODEMGR_WSenvironment variable sets a workspace as the default for

command-line commands. Once you set this variable, when you use command-line

commands (bringover, putback, freezept extract, and so on) the workspace will be

used automatically if you don’t specify a workspace with the -w option. To set a

default workspace:

This variable also has the effect of loading the workspaces when you start Forte

TeamWare tools.

For more information about command-line commands, see Chapter 10.

Setting a Search Path

The CODEMGR_PATH_ONLYenvironment variable lets you dictate where Forte

TeamWare tools look for other Forte TeamWare tools. To set the

CODEMGR_PATH_ONLYenvironment variable:

If the CODEMGR_PATH_ONLYvariable is not set, Forte TeamWare looks for other tools

in the current directory the tool is in, and then searches in the directories specified in

the PATHenvironment variable.

Converting From a Revision Control
System Project

The rcs2ws program produces a Configuring workspace from a Revision Control

System (RCS) source hierarchy. It converts a project developed in RCS and works its

way down through the hierarchy to convert the RCS files to SCCS.

The rcs2ws program operates on RCS files under the parent directory and converts

them to SCCS files, then puts the resulting SCCS files into a workspace. If a

workspace does not exist, it is created. The parent directory hierarchy is unaffected

by rcs2ws . The rcs2ws program searches directories recursively.

% setenv CODEMGR_WS /home/workspaces/myworkspace

% setenv CODEMGR_PATH_ONLY /bin/install/Teamware
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To convert files, rcs2ws invokes the RCS co command and the SCCS admin , get,
and delta commands. rcs2ws finds these commands using your PATHvariable. If

rcs2ws cannot find the SCCS commands, it looks for them in the /usr/ccs/bin
directory.

Note – rcs2ws requires that you have the RCS utility. If you get the error

“command not found ,” make sure you have RCS and that the location of RCS is

set in your PATH.

rcs2ws does not convert RCS keywords to SCCS keywords. Keywords are treated as

text in the SCCS delta.

The basic syntax of rcs2ws is:

The -p option names the RCS source directory and is required. Relative file names

are interpreted as being relative to RCS_source_dir.

The -w option names the TeamWare workspace. If the workspace does not exist,

using the -w option will create a workspace. The -w is optional if the workspace

already exists and it is your default workspace, or if the current directory is

contained within an existing TeamWare workspace.

For example, if you want to convert the RCS project /projects/prodA/release1
into a new TeamWare workspace /tw/workspaces/dev1 , type:

If the workspace /tw/workspaces/dev1 already exists and it is your default

workspace, you could type:

Use “.” to specify that every RCS file under RCS_source_dir should be converted. For

example, if you want to convert all the RCS files in the project directory

/projects/prodA , type:

To see a complete list of rcs2ws options, see the rcs2ws(1) man page.

rcs2ws -p [ RCS_source_dir] -w  [ teamware_workspace] [files | directory]

% rcs2ws -p /projects/prodA -w /tw/workspaces/dev1 release1

% rcs2ws -p /projects/prodA release1

% rcs2ws -p /projects/prodA .
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CHAPTER 4

Controlling Workspace Access

Forte TeamWare allows you to control who can putback files to workspaces by

setting permissions and through putback validation. This chapter covers the

following topics:

■ Specifying Permissions

■ Protecting Workspaces With Putback Validation

■ Removing Workspace Locks

Specifying Permissions

You can grant or deny permissions on a global (see “Specifying Global Permissions”

on page 56), group, or individual basis (see “Specifying Group or Individual

Permissions” on page 57).

You can grant or deny permission for individual users or groups to perform the

following Forte TeamWare transactions:

■ Bringover-from

■ Bringover-to

■ Putback-from

■ Putback-to

■ Undo

■ Workspace delete

■ Workspace move

■ Workspace reparent

■ Workspace reparent-to

Note – Transactions can take longer to complete when you set access control. If you

grant or deny permissions to a large group, Configuring can take several seconds to

look up the members of the group before executing a transaction.
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Specifying Global Permissions

To specify global permissions:

1. Start Configuring.

See “Starting Configuring” on page 17 for details.

2. Choose File ➤ Load Workspaces.

3. Select the workspace in the Load Workspaces dialog box and click Load
Workspaces.

4. Click on the workspace to select it.

5. Choose Workspace ➤ Properties.

6. Select the Access Control tab in the Workspace Properties dialog box.

FIGURE 4-1 Workspace Properties: Access Control Tab

7. Select an operation and click Edit.

This displays the Access Control Properties dialog box.
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8. Select the type of permission you want to allow:

■ None: No users have permission

■ All: All users have permission

By default, all users have permission to execute the transaction.

9. Click OK.

Specifying Group or Individual Permissions

1. Start Configuring.

See “Starting Configuring” on page 17 for details.

2. Choose File ➤ Load Workspaces.

3. Select the workspace in the Load Workspaces dialog box and click Load
Workspaces.

4. Click on the workspace to select it.

5. Choose Workspace ➤ Properties.

6. Select the Access Control tab in the Workspace Properties dialog box.

7. Select an operation and click Edit to display the Access Control Properties dialog
box.

8. Click the Specify permissions radio button.

9. In the Name text box, type a user’s (or group’s) login name.

10. Click the User or Netgroup button to indicate whether it is a single user or a
group.

11. Click the Granted or Denied radio button.

12. Click the Add button to add the user to the list (or to start the list). Use the Move
Up and Move Down buttons to change the new user’s order in the list.

See Note on page 58 for reasons as to why the order is significant.

13. Click OK.

The user or netgroup is displayed on the permissions list in the Access Control tab.
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Note – The order in which a user appears on the list can have an effect on

permissions. If a user is listed as having been both granted and denied permission,

Forte TeamWare tools use only the first reference. This can occur when you grant

access to an individual and deny access to a group that the individual belongs to. In

this instance, if the individual is listed first, the individual will have access, if the

group is listed first, the individual does not have access.

Protecting Workspaces With Putback
Validation

Use putback validation if you want to have more strict control over a workspace.

When you turn on putback validation, only putbacks are allowed to the workspace.

The user is also prompted for a “password” (Integration Request Identifier) before

doing a putback. Configuring does not validate the Integration Request Identifier,

but it will pass it on to another program. To validate the Integration Request

Identifier, you must write your own validation program. See “Invoking Your Own

Putback Validation Program” on page 60. If Putback Validation is turned on, but you

do not have your own putback validation script, Configuring always allows the

putback. The Integration Request Identifier supplied by the user is recorded in

workspace history file and under the heading RTI (Request To Integrate).

TABLE 4-1 summarizes the three Putback Validation modes.

TABLE 4-1 Putback Validation Modes

Mode User Configuring

Putback Validation

off (default)

Does nothing. Allows all putbacks to workspace.

Putback Validation

on

Turns on Putback

Validation.

Requires a “password” (Integration

Request Identifier) before a putback is

allowed. Password is not validated,

merely recorded.

Putback Validation

on and passwords

checked.

Writes putback

validation program,

turns on Putback

Validation, invokes

putback validation

program.

Requires a “password” (Integration

Request Identifier) before a putback is

allowed. Integration Request Identifier

is passed to validation program.

Validation program must grant

permission before putback is allowed.
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SCCS also allows you to require a check-in validation for individual files. See

“Setting SCCS File Properties” on page 106.

Turning On Putback Validation

To turn on Putback Validation:

1. In the Configuring Window, load an existing workspace by choosing File ➤ Load
Workspaces.

2. Click on the workspace to select it.

3. Choose Workspace ➤ Workspace Properties.

4. Click the Putback Validation tab in the Workspace Properties Dialog Box (see
FIGURE 4-2).

5. Click Putback Validation On.

6. Click OK.
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FIGURE 4-2 Workspace Properties: Putback Validation Tab

Invoking Your Own Putback Validation Program
If a validation program is set for a workspace, any putback operation to the

workspace will invoke the program that you indicate. If the program fails, then the

putback is canceled.

The validation program is not a part of Forte TeamWare. You must provide your

own putback validation program. A sample validation program is provided in

CODE EXAMPLE 4-1.

To invoke your validation program:

1. In the Configuring Window, load the workspace by choosing File ➤ Load
Workspaces.

2. Click on the workspace to select it.
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3. Choose Workspace ➤ Workspace Properties.

4. Click the Putback Validation tab in the Workspace Properties dialog box.

5. Click Putback Validation On.

6. Click Putback Approval: Approved by Validation Program.

7. Type the path to your validation program in the Validation Program text box.

8. Click OK.

Sample Validation Program

This is a sample validation program you can use to determine whether you want to

allow a putback to a specific workspace. It can be any executable file (shell script,

program, etc.) that accepts arguments passed by putback and returns nonzero exit

status to deny putback.

The user who wants to do a putback will be prompted for a Integration Request ID

and then the validation program will be invoked with the following arguments:

■ User ID of the user doing the putback ($1)

■ “from” workspace full path name ($2)

■ “to” workspace full path name ($3)

■ Integration Request ID ($4)

■ Name of the file which contains the list of files to be modified ($5)

CODE EXAMPLE 4-1 is a program that checks all the arguments and, if successful,

returns a zero exit status to allow the putback.

CODE EXAMPLE 4-1 Sample Putback Validation Program

## Start of sample validation program

#!/bin/sh

##

## Here is the list of users who can perform

## putback to the workspace

##

valid_users="nikm azv builder vvg aar"

##

## Here is the list of Integration Request Ids which

## are accepted

##

P1Bugs="1111111 2222222 1234567 bobs_bug"

##

## Here are the directories which cannot change
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##

DirsReady="doc subdir/doc"

##

## Save arguments

##

User=$1

        shift

Parent=$1

        shift

Child=$1

        shift

IRI=$1

        shift

Files=‘cat $1‘

##

## Validate user

##

isValid="false"

for u in $valid_users

do

   if [ "$User" = "$u" ] ; then

      isValid="true"

      break

   fi

done

if [ "$isValid" = "false" ] ; then

   # invalid user

   echo ""

   echo "*** Validation failed: User $User is not allowed \

        to putback to $Parent"

   echo ""

   exit 1

fi

##

## Validate Integration Request Id (IRI)

##

isValid="false"

for u in $P1Bugs

do

  if [ "$IRI" = "$u" ] ; then

     isValid="true"

     break

  fi

CODE EXAMPLE 4-1 Sample Putback Validation Program (Continued)
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Removing Workspace Locks

To assure consistency, the Configuring transactions—Bringover, Undo, and

Putback—lock workspaces during these transactions.

done

if [ "$isValid" = "false" ] ; then

   # invalid IRI

   echo ""

   echo "*** Validation failed: Integration request $IRI \

        is invalid"

   echo ""

   exit 1

fi

##

## Validate files

##

for u in $Files

do

   for uu in $DirsReady

   do

      x=‘echo $u | grep $uu‘

      if [ "$x" != "" ] ; then

         isValid="false"

         echo ""

               echo "*** Validation failed: File $u \

                    cannot be changed"

               echo ""

               exit 1

           fi

       done

done

##

## Exit 0 - putback is allowed

##

exit 0

## End of sample validation program

CODE EXAMPLE 4-1 Sample Putback Validation Program (Continued)
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If you attempt to bring over files into a workspace that is locked, you will get a

message that states the name of the user who has the lock, the command they are

executing, and the time they obtained the lock.

Forte TeamWare removes these locks after the transaction is over. Normally, you will

not encounter a locked workspace. However, if a transaction encounters problems,

sometimes locks stay in place and you can no longer access the workspace. If you

are sure no one else is accessing the workspace, but a lock remains, you can remove

it manually.

Note – Be sure no one else is modifying the workspace before removing the lock.

Removing a lock from a workspace that is currently being modified by another user

compromises the integrity of that workspace.

To remove a workspace lock:

1. Make sure no one else is modifying files or performing any transactions in the
workspace.

2. In the Configuring Window, load the workspace by choosing File ➤ Load
Workspaces.

3. Click on the workspace to select it.

4. Choose Workspace ➤ Edit Locks.

5. In the Edit Locks dialog box, click a lock to select it.

6. Click Delete.

7. To close the Edit Locks dialog box, click OK.

bringover: Cannot obtain a write lock in workspace “/tmp_mnt/
home/my_home/projects/mpages”
because it has the following locks:

Command: bringover (pid 20291), user: jack, machine: holiday,
time: 12/02/91 16:25:23
  (Error 2021)
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CHAPTER 5

Managing Files

Once you have created Forte TeamWare workspaces, you can start work on your

project files. Coordinating write access to source files is important when changes will

be made by several people. Maintaining a record of file updates allows you to

determine when and why changes were made. Versioning is the TeamWare tool you

use to manage files. This chapter shows you how to do these basic tasks in

Versioning:

■ Starting Versioning

■ Adding Files to a Workspace

■ Checking Out a File

■ Editing a File

■ Changing Your Default Editor

■ Checking In a File

■ Reversing Changes to a File

■ Integrating Changes by Putting Back Files

Starting Versioning

The Versioning tool allows you to control write access to source files and monitor

changes made to those files. Versioning allows only one user at a time to update a

file, and it records all changes in a history file.

To start the Versioning tool, do one of the following:

■ Click the Versioning button in the Forte for Java TeamWare toolbar

Note: the full Forte for Java TeamWare toolbar does not appear by default.

See “Accessing the Forte for Java TeamWare Toolbar” on page 145 for details.

■ From the Forte for Java Explorer window:

i. Right click on a Forte TeamWare directory

Note: you must first mount the Forte TeamWare directory before it will appear

in the Forte for Java Explorer window. See “Mounting a Forte TeamWare

Filesystem” on page 144 for details
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ii. Choose TeamWare ➤ Versioning

See Chapter 11 for further information about launching Forte TeamWare tools and

accessing commands from within the Forte for Java IDE.

■ Choose TeamWare ➤ Versioning in the Configuring (or Merging, or

Freezepointing) window.

When you start Forte TeamWare Versioning, the Versioning window opens. The

Versioning main window displays the directories and files of the current directory

(see FIGURE 5-1).

FIGURE 5-1 Versioning Window

The Versioning window displays the directories and files of your project. Versioning

displays all directories, but displays only files that are under SCCS control. See

“Adding Files to a Workspace” on page 67.

TABLE 5-1 describes the Versioning window menus.

TABLE 5-1 Versioning Window Menus

Menu Description

File Provides commands for managing files.

View Provides commands to control and update the icons shown in the

directory pane.

Commands Provides commands for checking files in and out.
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Directories are shown whether or not they contain files that are under SCCS control.

A directory is a container for files and directories and can possibly contain SCCS

files and directories further down the hierarchy. Files are only shown in the

Versioning window if they are under SCCS control. To look at the non-SCCS files in

a directory, use the Check in New window.

Adding Files to a Workspace

For the Forte TeamWare configuration management tools to be able to recognize

files, the files must be under SCCS version control.

You can add files to an existing Forte TeamWare workspace by doing one of the

following:

■ From the Forte for Java Explorer window:

i. Select the file to be added to the mounted Forte TeamWare directory.

The file will be marked with Check-in Needed.

ii. Right-click and select Check In.

iii. In the TeamWare Versioning Check In Dialog box, enter a comment.

iv. Click Check In

The file you have checked in is now marked as Checked In in the Forte for Java

Explorer window.

■ From the Versioning menu in the Forte for Java Main window:

i. Select the file to be checked in via the Forte for Java Explorer window.

The file will be marked with Check-in Needed.

ii. Choose Versioning ➤ Check In.

iii. In the TeamWare Versioning Check In Dialog box, enter a comment.

Workspace Provides commands for finding, deleting, and moving files under

SCCS control.

TeamWare Provides commands for starting other TeamWare tools.

Help Provides commands to display online help and release

documentation.

TABLE 5-1 Versioning Window Menus

Menu Description
Chapter 5 Managing Files 67



iv. Click Check In

The file you have checked is now marked as Checked In in the Forte for Java

Explorer window.

■ From the Configuring window (see “Starting Configuring” on page 17 for details):

i. Load the workspace you want to work with by choosing File ➤ Load
Workspaces.

If the directory is not yet a TeamWare workspace, see “Creating a Parent

Workspace” on page 20.

ii. Click on the workspace to select it.

iii. Choose TeamWare ➤ Versioning.

Note: You can also activate the Versioning Window via the Forte for Java

TeamWare toolbar by clicking the Versioning button.

iv. In the Versioning Window, choose Commands ➤ Check In New.

v. In the Check In New dialog box, select the files you want to add to the
workspace.

You can Shift-click to select multiple files.

vi. Click OK.

The files you have checked in are now displayed in the Versioning window.

Checking Out a File

Versioning requires that you check out a file before you modify it. When a file is

checked out from a workspace, no other user is allowed to check out the file. If you

have two users who need access to the same file, have one user create a child

workspace so they can have their own copy of the file.

To check out a file, you can do one of the following:

■ From the Forte for Java Explorer window:

i. Select the file to be checked out.

The file will be marked as Checked In.

ii. Right-click and select Check Out or Check Out & Edit.

■ From the Versioning menu in the Forte for Java Main window:

i. Select the file to be checked out via the Forte for Java Explorer window.
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The file will be marked as Checked In.

ii. Choose Versioning ➤ Check Out or Versioning ➤ Check Out & Edit.

■ From the Configuring window (see “Starting Configuring” on page 17 for details):

i. Choose TeamWare ➤ Versioning.

Note: You can also activate the Versioning Window via the Forte for Java

TeamWare toolbar by clicking the Versioning button.

ii. In the Versioning Window, navigate to the directory where the files exist and
select the icon of the first file you want to change.

You can shift-click to select several files.

iii. Choose Commands ➤ Check Out.

If you choose Commands ➤ Check Out and Edit, Versioning starts up an editor

for you.

A check mark is displayed on the file icon of the selected file. If you want to

use a different editor than the default, see “Changing Your Default Editor” on

page 70.

Editing a File

To edit a Forte TeamWare file, you can do one of the following:

■ From the Forte for Java Explorer window:

i. Select the checked out file to be edited.

Note: See “Forte for Java IDE Editor and Forte TeamWare Tools” on page 156

for more information the type of editor used if the file’s type is not recognized.

ii. Right-click and select Open.

■ From the Configuring Window:

i. Choose File ➤ Load Workspaces to load your workspace.

ii. Click the workspace to select it.

iii. Choose Teamware ➤ Versioning.

The Versioning Window appears.

Note: You can also activate the Versioning Window via the Forte for Java

TeamWare toolbar by clicking the Versioning button.

iv. In the Versioning window, select the file you want to edit by clicking on it.
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v. Choose Commands ➤ Check Out and Edit.

This opens the file in the default editor. If you want to use a different editor

than the default, see “Changing Your Default Editor” on page 70. If the

Configuring Window was launched from within the Forte for Java IDE, this

opens the file in an IDE file editor. The type of editor used depends on the file’s

type.

vi. After you have edited and saved the file, check in the file.

See “Checking In a File” on page 70.

Changing Your Default Editor

To change your default editor used in the Forte TeamWare windows:

1. In the Configuring Window, choose TeamWare ➤ Versioning.

2. In the Versioning Window, choose View ➤ Options.

3. In the Options dialog box, type the path to your editor in the Editor of Choice text
field.

Checking In a File

To check in a file, you can do one of the following:

■ From the Forte for Java Explorer window:

i. Select the file to be checked in.

The file will be marked with Checked Out.

ii. Right-click and select Check In.

iii. In the TeamWare Versioning Check In Dialog box, enter a comment.

iv. Click Check In

The file you have checked in is now marked as Checked In in the Forte for Java

Explorer window. Your comments and checks in the file. To integrate the

changes to the parent workspace, see “Integrating Changes by Putting Back

Files” on page 72.

■ From the Versioning menu in the Forte for Java Main window:
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i. Select the file to be checked in via the Forte for Java Explorer window.

The file will be marked with Checked Out.

ii. Choose Versioning ➤ Check In.

iii. In the TeamWare Versioning Check In Dialog box, enter a comment.

iv. Click Check In

The file you have checked in is now marked as Checked In in the Forte for Java

Explorer window. Your comments and checks in the file. To integrate the

changes to the parent workspace, see “Integrating Changes by Putting Back

Files” on page 72.

■ From the Configuring window (see “Starting Configuring” on page 17 for details):

i. Choose TeamWare ➤ Versioning.

Note: You can also activate the Versioning Window via the Forte for Java

TeamWare toolbar by clicking the Versioning button.

ii. In the Versioning Window, navigate to the directory where the files are
stored.

iii. Click the icon for file you want to check in.

You can Shift-click to select multiple files. Files that are checked out have a red

check mark on the icon.

iv. Choose Commands ➤ Check In.

v. In the Check In dialog box, type a comment.

vi. Click OK.

Forte TeamWare saves your comments and checks in the file. To integrate the

changes to the parent workspace, see “Integrating Changes by Putting Back

Files” on page 72.

Reversing Changes to a File

Versioning also provides a way to return a file to the state it was in before it was

checked out. This is useful if you have made changes to a file, but don’t want those

changes checked back in.

To reverse the changes made to a checked-out file, you can do one of the following:

■ From the Forte for Java Explorer window:

i. Select the checked-out file.
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The file will be marked as Checked Out.

ii. Right-click and select Uncheckout.

■ From the Versioning menu in the Forte for Java Main window:

i. Select the checked-out file via the Forte for Java Explorer window.

The file will be marked as Checked Out.

ii. Choose Versioning ➤ Uncheckout .

■ In the Configuring Window,

i. Choose TeamWare ➤ Versioning.

Note: You can also activate the Versioning Window via the Forte for Java

TeamWare toolbar by clicking the Versioning button.

ii. In the Versioning Window, navigate to the directory where the checked-out
file is stored.

The icon of the file should have red check mark, indicating it is checked out.

iii. Click on the file to select it.

Shift-click to select multiple files.

iv. Choose Commands ➤ Uncheckout.

This reverses the most recent changes to the document and returns the file to

its previous state.

Integrating Changes by Putting Back
Files

After you have made changes to the files in your workspace, you need to put back

these changes to the parent workspace. This makes your changes available to the

other members of your team.

To put back files to a parent workspace:

1. In the Configuring Window, choose Actions ➤ Putback.

2. In the Putback tab, select the files you want to put back.

3. Click in the Comments text box and type a comment.

Depending on how your administrator has set up email notification, many people

may see this comment.
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4. Click Putback.

The Transactions Output window is displayed and shows information about the

putback. If there is a conflict during a putback, Configuring automatically takes you

to the Resolve Tab (see Chapter 6).

5. Click Close to close the Transactions Output window.

Note – For a more detailed description of performing a putback, see “Putting Back

Changes to a Parent Workspace” on page 26.
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CHAPTER 6

Resolving Differences Between Files

When two copies of the same file have had changes made to them, these files are in

conflict. When you try to put back a file that you have changed in your child

workspace, but it has also been changed in the parent workspace, the Forte

TeamWare tools will prevent you from putting back the file until you have resolved

the differences between them. Merging is the tool you use to resolve conflicts

between files.

The chapter covers the following topics:

■ Starting Merging

■ Resolving Conflicts in a Workspace

■ Viewing the Merging Window

■ Resolving Differences

■ Using Automatic Merging

■ Undoing Changes

■ Merging Options

■ Merging Example

Starting Merging

To start the Merging tool, do one of the following:

■ Click the Merging button in the Forte for Java TeamWare toolbar

Note: the full Forte for Java TeamWare toolbar does not appear by default.

See “Accessing the Forte for Java TeamWare Toolbar” on page 145 for details.

■ From the Forte for Java Explorer window:

i. Right click on a Forte TeamWare directory

ii. Choose TeamWare ➤ Merging

See Chapter 11 for further information about launching Forte TeamWare tools and

accessing commands from within the Forte for Java IDE.
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■ Choose TeamWare ➤ Merging in the Configuring (or Versioning, or

Freezepointing) window.

Merging can also be started from the Resolve tab. See “Starting Merging From the

Resolve Tab” on page 76 for further details.

Workspace Conflicts

In the Configuring window, a workspace with conflicts has an icon in which one of

the files is red and red motion lines indicate a conflict. In FIGURE 6-1, ws2 has a file in

conflict with its parent, ws1.

FIGURE 6-1 Workspace Conflict Example

Conflicts need not be resolved immediately. You can continue to make changes and

create new deltas in conflicted files in the child workspace. New deltas are created

on a branch; when you finally resolve the conflict, the latest delta is the one merged

with the version brought over from the parent. Conflicts must be resolved before you can
put back the files to the parent. If you attempt a putback and files are in conflict,

Configuring will prompt you to perform a bringover and then display the conflicted

files in the Resolve tab of the Transactions dialog box.

Starting Merging From the Resolve Tab

The Resolve tab of the Transactions dialog box acts as intermediary between you and

Merging. It lists conflicted files that are detected during Bringover Update

transactions. The Resolve transaction allows you to select the conflicted file, and

starts Merging with the conflicted files already loaded. Configuring automatically

takes you to the Resolve tab of the Transactions dialog box if you chose to resolve a

conflict during a putback. You can also open the Resolve tab by choosing Actions ➤

Resolve.

ws2 showing a conflict
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Viewing the Merging Window

When you start Merging, the Merging window appears (see FIGURE 6-2). The

Merging window is divided into three panes: two side-by-side panes, which display

different versions of the file, and the merged result in the bottom pane. The top two

panes are read-only; the bottom pane contains selected lines from either or both

versions of the file and can be edited to produce a final merged version.

Each delta in each of the top panes is shown in comparison to the common ancestor

delta:

■ The child delta is displayed in the left pane labeled Child

■ The parent delta is displayed in the right pane labeled Parent

The common ancestor is the delta from which both the parent and child deltas are

descended. This arrangement permits you to make a three-way comparison—each

delta to the common ancestor and each delta to the other.

Resolving Conflicts in a Workspace

To resolve a conflict in a workspace:

1. In Configuring, double-click the icon of a conflicted workspace.

The Resolve tab of the Transaction dialog box opens with the names of its conflicted

files displayed in the File List pane.

2. Click Merge Conflicts.

Resolve starts Merging and begins to process the list of files in the File List pane. For

each file in the list, Configuring extracts the parent delta, the child delta, and the

common ancestor from the SCCS history file and passes their path names to

Merging. The Merging window opens with the files loaded and ready for merging.

3. Use Merging to resolve the differences between the parent and child versions of
the file.

See “Resolving Differences” on page 82 for details about using Merging.

4. Once you have resolved conflicts, save the file.

After you use Merging to resolve differences between the parent and child versions

of the file, Configuring creates a new delta in the child SCCS history file. The new

delta contains the merged result you created using Merging.

5. Repeat this process until all conflicts are resolved.
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FIGURE 6-2 Merging Window

Reading Merging Glyphs

To help you find differences more easily, Merging highlights lines that differ with

color and glyphs. Yellow shows an addition, red shows a change, green shows a

deletion.
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The meaning of glyphs is different if you are comparing two versions with each

other (two input files) or if you identify an ancestor for the two versions of the file

(three input files). FIGURE 6-2 shows the Merging window with glyphs indicating

differences between two files.

Two Input Files

When only two files have been loaded into Merging, lines in each file are marked by

glyphs to indicate when they differ from corresponding lines in the other file:

■ If two lines are identical, no glyph is displayed.

■ If two lines are different, a vertical bar (|) is displayed next to the line in each

input text pane, and the different characters are highlighted in yellow.

■ If a line appears in one file but not in the other, a plus sign (+) is displayed next

to the line in the file where it appears, and the different characters are highlighted

in red.

■ Resolved differences are marked by glyphs in outline font.

Three Input Files

When you load two files to be merged, you can also specify a third file, called the

ancestor of the two files. An ancestor file is any earlier version of the two files. When

you identify an ancestor file, it is used as a basis to compare the two files and

automatic merging can be done. Merging marks all lines in the derived files or their

descendants that differ from the ancestor and produces a merged file based on all

three files.

The lines in the files that are different from the ancestor file are marked with change

bars and colors. Here’s what each means:

■ If a line is identical in all three files, no glyph is displayed.

■ If a line is not in the ancestor but was added to one or both of the descendants, a

plus sign (+) is displayed next to the line in the file where the line was added, and

the different characters are highlighted in yellow.

■ If a line is in the ancestor but has been changed in one or both of the descendants,

a vertical bar (|) is displayed next to the line in the file where the line was

changed, and the different characters are highlighted in red.

■ If a line is present in the ancestor but was removed from one or both of the

descendants, a minus sign (-) is displayed next to the line in the file from which

the line was removed, and the different characters are highlighted in green and in

strikethrough.

■ Resolved differences are marked by glyphs in outline font.
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Loading Files Into Merging

If files are not automatically loaded into Merging by Resolve, you can load files by

choosing File ➤ Open or clicking the Open button. The Open Files dialog box is

displayed (see FIGURE 6-3).

FIGURE 6-3 Merging: Open Files Dialog Box
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TABLE 6-1 describes the text boxes in the Open Files dialog box.

In a loaded Merging window, the names of the left file, right file, and output file are

displayed above the appropriate text panes. The name of the ancestor file (for a

three-way diff only) is displayed in the window header.

TABLE 6-1 Merging Open Files Dialog Box Text Boxes

Text Box Description

Directory Shows the current working directory whenever you start

Merging from Sun WorkShop or from the command line with

no arguments. You can edit this field. Merging interprets the file

names you specify in the window as relative to the current

working directory. Therefore, you can use constructs such as

subdir/filename to specify a file in a subdirectory and ../filename to

specify a file in a parent directory. Any file name you specify

that begins with a “/ ” character is interpreted as an absolute

path name, not as relative to the current working directory.

Left File Lets you specify the file to appear in the left text pane, also

considered the child pane.

Right File Lets you specify the file to appear in the right text pane, also

considered the parent pane.

Ancestor File Lets you specify the name of an ancestor file. If you type a file

name in this text box, Merging compares the file to the files to

be merged and identifies lines in those files that differ from the

ancestor. The automerged file is based on the ancestor file, but

the ancestor file itself is not displayed in any Merging window.

If you do not type an ancestor file name, Merging compares

only the left and right files and derives the output file from

them. Automerging is not possible without an ancestor file.

Output File Lets you specify the name for the merged output file. Merging

uses the name filemerge.out unless you specify a different

name, and stores the file in the current working directory.
Chapter 6 Resolving Differences Between Files 81



Transaction Check In

If doing a putback from a conflicted workspace with files still checked out, the

Transaction CheckIn dialog box will appear. This dialog presents the following

options:

Resolving Differences

While focusing on a difference, you can accept a line from either of the original

deltas, or you can edit the merged version by hand. When you indicate that you are

satisfied with your changes by clicking on a control panel button, the current

difference is said to be resolved. After a difference is resolved, Merging changes the

glyphs that mark the difference to outline (hollow) font. Merging then automatically

advances to the next difference (if the Auto Advance property is on), or moves to

another difference of your choice.

A difference is represented by a blank line in the merged (output) file in the lower

text pane. To resolve a difference, you edit the line displayed by either:

■ Accepting the line displayed and incorporating it into the merged file by clicking

either the Accept or Accept & Next button over the pane you want to accept.

■ Editing the line in the merged file by hand, and marking the difference as

resolved by choosing Edit ➤ Mark Selected as Resolved.

If you want Merging to automatically put lines that are not in conflict (that is, the

line has changed in one file but not in the other) into the merged file, you can select

Options ➤ Auto Merge. Then when you start Merging, all the resolved lines are put

in the merged file for you. For more information, see “Using Automatic Merging” on

page 83.

To resolve differences between files:

1. Determine which difference you are dealing with:

■ Read the Status Line on the upper left side of the Merging window.

■ See which glyph is highlighted.

TABLE 6-2

Option Description

Checkin Checks the file back into your child workspace

Uncheckout Returns the file to its pre-checked out state in your child workspace

Skip Skips to the next checked out file (if any)
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The difference on which Merging is focusing at any given time is called the current
difference. The difference that appears immediately after in the file is called the next
difference; the difference that appears immediately before in the file is called the

previous difference.

2. Choose a version and accept it:

■ To accept the child version of the line, click the Accept button above the file on

the left.

■ To accept the parent version of the conflicted line, click on the Accept button

above the file on the right.

The version you accept will appear in the merged file in the bottom pane.

3. Click Next to go to the next conflict in the file.

To move between differences:

■ Click one of the Next buttons.

■ Use the Navigate menu.

■ Use the Diff Navigator (the up and down arrows above where the parent and

child panes meet).

If you do not want your changes and you want to start over, click the Reload button.

This ignores all the conflicts that you have resolved and reloads the files.

4. Click Save when you have resolved all conflicts.

Using Automatic Merging

If you have loaded a common ancestor file, Merging is often able to resolve

differences automatically, based on the following rules:

■ If a line has not been changed in either descendant (it is identical in all three files),

it is placed in the merged file.

■ If a line has been changed in only one of the descendants, the changed line is

placed in the merged file. A change could be the addition or removal of an entire

line, or an alteration to some part of a line.

■ If identical changes have been made to a line in both descendants, the changed

line is placed in the merged file.

■ If a line has been changed differently in both descendant files so that it is different

in all three files, Merging places no line in the merged file. You must resolve the

difference—either by using a line from the right or left file, or by editing the

merged file by hand.
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■ Resolved differences are marked by glyphs in outline font.

TABLE 6-3 summarizes the automerging algorithm.

■ Ancestor is the version of a text line that is in the ancestor file

■ Change 1 is a change to that line in one of the descendants

■ Change 2 is another change, different from Change 1.

■ When a line is changed differently in the left and right descendants, automerging

does not put either line in the merged file.

Undoing Changes

You can undo changes with the Edit ➤ Undo command.

You can also use the Reload button on the Merging window tool bar to ignore all

edits that have been performed on the two files and reload them from disk. Any

nonconflicting differences will be displayed in the bottom pane if the Auto Merge

option is selected.

Merging Options

You can change the behavior of Resolve and Merging in two places:

■ Resolve Options in Configuring

■ Display Options in Merging

TABLE 6-3 Automerging Rules Summary

Left Descendant Right Descendant Automerged Line

Ancestor Ancestor Ancestor

Change 1 Ancestor Change 1

Ancestor Change 2 Change 2

Change 1 Change 1 Change 1

Change 1 Change 2 No Automerge
84 Forte TeamWare User’s Guide • August 2001



Resolve Options

The Resolve tab of the Tool Properties window (FIGURE 6-4) lets you change the

behavior of the Resolve pane of the Transactions window. The specific properties are

described in TABLE 6-4.

FIGURE 6-4 Tool Properties Dialog Box: Resolve Tab

TABLE 6-4 Tool Properties Dialog Box: Resolve Tab

Property Description

Auto Start Merging Window Causes Merging to start automatically when you select

the Resolve transaction pane.

Auto Advance Causes the next file in the list to be automatically

loaded into Merging after the current file is resolved.

Prompt for Checkin Comments A default comment is automatically supplied during

comment is automatically supplied during check-in

after you resolve a file. This property causes you to be

prompted for an additional comment that is appended

to the standard comment.

Use Existing Merging Window If this property is set, a running Merging process is

reused during subsequent resolve operations.

Auto Save (when no unresolved

diffs)

If this property is set, and all the changes in the file

can be “automerged,” the files will also be saved and

checked in.
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Display Options in Merging

The Options menu in the Merging window contains the following components. The

first five options on this menu are toggles, that is, you can turn them on and off by

selecting them. A small box appears to the left of an option when it is on.

TABLE 6-5 lists the Merging Display options.

TABLE 6-5 Merging: Display Options

Property Description

Auto Merge Automatically resolves any nonconflicting differences and

constructs a merged version in the Merged Result Pane. The

default is on.

Scroll Together Lets you set the text panes so they scroll together

(corresponding lines are always aligned in each window) or

scroll separately. The default setting is Scroll Together.

Show Line Numbers Displays line numbers in the unmerged files.

Show Line Ends Displays a small black box at the end of each line in the

unmerged files.

Show Diff Navigator Displays the Diff Navigator between the two unmerged

files. The Diff Navigator displays differences between the

two files as colored lines. Click the slide boxes on either side

of the Diff Navigator to scroll through either file, or click the

arrows on the top or bottom to move the same distance in

both files.

Tab Display Lets you customize tab stops. You can choose:

Control Character (^I) Displays the ^I control

character for each tab space.

The default setting is on.

Spaces Allows you to set the

number of spaces in each tab

stop to 1, 2, 3, 4, 6, 8, 10, 12,

or 16. The default is 8.

Diff Options Lets you customize diff behavior. You can choose:
86 Forte TeamWare User’s Guide • August 2001



Merging Example

This example merges two files that have a common ancestor. The files are file_1
and file_2 , and the ancestor file is named matriarch . The descendant files

file_1 and file_2 were derived from matriarch by editing. The edits show all

varieties of changes that could occur in the descendants: deleting lines, adding new

lines, and changing lines.

The content of each line in the example helps to identify whether or not it was

changed, and how. The ancestor file contains only twelve lines and is shown in

CODE EXAMPLE 6-1.

Ignore trailing white space Ignores trailing white space

when finding lines that

differ. The default setting is

off.

Ignore all white space Ignores embedded and

trailing space when finding

lines that differ. The default

is off.

Suppress case sensitivity Ignore letter case when

finding lines that differ. The

default is off.

TABLE 6-5 Merging: Display Options (Continued)

Property Description
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Merging does not number lines in the files it loads; the numbers are part of the

example text and were placed there for clarity.

CODE EXAMPLE 6-2 shows the contents of file_1 . This file is identical to matriarch
with the following exceptions:

■ The line numbered 1 in the matriarch file was deleted in file_1 .

■ A new line was added following the line numbered 4.

■ The line numbered 6 was changed (a different change was made to this line in

file_2 ).

■ The line numbered 8 in the matriarch file was changed (an identical change was

made to this line in file_2 ).

CODE EXAMPLE 6-1 Ancestor File (matriarch )

1 This line is deleted in file_1
2 This line is in all three files
3 This line is deleted in file_2
4 This line is in all three files
5 This line is in all three files
6 This line is changed in descendants
7 This line is in all three files
8 This line is changed in descendants
9 This line is in all three files
10 This line is changed in file_2
11 This line is in all three files
12 This line is in all three files

CODE EXAMPLE 6-2 Descendant File (file_1 )

2 This line is in all three files
3 This line is deleted in file_2
4 This line is in all three files
 &&& Added to file_1 &&&
6 This line is modified in file_1 from matriarch
5 This line is in all three files
7 This line is in all three files
8 #&# Changed in file_1 and file_2 #&#
9 This line is in all three files
10 This line is changed in file_2
11 This line is in all three files
12 This line is in all three files
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CODE EXAMPLE 6-3 shows the contents of file_2 . This file is identical to matriarch
with the following exceptions:

■ The line numbered 3 in the matriarch file was deleted.

■ The line numbered 6 was changed (a different change was made to this line in

file_1 ).

■ The line numbered 8 was changed (an identical change was made to this line in

file_1 ).

■ The line numbered 10 was changed (no change was made to this line in file_1 ).

■ A new line was added following the line numbered 11.

In the upper left of the Merging window, Merging has reported finding seven

differences, of which only one remains unresolved (see FIGURE 6-5). Six differences

were resolved by automerging and are marked by glyphs in outline font (see

FIGURE 6-6 and FIGURE 6-7).

FIGURE 6-5 Merging Status of file_1 and file_2 After Automerging

CODE EXAMPLE 6-3 Descendant File (file_2)

1 This line is deleted in file_1
2 This line is in all three files
4 This line is in all three files
5 This line is in all three files
6 This line is altered in file_2 from matriarch
7 This line is in all three files
8 #&# Changed in file_1 and file_2 #&#
9 This line is in all three files
10 ### Changed in file_2 ###
11 This line is in all three files
 ### Added to file_2 ###
12 This line is in all three files
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FIGURE 6-6 Child Pane Showing file_1 After Automerging

FIGURE 6-7 Parent Pane Showing file_2 After Automerging

The meaning of the glyphs is as follows: a vertical bar means a change in the marked

line, a plus sign signifies a line added, a minus sign means a line was deleted.

Unresolved states are marked by solid glyphs, unresolved by outline. These glyphs

are highlighted in color except when the color map is full. The default significance

is: red indicates a change, green indicates a deletion, yellow shows an addition.

The unresolved difference (line 6) is marked by a vertical bar.
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Examining Differences

Merging highlights the unresolved difference, which it identifies as the line

numbered 6 in file_1 and file_2 . When differences are being resolved with

Merging, the resulting Merging window (filemerge .out ) shows the current state

of the file with automatic merging.

You can proceed to the next unresolved difference by clicking the down arrow above

the appropriate file or choosing Navigate ➤ Next ➤ Difference. The next difference

becomes the current difference.

You can proceed through the differences by clicking on the down arrow.

Automerging preserves a change that was made to one file if no change was made in

the other file. When a difference has not been resolved by automerging, as indicated

by the solid highlighted glyph next to the lines involved in the difference, you need

to resolve the difference by making a choice. The vertical line indicates that the line

has been changed (as opposed to added or deleted). Automerging does not include

either line in the merged file because the same line was changed differently in the

two files. You will have to determine which change to accept.

Resolving a Difference

You could resolve this difference in one of the following ways:

■ Clicking the Accept or Accept & Next button on the left to place the line from

file_1 into the output file

■ Clicking the Accept or Accept & Next button on the right to place the line from

file_2 into the output file

■ Editing the output file by hand

Editing the Output File

To edit the output file:

1. Move the pointer into the output file’s text pane and place it in the line you want
to change.

In this example, the following line was typed in:

>>> This line edited by hand <<<

2. Choose Edit ➤ Mark Selected as Resolved.

This menu item marks the difference as resolved. In this example there are no more

unresolved differences, so the next difference remains the current one.
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The message in the upper left part of the window now indicates that all differences

have been resolved.

3. Verify the automerged differences.

Navigate through the differences by clicking the down arrow.

The final difference results from a line that was added only to file_2 . Merging

would place the new line in the output file, just as it did when a new line was added

to file_1 , which resulted in the third difference.
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CHAPTER 7

Advanced File Management

This chapter shows you how to perform advanced file management, including:

■ Updating the Files in Your Workspace

■ Viewing File History

■ Renaming, Moving, or Deleting Files

■ Creating a Customized Menu

■ Adding a Path to the Load Menu

■ Changing Versioning Properties

■ Setting SCCS File Properties

Updating the Files in Your Workspace

Once you have created a workspace, you need to update it regularly using the

Bringover transaction.

To update your workspace:

1. In the Configuring Window, choose Actions ➤ Bringover Update.

2. Click the Bringover Update tab in the Transactions dialog box.

3. Confirm that the parent and child workspace directories are correct.

4. Select the directories and files to update.

5. Click Bringover.

For a detailed explanation of how to perform this transaction, see “Updating a Child

Workspace (Bringover Update)” on page 24.
93



Viewing File History

Versioning allows you to visually peruse the history of a file in a Forte TeamWare

workspace. This way, you can see who made changes to a file, when the changes

were made, and (with good comments) why changes were made.

The History window (see FIGURE 7-1) displays an illustration of delta branches for a

selected file. This history graph allows you to peruse the delta structure of a file and

assess associations between versions. Dashed lines are shown by default and

indicate that the delta to the right of the dashed line was created by including the

changes from the delta on the left. Following the dashed line provides you with a

time-ordering sequence.

Using the History window, you can:

■ Select a delta from the history graph that will display information about the delta

in the Delta Details pane.

■ Select a delta from the history graph to check it in or out, depending on its

current SCCS state.

■ View the contents of a selected delta by choosing View ➤ Show File Contents.

This opens an editor window with the contents of the selected delta displayed.

■ Select two deltas and choose View ➤ Diff in Merging Window. This displays a

Merging window in which the two selected deltas are displayed side by side for

comparison.

■ Select two deltas and choose View ➤ Diff in Text Window. An editor window

opens up displaying the textual differences from the SCCS diffs command.

■ Select two deltas and choose View ➤ Diff with Context. An editor window opens

up displaying the textual differences from the SCCS diffs -c command.

To view the history of a file:

1. In the Versioning Window, click a file to select it.

2. Choose File ➤ File History.

This displays the File History Window (see FIGURE 7-1).

3. When you want to view another delta of the same file, click a delta (represented
by a number, for example, 1.2) in the History Graph pane.
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FIGURE 7-1 File History Window

File History Window

TABLE 7-1 describes the items in the File History window:

TABLE 7-1 File History Window

Item Description

View menu Provides commands for managing files.

Version menu Provides commands for managing icons in the History Graph pane.

Filename text box Displays the file path name.

History Graph pane Displays icons for file deltas.

Delta Details pane Contains delta history information.

Delta Details pane Contains delta history information.

History
Graph
Pane
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File History Viewer Symbols

TABLE 7-2 lists the symbols you can see in the File History Viewer window.

How To Read a File’s History: Deltas, Branches,

and Versions

The Versioning tool keeps track of the various versions of a file for the entire life of

the file. Each time you check a file in, Versioning records the line-by-line differences

between the file you check in and the previous version of the file. This line-by-line

difference is known as a delta.

When you check a file in to Forte TeamWare for the first time, it is numbered 1.1 (by

default). Successive deltas are numbered 1.2, 1.3, and so forth. The straight

progression from 1.1, 1.2, 1.3, etc. is know as the trunk of an SCCS tree. There are

times, however, when it is necessary to create an alternative branch off of the trunk.

Branches are used to allow you to develop two different versions of the same file in

parallel, often for bug fixes in source code. Branches are numbered from where they

split off from the tree, for example, 1.2.1.1.

An SCCS delta ID (SID) is the number used to represent a specific delta. This is a

two-part number, with the parts separated by a dot (.). The SID of the initial delta is

1.1 by default. The first part of the SID is referred to as the release number, and the

second, the level number. When you check in a delta, the level number is increased

automatically. The SID for a branch delta consists of four parts: the release and level

numbers and the branch and sequence numbers, or release.level.branch.sequence.

The branch number is assigned to each branch that is a descendant of a particular

TABLE 7-2 File History Viewer Symbols

Symbol Description

A file icon to the left of the version number indicates the default delta.

A red check mark indicates the file is checked out.

Crossed out deltas are unmerged.

Solid lines represent the default deltas path.

Dotted lines with an arrow represent merged branches.

Double underline indicates the default branch (set by the sccs-admin
flag -d ). See “Setting SCCS File Properties” on page 106.
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trunk delta; the first branch is 1, the next 2, and so on. The sequence number is

assigned, in order, to each delta on a particular branch. Thus, 1.2.1.1 identifies the

first delta of the first branch derived from delta 1.2. A second branch to this delta

would be numbered 1.2.2.1 and so on.

The concepts of branching can be extended to any delta in the tree. The branch

component is assigned in the order of creation on the branch, independent of its

location relative to the trunk. Thus, a branch delta can always be identified from its

name. While the trunk delta can be identified from the branch delta's name, it is not

possible to determine the entire path leading from the trunk delta to the branch

delta.

For example, if delta 1.3 has one branch, all deltas on that branch will be named

1.3.1.n. If a delta on this branch has another branch emanating from it, all deltas on

the new branch will be named 1.3.2.n. The only information that can be derived from

the name of delta 1.3.2.2 is that it is the second chronological delta on the second

chronological branch whose trunk ancestor is delta 1.3. In particular, it is not

possible to determine from the name of delta 1.3.2.2 all of the deltas between it and

its trunk ancestor (1.3).

The terms delta and version are often used synonymously; however, their meanings

are not the same. Versioning constructs a version of a file from a set of accumulated

deltas. It is possible to retrieve a version of a file that omits certain deltas.

Merging Deltas

There are times when it makes sense to continue development in parallel, and there

are times when it makes sense to merge changes back into the main trunk. Once you

have merged the files, this is known as a branch closure.

To merge two deltas:

1. Start Versioning and select the working directory.

2. Choose Commands ➤ Check Out to check out a file.

3. Choose File ➤ File History to display the history graph of the file.

4. Select two deltas from the graph in the History window.

5. To inspect the differences, choose one of the following:

■ View ➤ Diff in Merging Window

■ View ➤ Diff in Text Window

■ View ➤ Diff with Contents

6. Make changes to the file.

7. Add necessary comments.
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8. Choose Commands ➤ Check in to check in the file.

Renaming, Moving, or Deleting Files

When you rename, move, or delete files, Configuring tracks those changes and

manages the altered files during Bringover and Putback transactions. Although

Configuring processes these files automatically, it is helpful for you to understand

some of the ramifications of renaming, moving, or deleting files.

Note – The best way to delete and rename files is to use the Move and Delete

commands from the TeamWare Versioning menu, rather than with the operating

system commands for moving or deleting files. Using the procedures detailed below

will maintain the correct relationships between files and accurate file histories.

Renaming or Moving Files

When you bring over or put back files that you (or another user) have renamed or

moved, Configuring must determine whether the files have been newly created or

whether they existed previously and have been renamed or moved. When you

rename or move a file, Configuring updates both the file name and history file for

that file. Configuring propagates the name change throughout the workspace

hierarchy using the same rules used with file content updates and conflicts.

During transactions, Configuring processes files individually. When you rename or

move a directory, each file in the directory is evaluated separately as if each had

been renamed or moved individually.

Example

In FIGURE 7-2, the name of file C in the parent is changed to D. When Configuring

brings the file over to the child, it must determine which of the following is true:

■ D has been newly created in the parent.

■ It is the same file as C in the child, only with a new name.
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FIGURE 7-2 File “C” Renamed to “D”

If the same case was the subject of a Putback operation, the same problem would

apply: Is “C” new in the child, or has it been renamed from some other file?

The action that Configuring takes is very different in each case. If it is a new file in

the parent, Configuring creates it in the child; if it has been renamed in the parent,

Configuring renames file “C” to “D” in the child.

Configuring stores information in the SCCS history files that enables it to identify

files even if their names are changed. You may have noticed the following message

when viewing Bringover and Putback output:

Configuring examines all files involved in a Bringover Update or Putback

transaction for potential rename conditions before it begins to propagate files.

When Configuring encounters renamed files, it propagates the name change to the

child in the case of Bringover, and to the parent in the case of Putback. You are

informed of the change in the Transaction Output window with the following

message:

Examined files:

rename from: old_filename
         to: new_filename

Parent
A B C D

A B D

A B C

Rename

Bringover

Parent

Child
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Name History

Configuring stores information about a file’s name history in its SCCS history file.

The name history is a list of the workspace-relative names that have been given to

the file during its lifetime. This information is used by Configuring to differentiate

between files that have been renamed and those that are new. When you rename a

file, Configuring updates the file’s name history during the next Bringover or

Putback transaction that includes it. When a name history is updated, you are

notified in the Transaction Output window.

Rename Conflicts

In rare cases, a file’s name is changed concurrently in parent and child workspaces.

This is referred to as a rename conflict. For example in FIGURE 7-3, the name of file “C”

is changed to “D” in the parent, and concurrently to “E” in the child.

FIGURE 7-3 File “C” Concurrently Renamed in Both Parent and Child Workspaces

Names Summary:
1 updated parent’s name history
1 updated children’s name history

Parent
A B C D

Rename

Child
A B C E

Rename

Parent
A B D

Bringover

Child
A B E
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When this occurs, Configuring determines that both “D” in the parent and “E” in the

child are actually the same file, but with different names. In the case of rename

conflicts:

■ Configuring reports the conflict using the name of the file in the child.

■ Configuring always resolves the conflict by automatically changing the name of

the file in the child workspace to the current (renamed) name in the parent. The

name of the file from the parent is always chosen, even in the case of a Putback

transaction.

When Configuring encounters a rename conflict, you are notified in the Transaction

Output window with the following message:

Deleting Files From Outside Forte TeamWare

Deleting files from a Configuring workspace can be deceptively simple. Deleting a

file from a workspace with something other than Forte TeamWare commands causes

Configuring to determine that the file has been newly created in the workspace’s

parent or child.

In the example in FIGURE 7-4, the file “C” is removed from the child workspace using

the SunOS operating system command rm; later the Bringover Update transaction is

used to update the child.

rename conflict: name_in_child
rename from: name_in_child
         to: name_in_parent
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FIGURE 7-4 File “C” Removed From the Child Using the rm Command, Then Recreated
by Bringover

Configuring examines the two workspaces and determines that the file “C” exists in

the parent and not in the child — following the usual Configuring rules, it creates

“C” in the child.

Always use Forte TeamWare commands to delete files and workspaces.

Deleting Files From Within Forte TeamWare

Use this procedure to delete files, rather than using operating system commands.

This procedure will maintain the relationships and history of the files.

To delete a Forte TeamWare file:

1. Start Versioning.

2. Click on a file.

3. Choose Workspace ➤ Delete Files.

Parent
A B C

Child
A B C

Parent
A B C

Bringover

Child
A B C

C Removed Using rm

C Created by Bringover
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4. Click OK.

Rather than actually deleting the file, Versioning moves the file to a

deleted_files directory. This change gets propagated throughout the workspace

hierarchy as a rename, “deleting” the file in all workspaces.

Using this procedure, you don’t have to worry about a file reappearing after you

have deleted it (see “Deleting Files From Outside Forte TeamWare” on page 101).

Creating a Customized Menu

In Versioning, you can create your own pull-down menu to access other programs or

frequently used commands.

To create a customized menu:

1. In the Configuring window, choose TeamWare ➤ Versioning to open the
Versioning window.

2. In the Versioning window, choose View ➤ Options.

3. Click the Customized Menu tab.

4. In the Customized Menu tab, type the full path name of the command. For
example:

/bin/grep

Forte TeamWare provides two macros to use as arguments to the command: ARGand

FILE.

For example:

/bin/grep $ARGS $FILES

5. Type the name you want to appear in the menu in the Menu Label box.

6. Check the Output Window check box if you want to see the output from your
command.

7. Check the Prompt Window check box if you want to prompt the user for input.

8. Type the text you want to appear in the prompt window in the Prompt box.

9. Click Add to add the menu item to the list.

10. Click Test to test your command.

11. Click OK.
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A new menu titled “Customized” appears in the Versioning window. The command

that you have added is on this menu.

Adding a Path to the Load Menu

Some projects have a complex structure, and it becomes burdensome to click down

several directories or type a long path to get to the files you regularly work with.

Instead, you can add a directory to the File ➤ Load menu.

To add a directory to the Load menu:

1. In the Configuring window, choose TeamWare ➤ Versioning to open the
Versioning window.

2. In the Versioning window, choose View ➤ Options and click the Load Menu
Defaults tab.

3. In the Pathname text box, type the full path name of the directory.

For example:

/set/pubs/Work/Workspaces/TAZ/IntA/sig_team

4. In the Menu Label text box, type the name you want to appear on the Load menu.

For example:

sigteam

5. Click Add.

The menu label appears in the Load Menu Defaults tab.

6. Click OK.

Your menu label is now on the File ➤ Load menu. Select this menu label and

Versioning loads the directory.
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Changing Versioning Properties
■ You can use the Options dialog box (see FIGURE 7-5) to set the Versioning

properties. To open the Options dialog box, choose View ➤ Options.

FIGURE 7-5 Versioning Options Dialog Box
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TABLE 7-3 describes the items in the General tab in the Versioning Options dialog box.

Setting SCCS File Properties

Use the SCCS File Properties dialog box to change SCCS flags. These are options to

the SCCS-admin command. You can learn more about SCCS file properties by

reading the Solaris Programming Utilities Guide or with the command

man sccs-admin .

To set SCCS File Properties:

1. In the Versioning Window, select a single file.

2. Choose File ➤ File Info to open the SCCS File Properties dialog box.

TABLE 7-3 Versioning Options Dialog Box: General Tab

Item Description

Version Control

button

Currently accepts only SCCS.

Main Filelist buttons Lets you specify the type of SCCS files displayed in the

Versioning window.

Double Click Action

buttons

If you select Toggle File State, you can also click Confirm

Double Click Check Out check box if you want the check mark

to be displayed on the file icon until you click OK in the

dialog box.

History Graph check

boxes

Lets you define items for display on the history graph.

History Information

buttons

Lets you select type of history information you want

displayed. If you select Show Entire File History, you can also

specify a command to gather the history.

File History

command text box

Available when you select the Show Entire History File

History button. Lets you specify the options to the sccs prt
command used to display the history file. The default is sccs
prt with no options.

Editor of Choice

menu

Lets you specify an editor that automatically starts up when

you view the contents of a delta or open a delta to edit. If you

select Other, you must type a command in the text box that

will start up your editor in a separate window. The file name

is appended to the supplied command.
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3. Set any of the properties in the SCCS File Properties dialog box.

TABLE 7-4 describes the items in the File Properties dialog box.

TABLE 7-4 SCCS File Properties

Flag Description

Force Encoding

(‘e’ flag)

This field is read only. Values are Yes and No.

Treatment of ‘No id

keywords’

(‘i’ flag)

Tells SCCS to issue either an error or a warning when it encounters

a file with no id keywords.

Empty Releases

(‘n’ flag)
Creates empty releases when releases are skipped. Values are

Allowed and Not Allowed.

Branch Deltas

(‘b’ flag)

Enables branch deltas. Values are Enabled and Disabled.

Concurrent Updates

(‘j’ flag)

Allows concurrent updates. Values are Allowed and Not Allowed.

Ceiling on the

Releases

(‘c’ flag)

Sets a ceiling on the number of releases that can be checked out.

Type a number from 1 to 9999. The default is 9999.

Floor on the

Releases

(‘f’ flag)

Sets a floor on the number of releases that can be checked out. Type

a number from 1 to 9999. The default is 1.

Default SID

(‘d’ flag)

Sets a default delta number, or SID. For example, you could enter

1.6. For a description of SIDs, see “How To Read a File’s History:

Deltas, Branches, and Versions” on page 96.

Lock Releases

(‘l’ flag)

Locks the release against deltas. Any attempt to check out and edit

the file will fail. Type a release number or list of release numbers

separated by commas. (For example: 2.1, 2.1.3).

‘Q’ Keyword Value

(‘q’ flag)

Sets a value for a keyword when the file is opened read-only.

Module Name

(‘m’ flag)

Sets a value for the module name keyword. The default is the SCCS

file name with the leading s removed.

Module Type

(‘t’ flag)

Sets a value for the module type.

Validation Program

(‘v’ flag)

Sets a validation program for the MR (Modification Request)

numbers associated with a new delta. When you attempt to check

in the file, Versioning will prompt you for an MR for the file and

pass the MR to the validation program. If the validation program is

successful, then the check in is allowed.
Chapter 7 Advanced File Management 107



108 Forte TeamWare User’s Guide • August 2001



CHAPTER 8

Using Freezepointing

With Freezepointing, you can preserve a “snapshot” of the files in your workspace

and then retrieve that version of the file at a later time.

The chapter contains the following sections:

■ Introduction to Freezepointing

■ How Freezepointing Works

■ Starting Freezepointing

■ Creating a Freezepoint File

■ Updating a Freezepoint File

■ Extracting Files

■ Automatically Generating Freezepoints

■ Reading Freezepoint Files Format

Introduction to Freezepointing

During the software development process, it is often useful to create freezepoints of

your work at certain times in the release cycle. Freezepoints serve as snapshots of a

project that enable you to later re-create the state of the project at key development

points.

One way to preserve the state of the project is to make a copy of the project files

using the standard backup utilities. This method is effective, but it requires a large

amount of storage resources and time. With Freezepointing, you preserve

freezepoints quickly and simply, using a small amount of storage resource.

This chapter covers the Freezepoint tool, which has a graphical user interface (GUI).

You can also issue freezepoint commands from the command line (see Chapter 10).
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How Freezepointing Works

Freezepointing lets you create freezepoint files from workspaces. At a later time you

can use the freezepoint files to re-create the files and directory hierarchies contained

in the workspaces. By default, Freezepointing extracts only files and directories; that

is, it retrieves the delta of each file without the file history. Freezepointing gives you

the option of recreating a workspace containing the histories for all extracted files.

Creation Defined

When you create a freezepoint file, you specify directories and files to include in the

Directories and Files pane of the Freezepointing window (see FIGURE 8-2).

Freezepointing recursively descends the directory hierarchies and identifies the most

recently checked-in deltas in each history file. Freezepointing then creates a

freezepoint file that consists of a list of those files and unique numerical identifiers

for each delta (see “Reading Freezepoint Files Format” on page 120).

Freezepointing saves the most recently checked-in delta of a file. This may or may

not be the same as the default delta. In the example below, the default delta is 1.3. If

1.2.1.1 is the last delta that has been checked in, Freezepointing will save 1.2.1.1.

FIGURE 8-1 Saving a Freezepointing Delta

Extraction Defined

After you have created a freezepoint file, you can use it to retrieve your files from it.

You specify the name of the freezepoint file, the path name of the directory hierarchy

from which the deltas are to be extracted (if different from the hierarchy from which

it was derived), and the directory where you want the source hierarchy recreated.

Note – Because a freezepoint file is only a list of differences, you must have the

original workspace (or its parent or child) to extract from a freezepoint file.

1.1 1.2 1.3

1.2.1.1
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The extract operation consists of creating a new directory hierarchy based on the

information contained in the freezepoint file. The new hierarchy is comprised of files

defined in the original history files; the history files themselves are not recreated

unless you ask Freezepointing to create a workspace while performing the

extraction. Deltas are extracted from history files located in the original source

workspace.

Source Workspace

The source workspace is the directory hierarchy that contains the SCCS history files

from which the freezepoint file is created. Usually, the source workspace is also the

directory hierarchy from which files are later extracted to recreate the hierarchy. You

can specify an alternate source directory at the time you perform the extract

operation.

Destination Directory

The destination directory is the top-level directory into which the files listed in the

freezepoint file are extracted. You specify the path name of this directory in the

Extract pane of the Freezepointing window.

Starting Freezepointing

To start the Freezepointing tool, do one of the following:

■ Click the Freezeponting button in the Forte for Java TeamWare toolbar

Note: the Forte for Java TeamWare toolbar does not appear by default. See

“Accessing the Forte for Java TeamWare Toolbar” on page 145 for details.

■ From the Forte for Java Explorer window:

i. Right click on a Forte TeamWare directory

ii. Choose TeamWare ➤ Freezepointing

See Chapter 11 for further information about launching Forte TeamWare tools and

accessing commands from within the Forte for Java IDE.

■ Choose TeamWare ➤ Freezepointing in the Configuring (or Versioning, or

Merging) window.

The Freezepointing window opens with the Creation tab displayed (see FIGURE 8-2).
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FIGURE 8-2 Freezepointing Window: Creation Tab

TABLE 8-1 lists the items in the Freezepointing Creation tab.

TABLE 8-1 Freezepointing Creation Tab

Item Description

File menu Provides a command to exit Freezepointing.

View menu Provides the Show Output command, where you can view and save

status and error messages.

TeamWare menu Provides commands for starting other TeamWare tools.

Help menu Provides commands to display help.
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Creating a Freezepoint File

To create a Freezepoint file:

1. In the Configuring Window, choose TeamWare ➤ Freezepointing to open the
Freezepointing window.

The Creation tab is displayed (see FIGURE 8-2).

2. You can accept the default name of freezepoint.out or type the name of the
freezepoint file in the Freezepoint File box.

When you start Freezepointing, the Freezepoint File text box is automatically set to

contain the file freezepoint.out appended to the path name of the directory from

which Freezepointing was started. You can enter your own path or file name. Path

names that are not absolute are assumed to be relative to the directory in which

Freezepointing is started.

Update Freezepoint

File check box

Lets you choose to update an existing freezepoint file rather than

create a new one.

Use Default

Workspace check box

Lets you use the workspace named in the freezepoint file.

Freezepoint File text

box

Lets you type the absolute path name of the freezepoint file.

Workspace text box Lets you specify the source workspace.

Directories and Files

pane

Contains a list of files and directories that will be preserved in the

freezepoint file.

Add Files button Opens the Add Files dialog box, where you can select

files to add to the Directories and Files pane.

Load Entire

Directory button

Loads the entire workspace directory.

Select All buttons Selects all the files and directories listed in the pane.

Deselect All button Deselects all the files and directories listed in the pane.

Comments text box Lets you include a comment with the freezepoint file.

Create button Creates the freezepoint file. Displays the Freezepoint Output box

with messages about the creation.

TABLE 8-1 Freezepointing Creation Tab

Item Description
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3. Type the name of the source workspace in the Workspace text box.

When you start Freezepointing, the Workspace text box is automatically set to the

workspace you have specified using the CODEMGR_WSenvironment variable. If the

variable is not set, and the directory from which Freezepointing is started is

hierarchically within a workspace, the Workspace text box is initialized with the

path name of that workspace.

4. Create a list of the directories and files that you want to preserve in the
Directories and Files pane.

Click the Add Files button to open the Add Files dialog box.

a. Select the files you want to include.

Click a file name to select it. You can Shift-click to select multiple files.

b. Click Add Files to List to add the file(s) to the Directory and Files pane.

The Load Entire Directory button inserts the “./ ” characters into the Directories

and Files pane indicating that the entire workspace hierarchy be included.

5. Type an optional comment in the Comments text field.

The comment is stored in the freezepoint file for future reference.

6. Click Create.

A counter on the bottom left of the Freezepointing window displays the progress of

the freezepoint operation.

Updating a Freezepoint File

To update a freezepoint file:

1. In the Configuring Window, choose TeamWare ➤ Freezepointing to open the
Freezepointing window.

2. Click the Update Freezepoint File check box.

3. You can accept the default name of freezepoint.out or type the name of the
freezepoint file in the Freezepoint File box.

4. Click the browse button to the right of the workspace box or type the name of the
workspace in the Workspace box.

5. Click Add to add files and directories to the Directories and Files list.

6. Type a comment in the Comments box (optional).
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7. Click Update.

8. If you want to update an existing Freezepoint file, select the Update Freezepoint
File check box.

The Use Default Workspace check box is enabled.

To freezepoint the workspace named in the existing Freezepoint File, select the Use

Default Workspace check box.

Extracting Files

To extract a new source hierarchy described by a freezepoint file:

1. In the Configuring Window, choose TeamWare ➤ Freezepointing to open the
Freezepointing window.

The Creation tab is displayed.

2. Click the Extraction tab.

The Extraction tab is displayed (see FIGURE 8-4).

3. Type the path name of your freezepoint file in the Freezepointing File text box.

Path names that are not absolute are assumed to be relative to the directory in which

Freezepointing is started.

4. Click the Full Extract or the Partial Extract radio button.

Full Extract extracts the complete set of frozen files. Partial Extract extracts a subset

that you identify. You must choose either a full or partial extract whether or not you

choose to create a workspace.

5. Click the Create Workspace check box to create a workspace that contains the
SCCS histories of the frozen files.

6. Click one of the three Extract FreezePoint Sources radio buttons to specify the
source workspace.

■ Use default from freezepoint files--uses the path name of the source workspace as

it is in the freezepoint file.

■ You specify--lets you type a workspace path name.

■ Show defaults and comments--displays the path name of the source workspace in

the Workspace text box.

To specify a source workspace hierarchy other than the one contained in the

freezepoint file, click the You specify radio button and type the path name of the

alternate source workspace in the Workspace text box.
Chapter 8 Using Freezepointing 115



7. Type the path name of the directory in which you want the new (extracted)
hierarchy to be located in the Destination Directory text box.

Path names that are not absolute are assumed to be relative to the directory in which

Freezepointing is started.

The destination directory that you specify can be new or existing. If you extract the

hierarchy to an existing directory, you receive a warning message and must confirm

the operation.

8. Click the Extract button to begin the extraction.

If you selected Partial Extract, Freezepointing opens a dialog box listing the source

files in the freezepoint file. Select the files you want to extract.

Clicking the Extract button causes a series of sccs get operations to be performed

on the source files listed in the freezepoint file. The version of each file extracted is

the version specified by the SMID in the freezepoint file. The extracted g-files are

written to destination directory. If you have selected Create Workspace, SCCS

histories are also written to the destination directory.

A counter on the bottom left of the Freezepointing window displays the progress of

the extract operation.

FIGURE 8-3 Freezepoint in Progress

Note – If, during an extraction, Freezepointing cannot locate a file that has been

renamed or deleted, the extraction is aborted and Freezepoint gives you the name of

files it could not find. You must edit the freezepoint file to remove the files. Refer to

the freezepointfile man page for information about determining the new name

of a renamed file.
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FIGURE 8-4 Freezepointing Window: Extraction Tab

TABLE 8-2 lists the items in the Freezepointing Extraction tab.

TABLE 8-2 Freezepointing Extraction Tab

Item Description

File menu Provides a command to exit Freezepointing.

View menu Provides the Show Output command.

TeamWare menu Provides commands for starting other TeamWare tools.

Tabs Lets you switch between the Creation and Extraction tabs of the

Freezepointing window.
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Automatically Generating Freezepoints

You can configure Forte TeamWare to create a freezepoint every time you perform a

certain transactions, such as bringovers and putbacks.

To set an auto-freezepoint:

1. In the Configuring Window, select a workspace.

2. Choose Workspace ➤ Properties.

3. Click the Freezepointing tab.

The Freezepointing tab of the Workspace Properties dialog box is displayed (see

FIGURE 8-5).

4. Click Yes for the time(s) you want a freezepoint created.

5. Click OK.

Full Extract radio

button

Lets you extract the complete set of frozen files.

Partial Extract radio

button

Lets you extract a subset of the frozen files.

Create Workspace

check box

Lets you create a TeamWare workspace from the freezepoint file.

Freezepoint File text

box

Lets you type the absolute path name of the freezepoint file.

Workspace text box Lets you specify the source workspace.

Extract Freezepoint

radio buttons

Use default Uses default from freezepoint file.

You Specify Lets you type a workspace path name.

Show default Uses the path name of the source workspace.

Destination Directory

text box

Lets you specify the path name of the directory in which you want

the new hierarchy to be located.

TABLE 8-2 Freezepointing Extraction Tab (Continued)

Item Description
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.

FIGURE 8-5 Workspace Properties Dialog Box: Freezepointing Tab

Freezepointing creates freezepoint files in your workspace under the

Codemgr_wsdata/Freezepoints directory. Autofreezepoint creates a directory for

each day in the format Codemgr_wsdata/Freezepoints/YYYY/MM/DD where

YYYYis the year, MMis the month, and DDis the day. The freezepoint file has a name

of HHMMSS.fp.Z , where HHis the hour, MMis the minute and SS is the second. The

.Z extension indicates that autofreezepoint files are compressed with the

/bin/compress command.
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Reading Freezepoint Files Format

You can view the contents of a freezepoint file using a standard text editor.

A freezepoint file is a text file that lists the default deltas from the SCCS history files

contained in the workspace hierarchy being preserved. When you later re-create the

hierarchy, Freezepointing uses those entries as pointers back to the original history

files and to the delta that was the default at the time the freezepoint file was created.

The deltas are not identified by their standard SCCS delta ID (SID). Instead, a new

means of identification called an SCCS Mergeable ID (SMID) is used. Using the

SMID enables Freezepointing to work properly with files in which SIDS have been

renumbered as part of a Configuring Bringover Update transaction. For more

information, see “About SCCS Mergeable IDs” on page 176.

The freezepoint file contains the following information:

■ The path name of the workspace from which the list of deltas was created

■ The date and time that the file was created

■ The login name of the user who created the freezepoint

■ A group of hex digits that identifies the most recent SCCS deltas found in each

file’s corresponding SCCS history file

■ A group of hex digits that identifies the root delta in each file’s corresponding

SCCS history file

■ An optional user-supplied comment
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The following example shows a section of a freezepoint file. There are three entries;

the rest of the lines are informational comments.

# Format:
# sfilename (previously SID) date time user hex hex hex hex hex hex hex hex
#
# First four hex’s are the SCCS Mergeable Id of the root delta of the
# containing delta tree.
# Last four hex’s are the SMID of the desired delta.

#sdata=99/03/10 09:20:26
#sdata=SunPro Code Manager data about conflicts, renames, etc...
#sdata=Name history : 1 0 list.c
#leaf=9f7398c4 cc06b ff6ce975 10b7656b
#leaf=f6ea91e2 bbd23cd1 3e052ed1 ca969a9e
./list.c (previously 1.5) 99/06/21 14:04:22 toriw 11db401e cd439eeb
ca3782dc 1aa255e9 97701645 bda0137e d24a3d6b 69f31f25
#sdata=99/03/10 09:20:24
#sdata=SunPro Code Manager data about conflicts, renames, etc...
#sdata=Name history : 2 1 testdir/index.html
#sdata=Name history : 1 0 index.html
#leaf=1fffddc9 85c63827 8172c838 52ba549b
./twtest/testdir/index.html (previously 1.6) 99/06/08 16:21:37 toriw
3ed3beea bb06794d 3f235871 dd89b225 d10d3db7 b8384098 3bb361a0 32e64f5e
#sdata=99/03/10 09:20:24
#sdata=SunPro Code Manager data about conflicts, renames, etc...
#sdata=Name history : 2 1 testdir/routine
#sdata=Name history : 1 0 routine
./twtest/testdir/routine1fs (previously 1.2) 99/03/12 09:11:10 toriw
e59da845 d7e3b7e6 f9e7765f 43d41389 89c058c1 f758edad 81fc5a22 576e5015
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CHAPTER 9

Using the dmake Utility

This chapter describes the way the distributed make (dmake) utility distributes

builds over several hosts to build programs concurrently over a number of

workstations or multiple CPUs.

Note – the dmake utility is only available on the Solaris™ Platform Editions

supported by this release.

■ Basic Concepts

■ Understanding the dmake Utility

■ Impact of the dmake Utility on Makefiles

■ Using the dmake Utility

Basic Concepts

Distributed make (dmake) allows you to concurrently distribute the process of

building large projects, consisting of many programs, over a number of workstations

and, in the case of multiprocessor systems, over multiple CPUs. The dmake utility

parses your makefiles and:

■ Determines which targets can be built concurrently

■ Distributes the build of those targets over a number of hosts

The dmake utility is a superset of the make utility.

To understand dmake, you should know about:

■ Configuration files (runtime and build server)

■ The dmake host

■ The build server
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Configuration Files

The dmake utility consults two files to determine to which build servers jobs are

distributed and how many jobs can be distributed to each.

Runtime Configuration File

The dmake utility searches for a runtime configuration file on the dmake host to

know where to distribute jobs. Generally, this file is in your home directory on the

dmake host and is named .dmakerc . It consists of a list of build servers and the

number of jobs to be distributed to each build server. See “The dmake Host“ section

for more information.

Build Server Configuration File

Each build server that you want to participate in a distributed build must have a

/etc/opt/SPROdmake/dmake.conf file. This file specifies the maximum total

number of dmake jobs that can be distributed to this build server by all dmake users.

In addition, it may specify the “nice” priority under which all dmake jobs should

run.

See “The Build Server” on page 127 for more information.

The dmake Host

The dmake host is defined as the machine on which the dmake command is initially

invoked. The dmake utility searches for a runtime configuration file to determine

where to distribute jobs. Generally, this file must be in your home directory on the

dmake host and is named .dmakerc . The dmake utility searches for the runtime

configuration file in these locations and in the following order:

1. The path name you specify on the command line using the -c option

2. The path name you specify using the DMAKE_RCFILEmakefile macro

3. The path name you specify using the DMAKE_RCFILEenvironment variable

4. $(HOME)/.dmakerc

If a runtime configuration file is not found, the dmake utility distributes two jobs to

the dmake host.
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The runtime configuration file allows you to specify a list of build servers and the

number of jobs you want distributed to each build server. The following is an

example of a .dmakerc file:

■ The entries: falcon , hawk, eagle , heron , and avocet are listed build servers.

■ You can specify the number of jobs you want distributed to each build server. The

default number of jobs is two.

■ Any line that begins with the # character is interpreted as a comment.

Note – In the code example above, list of build servers includes falcon which is

also the dmake host. The dmake host can also be specified as a build server. If you

do not include it in the runtime configuration file, no dmake jobs are distributed to

it.

You can also construct groups of build servers in the runtime configuration file.

dmake provides you with the flexibility of easily switching between different groups

of build servers as circumstances warrant. For instance, you may define groups of

build servers for builds under different operating systems, or you may define groups

of build servers that have special software installed on them.

CODE EXAMPLE 9-1 dmakerc file

# My machine. This entry causes dmake to distribute to it.
falcon { jobs = 1 }
hawk
eagle { jobs = 3 }
# Manager’s machine. She’s usually at meetings
heron { jobs = 4 }
avocet
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The following is an example of a runtime configuration file that contains groups of

build servers:

■ Formal groups are specified by the group keyword and lists of their members are

delimited by braces ({}).

■ Build servers that are members of groups are specified by the optional host
directive.

■ Groups can be members of other groups.

■ Individual build servers can be listed in runtime configuration files that also

contain groups of build servers; in this case, dmake treats these build servers as

members of the unnamed group.

In order of precedence, the dmake utility distributes jobs to the following:

1. The formal group specified on the command-line as an argument to the -g option

2. The formal group specified by the DMAKE_GROUPmakefile macro

3. The formal group specified by the DMAKE_GROUPenvironment variable

earth { jobs = 2 }
mars { jobs = 3 }

group lab1 {
host falcon{ jobs = 3 }
host hawk
host eagle { jobs = 3 }

}

group lab2 {
host heron
host avocet{ jobs = 3 }
host stilt { jobs = 2 }

}

group labs {
group lab1
group lab2

}

group sunos5.x {
group labs
host jupiter
host venus{ jobs = 2 }
host pluto { jobs = 3 }

}
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4. The first group specified in the runtime configuration file

The dmake utility allows you to specify a different execution path for each build

server. By default dmake looks for the dmake support binaries on the build server in

the same logical path as on the dmake host. You can specify alternate paths for build

servers as a host attribute in the .dmakerc file. For example:

You can use double quotation marks to enclose the names of groups and hosts in the

.dmakerc file. This allows you more flexibility in the characters that you can use in

group names. Digits are allowed, as well as alphabetic characters. Names that start

with digits should be enclosed in double quotes. For example:

The Build Server

The /etc/opt/SPROdmake/dmake.conf file is in the file system of build servers.

Use this file to limit the maximum number of dmake jobs (from all users) that can

run concurrently on a build server and to specify the “nice” priority under which all

dmake jobs should run. The following is an example of an /etc/opt/SPROdmake/
dmake.conf file. This file sets the maximum number of dmake jobs permitted to

run on a build server (from all dmake users) to be eight.

Note – If the /etc/opt/SPROdmake/dmake.conf file does not exist on a build

server, no dmake jobs will be allowed to run on that server.

group lab1 {
host falcon{ jobs = 10 , path = "/set/dist/sparc-S2/bin" }
host hawk{ path = "/opt/SUNWspro/bin" }

}

group "123_lab" {
host "456_hawk"{ path = "/opt/SUNWspro/bin" }

}

max_jobs: 8
nice_prio: 5
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Understanding the dmake Utility

To run a distributed make, use the executable file dmake in place of the standard

make utility. You should understand the Solaris make utility before you use dmake.

If you need to read more about the make utility, see the Solaris Programming Utilities
Guide. If you use the make utility, the transition to dmake requires little if any

alteration.

Impact of the dmake Utility on Makefiles

The methods and examples in this section show the kinds of problems that dmake
can help solve. As procedures become more complicated, so do the makefiles that

implement them. You must know which approach will yield a reasonable makefile

that works. The examples in this section illustrate common code-development

predicaments and some straightforward methods to simplify them using dmake.

Using Makefile Templates

If you use a makefile template from the outset of your project, custom makefiles that

evolve from the makefile templates will be:

■ More familiar

■ Easier to understand

■ Easier to integrate

■ Easier to maintain

■ Easier to reuse

The less time you spend editing makefiles, the more time you have to develop your

program or project.

Building Targets Concurrently

Large software projects typically consist of multiple independent modules that can

be built concurrently. The dmake utility supports concurrent processing of targets on

multiple machines over a network. This concurrency can markedly reduce the time

required to build a large project.
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When given a target to build, dmake checks the dependencies associated with that

target and builds those that are out of date. Building those dependencies may, in

turn, entail building some of their dependencies. When distributing jobs, dmake
starts every target that it can. As these targets complete, dmake starts other targets.

Nested invocations of dmake are not run concurrently by default, but this can be

changed (see “Restricting Parallelism” on page 132 for more information).

Since dmake builds multiple targets concurrently, the output of each build is

produced simultaneously. To avoid intermixing the output of various commands,

dmake collects output from each build separately. The dmake utility displays the

commands before they are executed. If an executed command generates any output,

warnings, or errors, dmake displays the entire output for that command. Since

commands started later may finish earlier, this output may be displayed in an

unexpected order.

Limitations on Makefiles

Concurrent building of multiple targets places some restrictions on makefiles.

Makefiles that depend on the implicit ordering of dependencies may fail when built

concurrently. Targets in makefiles that modify the same files may fail if those files are

modified concurrently by two different targets. Some examples of possible problems

are discussed in this section.

Dependency Lists

When building targets concurrently, it is important that dependency lists be

accurate. For example, if two executables use the same object file but only one

specifies the dependency, then the build may cause errors when done concurrently.

For example, consider the following makefile fragment:

When built serially, the target aux.o is built as a dependent of prog1 and is up-to-

date for the build of prog2 . If built in parallel, the link of prog2 may begin before

aux.o is built, and is therefore incorrect. The .KEEP_STATE feature of make detects

some dependencies, but not the one shown above.

all: prog1 prog2
prog1: prog1.o aux.o

$(LINK.c) prog1.o aux.o -o prog1
prog2: prog2.o

$(LINK.c) prog2.o aux.o -o prog2
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Explicit Ordering of Dependency Lists

Other examples of implicit ordering dependencies are more difficult to fix. For

example, if all of the headers for a system must be constructed before anything else

is built, then everything must be dependent on this construction. This causes the

makefile to be more complex and increases the potential for error when new targets

are added to the makefile. The user can specify the special target .WAIT in a

makefile to indicate this implicit ordering of dependents. When dmake encounters

the .WAIT target in a dependency list, it finishes processing all prior dependents

before proceeding with the following dependents. More than one .WAIT target can

be used in a dependency list. The following example shows how to use .WAIT to

indicate that the headers must be constructed before anything else.

You can add an empty rule for the .WAIT target to the makefile so that the makefile

is compatible with the make utility.

Concurrent File Modification

You must make sure that targets built concurrently do not attempt to modify the

same files at the same time. This can happen in a variety of ways. If a new suffix rule

is defined that must use a temporary file, the temporary file name must be different

for each target. You can accomplish this by using the dynamic macros $@or $* . For

example, a .c.o rule that performs some modification of the .c file before

compiling it might be defined as:

all: hdrs .WAIT libs functions

.c.o:
awk -f modify.awk $*.c > $*.mod.c
$(COMPILE.c) $*.mod.c -o $*.o
$(RM) $*.mod.c
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Concurrent Library Update

Another potential concurrency problem is the default rule for creating libraries that

also modifies a fixed file, that is, the library. The inappropriate .c.a rule causes

dmake to build each object file and then archive that object file. When dmake
archives two object files in parallel, the concurrent updates will corrupt the archive

file.

A better method is to build each object file and then archive all the object files after

completion of the builds. An appropriate suffix rule and the corresponding library

rule are:

Multiple Targets

Another form of concurrent file update occurs when the same rule is defined for

multiple targets. An example is a yacc (1) program that builds both a program and a

header for use with lex (1). When a rule builds several target files, it is important to

specify them as a group using the + notation. This is especially so in the case of a

parallel build.

This rule is actually equivalent to the two rules:

.c.a:
$(COMPILE.c) -o $% $<
$(AR) $(ARFLAGS) $@ $%
$(RM) $%

.c.a:
$(COMPILE.c) -o $% $<
$(COMPILE.c) -o $% $<

lib.a: lib.a($(OBJECTS))
$(AR) $(ARFLAGS) $(OBJECTS)
$(RM) $(OBJECTS)

y.tab.c y.tab.h: parser.y
$(YACC.y) parser.y

y.tab.c: parser.y
$(YACC.y) parser.y

y.tab.h: parser.y
$(YACC.y) parser.y
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The serial version of make builds the first rule to produce y.tab.c and then

determines that y.tab.h is up-to-date and need not be built. When building in

parallel, dmake checks y.tab.h before yacc has finished building y.tab.c and

notices that y.tab.h does need to be built, it then starts another yacc in parallel

with the first one. Since both yacc invocations are writing to the same files

(y.tab.c and y.tab.h ), these files are apt to be corrupted and incorrect. The

correct rule uses the + construct to indicate that both targets are built simultaneously

by the same rule. For example:

Restricting Parallelism

Sometimes file collisions cannot be avoided in a makefile. An example is xstr (1),

which extracts strings from a C program to implement shared strings. The xstr
command writes the modified C program to the fixed file x.c and appends the

strings to the fixed file strings . Since xstr must be run over each C file, the

following new .c.o rule is commonly defined:

The dmake utility cannot concurrently build targets using this rule since the build of

each target writes to the same x.c and strings files. Nor is it possible to change

the files used. You can use the special target .NO_PARALLEL: to tell dmake not to

build these targets concurrently. For example, if the objects being built using the

.c.o rule were defined by the OBJECTSmacro, the following entry would force

dmake to build those targets serially:

If most of the objects must be built serially, it is easier and safer to force all objects to

default to serial processing by including the .NO_PARALLEL: target without any

dependents. Any targets that can be built in parallel can be listed as dependencies of

the .PARALLEL: target:

y.tab.c + y.tab.h: parser.y
$(YACC.y) parser.y

.c.o:
$(CC) $(CPPFLAGS) -E $*.c | xstr -c -
$(CC) $(CFLAGS) $(TARGET_ARCH) -c x.c
mv x.o $*.o

.NO_PARALLEL: $(OBJECTS)

.NO_PARALLEL:

.PARALLEL: $(LIB_OBJECT)
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Nested Invocations of Distributed Make

When dmake encounters a target that invokes another dmake command, it builds

that target serially, rather than concurrently. This prevents problems where two

different dmake invocations attempt to build the same targets in the same directory.

Such a problem might occur when two different programs are built concurrently,

and each must access the same library. The only way for each dmake invocation to

be sure that the library is up-to-date is for each to invoke dmake recursively to build

that library. The dmake utility recognizes a nested invocation only when the

$(MAKE) macro is used in the command line.

If you nest commands that you know will not collide, you can force them to be done

in parallel by using the .PARALLEL: construct.

When a makefile contains many nested commands that run concurrently, the load-

balancing algorithm may force too many builds to be assigned to the local machine.

This may cause high loads and possibly other problems, such as running out of

swap space. If such problems occur, allow the nested commands to run serially.

Using the dmake Utility

You execute dmake on a dmake host and distribute jobs to build servers. You can also

distribute jobs to the dmake host, in which case it is also considered to be a build

server. The dmake utility distributes jobs based on makefile targets that dmake
determines (based on your makefiles) can be built concurrently. You can use a

machine as a build server if it meets the following requirements:

■ From the dmake host (the machine you are using) you must be able to use rsh ,

without being prompted for a password, to remotely execute commands on the

build server. See the rsh (1) man page for more information about the rsh
command. For example:

■ The bin directory in which the dmake software is installed must be accessible

from the build server. It is common practice to have all build servers share a

common dmake installation directory. See the share (1M) and mount (1M) man

pages or the system AnswerBook documentation for more information about

creating shared filesystems.

demo% rsh build_server which dmake
/opt/SUNWspro/bin/dmake
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■ By default, dmake assumes that the logical path to the dmake executables on the

build server is the same as on the dmake host. You can override this assumption

by specifying a path name as an attribute of the host entry in the runtime

configuration file. For example:

■ The source hierarchy you are building must be:

■ Accessible from the build server

■ Mounted under the same name

From the dmake host you can control which build servers are used and how many

dmake jobs are allotted to each build server. The number of dmake jobs that can run

on a given build server can also be limited on that server.

If you specify the -m option with the parallel argument, or set the DMAKE_MODE
variable or macro to the value parallel , dmake does not scan your runtime

configuration file. Therefore, you must specify the number of jobs using the -j
option or the DMAKE_MAX_JOBSvariable or macro. If you do not specify a value this

way, a default of two jobs is used.

If you modify the maximum number of jobs using the -j option, or the

DMAKE_MAX_JOBSvariable or macro when using dmake in distributed mode, the

value you specify overrides the values listed in the runtime configuration file. The

value you specify is used as the total number of jobs that can be distributed to all

build servers.

If you access dmake from the Building window, use the online help to see how to

specify your build servers and jobs. If you access dmake from the command line, see

the dmake man page (dmake.1 ).

group sparc-cluster {
   host wren   { jobs = 10 , path = “/export/SUNWspro/bin”}
   host stimpy { path = “/opt/SUNWspro/bin”             }
134 Sun WorkShop TeamWare User’s Guide • July 2001



CHAPTER 10

Forte TeamWare Shortcuts

Forte TeamWare provides several shortcuts to make it easier to use. This chapter

discusses the following topics:

■ Accessing TeamWare From the Command Line

■ GUI Shortcuts

Accessing TeamWare From the
Command Line

In addition to working with Forte TeamWare tools through the graphical user

interface (GUI), you can also type TeamWare commands at any system prompt. You

can access Forte TeamWare commands through the GUI and at the command line,

and both can be used interchangeably. You can simultaneously use the GUI for some

functions and work at the command line for others. You can include these

commands in scripts or programs to further automate your file management.

For information on accessing Forte TeamWare from the command line in a Microsoft

Windows environment, see “Using the Command-Line Interface” on page 219.
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Configuring Commands

To see a list of Configuring commands, type codemgr.

This list includes the syntax of each command with command options enclosed in

square brackets. For example, here is the syntax of the bringover command:

Here’s how you could issue a bringover command at the command line:

Forte TeamWare tools provide several ways to reduce typing long command lines,

including environment variables and argument files that store previously specified

arguments. To get a detailed description of the command and the options you can

use with it, see the corresponding man page, available through the Forte TeamWare

online help.

Note – Forte TeamWare man pages are no longer available through the command

man pages are no longer available through the command line interface, but through

the online help system. To access Forte TeamWare man pages, choose Command

Reference in the upper contents frame of the Forte TeamWare online help system.

See “Accessing Man Pages” on page 2.

example% codemgr
bringover ...
codemgrtool
help
putback ...
resolve ...
workspace ....
ws_undo  ....

bringover [-w child_ws] [-p parent_ws] [-c comment]
[-m comment_file] [[-f flp]...] [-n] [-g] [-q] [-v] [-B] [-C]
[files and dirs]

% bringover -w my_child  -p their_parent  /usr/ws/project
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TABLE 10-1 lists often-used Configuring menu items and their corresponding

commands.

To make a workspace the default for command line commands, set the CODEMGR_WS
environment variable. See “Configuring Environment Variables” on page 52.

Versioning Commands

To start Versioning from the command line, type twversion followed by the

ampersand (&):

Merging Commands

To start Merging from the command line without loading any input files (assuming

that the Merging executable is in your search path), at a shell command prompt,

type twmerge followed by the ampersand (&):

The twmerge command starts Merging (in the background) without loading any

files. To start Merging with files loaded in each window, see “Loading Two Files at

Startup” on page 138.

TABLE 10-1 Configuring Menu Items and Corresponding Commands

GUI Menu Item Corresponding Command

Create Workspace workspace create

Rename workspace move

Parent workspace parent

Bringover Create bringover

Bringover Update bringover

Putback putback

Undo ws_undo

Resolve resolve

demo% twversion &

demo% twmerge &
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The complete twmerge command is summarized below, with command options

enclosed in square brackets.

Loading Two Files at Startup

To load two files at the time you start Merging from the command line, change to the

directory in which the files are stored and specify the file names on the command

line. To merge two files named file_1 and file_2 , use the following command:

The first file listed appears in the left text pane; the second file appears in the right

pane.

Loading Three Files at Startup

To merge the same two files and at the same time compare them to a common

ancestor named ancestor_file , change to the directory in which the files are

stored and use the following command:

The ancestor file is not displayed, but differences between the ancestor file and the

two descendants are marked, and the merged output file is based on the ancestor

file.

twmerge [-b] [-r] [-tabsize number] [-diffopt [bwi]]
[-a  ancestor] [-f1  name1] [-f2  name2]
[-l listfile] [  leftfile rightfile [outfile]  ] [-V]

demo% twmerge  file_1 file_2  &

demo% twmerge -a ancestor_file file_1 file_2 &
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Freezepoint Commands

You can create, update, and extract freezepoints at the command line. To see a list of

Freezepoint commands, type freezept .

GUI Shortcuts

There are several shortcuts built into the Forte TeamWare interface. These apply to

the selection of workspaces, directories and files:

■ Click an icon to select a single workspace, file or directory. Shift-click to select

multiple workspaces, files or directories.

■ Select groups of files by clicking the left mouse button in an empty portion of the

dialog box and dragging the bounding box to surround any number of icons.

When you release the button, all the files within the bounding box are selected.

■ Select files and directories by moving the pointer over any file or directory icon

and clicking. You can extend the selection to include any number of additional

files and directories by moving the pointer over them and clicking the middle

mouse button.

example% freezept
compare ...
create ...
diff ...
extract ...
help
sid ...
smid ...
update  ....
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TABLE 10-2 lists other Forte TeamWare mouse and keyboard shortcuts.

TABLE 10-2 Mouse and Keyboard Shortcuts

Action Result For More Information

Drag and drop workspace

icon on an open area.

Displays Bringover Create

Transaction dialog box.

Drag and drop parent

workspace icon on a child

workspace icon.

Displays Bringover Update tab in

the transaction dialog box.

Drag and drop child

workspace icon on a

parent workspace icon.

Displays Putback tab in the

Transaction dialog box.

Drag and drop workspace

icon on an unrelated

workspace icon.

Displays a pop-up dialog box

asking if you want to perform a

bringover or a putback.

Control+drag and drop

workspace icon on

another workspace.

Reparents workspace. “Reparenting a

Workspace” on

page 44.

Control+drag and drop

workspace icon on an

open area.

Orphans workspace. “Reparenting a

Workspace” on

page 44.

Click workspace icon

name field.

Renames workspace.

Click right mouse button

in Configuring.

Displays a combination menu of

File, Workspace and Transaction

menus.

Double-click workspace

workspace icon in

Configuring.

Launches a tool. User configurable,

Versioning is the default.

“Double-Click

Actions in

Configuring” on

page 141.

Double-click icon of a

workspace that contains

conflicts.

Launches a tool. User configurable,

Resolve window is the default.

“Double-Click

Actions in

Configuring” on

page 141.

Double-click on file icon

in Versioning.

Checks out the file or displays file

history; user configurable.

“Double-Click

Actions in

Configuring” on

page 141.

Double-click on delta in

Versioning File History.

Displays the delta in your default

editor.

“Double-Click

Actions in

Configuring” on

page 141.
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Double-Click Actions in Configuring

When you double-click with the pointer over a workspace icon, the TeamWare

Versioning is automatically started (with the selected workspace automatically

loaded). If you double-click when the pointer is over the icon of a workspace that

contains unresolved conflicts, Configuring automatically activates the Resolve tab.

Conflicted files from the selected workspace are automatically loaded and ready for

processing. You can customize Configuring double-click behavior using the Tool

Properties dialog box (see FIGURE 3-7).

Double-Click Actions in Versioning

By default, double-clicking on a file in the Versioning window “toggles” the state of

the file, that is, it will check out the file, or if the file is already checked out, it will

check in the file. You can change the double-click action to display the file history

instead in Versioning Options (View ➤ Options, General Tab). See “Changing

Versioning Properties” on page 105.

Double-Click Action File History

Double-clicking on a delta in the Versioning File History window displays the delta

in your default editor.

Click right mouse button

in Versioning.

Displays a combination menu of

Select Files and commands menu.

Click right mouse button

in Versioning File History.

Displays a combination menu of the

Version menu and Merge Branches.

“Viewing File

History” on page 94.

Click right mouse button

in Merging.

Displays the Navigate menu. “Resolving

Differences” on

page 82.

TABLE 10-2 Mouse and Keyboard Shortcuts (Continued)

Action Result For More Information
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CHAPTER 11

Using Forte TeamWare From Within
the Forte for Java IDE

With this release, Forte TeamWare is an integration module that can be optionally

installed with the Forte for Java integrated development environment (IDE). This

chapter explains the relationship between the Forte TeamWare integration module

and the Forte for Java IDE and documents additional access points to Forte

TeamWare commands from within Forte for Java.

The chapter contains the following sections:

■ Using Forte TeamWare With Forte for Java

■ Accessing Forte TeamWare Commands and Features

Using Forte TeamWare With Forte for
Java

Forte TeamWare is an integration module that can be optionally installed along with

Forte for Java. In this context, Forte TeamWare operates within the Forte for Java

environment. The Forte for Java GUI provides direct access points to Forte

TeamWare tools and commands.

Forte TeamWare also exists as a standalone application that does not require the

Forte for Java IDE.

What Is Forte for Java?

Forte for Java is a cross-platform, extensible IDE for the Java platform. It includes a

user interface along with editing, compiling, and debugging features. Forte for Java

provides additional features that are designed to enable small teams to quickly and

efficiently build web-based applications that connect to databases.
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Forte TeamWare Functionality Within Forte for

Java

Forte TeamWare functionality within the Forte for Java IDE is implemented at two

different levels:

■ Many Versioning and Configuring tool commands are available directly from the

Forte for Java GUI.

■ All remaining commands and features are accessible through the native Forte

TeamWare GUI tools, which can be easily launched from the Forte for Java GUI.

Within the Forte for Java IDE, Forte TeamWare commands can be found in the

following locations:

■ Contextual menus (activated by right-clicking the mouse)

■ The TeamWare toolbars (abbreviated and full)

■ The Versioning menu

Mounting a Forte TeamWare Filesystem

In order to access Forte TeamWare workspaces within the Forte for Java Explorer

window, you must first mount the Forte TeamWare workspace by doing one of the

following:

■ In the Forte for Java main window:

i. Choose File ➤ Mount Filesystem

ii. Select Add (other file system type)

iii. Select TeamWare Version Control System for Type

iv. Click Browse and specify the path to the existing workspace

■ In the Forte for Java main window:

i. Choose Versioning ➤ Mount TeamWare Version Control System or
Versioning ➤ New TeamWare Workspace to load (an existing) or create (a
new) Forte TeamWare workspace respectively

ii. In the Mount Existing TeamWare File System dialog, type the path of the
workspace and click Mount or in the New TeamWare Workspace dialog, type
the path for the new workspace and click Create.

■ In the Forte for Java Explorer window:

i. Right-click on Filesystems

ii. Choose Mount TeamWare Version Control System
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■ In the Configuring tool:

i. Choose File ➤ Load Workspaces or File ➤ Create Workspace to load (an
existing) or create (a new) Forte TeamWare workspace respectively

ii. In the Load Workspaces dialog, select the workspace or specify the full path
of the workspace to be loaded and click Load Workspaces.

iii. In the TeamWare Configuring window, select the workspace and choose
Workspace ➤ Mount in Explorer or right-click on the workspace and choose
Mount in Explorer

Accessing the Forte for Java TeamWare Toolbar

If the Forte TeamWare module is installed with the Forte for Java IDE, an

abbreviated Forte TeamWare toolbar is displayed by default when the Forte for Java

IDE is first launched. The abbreviated toolbar consists of the TeamWare Configuring

icon and the New TeamWare Workspace icon. To access the full Forte for Java

TeamWare toolbar:

1. Right-click anywhere in the existing toolbar (but not directly over a toolbar icon)

2. Choose TeamWare (Full) from the context menu

Note – You may also disable the abbreviated Forte TeamWare toolbar, by

deselecting TeamWare from the context menu.

Forte for Java and Forte TeamWare in Action

FIGURE 11-1 illustrates the Forte for Java IDE in conjunction with the Forte

TeamWare integration module. The Forte for Java GUI windows are labeled along

with their access points to Forte TeamWare commands and features. The full Forte

TeamWare toolbar has been activated.
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FIGURE 11-1 Forte for Java With Forte TeamWare Integration Module

Forte for Java
Main window

Forte for Java
Editor window

Forte TeamWare
Configuring window

Forte for Java
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TeamWare toolbar Forte for Java

Versioning menu

Contextual menu
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Accessing Forte TeamWare Commands
and Features

The following charts briefly list Forte TeamWare commands and features available

from the Forte for Java GUI. For further details see the corresponding chapters in

this book and the Forte TeamWare online help.

Note – These charts assume you have activated the full Forte TeamWare toolbar,

which does not appear by default. See “Accessing the Forte for Java TeamWare

Toolbar” on page 145 for details.

Forte TeamWare Tools and Tasks

TABLE 11-1 lists Forte TeamWare tools, their main associated tasks that are available

within Forte for Java, and alternative access methods.

TABLE 11-1 Forte TeamWare Tools, Tasks, and Access Methods

Configuring (See Chapter 2 for more information about Configuring tool)

• Open Forte TeamWare Configuring Tool

Forte for Java

TeamWare Toolbar

Click the Configuring button

Forte for Java

Explorer

1. Right-click on a mounted Forte TeamWare

file system or a directory that is accessible

to Forte TeamWare

2. Choose TeamWare ➤ Configuring

• Create new Forte TeamWare workspace

Forte for Java

Menubar

Choose Versioning ➤ New TeamWare

Workspace

Forte for Java

TeamWare Toolbar

Click the New TeamWare Workspace button

Configuring Tool Choose File ➤ Create Workspace
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• Load existing Forte TeamWare workspace

Forte for Java

TeamWare Toolbar

1. Click the TeamWare Configuring button

2. In the Configuring tool, choose

File ➤ Load Workspaces

Forte for Java

Explorer

1. Right-click on Filesystems

2. Choose Mount TeamWare Version Control

System

3. In the Mount Existing TeamWare File

System dialog, type the full pathname of a

workspace

Forte for Java

Menubar

1. Choose Versioning ➤ Mount TeamWare

Version Control System

2. In the Mount Existing TeamWare File

System dialog, type the name of a

workspace

Configuring Tool Choose File ➤ Load Workspaces

• Putback

Forte for Java

Explorer

1. Right-click on a Forte TeamWare file

system or directory

2. Choose TeamWare ➤ Putback

Forte for Java

Menubar

Choose Versioning ➤ TeamWare ➤ Putback

after selecting a Forte TeamWare file system

or directory in the Forte for Java Explorer

window

Configuring Tool Choose Actions ➤ Putback

• Bringover

Forte for Java

Explorer

1. Right-click on a Forte TeamWare directory

2. Choose TeamWare ➤ Bringover

Forte for Java

Menubar

Choose Versioning ➤ TeamWare ➤
Bringover after selecting a Forte TeamWare

file system or directory in the Forte for Java

Explorer

Configuring Tool Choose Actions ➤ Bringover Create

or Actions ➤ Bringover Update

Merging (See Chapter 6 for more information about Merging tool)

• Open Forte TeamWare Merging Tool

Forte for Java

TeamWare Toolbar

Click the TeamWare Merging button

TABLE 11-1 Forte TeamWare Tools, Tasks, and Access Methods
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Forte for Java

Explorer

1. Right-click on a Forte TeamWare file or

directory

2. Choose TeamWare ➤ Merging

Forte for Java

Menubar

Choose Versioning ➤ TeamWare ➤ Merging

after selecting a Forte TeamWare file, file

system or directory in the Forte for Java

Explorer

Freezepointing (See Chapter 8 for more information about Freezepointing tool)

• Open Forte TeamWare Freezepointing Tool

Forte for Java

TeamWare Toolbar

Click the TeamWare Freezepointing button

Forte for Java

Explorer

1. Right-click on a Forte TeamWare file or

directory

2. Choose TeamWare ➤ Freezepointing

Forte for Java

Menubar

Choose Versioning ➤ TeamWare ➤
Freezepointing after selecting a Forte

TeamWare file system or directory in the

Forte for Java Explorer.

TABLE 11-1 Forte TeamWare Tools, Tasks, and Access Methods
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Versioning (See Chapter 5 for more information about Versioning tool)

• Open Forte TeamWare Versioning Tool

Forte for Java

TeamWare Toolbar

Click the Versioning button

Forte for Java

Explorer

1. Right-click on a Forte TeamWare directory

2. Choose TeamWare ➤ Versioning

Forte for Java

Menubar

Choose Versioning ➤ TeamWare ➤
Versioning after selecting a Forte TeamWare

file, file system or directory in the Forte for

Java Explorer

• Check Out or Check Out and Edit

Forte for Java

Explorer

1. Right-click on a file that is CheckedIn

2. Choose Checkout or Checkout and Edit

Forte for Java

TeamWare Toolbar

Click the Check Out button

Forte for Java

Menubar

Choose Versioning ➤ Check Out or

Versioning ➤ Check Out and Edit after

selecting a checked in file contained in a

mounted Forte TeamWare filesystem

Versioning Tool Choose Commands ➤ Check Out

or Commands ➤ Check Out and Edit

• Check In

Forte for Java

Explorer

1. Right-click on a file that is CheckedOut

2. Choose Check In

Forte for Java

TeamWare Toolbar

Click the Check In button

Forte for Java

Menubar

Choose Versioning ➤ Check In after selecting

a checked out or new file contained in a

mounted Forte TeamWare filesystem

Versioning Tool Choose Commands ➤ Check In

• Uncheckout

Forte for Java

Explorer

1. Right click on a file that is CheckedOut

2. Choose Uncheckout

Forte for Java

Menubar

Choose Versioning ➤ Uncheckout after

selecting a checked out file contained in a

mounted Forte TeamWare filesystem

Versioning Tool Choose Commands ➤ Uncheckout

TABLE 11-1 Forte TeamWare Tools, Tasks, and Access Methods
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GUI Elements and Forte TeamWare Commands

TABLE 11-2 lists all Forte TeamWare commands available from within the Forte for

Java IDE for each Forte for Java GUI element.

• File History

Forte for Java

Explorer

1. Right-click on a Forte TeamWare file

2. Choose TeamWare ➤ File History

Versioning Tool Choose File ➤ File History

TABLE 11-2 Forte for Java GUI Element and associated Forte TeamWare Commands

GUI Element Description

TeamWare
Toolbar

Check Out

(only available when a checked

in Forte TeamWare file is

selected in the Explorer)

Checks out a Forte TeamWare file.

Check In

(only available when a checked

out Forte TeamWare file is

selected in the Explorer)

Checks in a Forte TeamWare file.

New TeamWare Workspace Creates a new Forte TeamWare

workspace

Configuring Opens Forte TeamWare Configuring tool

Versioning Opens Forte TeamWare Versioning tool

Merging Opens Forte TeamWare Merging tool

Freezepointing Opens Forte TeamWare Freezepointing

tool

Menubar

Versioning menu

New TeamWare Workspace Creates a new Forte TeamWare

workspace

TABLE 11-1 Forte TeamWare Tools, Tasks, and Access Methods
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Mount TeamWare Version

Control System

Mounts an existing Forte TeamWare

filesystem and makes it accessible from

the Explorer window

Explorer Window

Contextual menu – when a Forte TeamWare file is selected.

Note: These context sensitive menu items are also available via the Versioning

menu on the Forte for Java menubar.

TeamWare ➤ Versioning Opens Forte TeamWare Versioning tool

TeamWare ➤ Merging Opens Forte TeamWare Merging tool

TeamWare ➤ File History Opens Forte TeamWare Versioning tool’s

File History dialog box. Same as

Versioning tool, File ➤ File History

TeamWare ➤ Refresh Updates Forte TeamWare directory

listing

TeamWare ➤ Move Opens Forte TeamWare Versioning

Tool’s Move Files dialog box. Moves the

current copy of the file and its history

file to the specified destination.

• Note: The Move action on a file is

only enabled for a file under Forte

TeamWare’s source control and only

allowed within the same Forte

TeamWare workspace. The file’s

permission settings prior to the Move

action are preserved after the Move

operation is performed. The package

statement inside java files are not

updated automatically to reflect the new

package directory location.

Renaming of the file is not allowed with

this operation.

TABLE 11-2 Forte for Java GUI Element and associated Forte TeamWare Commands

GUI Element Description
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TeamWare ➤ Delete Moves the file to the Forte TeamWare

deleted_files directory if the

selected file’s current state is Checked

In.

If the file’s current state is Checked Out,

the Forte TeamWare Versioning Checkin

or Uncheckout Confirmation dialog box

is displayed and prompts the user to

select Check In, Uncheckout or Cancel.

Note: This action is only enabled for

files under Forte TeamWare’s source

control.

TeamWare ➤ Get Default

Version

• If the file’s state is Checked In and it is

is read-only, this operation fetches the

latest default version of the file and

replaces the current copy loaded in the

Forte for Java Explorer window.

• If the file’s state is Checked Out and

the file is writable, the latest default

version is not fetched.

Check In

(only available if a checked-out

Forte TeamWare file is selected

or if the file is new and is

marked as Check-in Needed)

Checks in a Forte TeamWare file

Check Out

(only available if a checked-in

Forte TeamWare file is selected)

Checks out a Forte TeamWare file

Check Out and Edit

(only available if a checked-in

Forte TeamWare file is selected)

Checks out a Forte TeamWare file and

opens it in the Forte for Java IDE editor.

(Note: the type of editor used depends

on the file’s type. Please see “Forte for

Java IDE Editor and Forte TeamWare

Tools” on page 156 for further details.

Uncheckout Reverses changes to a Forte TeamWare

file

TABLE 11-2 Forte for Java GUI Element and associated Forte TeamWare Commands

GUI Element Description
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Cut / Paste • If the destination is within the same

Forte TeamWare workspace, the current

copy of the file and its history are

moved to the destination directory

specified with the Paste action. The

package statement inside java files are

updated automatically to reflect the new

package directory location.

• If the destination directory specified

with the Paste action is outside of the

current Forte TeamWare workspace, the

current copy of the selected file is moved

to that directory and the associated

history file is moved to the

deleted_files directory of the

current Forte TeamWare workspace. The

package statement inside java files are

updated automatically to reflect the new

package directory location.

Note: It is highly recommended that the

TeamWare ➤ Move action is used

instead.

Copy / Paste Copies only the current copy of the file

and not its history to the destination

directory specified with the Paste action.

Delete Moves the Forte TeamWare controlled

file to the Forte TeamWare

deleted_files directory. If the file is

not under Forte TeamWare source

control, it is deleted from the filesystem.

Rename Renames the current copy of the file and

its history file under the SCCS directory.

Contextual menu – when a Forte TeamWare Versioning File System or directory is

selected

Note: These context sensitive menu items are also available via the Versioning

menu on the Forte for Java men bar.

TeamWare ➤ Versioning Opens Forte TeamWare Versioning tool

TeamWare ➤ Merging Opens Forte TeamWare Merging tool

TeamWare ➤ Configuring Opens Forte TeamWare Configuring tool

TABLE 11-2 Forte for Java GUI Element and associated Forte TeamWare Commands

GUI Element Description
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Freezepointing Opens Forte TeamWare Freezepointing

tool

TeamWare ➤ Putback Performs a putback transaction on the

selected directory

TeamWare ➤ Bringover Performs a bringover transaction on the

selected directory

TeamWare ➤ Update Performs a non-recursive Get Default

Version action on each of the files in the

selected directory.

TeamWare ➤Update

(Recursive)

Performs a recursive Get Default Version

action on each of the files in the selected

directory.

TeamWare ➤ Move Opens Forte TeamWare Versioning

Tool’s Move Files dialog box. Moves the

current copy of each file contained in the

directory and its associated history file

to the specified destination directory.

Note: The Move action on a directory is

only enabled for a directory under Forte

TeamWare’s source control and only

allowed within the same Forte

TeamWare workspace. The directory’s

permission settings prior to the Move

action are preserved after the Move

operation is performed. Renaming of the

directory is not allowed with this

operation.

TeamWare ➤ Delete Moves the directory to the Forte

TeamWare deleted_files directory.

Note: This action is enabled for files

under Forte TeamWare’s source control.

TeamWare ➤ Refresh Refreshes the Forte TeamWare directory

listing

TABLE 11-2 Forte for Java GUI Element and associated Forte TeamWare Commands

GUI Element Description
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Forte for Java IDE Editor and Forte TeamWare

Tools

Forte TeamWare uses a file editor for both source and temporary files in the

following actions.

■ From the Forte TeamWare Versioning window:

■ File ➤ New

■ File ➤ View

■ File ➤ Edit (for checked-out file)

■ Commands ➤ Checkout and Edit

When any of the above actions is selected, a Forte for Java’s IDE source editor is

opened. The type of source editor used depends on the file’s type.

The following table describes the file editor used as a result of the Forte

TeamWare Versioning File action.

■ From the Forte TeamWare File History Viewer window:

TABLE 11-3 File Editor Used Based on Selected File’s Mount Status

Selected File’s Mount Status
Result of Forte TeamWare Versioning File
Action

File is mounted in the Forte for Java Explorer Opens the appropriate Forte for Java

Editor window, depending on the file

type.

File is not mounted in the IDE Explorer, but is

part of a Forte TeamWare workspace

• If the file’s type is not .java, a Forte for

Java Editor window is opened. The type

of Editor used depends on the file’s

type.

• If the file’s type is java, an attempt is

made to determine the Java package to

which the file belongs. The user is either

asked to confirm the package

determined or is asked to select a

package. The selected mount point is

mounted in the Forte for Java Explorer

window as a Forte TeamWare filesystem.

The Forte for Java Editor window iis

opened.

File is not mounted in the IDE Explorer and is

not part of a Forte TeamWare workspace, but is

under version control

Opens the default editor as set under the

Forte TeamWare Versioning View ➤
Options dialog.
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■ View ➤ Diff in Text Window

■ View ➤ Diff With Context

■ View ➤ Show File Contents

When one of the above actions is selected, a temporary file is created and the file

is displayed via a Forte TeamWare Viewer [temporary-filename] window. The

temporary file will not be mounted as a filesystem in the Forte for Java Explorer

window.
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CHAPTER 12

Forte TeamWare Architecture

This chapter describes the underlying files that Forte TeamWare uses to track

workspaces and files. It also describes the ways Configuring manipulates SCCS

history files when you copy files between workspaces and resolve conflicts.

This chapter discusses the following topics:

■ Workspace Metadata Directory

■ Configuring Defaults Files

■ How Configuring Merges Files

■ About SCCS Mergeable IDs

Workspace Metadata Directory

A Configuring workspace is a directory hierarchy that contains a directory named

Codemgr_wsdata in its root directory. The Configuring program stores data

(metadata) about that workspace in Codemgr_wsdata . Configuring commands use

the presence or absence of this directory to determine whether a directory is a

workspace.

Configuring provides the tools necessary to maintain the information kept in the

Codemgr_wsdata directory. Although not recommended, it might be necessary to

modify certain files manually; however, you must be very careful to preserve the
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format of each file you edit. TABLE 12-1 briefly describes each of the files and

directories contained in the Codemgr_wsdata directory. Information regarding the

format of these files is available in the man(4) page for each file.

TABLE 12-1 Contents of the Codemgr_wsdata Metadata Directory

File/Dir Name Description

access_control Contains information that controls which users are allowed to

execute Configuring transactions and commands for a given

workspace. When workspaces are created, a default access control

file is also created. See Chapter 4 and “The access_control File” on

page 162.

args Contains a list of file, directory, and FLP arguments and is

maintained by the Configuring, Bringover, and Putback transaction

commands. Initially, the args file contains the arguments specified

when the workspace was created. If you explicitly specify

arguments during subsequent Bringover or Putback transactions,

the commands determine if the new arguments are more

encompassing than the arguments already in the args file; if they

are, the new arguments replace the old. See “Creating Customized

Bringover and Putback File Lists” on page 40.

backup/ Stores information that Configuring uses to “undo” a Bringover or

Putback transaction. See “Undoing Changes to a Workspace” on

page 28.

children Contains a list of the workspace’s child workspaces. The names of

child workspaces are entered into the workspace’s children file

during the Bringover Create transaction. Configuring consults this

file to obtain the list of child workspaces. When you delete, move,

or reparent a workspace, Configuring updates the children file in

its parent.

conflicts Contains a list of files in that workspace that are currently in

conflict. See Chapter 6 for more information about conflicts and

how to resolve them.

description Contains a descriptive name and detailed description of a

TeamWare workspace created by the user. See “Giving a Workspace

a Descriptive Name” on page 43.

freezepoints/ Created when you set up auto-freezepoints. See “Automatically

Generating Freezepoints” on page 118.

history An historical log of transactions and updated files that affect a

workspace. See “Viewing Workspace History” on page 31 for more

information.
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Configuring Defaults Files

When you change Configuring behavior using the Tool Properties window, click the

Apply button to preserve the changes in runtime configuration files in your home

directory. The runtime configuration files are consulted by Configuring when it

starts; your changes are used as the default values.

Changes made in the Configuring and Bringover/Putback panes of the Tool

Properties window are written to the file ~/.codemgrtoolrc . This file is an

XWindows resource file.

Changes made in the Resolve pane of the Tool Properties window are written to the

runtime configuration file ~/.codemgr_resrc .

locks To assure consistency, Configuring locks workspaces during

Bringover, Putback, and Undo transactions. Locks are recorded in

the locks file in each workspace; Configuring checks that file

before acting in a workspace. See “Removing Workspace Locks” on

page 63.

nametable Contains a table of SCCS file names (path names relative to that

workspace) and a unique number represented as four 32-bit

hexadecimal words. Each entry in the table is terminated by a

newline character. The nametable file is used by Configuring

during bringover and putback to accelerate the processing of files

that have been renamed. If this file is not available, Configuring

rebuilds it automatically during the next Putback or Bringover

transaction. See “Renaming, Moving, or Deleting Files” on page 98.

notification Permits Configuring to detect events that involve that workspace

and to send e-mail in response to the event. See “Notifying Users of

Transactions” on page 42.

parent The parent file contains the path name of the workspace’s parent

workspace and is created by the Bringover Create transaction, or by

the reparent command if the workspace was originally created

with the create workspace command (and thus had no parent).

Configuring consults this file to determine a workspace’s parent.

When you delete, move, or reparent a workspace, Configuring

updates the parent file in its children.

putback.cmt A cache of the text of the comment from the last blocked Putback

transaction. Configuring caches the comment in putback.cmt so

that you can retrieve the original text when you re-execute the

transaction.

TABLE 12-1 Contents of the Codemgr_wsdata Metadata Directory (Continued)

File/Dir Name Description
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You can also control which workspaces are loaded by default using environment

variables (see “Configuring Environment Variables” on page 52). You can save a

default list of files to bringover/putback (see “Generating a Customized List of

Files” on page 41).

The access_control File

Chapter 4 introduces the concept of controlling who can perform which transactions

on a workspace. When you set permissions in the Access Control tab (under

Workspace ➤ Properties), TeamWare writes the permission in the access_control
file. TABLE 12-2 shows the default contents of access_control after you create a

workspace.

TABLE 12-2 Default Access Control Permissions

Operation Default Permission

bringover-from all users

bringover-to creator

putback-from all users

putback-to all users

undo all users

workspace-delete creator

workspace-move creator

workspace-reparent creator

workspace-reparent-to all users
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You can manually edit the access_control file to control which users have access

to a workspace. TABLE 12-3 shows all of the value types you can specify to control

access to your workspaces and what the entries mean.

How Configuring Merges Files

This discussion assumes that you are familiar with SCCS, including the concept of

branching. Branching is defined in “How To Read a File’s History: Deltas, Branches,

and Versions” on page 96. SCCS is described in detail in the Solaris Programming
Utilities manual.

When considering Bringover and Putback transactions, remember that source files

are derived from SCCS deltas and are identified by SCCS delta IDs (SIDs). When a

file is copied by either a Putback or Bringover transaction, the Configuring program

must manipulate the file’s SCCS history file (also known as the “s-dot-file”).

When a file is copied (using a Bringover or Putback transaction) from a source

workspace to a destination workspace, it appears that a single file has been

transferred. In fact, all of the SCCS information for that file (deltas, comments, and

so on) must be merged into the destination SCCS history file. By merging the

information from the source into the destination history file, the current version

(delta) can be derived, and the file’s entire delta and comment history are available.

TABLE 12-3 Workspace Access Control Values

Value Meaning

@engineering All users in the net group named engineering can

execute this operation.

-@engineering No users from the net group named engineering can

execute this operation. “- ” denotes negation.

@special -user2 @engineering All users in the net groups special and engineering
can execute the operation; user2 cannot (unless user2
is in the special netgroup). “- ” denotes negation.

user1 user2 The users user1 and user2 can execute the operation.

“-” No user can execute the operation.

creator Only the user who created the workspace can execute

the operation. Note that the creator’s login name

actually appears.

(no entry) Any user can execute the operation.
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The exception is when the file does not exist in the destination workspace. In this

case, the entire history file is copied from the source workspace to the destination

workspace.

Merging Files That Do Not Conflict

If the file in the destination workspace is being updated (the file has changed in the

source of a Bringover or Putback transaction and has not changed in the

destination), the new deltas from the destination are added to the history file in the

destination. SCCS history files are merged in this case (rather than the source history

file being copied over the destination history file) to prevent administrative

information (for example, flags and access lists) stored in the destination history file

from being overwritten.

To accomplish the merger, the Configuring program determines where the delta

histories diverge and adds (to the destination workspace) only the deltas that were

created in the source workspace since they diverged. To determine where the

histories diverge, the Configuring program compares the delta tables in both the

parent and child history files; information used in this comparison includes

comments and data, such as who created the delta and when.

FIGURE 12-1 contains an example of a Putback transaction where the Configuring

program adds deltas 1.3 and 1.4 from the child workspace to the SCCS history file in

the parent.
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FIGURE 12-1 Updating a File in the Destination Workspace That Has Not Changed

Merging Files That Conflict

When you propagate files between parent and child workspaces, both the version of

the file from the parent and the version in your child often change since they were

last updated. When that is the case, the parent and child versions of the file are in

conflict.

When file contents conflict, Configuring helps you to resolve the potentially

conflicting changes that were made to the file and preserves the file’s delta,

administrative, and comment history. Configuring merges the SCCS deltas from the

parent into the history file in the child. Configuring’s Resolve transaction is then

used to resolve the conflict in the child. For details on resolving conflicts, see

“Resolving Differences” on page 82.

1.1

1.2

1.3

1.4

1.1

1.2

Parent

Child

Putback/merge

1.1

1.2

1.3

1.4

Parent

           Child

1.1

1.2

1.3

1.4
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How Merging Tracks Deltas

This merge example involves an integration workspace and two child workspaces

owned by different developers, Ian and Ramona. The developers bring over copies

of the same file from the integration workspace, and independently change the file.

The illustrations show how the SCCS history file is manipulated when conflicts

occur and when they are resolved. Some notes regarding the following figures:

■ The default delta (the point at which the next delta is added to the SCCS delta

tree) is identified by an unattached descending line.

■ You can use Versioning to graphically display SCCS delta trees in much the same

way they are depicted here.

Both Ian and Ramona copy the same file from the integration workspace with the

Bringover transaction. The file is new in both workspaces, so the SCCS history file is

copied to both. Integration Workspace represents the parent workspace that both Ian

and Ramona use.

1.1

1.2

1.1

1.2

1.1

1.2

Ramona’s WorkspaceIan’s Workspace

Bringover

Integration Workspace
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Ramona makes changes to the file, creating two new deltas: 1.3 and 1.4, and then

puts the file back into the integration workspace (with the Putback transaction).

Configuring appends the two new deltas to the parent SCCS delta tree.

Rather than replacing the destination workspace version of the SCCS history file

with the source’s version, the new deltas are added to the destination SCCS history

file to preserve administrative information such as access lists.

1.1

1.2

1.3

1.4

Integration Workspace

Putback

1.1

1.2

1.3

1.4

Ramona’s WorkspaceIan’s Workspace

1.1

1.2
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In the meantime, Ian also changes the file (creating three new deltas: 1.3, 1.4, and 1.5)

and now attempts to put back the file into the integration workspace.

Configuring blocks the Ian’s Putback transaction of because the files are in conflict.

Ramona’s changes that she put back would be overwritten. Ian must first

incorporate the changes made by Ramona into his work.

1.1

1.2

1.3

1.4

Putback blocked

1.1

1.2

1.3

1.4

1.1

1.2

1.3

1.4

1.5

Integration Workspace

Ramona’s WorkspaceIan’s Workspace
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Ian brings over the file that now contains the changes made by Ramona into his

workspace from the integration workspace. The deltas that Ramona created are

added into the child SCCS history file by Configuring.

The delta tree brought down from the parent is unchanged in the child. The new

deltas created in the child are attached as an SCCS branch to the last delta that the

child and parent had in common; the deltas from the child are assigned new SIDs

accordingly. The deltas are renumbered using the SCCS branch-numbering

algorithm that derives the SID from the point at which it branches. In this case, the

branch is attached to SID 1.2; the first delta is renumbered to 1.2.1.1. The last delta

created in the child (1.2.1.3, formerly 1.5) is still the default delta. Therefore, any new

deltas that Ian creates in the child before the conflict is resolved are added to the

child line of work, and not the trunk (the parent line of work).

Bringover/merge

1.2

1.3

1.4

1.2.1.1

1.2.1.2

1.2.1.3

1.1

1.2

1.3

1.4

Integration Workspace

Ramona’s WorkspaceIan’s Workspace

1.1

1.2

1.3

1.4

1.3

1.4

1.5

1.1
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Ian resolves the conflict in his workspace using the Resolve transaction (see

“Resolving Differences” on page 82 for details regarding conflict resolution). Ian

uses the Resolve transaction to help him decide how to merge the versions of the file

represented by SIDs 1.2.1.3 and 1.4. When he commits the changes, the Resolve

transaction places the newly merged contents into a new delta 1.5:

■ The new delta, 1.5, is contained in a circle because Ian created it.

■ The newly created delta is now the default location for any new work Ian creates.

1.1

1.2

Resolve Merge

1.5

1.3

1.4

1.1

1.2

1.3

1.4

Integration Workspace

Ramona’s WorkspaceIan’s Workspace

1.2.1.1

1.2.1.2

1.2.1.3

1.1

1.2

1.3

1.4
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With the conflict resolved, Ian puts back the file into the integration workspace. The

branch and the newly created delta are added to the SCCS history file in the

integration workspace.

Putback

Integration Workspace

Ramona’s WorkspaceIan’s Workspace

1.1

1.2

1.3

1.4

1.1

1.2

1.5

1.3

1.4

1.2.1.1

1.2.1.2

1.2.1.3

1.1

1.2

1.5

1.3

1.4

1.2.1.1

1.2.1.2

1.2.1.3
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Ramona makes another change to the file in her workspace, creating delta 1.5. She

attempts to put back the new work to the integration workspace, but the Putback

transaction is blocked because it conflicts with the newly merged delta 1.5 that Ian

had put back.

Integration Workspace

Ramona’s WorkspaceIan’s Workspace

Putback Blocked

1.1

1.2

1.3

1.4

1.5

1.1

1.2

1.5

1.3

1.4

1.2.1.1

1.2.1.2

1.2.1.3

1.1

1.2

1.5

1.3

1.4

1.2.1.1

1.2.1.2

1.2.1.3
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Ramona brings over the changed file into her workspace where its deltas are added

into the child SCCS history file and renumbered by Configuring.

Integration Workspace

Ramona’s WorkspaceIan’s Workspace

Bringover
1.1

1.2

1.5

1.3

1.4

1.2.1.1

1.2.1.2

1.2.1.3

1.1

1.2

1.5

1.3

1.4

1.2.1.1

1.2.1.2

1.2.1.3

1.1

1.2

1.5

1.3

1.4

1.2.1.1

1.2.1.2

1.2.1.3

1.4.1.1
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As in the previous case, Configuring appends the delta that Ramona created to the

last common delta on the delta tree trunk as a branch and renumbers it

appropriately. 1.5 becomes 1.4.1.1. 1.4.1.1 remains the default delta. Any new deltas

created in the child before the conflict is resolved will be added to the branch.

Ramona’s Workspace

1.1

1.2

1.5

1.3

1.4

1.2.1.1

1.2.1.2

1.2.1.3

1.4.1.1
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Using the Resolve transaction, Ramona resolves the conflict merging the differences

between 1.5 and 1.4.1.1 to create the new delta 1.6:

■ The newly created merged contents are added as a new delta to the parent delta

1.6.

■ The new delta is owned by Ramona, who owns the workspace.

■ The new delta becomes the default delta; therefore, new work in the child will

now be added beneath it.

This merge example has shown what happens when you have an integration

workspace and two child workspaces owned by different developers. The

developers bring over copies of the same file from the integration workspace and

independently change the file. When they attempt to put their changes back,

conflicts occur. Configuring manages deltas to ensure that no one’s changes are

overwritten and manipulates the SCCS history file so that the file history is accurate

and complete.

Ramona’s Workspace

1.1

1.2

1.5

1.3

1.4

1.2.1.1

1.2.1.2

1.2.1.3

1.6

1.4.1.1
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About SCCS Mergeable IDs

This section explains why SCCS Mergeable IDs (SMIDs) are necessary, how to

translate SCCS delta IDS (SIDs) to SMIDs, and how to translate SMIDs to SIDs.

The use of SMIDs ensures that every delta is uniquely identifiable, even if its SID is

changed. A SMID is a number generated using the Xerox Secure Hash Function.

When you use Freezepointing to create a freezepoint file, it calculates the SMID for

both the current delta and the root delta in the SCCS history file. Using both of these

values, Freezepointing can identify a delta in a file even if its SID has been changed.

Why SMIDs Are Necessary

When Configuring encounters a file conflict during a Bringover Update transaction

(file is changed in both the parent and child workspaces), it merges the new deltas

from the parent workspace into the SCCS history file in the child. When this merge

occurs, the deltas that were created in the child are moved to an SCCS branch off of

the delta that both deltas have in common (common ancestor).

When Configuring relocates the child deltas to a branch, it changes their SID. If SIDS

were used in freezepoint files to identify deltas, this relocation would invalidate the

information contained in the freezepoint file. For that reason, SIDs cannot be used to

identify deltas after conflicting SCCS histories have been merged.

Translating Between SMIDs and SIDs

You can translate SMIDs into SIDs and SIDs into SMIDs using the freezept sid
and freezept smid commands. Use to write your own scripts or programs to

track deltas.

Translating SIDs to SMIDs

Use the freezept smid command to translate SIDs to SMIDs. The syntax is:

■ Use the -r option to specify the SID (in file file) for which you want to calculate a

SMID.

freezept smid  [ -w workspace] [ -r SID] [ -a ] file
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■ Use the -a option to calculate a SMID for all of the SIDS in file.

Examples

Translating SMIDS to SIDS

Use the freezept sid command to translate SMIDs to SIDs. The syntax is:

■ Use the -m option to specify the SMID (in file file) for which you want to calculate

a SID.

■ Use the -a option to calculate a SID for all of the deltas in file.

Note – Because the SMID contains white space, you must enclose it within

quotation marks.

example% freezept smid -r 1.38 module.c
SID 1.38 = SMID “f5b67794 705f0768 a89b1f4 588de104”

example%  freezept smid -a bringover.1
SID 1.1 = SMID “b05b0a2f 1db5246e 1a466014 707e38f5”
SID 1.2 = SMID “d6a5c61f 5634f0ef 9847a080 d0d7b212”
SID 1.2 = SMID “e31acdd5 6c1232e2 9e81c287 1edb2f41”
SID 1.3 = SMID “c34c91b4 a818622a 2457356a 489b2728”
SID 1.4 = SMID “98c0fd8d 889563fb cf722c2b 6afc9636”
SID 1.5 = SMID “b1e24be3 752fec3e df2d2717 a9b3f1fa”
SID 1.6 = SMID “2b93d39 1ea2f6ba 9814320c bc609acb”
SID 1.7 = SMID “1db7d640 42b0f009 35c60d7b b230bd85”
SID 1.8 = SMID “906dfe9a ca7e2d6c a64da5be 4baef254”

freezept sid  [-w workspace] [-m “SMID”] [-a ] file
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Examples

example%  freezept sid -m “64fdd0df de9d7dd de75812 23da96aa”
module.c
SMID “64fdd0df de9d7dd de75812 23da96aa” = SID 1.36

example% freezept sid -a bringover.1
SMID “b05b0a2f 1db5246e 1a466014 707e38f5” = SID 1.1
SMID “d6a5c61f 5634f0ef 9847a080 d0d7b212” = SID 1.2
SMID “e31acdd5 6c1232e2 9e81c287 1edb2f41” = SID 1.2
SMID “c34c91b4 a818622a 2457356a 489b2728” = SID 1.3
SMID “98c0fd8d 889563fb cf722c2b 6afc9636” = SID 1.4
SMID “b1e24be3 752fec3e df2d2717 a9b3f1fa” = SID 1.5
SMID “2b93d39 1ea2f6ba 9814320c bc609acb” = SID 1.6
SMID “1db7d640 42b0f009 35c60d7b b230bd85” = SID 1.7
SMID “906dfe9a ca7e2d6c a64da5be 4baef254” = SID 1.8
SMID “77481e8a 61542339 cc28f532 e5fc6389” = SID 1.9
SMID “cb97c9a6 d0342cf6 19b7b743 2436ca1c” = SID 1.10
SMID “46de4131 b95b9973 93958a07 b960074c” = SID 1.11
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APPENDIX A

Error and Warning Messages

This appendix describes the error and warning messages displayed by Forte

TeamWare.

The chapter contains the following sections:

■ Error Messages

■ Warning Messages

All messages are numbered and are listed in numerical order. For each message, the

meaning of the message and a possible solution for the error are provided.

Error Messages

TABLE A-1 describes error messages, their meanings, and possible solutions.2538

TABLE A-1 Configuring Error Messages

1000 - 1999 System Errors

Error messages between 1000 and 1999 report errors from operating system calls

made by Configuring commands. They consist of a short Configuring message

and an appended system error message and number. Refer to operating system

documentation for information regarding these errors.

2000 Line too long or unexpected end of file in file_name

Meaning: While reading the file_name, a line was encountered that contained too

many characters for a Configuring command to buffer. The maximum line length

is 1024 characters.

Solution: Reduce the size of the long line and re-execute the command.
179



2001 Must specify a [child]* workspace either with the -w option
or via the CODEMGR_WS environment variable

Meaning: The Configuring command could not determine the workspace on

which to act. Configuring commands attempt to acquire the workspace path

name in the following order:

• As specified by the command’s -w option

• As specified by the value of the environment variable CODEMGR_WS
The current directory, if it is hierarchically within a workspace

*When the error is reported by Bringover and Putback the word child is

included, when reported by Undo and Resolve it is not included.

Solution: Specify the workspace path name using one of the methods listed

above.

2003 directory_name is not a workspace

Meaning: The directory specified in the command is not a Configuring

workspace. Configuring workspaces are distinguished by the presence of the

Codemgr_wsdata directory in the top level directory.

Solution: Specify a different workspace name or use the workspace create
command or the GUI File ➤ Create Workspace command to convert the

directory into a workspace.

2004 Workspace workspace_name doesn’t have a parent workspace

Meaning: A Configuring command (Bringover or Putback) could not complete

execution because a parent workspace could not be found for workspace

workspace_name.

Solution: Use the workspace parent command or the GUI Edit ➤ Parent

menu item to reparent the orphaned workspace.

2005 Parent workspace workspace_name is not visible as it is not
mounted on machine_name

Meaning: The file system that contains the parent workspace is not currently

mounted on machine machine_name.

Solution: Mount the file system that contains the parent workspace and reissue

the command.

2006 Filename file_name has too many “..” path components in it

Meaning: Relative file names specified to Configuring commands are interpreted

as being relative to the root directory of the workspace. If a file name contains

“.. ” components, it is possible for one of the “.. ” components to reach a

directory that is hierarchically above the workspace root.

Solution: Specify the path name with fewer (or no) “.. ” path name components

2007 Could not get username for uid uid_number

Meaning: The uid could not be found in the NIS maps or in /etc/passwd

TABLE A-1 Configuring Error Messages (Continued)
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Solution: Check NIS server and maps.

2008 No version number in file file_name

Meaning: When a Configuring command accesses a metadata file (a file in the

Codemgr_wsdata directory), it checks the version number written in the file

when it was created (for example, VERSION 1). The metadata file file_name does

not contain the version string.

Solution: Check the integrity of file_name. The version string may have been

removed when the file was edited. If the version string is missing, and the file is

not otherwise corrupted, use the workspace create command or the GUI File

➤ Create Workspace menu item to create a new workspace. Check the value of

the version string for the analogous file in the new workspace and edit that

string into file_name.

2009 Command command_name failed, /bin/sh killed by signal signal

Meaning: A Configuring command attempted to execute command_name and

was unable to because the shell was killed by signal.

Solution: Re-execute the Configuring command.

2010 Command command_name failed, could not execute the shell, /
bin/sh

Meaning: A Configuring command could not start a shell. This indicates that

some system resource, such as swap space or memory, was insufficient.

Solution: Check system resources.

2011 Commandcommand_name killed by signal signal

Meaning: A command started by a Configuring command received a signal.

Solution: Re-execute the command. If the error reoccurs, refer to the Solaris

documentation for information about the signal.

2012 Command command_name exited with status status

Meaning: Configuring expects commands it executes to exit with a status of zero

indicating successful completion. Configuring considers it an error if a command

exits with a nonzero status.

Solution: Refer to the documentation for command_name to determine the

meaning of status.

2013 FLP FLP_name does not exist in the parent or child workspace

Meaning: The file list program (FLP) FLP_name specified for the Bringover or

Putback transaction could not be found in either the parent or child workspace

Solution: Check the path name of the intended FLP and re-execute the

transaction.
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2014 Could not execute program_name

Meaning: A Configuring command attempted to execute another program and

was unable to do so.

Solution: Ensure that your installation is correct. Ensure that the program is in

your search path and that its permissions are set correctly.

2015 Workspace workspace_name already exists

Meaning: An attempt was made to create a workspace that already exists.

Solution: Re-execute the command using a different workspace name.

2016 Workspace name does not exist

Meaning: The workspace name specified as an argument for a Configuring

command could not be found.

Solution: Ensure that the path name was specified correctly.

2017 Can’t open file file_name so can’t get comments for check in

Meaning: Configuring stored check in comments in a temporary file and was

unable to open that file to read the comments.

Solution: Check file permissions and other file system problems that would

prohibit opening the file.

2018 Can’t reparent a workspace to itself

Meaning: An attempt was made (either as part of a transaction, or by using an

explicit reparent command) to make a workspace its own new parent.

Solution: Re-execute the command, specifying a different parent.

2019 Internal error: unknown locktype lock

Meaning: The workspace lock file (Codemgr_wsdata/locks ) is corrupted. An

unknown lock value was found.

Solution: Edit the lock file to repair the damage. For more information, see the

locks(4) man page or “Removing Workspace Locks” on page 63.

2020 You must specify a workspace name

Meaning: The Configuring command could not determine the workspace on

which to act. Configuring commands attempt to acquire the workspace path

name in the following order:

• As specified by the command’s -w option
• As specified by the value of the environment variable CODEMGR_WS
• The current directory, if it is hierarchically within a workspace

Solution: Specify the workspace path name using one of the methods listed

above.
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2021 Cannot obtain a type lock in workspace workspace_name because
it has the following locks: Command: command (pid), user: user,
machine: machine, time: time

Meaning: To ensure consistency, Configuring interworkspace commands lock

workspaces while they read and write data in them. The command you issued

could not obtain a lock because the workspace is already locked. While

Configuring is reading and examining files in the parent workspace during a

Bringover transaction, it obtains a read-lock for that workspace. While it is

manipulating files in the child workspace, it obtains a write-lock. Read-locks may

be obtained concurrently by multiple Configuring commands that read files in

the workspace. No commands may write to a workspace while any read-locks

are in force. Only a single write-lock can be in force at any time; no Configuring

command may write to a workspace while a write-lock is in force. Lock status is

controlled by the Codemgr_wsdata/locks file in each workspace.

Solution: If the system is running normally, wait until the command that is

locking the workspace releases its lock. If the workspace is stuck in a locked state

(for example, the system crashed while a command had a lock in force), use the

GUI Options ➤ Workspace menu item and selecting Locks from the Category list

box in the Workspace Properties dialog box, or use the workspace locks
command, to remove the lock.

2022 Invalid subcommand - command_name

Meaning: An attempt was made to obtain help on a subcommand of the

resolve , workspace , or codemgr command and the name of a nonexistent

subcommand was specified.

Solution: For the list of valid subcommands for each command, type the

command and specify the help subcommand.

2023 Integration Request failed

Meaning: Putback validation is activated in the parent workspace and the

validation program returned nonzero exit status.

Solution: Re-execute the putback command specifying the correct modification

request id.

2024 File file_name has no deltas

Meaning: The SCCS history file file_name contains no deltas, therefore, it cannot

be processed.

Solution: Perhaps the history file was mistakenly overwritten.

2025 Could not find the command_name command.Executable does not
exist: name Also could not find the name command in PATH
PATH_contents

Meaning: A Configuring command attempted to execute another program and

was not able to find it.
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Solution: Ensure that your installation is correct. Include the directory that

contains the missing program.

2026 Unknown SCCS control character (char) in file file_name at line
line_number

Meaning: A Configuring command expected file_name to be an SCCS history file;

based on the character it encountered, it is either not a history file, or it has been

corrupted.

Refer to the Solaris SCCS documentation regarding SCCS history file format.

2027 Corrupted file - file_name, line line_number

Meaning: A Configuring command was unable to read a workspace metadata file

(a file in the Codemgr_wsdata directory). Illegal characters were found in line

line_number.

Solution: Check and repair the file. All Configuring metadata files are ASCII text

files and can be edited. See “Workspace Metadata Directory” on page 159 for

more information about the files in the Codemgr_wsdata directory or the

file_name(4) man page.

2028 Could not find the command_name command in PATH path_name

Meaning: A Configuring command attempted to execute another program and

was not able to find it.

Solution: Ensure that your installation is correct. Include the directory that

contains the missing program.

2029 The file has unresolved conflicts. Run ‘edit m’ and search
for ^<<<<<<<

Meaning: This error is issued by the resolve command. An attempt was made to

save the file while it still contained unresolved conflicts.

Solution: Use the edit m subcommand (edit the merged result) to resolve the

conflicts and then save the file. Conflicts are marked with ^<<<<<<<.

2030 No file with number file_number

Meaning: The resolve command creates a numbered list of files that contain

conflicts. The file_number chosen does not exist in this list.

Solution: Use the list subcommand to list the files and determine the correct

number of the file you want to specify.

2031 Can’t find home directory so can’t write to file file_name

Meaning: A Configuring command was unable to find the user’s home directory

and cannot locate file file_name. This usually indicates a problem with NIS maps.

Solution: Check NIS server and appropriate NIS maps.

2032 Can’t parse line in file file_name: line
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Meaning: Upon startup, the resolve command reads the ~/.codemgr_resrc file

to obtain user defined properties. The line line could not be interpreted correctly

by the program.

Solution: Correct the file ~/.codemgr_resrc file so that it includes only valid

entries. For information regarding these entries, see the resolve (1) manual

page.

2033 Must specify a directory list either as arguments or via the
CODEMGR_WSPATH environment variable

Meaning: This message is reported by the workspace list command when a

directory (or list of directories) was not specified correctly. Directories can be

specified as the standard argument to the command, or by defining the

CODEMGR_WSPATHvariable to contain the path name of a directory.

Solution: Re-execute the command specifying a directory, or set the

CODEMGR_WSPATHdirectory to contain a directory path.

2034 Internal error: Access control operation operation_name does
not have a Ibuilt-in default

Meaning: A Configuring command attempted to verify access permission for a

workspace operation (for example: bringover-from, putback-to, reparent-to). An

internal consistency check failed.

Solution: Contact your local service representative.

2035 Access control file does not exist

Meaning: A Configuring command attempted to verify access permission for a

workspace operation (for example: bringover-from, putback-to, reparent-to). The

access control file (Codemgr_wsdata/access_control ) in the affected

workspace was not found.

Solution: If the access control file has been deleted from the workspace, copy a

new one from another workspace and edit it so that the access permissions are

correct. If no other workspaces are available, create a new workspace using the

CLI workspace create command or the GUI File ➤ Create Workspace menu

item and copy the file from the newly created workspace. For more information

refer to Chapter 4 or the access_control (4) man page.

2036 Cannot specify common ancestor file; there is no common
ancestor delta

Meaning: The ancestor (a) was specified as an argument to a resolve
subcommand (diff , edit , more ). The files that are being resolved do not have

an ancestor in common. This occurs most commonly in cases where files with the

same name are created concurrently in both the child and the parent. They have

the same name but are not descended from a common ancestor. For more

information about ancestors and their role in resolving conflicts, see Chapter 6.

Solution: Proceed with the conflict resolution process without specifying the

ancestor (a) as an argument to the diff , edit , and more subcommands.
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2037 Invalid argument - character

Meaning: An invalid argument was specified to one of the resolve
subcommands. The command expected one of the following characters: a
(ancestor), c (child), p (parent), m(merged result).

Solution: Specify one of the valid arguments: a, c, p, m . See the resolve (1)

man page for more information.

2039 File file_name is probably not an s-file on line line_number
expected ^A, but got char

Meaning: A Configuring command expected file_name to be an SCCS history

file. Based on the format, it is either not a history file or it was corrupted.

Solution: Refer to Solaris SCCS documentation regarding SCCS history file

format.

2040 File file_name has not been merged. Use the merge subcommand
first or use the filemerge subcommand

Meaning: An attempt was made to commit (save) a file that had not yet been

merged.

Solution: Merge the file using either Filemerge or the twmerge command. For

more information about the twmerge command see the twmerge (1) man page.

2041 path_name is not a workspace or a directory

Meaning: The string path_name specified in the Bringover Create transaction is

not a Configuring workspace or a directory.

Solution: Specify a different workspace or directory name.

2042 Can’t create ToolTalk message, error = TT_error_code

Meaning: The resolve command communicates with the Merging program via

the ToolTalk service. ToolTalk is an interapplication communication service

distributed with the Solaris OpenWindows windowing system. In this case the

resolve command called a ToolTalk routine to create a ToolTalk message for

Merging. The ToolTalk routine could not create the message and passed back

TT_error_code.

Solution: Refer to the OpenWindows ToolTalk documentation for information

about the error.

2043 SCCS file file_name is corrupted

Meaning: The SCCS admin -h command reports that the newly computed

check-sum does not compare with the one stored in the first line of the file.

Solution: See the Solaris SCCS documentation for more information.

2044 Unable to create a temporary name from template temp_file_name

Meaning: A Configuring command was unable to create a temporary file for its

use. This is a Configuring internal error.
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Solution: Check for any system-level reasons why the command could not write

this file (for example, file permission restrictions or incorrect command

ownership).

2045 Fprintf of file_name failed

Meaning: A command was unable to write to the file file_name.

Solution: Check file permissions and other such file system problems that would

prohibit writing in the file system.

2046 Version mismatch in file file_name, expected version
expected_number, but found actual_number

Meaning: Each Configuring metadata file (Codemgr_wsdata/* ) contains a

string that includes a version number (for release 1.0 the version number string is

VERSION 1). As a consistency check, when Configuring commands read and

write to these files, they check to determine whether the file contains the version

that the command expects. In this case the command expected to find

expected_number but found actual_number instead. This may indicate that old

binaries are being used with new metadata files and could cause the file to be

corrupted.

Solution: Make sure that the most current versions of the Configuring binaries

are being accessed.

2047 Do not know how to convert file file_name from version
found_version_number to current_version_number

Meaning: A command found a metadata file with a version number earlier than

1. Each Configuring file (Codemgr_wsdata/* ) contains a string that includes a

version number (for release 1.0, the version number string is VERSION 1). As a

consistency check, when Configuring commands read and write to these files,

they check to determine whether the file contains the version that the command

expects. It is anticipated that when new versions of Configuring binaries and

metadata files are released, the formats of some of these files may change.

Commands contain code to make this conversion.

Solution: The version string in the metadata file must have been inadvertently

changed during editing. Check the file and make sure that the first line has the

correct version number.

2048 Must specify at least one file, directory or -f argument to
a bringover that creates a child workspace

Meaning: The command line for a Bringover transaction was not constructed

properly. An argument that specifies at least one file, directory or FLP must be

included. If this argument is omitted, Configuring attempts to take the

arguments from the workspace’s Codemgr_wsdata/args file.

Solution: Re-enter the command and ensure that you’ve included the correct

number of arguments.

2049 Could not determine where file_name is mounted from
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Meaning: Configuring commands convert path names of NFS mounted

directories to the machine_name:path_name format to do much of their work. This

message indicates that the mount entry contained in /etc/mnttab is no longer

present.

Solution: Remount the file system that contains file_name .

2050 Could not determine the absolute pathname for file_name

Meaning: A Configuring command was unable to read a directory. This indicates

some corruption in the file system; for example, incorrect directory permissions.

Solution: Check the file system, especially directory and file permissions in the

path of file_name.

2051 Can’t rename to file_name; it exists

Meaning: During a Bringover, Putback, or Undo transaction, a file was found that

was renamed in the source workspace to a name already in use in the destination

workspace.

Solution: Change the name in one of the directories.

2052 Corrupted file - file_name, text after BEGIN, line number. Can’t
send notification

Meaning: A Configuring command encountered an error when reading the

workspace notification file Codemgr_wsdata/notification . The BEGIN
statement that delimits the list of files/directories for which notification is

requested must be the only text on the line, other text was encountered. The

Configuring command cannot correctly parse the request; if the file contains a

notification request, it cannot be sent.

Solution: Edit the notification file and enter the appropriate BEGIN statement. See

the notification (4) man page or Chapter 4 for more information on its format.

2053 Corrupted file - file_name, text after END, line number. Can’t
send notification

Meaning: A Configuring command encountered an error when reading the

workspace notification file Codemgr_wsdata/notification . The END
statement that delimits the list of files/directories for which notification is

requested must be the only text on the line, other text was encountered. The

Configuring command cannot correctly parse the request; if the file contains a

notification request, it cannot be sent.

Solution: Edit the notification file and enter the appropriate ENDstatement. See

the notification (4) manual page or “Notifying Users of Transactions” on

page 42 for more information on its format.
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2054 Corrupted file - file_name, missing END, line number. Can’t send
notification

Meaning: A Configuring command encountered an error when reading the

workspace notification file Codemgr_wsdata/notification . The END
statement that delimits the list of files/directories for which notification is

requested, is missing. The Configuring command cannot correctly parse the

request; if the file contains a notification request, it cannot be sent.

Solution: Edit the notification file and enter the appropriate ENDstatement. See

the notification (4) man page or “Notifying Users of Transactions” on page 42

for more information on its format.

2055 File file_name has incomplete delta table

Meaning: The delta table in the SCCS history file file_name is incomplete. This

indicates that the file was corrupted.

Solution: Fix the file, or copy in a new version.

2056 Badly formatted line in file_name: line_number

Meaning: A Configuring command was reading a temporary log file left over

from an aborted Bringover or Putback operation and encountered a malformed

line. This indicates that the file was corrupted.

Solution: Execute the workspace updatenames command to rebuild the

nametable and then re-execute the command.

2057 Zero-length SCCS file, file_name

Meaning: An SCCS history file was encountered that contained no data.

Solution: Remove the SCCS history file.

2058 Can’t get a version of the child file until it is checked in

Meaning: During a Resolve transaction a file was encountered that is not checked

in to SCCS. Files must be checked in before conflicts can be resolved.

Solution: Check the file in and re-start the transaction.

2059 Name history serial number number out of order in file file_name

Meaning: Rename information in the SCCS history file file_name is corrupted.

The name history records in this SCCS file are not in numerically descending

order.

Solution: Reorder the name history records, or copy in a new version of the file

using the Bringover or Putback transaction.

2060 Delta serial number number out of order in file file_name

Meaning: Delta numbers are not in numerically descending order in the SCCS

history file file_name. This indicates that the file is corrupted.

Solution: Reorder the delta numbers, or copy in a new version of the file using

the Bringover or Putback transaction.
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2061 Must have DISPLAY environment variable set to invoke twmerge
or filemerge

Meaning: Merging is an XWindows program. The DISPLAY environment

variable is used to determine where the program displays its windows. If you are

running CDE or OpenWindows, this variable is usually set for you. For other

XWindow display servers, you may need to set this variable manually before

starting Merging.

Solution: Determine the correct setting for your display server and set the

DISPLAY environment variable appropriately.

2062 Can’t resolve file file_name because it is writable

Meaning: The file file_name is not checked out from SCCS but its file permissions

indicate that it is writable. Resolving this conflict will result in writing to a file

that is not checked out.

Solution: Reconcile the file permissions (for example, check out the file and then

check it back in) and then re-execute the Resolve transaction.

2063 Cannot create workspace name because it would be nested
within workspace name

Meaning: An attempt was made to create a workspace hierarchically beneath an

existing workspace.

Solution: Create the new workspace hierarchically outside of any existing

workspaces.

2064 Cannot delete a workspace that is a symbolic link. Run
workspace delete workspace_name

Meaning: Configuring commands will not delete directories or files that are

symbolic links. You must delete the physical copy of the file. The appropriate

command line is provided.

Solution: Use the workspace delete command to delete workspace_name.
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2065 This error message may be issued in any of the following forms:

User user_name does not have access to bringover from
workspace workspace_name
User user_name does not have access to bringover to workspace
workspace_name
User user_name does not have access to putback from workspace
workspace_name
User user_name does not have access to putback to workspace
workspace_name
User user_name does not have access to undo workspace
workspace_name
User user_name does not have access to delete workspace
workspace_name
User user_name does not have access to move workspace
workspace_name
User user_name does not have access to change the parent of
workspace workspace_name
User user_name does not have access to change the parent to
workspace workspace_name

Meaning: The user user_name attempted an operation that affected the workspace

workspace_name; access permissions in workspace_name do not permit user_name
access to execute that operation.

Solution: The file workspace_name/Codemgr_wsdata/access_control is a text

file that specifies access permissions for various workspace operations. The

owner of the workspace must change the permissions to include user_name in

order for the operation to proceed. Permissions can be changed using the

Workspace ➤ Properties menu item and selecting the Access Control tab in the

Workspace Properties dialog box, or by editing the access_control file

directly. For more information, see Chapter 4 or the access_control (4) man

page.

2066 Corrupted file - file_name, whitespace in pathname, line
line_number. Can’t send notification

Meaning: A Configuring command encountered an error when reading the

workspace notification file Codemgr_wsdata/notification . A white space

character was encountered in a line where a single path name was expected.

Solution: Edit the Codemgr_wsdata/notification file to remove the

whitespace characters from the line. See the notification (4) man page or

“Notifying Users of Transactions” on page 42.
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2067 Corrupted file - file_name, missing notification event, line
line_number. Can’t send notification

Meaning: A Configuring command encountered an error when reading the

workspace notification file Codemgr_wsdata/notification . The Configuring

event (for example, bringover-to) was not specified.

Solution: Edit the Codemgr_wsdata/notification file to add the correct

event.

2068 SCCS error for file file - can not create lock file (cm4)

Meaning: Someone else is updating the SCCS file or the p-file, or you do not have

write permission for the directory in which the SCCS file resides.

Solution: If someone else is updating the SCCS file or the p-file, wait until they

release the lock and then try again to access the file. If you do not have write

permission in the directory, you cannot create a lock file in that directory until

you obtain write permission.

2069 Not used

2070 Description file is corrupted: has no name
Description file is corrupted: has no keyword for description

Meaning: The workspace description metadata file (Codemgr_wsdata/
description ) is corrupted.

Solution: Recreate workspace description metadata file.

2071 You must specify either -m or -c option
Only one of -m or -c option is allowed

Meaning: The workspace find command accepts either -m or -c options.

These options cannot be specified together and one of these options should

always be specified

Solution: Re-execute the workspace find command and ensure that you have

specified the correct arguments.

2072 Not used

2073 Not used

2074 Workspace workspace_name has no locks

Meaning: An attempt was made to remove locks from a workspace that had no

active locks.

2075 Lock lock_name does not exist for workspace workspace_name

Meaning: While using the workspace locks -r command, a lock number was

specified that is out of range of the lock list.

Solution: Check the lock numbers for the workspace using the workspace
locks command and enter a valid number.
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2076 Internal error: Cannot find the directory in which command
command_name is located because avo_find_dir_init() has not
been called

Meaning: This is an internal error.

Solution: Contact your local service representative.

2077 number is not a valid number

Meaning: While using the resolve command, a number was referenced that is

outside of the listed values.

Solution: List the values to determine the valid number for your selection.

2078 Cannot access workspace workspace_name

Meaning: File permissions for workspace_name prohibit access by the Configuring

command.

Solution: Default permissions for workspace directories are 777.

2079 Could not parse name history for file file_name, contains: text

Meaning: There is a format error in the name history record in the SCCS history

file file_name. The text in error is displayed.

Solution: If possible, fix the record; otherwise, copy a new version of the file

using the Bringover or Putback transaction.

2080 Could not remove or rename backup directory directory_name

Meaning: Configuring attempted to clear the backup area directory_name so that

it could backup a new transaction. Configuring was not able to delete or rename

the directory out of the way. The most likely cause is that file permissions have

been changed for the directory.

Solution: Check directory permissions for directory_name. Default Configuring

permissions for this directory are 777.

2081-2087 Not used.

2088 Nametable in workspace workspace_name cannot be read because
the following SCCS files have identical root deltas
file_name
file_name
Run the following command and then re-execute the command_name
command:

path_name/workspace updatenames workspace_name

Meaning: An SCCS history file was copied within a workspace using the cp
command. As a result, the two files contain the identical root delta. Configuring

uses the root delta to distinguish between files. The workspace updatenames
command enables Configuring to distinguish between the files.
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Solution: Execute the workspace updatenames command and then re-execute

the command that spawned the error.

2089 Cannot move workspace workspace_name
because it is a symlink to directory_name.
Use a workspace name that is not a symlink.

Meaning: Configuring commands will not move directories or files that are

symbolic links.

Solution: Move the workspace to a name that is not a symbolic link.

2090 Nametable in workspace workspace_name not written because the
following SCCS files have identical root deltas
file_name
file_name
Run the following command and then re-execute the command_name
command:
path_name/workspace updatenames workspace_name

Meaning: An SCCS history file was copied within a workspace using the cp
command. As a result the two files contain the identical root delta. Configuring

uses the root delta to distinguish between files. The workspace updatenames
command enables Configuring to distinguish between the files.

Solution: Execute the workspace updatenames command and then re-execute

the command that spawned the error.

2091 Internal error: hash table missing entry

Meaning: Internal error.

Solution: Contact your local service representative.

2092 An SCCS file (A) was copied (to file B). The original SCCS
file (A) cannot be found.
Run the following command and then re-execute the command_name
command:
path_name/workspace updatenames workspace_name

Meaning: An SCCS history file was copied within a workspace using the cp
command. The original file (A) was subsequently renamed or removed from the

workspace. Configuring is unable to determine whether the file has been

renamed (and to what name) or removed from the workspace. The workspace
updatenames command interactively displays the possible names to which the

file could have been renamed, and asks you to determine the file’s current state:

its new name or its absence from the workspace. Configuring can then correctly

propagate the changes throughout the workspace hierarchy.

Solution: Execute the workspace updatenames command and then re-execute

the command that spawned the error.

2093 Internal error: SmIDs not equivalent

Meaning: Internal error.
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Solution: Contact your local service representative.

2094 Internal error: SmID not found

Meaning: Internal error.

Solution: Contact your local service representative.

2095 Could not make SmID unique in file file_name

Meaning: Configuring command found files with identical root deltas.

Subsequent attempt to differentiate these files failed.

Solution: Execute the workspace updatenames command in the workspace

that contains file_name and re-execute the command that spawned the error.

2096 Not used

2097 Cannot remove workspace workspace_name

Meaning: The workspace move command was unable to delete the original

workspace after a copy was done.

Solution: Check permissions and manually remove the original workspace.

2098 Cannot delete workspace workspace_name. Please check
permissions

Meaning: The workspace delete command is unable to remove specified

workspace.

Solution: Check permissions and then re-execute the command.

2099 - 2499 Not used

2500 - 2536 Internal errors

Meaning: Error numbers 2500 through 2600 are Configuring programs internal

errors. These errors indicate problems that users cannot correct. Contact your

local service representative.

2537 File parent_file has incompatible type with file child_file (text/
binary)

Meaning: Bringover/Putback command detected that the parent_file type (text/

binary) is not compatible with the type of the child_file.

Solution: Fix the file or copy in a new version of the file using Bringover or

Putback translation.

2538 Can’t set autofreezepoint properties.

Meaning: Internal error.

Solution: Call your local service representative.

2539-2600 Internal errors
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2610 Only putback to workspace_name is currently allowed

Meaning: You are trying to bringover files to a workspace workspace_name which

has putback validation activated. Only putbacks are allowed to workspaces that

have putback validation activated.

Solution: Disable putback validation for the workspace_name and then re-execute

the bringover command.

5005 Destination directory directory is not empty

Meaning: Directory directory specified for freezept extract command is not

empty.

Solution: Re-execute the freezept extract command specifying an empty

destination directory.

5009 Invalid date format:
date

expected:
YYYY/MM/DD or YYYY/MM/DD/hh/mm/ss

Meaning: The date specified for the freezept command is has an incorrect

format.

Solution: Re-execute the freezept command specifying the date in a correct

format, either YYYY/MM/DD or YYYY/MM/DD/hh/mm/ss.

5010 The delta specified in freezepoint freezepoint_file
for file file
does not exist in workspace workspace

Meaning: This message is issued in the case when a freezept extract
command finds a reference in freezepoint_file to a delta that does not exist in file

file in workspace workspace. The most probable reason for this error is that the

freezepoint freezepoint_file was created from a workspace that was freezept
update d in relation to workspace workspace that was specified for freezept
extract command.

Solution: Re-execute the freezept extract command specifying the correct

workspace.

5011 Your directory contains SCCS files with duplicate smids

Meaning: The directory specified for freezept create command contains files

with identicat root deltas.

Solution: Create a new Forte TeamWare workspace from directory and re-execute

the freezept create command.

5103 Freezepoint file freezepoint_file is corrupted.

Meaning: The specified freezepoint file is corrupted.

Solution: Fix the file, or copy in a new version and re-execute the freezept
command.
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5107 Must specify a workspace with the -w option since there is no
default workspace in freezepoint file freezepoint_file

Meaning: The specified freezepoint file does not contain a default workspace that

should be used for freezept update or freezept extract commands.

Solution: Re-execute the freezept command specifying the correct workspace

name.

5108 The number of errors during extract is number .

Meaning: The freezept extract command displays the number of encountered

errors at the end of work.

Solution: Not applicable.

5109 There is no default workspace in freezepoint file
freezepoint_file.

Meaning: The specified freezepoint file does not contain a default workspace that

should be used for freezept update or freezept extract commands

Solution: Re-execute the freezept command specifying the correct workspace

name.

6000 When the -l option is used, both the leftfile and rightfile
arguments must be names of directories .

Meaning: In the case when -l option is specified for the filemerge command,

the values specified for the leftfile and rightfile arguments in the commandline

should be names of directories.

Solution: Re-execute the filemerge command and specify the correct values for

the leftfile and rightfile arguments.

6003 Merging: Could not parse diff output line: “line”

Meaning: Internal error.

Solution: Contact your local service representative.
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Warning Messages

TABLE A-2 describes warning messages, their meanings, and possible solutions.

TABLE A-2 Configuring Warning Messages

2020 Parent defined with the option -p :
workspace

differs from native parent :
parent_workspace

Meaning: The workspace workspace specified with the -p option for the

bringover or putback command is not a parent workspace of the child

specified for the bringover or putback transaction. The actual parent of the

child workspace is a parent_workspace.

2023 Removing a command's lock while the command is running may
corrupt SCCS files in either the parent or the child
workspace

Meaning: Self-explanatory. Issued by workspace locks command.

2601 Could not remove backup directory old_dir_name, so it was
renamed to new_dir_name

Meaning: Configuring attempted to clear the backup area old_dir_name so that it

could backup a new transaction. Configuring was not able to clear the backup

directory by deleting it, but it was able to rename it out of the way to the name

new_dir_name. The most likely cause is that file permissions were changed for the

directory.

Solution: Check directory permissions for old_dir_name. Default Configuring

permissions for this directory are 777. Delete the contents of new_dir_name.

2602 File file_name is not under SCCS in either workspace - ignored

Meaning: Configuring could not find an SCCS history file in either workspace for

file_name.

Solution: The file name was probably entered incorrectly; re-execute the

command.

2603 Zero length filename - ignored

Meaning: A file name specified as an argument on the command-line (or in the

Codemgr_wsdata/args file) contained no characters (““).

Solution: Re-execute the command and re-specify the file name argument. If the

problem persists, check the arguments listed in the args file.

2604 Filename file_name has whitespace characters in it - ignored
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Meaning: A file name specified as an argument on the command-line (or in the

Codemgr_wsdata/args file) contained whitespace characters. Configuring

commands do not accept file names that contain whitespace characters.

Solution: Re-execute the command and re-specify the file name argument. If the

problem persists, check the arguments listed in the args file.

2605 Not used

2606 File file_name not brought over because it is a file_type in
workspace workspace_name and a file_type in workspace workspace_name

Meaning: A file name has a different file type (regular file vs. directory vs.

symbolic link) in the parent and child workspaces.

Solution: Take whatever action is appropriate to make the listed files the same

type, or change one of the names.

2607 Not used

2608 Workspace child_ws_name is a child of parent_ws_name. Could not
update its parent file

Meaning: During a workspace delete or workspace move operation

involving child_ws_name, the command found that the children file in the

workspace’s parent (parent_ws_name) did not contain an entry specifying

child_ws_name as a child of that parent.

Solution: Advisory only; the command corrects the discrepancy. However, this

could indicate that the parent’s children file was corrupted.

2609 Not used

2610 directory_name is not a workspace

Meaning: The directory specified in the command is not a Configuring

workspace. Configuring workspaces are distinguished by the presence of the

Codemgr_wsdata directory in the top level directory.

Solution: Specify a different workspace name or use the CLI workspace
create command or GUI File ➤ Create Workspace menu item to convert the

directory into a workspace.

2611 file_name does not exist in either workspace - ignored

Meaning: The file file_name was not found in either the parent or child

workspace.

Solution: Check to be sure the name was specified correctly.

2612 Workspace workspace_name does not have Codemgr_wsdata/args file
Workspace workspace_name has empty Codemgr_wsdata/args file.

Meaning: The workspace specified for the bringover or putback command does not

have args metadata file or has an empty args metadata file. In this case, the

bringover/putback command cannot determine default files/directories for the

transaction.
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Solution: Re-execute the bringover or putback command and specify, on the

command line, the files/directories to be used for the transaction

2613 Filename file_name has too many “..” path components in it -
ignored

Meaning: Possible causes include that the Configuring command cannot resolve

the path name into a:

• workspace-relative file name

• fully qualified workspace name

Solution: Specify the path name with fewer (or no) “.. ” path name components

2614 Line line_number too long or unexpected end of file in file_name

Meaning: While reading the Codemgr_wsdata/nametable file, a line was

encountered that contained too many characters for a Configuring command to

buffer. The maximum line length is 1024 characters. This indicates that

nametable has been corrupted.

Solution: Configuring automatically rebuilds the nametable. This takes some

time.

2615 Line line_number has bad format in file_name

Meaning: This indicates that the Codemgr_wsdata/nametable file has been

corrupted.

Solution: Configuring automatically rebuilds the nametable. This takes some

time.

2616 Not used

2617 Unexpected name table editlog record type type_number - ignored

Meaning: A Configuring command was reading a temporary log file left over

from an aborted Bringover or Putback operation and encountered a malformed

record. This indicates that the file has been corrupted.

Solution: Execute the workspace updatenames command to rebuild

nametable and then re-execute the command.

2618 Can’t open file_name - can’t send mail notification

Meaning: The Configuring notification facility failed to open the file file_name. As

a result, notification mail is not sent for the current operation.

Solution: Check file permissions for file_name.

2619 Not used

2620 Can’t fork process to send notification

Meaning: Lack of system resources (memory, swap space) prevented the

Configuring notification facility from sending notification mail.

Solution: Check system resources.
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2621 Not used

2622 Filename file_name contains a comment character (#) - ignored

Meaning: A file name specified as an argument to a command (or in the

Codemgr_wsdata/args file) contains the # character. Configuring reserves this

character to denote comments.

Solution: Change the name of the file so that its file name does not contain the #
character. If the problem persists, check the arguments listed in the args file.

2623 Read-lock left in workspace or Write-lock left in workspace

Meaning: A Configuring command was unable to remove locks in

workspace_name. This may indicate that there is insufficient disk space, or that

permissions on the file Codemgr_wsdata/locks were changed since the lock

was originally written.

Solution: Remove the locks by using the GUI Options ➤ Workspace menu item

and selecting Locks in Category list box in the Workspace Properties dialog box,

or by using the CLI workspace locks command.

2624 File file_name is checked out in workspace workspace_name. The
changes in the checked out file will not be brought over

Meaning: The file file_name is checked out in the parent workspace. You are being

advised that any changes in the g-file were not brought over as part of the

Bringover transaction.

Solution: Not applicable.

2625 File file_name is not in conflict according to the SCCS file.
Removing it from the conflict file

Meaning: The information in the SCCS history file indicates that the file contains

no unresolved conflicts, however, the Codemgr_wsdata/conflicts file in the

workspace lists it as being in conflict. The command removed it from the

conflicts file.

Solution: Not applicable.

2626 File file_name not brought over because it is unresolved in
workspace workspace_name

Meaning: The file file_name was not brought over because it contains an

unresolved conflict in workspace_name.

Solution: Use the GUI Resolve transaction or the CLI resolve command to

resolve the conflict and then re-execute the Bringover transaction.

2627 Directory directory_name is mounted read-only.
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Meaning: Before beginning Bringover and Putback transactions, Configuring

checks to determine whether the destination workspace root (top-level) directory

is accessible for writing. This is not treated as an error condition because lower

level directories within the workspace could be mounted from different areas

and they may be accessible for writing. This warning is issued as an early

warning that directory permissions might be set incorrectly.

Solution: If write access is not intentionally denied, change the root directory

permissions.

2628 Not updating clear files because the ‘check out’ command
couldn’t be found in PATH search_path

Meaning: The clear files could not be updated as part of a Bringover or Putback

transaction because the SCCS get command could not be executed; it was not

found in your search path.

Solution: If you want clear files to be updated as part of transactions, include the

get command in your search path.

2630 This workspace is being created over an existing directory

Meaning: You are converting an already existing directory into a Configuring

workspace. Creating a workspace from an existing directory hierarchy consists of

creating the Codemgr_wsdata metadata directory in the top-level directory.

Once the directory becomes a workspace, its contents can be deleted using the

Configuring workspace delete command.

Solution: Not applicable.

2631 File file_name not brought over because it is checked out and
not writable in workspace workspace_name

Meaning: The file file_name was not brought over as part of the Bringover

transaction because it is checked out (p-file exists) and not writable in the child

workspace workspace_name. The unusual state of this file indicates that it is safer

not to process the file.

Solution: Reconcile the write permissions with its SCCS status.

2632 Omitting contents change to file file_name because of rename
error

Meaning: An error was encountered while processing the name of file_name. As a

result, the change in the file from the source workspace could not be propagated

to the destination workspace.

Solution: Correct the rename problem (see the rename error text) and re-execute

the Configuring transaction.

2633 Pathname "path_name" contains a symlink - ignored

Meaning: A symbolic link was encountered during a transaction. The directory is

ignored and the transaction continues.
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Solution: Do not use symbolic links inside of Sun WorkShop Teamware

workspaces.

2699 File file_name ignored because it is renamed to file_name1
in source_workspace and both file_name and file_name1 exist
in destination_workspace .

Meaning: A cyclic file rename has occurred. For example, there are two files,

file_name and file_name1, in both parent and child workspaces. Then, in

parent workspace, file file_name was renamed to file_name1 and

file_name1 was renamed to file_name :

% workspace filemv file_name tmp_file
% workspace filemv file_name1 file_name
% workspace filemv tmp_file file_name1

The bringover cannot perform such rename (using temporary filename) in

child workspace and issues this warning message.
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APPENDIX B

Troubleshooting

This appendix describes common problems with Forte TeamWare and their

solutions.

■ Bringover and Putback Errors

■ Environment Variables

■ Java Issues

■ Microsoft Windows and Unix Operating System Incompatibilities

■ Microsoft Windows File Sharing

■ Process Monitoring

■ SCCS Commands to Avoid

■ SCCS History Files

■ SCCS Errors

■ Text Formatting Issues

■ Version Verification

■ Workspaces
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Bringover and Putback Errors

TABLE B-1 shows some common bringover and putback errors.

TABLE B-1 Bringover and Putback Errors

Problem Solution

Errors received while attempting a

putback operation.

1. Preview the putback operation: find out how

many file updates are to be made, without

actually making them. From the Forte TeamWare

GUI, select the Preview checkbox in the Putback

dialog. Or at the command line:

$ cd child_directory
$ putback -n
(where child_directory is the top-level directory of

your child workspace).

2. Verify there is sufficient disk space to write the

putback operation’s changes. Check available

space on the disk where the parent workspace

resides (see next solution). Also check the /tmp
directory, and available swap space.

3. If still experiencing difficulties, try to do a partial

putback in order to isolate the problem. A putback

may consist of just a single directory or even a

single file.

Receipt of the following error message

while doing a putback:

putback: Line XXX has bad
format...(Warning 2615)
(where XXX is a line number)

There may be insufficient disk space to write to the

parent workspace. You can check available disk space

by executing the df -k command in the directory

where the parent workspace resides:

$ df -k parent_workspace_directory
Note: available disk space is shown in kilobytes.

Errors involving file names which

contain spaces.

If using the command line interface, place any file

names which contain spaces within double quotes.

The Forte TeamWare GUI will correctly handle

transactions involving file names which contain

spaces.
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Environment Variables

TABLE B-2 lists some problems relating to environment variables.

TABLE B-2 Environment Variables and Related Problems

Problem Solution

Putback causes errors on the Microsoft

Windows platform, even though

Samba file sharing is used and

correctly configured.

Check the environment variables listed on page 218

are set correctly. In particular, the environment

variable SENDMAILHOST may cause problems

when not set to a valid Sendmail host

Any of the following error messages

and symptoms during bringover,

putback, workspace, and SCCS

operations:

• /util/find: not found PC/
bin/def.dir.flp:/
SunWorkshop/TeamWare/bin

• cd : lstat /X failed
• A putback completes without error,

but none of the updates are actually

putback.

• Executing the command, sccs
edit filename, returns the prompt

without doing anything.

Check your PATH environment variable and verify

that TeamWare/bin is listed before any other

applications in the /bin directory.
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Java Issues

TABLE B-3 lists some problems relating to Java.

TABLE B-3 Issues Relating to Java

Problem Solution

Launching any of the Forte TeamWare

GUI tools produces the error:

NoClassDefFoundError

It is recommended that you launch Forte TeamWare

GUI tools using the launch scripts provided in the

install-root/bin directory (where install-root is the

root directory into which Forte TeamWare was

installed):

• codemgrtool

• vertool

• filemerge

• freezepttool

On Microsoft Windows, the shortcuts under the Start

menu point to these launch scripts.

These scripts contain the necessary CLASSPATH and

java interpreter invocations.

If you still get the NoClassDefFoundError from

running the scripts, you may need to reinstall Forte

TeamWare so that the scripts can be refreshed with

correct CLASSPATH information.
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Microsoft Windows and Unix Operating
System Incompatibilities

Certain problems arise from incompatibilities between supported UNIX operating

systems (Solaris and Linux) and Microsoft Windows. These are described in

TABLE B-4.

TABLE B-4 UNIX and Microsoft Windows Incompatibilities

Problem Solution

End of line (EOL) character

incompatibilities.

Unix environments use the Line Feed

(LF) character to indicate EOL;

whereas Microsoft Windows

environments use the Carriage Return

Line Feed (CRLF) for EOL. Problems

can arise, for example, with a

Bringover Create operation on source

files created in a Unix environment to

a workspace resident in a Microsoft

Windows environment.

By default, Forte TeamWare does not translate EOL

characters, which is appropriate most of the time.

However, if you are experiencing EOL-related

problems you can force Forte TeamWare to translate

EOL characters by setting the following environment

variable:

SCCS_GET_TRANS_LF=Yes

Note: this applies only to Microsoft Windows

environments.

Errors involving workspace names

which contain spaces.

In general, names containing spaces are not valid in

Unix environments. However, problems with

workspace names containing spaces can be solved by

reparenting the workspace. To reparent a workspace,

in the Configuring tool, choose Workspace ➤
Reparent.

Errors involving file names which

contain spaces.

The Forte TeamWare GUI will correctly handle

transactions involving file names which contain

spaces.

If using the command line interface, place any file

names which contain spaces within double quotes.
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Microsoft Windows File Sharing

Certain problems may arise from incompatible or improperly configured Microsoft

Windows file sharing services. These are described in TABLE B-5.

TABLE B-5 Microsoft Windows File Sharing Issues

Problem Solution

The following conditions are usually

caused by an incompatible or

improperly configured Microsoft

Windows file sharing service:

• Errors related to improper

permissions for Codemgr_wsdata
files

• The preview putback command

(putback -n ) works, but an actual

putback results in a hung process

• Forte TeamWare freezes when

multiple users try to putback to the

same workspace at the same time

• On Microsoft Windows, the display

goes blank, and I have to reboot to

get back control.

• On Solaris, a putback succeeds

when the SCCS master file is owned

by the user doing the putback, but

fails when the user does not own the

SCCS master file.

Samba is the only Forte TeamWare supported file

sharing service. See page 223 for information about

configuring Samba for use with Forte TeamWare.

Putback causes errors even though

Samba file sharing is used and

correctly configured.

Check the environment variables listed on page 218

are set correctly. In particular, the environment

variable SENDMAILHOST may cause problems

when not set to a valid Sendmail host

After installing Microsoft Windows

NT Service Pack 5, your environment

can no longer mount the file system

shared through Samba

There may be problems associated with certain

versions of Samba used with Microsoft Windows NT

Service Pack 5. Try using the latest version of Samba

or revert to Microsoft Windows NT Service Pack 4.
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Process Monitoring

TABLE B-6 shows some common issues around process monitoring

SCCS Commands to Avoid

The following SCCS commands should be avoided as their use may make alterations

to and prevent Forte TeamWare from being able to track SCCS history files:

■ cdc
■ comb
■ fix
■ rmdel

These commands also have undesirable side effects when used on files that exist in

multiple workspaces that may eventually be merged.

A description of specific problems which may arise from these commands is shown

in TABLE B-7.

TABLE B-6 Process Monitoring

Problem Solution

How to monitor currently running

Forte TeamWare processes.

The following solution applies only to the Solaris

platform. At the command line, type:

truss -o /tmp/truss_output -f \
-vall -p TeamWare_PID
where TeamWare_PID is the process identification

number of the currently running Forte TeamWare

process.

TABLE B-7 SCCS Commands to Avoid

SCCS Command Associated Problem

cdc May cause unnecessary branching and confusing histories.
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SCCS History Files

TABLE B-8 shows some common problems with SCCS history files

comb Completely rebuilds the SCCS history file.

fix A front-end for rmdel .

rmdel SCCS restricts the use of the rmdel command to remove only the most

recent (leaf) delta on a branch. If you remove a delta that also exists in

another workspace, it is possible that another user will add a delta in the

other workspace. In this case, the delta that was removed in your workspace

will no longer be a leaf delta when the files are merged.

TABLE B-8 SCCS History Files

Problem Solution

How to validate the SCCS history file. Use the sccs-val command to do a diagnostic test on

a specified file or files. The sccs-val command

checks each file for:

• history file corruption

• history file read problems

How to restore a corrupted SCCS

history file.

The SCCS history file contains a checksum. If the SCCS

history file becomes corrupted, the checksum will need

to be corrected. This can be accomplished with the

following command:

sccs admin -z peogram.c

Note: If the SCCS history file is corrupted, the problem

may be more serious than an incorrect checksum.

Always backup your current changes before

attempting to correct the SCCS history file.

TABLE B-7 SCCS Commands to Avoid

SCCS Command Associated Problem
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SCCS Errors

TABLE B-9 describes some problems related to SCCS errors.

TABLE B-9 Problems with SCCS Errors

Problem Solution

Either of the following error messages may

result from Y2K compliance issues and older

versions of SCCS:

• ERROR [SCCS/s.foo.java] format
error at line X (c04)

• bringover: Command get -s -G foo
SCCS/s. foo exited with status 1
(Error 2012)

(where foo is a real file name and X is a line

number).

The following applies only to the Solaris

platform. There are no known Y2K-related

issues on the Microsoft Windows or Linux

platforms.

Determine whether your version of SCCS is

Y2K compliant by executing the following

commands:

$ which get
to which the system should respond:

/usr/ccs/bin/get
then type:

/usr/ccs/bin/what /usr/ccs/bin/get
to which the system should respond with

either:

• 01/01/1997 - for Solaris 2.6

• 04/23/1998 - for Solaris 7

Any version of Solaris less than 2.6 is not Y2K

compliant. If you find that your version of

SCCS is not Y2K compliant, consult SunSolve

Online for the appropriate patch.

Executing the command, sccs diffs
SCCS, produces the error:

diff: SCCS/xxx0.0: No such file or
directory

The version of SCCS that was shipped with

Solaris 2.6 has a known bug. Specifically, the

diffs subcommand does not understand the

SCCSdirectory as a parameter. To solve this

problem you should obtain the appropriate

patches for Solaris 2.6.

Note: this issue does not apply to the Microsoft

Windows or Linux platforms.
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Text Formatting Issues

TABLE B-10 describes some issues related to text file formatting.

TABLE B-10 Issues With Text Formatting

Problem Solution

Forte TeamWare mistakes a text file for a

binary file, producing an error such as:

bringover: Line too long or
unexpected end of file in “//c/
builds/ child_workspace/ filename” (Error
2000)

Forte TeamWare makes the assumption that a

text file must end with a terminating newline,

otherwise it is treated as a binary file. To

prevent this problem ensure that all text files

end in a terminating newline, adding them as

necessary to your source files.

Blank lines and extra white space are being

added to your source files.

Editing text files that are shared between

Microsoft Windows and UNIX environments,

can sometimes cause extra line termination

characters to be inserted into the file. The

following is a possible scenario, illustrating

how this side effect can happen:

1. Create or edit a file in a Microsoft

Windows environment. The file will be

saved with carriage return line feed

(CRLF) line terminators.

2. Check in the file in a Solaris environment.

Solaris SCCS does not perform CRLF to

LF translations, so the CR gets copied into

the history file. (A future Solaris SCCS

patch will be provided that does perform

CRLF translations).

3. Check out the file in a Microsoft Windows

environment with default SCCS behavior

(that is, with

SCCS_GET_TRANS_LF=YES). Now the

CRLF characters are translated to

CRCRLF. The translation is actually

performed by the text mode behavior of

the Microsoft Win32 fwrite system call.

4. Editing the file with Microsoft Visual

Studio C++ will cause each extra CR to be

converted to CRLF, thereby creating an

extra line. Other editors such as Notepad,

WordPad, and VI do not seem to do this.

To avoid this problem, turn off CRLF

translation in your Microsoft Windows

environment (that is, set

SCCS_GET_TRANS_LF=NO). This will prevent

extra CR characters from appearing in the clear

file. Microsoft Visual Studio C++ should still be

able to process the file; Notepad, however, may

have a problem accessing the file.

In general, sharing “clear files” (that is, those

produced from sccs get commands) between

the Solaris and Microsoft Windows

environments can be problematic. For this

reason, it is recommend you dedicate your

Solaris/Samba workspace exclusively to

Microsoft Windows access. When you need to

integrate to a workspace that will be processed

by Solaris tools, perform a putback from your

Solaris/Samba workspace using Forte

TeamWare in the Solaris environment. This will

ensure that the clear files in the parent

workspace are in the correct format for Solaris,

while the clear files in the child workspace will

be in the correct format for Microsoft

Windows.
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Version Verification

TABLE B-11 shows some common issues with version verification.

TABLE B-11 Version Verification

Problem Solution

How to determine what version of

Forte TeamWare your are using.

From the Forte TeamWare GUI, choose Help ➤ About

TeamWare.

Or alternatively, at the command line, type:

teamware -V
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Workspaces

TABLE B-12 describes some common issues with workspaces.

TABLE B-12 Workspace Issues

Problem Solution

Concerns about workspace corruption. 1. The workspace check command audits

workspaces and reports on inconsistencies. It

checks files, access modes, parent-child

relationships, and the condition of the history file.

To execute the workspace check command,

type:

workspace check workspace_name
(where workspace_name is the name of a

workspace).

The command exits with either of the following

values:

0 = workspace is okay

1 = error

2. The workspace Auto-Freezepoint feature

automatically snapshots a workspace before and

after various transactions. While there is some

overhead involved in using this feature, it is

intended for master integration workspaces where

integrity is of paramount importance.

To more information about Auto-Freezepointing

see page 118.

Incompatibility concerns regarding

workspaces created using earlier

versions of Forte TeamWare.

There are no incompatibility issues regarding

workspaces created using earlier versions of Forte

TeamWare.
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APPENDIX C

Using Forte TeamWare in a
Microsoft Windows Environment

This appendix describes issues specific to using Forte TeamWare in a Microsoft

Windows environment. This appendix covers the following topics:

■ Launching Forte TeamWare Tools

■ Setting Environment Variables

■ Using the Command-Line Interface

■ Selecting Drive Letter and Path-Name Syntax

■ Understanding Carriage Return and Line Feed Translation

■ Adding Newline Characters to Text Files

■ Cross-Platform Interoperability

■ Sharing Files With Solaris Users

■ Configuring the Samba File Server

■ Using Forte TeamWare as a Plugin to Microsoft Visual Studio

Launching Forte TeamWare Tools

To launch Forte TeamWare GUI tools within the Forte for Java environment, choose

one of the methods described in “Forte TeamWare Tools, Tasks, and Access

Methods” on page 147. For example, click the Configuring button in the Forte for

Java TeamWare tool bar.

On Microsoft Windows, Forte TeamWare GUI tools may also be launched from the

Start menu. However, this will launch the tools in stand-alone mode—that is, they

will not be integrated within the Forte for Java environment. To launch Forte

TeamWare tools in stand-alone mode, under the Start menu, navigate to Programs ➤

Forte for Java ➤ TeamWare, and select from the shortcuts listed in TABLE C-1.
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Caution – The batch files in the Forte TeamWare installation directory are

overwritten each time the product is installed. If you customize these files, copy

them to a safe place, such as your home directory.

Setting Environment Variables

If you wish to launch Forte TeamWare tools without the aid of the shortcuts and

corresponding batch files (described in TABLE C-1), you must first make sure the

following environment variables are set. To set environment variables on the

Microsoft Windows platform:

1. Choose Start ➤ Settings ➤ Control Panel.

2. Double-click System to launch the System Properties control panel.

3. Click the Environment tab.

TABLE C-1 Microsoft Windows Start Menu Forte TeamWare Shortcuts

Shortcut Corresponding File in bin Directory

CodeManager Tool (Configuring) Codemgrtool.BAT

Command-Line Interface CommandShell.BAT

FileMerge Tool (Merging) FileMerge.BAT

Freezepointing Tool (Freezepointing) Freezepttool.BAT

Versioning Tool (Versioning) Vertool.BAT

Shortcut Description

Quick Tour Forte TeamWare interactive Quick Tour

Release Notes Important late-breaking news

User’s Guide This manual
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4. Set the environment variables (described in TABLE C-2).

Using the Command-Line Interface

Forte TeamWare’s features are available either from the GUI tools or from the

command line. If you wish to use the command-line interface, you may use a

command-shell environment, such as MKS, Cygnus, UWIN, or the Microsoft

Windows command prompt. To access the Microsoft Windows command prompt, go

to the Start menu and choose:

Programs ➤ Forte for Java ➤ TeamWare ➤ Command-Line Interface

Selecting Drive Letter and Path-Name
Syntax

File-name and path-name conventions on the Microsoft Windows platform differ

from those on either of the supported UNIX environments (Solaris and Linux).

Furthermore, on the Microsoft Windows platform, in addition to the standard DOS

syntax, other conventions are supported by different—and commonly used—UNIX

emulation tools such as MKS, Cygnus, and UWIN.

TABLE C-2 Environment Variable Settings for Forte TeamWare on Microsoft Windows

Environment Variable Description

PATH Include the full path name to the bin directory where Forte TeamWare

has been installed. Please see the Forte TeamWare Release Notes for

more specific information on the installation directory for the Forte

TeamWare executables.

SENDMAILHOST Use to specify a host name of a machine running the sendmail daemon.

This is required for sending workspace notifications of bringovers,

putbacks, and other workspace transactions; and for usage tracking.

CLASSPATH If Forte TeamWare is invoked from the batch file scripts (which is the

case when using Program menu shortcuts), there is no need to set the

classpath. Otherwise, make sure the path to the teamware.jar file is

in the classpath. Please see the Forte TeamWare Release Notes for more

specific information on the installation directory for the

teamware.jar file.
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Forte TeamWare can accommodate multiple path-name conventions, enabling

Microsoft Windows users to select their preferred syntax. The choice of syntax is

made by setting the environment variable CODEMGR_PATHNAME_STYLE. TABLE C-3

shows the supported syntax conventions along with their corresponding

CODEMGR_PATHNAME_STYLEsettings.

In the examples in TABLE C-3, c is the drive letter; dir is a directory name; and

file is a file name.

Note – The absence of a drive-letter specification (for example, /dir1/dir2 ) is

ambiguous on Microsoft Windows and not recommended for use in Forte

TeamWare.

Understanding Carriage Return and
Line Feed Translation

UNIX and Microsoft Windows platforms have different conventions for end-of-line

(EOL) delimiters in text files. In UNIX environments, the EOL delimiter is the line

feed (LF), while on Microsoft Windows, the EOL delimiter is the carriage-return line-

feed (CRLF). For interoperability, SCCS uses the single LF as the universal EOL

delimiter in the SCCS history file. Whenever a Microsoft Windows text file is

checked in with SCCS, any CRLF line delimiters are automatically converted to LF

characters. This operation is transparent to the user and cannot be overridden.

When a working version of a file, known as a “clear file,” is obtained from SCCS (for

example, from sccs get or edit operations), SCCS retains the single LF line

delimiters by default. Most Microsoft Windows applications can properly process

single LF delimiters. When the CRLF convention must be used, you can instruct

SCCS to translate LF delimiters into CRLF delimiters in the clear file by setting the

environment variable SCCS_GET_TRANS_LFto Yes. For example:

set SCCS_GET_TRANS_LF=Yes

TABLE C-3 Supported Path-Name Conventions for Microsoft Windows

Syntax Example CODEMGR_PATHNAME_STYLESetting

Microsoft Windows (DOS shell) c:\dir\file DOS

Alternate 1: MKS c:/dir/file ALT1

Alternate 2: Canonical UNIX //c/dir/file ALT2
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export SCCS_GET_TRANS_LF

CRLF translation, or lack of it, also affects the behavior of Forte TeamWare

transactions. When Forte TeamWare performs a bringover or putback operation, the

default behavior is to make SCCS extract a clear file for each updated history file.

The setting of the SCCS_GET_TRANS_LFvariable decides what kind of clear files

appear in the workspace.

For most Microsoft Windows editors, the single LF character does not pose a

problem and has the added benefit of being suitable for viewing from the UNIX

platform. However, when Forte TeamWare workspaces are shared between

platforms, it is highly recommended to use the default SCCS (non-translation) mode

or explicitly set SCCS_GET_TRANS_LFto No.

Adding Newline Characters to Text Files

Not all applications include newline characters on the last line of a text file, which

can cause Forte TeamWare to interpret text files as binary files. To prevent this from

happening, the software appends a newline character to files that have previously

been identified as a text files (if a terminating newline character is not already

present).

You can override this feature by setting the following environment variable:

SCCS_NO_NL_TERMINATE=YES

Cross-Platform Interoperability

Forte TeamWare uses a common, platform-independent format for SCCS history files

and workspace metadata structures. With the use of appropriate file-sharing

services, users running Forte TeamWare on different platforms can share a single

workspace.

Sharing SCCS History Files

Because the format of SCCS (Source Code Control System) history files is compatible

across platforms, these files can be:

■ Copied or propagated from one platform to another
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■ Processed by SCCS and Forte TeamWare utilities on either platform

Editing text files that are shared between UNIX® and Microsoft Windows

environments can produce unexpected results due to the different ways in which

text editing software in these environments represents the end-of-line (EOL)

delimiter. To minimize the effect of EOL differences, SCCS provides an EOL-

translation feature for plain text files. See “Understanding Carriage Return and Line

Feed Translation” on page 220 for further details.

Sharing Workspaces

The Forte TeamWare workspace is compatible across platforms. For example, a

Microsoft Windows user of Forte TeamWare can perform putback and bringover

operations with a workspace created by Forte TeamWare in a Solaris environment.

This sort of task requires file-sharing services for accessing Solaris file systems from

Microsoft Windows systems. Currently, there is only one supported option: Samba.

Samba is a Microsoft Windows/UNIX networking and file-sharing software product,

freely distributed under the GNU public license. For further information about Samba, go

to the Samba website at http://us1.samba.org .

Problems with Logical Paths and Workspace

Metafiles

A Forte TeamWare workspace maintains a record of the parent and child

relationships it shares with other workspaces. This information consists of the

location of all parent and child workspaces, and is stored in a metadata file

contained in the workspace. When a workspace is shared among multiple users

running Forte TeamWare on different platforms, the logical path(s) to that workspace

may differ depending on the way the workspace is mounted with respect to a given

user’s system. When problems arise due to unrecognized entries in the parent and

child workspace metafiles, the solution is to reparent the affected workspace. To do

so, in the Configuring tool, choose Workspace ➤ Reparent, or type the following

command:

workspace parent -p new-parent
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Sharing Files With Solaris Users

Forte TeamWare does not work properly on integration workspaces that reside on

file systems mounted using PC-NFS™ software. SCCS assumes a user with write

access can remove a read-only file. PC-NFS precludes this ability, which causes SCCS

and Forte TeamWare to malfunction. To circumvent this problem, use an alternative

file-sharing service.

For example, when properly configured, the Samba file server provides access to

UNIX file systems from Microsoft Windows that Forte TeamWare requires.

Configuring the Samba File Server

The Samba file server software is freely available under the GNU General Public

License. See http://www.samba.org for details and download information.

To make Samba work properly with Forte TeamWare on Microsoft Windows, edit the

Samba configuration file smb.conf and set the parameters as shown in TABLE C-4:

TABLE C-4 Samba Configuration File Parameter Settings

Parameter Group Parameter Name Setting

[global] preserve case yes

short preserve
case

yes

case sensitive yes

delete readonly yes

create mask 777

directory mask 777

encrypt passwords yes

[ export-directory-name ] comment export-directory-name

path /export
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Encrypted passwords are enabled in Windows NT Service Pack 3 or compatible.

Samba support for encrypted passwords is provided in version 1.9.18 or compatible.

For more information, see the Samba FAQ at http://us1.samba.org/samba/
docs/FAQ .

Using Forte TeamWare as a Plugin to
Microsoft Visual Studio

Once installed in the Microsoft Windows environment, Forte TeamWare will

automatically serve as the default Source Code Control (SCC) system for Microsoft

Visual Studio. Visual Studio projects are placed under Forte TeamWare SCC, and

access to basic Forte TeamWare commands is available from the Project ➤ Source

Control menu options.

Placing a Microsoft Visual Studio Project Under

Forte TeamWare SCC

To place a Visual Studio project and all its component files under Forte TeamWare

SCC:

1. Select the project in the Microsoft Visual Studio “Workspace Window”.

2. From the Project ➤ Source Control menu, choose Add to Source Control

writeable yes

public no

create mask 777

TABLE C-4 Samba Configuration File Parameter Settings

Parameter Group Parameter Name Setting
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Accessing Forte TeamWare Commands in

Microsoft Visual Studio

Having placed your project under Forte TeamWare SCC in Microsoft Visual Studio,

basic Forte TeamWare functionality is available using the commands in the Project ➤

Source Control menu. This menu is shown in FIGURE C-1 below.

FIGURE C-1 Source Control Menu in Microsoft Visual Studio

The Project ➤ Source Control menu options shown in FIGURE C-1 above, correspond

with Forte TeamWare commands documented elsewhere in this manual. TABLE C-5

shows the correspondence between Project ➤ Source Control menu options and

Forte TeamWare commands, giving for each command a reference to the full

description in this book.

TABLE C-5 Source Control Menu Options and Forte TeamWare Commands

Source Control Menu Option Forte TeamWare Command Reference

Get Latest Version Bringover “Propagating Changes

Across Workspaces” on

page 24

Check Out Check Out “Checking Out a File” on

page 68

Check In Check In “Checking In a File” on

page 70

Undo Check Out Uncheckout “Reversing Changes to a

File” on page 71
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Add to Source Control Check In New “Adding Files to a

Workspace” on page 67

Create Workspace “Creating Child

Workspaces” on page 21

Remove from Source Control Workspace

Reconversion

“Deleting or Reconverting

Workspaces” on page 30

Show History File History “Viewing File History” on

page 94

Show Differences Latest Diffs Opens a Merging window

to display current file

differences. See “Reading

Merging Glyphs” on

page 78 for further

information.

Share from Forte-SCCS The Share from Forte-SCCS command allows files

already under Forte TeamWare/SCCS control but not

currently included in a Microsoft Visual Studio

workspace, to be accessible from within the Visual

Studio SCC environment.

Note: this command has no Forte TeamWare

equivalent.

Refresh Status View ➤ Refresh/

Update

This command ensures

that the current status of

files is accurately shown

in the GUI. See online help

for further information.

TABLE C-5 Source Control Menu Options and Forte TeamWare Commands

Source Control Menu Option Forte TeamWare Command Reference
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Glossary

access control A feature in Configuring you can use to control access to workspaces.

branch (SCCS) A delta or series of deltas that are placed off the main line of deltas in an SCCS

history file.

Bringover Create
transaction The transaction used to copy groups of files from a parent workspace to a

nonexistent child workspace. The new child workspace is created as a result of

the transaction. All Configuring transactions are performed from the

perspective of the child workspace; hence, the Bringover Create transaction

“brings over” files to the child from the parent workspace. See also Bringover
Update transaction, workspace, and putback.

Bringover Update
transaction The transaction used to update an existing child workspace with respect to

files contained in its parent workspace. All Configuring transactions are

performed from the perspective of the child workspace; hence, the Bringover

Update transaction “brings over” files to the child from the parent workspace.

See also Bringover Create transaction, workspace, and putback.

child workspace A workspace that has a parent workspace listed in its Codemgr_wsdata/
parents file. Development work is typically done in a child workspace and

put back to a parent workspace after the work has been tested. All conflicts are

resolved in the child workspace. Configuring transactions are viewed from the

perspective of the child workspace.

Codemgr_wsdata
directory Every TeamWare workspace contains a metadata directory in its root directory

named Codemgr_wsdata . Configuring stores data about the workspace in

Codemgr_wsdata . The presence of this directory is the sole factor that defines

it as a TeamWare workspace (as opposed to a normal directory). Configuring

commands use the presence or absence of this directory to determine whether

a directory is a workspace. See “Workspace Metadata Directory” on page 159

for more information.

Configuring tool The tool you use to manage Forte TeamWare workspaces. See Chapter 2.
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conflict The condition that exists when a file has changed in both the child and parent

workspace. Conflicts are identified by the Bringover Update transaction and

are resolved by using the Resolve transaction.

copy-modify-merge
model The concurrent development model upon which Configuring is based. Using

this model, multiple developers concurrently copy sources from a common

area, modify the source in isolation, and then merge those changes with changes

made by other developers.

create Used in Configuring transaction output. Files are said to be created if they exist

in the source workspace and not in the destination workspace, and are copied

into the destination workspace as part of a Bringover or Putback transaction.

default path The branch in an SCCS history file upon which the next delta will be added.

This is indicated in a history file by a solid line.

def.dir.flp
program The default FLP shipped with Configuring is def.dir.flp ; this FLP

recursively descends directory hierarchies and lists all files for which SCCS

history files exist. See FLP.

delta The set of differences between two versions of a file checked into SCCS. When

you check in a file, SCCS records only the line-by-line differences between the

text you check in and the previous version of the file. This set of differences is

known as a delta. The file version that you initially checked out was

constructed from a set of accumulated deltas. The terms delta and version are

often used synonymously; however, their meanings are not the same. It is

possible to retrieve a version that omits selected deltas. See Version.

FLP An FLP or File List Program is a program or script that generates a list of files

that Configuring uses during Bringover and Putback transactions. See

def.dir.flp.

Freezepointing tool The Forte TeamWare tool you use to make snapshots of workspaces (or

portions of them) at important junctures or “freezepoints.” See Chapter 8.

g-file (SCCS) The working copy of a file retrieved from an SCCS history file by the

sccs-get command.

history file When you initially put a file under SCCS control, a history file is created for

the new SCCS file. The initial version of the history file uses the complete text

of the source file. The initial history file is the file that further deltas are

compared to. Because of its prefix (s.), the history file is often referred to as the

s.file (s-dot-file).

integration request
identifier A “password” required by Putback Validation before Configuring allows a

putback.

integration
workspace A workspace to which multiple developers put back their work.
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lock To assure consistency, the Configuring file transfer transactions Bringover and

Putback lock workspaces while in progress. Locks are recorded in the

Codemgr_wsdata/lock file in each workspace; the Configuring commands

consult that file before acting in a workspace.

merge To produce a single version of a file from two conflicting files. Accomplished

with the assistance of the Merging tool.

Merging tool The Forte TeamWare tool you use to merge two different versions of the same

file. See Chapter 6.

MR Modification Request. A “password” required by Versioning before a file can

be checked in.

notification A Configuring feature that mails notices of events, such as changes to files or

directories, to users.

parent workspace A workspace that has a child workspace. Parent workspaces are typically used

as integration areas, whereas development, testing, and conflict resolution are

done in child workspaces.

putback The transaction used to update a parent workspace with respect to files

contained in its child workspace. All Configuring transfer transactions are

performed from the perspective of the child workspace; the Putback

transaction “puts back” files to the parent from the child workspace. See also

Bringover Create transaction, Bringover Update transaction, and workspace.

putback validation A Configuring feature that allows you to control which putbacks are allowed

to a specific workspace.

reparent To change the parent of a child workspace.

resolve To produce a new delta of a file from two conflicting deltas. See merge and

conflict.

root directory The top-level directory of a Configuring workspace. This directory’s path name

is the name by which the workspace is referred.

RTI Request To Integrate, the heading used to record an Integration Request

Identifier in a workspace history file.

SCCS Delta ID (SID) The number used to represent a specific delta. This is a two-part number, with

the parts separated by a dot (.). The SID of the initial delta is 1.1 by default.

The first part of the SID is referred to as the release number and the second, the

level number. When you check in a delta, the level number is increased

automatically.

SCCS file properties Properties that you can assign to individual files.

SCCS history file The file that contains a given file’s delta history; also referred to as an

“s-dot-file.” All SCCS history files must be located in a directory named SCCS,

which is located in the same directory as the g-file. See g-file.
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SCCS Mergeable ID
(SMID) A number generated using the Xerox Secure Hash Function that ensures that

every delta is uniquely identifiable, even if its SID is changed.

SID See SCCS delta ID.

SMID See SCCS Mergeable ID.

uncheckout To return a file to the state it was in before the most recent checkout.

undo To return a workspace to the state it was in before the most recent Bringover or

Putback transaction, thereby “undoing” the action of the transaction.

update Files are updated during a Bringover or Putback transaction if they exist in

both the source workspace and in the destination workspace, and have

changed in the source workspace. The SCCS history file in the destination

workspace is updated with new deltas from the source workspace.

version When you check in a file, SCCS records only the line-by-line differences

between the text you check in and the previous version of the file. This set of

differences is known as a delta. The file version that you initially checked out

was constructed from a set of accumulated deltas. The terms delta and version

are often used synonymously; however, their meanings are not the same. It is

possible to retrieve a version that omits selected deltas. See delta.

Versioning tool The Forte TeamWare tool you use to manage Forte TeamWare files. See

Chapter 5.

workspace A specially designated directory, its subdirectories, and the files contained
in those directories. The files within a workspace have been placed under
the control of Forte TeamWare and SCCS so that TeamWare can manipulate

those files. Usually, a developer works in his or her own isolated workspace,

while other developers on the same project work concurrently in their own

workspaces. The Configuring tool provides utilities to manage workspaces. See

Chapter 2; also see parent workspace and child workspace.

Workspace hierarchy A hierarchy of parent and child workspaces in which developers and release

engineers develop, test, share, and release software products.
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SYMBOLS
-, 79

+, 79

., 132

|, 79

A
access control, workspace

default permissions, 162

setup, 55

values, 163

access_control  file, 160, 162

Actions menu (Configuring), 19

adding (mounting)

files to a workspace, 67

path to Load menu (Versioning), 104

ancestor file (Merging), 81

loading at startup, 138

archiving libraries, 131

args  file, 160

arrow, 96

automatic merging, 83

automatically creating

bringover/putback file lists, 40

freezepoint file, 118

B
backup  subdirectory, 160

batch files, 218

branch, 45, 96, 97

SCCS history file, 169

bringover and putback options

delta comments, 39

force conflicts, 39

preview, 39, 40

quiet, 39, 40

setting, 37

skip backups, 39

skip SCCS gets, 39

verbose, 39

Bringover Create

tab, 22

transaction, 22

Bringover Update

file list, 40

tab, 25

transaction, 24

updating your workspace, 93

build server configuration file, 124

build servers, 133

C
carriage returns, 220

changing

default editor, 70

workspace history viewer, 31

Check In New, 68

checking out a file, 68
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child workspace

creating, 21

defined, 9

reasons to reparent, 44

reparenting by dragging and dropping, 46

reparenting by using a Parent menu item, 45

reparenting example, 46

children  file, 160

CLASSPATH environment variable, 219

CodeManager tool

codemgr  command, 136

See "Configuring"

codemgr  command, 136

CODEMGR_DIR_FLP, 42

CODEMGR_PATH, 52

CODEMGR_PATH_ONLY, 53

CODEMGR_PATHNAME_STYLE, 220

.codemgr_resrc  file, 161

CODEMGR_WS, 53, 114

Codemgr_wsdata  subdirectory

access_control  file, 160, 162

args  file, 160

backup  subdirectory, 160

children  file, 160

conflicts  file, 160

description  file, 160

errors with, 210

freezepoints  subdirectory, 160

history  file, 160

locks  file, 161

nametable  file, 161

notification  file, 161

parent  file, 161

putback.cmt  file, 107, 161

.codemgrtoolrc  file, 161

colors in Merging window, 78

command-line interface, 135 to 141

accessing on Microsoft windows, 219

Configuring, 136

Freezepointing, 139

Merging, 137

commands, 135 to 141

accessing man pages, 136

freezept , 139

SCCS commands to avoid, 211

twconfig , 18

twmerge , 138

twversion , 137

Commands menu (Versioning), 66

comment

Bringover/Putback warning, 40

Check In, 71

Checkin default, 85

delta, 39

email transaction comments, 42

merging delta, 97

Putback, 28, 72

concurrent file modification, 130

configuration, Samba file server, 223

Configuring

accessing commands from within Forte for

Java, 147

command-line interface, 136

customization, 49

customizing, 49

error messages, 179

properties, 49

starting the Configuring tool, 17

warning messages, 198

Configuring window, 19

Configuring workspace, defined, 159

conflicts

defined, 76

merging, 77

conflicts  file, 160

controlling workspace access, 55

converting an RCS project to TeamWare, 53

copy-modify-merge, 8

creating

child workspace, 21

customized menu (Versioning), 103

empty workspace, 20

freezepoint file, 110, 113

parent workspace, 20

workspace from file hierarchy, 21

crossed-out delta, 96

current difference (Merging), 83

customizing Configuring, 49

Cygnus tool, 219

D
def.dir.flp  file, 41
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default editor, 70, 106

default file list, 40

deleting

files, 98

moving instead, 29

workspaces, 30

delta

comments option, 39

defined, 9, 96

history view, 94

in freezepoint files, 120

dependency lists

explicit ordering of, 130

implicit ordering of, 129

description  file, 160

descriptive workspace names, 43

difference (Merging)

current, 83

next, 83

previous, 83

resolved, 82

resolving, 82

diffs, 94

directory, current working (Merging), 81

disk space

verifying sufficient for putback, 206

displaying

differences between deltas, 105

distributed make

see dmake

dmake
basic concepts, 123

command, 133

host, 133, 134

impact on makefiles, 128

-j option , 134

-m option , 134

nested invocations of, 133

understanding, 128

dmake.conf  file, 124, 127

.dmakerc  file, 124

dotted lines, 96

double underline, 96

double-click, 51, 106, 140

drag-and-drop, 140

reparenting workspaces, 45

workspace icons, 46

drive letters, 219

E
edit locks, 64

editing output file (Merging), 91

editor

changing, 70

default, 106

email notification, 42

environment variable

CLASSPATH, 219

CODEMGR_DIR_FLP, 42

CODEMGR_PATH, 52

CODEMGR_PATH_ONLY, 53

CODEMGR_PATHNAME_STYLE, 220

CODEMGR_WS, 53, 114

PATH, 207, 219

SCCS_GET_TRANS_LF, 209, 214, 220

SENDMAILHOST, 207, 210, 219

setting path syntax, 220

EOL delimiters, 209, 220

error messages

Configuring, 179

Freezepointing, 112

examples

Copy-Modify-Merge, 11

loading workspaces automatically, 52

Merging, 87 to 92

putback validation program, 61

renaming conflicts, 100

renaming or moving files, 98

reparenting a workspace, 46

setting a search path, 53

setting focus for command-line commands, 53

Team-Project, 12

existing files, creating a workspace from, 21

extracting

deltas from freezepoint file, 110, 115

freezepoint file, 115

source hierarchy, 110, 115

F
file
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access_control , 160, 162

ancestor, 81

args , 160

build server configuration, 124

checking out, 68

children , 160

.codemgr_resrc , 161

.codemgrtoolrc , 161

concurrent modification, 130

conflicts , 160

deleting, 98, 101

description , 160

dmake.conf , 124, 127

.dmakerc , 124

freezepoint, 110

automatically creating, 118

creating, 110, 113

defined, 120

extracting, 115

updating, 114

history, 94

history  file, 160

in conflict (Merging), 165

loading three at startup (Merging), 138

loading two at startup (Merging), 138

locks , 161

moving, 98

name history, 100

nametable , 161

not in conflict (Merging), 164

notification , 161

parent , 161

putback.cmt , 107, 161

reloading (Merging), 84

renaming, 98

runtime configuration, 124

SCCS properties, 106

unchecking out, 71

version, 97

.Z  extension, 119

file history

symbols, 96

viewing, 94

File List Program (FLP), 41

sample, 41

File menu

Configuring, 19

Freezepointing, 112

Versioning, 66

file server configuration, 223

file sharing, 223

file-name syntax, 219

files

customized bringover/putback list, 40

loading (Versioning), 104

filtering workspace history viewer info, 34

force conflicts option, 39

Forte for Java

configuring commands, 147

Explorer window, 152

freezepointing commands, 149

menubar, 151

merging commands, 148

TeamWare toolbar, 151

versioning commands, 150

freezepoint file, 110

autofreezepoint, 118

contents, 120

creating, 110, 113

defined, 120

extracting, 115

updating, 114

freezepoint, defined, 109

Freezepointing

accessing commands from within Forte for

Java, 149

command-line interface, 139

creation defined, 110

extraction defined, 110

starting, 111

Freezepointing tool, 218

Freezepointing window

in Creation mode, 112

in Extraction mode, 117

Freezepoints  subdirectory, 160

freezept  command, 139

G
General tab, 106

getting started, 12 to 16

global permission, 56

glyphs, meaning of (Merging), 78, 90
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group permission, 57

H
Help menu

Configuring, 19

Freezepointing, 112

Versioning, 67

history

file, 160, 163

sharing SCCS files, 221

workspace, 31

hollow font, 79

I
individual permission, 57

integrating file changes, 72

Integration Request ID, 61

interoperability, 221

K
keyboard shortcuts, 140

L
library update, concurrent, 131

limitations on makefiles, 129

line feed translation, 214, 220

Load menu (Versioning), 104

loading (see"adding")

files from Merging window, 80

two or three files at Merging startup, 138

locks

removing workspace locks, 63

locks  file, 161

logical paths and workspace metafiles, problems

with, 222

M
macros

dynamic, 130

makefile

file collisions in, 132

impact of dmake utility on, 128

limitations, 129

template, using, 128

man pages, 2

menu customized (Versioning), 103

Merging

accessing commands from within Forte for

Java, 148

automatic, 83

command-line interface, 137

files in conflict, 165

files not in conflict, 164

options, 84

reversing changes, 84

SCCS history files, 165

tool, 218

merging deltas, 97

Merging example, 87 to 92

merging files in conflict, 77

Microsoft Windows

NT Service Pack 5, 210

sharing files, 223

minus sign, 79

MKS tool, 219

Modification Request (MR), 107

monitoring

processes, 211

mounting, see adding

mouse shortcuts, 51, 140

moving

files, 98

workspaces, 29

MR (Modification Request), 107

multiple targets, 131

N
name

history, 100

workspace, 43
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nametable  file, 161

netgroup, 57

newline characters, 214, 221

next difference (Merging), 83

NO_PARALLEL: special target, 132

NoClassDefFoundError , 208

notification  file, 161

notification, email, 42

entering putback comments, 72

O
Open Files dialog box (Merging), 80

options

bringover/putback, 37

Configuring, 49

Merging, 84

resolve (Merging), 85

Options menu (Configuring), 19

outline font, 79

output file (Merging), 91

Output Transaction Window, 23

P
PARALLEL: special target, 132

parallelism, 132

parent  file, 161

parent workspace

creating, 20

defined, 9

PATH environment variable, 207, 219

path syntax, 219

PCNFS, 223

permission, 56

plus sign, 79

preview option, 39

previous difference (Merging), 83

process monitoring, 211

project, converting RCS to TeamWare, 53

propagating changes, 24

Putback

comments, 28

file list, 40

preview, 39, 206

tab, 27

transaction, 26

putback

options, 37

problems with multiple simultaneous users, 210

putback validation, 58

sample program, 61

turning on, 60

putback.cmt  file, 107, 161

Q
quiet option, 39

R
rcs2ws , using, 54

reconverting a workspace, 30

red check mark, 96

removing

files, 98

workspace locks, 63

workspaces, 30

rename conflict, 100, 101

renaming

files, 98

workspaces, 29

reparenting a workspace, 44

example, 46

problems with logical paths and workspace

metafiles, 222

temporarily, 46

Resolve transaction, 76, 141

conflict within child workspace, 165

merging SCCS history files, 170

resolving differences, 82

restricting parallelism, 132

restrictions on makefiles, 129

reversing changes

file, 71

Merging, 84

workspace, 28

Revision Control System (RCS), 53
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right mouse button, 140, 141

RTI (Request To Integrate), 58

runtime configuration file, 124

S
Samba, 223

SCCS

commands to avoid, 211

defined, 9

delta ID (SID), 96

diffs subcommand, problem with, 213

errors, 213

file properties, 106

history file, 163, 212

history file and branching, 169

history file and merging, 159, 170

history file restoration, 212

history file validation, 212

history files, sharing, 221

master file, 210

s-dot-file, 163

Y2K compliance, 213

SCCS delta ID (SID)

and SCCS Mergeable ID (SMID), 120

to SCCS Mergeable ID (SMID) translation, 176

SCCS Mergeable ID (SMID)

and SCCS delta ID (SID), 120

to SCCS delta ID (SID) translation, 176, 177

why necessary, 176

SCCS_GET_TRANS_LF, 209, 214, 220

SCCS_NO_NL_TERMINATE, 221

sccs-admin  command, 106

s-dot-file, 163

searching workspace history, 35

selecting groups of files, 139

SENDMAILHOST, 207, 210, 219

server configuration and Samba, 223

setting up TeamWare, 12

sharing files, 223

sharing workspaces, 222

shift-click, 139

shortcuts

keyboard, 140

mouse, 140

SID

defined, 96

translating to SMID, 176

skip backups option, 39

skip SCCS gets option, 39

solid lines, 96

sorting workspace history viewer info, 34

Source Code Control System (see SCCS)

source hierarchy

extracting, 115

recreating, 115

source workspace, 111

spaces

blank lines and extra white space, 214

in file names, 206

in workspace names, 209

starting

Configuring, 17

Freezepointing, 111

Merging from the command line, 137

Versioning, 65, 141

Versioning from the command line, 137

symbols

file history, 96

glyphs in Merging, 78

T
target

building multiple concurrently, 129

multiple, 131

special

.WAIT , 130

NO_PARALLEL:, 132

PARALLEL:, 132

WAIT, 130

TeamWare

tools, 14

workflow, 13

TeamWare menu

Configuring, 19

Freezepointing, 112

Versioning, 67

terminating newline characters, 214, 221

text files, 221

Tool Properties dialog box, 49
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Configuring pane, 49

Resolve tab, 85

tools, list of, 14

transactions

Bringover Create, 22

Bringover Update, 24

controlling, 55

notifying other users, 42

Putback, 26

Resolve, 76, 141, 165

Undo (Configuring), 28

Undo (Merging), 84

twconfig  command, 18

twmerge  command, 138

twversion  command, 137

U
uncheckout, 71, 82

Undo transaction, 28

UNIX syntax, 219

updating

bringover/putback list of files, 41

freezepoint file, 114

V
validation, 58

verbose option, 39

version defined, 97

version, verification of Forte TeamWare, 215

Versioning

accessing commands from within Forte for

Java, 150

customized menu, 103

starting automatically with double-click, 141

starting from command line, 137

vertical bar, 79

View menu (Configuring), 19

View menu (Freezepointing), 112

View menu (Versioning), 66

viewing

diffs, 94

file history, 94

non-SCCS files, 67

workspace history, 31

viewing workspace names, 43

W
WAIT special target, 130

warning messages, Configuring, 198

workspace

access, 55

access control, 162, 163

adding files, 67

child, 9, 21

compatibility, 216

Configuring, defined, 159

conflict, 76

conflicts, 76

corruption, 216

creating from file hierarchy, 21

defined, 17

deleting, 30

descriptive name, 43

empty, 20

event notification, 42

locks, 63

metadata directory (Codemgr_wsdata ), 159

moving, 29

name, 43

parent, 9, 20

problems with metafiles and logical paths, 222

putback validation, 58

reasons to reparent, 44

reconverting, 30

removing locks, 63

renaming, 29

reparenting, 44, 46, 222

reversing changes, 28

searching history, 35

source, 111

viewing history, 31

workspace descr  command, 43

workspace history viewer

filtering info, 34

launching, 31

Workspace menu

Configuring, 19

Versioning, 67

workspace permissions, 55
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workspaces, sharing, 222

Y
Year 2000 (Y2K) compliance, 213

Z
.Z  extension, 119
Index 239



240 Forte TeamWare User’s Guide • August 2001


	Forte TeamWare User’s�Guide
	Contents
	Figures
	Preface
	Multiplatform Release
	Microsoft Windows Issues
	Using Forte TeamWare as an Integration Module
	Accessing Man Pages
	How This Book Is Organized
	Typographic Conventions
	Shell Prompts
	Related Documentation

	Introduction to Forte TeamWare
	What Forte TeamWare Does
	Basic Concepts
	Why Use Forte TeamWare?
	Parent and Child Workspaces
	Source Code Control System (SCCS)

	Forte TeamWare�Models
	The Copy-Modify-Merge Model
	The Team-Project Model
	Forte TeamWare Environment Setup
	Day-to-Day Work in a Forte TeamWare Environment


	Working With Forte TeamWare
	Forte TeamWare Scenarios
	Joining an Existing Team
	Setting Up a Forte TeamWare Environment


	Managing Workspaces
	Starting Configuring
	Launching Forte TeamWare from the Forte for Java IDE
	Launching Forte TeamWare as a Stand-Alone Application

	Creating a Parent Workspace
	Creating an Empty Workspace
	Creating a Workspace from Existing Files

	Creating Child Workspaces
	Propagating Changes Across Workspaces
	Updating a Child Workspace (Bringover Update)
	Putting Back Changes to a Parent Workspace

	Undoing Changes to a Workspace
	Renaming or Moving Workspaces
	Deleting or Reconverting Workspaces
	Deleting a Workspace
	Reconverting a Workspace

	Viewing Workspace History
	Changing the Workspace History Viewer Display
	Adding or Removing Transaction Information From the Workspace History Viewer
	Sorting Transaction Information in the Workspace History Viewer
	Adding Filtering Options to the Workspace History Viewer
	Filtering Transaction Information From the Workspace History Viewer
	Searching for Transactions


	Advanced Workspace Management
	Using Bringover and Putback Options
	Setting Options During a Bringover or Putback
	Setting Tool Properties

	Creating Customized Bringover and Putback File Lists
	Saving a Default List of Files
	Generating a Customized List of Files

	Notifying Users of Transactions
	Giving a Workspace a Descriptive Name
	Reparenting a Workspace
	Reasons to Change a Workspace’s Parent
	Ways to Reparent Workspaces
	The Reparent Command
	Drag-and-Drop Workspace Icons
	Temporary Reparenting

	Reparenting Example

	Using Tool Properties to Customize Configuring
	Configuring Environment Variables
	Loading Workspaces Automatically
	Setting Focus for Command-Line Commands
	Setting a Search Path

	Converting From a Revision Control System Project

	Controlling Workspace Access
	Specifying Permissions
	Specifying Global Permissions
	Specifying Group or Individual Permissions

	Protecting Workspaces With Putback Validation
	Turning On Putback Validation
	Invoking Your Own Putback Validation Program
	Sample Validation Program


	Removing Workspace Locks

	Managing Files
	Starting Versioning
	Adding Files to a Workspace
	Checking Out a File
	Editing a File
	Changing Your Default Editor
	Checking In a File
	Reversing Changes to a File
	Integrating Changes by Putting Back Files

	Resolving Differences Between Files
	Starting Merging
	Workspace Conflicts
	Starting Merging From the Resolve Tab
	Viewing the Merging Window

	Resolving Conflicts in a Workspace
	Reading Merging Glyphs
	Two Input Files
	Three Input Files

	Loading Files Into Merging
	Transaction Check In

	Resolving Differences
	Using Automatic Merging
	Undoing Changes
	Merging Options
	Resolve Options
	Display Options in Merging

	Merging Example
	Examining Differences
	Resolving a Difference
	Editing the Output File


	Advanced File Management
	Updating the Files in Your Workspace
	Viewing File History
	File History Window
	File History Viewer Symbols

	How To Read a File’s History: Deltas, Branches, and Versions
	Merging Deltas


	Renaming, Moving, or Deleting Files
	Renaming or Moving Files
	Example
	Name History
	Rename Conflicts

	Deleting Files From Outside Forte TeamWare
	Deleting Files From Within Forte TeamWare

	Creating a Customized Menu
	Adding a Path to the Load Menu
	Changing Versioning Properties
	Setting SCCS File Properties

	Using Freezepointing
	Introduction to Freezepointing
	How Freezepointing Works
	Creation Defined
	Extraction Defined
	Source Workspace
	Destination Directory

	Starting Freezepointing
	Creating a Freezepoint File
	Updating a Freezepoint File
	Extracting Files
	Automatically Generating Freezepoints
	Reading Freezepoint Files Format

	Using the dmake Utility
	Basic Concepts
	Configuration Files
	Runtime Configuration File
	Build Server Configuration File

	The dmake Host
	The Build Server

	Understanding the dmake Utility
	Impact of the dmake Utility on Makefiles
	Using Makefile Templates
	Building Targets Concurrently
	Limitations on Makefiles
	Dependency Lists
	Explicit Ordering of Dependency Lists

	Concurrent File Modification
	Concurrent Library Update
	Multiple Targets
	Restricting Parallelism
	Nested Invocations of Distributed Make

	Using the dmake Utility

	Forte TeamWare Shortcuts
	Accessing TeamWare From the Command Line
	Configuring Commands
	Versioning Commands
	Merging Commands
	Loading Two Files at Startup
	Loading Three Files at Startup

	Freezepoint Commands

	GUI Shortcuts
	Double-Click Actions in Configuring
	Double-Click Actions in Versioning
	Double-Click Action File History


	Using Forte TeamWare From Within the Forte for Java IDE
	Using Forte TeamWare With Forte for Java
	What Is Forte for Java?
	Forte TeamWare Functionality Within Forte for Java
	Mounting a Forte TeamWare Filesystem
	Accessing the Forte for Java TeamWare Toolbar
	Forte for Java and Forte TeamWare in Action

	Accessing Forte TeamWare Commands and Features
	Forte TeamWare Tools and Tasks
	GUI Elements and Forte TeamWare Commands
	Forte for Java IDE Editor and Forte TeamWare Tools


	Forte TeamWare Architecture
	Workspace Metadata Directory
	Configuring Defaults Files
	The access_control File
	How Configuring Merges Files
	Merging Files That Do Not Conflict
	Merging Files That Conflict
	How Merging Tracks Deltas

	About SCCS Mergeable IDs
	Why SMIDs Are Necessary
	Translating Between SMIDs and SIDs
	Translating SIDs to SMIDs
	Translating SMIDS to SIDS



	Error and Warning Messages
	Error Messages
	Warning Messages

	Troubleshooting
	Bringover and Putback Errors
	Environment Variables
	Java Issues
	Microsoft Windows and Unix Operating System Incompatibilities
	Microsoft Windows File Sharing
	Process Monitoring
	SCCS Commands to Avoid
	SCCS History Files
	SCCS Errors
	Text Formatting Issues
	Version Verification
	Workspaces

	Using Forte TeamWare in a Microsoft Windows Environment
	Launching Forte TeamWare Tools
	Setting Environment Variables
	Using the Command-Line Interface
	Selecting Drive Letter and Path-Name Syntax
	Understanding Carriage Return and Line Feed Translation
	Adding Newline Characters to Text Files
	Cross-Platform Interoperability
	Sharing SCCS History Files
	Sharing Workspaces
	Problems with Logical Paths and Workspace Metafiles

	Sharing Files With Solaris Users
	Configuring the Samba File Server
	Using Forte TeamWare as a Plugin to Microsoft Visual Studio
	Placing a Microsoft Visual Studio Project Under Forte TeamWare SCC
	Accessing Forte TeamWare Commands in Microsoft Visual Studio


	Glossary
	Index

