Guida all'installazione di Solaris 9

Messaggi di errore relativi al boot dalla rete


WARNING: getfile: RPC failed: error 5 (RPC Timed out).

Descrizione:

Questo errore si verifica quando nella rete vi sono due o più server che rispondono alla richiesta di boot di un client. Il client di installazione si connette al server di boot sbagliato e l'installazione si blocca. Questo errore può essere causato da due ragioni specifiche:

Causa:

Causa 1: È possibile che vi siano due file /etc/bootparams su server diversi con una voce per quel client di installazione.

Soluzione:

Causa 1: Verificare che i server della rete non contengano più voci per il client di installazione nel file /etc/bootparams. Se sono presenti più voci, rimuovere quelle relative al client dal file /etc/bootparams di tutti i server di installazione e di boot ad eccezione di quello che il client dovrà usare.

Causa:

Causa 2: È possibile che esistano più voci per quel client di installazione nelle directory /tftpboot o /rplboot.

Soluzione:

Causa 2: Verificare che i server della rete non contengano più voci per il client di installazione nelle directory /tftpboot o /rplboot. Se sono presenti più voci, rimuovere quelle relative al client dalle directory /tftpboot o /rplboot di tutti i server di installazione e di boot ad eccezione di quello che il client dovrà usare.

Causa:

Causa 3: È possibile che esista una voce per il client di installazione nel file /etc/bootparams di un server e una seconda voce in un altro file /etc/bootparams che abilita tutti i sistemi ad accedere al server dei profili. Tale voce può avere la forma seguente:

* install_config=server_profili:percorso

L'errore può essere causato anche da una riga simile alla precedente nella tabella bootparams di NIS o NIS+.

Soluzione:

Causa 3: Se esiste una voce "jolly" nella mappa o nella tabella bootparams del servizio di denominazione (ad esempio, * install_config=), eliminarla e aggiungerla al file /etc/bootparams del server di boot.


Server di boot non presente. Impossibile installare il sistema. Vedere le istruzioni di installazione.

Causa:

Questo errore si verifica sui sistemi che si cerca di installare dalla rete. Il sistema non è configurato correttamente.

Soluzione:

Verificare che il sistema sia stato configurato correttamente per l'installazione in rete. Vedere "Aggiunta dei sistemi da installare in rete".


prom_panic: Impossibile attivare il file system

Causa:

Questo errore si verifica quando si cerca di installare Solaris 9 dalla rete ma il software di boot non riesce a trovare:

  • Il DVD di Solaris 9, come DVD effettivo o come copia dell'immagine del DVD sul server di installazione

  • L'immagine del CD "Solaris 9 Software 1 of 2", direttamente sul CD "Solaris 9 Software 1 of 2" o in una copia dell'immagine del CD sul server di installazione

Soluzione:

Verificare che il software di installazione sia attivato e condiviso.

  • Se si sta installando Solaris 9 dal lettore di DVD-ROM o di CD-ROM del server di installazione, verificare che il DVD di Solaris 9 o il CD "Solaris 9 Software 1 of 2" siano inseriti nel sistema, siano attivati e siano condivisi nel file /etc/dfs/dfstab.

  • Se l'installazione viene eseguita da una copia dell'immagine del DVD di Solaris 9 o del CD "Solaris 9 Software 1 of 2" sul disco del server di installazione, verificare che il percorso della copia sia condiviso nel file /etc/dfs/dfstab.

Vedere la pagina man di install_server.


Timeout waiting for ARP/RARP packet...

Causa:

Causa 1: Il client sta cercando di eseguire il boot dalla rete, ma non riesce a trovare un sistema che lo riconosca.

Soluzione:

Causa 1: Verificare che il nome host del sistema sia presente nel servizio di denominazione NIS o NIS+. Inoltre, controllare l'ordine di ricerca di bootparams nel file /etc/nsswitch.conf del server di boot.

Ad esempio, la riga seguente nel file /etc/nsswitch.conf indica che JumpStart o il programma suninstall di Solaris inizieranno la ricerca delle informazioni di bootparams nelle mappe NIS. Se non vengono trovate informazioni, il programma JumpStart o il programma suninstall di Solaris le cercano nel file /etc/bootparams del server di boot.

bootparams: nis files
Causa:

Causa 2: L'indirizzo Ethernet del client non è corretto.

Soluzione:

Causa 2: Verificare che l'indirizzo Ethernet del client nel file /etc/ethers del server di installazione sia corretto.

Causa:

Causa 3: In un'installazione JumpStart personalizzata, il comando add_install_client specifica il gruppo di piattaforme che dovrà usare un determinato server come server di installazione. Se viene usato un valore sbagliato per l'architettura dei sistemi, viene generato questo errore. Ad esempio, il sistema da installare ha un'architettura sun4u mentre è stata specificata l'architettura sun4m.

Soluzione:

Causa 3: Rieseguire add_install_client con il valore corretto per l'architettura.