The projdel utility deletes a project from the system and makes the appropriate changes to the system file.
The following exit values are returned:
The command syntax was invalid. A usage message for projdel is displayed.
An invalid argument was provided to an option.
The projid given with the -p option is already in use.
The project files contain an error. See project(4).
The project to be modified, group, or user does not exist.
The project is already in use.
Cannot update the /etc/project file.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
In case of an error, projdel prints an error message and exits with a non-zero status.
projdel deletes a project definition only on the local system. If a network name service such as NIS or LDAP is being used to supplement the local /etc/project file with additional entries, projdel cannot change information supplied by the network name service.