#include <sys/ddi.h> #include <sys/sunddi.h>void outb(int port, unsigned char value);
The functions described here are obsolete. For the outb(), outw(), and outl() functions use, respectively, ddi_put8(9F), ddi_put16(9F), and ddi_put32(9F) instead. For repoutsb(), repoutsw(), andrepoutsl(), use, respectively, ddi_rep_put8(9F), ddi_rep_put16(9F), and ddi_rep_put32(9F) instead.
A valid I/O port address.
The data to be written to the I/O port.
The address of a buffer from which the values will be fetched.
The number of values to be written to the I/O port.
These routines write data of various sizes to the I/O port with the address specified by port.
The outb(), outw(), and outl() functions write 8 bits, 16 bits, and 32 bits of data respectively, writing the data specified by value.
The repoutsb(), repoutsw(), and repoutsd() functions write multiple 8-bit, 16-bit, and 32-bit values, respectively. count specifies the number of values to be written. addr is a pointer to a buffer from which the output values are fetched.
These functions may be called from user or interrupt context.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|