#include <sys/ddi.h> #include <sys/sunddi.h>int pm_create_components(dev_info_t *dip, int components);
Solaris DDI specific (Solaris DDI).
The pm_create_components() and pm_destroy_components() functions are now obsolete and will be removed in a future release. It is recommended that the driver use pm-components(9) instead.
The pm_create_components() function creates power-manageable components for a device. It should be called from the driver's attach(9E) entry point if the device has power-manageable components.
The correspondence of components to parts of the physical device controlled by the driver are the responsibility of the driver.
The pm_destroy_components() function removes all components from the device. It should be called from the driver's detach(9E) entry point.
The pm_create_components() function returns:
Components are successfully created.
The device already has components.
These functions may be called from user or kernel context.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|