The boot(1M) program, ufsboot, is loaded from disk by the bootblock program which resides in the boot area of a disk partition.
The ufs boot objects are platform-dependent, and reside in the /usr/platform/platform-name/lib/fs/ufs directory. The platform name can be found using the -i option of uname(1).
The name of the bootblock code.
The name of the disk device onto which the bootblock code is to be installed; it must be a character device which is readable and writable. Naming conventions for a SCSI or IPI drive are c?t?d?s? and c?d?s? for an IDE drive.
The name of the partition boot file.
To install a ufs bootblock on slice 0 of target 0 on controller 1 of the platform where the command is being run, use:
example# installboot /usr/platform/`uname -i`/lib/fs/ufs/bootblk \ /dev/rdsk/c1t0d0s0
To use installboot to install the ufs bootblock and partition boot program on a disk in an IA machine, you must specify slice 2 and that slice must be the entire disk. For example, to install the UFS bootblock on target 0, controller 1 of the platform where the command is being run, use:
example# installboot /usr/platform/`uname -i`/lib/fs/ufs/pboot \ /usr/platform/`uname -i`/lib/fs/ufs/bootblk /dev/rdsk/c1t0d0s2
directory where ufs boot objects reside.
second level program to boot from a disk or CD
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
The installboot utility fails if the bootblk, pboot or openfirmware files do not exist or if the raw disk device is not a character device.