The functionality provided by the in.rdisc daemon is now included in in.routed(1M). in.rdisc remains part of the software distribution of the Solaris Operating Environment. However, the system startup scripts in /etc/init.d start in.routed and do not start in.rdisc. If you want to customize router discovery behavior, consult gateways(4). See in.routed(1M) for information on that daemon.
in.rdisc implements the ICMP router discovery protocol. The first form of the command is used on hosts and the second form is used on routers.
in.rdisc can be invoked in either the first form (host mode) or second form (router mode).
On a host, in.rdisc populates the network routing tables with default routes. On a router, advertises the router to all the hosts.
On a host, in.rdisc listens on the ALL_HOSTS (126.96.36.199) multicast address for ROUTER_ADVERTISE messages from routers. The received messages are handled by first ignoring those listed router addresses with which the host does not share a network. Among the remaining addresses, the ones with the highest preference are selected as default routers and a default route is entered in the kernel routing table for each one of them.
Optionally, in.rdisc can avoid waiting for routers to announce themselves by sending out a few ROUTER_SOLICITATION messages to the ALL_ROUTERS (188.8.131.52) multicast address when it is started.
A timer is associated with each router address. The address will no longer be considered for inclusion in the routing tables if the timer expires before a new advertise message is received from the router. The address will also be excluded from consideration if the host receives an advertise message with the preference being maximally negative or with a lifetime of zero.
When in.rdisc is started on a router, it uses the SIOCGIFCONF ioctl(2) to find the interfaces configured into the system and it starts listening on the ALL_ROUTERS multicast address on all the interfaces that support multicast. It sends out advertise messages to the ALL_HOSTS multicast address advertising all its IP addresses. A few initial advertise messages are sent out during the first 30 seconds and after that it will transmit advertise messages approximately every 600 seconds.
When in.rdisc receives a solicitation message, it sends an advertise message to the host that sent the solicitation message.
When in.rdisc is terminated by a signal, it sends out an advertise message with the preference being maximally negative.
Accept all routers independent of the preference they have in their advertise messages. Normally, in.rdisc only accepts (and enters in the kernel routing tables) the router or routers with the highest preference.
Run in.rdisc forever even if no routers are found. Normally, in.rdisc gives up if it has not received any advertise message after soliciting three times, in which case it exits with a non-zero exit code. If -f is not specified in the first form then -s must be specified.
Act as a router, rather than a host.
Send three solicitation messages initially to quickly discover the routers when the system is booted. When -s is specified, in.rdisc exits with a non-zero exit code if it can not find any routers. This can be overridden with the -f option.
Set the preference transmitted in the solicitation messages. The default is zero.
Set the interval between transmitting the advertise messages. The default time is 600 seconds.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
Deering, S.E., editor, ICMP Router Discovery Messages, RFC 1256, Network Information Center, SRI International, Menlo Park, California, September 1991.