#include <sys/processor.h>processorid_t getcpuid(void);
The getcpuid() function returns the processor ID on which the calling thread is currently executing.
The gethomelgroup() function returns the home locality group ID of the calling thread.
No errors are defined.
Both the current CPU and the home locality group can change at any time.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
|Interface Stability||getcpuid() is Stable; gethomelgroup() is Obsolete.|
The gethomelgroup() function is obsolete and might be removed in a future release. It has been replaced by lgrp_home(3LGRP).