#include <stddef.h>size_t offsetof(type, member-designator);
The offsetof() macro defined in <stddef.h> expands to an integral constant expression that has type size_t. The value of this expression is the offset in bytes to the structure member (designated by member-designator) from the beginning of its structure (designated by type).
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|