Sun Microsystems Logo
Products and Services
 
Support and Training
 
 

A  B  C  D  E  F  G  H  I  J  K  L  M  N  O  P  Q  R  S  T  U  V  W  X  Y  Z  
 
System Administrationaddboard(1m)


NAME

 addboard - assign, connect and configure a board to a domain

SYNOPSIS

 addboard -d domain_indicator [-c function] [-r retry_count [-t timeout ] ] [-q] [-f] [-y|-n] location ...
 addboard -h

DESCRIPTION

 

addboard(1M) assigns, connects, and configures a location to the domain domain_id or domain_tag.

The board must be either available or assigned to the domain to which it is being added. The -c option is used to specify the transition of the board from the current configuration state to a new configuration state. Configuration states are assign, connect, and configure. If the -c option is not specified, the default expected configuration state is configure.

Note – addboard performs tasks synchronously and does not return control to the user until the command is complete. If the board is not powered on or tested and a -c connect|configure option is specified, then the command powers on the board and tests it. Note – If only one board is specified and it is in the automatic system recovery (ASR) blacklist file, addboard displays an error message and exits. If more than one board is specified, addboard displays a message that the board is being skipped, and then goes on to the next board or, after the last board, exits. Note – If the addboard command fails, a board does not return to its original state. A dxs or dca error message is logged to the domain. If the error is recoverable, you can retry the command. If it is unrecoverable, you need to reboot the domain in order to use that board.

OPTIONS

 

The following options are supported:

-c function
Valid function values are assign, connect, and configure. This option is used to control the configuration state transition. Each successive function builds upon the last. For example, configure first assigns and then connects the board before configuring it.

The possible transition states and their meanings are as follows:

assign
Assigns the board to the logical domain. This is a board state in which the domain has sole access to the board; however, the board is not active. Once assigned, the board can be connected or configured into the domain with the use of either setkeyswitch on or the connect or configure options.
connect
Assigns the board to the logical domain (if it is not already assigned).

Transitions the board into the connected|unconfigured state. In this state the system board is assigned to the logical domain and connected (becomes active). This state allows normal system access to hardware resources on the board, but the hardware resources of the board are not represented by the normal Solaris software data structures and thus are not available for use by the Solaris operating environment. Operations allowed on the board are limited to configuration administration operations. This is an intermediate state and does not have any standalone implementation at this time.

configure
Assigns the board to the logical domain (if it is not already assigned).

Transitions the board into the connected|configured state. In this state the board is not only assigned, active, and connected to a domain, but also configured into the Solaris operating environment. The hardware resources on the board can be used by Solaris software.

-d domain_indicator
Specifies the domain using one of the following:

domain_id - ID for a domain. Valid domain_ids are A-R and are not case sensitive.

domain_tag - Name assigned to a domain using addtag(1M).

-f
Forces the specified action to occur. Typically, this is a hardware-dependent override of a safety feature. Forcing a state change operation can allow use of the hardware resources of an occupant that is not in the ok or unknown conditions, at the discretion of any hardware-dependent safety checks.
-h
Help. Displays usage descriptions. Note – Use alone. Any option specified in addition to -h is ignored.
-n
Automatically answers no to all prompts. Prompts are displayed unless used with the -q option.
-q
Quiet. Suppresses all messages to stdout including prompts.

When used alone -q defaults to the -n option for all prompts.

When used with either the -y or the -n option, -q suppresses all user prompts and automatically answers with either 'y' or 'n' based on the option chosen.

-r retry_count -t timeout
These command arguments enable the user to specify retries in case of failures encountered during state transitions. The -r retry_count option can be used alone and indicates the number of times the configuration state change request should be retried by the domain. The -t timeout option cannot be used without the -r retry_count option and specifies the number of seconds that the domain should wait before the next retry is made. If the -t timeout is not specified, the default timeout is zero, meaning that the request is retried immediately.
-y
Automatically answers yes to all prompts. Prompts are displayed unless used with the -q option.

OPERANDS

 

The following operands are supported:

location
List of board locations separated by a space. Multiple location arguments are permitted.

The following location forms are accepted:

Sun Fire 15K, Sun Fire 12K

SB(0...17), SB(0...8)

IO(0...17), IO(0...8)

Note – Use showboards(1M) to display board type.

EXTENDED DESCRIPTION

 

Group Privileges Required

 

If you have platform administrator privileges, you can perform only the -c assign option.

If you have domain administrator or configurator privileges, you can execute this command, but only on your respective domains. If the board(s) are not already assigned to the domain, the board(s) must be in the available component list of the domain.

Refer to Chapter 2, "SMS Security Options and Administrative Privileges" in the System Management Services (SMS) 1.4 Administrator Guide for more information.

EXAMPLES

 Example 1. Assigning Boards to Domain C
 

To assign four boards to domain C you must have platform privileges or domain privileges and the boards must be in the domain available component list.

 
sc0:sms-user:> addboard -d C -c assign SB0  IO1 SB1 SB2
SB0 assigned to domain: C
IO1 assigned to domain: C
SB1 assigned to domain: C
SB2 assigned to domain: C
sc0:sms-user:>
Example 2. Assigning a Blacklisted Board to Domain C
 

To assign four boards to domain C you must have platform privileges or domain privileges and the boards must be in the domain available component list.

 
sc0:sms-user:> addboard -d C -c assign SB0  IO2 SB1 SB2
SB0 assigned to domain: C
IO2 assigned to domain: C
Warning: IO2 is blacklisted. 
You will not be able to connect or configure it.
SB1 assigned to domain: C
SB2 assigned to domain: C
sc0:sms-user:>
Example 3. Connecting Boards to Domain A
 

This example connects three boards to domain A, setting retries to five and timeout to five seconds. You must have domain privileges for domain A.

 
sc0:sms-user:> addboard -d A -c connect -r 5 -t 5 IO3 IO4 IO5
Example 4. Connecting Boards Containing an ASR Blacklisted Board to Domain C
 

You must have domain privileges for domain C. Blacklisted boards are skipped.

 
sc0:sms-user:> addboard -d C -c connect SB0
SB0 is blacklisted. Exiting.
sc0:sms-user:>
Example 5. Configuring Boards to Domain A
 

You must have domain privileges for domain A.

 
sc0:sms-user:> addboard -d A -c configure IO3 IO4 IO5
Example 6. Configuring Boards Containing an ASR Blacklisted Board to Domain A
 

You must have domain privileges for domain A. Blacklisted boards are skipped.

 
sc0:sms-user:> addboard -d A -c configure IO7 IO8 IO9
Skipping IO8. It is blacklisted.

EXIT STATUS

 

The following exit values are returned:

0
Successful completion.
1
No acknowledge.
2
Not supported.
3
Operation not supported.
4
Invalid privileges.
5
Busy.
6
System busy.
7
Data error.
8
Library error.
9
No library.
10
Insufficient condition.
11
Invalid.
12
Error.
13
A PID does not exist.
14
Invalid attribute.
30
Invalid board ID type.
31
Invalid permissions.
32
Assigned to another domain.
33
Unable to get permissions.
34
Unable to get domain board info.
35
Unable to get active board list.
36
Unable to get assigned board list.
38
Solaris not running.
39
Unable to assign/unassign.
40
Unable to get domain permissions.
41
Unable to get platform permissions.
51
Invalid domain.
52
Invalid privileges.
53
Internal error.
54
Library error.
56
DR command syntax error.
57
Location already assigned.
58
Internal error.
59
Component blacklisted.
60
Unable to get ASR blacklist.
61
Unable to get domain blacklist.
62
Unable to get platform blacklist.
70
DR operation failed.

FILES

 

The following files are used by this command.

/etc/opt/SUNWSMS/config/asr/blacklist
List of components excluded by esmd.
/etc/opt/SUNWSMS/config/platform/blacklist
List of platform components excluded.
/etc/opt/SUNWSMS/config/domain_id/blacklist
List of domain components excluded.

Note – This file is created and used internally and should not be edited manually. To remove a component from the ASR blacklist file, use enablecomponent(1M).

ATTRIBUTES

 

See attributes(5) for descriptions of the following attributes.

Attribute TypesAttribute Values
AvailabilitySUNWSMSop

SEE ALSO

 

addtag(1m), enablecomponent(1m), esmd(1m), showcomponent(1m)


SMS 1.4Go To TopLast Changed 19 September 2003